Cisco Security Advisory: CDS Internet Streamer: Web Server Directory Traversal Vulnerability

2010 年 7 月 21 日 - ライター翻訳版
その他のバージョン: PDFpdf | 英語版 (2010 年 7 月 21 日) | フィードバック


Advisory ID: cisco-sa-20100721-spcdn

http://www.cisco.com/warp/public/707/cisco-sa-20100721-spcdn.shtml

日本語による情報は、英語による原文の非公式な翻訳であり、英語原文との間で内容の齟齬がある場合には、英語原文が優先します。

Revision 1.1

Last Updated 2010 July 29 1300 UTC (GMT)

For Public Release 2010 July 21 1600 UTC (GMT)


要約

シスコ コンテント デリバリ システムの一部を構成する Cisco Internet Streamer アプリケーションは、任意のファイル アクセスを可能にしてしまうディレクトリ トラバーサルの脆弱性を Web サーバ コンポーネントに含んでいます。この脆弱性が悪用されると、特別に細工された URL を使用して、デバイス上の Web サーバ ドキュメント ディレクトリ外にある任意のファイルが読み取られる場合があります。

認証されていない攻撃者がこの問題を悪用して、パスワード ファイルやシステム ログなどの機密情報にアクセスし、それらを利用してさらに攻撃を行う可能性があります。

シスコはこの脆弱性に対処する無償のソフトウェア アップデートをリリースしました。

この脆弱性を軽減する回避策があります。

このアドバイザリは次のリンクに掲載されます。 http://www.cisco.com/warp/public/707/cisco-sa-20100721-spcdn.shtml

該当製品

Cisco Internet Streamer アプリケーションのシステム ソフトウェアの First Fixed Release 以前の全バージョンに脆弱性が存在します。

脆弱性が存在する製品

シスコ コンテント デリバリ エンジンで実行されているソフトウェアを確認するには、デバイスにログインし、show version コマンド ライン インターフェイス(CLI)コマンドを実行してシステム バナーを表示させます。Cisco CDS Internet Streamer ソフトウェアは「Content Delivery System Software Release」として表示されます。同じ行にバージョン番号が示されます。次の例は、シスコ コンテント デリバリ システム ソフトウェア リリース 2.5.3 を実行しているシスコ コンテント デリバリ エンジンを示しています。

cdn-cde#show version
Content Delivery System Software (CDS)
Copyright ©) 1999-2010 by Cisco Systems, Inc.
Content Delivery System Software Release 2.5.3 (build b8 Jan 21 2010)
Version: cde200-2.5.3.8

Compiled 16:07:11 Jan 21 2010 by ipvbuild
Compile Time Options: KQ SS

System was restarted on Thu Jun  3 04:09:25 2010.
The system has been up for 2 hours, 11 minutes, 27 seconds.

cdn-cde#

または、コンテント デリバリ システム マネージャのホーム ページも、コンテント デリバリ システム ネットワーク内の全デバイスで使用されているソフトウェア バージョンの簡単なまとめを表示できます。

特定のデバイス上で実行されているソフトウェア バージョンを確認するには、[Devices] > [Devices] を選択してください。[Devices Table] ページに各デバイスのソフトウェア バージョンが表示されます。ソフトウェア バージョンの確認方法についての詳細は、次のリンクの「Maintaining the Internet Streamer CDS」を参照してください。 http://www.cisco.com/en/US/docs/video/cds/cda/is/2_5/configuration_guide/maint.html#wp1198510

脆弱性が存在しない製品

TV ストリーミング コンテント デリバリ アプリケーションおよび Video Navigator Application を実行しているシスコ コンテント デリバリ エンジンは影響を受けません。

他のシスコ製品において、このアドバイザリの影響を受けるものは現在確認されていません。

詳細

Cisco Internet Streamer アプリケーションは、PC などのサブスクライバ IP デバイスへのエッジ キャッシング、コンテント ストリーミング、ダウンロードを可能にします。

シスコ コンテント デリバリ システムの一部を構成する Cisco Internet Streamer アプリケーションは、任意のファイル アクセスを可能にしてしまうディレクトリ トラバーサルの脆弱性を Web サーバ コンポーネントに含んでいます。特別に細工された URL を使用することで、インターネット ストリーマ アプリケーションを実行しているシスコ コンテント デリバリ エンジン上の、Web サーバのドキュメント ディレクトリ外にある任意のファイルを読み取ることができます。 これは、管理者アカウントの詳細を含むパスワード ファイルや、 システム ログなどを含みます。

認証されていない攻撃者がこの問題を悪用して、機密情報にアクセスし、それらを利用してさらに攻撃を行う可能性があります。

サービス エンジンおよびシスコ コンテント デリバリ システム マネージャにおいて、この脆弱性はすべてのオープン HTTP ポートで悪用される可能性があります。これには TCP ポート 80(デフォルト HTTP ポート)、443(デフォルト HTTPS ポート)および 8090(代替 HTTP および HTTPS ポート)、さらに HTTP プロキシの一部として構成されたポートが含まれます。

サービス ルータにおいては、TCP ポート 8090(代替 HTTP および HTTPS ポート)で悪用される可能性があります。

シスコ コンテント デリバリ システム ソフトウェア 2.5.3 以前では、[Enable Incoming Proxy](受信プロキシを有効にする)を設定することができ、これを有効にすると、TCP ポート 80 に加えて、構成されたポート上の受信リクエストが許可されます。デバイスが HTTP リクエストを受け付ける追加のポートは、コンテント デリバリ システム マネージャ メニューの [Devices] > [Devices] > [Application Control] > [Web] > [HTTP] > [HTTP Connections] の [List of Incoming HTTP Ports] で定義されています。HTTP 設定の詳細については、次のリンクで「Cisco Internet Streamer CDS 2.5 Software Configuration Guide - Configuring Devices」を参照してください。 http://www.cisco.com/en/US/docs/video/cds/cda/is/2_5/configuration_guide/configdevice.html

この脆弱性は Cisco Bug ID CSCtd68063 登録ユーザのみ)に文書化されており、Common Vulnerabilities and Exposures(CVE)ID として CVE-2010-1577 が割り当てられています。

脆弱性スコアの詳細

シスコはこのアドバイザリでの脆弱性に対して Common Vulnerability Scoring System(CVSS)に基づいたスコアを提供しています。このセキュリティ アドバイザリでの CVSS スコアは CVSS バージョン 2.0 に基づいています。

CVSS は、脆弱性の重要度を示唆するもので、緊急性および対応の優先度を決定する手助けとなる標準ベースの評価法です。

シスコは基本評価スコア(Base Score)および現状評価スコア(Temporal Score)を提供しています。お客様はこれらを用いて環境評価スコア(Environmental Score)を算出し、個々のネットワークにおける脆弱性の影響度を導き出すことができます。

シスコは次の URL にて CVSS に関する FAQ を提供しています。

http://www.cisco.com/web/about/security/intelligence/cvss-qandas.html

また、シスコは個々のネットワークにおける環境影響度を算出する CVSS 計算ツールを以下の URL にて提供しています。

http://tools.cisco.com/security/center/cvssCalculator.x

CSCtd68063: CDS Internet Streamer: Web Server Directory Traversal Vulnerability.

Calculate the environmental score of CSCtd68063

CVSS Base Score - 7.8

Access Vector

Access Complexity

Authentication

Confidentiality Impact

Integrity Impact

Availability Impact

Network

Low

None

Complete

None

None

CVSS Temporal Score - 6.4

Exploitability

Remediation Level

Report Confidence

Functional

Official-Fix

Confirmed

影響

認証されていない攻撃者がこの問題を悪用して、パスワード ファイルやシステム ログなどの機密情報にアクセスし、それらを利用してさらに攻撃を行う可能性があります。

ソフトウェアのバージョンおよび修正

ソフトウェアのアップグレードを検討する際には、 http://www.cisco.com/go/psirt/ および本アドバイザリ以降に公開のアドバイザリも参照して、起こりうる障害と完全なアップグレード ソリューションを判断してください。

いずれの場合も、アップグレードするデバイスに十分なメモリがあること、および現在のハードウェアとソフトウェアの構成が新しいリリースで引き続き適切にサポートされていることの確認を十分に行ってください。情報が不明確な場合は、Cisco Technical Assistance Center(TAC)もしくは契約しているメンテナンス プロバイダーにお問い合わせください。

推奨リリースにはシスコが推奨するその他のソフトウェアの修正が含まれています。詳細については次のリンクでリリース ノートを参照してください。 http://www.cisco.com/en/US/docs/video/cds/cda/is/2_5/release_notes/CDS_RelNotes2_5_9.html#wp100128

Cisco Content Delivery System Software Release

First Fixed Release

Recommended Release

2.2.x

Vulnerable, Migrate to 2.5.7 or later

2.3.x

Vulnerable, Migrate to 2.5.7 or later

2.4.x

Vulnerable, Migrate to 2.5.7 or later

2.5.x

2.5.7

2.5.9

回避策

サービス ルール

シスコ コンテント デリバリ システム ソフトウェアのアップグレードを行うまでの暫定手順として、サービス ルールを使用して機密のディレクトリに対するアクセスを拒否することが可能です。この回避策はサービス エンジンのみに適用可能です。次に例として、ディレクトリ階層を上に移動するアクセスを拒否する方法を示します。これは、「¥.¥./」、「.¥./」、「¥../」などほかのディレクトリ移動にも対応します。

rule enable
rule action block pattern-list 1
rule pattern-list 1 url-regex ^http://.*/../.* 
rule pattern-list 1 url-regex ^https://.*/../.*

サービス ルール設定およびコンテント デリバリ システム マネージャからこれを実行する方法の詳細ついては、次のリンクの「Cisco Internet Streamer CDS 2.5 Software Configuration Guide」を参照してください。 http://www.cisco.com/en/US/docs/video/cds/cda/is/2_5/configuration_guide/configdevice.html#wp1773573

Cisco CDS エンジン IP アクセス コントロール リスト

この回避策はサービス ルータおよびコンテント デリバリ システム マネージャのみに適用可能です。これらは上記のサービス ルールをサポートしていないためです。この回避策はサービス エンジンには適用できません。

ネットワークを通過するトラフィックを遮断することはしばしば困難ですが、インフラストラクチャ デバイスをターゲットとした許可すべきではないトラフィックを特定し、そのようなトラフィックをデバイスのインターフェイスまたはネットワークの境界で遮断することは可能です。下記の IP ACL の例は、信頼できるネットワーク セグメント 192.168.10.X が、シスコ コンテント デリバリ サービス エンジン インターフェイスである IP アドレス 10.1.1.1 への HTTP アクセス(TCP ポート 80 および 443)を許可された例を示しています。このアドレスへのその他すべての HTTP トラフィックは廃棄されます。

注: IP ACL は、シスコ コンテント デリバリ サービス エンジン上で構成されているすべてのインターフェイスの IP アドレスを含む必要があります。この例では、1 つの IP アドレスのみを示しています。

ip access-list extended cisco-sa-20100721-spcdn
     permit tcp 192.168.10.0 0.0.0.255 host 10.1.1.1 eq www
     permit tcp 192.168.10.0 0.0.0.255 host 10.1.1.1 eq https
    

    !--
    !-- TCP port 8090 is not normally used so normally will not have to
    !-- be explicitly permitted. 
    !--
    !-- Permit any additional TCP ports that may have been configured
    !-- via the HTTP Proxy before continuing to add the deny statements.
    !--

     deny tcp any host 10.1.1.1 eq 8090
     deny tcp any host 10.1.1.1 eq www
     deny tcp any host 10.1.1.1 eq https
     permit ip any any
     exit

IP ACL をシスコ コンテント デリバリ サービス ルータのすべてのインターフェイスまたはコンテント デリバリ システム マネージャに適用してください。この例では、1 つのインターフェイスのみを示しています。

interface GigabitEthernet 2/0
     ip address 10.1.1.1 255.255.255.0
     ip access-group cisco-sa-20100721-spcdn in

IP アクセス リストの設定や、それをコンテント デリバリ システム マネージャで実行する方法の詳細については、次のリンクにある『Cisco Internet Streamer CDS 2.5 Software Configuration Guide』を参照してください。 http://www.cisco.com/en/US/docs/video/cds/cda/is/2_5/configuration_guide/configdevice.html#wp1086184

修正済みソフトウェアの取得

シスコはこの脆弱性に対処する無償のソフトウェア アップデートをリリースしました。ソフトウェアの導入を行う前にお客様のメンテナンス プロバイダーにご相談いただくかソフトウェアのフィーチャ セットの互換性およびお客様のネットワーク環境に特有の問題に関してご確認下さい。

お客様がインストールしたりサポートを受けたりできるのは、ご購入いただいたフィーチャ セットに対してのみとなります。そのようなソフトウェア アップグレードをインストール、ダウンロード、アクセスまたはその他の方法で使用した場合、お客様は http://www.cisco.com/en/US/docs/general/warranty/English/EU1KEN_.html に記載のシスコのソフトウェア ライセンスの条項または、Cisco.com Downloads の http://www.cisco.com/public/sw-center/sw-usingswc.shtml に説明のあるその他の条項に従うことに同意したことになります。

ソフトウェアのアップグレードに関し、psirt@cisco.com もしくは security-alert@cisco.com にお問い合わせいただくことはご遠慮ください。

サービス契約をご利用のお客様

サービス契約をご利用のお客様は、通常のアップデート チャネルからアップグレード ソフトウェアを入手してください。ほとんどのお客様は、シスコのワールドワイド Web サイト上の Software Cernter からアップグレードを入手することができます。 http://www.cisco.com

サードパーティのサポート会社をご利用のお客様

シスコ パートナー、正規販売代理店、サービス プロバイダーなど、サードパーティのサポート会社と以前に契約していたか、または現在契約しており、その会社からシスコ製品の提供または保守を受けているお客様は、該当するサポート会社に連絡し、本脆弱性に関する適切な処置について指示と支援を受けてください。

回避策の効果は、使用製品、ネットワーク トポロジー、トラフィックの性質や組織の目的などのお客様の状況に依存します。影響製品が多種多様であるため、回避策を実際に展開する前に、対象とするネットワークで適用する回避策が最適であるか、お客様のサービス プロバイダーやサポート会社にご相談ください。

サービス契約をご利用でないお客様

シスコから直接購入したがシスコのサービス契約をご利用いただいていない場合、また、サードパーティ ベンダーから購入したが修正済みソフトウェアを購入先から入手できない場合は、Cisco Technical Assistance Center(TAC)に連絡してアップグレードを入手してください。TAC の連絡先は次のとおりです。

  • +1 800 553 2447(北米内からのフリー ダイヤル)
  • +1 408 526 7209(北米以外からの有料通話)
  • 電子メール:tac@cisco.com

無償アップグレードの対象であることをご証明いただくために、製品のシリアル番号と、このお知らせの URL をご用意ください。サービス契約をご利用でないお客様に対する無償アップグレードは、TAC 経由でご要求いただく必要があります。

さまざまな言語向けの各地の電話番号、説明、電子メール アドレスなどの、この他の TAC の連絡先情報については、 http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html を参照してください。

不正利用事例と公式発表

Cisco PSIRT では、本アドバイザリに記載されている脆弱性の不正利用事例とその公表は確認しておりません。

この脆弱性は Christopher Richardson 氏、Simon John 氏により発見され、BT によりシスコに報告されたものです。

この通知のステータス:FINAL

本アドバイザリは無保証のものとしてご提供しており、いかなる種類の保証を示唆するものでもありません。本アドバイザリの情報およびリンクの使用に関する責任の一切はそれらの使用者にあるものとします。またシスコシステムズはいつでも本ドキュメントの変更や更新を実施する権利を有します。

後述する情報配信の URL を省略し、本アドバイザリの記述内容に関して単独の転載や意訳を実施した場合には、事実誤認ないし重要な情報の欠落を含む統制不可能な情報の伝搬が行われる可能性があります。

情報の配信

本アドバイザリは、次のシスコのワールドワイド Web サイト上に掲載されます。

http://www.cisco.com/warp/public/707/cisco-sa-20100721-spcdn.shtml

ワールドワイド Web 以外にも、次の電子メールおよび Usenet ニュースの受信者向けに、この通知のテキスト版が Cisco PSIRT PGP キーによるクリア署名つきで投稿されています。

  • cust-security-announce@cisco.com
  • first-bulletins@lists.first.org
  • bugtraq@securityfocus.com
  • vulnwatch@vulnwatch.org
  • cisco@spot.colorado.edu
  • cisco-nsp@puck.nether.net
  • full-disclosure@lists.grok.org.uk
  • comp.dcom.sys.cisco@newsgate.cisco.com

このアドバイザリに関する今後の更新は、いかなるものもシスコのワールドワイド Web サイトに掲載される予定です。 しかしながら、前述のメーリング リストもしくはニュースグループに対し 積極的に配信されるとは限りません。この問題に関心があるお客様は上記 URL にて最新情報を ご確認いただくことをお勧めいたします。

更新履歴

Revision 1.1

2010 July 29

Updated Details and Workaround sections

Revision 1.0

2010 July 21

Initial public release.

シスコのセキュリティ手順

シスコ製品におけるセキュリティの脆弱性の報告、セキュリティ事故に関する支援、およびシスコからセキュリティ情報を入手するための登録方法について詳しく知るには、シスコ ワールドワイド Web サイトの http://www.cisco.com/en/US/products/products_security_vulnerability_policy.html にアクセスしてください。このページには、シスコのセキュリティ通知に関してメディアが問い合わせる際の指示が掲載されています。すべてのシスコ セキュリティ アドバイザリは http://www.cisco.com/go/psirt/ で確認することができます。