Cisco Security Advisory: Hard-Coded SNMP Community Names in Cisco Industrial Ethernet 3000 Series Switches Vulnerability

2010 年 7 月 7 日 - ライター翻訳版
その他のバージョン: PDFpdf | 英語版 (2010 年 7 月 7 日) | フィードバック


Advisory ID: cisco-sa-20100707-snmp

http://www.cisco.com/warp/public/707/cisco-sa-20100707-snmp.shtml

日本語による情報は、英語による原文の非公式な翻訳であり、英語原文との間で内容の齟齬がある場合には、英語原文が優先します。

Revision 1.0

For Public Release 2010 July 07 1600 UTC (GMT)


要約

Cisco IOS® ソフトウェア リリース 12.2(52)SE または 12.2(52)SE1 が稼働する Cisco Industrial Ethernet 3000(IE 3000)シリーズ スイッチに、既知の読み込みおよび書き込み SNMP コミュニティ名がハードコードされているという脆弱性が存在します。ハードコードされたコミュニティ名は「public(パブリック)」と「private(プライベート)」です。

シスコは全管理者に対して、回避策のセクションに記載された緩和策を実装するか、または Cisco IOS ソフトウェアをアップグレードすることを推奨します。

シスコはこの脆弱性に対処する無償のソフトウェア アップデートをリリースしました。

この脆弱性を軽減する回避策があります。

このアドバイザリは次のリンクに掲載されます。 http://www.cisco.com/warp/public/707/cisco-sa-20100707-snmp.shtml

該当製品

次の製品はこの脆弱性の影響を受けます。

  • Cisco Industrial Ethernet 3000 シリーズ スイッチ

脆弱性が存在する製品

次のいずれかの Cisco IOS ソフトウェア リリースで稼働する Cisco Industrial Ethernet 3000 シリーズ スイッチに脆弱性が存在します。

  • Cisco IOS Software release 12.2(52)SE または 12.2(52)SE1

脆弱性が存在しない製品

他のシスコ製品において、このアドバイザリの影響を受けるものは現在確認されていません。

脆弱性のある Cisco IOS ソフトウェア バージョンが稼働しているその他シスコ スイッチング製品のハードウェア モデルは、この脆弱性の影響を受けません

上記に記載された Cisco IOS ソフトウェアが稼働していない Cisco Industrial Ethernet 3000 シリーズ スイッチには脆弱性が存在しません。

詳細

影響を受ける Cisco IOS ソフトウェアのバージョンが稼働する Cisco Industrial Ethernet 3000 シリーズ スイッチには、ハードコードされた読み込みおよび書き込み SNMP コミュニティ名が存在します。

Cisco Industrial Ethernet 3000 シリーズは、過酷な環境下で頑丈かつ使い勝手がよく、セキュアなインフラストラクチャを提供するスイッチ ファミリです。

SNMP はデバイスを管理およびモニタリングする際に用いられ、コミュニティ名はパスワードに相当します。

ハードコードされた SNMP コミュニティ名は、次のとおりです。

snmp-server community public RO
snmp-server community private RW

SNMP コミュニティ名は削除できます。ただし、ハードコードされたコミュニティ名はデバイスを再起動すると、稼動中の設定に再度適用されてしまいます。シスコは、デバイスの再起動時にコミュニティ名を削除するための回避策を提供しています。

:アクセス リストまたは制限付き MIB ビューの設定は、次のとおりです。

snmp-server community public RO 99
snmp-server community private RW 99
snmp-server community public view <mib> RO 99
snmp-server community private view <mib> RO 99

access-list 99 deny   any

この手順は、デバイスが再起動されるまでの回避策となります。デバイスを再起動すると、コミュニティ名にアクセス リストまたは MIB ビューが割り当てられていない元の設定が挿入されます。このアドバイザリの回避策セクションを参照してください。

この脆弱性は、影響を受けるリリースに統合された新機能 PROFINET の一部として発生します。このアドバイザリが公開される時点で、PROFINET は Cisco Industrial Ethernet 3000 シリーズ スイッチでのみサポートされています。

この脆弱性は Cisco Bug ID CSCtf25589 登録ユーザのみ)として文書化されています。この脆弱性に対して Common Vulnerabilities and Exposures(CVE)ID CVE-2010-1574 が割り当てられています。

脆弱性スコアの詳細

シスコはこのアドバイザリでの脆弱性に対して Common Vulnerability Scoring System(CVSS)に基づいたスコアを提供しています。このセキュリティ アドバイザリでの CVSS スコアは CVSS バージョン 2.0 に基づいています。

CVSS は、脆弱性の重要度を示唆するもので、緊急性および対応の優先度を決定する手助けとなる標準ベースの評価法です。

シスコは基本評価スコア(Base Score)および現状評価スコア(Temporal Score)を提供しています。お客様はこれらを用いて環境評価スコア(Environmental Score)を算出し、個々のネットワークにおける脆弱性の影響度を導き出すことができます。

シスコは次の URL にて CVSS に関する FAQ を提供しています。

http://www.cisco.com/web/about/security/intelligence/cvss-qandas.html

また、シスコは個々のネットワークにおける環境影響度を算出する CVSS 計算ツールを以下の URL にて提供しています。

http://tools.cisco.com/security/center/cvssCalculator.x

CSCtf25589: Hard-coded SNMP Community Names in Cisco Industrial Ethernet 3000 Series

Calculate the environmental score of CSCtf25589

CVSS Base Score - 9

Access Vector

Access Complexity

Authentication

Confidentiality Impact

Integrity Impact

Availability Impact

Network

Low

None

Complete

Complete

Complete

CVSS Temporal Score - 8.3

Exploitability

Remediation Level

Report Confidence

Functional

Official-Fix

Confirmed

影響

この脆弱性の不正利用に成功した場合、攻撃者はデバイスのコントロールを完全に掌握できます。

ソフトウェアのバージョンおよび修正

ソフトウェアのアップグレードを検討する際には、 http://www.cisco.com/go/psirt/ および本アドバイザリ以降に公開のアドバイザリも参照して、起こりうる障害と完全なアップグレード ソリューションを判断してください。

いずれの場合も、アップグレードするデバイスに十分なメモリがあること、および現在のハードウェアとソフトウェアの構成が新しいリリースで引き続き適切にサポートされていることの確認を十分に行ってください。情報が不明確な場合は、Cisco Technical Assistance Center(TAC)もしくは契約しているメンテナンス プロバイダーにお問い合わせください。

Cisco IOS ソフトウェアテーブル(下記)の各行は Cisco IOS のリリーストレインを示します。あるリリーストレインが脆弱である場合、修正を含む最初のリリースは、表の「First Fixed Release」列に示されます(入手可能予想日が示される場合もあります)。実行しているリリースが、そのトレインで「First Fixed Release」以前のものである機器は脆弱であることが知られています。シスコ はテーブルの「Recommended Releases」列のリリース、またはそれ以降のリリースにアップグレードすることを推奨します。

Major Release

Availability of Repaired Releases

Affected 12.0-Based Releases

First Fixed Release

There are no affected 12.0 based releases

Affected 12.1-Based Releases

First Fixed Release

There are no affected 12.1 based releases

Affected 12.2-Based Releases

First Fixed Release

12.2SE

Releases prior to 12.2(52)SE are not vulnerable.First fixed in release 12.2(55)SE.Currently scheduled to be available August 2010.

There are no other affected 12.2 based releases

Affected 12.3-Based Releases

First Fixed Release

There are no affected 12.3 based releases

Affected 12.4-Based Releases

First Fixed Release

There are no affected 12.4 based releases

Affected 15.0-Based Releases

First Fixed Release

There are no affected 15.0 based releases

Affected 15.1-Based Releases

First Fixed Release

There are no affected 15.1 based releases

回避策

手動による SNMP コミュニティ名の削除

:次の回避策は、デバイスが再起動されるまで有効です。デバイスを再起動するたびに、この回避策を再適用する必要があります。シスコでは、この脆弱性を完全に排除する方法として Cisco IOS ソフトウェアのアップグレードをお勧めします。

デバイスにログインして、コンフィギュレーション モードに入ります。次の設定コマンドを入力します。

no snmp-server community public RO
no snmp-server community private RW

設定を保存すると、起動設定ファイルが更新されます。ただし、ハードコードされたコミュニティ名はデバイスが再起動すると稼動中の設定に再度挿入されます。この回避策は、デバイスを再起動するたびに適用する必要があります。

SNMP コミュニティ名の自動削除

Embedded Event Manager(EEM)ポリシーを作成することで、デバイスを再起動するたびにハードコードされた SNMP コミュニティ名を自動削除することができます。次の EEM ポリシーは、デバイスが再起動されるたびにハードコードされた SNMP コミュニティ名を削除するポリシー例です。

event manager applet cisco-sa-20100707-snmp
 event timer countdown time 30 
 action 10 cli command "enable"
 action 20 cli command "configure terminal"
 action 30 cli command "no snmp-server community public RO"
 action 40 cli command "no snmp-server community private RW"
 action 50 cli command "end"
 action 60 cli command "disable"
 action 70 syslog msg "Hard-coded SNMP community names as per Cisco Security Advisory cisco-sa-20100707-snmp removed"

EEM ポリシーの詳細については、次のリンクの『Cisco IOS Network Management Configuration Guide - Embedded Event Manager Overview』を参照してください。 http://www.cisco.com/en/US/docs/ios/netmgmt/configuration/guide/nm_eem_overview_ps6441_TSD_Products_Configuration_Guide_Chapter.html

Infrastructure Access Control Lists(iACLs)

ネットワークを通過するトラフィックを遮断することはしばしば困難ですが、インフラストラクチャ デバイスをターゲットとした許可すべきではないトラフィックを特定し、そのようなトラフィックをデバイスのインターフェイスまたはネットワークの境界で遮断することは可能です。

IE3000 で SNMP を管理する必要がない場合、すべての SNMP トラフィックを破棄することも十分な回避策になります。レイヤ 3 アクセスのインターフェイス 2 ポートを搭載する IE3000 で、同デバイスに送信されるすべての SNMP クエリーを破棄する iACL は、次のとおりです。


!---
!--- Deny SNMP traffic from all other sources destined to 
!--- configured IP addresses on the IE3000.
!---


access-list 150 deny udp any host 192.168.0.1 eq snmp
access-list 150 deny udp any host 192.168.1.1 eq snmp


!---
!--- Permit/deny all other Layer 3 and Layer 4 traffic in 
!--- accordance with existing security policies and configurations
!--- Permit all other traffic to transit the device.
!---


access-list 150 permit ip any any


!---
!--- Apply access-list to all Layer 3 interfaces 
!--- (only two examples shown)
!---


interface Vlan1
 ip address 192.168.0.1 255.255.255.0
 ip access-group 150 in

interface GigabitEthernet1/1
 ip address 192.168.1.1 255.255.255.0
 ip access-group 150 in

ホワイトペーパーの『Protecting Your Core: Infrastructure Protection Access Control Lists』には、 アクセスリストによってインフラストラクチャ デバイスを保護するガイドラインと、推奨される導入方法が記載されています。このホワイトペーパーは、以下のリンクから入手可能です。 http://www.cisco.com/cisco/web/support/JP/100/1006/1006441_iacl-j.html

修正済みソフトウェアの取得

シスコはこの脆弱性に対処する無償のソフトウェア アップデートをリリースしました。ソフトウェアの導入を行う前にお客様のメンテナンス プロバイダーにご相談いただくかソフトウェアのフィーチャ セットの互換性およびお客様のネットワーク環境に特有の問題に関してご確認下さい。

お客様がインストールしたりサポートを受けたりできるのは、ご購入いただいたフィーチャ セットに対してのみとなります。そのようなソフトウェア アップグレードをインストール、ダウンロード、アクセスまたはその他の方法で使用した場合、お客様は http://www.cisco.com/en/US/docs/general/warranty/English/EU1KEN_.html に記載のシスコのソフトウェア ライセンスの条項または、Cisco.com Downloads の http://www.cisco.com/public/sw-center/sw-usingswc.shtml に説明のあるその他の条項に従うことに同意したことになります。

ソフトウェアのアップグレードに関し、psirt@cisco.com もしくは security-alert@cisco.com にお問い合わせいただくことはご遠慮ください。

サービス契約をご利用のお客様

サービス契約をご利用のお客様は、通常のアップデート チャネルからアップグレード ソフトウェアを入手してください。ほとんどのお客様は、シスコのワールドワイド Web サイト上の Software Cernter からアップグレードを入手することができます。 http://www.cisco.com

サードパーティのサポート会社をご利用のお客様

シスコ パートナー、正規販売代理店、サービス プロバイダーなど、サードパーティのサポート会社と以前に契約していたか、または現在契約しており、その会社からシスコ製品の提供または保守を受けているお客様は、該当するサポート会社に連絡し、本脆弱性に関する適切な処置について指示と支援を受けてください。

回避策の効果は、使用製品、ネットワーク トポロジー、トラフィックの性質や組織の目的などのお客様の状況に依存します。影響製品が多種多様であるため、回避策を実際に展開する前に、対象とするネットワークで適用する回避策が最適であるか、お客様のサービス プロバイダーやサポート会社にご相談ください。

サービス契約をご利用でないお客様

シスコから直接購入したがシスコのサービス契約をご利用いただいていない場合、また、サードパーティ ベンダーから購入したが修正済みソフトウェアを購入先から入手できない場合は、Cisco Technical Assistance Center(TAC)に連絡してアップグレードを入手してください。TAC の連絡先は次のとおりです。

  • +1 800 553 2447(北米内からのフリー ダイヤル)
  • +1 408 526 7209(北米以外からの有料通話)
  • 電子メール:tac@cisco.com

無償アップグレードの対象であることをご証明いただくために、製品のシリアル番号と、このお知らせの URL をご用意ください。サービス契約をご利用でないお客様に対する無償アップグレードは、TAC 経由でご要求いただく必要があります。

さまざまな言語向けの各地の電話番号、説明、電子メール アドレスなどの、この他の TAC の連絡先情報については、 http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html を参照してください。

不正利用事例と公式発表

Cisco PSIRT では、本アドバイザリに記載されている脆弱性の不正利用事例とその公表は確認しておりません。

この脆弱性は、カスタマー サポート コールの処理中に発見されたものです。

この通知のステータス:FINAL

本アドバイザリは無保証のものとしてご提供しており、いかなる種類の保証を示唆するものでもありません。本アドバイザリの情報およびリンクの使用に関する責任の一切はそれらの使用者にあるものとします。またシスコシステムズはいつでも本ドキュメントの変更や更新を実施する権利を有します。

後述する情報配信の URL を省略し、本アドバイザリの記述内容に関して、単独の転載や意訳を実施した場合には、事実誤認ないし重要な情報の欠落を含む統制不可能な情報の伝搬が行われる可能性があります。

情報の配信

本アドバイザリは、次のシスコのワールドワイド Web サイト上に掲載されます。

http://www.cisco.com/warp/public/707/cisco-sa-20100707-snmp.shtml

ワールドワイド Web 以外にも、次の電子メールおよび Usenet ニュースの受信者向けに、この通知のテキスト版が Cisco PSIRT PGP キーによるクリア署名つきで投稿されています。

  • cust-security-announce@cisco.com
  • first-bulletins@lists.first.org
  • bugtraq@securityfocus.com
  • vulnwatch@vulnwatch.org
  • cisco@spot.colorado.edu
  • cisco-nsp@puck.nether.net
  • full-disclosure@lists.grok.org.uk
  • comp.dcom.sys.cisco@newsgate.cisco.com

このアドバイザリに関する今後の更新は、いかなるものもシスコのワールドワイド Web サイトに掲載される予定です。 しかしながら、前述のメーリング リストもしくはニュースグループに対し 積極的に配信されるとは限りません。この問題に関心があるお客様は上記 URL にて最新情報を ご確認いただくことをお勧めいたします。

更新履歴

Revision 1.0

2010-July-07

Initial public release.

シスコのセキュリティ手順

シスコ製品におけるセキュリティの脆弱性の報告、セキュリティ事故に関する支援、およびシスコからセキュリティ情報を入手するための登録方法について詳しく知るには、シスコ ワールドワイド Web サイトの http://www.cisco.com/en/US/products/products_security_vulnerability_policy.html にアクセスしてください。このページには、シスコのセキュリティ通知に関してメディアが問い合わせる際の指示が掲載されています。すべてのシスコ セキュリティ アドバイザリは http://www.cisco.com/go/psirt/ で確認することができます。