音声とユニファイド コミュニケーション : Cisco Unified Border Element

Unified Videoconferencing(CUVC)IVR を使用した Unified Border Element(CUBE)の設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

企業内の IPベース ビデオ コミュニケーションの採用は順調に進められています。 今日の経済的な環境では、顧客は従業員の生産性および操作効率両方でゲインであるこの採用の主な利点が付いている社内通信のためにツールとしてビデオをより頻繁に使用します。

ほとんどの企業 IPベース ビデオ コミュニケーション ネットワークはより古い Integrated Services Digital Network (ISDN) テクノロジーを使用して相互接続される他のそのようなエンタープライズ ネットワークに関連してアイランドのよう今日です。 ISDN は他のビジネスのと、場合によっては、企業内のリモートブランチ自体が付いているすべての余分企業か余分キャンパス通信のために非常に広く使われています。 IPベース ビデオ コミュニケーションの広範囲に及ぶ利点は組織内のまたは間のエンドツーエンド IP接続とビジネス ツー ビジネス(B2B)通信を促進するために実際に得ることができます。 これは ISDN からの PSTN の代りにインターネットを横断する IPベース ソリューションへの遷移を必要としま、社内および B2B 通信のための比較的安価のコンバージしたオプションを有効に します。

ISDN回線からのインターネットによる IP 接続への卸売遷移はとるに足らないプロジェクトではないです。 ISDN回線およびに ISDN を IPベース ビデオ コミュニケーション世界結ぶビデオ ゲートウェイは、広く展開され、実績があり、信頼されたソリューションです。 次世代ビデオ コミュニケーション サービスを取り扱うことの制限にもかかわらず、ISDN はまだ新しいソリューションがセキュリティ、プライバシー、請求および分界を考慮に入れるとき測定される規格を設定 します。 新しいソリューションは実行可能な代案としてそれらを考慮するために企業およびサービスプロバイダーのための同じような service-level 保証を提供する必要があります。 企業はこうして企業を越える IPベース ビデオ コミュニケーションの拡張の効率を不正利用している間 ISDN と関連付けられる利点すべてを維持する方法を必要とします。

この設定例では、Cisco Unified Border Element(CUBE)の機能に注目し、特にインターネットのどこかに存在するエンドポイントが企業ファイアウォールの背後にあるマルチポイント コントロール ユニット(MCU)またはエンドポイントに、IP アドレスでダイヤルする機能を CUBE がどのようにサポートするかを示します。 この機能性は CUBE 1.3 の 12.4(22)YB リリースで利用可能 なヌル呼出数上書きする 機能および Cisco Unified videoconferencing (CUVC)の 5.6 リリースで MCU 利用可能 な IVR 機能性を展示します。 この資料はこの関連の積み込む企業のための設定 に 関する 推奨事項および可能性のある 開始点が含まれています。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • Cisco IOSボイスを設定し使用する方法の基本的な知識(ダイヤル ピアのような)

  • CUBE の設定および使用方法に関する基礎知識

  • ファイアウォールがどのようにのはたらくか基本的な知識

使用するコンポーネント

このドキュメントの情報は、次のハードウェアに基づくものです。

  • Cisco 2800 ルータで動作し、Cisco IOS リリース 12.4.22(YB) か Cisco IOS Release 15.0.1M を使用する Cisco Unified Border Element および Cisco IOS ゲートキーパー

  • Cisco IP ビデオ会議 3545 ソリューション ソフトウェア バージョン 5.6 またはそれ以降を実行する

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このダイアグラムは CUBE に安全に 内部 エンドポイント IP アドレスによってカスタマーネットワークにダイアルインする外部エンドポイントを示します。

/image/gif/paws/111313/cube-cuvc-01.gif

ダイアグラム コールフロー

  1. Cisco 内部 マルチポイント制御装置(MCU)に常駐するインターネットの外部エンドポイントは CUBE のパブリックIPアドレスにダイヤルします(192.168.1.2)加入するためテレビ会議に。 H.323 呼び出しセットアップメッセージはネットワークにセキュリティ境界を提供するファイアウォールである Cisco 適応性があるセキュリティ アプライアンス モデル(ASA)で設定される TCPポート 1720 のための最初のピンホールによって CUBE で着きます。 この例では、CUBE にプライベート IP アドレスがあります従って外部エンドポイントによって目標とされる公にルーティングできるアドレスは ASA によって実行された スタティック NAT (ネットワークアドレス変換)の結果です。

    注: 例示を目的として、Cisco はドキュメントでプライベート IP アドレス領域だけ使用します。

  2. 着信セットアップメッセージが CUBE が普通コールの次のレグを目標とする通常ダイヤルされた数字が含まれていないので、使用をディジット立方体にして下さい(1234567890)ヌル呼出数上書きする 設定コマンドによって設定される。 このアドレスを使用する、呼び出しセットアップメッセージは内部 カスタマーネットワークの方に続行します。

  3. ASA にコールのこのステージをサポートする 2 つのピンホールがあります: CUVC-M 内部 ゲートキーパー 機能によって望ましい アドレスを CUBE からの結果として生じるセットアップメッセージが CUVC-M に CUBE のダイヤル ピアで設定される E.164 アドレスに基づく MCU にコールを確立することを到達するように調べるように CUBE がする 1 つおよび 1。 ASA の H.323 インスペクション 機能を使用する、残りのシグナリングおよびメディアは情報に従ってコールセットアップ シグナリングからグリーニングされる TCP および UDP 接続動的に開発されますフローします。

  4. CUVC-M 内部 ゲートキーパーは外部ユーザにグラフィカル Options メニューを示す新しいビデオ IVR 機能を含む IPVC-MCU にコールをルーティングします。 このメニューは呼出すエンドポイントのダイヤル パッドか遠隔制御装置で DTMF トーンの入力によってナビゲート されます。 エンドユーザは加入 conference メニュー オプションから会議 ID を単に選択し、次にもし設定するなら必要なパスワードを入力します。

  5. 内部 ビデオ エンドポイントは外部エンドポイントと同じ会議 ID のダイヤルによって会議に加入します。

設定

このドキュメントでは、次の設定を使用します。

CUBE 設定
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname cube1
!
boot-start-marker
boot system flash:c2800nm-adventerprisek9_ivs-mz.124-22.YB.bin
boot-end-marker
!
ip source-route
!
!
multilink bundle-name authenticated
!
!
!
voice service voip
  allow-connections h323 to h323
  h323
  emptycapability
  null-called-number override 1234567890
  h225 start-h245 on-connect
  call start slow 
  h245 passthru all
!
!
!
voice class h323 10
!
!
voice-card 0
!
!
!
!
interface GigabitEthernet0/0
 ip address 172.16.1.100 255.255.255.0
 ip route-cache same-interface
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip id vgk1 ipaddr 172.16.1.100 1719 priority 1 

!--- vgk1 defines zone the cube to register with the local Gatekeeper service
 
 h323-gateway voip h323-id cube1

!--- Defines the ID of CUBE
 
 h323-gateway voip tech-prefix 1#
 h323-gateway voip bind srcaddr 172.16.1.100
!
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.1.1
ip http server
no ip http secure-server
!
!
!
!
dial-peer voice 1 voip
destination-pattern .T

!--- To match outbound call leg to send to GK process

session target ras
incoming called-number .

!--- For inbound call leg

codec transparent



!
!
gateway
timer receive-rtp 1200
!
!
!
gatekeeper
zone local vgk1 cisco.com 
zone remote CUVCM cisco.com 10.1.1.26 invia vgk1 outvia vgk1
enable-intrazone
zone prefix CUVCM 1234567890
gw-type-prefix 1#* default-technology
no use-proxy GK1 default inbound-to terminal
no use-proxy GK1 default outbound-from terminal
bandwidth interzone default 1000000
no shutdown
!

end

ASA の設定
ASA Version 8.2(1)
! 

!--- This is only a portion of the ASA config.
!--- In a typical production scenario, these commands would
!--- be in addition to the current security policies configured.

!
interface Ethernet0/0
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/0.2
 vlan 2
 nameif inside
 security-level 100
 ip address 10.1.1.1 255.255.255.0 
!
interface Ethernet0/0.12
 vlan 12
 nameif dmz
 security-level 50
 ip address 172.16.1.1 255.255.255.0 
!
interface Ethernet0/0.500
 vlan 500
 nameif outside
 security-level 0
 ip address 192.168.1.2 255.255.255.0 
!
boot system disk0:/asa821-k8.bin
ftp mode passive
clock timezone CDT -6
access-list dmz-in extended permit icmp any any 
access-list dmz-in extended permit udp host 172.16.1.100any eq 1719 
access-list dmz-in extended permit tcp host 172.16.1.100any eq h323

!--- The access list allows CUBE address lookups and call
!--- signaling respectively to get to the interior of the network.

!
access-list outside_access_in extended permit icmp any any 
access-list outside_access_in extended permit tcp any host 192.168.1.2 eq h323 
access-list outside_access_in extended permit udp any host 192.168.1.2 eq 1719

!--- The access list allows exterior call setups and address
!--- look ups respectively to get to the CUBE.

!  
! 
access-list inside-to-DMZ-exemption extended permit ip 10.0.0.0 255.0.0.0 10.150
.150.0 255.255.255.0

!--- This access list prevents the global NAT translation intended
!--- for the outside interface from being used on the conversations
!--- between internal endpoints and CUBE.

!
mtu inside 1500
mtu dmz 1500
mtu outside 1500
nat-control
global (outside) 1 192.168.1.5-192.168.1.100 netmask 255.255.255.0

!--- Note that the general NAT pool should not overlap the
!--- ASA interface nor the static NAT used for CUBE.

!
nat (inside) 0 access-list inside-to-DMZ-exemption
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 1 172.168.1.0 255.255.255.0
static (dmz,outside) 192.168.1.2 172.16.1.100 netmask 255.255.255.255

!--- The previous statement is what establishes the publicly
!--- routed address for CUBE on the outside interface.

! 
access-group dmz-in in interface dmz
access-group outside_access_in in interface outside
route inside 10.0.0.0 255.255.255.0 10.1.1.2 1
route outside 0.0.0.0 0.0.0.0 192.168.1.254 1

!--- These two static route statements assume the existence of
!--- a next hop router on both inside and outside interfaces.

!
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:10:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:10:00 h225 1:00:00 mgcp 0:10:00 mgcp-pat 0:10:00

!--- Note: It is a good idea to increase the H.225 timeout. Not all endpoints
!--- send enough traffic on this connection to keep it alive. The H.225 command
!--- includes the H.245 attributes.

!
policy-map global_policy
 class inspection_default
  inspect h323 h225 
  inspect h323 ras

確認

ここでは、設定が正常に動作していることを確認します。

このイメージは Cisco Unified Videoconferencing Manager に追加されている Cisco IOS ゲートキーパーを示します。 Cisco IOS ゲートキーパー モデルはドロップダウン リストで選ばれます。

cube-cuvc-02.gif

このイメージは Cisco IOS ゲートキーパーが追加に成功したこと Cisco Unified ビデオ会議マネージャのリソース管理 セクション内の確認を示します。 172.16.1.100 の IP アドレスとリストされている Cisco IOS H.323 ゲートキーパーを表示できます。

cube-cuvc-03.gif

このイメージは e.164 アドレスを表示する Cisco Unified ビデオ会議で自動転送 設定を示します(1234567890)ヌル呼出 し 番号に対応する CUBE で設定しました。

cube-cuvc-04.gif

このイメージは Cisco IPVC ビデオ IVR が呼出すビデオ エンドポイントに送返すものを示します。 ビデオ エンドポイントの遠隔制御装置またはキーパッド制御を使用する、ユーザは(インバンド) CUVC MCU でホストされる選択し、適切なビデオ会議に加わります DTMF によってビデオ会議を。

/image/gif/paws/111313/cube-cuvc-05.gif

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 111313