ルータ : Cisco 3800 シリーズ サービス統合型ルータ

CCP による IOS ルータ上の AnyConnect VPN(SSL)クライアントの設定例

2016 年 3 月 19 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2010 年 12 月 22 日) | 英語版 (2016 年 2 月 29 日) | フィードバック

概要

この資料に Cisco Configuration Professional(CCP) (CCP)を使用している Cisco AnyConnect VPN Client と棒の Secure Sockets Layer (SSL) VPN を行うために Cisco IOS ® ルータを設定する方法を記述されています。 このセットアップはルータの AnyConnect が分割トンネリングで設定される、共有リソースにクライアント 安全なアクセスを許可し、またインターネットに保護されていないアクセスを提供します特定のケースに適用し。

SSL VPN か WebVPN テクノロジーは統合サービス ルータ(ISR)生成 1 のようなほとんどのルータ プラットフォームで、生成 2 サポートされます(ISR 製品のリストのために ISR 製品を参照して下さい)。 顧客は AnyConnect VPN (SSL)クライアント サポートする Cisco IOSプラットフォームの完全なリストを得るために機能ナビゲータ ガイドを参照するように勧告されます(または他のどの機能テクノロジーもその点では)。 この情報は機能ナビゲータで利用できます。

Cisco IOS ベース アクセスルータを設定することを可能にする CCP は GUI ベース デバイス管理 ツールです。 CCP は PC でインストールされ、GUI ベース、使いやすいウィザードを通してルータ、セキュリティ、Unified Communication、ワイヤレス、WAN および基本的な LAN コンフィギュレーションを簡約化します。

Bratin Saha および Rahul Govindan によって貢献される、Cisco TAC エンジニア。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • 適したクライアント オペレーティング システム。 サポートされたオペレーティングシステムのために AnyConnect リリース ノートを参照して下さい。

  • SUN JRE バージョン 1.4 またはそれ以降の Webブラウザか ActiveX はブラウザを制御しました

  • クライアント上のローカルな管理者権限

  • Advanced Security イメージ -12.4(20)T 以降がインストールされた Cisco IOS ルータ

  • Cisco Configuration Professional(CCP) バージョン 1.3 または それ 以降

Cisco Configuration Professional(CCP)がコンピュータでまだロードされていない場合、ソフトウェアの無料 版を入手し、ソフトウェアダウンロードから .exe (cisco-config-pro-k9-pkg-2_8-en.zip)ファイルをインストールできます。 CCP のインストールと設定の詳細は、『Cisco Configuration Professional クイック スタート ガイド』を参照してください。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • ソフトウェア バージョン 15.1(4)M8 が付いている Cisco IOS シリーズ CISCO2811 ルータ

  • CCP バージョン 2.8

  • Windows 3.1 .05160 のための Cisco AnyConnect SSL VPN クライアント バージョン

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

設定

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

設定前の作業

  1. CCP のためのルータを設定して下さい。

    適切なセキュリティ バンドル ライセンスのルータに既にフラッシュするでロードされる CCP アプリケーションがあっています。 ソフトウェアを入手し、設定するために Cisco Configuration Professional(CCP) クイックスタートガイドを参照して下さい。

  2. Anyconnect VPN .pkg ファイルのコピーを管理 PC にダウンロードします。

設定

このセクションでは、この資料に説明がある機能を設定するのに必要なステップが表示されます。 この設定例は IOSルータの Anyconnect VPN のオペレーションを有効に するために CCP ウィザードを使用します。

次のステップを実行して、Cisco IOS ルータに Anyconnect VPN を設定します。

  1. CCP を設定し、Cisco IOS ルータを検出して下さい。

  2. Cisco IOS ルータの Anyconnect VPN ソフトウェアをインストールし、有効に して下さい。

  3. CCP ウィザードで SSL VPN コンテキストおよび SSL VPNゲートウェイを設定して下さい。

  4. Anyconnect VPN ユーザ向けのユーザデータベースを設定して下さい。

  5. AnyConnect 完全なトンネルを設定して下さい。

これらのステップのそれぞれはこの資料の次の セクションにより詳しく説明があります。

ステップ 1: CCP を設定し、Cisco IOS ルータを検出して下さい

  1. ルータデバイス 情報を表示するために CCP ウィンドウのルータ ステータスをクリックして下さい。



  2. 設定を始めるために『Configure』 をクリック して下さい。



ステップ 2:

 IOS ルータに Anyconnect VPN ソフトウェアをインストールし、有効にする

IOSルータで Anyconnect VPN ソフトウェアをインストールし、有効に するためにこれらのステップを完了して下さい:

  1. CCP アプリケーションを開き、> Security を設定するためにナビゲート しそれから『VPN』 をクリック して下さい。

  2. [SSLVPN] を展開し、[Packages] を選択します。



    SSL VPN フィーチャー ライセンスがデバイスでインストールされているようにして下さい、さもなければ前のイメージで示されている警告を得るかもしれません。 発注情報 セクションを表示するためにフィーチャー ライセンス リンクを参照して下さい。

  3. Cisco SSLVPN クライアント ソフトウェアで、[Browse] をクリックします。

    Select SVC location ダイアログ ボックスが表示されます。



  4. Cisco AnyConnect VPN Client イメージの位置を規定 して下さい(利用可能 な 2 つのオプションのどちらかを選択して下さい)。

    • Cisco AnyConnect VPN Client イメージがルータフラッシュにある場合、ルータ ファイル システム オプション ボタン ダイアログボックスをクリックし、『Browse』 をクリック して下さい





    • Cisco AnyConnect VPN Client イメージがルータフラッシュにない場合、マイ コンピュータ Radio ダイアログボックスをクリックし、『Browse』 をクリック して下さい。


  5. インストールし、『OK』 をクリック してほしいクライアント イメージを選択して下さい。

  6. クライアント イメージの場所を指定してから、[Install] をクリックします。

  7. 『Yes』 をクリック し、次に『OK』 をクリック して下さい。

  8. クライアント イメージのインストールに成功すれば、成功 メッセージを受け取ります。 [OK] をクリックして続行します。

  9. インストールされる、セキュリティ > VPN > SSL の下でインストール済み パッケージ 詳細を VPN > パッケージ表示して下さい。

手順 3: CCP ウィザードで SSL VPN コンテキストと SSL VPN ゲートウェイを設定する

SSL VPN コンテキストおよび SSL VPNゲートウェイを設定するためにこれらのステップを完了して下さい:

  1. [Configure] > [Security] > [VPN] を順に選択してから、[SSL VPN] をクリックします。

  2. SSL VPN マネージャをクリックし、次に作成 SSL VPN タブをクリックして下さい。



  3. まだ有効に なって いない場合認証、許可、アカウンティング(AAA)を有効に するためにプロンプトに従って下さい。









  4. 作成を新しい SSL VPNオプション・ボタン チェックし、次に『選択したタスクの起動』 をクリック して下さい。

    [SSL VPN Wizard] ダイアログボックスが表示されます。



  5. [Next] をクリックします。



    : SSL VPN が Cisco が CP 呼び出されるインターフェイスの下で設定されれば、によりルータからの disconnet に Cisco CP を引き起こすかもしれません。 よりよい推奨事項として、SSL VPN は外部インターフェイス FastEthernet0/0 の下で設定されるが内部 インターフェースから CCP によって Cisco IOS ルータにアクセスできます(この例、10.106.44.141)または他のどのでもインターフェイス、(この例で、10.105.130.149)。





  6. 新しい SSL VPNゲートウェイの IP アドレスを入力し、この SSL VPN コンテキストの固有の名前を入力して下さい。

    同じ IP アドレス(SSL VPN ゲートウェイ)に異なった SSL VPN コンテキストを作成することはできますが、それぞれの名前は一意にする必要があります。 この例では、次の IP アドレスを使用します。 https://10.105.130.149/

  7. 『Next』 をクリック し、次の セクションに進んで下さい。

ステップ 4: Anyconnect VPN ユーザのユーザ データベースを設定する

認証には、AAA サーバ、ローカル ユーザ、またはその両方を使用できます。 この設定例は認証のためにローカルで作成されたユーザを使用します。

Anyconnect VPN ユーザ用のユーザ データベースを設定するには、次のステップを実行します。

  1. ステップ 3 を完了した後、SSL VPN ウィザード ユーザ認証 ダイアログボックスで見つけられるこのルータ オプション ボタンをローカルでクリックして下さい。



    このダイアログ ボックスで、ユーザをローカル データベースに追加できます。

  2. ユーザ情報を『Add』 をクリック し、入力して下さい。



  3. 必要に応じて追加ユーザを『OK』 をクリック し、追加して下さい。

  4. 必要なユーザを追加した後、『Next』 をクリック し、次の セクションに進んで下さい。

ステップ 5. Anyconnect トンネルを設定して下さい

ユーザ向けの IP アドレスの Anyconnect トンネルおよびプールを設定するためにこれらのステップを完了して下さい:

  1. Anyconnect がコーポレート イントラネット リソースにダイレクトアクセスを提供するので、URLリストは設定するため必要ではないです。 [Configure Intranet Websites] ダイアログボックスにある [Next] ボタンをクリックします。



  2. [Enable Full Tunnel] チェック ボックスにチェックマークが入っていることを確認します。



  3. この SSL VPN コンテキストのクライアントが使用できる IP アドレスのプールを作成します。

    アドレスのプールはイントラネットで利用可能 で、ルーティング可能 な アドレスに対応する必要があります。

  4. 省略記号をクリックして下さい() IP アドレスの隣でフィールドをプーリングし、新しい IPプールを『Create』 を選択 して下さい。

  5. [Add IP Local Pool] ダイアログボックスで、プールの名前を入力し(新規など)、[Add] をクリックします。



  6. 追加 IPアドレス範囲 ダイアログボックスでは、Anyconnect VPN クライアントのためのアドレス プール 範囲を入力し、『OK』 をクリック して下さい。

    バージョン 12.4(20)T の前に、IP アドレス プールは直接ルータに接続されるインターフェイスの範囲にあるはずです。 別のプール範囲を使用したいと思う場合この要件を満たすために新しいプールと関連付けられるループバックアドレスを作成できます。



  7. [OK] をクリックします。

  8. configure 分割トンネリング、分割DNS、ブラウザ プロキシ 設定および Domain Name System (DNS)および Windows Internet Name Service (WINS)サーバのようなトンネル オプションを、進めました。

    : Cisco は少なくとも DNS および WINS サーバを設定することを推奨します。



    分割トンネリングのような高度トンネル オプションを、設定するためにこれらのステップを完了して下さい:

    1. [Advanced Tunnel Options] ボタンをクリックします。

    2. DNS および WINS サーバ タブをクリックし、DNS および WINS サーバのためのプライマリ IP アドレスを入力して下さい。



    3. 分割トンネリングを設定するために分割トンネリング タブをクリックして下さい。



      同一のインターフェイス上でセキュリティで保護されたトラフィックと保護されていないトラフィックの両方を送信する機能は、スプリット トンネリングという名前で知られています。 スプリット トンネリングでは、どのトラフィックがセキュリティで保護され、そのトラフィックの宛先はどこであるかをユーザが正確に指定する必要があります。それによって、指定されたトラフィックだけがトンネル内に入り、それ以外のトラフィックはパブリック ネットワーク(インターネット)経由で暗号化されずに送信されます。

      例ではトラフィックを含むために、スプリットトンネルは設定されます。


  9. 必要なオプションを設定したら、[Next] をクリックします。 適切な SSL VPN トンネルインターフェイス オプションを選択し、『Next』 をクリック して下さい。



  10. SSL VPN ポータル ページをカスタマイズするか、またはデフォルト値を選択します。

    [Customize SSL VPN Portal Page] では、SSL VPN ポータル ページのお客様への表示方法をカスタマイズできます。



  11. SSL VPN ポータル ページのカスタマイズが終了したら、[Next] をクリックします。

  12. [Finish] をクリックします。



  13. 設定を保存し、次に『OK』 をクリック するために渡しますクリックして下さい。

    SSL VPN ウィザードはルータにコマンドを入れます。





基本的にはこれらは CCP からルータに提供されるコマンドです:

AAA commands:

aaa new-model
aaa authorization exec default local
aaa authentication login default local
line vty 0 4
login authentication default
authorization exec default
exit

Remaining commands:

aaa authentication login ciscocp_vpn_xauth_ml_1 local
ip local pool IP_Pool 192.168.1.10 192.168.1.15
interface Virtual-Template1
exit
default interface Virtual-Template1
interface Virtual-Template1
no shutdown
ip unnumbered FastEthernet0/0
exit
webvpn gateway gateway_1
ip address 10.105.130.149 port 443
http-redirect port 80
inservice
ssl trustpoint TP-self-signed-1878971148
exit
webvpn context Test
aaa authentication list ciscocp_vpn_xauth_ml_1
gateway gateway_1
virtual-template 1
max-users 1000
inservice
secondary-color white
title-color #FF9900
text-color black
policy group policy_1
svc split include 10.106.44.0 255.255.255.0
svc keep-client-installed
functions svc-enabled
svc address-pool IP_Pool netmask 255.255.255.255
svc default-domain cisco.com
svc dns-server primary 10.106.44.10
svc wins-server primary 10.106.44.12
exit
default-group-policy policy_1
exit
! IP address / user account command
username user1 privilege 1 secret 0 *********

: エラーメッセージを受け取る場合、SSL VPN ライセンスは不正確であるかもしれません。

ライセンス問題を解決するためにこれらのステップを完了して下さい:

  1. [Configure] > [Security] > [VPN] を順に選択してから、[SSL VPN] をクリックします。

  2. SSL VPN マネージャをクリックし、次に右側の編集 SSL VPN タブをクリックして下さい。



  3. 新しく作成されたコンテキストを強調表示し、Edit ボタンをクリックして下さい。



  4. [Maximum Number of users] フィールドで、ライセンスの正確なユーザ数を入力します。

  5. [OK] をクリックしてから、[Deliver] をクリックします。

    コマンドはコンフィギュレーション ファイルに書かれています。

CLI 設定

CCP は次のコマンドライン設定を作成します。

Router#show running-config
Building configuration...

Current configuration : 3590 bytes
!
! Last configuration change at 06:30:34 UTC Sat Nov 29 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login ciscocp_vpn_xauth_ml_1 local
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-1878971148
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1878971148
 revocation-check none
 rsakeypair TP-self-signed-1878971148
!
!
crypto pki certificate chain TP-self-signed-1878971148
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31383738 39373131 3438301E 170D3134 31313239 30353537
  32355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 38373839
  37313134 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C77D F135BBCA 8A84DE7D A3330085 3694EC3B 9BAE2F94 AF19CAEC 89A4AA6A
  DC098301 AC996CA7 BE1C6AB2 BF4745F4 911E9812 97BC1A1F 15D1AFD0 384878C6
  8781D8A7 3BFCFCFF 5626EF1A BCF73C78 B07E4587 710B6F18 B4E0017F 807606EA
  03E398B0 A2DE06B6 2D39B122 32D82E1B 7AE55554 63D8BDD6 222CF884 C9D5570D
  74BD0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1455F1A2 00753895 04EB04BE 13273EEF D48D86C6 84301D06
  03551D0E 04160414 55F1A200 75389504 EB04BE13 273EEFD4 8D86C684 300D0609
  2A864886 F70D0101 05050003 81810013 B72A05AE E7816FB7 377FC3B3 8EE7D2AC
  9211B78D 8B6A604A DA7D571F 6E083B78 279F0EB1 95B5ADC8 79572616 53B52B90
  1BF1A39B 46F8C88C 3335F498 E2CF5ABC 5D942A23 7DE35239 04D509EF 88E60201
  8B111BD6 FE82E159 67E05A62 03BFBCA6 E99EA1CE DA52F66A 8CE502C1 B9FAA488
  8A5B022A 3003F718 E8E1C6CC 2EB03C
        quit
!
!
license udi pid CISCO2811 sn FHK1404F3X2
username username privilege 15 secret 5 $1$hPnV$zwQ6MMwLA7HUC/NJRCMyt1
username user1 secret 5 $1$X3Vu$h5/xHipon7Fym16G2SCrz1
!
redundancy
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address dhcp
 duplex auto
 speed auto
!
interface Virtual-Template1
 ip unnumbered FastEthernet0/0
!
ip local pool IP_Pool 192.168.1.10 192.168.1.15
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 transport input all
!
scheduler allocate 20000 1000
!
webvpn gateway gateway_1
 ip address 10.105.130.149 port 443
 http-redirect port 80
 ssl trustpoint TP-self-signed-1878971148
 inservice
 !
webvpn install svc flash:/webvpn/anyconnect-win-3.1.05160-k9.pkg sequence 1
 !
webvpn context Test
 secondary-color white
 title-color #FF9900
 text-color black
 ssl authenticate verify all
 !
 !
 policy group policy_1
   functions svc-enabled
   svc address-pool "IP_Pool" netmask 255.255.255.255
   svc default-domain "cisco.com"
   svc keep-client-installed
   svc split include 10.106.44.0 255.255.255.0
   svc dns-server primary 10.106.44.10
   svc wins-server primary 10.106.44.12
 virtual-template 1
 default-group-policy policy_1
 aaa authentication list ciscocp_vpn_xauth_ml_1
 gateway gateway_1
 inservice
!
end

Router#sh run int Virtual-Access2
Building configuration...

Current configuration : 104 bytes
!
interface Virtual-Access2
 description ***Internally created by SSLVPN context Test***
 mtu 1406
end

AnyConnect VPN Client 接続の確立

ルータが付いている AnyConnect VPN 接続を確立するためにこれらのステップを完了して下さい。

: Internet Explorer の信頼できるサイトのリストにルータを追加して下さい。 詳細は、「信頼済みサイトのリスト(IE)にセキュリティ アプライアンス/ルータを追加する」を参照してください。

  1. 示されているように形式の Webブラウザでルータ WebVPN インターフェイスの URL か IP アドレスを入力して下さい。

    https://<url>


    または

    https://<IP address of the Router WebVPN interface>


  2. ユーザ名とパスワードを入力します。



  3. Anyconnect VPN トンネル接続を開始するために『Start』 をクリック して下さい。



    SSL VPN 接続が確立される前に次のウィンドウが表示されます。



    : ActiveX ソフトウェアはコンピュータで Anyconnect VPN をダウンロードする前にインストールする必要があります。





  4. 接続が正常に確立されたら、[Statistics] タブをクリックします。

    [Statistics] タブに SSL 接続についての情報が表示されます。



    統計情報 Details ダイアログボックスは接続のトンネルステートがおよびモード、期間、送信 され、受信されたバイト数およびフレーム含まれている詳しい接続統計情報を、アドレス情報、転送する 情報および Cisco Secure Desktop ポスチャ アセスメント ステータスは表示する。 このタブの [Reset] ボタンを押すと、送信統計情報がリセットされます。 エクスポート統計ボタンはテキストファイルに現在の統計情報、インターフェイスおよびルーティング テーブルをエクスポートすることを可能にします。 AnyConnect クライアントからテキスト ファイルの名前と格納場所を入力するように要求されます。 既定値 の 名前は nyConnect-ExportedStats.txt であり、デフォルト の ロケーションはデスクトップにあります。

  5. ルート Details タブの下でルート 詳細を(スプリットトンネル 設定に基づいて)チェックして下さい。



  6. Cisco AnyConnect VPN Client ダイアログボックスで、Cisco AnyConnect VPN Client バージョン情報を表示するために About タブをクリックして下さい。



確認

このセクションでは、設定が正常に機能していることを確認します。

コマンド

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

いくつかの show コマンドは WebVPN に関連しています。 CLI show statistics および他の情報でこれらのコマンドを実行できます。 show コマンドの詳細は、『WebVPN 設定の確認』を参照してください。

webvnp セッション コンテキストをすべて示して下さい

Router#show webvpn session context all
WebVPN context name: Test
Client_Login_Name  Client_IP_Address  No_of_Connections  Created  Last_Used
user1              10.106.42.10                1         00:01:22  00:00:01

webvpn セッション ユーザ user1 コンテキスト テストを示して下さい

Router#show webvpn session user user1 context Test detail
Session Type      : Full Tunnel
Client User-Agent : AnyConnect Windows 3.1.05160

Username          : user1                Num Connection : 1
Public IP         : 10.106.42.10         VRF Name       : None
Context           : Test                 Policy Group   : policy_1
Last-Used         : 00:00:00             Created        : *06:33:24.505 UTC Sat
Nov 29 2014
Session Timeout   : Disabled             Idle Timeout   : 2100
DNS primary serve : 10.106.44.10         WINS primary s : 10.106.44.12
DPD GW Timeout    : 300                  DPD CL Timeout : 300
Address Pool      : IP_Pool              MTU Size       : 1199
Rekey Time        : 3600                 Rekey Method   :
Lease Duration    : 43200
Tunnel IP         : 192.168.1.10         Netmask        : 255.255.255.255
Rx IP Packets     : 0                    Tx IP Packets  : 617
CSTP Started      : 00:01:22             Last-Received  : 00:00:00
CSTP DPD-Req sent : 0                    Virtual Access : 2
Msie-ProxyServer  : None                 Msie-PxyPolicy : Disabled
Msie-Exception    :
Split Include     : 10.106.44.0 255.255.255.0
Client Ports      : 60304

Detail Session Statistics for User:: user1
----------------------------------

CSTP Statistics::
Rx CSTP Frames    : 618                Tx CSTP Frames   : 0
Rx CSTP Bytes     : 46113              Tx CSTP Bytes    : 0
Rx CSTP Data Fr   : 617                Tx CSTP Data Fr  : 0
Rx CSTP CNTL Fr   : 1                  Tx CSTP CNTL Fr  : 0
Rx CSTP DPD Req   : 0                  Tx CSTP DPD Req  : 0
Rx CSTP DPD Res   : 0                  Tx CSTP DPD Res  : 0
Rx Addr Renew Req : 0                  Tx Address Renew : 0
Rx CDTP Frames    : 0                  Tx CDTP Frames   : 0
Rx CDTP Bytes     : 0                  Tx CDTP Bytes    : 0
Rx CDTP Data Fr   : 0                  Tx CDTP Data Fr  : 0
Rx CDTP CNTL Fr   : 0                  Tx CDTP CNTL Fr  : 0
Rx CDTP DPD Req   : 0                  Tx CSTP DPD Req  : 0
Rx CDTP DPD Res   : 0                  Tx CDTP DPD Res  : 0
Rx IP Packets     : 0                  Tx IP Packets    : 617
Rx IP Bytes       : 0                  Tx IP Bytes      : 41122

CEF Statistics::
Rx CSTP Data Fr   : 0                  Tx CSTP Data Fr  : 0
Rx CSTP Bytes     : 0                  Tx CSTP Bytes    : 0

webvpn 統計を示して下さい

Router#show webvpn stats
User session statistics:
    Active user sessions     : 1          AAA pending reqs         : 0
    Peak user sessions       : 1          Peak time                : 00:02:29
    Active user TCP conns    : 1          Terminated user sessions : 0
    Session alloc failures   : 0          Authentication failures  : 0
    VPN session timeout      : 0          VPN idle timeout         : 0
    User cleared VPN sessions: 0          Exceeded ctx user limit  : 0
    Exceeded total user limit: 0
    Client process rcvd pkts : 57         Server process rcvd pkts : 0
    Client process sent pkts : 8134       Server process sent pkts : 0
    Client CEF received pkts : 664        Server CEF received pkts : 0
    Client CEF rcv punt pkts : 29         Server CEF rcv punt pkts : 0
    Client CEF sent pkts     : 0          Server CEF sent pkts     : 0
    Client CEF sent punt pkts: 0          Server CEF sent punt pkts: 0

    SSLVPN appl bufs inuse   : 0          SSLVPN eng  bufs inuse   : 0
    Active server TCP conns  : 0

Mangling statistics:
    Relative urls            : 0          Absolute urls            : 0
    Non-http(s) absolute urls: 0          Non-standard path urls   : 0
    Interesting tags         : 0          Uninteresting tags       : 0
    Interesting attributes   : 0          Uninteresting attributes : 0
    Embedded script statement: 0          Embedded style statement : 0
    Inline scripts           : 0          Inline styles            : 0
    HTML comments            : 0          HTTP/1.0 requests        : 0
    HTTP/1.1 requests        : 3          Unknown HTTP version     : 0
    GET requests             : 3          POST requests            : 0
    CONNECT requests         : 0          Other request methods    : 0
    Through requests         : 0          Gateway requests         : 3
    Pipelined requests       : 0          Req with header size >1K : 0
    Processed req hdr bytes  : 844        Processed req body bytes : 0
    HTTP/1.0 responses       : 0          HTTP/1.1 responses       : 0
    HTML responses           : 0          CSS responses            : 0
    XML responses            : 0          JS responses             : 0
    Other content type resp  : 0          Chunked encoding resp    : 0
    Resp with encoded content: 0          Resp with content length : 0
    Close after response     : 0          Resp with header size >1K: 0
    Processed resp hdr size  : 0          Processed resp body bytes: 0
    Backend https response   : 0          Chunked encoding requests: 0

HTTP Authentication stats :
    Successful NTLM Auth     : 0          Failed NTLM Auth         : 0
    Successful Basic Auth    : 0          Failed Basic Auth        : 0
    Unsupported Auth         : 0          Unsup Basic HTTP Method  : 0
    NTLM srv kp alive disabld: 0          NTLM Negotiation Error   : 0
    Oversize NTLM Type3 cred : 0          Internal Error           : 0
    Num 401 responses        : 0          Num non-401 responses    : 0
    Num Basic forms served   : 0          Num NTLM forms served    : 0
    Num Basic Auth sent      : 0          Num NTLM Auth sent       : 0

CIFS statistics:
  SMB related Per Context:
    TCP VC's                 : 0          UDP VC's                 : 0
    Active VC's              : 0          Active Contexts          : 0
    Aborted Conns            : 0
  NetBIOS related Per Context:
    Name Queries             : 0          Name Replies             : 0
    NB DGM Requests          : 0          NB DGM Replies           : 0
    NB TCP Connect Fails     : 0          NB Name Resolution Fails : 0
  SMB related Global:
    Sessions in use          : 0          Mbufs in use             : 0
    Mbuf Chains in use       : 0          Active VC's              : 0
    Active Contexts          : 0          Browse Errors            : 0
    Empty Browser List       : 0          NetServEnum Errors       : 0
    Empty Server List        : 0          NBNS Config Errors       : 0
    NetShareEnum Errors      : 0
  HTTP related Per Context:
    Requests                 : 0          Request Bytes RX         : 0
    Request Packets RX       : 0          Response Bytes TX        : 0
    Response Packets TX      : 0          Active Connections       : 0
    Active CIFS context      : 0          Requests Dropped         : 0
  HTTP related Global:
    Server User data         : 0          CIFS User data           : 0
    Net Handles              : 0          Active CIFS context      : 0
    Authentication Fails     : 0          Operations Aborted       : 0
    Timers Expired           : 0          Pending Close            : 0
    Net Handles Pending SMB  : 0          File Open Fails          : 0
    Browse Network Ops       : 0          Browse Network Fails     : 0
    Browse Domain Ops        : 0          Browse Domain Fails      : 0
    Browse Server Ops        : 0          Browse Server Fails      : 0
    Browse Share Ops         : 0          Browse Share Fails       : 0
    Browse Dir Ops           : 0          Browse Network Fails     : 0
    File Read Ops            : 0          File Read Fails          : 0
    File Write Ops           : 0          File Write Fails         : 0
    Folder Create Ops        : 0          Folder Create Fails      : 0
    File Delete Ops          : 0          File Delete Fails        : 0
    File Rename Ops          : 0          File Rename Fails        : 0
    URL List Access OK       : 0          URL List Access Fails    : 0

Socket statistics:
    Sockets in use           : 1          Sock Usr Blocks in use   : 1
    Sock Data Buffers in use : 0          Sock Buf desc in use     : 0
    Select timers in use     : 1          Sock Select Timeouts     : 0
    Sock Tx Blocked          : 150        Sock Tx Unblocked        : 150
    Sock Rx Blocked          : 0          Sock Rx Unblocked        : 0
    Sock UDP Connects        : 0          Sock UDP Disconnects     : 0
    Sock Premature Close     : 0          Sock Pipe Errors         : 13
    Sock Select Timeout Errs : 0

Smart Tunnel statistics:
  Client                                Server
    proc pkts                : 0          proc pkts                 : 0
    proc bytes               : 0          proc bytes                : 0
    cef  pkts                : 0          cef  pkts                 : 0
    cef  bytes               : 0          cef  bytes                : 0

Port Forward statistics:
  Client                                Server
    proc pkts                : 0          proc pkts                 : 0
    proc bytes               : 0          proc bytes                : 0
    cef pkts                 : 0          cef pkts                  : 0
    cef bytes                : 0          cef bytes                 : 0

WEBVPN Citrix statistics:

               Server                   Client
  Packets in  : 0                        0
  Packets out : 0                        0
  Bytes in    : 0                        0
  Bytes out   : 0                        0

ACL statistics:
    Permit web request       : 0          Deny web request         : 0
    Permit cifs request      : 0          Deny cifs request        : 0
    Permit without ACL       : 0          Deny without match ACL   : 0
    Permit with match ACL    : 0          Deny with match ACL      : 0

Single Sign On statistics:
    Auth Requests            : 0          Pending Auth Requests    : 0
    Successful Requests      : 0          Failed Requests          : 0
    Retranmissions           : 0          DNS Errors               : 0
    Connection Errors        : 0          Request Timeouts         : 0
    Unknown Responses        : 0

URL-rewrite splitter statistics:
    Direct access request    : 0          Redirect request         : 0
    Internal request         : 0

Tunnel Statistics:
    Active connections       : 1
    Peak connections         : 1          Peak time                : 00:01:44
    Connect succeed          : 2          Connect failed           : 0
    Reconnect succeed        : 1          Reconnect failed         : 0
    DPD timeout              : 0
  Client
    in  CSTP frames          : 671        in  CSTP control         : 1
    in  CSTP data            : 670        in  CSTP bytes           : 50002
    out CSTP frames          : 0          out CSTP control         : 0
    out CSTP data            : 0          out CSTP bytes           : 0
    in  CDTP frames          : 0          in  CDTP control         : 0
    in  CDTP data            : 0          in  CDTP bytes           : 0
    out CDTP frames          : 0          out CDTP control         : 0
    out CDTP data            : 0          out CDTP bytes           : 0
    cef in  CSTP data frames : 0          cef in  CSTP data bytes  : 0
    cef out CSTP data frames : 0          cef out CSTP data bytes  : 0
    cef in  CDTP data frames : 0          cef in  CDTP data bytes  : 0
    cef out CDTP data frames : 0          cef out CDTP data bytes  : 0
  Server
    In  IP pkts              : 0          In  IP bytes             : 0
    Out IP pkts              : 670        Out IP bytes             : 44587

CCP で、> Security > VPN ステータス > SSL VPN (すべてのコンテキスト)をルータの電流 SSL VPN ユーザー一覧を表示するために『Monitoring』 を選択 して下さい。

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を提供します。

トラブルシューティングのためのコマンド

いくつかの clear コマンドは、WebVPN に関連しています。 これらのコマンドの詳細については、『WebVPN の Clear コマンドの使用』を参照してください。

いくつかの debug コマンドは、WebVPN に関連しています。 これらのコマンドの詳細については、『WebVPN の Debug コマンドの使用』を参照してください。

debug コマンドを使用すると、Cisco デバイスに悪影響が及ぶ可能性があります。 debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 110608