スイッチ : Cisco Catalyst 3750 シリーズ スイッチ

Catalyst 3750 および 3560 シリーズ スイッチでの PIM スタブ ルーティング

2009 年 7 月 17 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2011 年 8 月 4 日) | フィードバック

目次


概要

マルチキャスト コントロール プレーン トラフィックは、LAN 環境にあるすべてのルータで常に見られます。スタブ IP マルチキャストは、LAN のアクセス層で見られる不要なマルチキャスト トラフィックを削減および最小化し、マルチキャスト トラフィックをアップストリームのディストリビューション レイヤとコア レイヤに転送するためのメディアでの帯域幅を節約するために使用されます。

Catalyst 3750 および 3560 シリーズ スイッチでは、PIM スタブ マルチキャスト機能によりディストリビューション レイヤとアクセス レイヤ間のマルチキャスト ルーティングがサポートされています。ここでは、アップリンク PIM インターフェイスと PIM 受動インターフェイスの 2 種類の PIM インターフェイスがサポートされています。特に、PIM パッシブ モードに設定されているルーテッド インターフェイスでは、PIM コントロール プレーン トラフィックの通過と転送は行われず、IGMP トラフィックの通過と転送だけが行われます。



前提条件

要件

この設定を開始する前に、次の要件が満たされていることを確認してください。

  • PIM スタブ ルータでは、ディストリビューション ルータ間の中継トラフィックのルーティングは行われません。この動作は、ユニキャスト(EIGRP)スタブ ルーティングによるものです。この PIM スタブ ルータの動作を補佐するには、正確なユニキャスト スタブ ルーティングの設定が必要です。ルータ管理者がこの制限を回避するように RIP、スタティック ルート、または PIM RP を設定することが、PIM スタブ機能によって妨げられることはありません。

  • 直接接続されているマルチキャスト(IGMP)の受信側と発信元だけが、レイヤ 2 アクセス ドメインで許可されています。PIM プロトコルはアクセス ドメインではサポートされていません。

  • リダンダント PIM スタブ ルータのトポロジはサポートされていません。



使用するコンポーネント

このドキュメントの情報は、Catalyst 3750 スイッチからの出力に基づくものです。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。



関連製品

この設定は、次のスイッチ タイプにも使用できます。

  • Catalyst 3750 および 3560 シリーズ スイッチ

Cisco Catalyst 3750 および 3560 スイッチでは、PIM スタブ マルチキャスト ルーティング コード バージョン 12.2(37)SE 以降がサポートされています。



表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



設定

このセクションでは、このドキュメントで説明する機能の設定に必要な情報を提供しています。

PIM SSM は、アップストリーム ルータと通信するためにアップリンクで使用されます。ユーザは他のいずれの PIM モード(稠密モードまたは希薄モードなど)も使用できます。

3750 シリーズ スイッチでのマルチキャスト ルーティングの設定についての詳細は、『IP マルチキャスト ルーティングの設定』を参照してください。

注:このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。



ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

ネットワーク ダイアグラム



設定例

このドキュメントでは、次の設定を使用しています。

次の手順を実行して、PIM スタブ ルーティングを設定します。

  1. 次のコマンドを発行して、スイッチやスイッチ スタックでグローバルにマルチキャスト ルーティングをイネーブルにします。

    mix_stack(config)#ip multicast-routing distributed
    
  2. 次のコマンドを発行して、IP マルチキャスト アドレスの SSM 範囲をデフォルトのグループ範囲で定義します。

    mix_stack(config)#ip pim ssm default
    
  3. 次のコマンドを発行して、アップリンクで PIM SSM をイネーブルにします。

    mix_stack(config)#interface GigabitEthernet3/0/25
    mix_stack(config-if)ip pim sparse-dense-mode
    
  4. 次のコマンドを発行して、VLAN インターフェイスで PIM スタブ ルーティングをイネーブルにします。

    mix_stack(config)#interface vlan100
    mix_stack(config-if)ip pim passive
    


スイッチ(mix_stack)の設定

mix_stack#sho run
Building configuration...
 
Current configuration : 7810 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mix_stack
!
!
switch 2 provision ws-c3750e-24pd
switch 3 provision ws-c3750g-24ts
switch 5 provision ws-c3750-24fs
switch 9 provision ws-c3750e-24pd
!
ip routing
!
!
ip multicast-routing distributed
!
!--- 出力を省略。
!
!
vlan 100
!
!
interface GigabitEthernet2/0/1
switchport access vlan 100
no keepalive
spanning-tree portfast
!
interface GigabitEthernet2/0/2
switchport access vlan 100
no keepalive
spanning-tree portfast
!
!
!--- 出力を省略。
!
!
interface GigabitEthernet3/0/25
no switchport
ip address 3.1.1.2 255.255.255.248
ip pim sparse-dense-mode
!
!
!--- 出力を省略。
!
!
interface GigabitEthernet9/0/24
no switchport
ip address 10.1.1.1 255.255.255.0
ip pim passive
no keepalive
!
!
!--- 出力を省略。
!
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 100.1.1.1 255.255.255.0
ip pim passive
!
!
!--- 出力を省略。
!
! 
ip pim ssm default
!
!
!--- 出力を省略。
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
speed 115200
line vty 0 4
login
line vty 5 15
login
!
end


確認

ここでは、設定が正常に動作していることを確認します。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)(OIT)でサポートされています。OIT を使用すると、show コマンドの出力を分析できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

show ip pim interface コマンドを発行して、各インターフェイスに対してイネーブルにされている PIM スタブを表示します。

mix_stack#show ip pim interface 

Address    Interface               Ver/    Nbr     Query   DR     DR
                                   Mode    Count   Intvl   Prior

3.1.1.2    GigabitEthernet3/0/25   v2/SD   1       30      1      3.1.1.2
100.1.1.1  Vlan100                 v2/P    0       30      1      100.1.1.1
10.1.1.1   GigabitEthernet9/0/24   v2/P    0       30      1      10.1.1.1

show ip igmp detail を発行して、特定のマルチキャスト ソースやグループに加入している対象クライアントを表示します。

mix_stack#sho ip igmp group 232.0.0.9 det

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit

Interface: GigabitEthernet9/0/24
Group: 232.0.0.9
Flags: SSM 
Uptime: 00:00:10
Group mode: INCLUDE
Last reporter: 10.1.1.2
CSR Grp Exp: 00:02:57
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 00:00:10 stopped 00:02:57 Yes CM

Interface: Vlan100
Group: 232.0.0.9
Flags: SSM 
Uptime: 01:42:08
Group mode: INCLUDE
Last reporter: 100.1.1.3
CSR Grp Exp: 00:02:00
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 01:42:12 stopped 00:02:00 Yes CM
mix_stack#

show ip igmp mroute を発行して、マルチキャスト ストリームのソースから対象クライアントへの転送を確認します。

mix_stack#sho ip mroute 232.0.0.9
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, 
Z - Multicast Tunnel, z - MDT-data group sender, 
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(200.1.1.3, 232.0.0.9), 01:44:23/00:02:52, flags: sTI
Incoming interface: GigabitEthernet3/0/25, RPF nbr 3.1.1.1
Outgoing interface list:
GigabitEthernet9/0/24, Forward/Sparse-Dense, 00:02:24/00:02:50
Vlan100, Forward/Sparse-Dense, 01:44:23/00:02:52



関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報




Document ID: 98289