スイッチ : Cisco Catalyst 6500 Virtual Switching System 1440

スタンドアロン Cisco Catalyst 6500 スイッチの Cisco Catalyst 6500 Virtual Switching System への移行

2009 年 6 月 16 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2009 年 2 月 25 日) | フィードバック

目次


概要

このドキュメントでは、スタンドアロン Cisco Catalyst 6500 シリーズ スイッチの Cisco Catalyst 6500 Virtual Switching System への移行のための手順に関する情報を提供しています。

注:このドキュメントで提供しているのは、移行に必要な一般的な手順です。厳密な手順は現状のスイッチ設定に基づくため、説明されている手順とは若干異なる可能性があります。



前提条件

要件

次の項目に関する知識があることを推奨します。



使用するコンポーネント

このドキュメントの情報は、Cisco IOS(R) ソフトウェア リリース 12.2(33)SXH1 以降が稼働する Supervisor VS-S720-10G-3C/XL が搭載された Cisco Catalyst 6500 シリーズ スイッチに基づくものです。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。



表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



背景説明

Virtual Switching System(VSS)は、単一の論理エンティティへの 2 台の物理的なシャーシのクラスタ処理を効果的に実現する、Cisco Catalyst 6500 シリーズ スイッチの革新的な新機能です。このテクノロジーによって、ハイ アベイラビリティ、スケーラビリティまたはパフォーマンス、管理、および保守など、企業キャンパスとデータセンター展開の全領域における新たな拡張が可能になります。

VSS の現行の実装を使用すると、2 台の物理的な Cisco Catalyst 6500 シリーズ スイッチを、論理的に管理された単一のエンティティへ統合することができます。次の図は、VSS が有効になると、2 台の 6509 シャーシを単一の 18 スロット シャーシとして管理することが可能になる場合の概念を図示しています。

物理シャーシと仮想的な論理シャーシ

物理シャーシと仮想的な論理シャーシ



移行プロセス

ハードウェアおよびソフトウェアのサポート

VSS は Cisco Catalyst 6500 シリーズ スイッチでのみ使用可能なソフトウェア機能です。この機能をイネーブルにして設定するには、次が必要です。

ハードウェア

VS-S720-10G-3C/XL

VS-S720-10G-3C/XL の外観

ソフトウェア

Cisco IOS ソフトウェア リリース 12.2(33)SXH1 以降




移行パス

この表では、可能な VSS への移行パスの一部を説明しています。このリストは提案に過ぎず、すべてを網羅しているわけではありません。

初期設定 必要なアップグレード 最終設定

WS-SUP720-3B スーパーバイザ搭載の 2 台の Cisco Catalyst 6500 シリーズ スイッチ

WS-SUP720-3B スーパーバイザ搭載の 2 台の Cisco Catalyst 6500 シリーズ スイッチ

ハードウェア アップグレード:スーパーバイザ VS-S720-10G-3C/XL

ソフトウェア アップグレード:Cisco IOS 12.2(33)SXH1 以降

VSS

概念上の VSS

VS-S720-10G-3C/XL スーパーバイザ搭載の 2 台の Cisco Catalyst 6500 シリーズ スイッチ

VS-S720-10G-3C/XL スーパーバイザ搭載の 2 台の Cisco Catalyst 6500 シリーズ スイッチ

ソフトウェア アップグレード:Cisco IOS 12.2(33)SXH1 以降

VSS

概念上の VSS




移行の概要

スタンドアロン環境での一般的な構成

スタンドアロン環境での一般的な構成

レイヤ 3(L3)コアと L2/L3 ディストリビューションの間で実行される機能またはプロトコル:

  • IP ルーティング プロトコル

  • L3 ポート チャネルまたは IP ルーティングの等コスト マルチパス機能

L2/L3 ディストリビューションとアクセス レイヤの間で実行される機能またはプロトコル:

  • スパニング ツリー プロトコル

  • First Hop Routing Protocol(FHRP)

  • ポリシー:QoS、ACL

  • L2 トランク、VLAN、ポート チャネル

VSS への移行

これは段階的なプロセスで、このセクションでは各段階について説明しています。

VSS への移行

コアとディストリビューション レイヤの間の移行手順:

  • MultiChassis EtherChannel(MEC)の設定

  • IP ルーティング設定の修正と不要になったコマンドの削除

ディストリビューションとアクセス レイヤの間の移行手順:

  • MEC の設定

  • スパニング ツリー プロトコルのイネーブル状態の維持

  • FHRP コマンドの修正

  • QoS と ACL のポリシーの MEC への移行(必要な場合)

  • L2 トランク設定の MEC への移行



移行プロセス手順

次の手順を実行します。

  1. 初期スタンドアロン設定では、一般的には、VLAN ロード シェアリングと HSRP 設定を使用して、トラフィックがディストリビューション スイッチ間でロード バランスされています。

    トラフィックがディストリビューション スイッチ間でロード バランスされている初期状態

    トラフィックがディストリビューション スイッチ間でロード バランスされている初期状態

  2. HSRP と STP の設定を修正し、Distribution-1 がすべてのフローに対してアクティブで、隣接デバイスによってこの変更が検出され、すべてのトラフィックが Distribution-1 に送信されるようにします。

    すべてのフローに対して Distribution-1 がアクティブになっている状態

    すべてのフローに対して Distribution-1 がアクティブになっている状態

  3. Distribution-2 の物理インターフェイスをシャットダウンして、ネットワークから切り離します。

    Distribution-2 が切り離された状態

    Distribution-2 が切り離された状態

    .

    Distribution-2 が完全にネットワークから削除されたら、本稼働トラフィックを中断することなく VSS モードへ変換することができます。

  4. またインストールしていない場合は、新しいスーパーバイザ(VS-SUP720-10G)をインストールして、ステータスを確認します。

    Distribution-2#show module
    Mod Ports Card Type                              Model              Serial No.
    --- ----- -------------------------------------- ------------------ -----------
      5  5  Supervisor Engine 720 10GE (Active)  VS-S720-10G   SAD104707BB
      9   48  CEF 720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX     SAL1020NGY3
    
  5. VSS 互換の Cisco IOS ソフトウェアを sup-bootdisk: にコピーします。

    Distribution-2#copy ftp: sup-bootdisk:
    Address or name of remote host []? 172.16.85.150
    Source filename []? s72033-ipservices_wan_vz.122-33.SXH1.bin
    Destination filename [s72033-ipservices_wan_vz.122-33.SXH1.bin]?
    Accessing ftp://172.16.85.150/s72033-ipservices_wan_vz.122-33.SXH1.bin...
    
  6. bootvar を更新して、sup-bootdisk: にコピーされた Cisco IOS ソフトウェアをロードします。

    Distribution-2(config)#boot system flash sup-bootdisk:s72033-ipservices_wan_vz.122-33.SXH1.bin
    
    
  7. Distribution-2 スイッチを VSS モードで稼働させるには、Virtual Switch Link(VSL)が必要です。VSL を形成するには、Distribution-1Distribution-2 の間の現行のポート チャネル リンクを使用できます。

    Distribution-1 と Distribution-2 の間の VSL リンク

    Distribution-1 と Distribution-2 の間の VSL リンク

  8. 仮想スイッチのアトリビュートを次のように設定します。

    1. Virtual Switch Domain Number(ネットワーク内部で一意)

    2. Virtual Switch Number(ドメイン内部で一意)

    3. Virtual Switch Link(VSL)

    Distribution-2(config)#hostname VSS
    
    VSS(config)#switch virtual domain 100
    
    VSS(config-vs-domain)#switch 1
    
    
    !--- 変換後、Distribution-2 は 
    !--- VSS モード内で Switch 1 として認識されます。
    
    VSS(config-vs-domain)# exit
    VSS(config)#interface port-channel 1
    VSS(config-if)#switch virtual link 1
    
    VSS(config-if)#interface TenG 5/4
    VSS(config-if)#channel-group 1 mode on
    VSS(config-if)#interface TenG 5/5
    VSS(config-if)#channel-group 1 mode on
    VSS(config-if)# ^Z
    VSS#
    
  9. Distribution-2 スイッチを VSS モードに変換します。

    注:スイッチのコンソールから次のコマンドを発行します。

    VSS#switch convert mode virtual
    
    This command will convert all interface
    names to naming convention "interface-type
    switch-number/slot/port",
    save the running config to startup-config and
    reload the switch.
    Do you want to proceed? [yes/no]: yes
    Converting interface names
    Building configuration...
    
    
    !--- この時点でスイッチがリブートされます。
    
    
    
    !--- コンソール出力の一部。
    
    System detected Virtual Switch configuration...
     Interface TenGigabitEthernet 1/5/4 is member of
    PortChannel 1
     Interface TenGigabitEthernet 1/5/5 is member of
    PortChannel 1
    
    !--- コンソール出力の一部。
    
    00:00:23: %PFREDUN-6-ACTIVE: Initializing as ACTIVE
    processor for this switch
    
    !--- コンソール出力の一部。
    
    00:00:28: %VSL_BRINGUP-6-MODULE_UP: VSL module in slot 5
    switch 1 brought up
    Initializing as Virtual Switch Active
    
  10. Distribution-2 スイッチの VSS モードへの変換を確認します。

    VSS#show switch virtual role
    
    Switch  Switch Status  Preempt    Priority   Role     Session ID
            Number         Oper(Conf) Oper(Conf)          Local  Remote
    -------------------------------------------------------------------
    LOCAL    1     UP      FALSE(N)    110(110)  ACTIVE    0      0
    
    In dual-active recovery mode: No
    

    Distribution-2 スイッチが正常に変換され、VSS モードで動作しています。Distribution-1 の変換後、事前設定された手順も実行できます。ただし、事前設定は移行中のパケット損失量の削減に役立ちます。

    VSS に移行した Distribution-2

    VSS に移行した Distribution-2

  11. 次の手順を実行して、VSS Switch 1 を事前設定します。

    1. Switch-1 のローカル インターフェイスを使用して MEC を設定します。Switch-2(現在の Distribution-1)のインターフェイスを VSS モードへの変換後に MEC に追加できます。

      • MEC を設定します。

      • インターフェイス設定を MEC へ移行します。

      • QoS と ACL のポリシーを MEC へ移行します。

      初期設定
      interface TenGigabitEthernet1/2/1
       ip address 192.168.4.2 255.255.255.0
      
      interface GigabitEthernet1/1/2
       switchport
       switchport trunk encapsulation dot1q
       switchport trunk allowed vlan 10,20
      
      設定の変更
      
      !--- MEC からコア レイヤ。
      
      VSS(config)# int ten 1/2/1
      VSS(config-if)# no ip address
      VSS(config-if)# interface po20
      VSS(config-if)# ip address 192.168.4.2 255.255.255.0
      VSS(config-if)# no shut
      VSS(config-if)# interface ten1/2/1
      VSS(config-if)# channel-group 20 mode desirable
      
      
      !--- MEC からアクセス レイヤ。
      
      VSS(config-if)# interface po10
      VSS(config-if)# switchport
      VSS(config-if)# switchport trunk encapsulation dot1q
      VSS(config-if)# switchport trunk allowed vlan 10,20
      VSS(config-if)# no shut
      VSS(config-if)# interface gig1/1/2
      VSS(config-if)# switchport
      VSS(config-if)# channel-group 10 mode desirable
      
      ポート チャネルに対応するための隣接デバイスの設定

      VSS Switch-1 とその隣接デバイスの間の接続は、この時点でダウンしています。したがって、ポート チャネルは Distribution-1 を通過するトラフィック フローに干渉せずに設定されます。

      
      !--- コア レイヤ デバイス内。
      
      Core(config)# int gig 1/1
      Core(config-if)# no ip address
      Core(config-if)# int po20
      Core(config-if)# ip address 192.168.4.1 255.255.255.0
      Core(config-if)# no shut
      Core(config-if)# int gig 1/1
      Core(config-if)# channel-group 20 mode desirable
      
      
      !--- アクセス レイヤ デバイス内。
      
      Access(config)# int po10
      Access(config-if)# switchport
      Access(config-if)# switchport trunk encapsulation dot1q
      Access(config-if)# switchport trunk
      Access(config-if)# no shut
      Access(config-if)# int gig 1/1
      Access(config-if)# channel-group 10 mode desirable
      
    2. VSS では、アクティブ側とスタンバイ側のどちらのシャーシによっても、アクティブ側のシャーシに焼き付けられた MAC アドレスと VLAN IP アドレスが使用されます。HSRP は不要になります。

      • HSRP 仮想 IP アドレスを VLAN インターフェイスに移行します。

      • VLAN インターフェイスから HSRP 設定を削除します。

      初期設定
      interface Vlan10
       ip address 10.1.1.2 255.255.255.0
       standby 10 ip 10.1.1.1
       standby 10 priority 110
      !
      interface Vlan20
       ip address 20.1.1.2 255.255.255.0
       standby 20 ip 20.1.1.1
       standby 20 priority 110
      !
      
      設定の変更
      VSS(config)# interface Vlan10
      VSS(config-if)# no standby 10 ip 10.1.1.1
      VSS(config-if)# no standby 10 priority 110
      VSS(config-if)# ip address 10.1.1.1 255.255.255.0
      VSS(config-if)# interface Vlan20
      VSS(config-if)# no standby 20 ip 20.1.1.1
      VSS(config-if)# no standby 20 priority 110
      VSS(config-if)# ip address 20.1.1.1 255.255.255.0
      

      注:エンド デバイスでは、その ARP エントリによって初期の HSRP MAC アドレスが引き続きポイントされている場合があります。これらのエントリにタイム アウトが発生するか、別の ARP がキャッシュをアップデートするために送信されるまで、接続の一部が失われます。

    3. 使用される IP ルーティング プロトコルに NSF-SSO 機能をイネーブルにします。VSS ではルーティング設定が簡素化されるため、一部の network 設定文が不要になります。したがって、これらを削除できます。

      VSS Switch-1
      VSS#show running-config | begin ospf
      router ospf 1
       log-adjacency-changes
       network 10.1.1.0 0.0.0.255 area 0
       network 20.1.1.0 0.0.0.255 area 0
       network 192.168.4.0 0.0.0.255 area 0
       network 192.168.5.0 0.0.0.255 area 0
      
      !--- 残りの出力を省略。
      
      
      
      !--- 以前の L3 インターフェイスが MEC として統合されているため、
      一部の routing 設定文は不要になります。
      
      
      VSS(config)# router ospf 1
      VSS(config-router)# nsf
      VSS(config-router)# no network 192.168.5.0 0.0.0.255 area 0
      
      コア
      Core#show running-config | begin ospf
      router ospf 1
       log-adjacency-changes
       network 192.168.4.0 0.0.0.255 area 0
       network 192.168.5.0 0.0.0.255 area 0
      
      !--- 残りの出力を省略。
      
      
      
      !--- 以前の L3 インターフェイスが MEC として統合されているため、
      一部の routing 設定文は不要になります。
      
      
      Core(config)# router ospf 1
      Core(config-router)# nsf
      Core(config-router)# no network 192.168.5.0 0.0.0.255 area 0
      
    4. STP 設定を修正して、VSS Switch-1 がすべての VLAN のルート(root)になるようにします。

  12. VSS Switch-1 設定と接続を確認します。

    • VSS Switch-1 インターフェイスをイネーブルにします。

    • アクセス レイヤ デバイスへの L2 接続を確認します。

    • コア レイヤ デバイスへの L3 接続を確認します。

    VSS Switch-1 の接続

    VSS Switch-1 の接続

  13. VSS Switch-1 接続の確認後、Distribution-1 のインターフェイスをシャットダウンし、トラフィックを VSS にスイッチングします。

    Distribution-1 がシャットダウンされた状態

    Distribution-1 がシャットダウンされた状態

  14. Distribution-1 スイッチ上で変換手順を繰り返し、優先する VSS スタンバイ モードにします。

    Distribution-1(config)#hostname VSS
    
    VSS(config)#switch virtual domain 100
    
    VSS(config-vs-domain)#switch 2
    
    
    !--- 変換後、Distribution-1 は 
    !--- VSS モード内で Switch 2 として認識されます。
    
    VSS(config-vs-domain)# exit
    VSS(config)#interface port-channel 2
    VSS(config-if)#switch virtual link 2
    
    VSS(config-if)#interface TenG 5/4
    VSS(config-if)#channel-group 2 mode on
    VSS(config-if)#interface TenG 5/5
    VSS(config-if)#channel-group 2 mode on
    VSS(config-if)# ^Z
    VSS#
    
    VSS#switch convert mode virtual
    
    This command will convert all interface
    names to naming convention "interface-type
    switch-number/slot/port",
    save the running config to startup-config and
    reload the switch.
    Do you want to proceed? [yes/no]: yes
    Converting interface names
    Building configuration...
    
    
    !--- この時点でスイッチがリブートされます。
    
    
    
    !--- コンソール出力の一部。
    
    System detected Virtual Switch configuration...
     Interface TenGigabitEthernet 2/5/4 is member of
    PortChannel 2
     Interface TenGigabitEthernet 2/5/5 is member of
    PortChannel 2
    
    !--- コンソール出力の一部。
    
    00:00:23: %PFREDUN-6-ACTIVE: Initializing as ACTIVE
    processor for this switch
    
    !--- コンソール出力の一部。
    
    00:00:28: %VSL_BRINGUP-6-MODULE_UP: VSL module in slot 5
    switch 2 brought up
    Initializing as Virtual Switch Standby
    
  15. VSS スタンバイ スイッチのブートアップ後、VSS アクティブ設定が自動的に VSS スタンバイへ同期されます。ブートアップ時、VSS スタンバイ(Switch-2)のインターフェイスはシャットダウン状態になります。

    VSS スタンバイの同期

    VSS スタンバイの同期

  16. Switch-2 インターフェイスを MEC へ追加します。

    • VSS
      
      !--- コア レイヤ向け。
      
      VSS(config)# interface range tengig 1/2/1, tengig2/2/1
      VSS(config-if-range)# channel-group 20 mode desirable
      VSS(config-if-range)# no shut
      
      
      !--- アクセス レイヤ向け。
      
      VSS(config)# interface range gig 1/1/2, gig 2/1/2
      VSS(config-if-range)# switchport
      VSS(config-if-range)# channel-group 10 mode desirable
      VSS(config-if-range)# no shut
      
    • VSS ネイバー:コア
      Core(config)# interface range gig 1/1, gig 1/2
      Core(config-if-range)# channel-group 20 mode desirable
      Core(config-if-range)# no shut
      
    • VSS ネイバー:アクセス
      Access(config)# interface range gig 1/1, gig 1/2
      Access(config-if-range)# channel-group 10 mode desirable
      Access(config-if-range)# no shut
      

    VSS への移行が完了しました。この時点で、VSS のどちらのスイッチも稼働し、トラフィックはすべてのアップリンク インターフェイスでロード バランスされています。

    VSS への移行が完了した状態

    VSS への移行が完了した状態




関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報




Document ID: 109573