Cisco Security Advisory: Cisco IOS Software Multiple Features Crafted UDP Packet Vulnerability

2009 年 3 月 25 日 - ライター翻訳版
その他のバージョン: PDFpdf | 英語版 (2009 年 3 月 25 日) | フィードバック

Advisory ID: cisco-sa-20090325-udp

http://www.cisco.com/warp/public/707/cisco-sa-20090325-udp.shtml

本翻訳は、原文の機械翻訳後に技術者が簡易レビューをしたものです。
日本語による情報は、英語による原文の非公式な翻訳 であり、英語原文との間で内容の齟齬がある場合には、英語原文が優先します。

Revision 1.5

Last Updated 2009 June 26 1500 UTC (GMT)

For Public Release 2009 March 25 1600 UTC (GMT)


要約

Cisco IOSソフトウェアのいくつかの機能は、巧妙に細工された UDP パケットによる脆弱性の影響を受けます。影響を受ける機能が有効な状態で攻撃を受けた場合、受信インターフェースの入力キューブロックがもたらされます。機器宛の巧妙に細工された UDPパケットだけがインターフェースのブロックを引き起こし、通過するトラフィックは影響を及ぼしません。

Ciscoはこの脆弱性に対処する無償のソフトアップデートをリリースしました。

この脆弱性に対する緩和策が存在します。

このアドバイザリは次のリンクに掲載されます: http://www.cisco.com/cisco/web/support/JP/106/1065/1065622_cisco-sa-20090325-udp-j.html

注:2009年 3月 25日のIOSアドバイザリバンドル公開には 8つの Security Advisory が含まれています。それらは全て Cisco IOS ソフトウェアの脆弱性に対処するものです。各アドバイザリには、そのアドバイザリで記述された脆弱性を解決するリリースを記載しています。個々の公開リンクは下記に掲載されています:

該当製品

脆弱性のある製品

Cisco IOSソフトウェアおよびCisco IOS XEソフトウェアの影響を受けたバージョンで次の機能を実行する場合、機器は影響を受けます:

  • IP Service Level Agreements (SLA) Responder
  • Session Initiation Protocol (SIP)
  • H.323 Annex E Call Signaling Transport
  • Media Gateway Control Protocol(MGCP)

影響を受ける機能が機器上で有効になっているかを確認する方法の詳細は、本アドバイザリの詳細の項目で提供されています。

Cisco 製品で稼動中の Cisco IOS ソフトウェア リリースを確認するには、 機器にログインし show version コマンドを 実行してシステムバナーを表示させます。Cisco IOS ソフトウェアは、 "Internetwork Operating System Software" もしくは "Cisco IOS Software" と表示されます。 その後ろにイメージ名が括弧の間に表示され、 続いて "Version" と Cisco IOS ソフトウエア リリース名が表示されます。 他の Cisco 機器では、 show version コマンドがない場合や、 異なる表示をする場合があります。

以下の例では、Cisco 製品にて、IOSリリース 12.3(26) が稼動し、 そのイメージ名が C2500-IS-L であることを示しています:

Router#show version
 Cisco Internetwork Operating System Software
 IOS (tm) 2500 Software (C2500-IS-L), Version 12.3(26), RELEASE SOFTWARE (fc2)
 Technical Support: http://www.cisco.com/techsupport
 Copyright (c) 1986-2008 by cisco Systems, Inc.
 Compiled Mon 17-Mar-08 14:39 by dchih

 <output truncated>

以下の例では、Cisco 製品にて、IOSリリース 12.4(20)T が稼動し、 そのイメージ名が C1841-ADVENTERPRISEK9-Mであることを示しています:

Router#show version
Cisco IOS Software, 1841 Software (C1841-ADVENTERPRISEK9-M), Version 12.4(20)T, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Thu 10-Jul-08 20:25 by prod_rel_team

<output truncated>

Cisco IOS ソフトウエアのリリース命名規則の追加情報は以下のリンクの "White Paper: Cisco IOS Reference Guide"で確認できます: http://www.cisco.com/warp/public/620/1.html

脆弱性が存在しない製品

以下の機能およびソフトウェアはこの脆弱性の影響を受けません。

  • Cisco IOS XR ソフトウェア
  • Cisco 500 Series Wireless Express Access Points
  • Cisco WMIC (in Cisco 3200 MARs)
  • Service Assurance Agent(SAA)
  • Response Time Reporter (RTR)
  • Cisco IOSで動作し、影響があると確認されているもの以外の機能およびプロトコル
  • Cisco Aironet 1250 Series
  • Cisco Aironet 1240 AG Series
  • Cisco Aironet 1230 AG Series
  • Cisco Aironet 1200 Series
  • Cisco Aironet 1140 Series
  • Cisco Aironet 1130 AG Series
  • Cisco Aironet 1100 Series
  • Cisco Aironet 1500 Series
  • Cisco Aironet 1400 Series
  • Cisco Aironet 1300 Series
  • Cisco AP801 (in 860 and 880 series ISRs)

他のシスコ製品において本アドバイザリーの影響を受けるものは現在確認されていません。

詳細

以下に記載されている機能のいずれかが設定されており、それに関連した UDP ポート番号にアクセス可能な場合、その機器には脆弱性が存在します。それぞれの機能について、脆弱性が存在する設定かどうかを確認することに加え、管理者はいくつかの show コマンドによって Cisco IOS 機器が UDPサービスを処理するプロセスが実行されているか、影響のある UDPポートを開放しているかを確認することもできます。

Cisco IOS 機器が開放している UDPポートを表示する方法は Cisco IOS ソフトウェアのバージョンによって異なります。show ip socketsshow udp コマンドはこれらのポートを確認するために使用することができます。それぞれの機能について、上記のコマンドを使用した例が下記に例示されています。

この脆弱性の影響を受けた場合、その機器のインターフェースがブロックされます。この脆弱性について、インターフェースのタイプは無関係であるため、イーサネットベースの全てのインターフェース、ATM、シリアル、POS、および全てのタイプのインタフェースが影響を受けます。メイン物理インターフェースに設定されたサブインターフェースは、メインインターフェースがブロックされた場合に影響を受けます。攻撃がサブインタフェースに対して発生した場合、メインインターフェースがブロックされます。ブロックされたインターフェースでは、ブロック状態が解消されるまでの間、後続のパケットを受信することができません。他のインターフェースは影響を受けることはなく、パケットの送受信を継続します。

機器のインターフェースに設定された到達可能な IP アドレス宛のパケットのみがこの脆弱性を利用することができます。機器を通過するトラフィックはこの脆弱性を利用できません。

入力キューがブロックされた場合、ルーティングプロトコル(OSPF、EIGRP、BGP、ISIS、等)および MPLS TDP/LDPのようなコントロール・プレーン・プロトコルにおいて、影響を受けたインターフェースを通じた適切な接続確立が失敗します。影響を受けた機器において、プロトコルのタイマーが切れた場合、通過するトラフィックも影響を受ける可能性があります。

ブロックされたインプットインターフェイスを識別するためには、show interfaces コマンドを実行し、Input Queue の行を確認します。インプットキューのサイズが増加し続けています。現在のサイズが、下記の例では76ですが、最大サイズ(デフォルトは75)と等しい、もしくは大きい場合、入力キューはブロックされている可能性があります。

機器が一時的に大量のコントロールプレーン向けのトラフィックを受信することもあり、キューが最大の状態は一時的なイベントである可能性も考えられます。インターフェースが本当にブロックされているかを確認するために、shutdown インターフェースコンフィグレーションコマンドを使用して、インターフェースをシャットダウンし、入力キューを確認します。もし入力キューが 0 パケットでない場合、インターフェースはブロックされています。

Router#show interface ethernet 0/0
Ethernet0/0 is up, line protocol is up
 Hardware is AmdP2, address is 0050.500e.f1e0 (bia 0050.500e.f1e0)
 Internet address is 192.168.0.1/24
 MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
 Encapsulation ARPA, loopback not set, keepalive set (10 sec)
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 00:00:41, output 00:00:07, output hang never
 Last clearing of "show interface" counters 00:07:18
 Input queue: 76/75/1091/0 (size/max/drops/flushes); Total output drops: 0

IP Service Level Agreements (SLA) Responder

Cisco IOS の IP Service Level Agreements (SLAs) Responder で、User Datagram Protocol (UDP) echo または jitter operations の機能を設定している機器は脆弱性の影響を受けます。responderとして動作するように設定されている機器全てが脆弱性の対象となります。以下は脆弱性の影響を受ける 2つの設定です。1つ目は、一般的な IP SLA responderとなるための設定です:

ip sla responder

または

ip sla monitor responder

以下は、2つ目の設定で、ある特定の UDP responderになるための設定を示しています。:

ip sla responder
ip sla responder udp-echo ipaddress 10.10.10.10 port 1025

Service Assurance Agent (SAA) と Response Time Reporter (RTR) 機能は、脆弱性の影響を受けず"rtr"コマンド構文を使用します。以下は脆弱性の影響を受けない設定例です:

rtr responder

以下は、デフォルトの UDPポート 1967で IP SLA コントロールチャンネルを開放し、影響を受ける機器の例です。

Router#show udp
Proto    Remote      Port      Local       Port  In Out Stat TTY OutputIF
 17 0.0.0.0             0 10.2.6.1         1967   0   0  211   0

Cisco IOS IP SLAの追加情報は以下のリンクの "Cisco IOS IP SLAs Configuration Guide, Release 12.4 - Cisco IOS IP SLAs Overview"で確認できます:: http://www.cisco.com/en/US/docs/ios/12_4/ip_sla/configuration/guide/hsoverv.html

Session Initiation Protocol (SIP)

注: SIPをご利用のお客様は、以下のリンクの "Cisco Security Advisory: Cisco IOS Session Initiation Protocol Denial of Service Vulnerability" も併せてご参照ください: http://www.cisco.com/warp/public/707/cisco-sa-20090325-sip.html

SIP メッセージを処理する Cisco機器は影響を受けます。Cisco IOS ソフトウェアの最近のバージョンは、デフォルトで SIP メッセージを処理しません。"dial-peer voice" に何らかのオプションをつけて実行し、"dial peer" を作成することで SIPプロセスが開始され、Cisco IOSソフトウェアは SIP メッセージの処理を開始します。ePhoneなどの Cisco Call Manager Express内のいくつかの機能は、一度設定されると自動的に SIPプロセスが開始され、そのデバイスは SIPメッセージの処理を開始します。なんらかの Voice設定を実施している場合は、"show ip socket""show udp" コマンドで SIPプロセスが存在しているかどうかを確認することを推奨します。 以下は影響を受ける設定の例です:

dial-peer voice <Voice dial-peer tag> voip
 ...
!

注: より古いバージョンの Cisco IOS ソフトウェアは、SIP動作のための設定がない状態でも Cisco IOS ソフトウェアに SIPを処理させるという不具合の影響を受けています。以下のリンクの "Cisco Security Advisory: SIP Packets Reload IOS Devices with support for SIP" も併せてご参照ください: http://www.cisco.com/warp/public/707/cisco-sa-20070131-sip.shtml

以下は、機器がデフォルトの UDP ポート 5060で SIP メッセージを処理し、影響を受ける例です:

Router#show ip socket
Proto    Remote      Port      Local       Port  In Out Stat TTY OutputIF
 17 0.0.0.0             0 192.168.0.2      5060   0   0  211   0

SIPの追加情報は以下のリンクの "Cisco IOS SIP Configuration Guide"で確認できます: http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/vvfax_c/callc_c/sip_c/sipc1_c/index.htm

H.323 Annex E Call Signaling Transport

H.323をサポートするように設定されている Cisco機器は影響を受けます。影響を受けるプロトコルは、UDP上で動作する H.323 Annex E Call Signaling Transport です。 ITU-T 勧告 H.323 Annex Eには、H.225.0 呼び出し信号を UDP上で転送するための、シグナリングフレームワークとワイヤープロトコルを記述しています。Cisco IOS ソフトウェアの最近のバージョンでは、デフォルトで H.225.0 UDPポートを開放していません。"dial-peer voice" を何らかのオプションをつけて実行し、"dial peer" を作成することで、H.225.0 UDP ポートを開放します。ePhoneなどの Cisco Call Manager Express内のいくつかの機能は、一度設定されると自動的に H.323プロセスが開始され、そのデバイスは H.323メッセージの処理を開始します。なんらかの Voice設定を実施している場合は、"show ip socket""show udp"コマンドで H.323プロセスが存在しているかどうかを確認することを推奨します。 以下は影響を受ける設定例です:

dial-peer voice <Voice dial-peer tag> voip
 ...
!

注: より古いバージョンの Cisco IOSソフトウェアは、H.323動作のための設定がない状態でも Cisco IOS ソフトウェアにH.323のポートを開放させるという不具合の影響を受けています。以下の Cisco Bug IDを併せてご参照ください: CSCsb25337 (登録ユーザのみ)

以下は、デフォルトの UDPポート 2517で H.225.0パケットを処理し、影響を受ける例です:

Router#show ip socket
Proto    Remote      Port      Local       Port  In Out Stat TTY OutputIF

 17 0.0.0.0             0 192.168.0.2      2517   0   0  211   0

H.323の追加情報は以下のリンクの "Cisco IOS H.323 Configuration Guide"で確認できます: http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_h323_configuration_guide/old_archives_h323/323confg.html

Media Gateway Control Protocol(MGCP)

MGCP機能を設定されている機器は影響を受けます。MGCPは"mgcp"コマンドで全体に有効になります。MGCPのデフォルトの開放ポートは2427です。以下は脆弱性の影響を受ける設定例です:

mgcp

以下は、影響のあるUDP ポートで MGCPパケットを処理する機器の例です:

Router#show ip socket
Proto    Remote      Port      Local       Port  In Out Stat TTY OutputIF
 17 192.168.0.1     2427 10.66.91.138      2427   0   0  211   0

MGCPの追加情報は以下のリンクの "Configuring the Cisco IOS MGCP Gateway reference"で確認できます: http://www.cisco.com/cisco/web/support/JP/111/1115/1115958_vg200_cfg-j.html

この脆弱性は、Cisco Bug ID CSCsk64158 (登録ユーザのみ) として文書化され、Common Vulnerabilities and Exposures(CVE) IDとして CVE-2009-0631 が割り当てられています。

脆弱性スコア詳細

Cisco はこのアドバイザリでの脆弱性に対して Common Vulnerability Scoring System (CVSS) に基づいたスコアを提供しています。 このセキュリティアドバイザリでの CVSSスコアは CVSS version 2.0に基づいています。

CVSSは、脆弱性の重要度を示唆するもので、緊急性および対応の優先度を決定する手助けとなる標準ベースの評価法です。

Cisco は基本評価 (Base Score) および現状評価スコア (Temporal Score) を提供いたします。 お客様はこれらを用いて環境評価スコア (Environmental Score) を算出し、 個々のネットワークにおける脆弱性の影響度を導き出すことができます。

Cisco は以下の URL にて CVSS に関する FAQ を提供しています。

http://www.cisco.com/web/about/security/intelligence/cvss-qandas.html

また Cisco は個々のネットワークにおける環境影響度を算出する CVSS 計算ツールを以下の URL にて提供しています。

http://intellishield.cisco.com/security/alertmanager/cvss

CSCsk64158: Cisco IOS Software Multiple Features Crafted UDP Packet Vulnerability

Calculate the environmental score of CSCsk64158
CVSS Base Score - 7.8
Access VectorAccess ComplexityAuthenticationConfidentiality ImpactIntegrity ImpactAvailability Impact
NetworkLowNoneNoneNoneComplete
CVSS Temporal Score - 6.4
ExploitabilityRemediation LevelReport Confidence
FunctionalOfficial-FixConfirmed

影響

この脆弱性の影響を受けた場合、入力インターフェースがブロックされ、受信トラフィックが破棄されます。通常の機能を回復するためには機器のリロードが必要です。

ソフトウエアバージョン及び修正

ソフトウェアのアップグレードを検討する際には、 http://www.cisco.com/go/psirt および、本アドバイザリ以降に公開のアドバイザリも参照して、 起こりうる障害と完全なアップグレード ソリューションを判断してください。

いずれの場合も、アップグレードする機器に十分なメモリがあること、 および現在のハードウェアとソフトウェアの構成が新しいリリースで 引き続き適切にサポートされていることの確認を十分に行ってください。 情報が不明確な場合は、Cisco Technical Assistance Center (TAC) もしくは契約している保守会社にお問い合せください。

Cisco IOS ソフトウェアテーブル(下記)の各行は Cisco IOS のリリーストレインを示します。 あるリリーストレインが脆弱である場合、修正を含む最初のリリースは、 表の "First Fixed Release" 列に示されます(入手可能予想日が示される場合もあります)。 "Recommended Release" 列は、このアドバイザリの公開時点において 公開済みである全ての脆弱性についての修正を含むリリースを示します。 実行しているリリースが、そのトレインで "First Fixed Release" 以前のものである 機器は脆弱であることが知られています。 Cisco はテーブルの "Recommended Releases" 列のリリース、 またはそれ以降のリリースにアップグレードすることを推奨します。

Major Release

Availability of Repaired Releases

Affected 12.0-Based Releases

First Fixed Release

Recommended Release

12.0

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0DA

Vulnerable; first fixed in 12.2DA

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0DB

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0DC

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0S

12.0(32)S12

12.0(33)S3; Available on 30-APR-2009

12.0(32)S12

12.0SC

Vulnerable; first fixed in 12.0S

12.0(32)S12

12.0SL

Vulnerable; first fixed in 12.0S

12.0(32)S12

12.0SP

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0ST

Vulnerable; first fixed in 12.0S

12.0(32)S12

12.0SX

Vulnerable; first fixed in 12.0S

12.0(32)S12

12.0SY

12.0(32)SY8

12.0(32)SY8

12.0SZ

Vulnerable; first fixed in 12.0S

12.0(32)S12

12.0T

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0W

Vulnerable; contact TAC

 

12.0WC

Vulnerable; contact TAC

 

12.0WT

Not Vulnerable

 

12.0XA

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XB

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XC

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XD

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XE

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XF

Not Vulnerable

 

12.0XG

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XH

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XI

Releases prior to 12.0(4)XI2 are vulnerable, release 12.0(4)XI2 and later are not vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XJ

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XK

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XL

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XM

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XN

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XQ

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XR

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XS

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XT

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.0XV

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

Affected 12.1-Based Releases

First Fixed Release

Recommended Release

12.1

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1AA

Vulnerable; contact TAC

 

12.1AX

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.1AY

Vulnerable; first fixed in 12.1EA

12.1(22)EA13

12.2(44)SE6

12.1AZ

Vulnerable; first fixed in 12.1EA

12.1(22)EA13

12.2(44)SE6

12.1CX

Vulnerable; contact TAC

 

12.1DA

Vulnerable; contact TAC

 

12.1DB

Vulnerable; contact TAC

 

12.1DC

Vulnerable; contact TAC

 

12.1E

Vulnerable; first fixed in 12.2SXF

12.2(18)SXF16

12.1EA

12.1(22)EA13

12.1(22)EA13

12.1EB

Vulnerable; contact TAC

 

12.1EC

Vulnerable; first fixed in 12.3BC

12.2(33)SCB1

12.3(23)BC6

12.1EO

Vulnerable; contact TAC

 

12.1EU

Vulnerable; first fixed in 12.2SG

12.2(31)SGA9

12.1EV

Vulnerable; contact TAC

 

12.1EW

Vulnerable; migrate to 12.2SGA

12.2(31)SGA9

12.1EX

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1EY

Vulnerable; contact TAC

 

12.1EZ

Vulnerable; first fixed in 12.2SXF

12.2(18)SXF16

12.1GA

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1GB

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1T

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XA

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XB

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XC

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XD

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XE

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XF

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XG

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XH

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XI

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XJ

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XL

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XM

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XP

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XQ

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XR

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XS

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XT

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XU

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XV

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XW

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XX

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XY

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1XZ

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1YA

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1YB

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1YC

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1YD

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1YE

Releases prior to 12.1(5)YE6 are vulnerable, release 12.1(5)YE6 and later are not vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1YF

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1YH

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.1YI

Vulnerable; contact TAC

 

12.1YJ

Vulnerable; first fixed in 12.1EA

12.1(22)EA13

12.2(44)SE6

Affected 12.2-Based Releases

First Fixed Release

Recommended Release

12.2

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2B

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.2BC

Vulnerable; migrate to 12.2SCB or 12.3BC

12.2(33)SCB1

12.3(23)BC6

12.2BW

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2BX

Vulnerable; migrate to 12.2SB

12.2(33)SB4

12.2BY

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2BZ

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2CX

Vulnerable; migrate to 12.2SCB or 12.3BC

12.2(33)SCB1

12.3(23)BC6

12.2CY

Vulnerable; migrate to 12.2SCB or 12.3BC

12.2(33)SCB1

12.3(23)BC6

12.2CZ

Vulnerable; first fixed in 12.2SB

12.2(33)SB4

12.2DA

12.2(12)DA14; Available on 30-JUL-2009

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2DD

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2DX

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2EW

Vulnerable; first fixed in 12.2SG

12.2(31)SGA9

12.2EWA

Vulnerable; first fixed in 12.2SG

12.2(31)SGA9

12.2EX

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2EY

12.2(44)EY

12.2(44)SE6

12.2EZ

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2FX

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2FY

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2FZ

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2IRA

Vulnerable; first fixed in 12.2SRC

12.2(33)SRC4; Available on 18-MAY-2009

12.2IRB

Vulnerable; first fixed in 12.2SRC

12.2(33)SRC4; Available on 18-MAY-2009

12.2IXA

Vulnerable; migrate to any release in 12.2IXH

12.2(18)IXH; Available on 31-MAR-2009

12.2IXB

Vulnerable; migrate to any release in 12.2IXH

12.2(18)IXH; Available on 31-MAR-2009

12.2IXC

Vulnerable; migrate to any release in 12.2IXH

12.2(18)IXH; Available on 31-MAR-2009

12.2IXD

Vulnerable; migrate to any release in 12.2IXH

12.2(18)IXH; Available on 31-MAR-2009

12.2IXE

Vulnerable; migrate to any release in 12.2IXH

12.2(18)IXH; Available on 31-MAR-2009

12.2IXF

Vulnerable; migrate to any release in 12.2IXH

12.2(18)IXH; Available on 31-MAR-2009

12.2IXG

Vulnerable; migrate to any release in 12.2IXH

12.2(18)IXH; Available on 31-MAR-2009

12.2JA

Not Vulnerable

 

12.2JK

Not Vulnerable

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.2MB

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2MC

12.2(15)MC2m

12.2(15)MC2m

12.2S

Vulnerable; first fixed in 12.2SB

12.2(33)SB4

12.2SB

12.2(31)SB14

12.2(33)SB3

12.2(28)SB13

12.2(33)SB4

12.2SBC

Vulnerable; first fixed in 12.2SB

12.2(33)SB4

12.2SCA

Vulnerable; first fixed in 12.2SCB

12.2(33)SCB1

12.2SCB

12.2(33)SCB1

12.2(33)SCB1

12.2SE

12.2(46)SE2

12.2(44)SE5

12.2(50)SE

12.2(44)SE6

12.2SEA

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2SEB

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2SEC

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2SED

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2SEE

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2SEF

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2SEG

Vulnerable; first fixed in 12.2SE

12.2(44)SE6

12.2SG

12.2(50)SG

12.2(52)SG; Available on 15-MAY-2009

12.2SGA

12.2(31)SGA9

12.2(31)SGA9

12.2SL

Not Vulnerable

 

12.2SM

Vulnerable; contact TAC

 

12.2SO

Vulnerable; contact TAC

 

12.2SQ

12.2(44)SQ1

 

12.2SRA

Vulnerable; first fixed in 12.2SRC

12.2(33)SRC4; Available on 18-MAY-2009

12.2SRB

Vulnerable; first fixed in 12.2SRC

12.2(33)SRC4; Available on 18-MAY-2009

12.2(33)SRB5a; Available on 3-April-2009

12.2SRC

12.2(33)SRC3

12.2(33)SRC4; Available on 18-MAY-2009

12.2SRD

Not Vulnerable

 

12.2STE

Vulnerable; contact TAC

 

12.2SU

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.2SV

Vulnerable; contact TAC

 

12.2SVA

Vulnerable; contact TAC

 

12.2SVC

Vulnerable; contact TAC

 

12.2SVD

Vulnerable; contact TAC

 

12.2SVE

Vulnerable; contact TAC

 

12.2SW

Vulnerable; contact TAC

 

12.2SX

Vulnerable; first fixed in 12.2SXF

12.2(18)SXF16

12.2SXA

Vulnerable; first fixed in 12.2SXF

12.2(18)SXF16

12.2SXB

Vulnerable; first fixed in 12.2SXF

12.2(18)SXF16

12.2SXD

Vulnerable; first fixed in 12.2SXF

12.2(18)SXF16

12.2SXE

Vulnerable; first fixed in 12.2SXF

12.2(18)SXF16

12.2SXF

12.2(18)SXF16

12.2(18)SXF16

12.2SXH

12.2(33)SXH5; Available on 20-APR-2009

12.2(33)SXH5; Available on 20-APR-2009

12.2SXI

Not Vulnerable

 

12.2SY

Vulnerable; first fixed in 12.2SB

12.2(33)SB4

12.2SZ

Vulnerable; first fixed in 12.2SB

12.2(33)SB4

12.2T

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2TPC

Vulnerable; contact TAC

 

12.2XA

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XB

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XC

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XD

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XE

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XF

Vulnerable; migrate to 12.2SCB or 12.3BC

12.2(33)SCB1

12.3(23)BC6

12.2XG

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XH

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XI

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XJ

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XK

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XL

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XM

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XN

Vulnerable; first fixed in 12.2SRC

12.2(33)SB4

12.2(33)SRD1

12.2XNA

Vulnerable; migrate to any release in 12.2SRD

12.2(33)SRD1

12.2XNB

12.2(33)XNB1

12.2(33)XNB3

12.2XNC

Not Vulnerable

 

12.2XO

12.2(46)XO

12.2(46)XO

12.2XQ

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XR

Not Vulnerable

 

12.2XS

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XT

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XU

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XV

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2XW

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2YA

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2YB

Vulnerable; contact TAC

 

12.2YC

Vulnerable; contact TAC

 

12.2YD

Vulnerable; contact TAC

 

12.2YE

Vulnerable; contact TAC

 

12.2YF

Vulnerable; contact TAC

 

12.2YG

Vulnerable; contact TAC

 

12.2YH

Vulnerable; contact TAC

 

12.2YJ

Vulnerable; contact TAC

 

12.2YK

Vulnerable; contact TAC

 

12.2YL

Vulnerable; contact TAC

 

12.2YM

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.2YN

Vulnerable; contact TAC

 

12.2YO

Vulnerable; contact TAC

 

12.2YP

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2YQ

Vulnerable; contact TAC

 

12.2YR

Vulnerable; contact TAC

 

12.2YS

Not Vulnerable

 

12.2YT

Vulnerable; contact TAC

 

12.2YU

Vulnerable; contact TAC

 

12.2YV

Vulnerable; contact TAC

 

12.2YW

Vulnerable; contact TAC

 

12.2YX

Vulnerable; contact TAC

 

12.2YY

Vulnerable; contact TAC

 

12.2YZ

Vulnerable; contact TAC

 

12.2ZA

Vulnerable; first fixed in 12.2SXF

12.2(18)SXF16

12.2ZB

Vulnerable; contact TAC

 

12.2ZC

Vulnerable; contact TAC

 

12.2ZD

Vulnerable; contact TAC

 

12.2ZE

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2ZF

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.2ZG

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.2ZH

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.2ZJ

Vulnerable; contact TAC

 

12.2ZL

Vulnerable; contact TAC

 

12.2ZP

Vulnerable; contact TAC

 

12.2ZU

Vulnerable; first fixed in 12.2SXH

12.2(33)SRC4; Available on 18-MAY-2009

12.2ZX

Vulnerable; first fixed in 12.2SB

12.2(33)SB4

12.2ZY

Vulnerable; contact TAC

 

12.2ZYA

12.2(18)ZYA1

12.2(18)ZYA1

Affected 12.3-Based Releases

First Fixed Release

Recommended Release

12.3

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.3B

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3BC

12.3(23)BC6

12.3(23)BC6

12.3BW

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3EU

Not Vulnerable

 

12.3JA

Not Vulnerable

 

12.3JEA

Not Vulnerable

 

12.3JEB

Not Vulnerable

 

12.3JEC

Not Vulnerable

 

12.3JK

Not Vulnerable

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3JL

Vulnerable; contact TAC

 

12.3JX

Not Vulnerable

 

12.3T

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3TPC

Vulnerable; contact TAC

 

12.3VA

Vulnerable; contact TAC

 

12.3XA

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.3XB

Vulnerable; contact TAC

 

12.3XC

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3XD

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3XE

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.3XF

Vulnerable; contact TAC

 

12.3XG

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3XI

Vulnerable; first fixed in 12.2SB

12.2(33)SB4

12.3XJ

Vulnerable; first fixed in 12.3YX

12.3(14)YX14

12.3XK

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3XL

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3XQ

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3XR

Vulnerable; first fixed in 12.4

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.3XS

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3XU

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3XW

Vulnerable; first fixed in 12.3YX

12.3(14)YX14

12.3XX

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3XY

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3XZ

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3YA

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3YD

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3YF

Vulnerable; first fixed in 12.3YX

12.3(14)YX14

12.3YG

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3YH

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3YI

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3YJ

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3YK

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3YM

12.3(14)YM13

12.3(14)YM13

12.3YQ

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3YS

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3YT

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.3YU

Vulnerable; first fixed in 12.4XB

12.4(22)T1

12.3YX

12.3(14)YX14

12.3(14)YX14

12.3YZ

Vulnerable; contact TAC

 

12.3ZA

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

Affected 12.4-Based Releases

First Fixed Release

Recommended Release

12.4

12.4(23)

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.4(18e)

12.4(23a); Available on 05-JUN-2009

12.4JA

Not Vulnerable

 

12.4JDA

Not Vulnerable

 

12.4JK

Not Vulnerable

 

12.4JL

Not Vulnerable

 

12.4JMA

Vulnerable; contact TAC

 

12.4JMB

Vulnerable; contact TAC

 

12.4JX

Not Vulnerable

 

12.4MD

12.4(11)MD7

12.4(11)MD7

12.4MR

12.4(19)MR1

12.4(19)MR2

12.4SW

Vulnerable; contact TAC

 

12.4T

12.4(15)T8

12.4(20)T2

12.4(22)T

12.4(15)T9; Available on 29-APR-2009

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XA

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XB

12.4(15)T8

12.4(20)T2

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XC

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XD

12.4(4)XD12; Available on 27-MAR-2009

12.4(4)XD12; Available on 27-MAR-2009

12.4XE

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XF

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XG

12.4(15)T8

12.4(20)T2

12.4(22)T1

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XJ

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XK

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XL

12.4(15)XL4

12.4(15)XL4

12.4XM

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XN

Vulnerable; contact TAC

 

12.4XP

Vulnerable; contact TAC

 

12.4XQ

12.4(15)XQ2

12.4(15)XQ2

12.4XR

12.4(15)XR4

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XT

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XV

Vulnerable; contact TAC

 

12.4XW

12.4(11)XW10

12.4(11)XW10

12.4XY

Vulnerable; first fixed in 12.4T

12.4(22)T1

12.4(15)T9; Available on 29-APR-2009

12.4XZ

12.4(15)XZ2

12.4(15)XZ2

12.4YA

12.4(20)YA2

12.4(20)YA3

12.4YB

Not Vulnerable

 

12.4YD

Not Vulnerable

 

回避策

この脆弱性には、以下の緩和策が確認されています。機器上に設定されたIPアドレス宛のパケットのみが脆弱性の対象となります。通過するトラフィックは脆弱性を引き起こすことはありません。

影響のある開放ポートの無効化

影響のある機能が必要でない場合、それを明示的に無効にすることができます。無効にした場合、CLIコマンドの "show udp""show ip socket" コマンドを実行することで、開放されていた UDPポートが閉じたかどうかを確認することができます。機能によっては、開放されていた UDPのポートを閉じるために、機能を無効にした後、機器のリロードを必要とするものがあります。

SIPに関して、TCPサービスのみが必要な場合には、UDPの開放を無効にすることが可能です。以下は、SIPにおいて関連したUDPポートを無効にするための設定例です。

注: この回避策は Cisco Bug ID CSCsi34903の修正がされている Cisco IOS Software Imageのみに適用されます。

警告: 回避策を MGCPや H.323を実行する機器に適用する場合、アクティブな呼が処理されている間は、SIP処理を停止することができません。可能な限り、この回避策はアクティブな呼を一時的に停止可能なメンテナンス時間に実施することをお勧めします。

Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#sip-ua
Router(config-sip-ua)#no transport udp
Router(config-sip-ua)#end

SIPに関して、以下のように、プロセスを自身のアドレスを持つインターフェースにバインドすることが可能です。これによって、SIPは内部インターフェースにおいてのみ開放され、脆弱性の危険性を制限することが可能です:

voice service voip
 sip
  bind control source-interface <int>
  bind media source-interface <int>

Infrastructure Access Control Lists

警告: この脆弱性における機能は UDPをその転送手段として使用しているため、送信元の IPアドレスを偽装することも考えられ、これらのUDPポート宛の、信用された送信元 IPアドレスのみを許可するような ACLでは防ぎきれない場合もあります。より有効な緩和策としてユニキャスト RPFを併用することもお勧めします。

ネットワークを通過するトラフィックを遮断することはしばしば困難ですが、 インフラストラクチャ デバイスをターゲットとした許可すべきではないトラフィックを特定し、 そのようなトラフィックをネットワークの境界で遮断することは可能です。 Infrastructure Access Control Lists(iACLs) は、ネットワークセキュリティの ベストプラクティスであり、特定の脆弱性に対する回避策であると同時に 長期に渡って役立つネットワークセキュリティを付加することができます。 以下の iACL の例は、Infrastructure access-list の一部として設定されるべきであり、 インフラストラクチャ IP アドレスの範囲に含まれる IP アドレスを持つ全ての機器を防御します:

!--- Only sections pertaining to features enabled on the device
!--- need be configured.
!---
!---
!--- Feature: IP SLAs UDP Responder
!---

access-list 150 permit udp TRUSTED_SOURCE_ADDRESSES WILDCARD 
    INFRASTRUCTURE_ADDRESSES WILDCARD eq 1967

!--- Deny IP SLAs UDP Responder traffic from all other sources 
!--- destined to infrastructure addresses.

access-list 150 deny udp any 
     INFRASTRUCTURE_ADDRESSES WILDCARD eq 1967

!---
!--- Feature: Session Initiation Protocol (SIP)
!---

access-list 150 permit udp TRUSTED_SOURCE_ADDRESSES WILDCARD 
     INFRASTRUCTURE_ADDRESSES WILDCARD eq 5060

!--- Deny SIP traffic from all other sources destined
!--- to infrastructure addresses.

access-list 150 deny udp any 
     INFRASTRUCTURE_ADDRESSES WILDCARD eq 5060

!---
!--- Feature: H.323 Call Signaling
!---

access-list 150 permit udp TRUSTED_SOURCE_ADDRESSES WILDCARD 
     INFRASTRUCTURE_ADDRESSES WILDCARD eq 2517

!--- Deny H.323 Call Signaling traffic from all other sources
!--- destined to infrastructure addresses.

access-list 150 deny udp any 
     INFRASTRUCTURE_ADDRESSES WILDCARD eq 2517

!---
!--- Feature: Media Gateway Control Protocol (MGCP)

!---

access-list 150 permit udp TRUSTED_SOURCE_ADDRESSES WILDCARD 
    INFRASTRUCTURE_ADDRESSES WILDCARD eq 2427

!--- Deny MGCP traffic from all other sources destined
!--- to infrastructure addresses.

access-list 150 deny udp any 
     INFRASTRUCTURE_ADDRESSES WILDCARD eq 2427

!--- Permit/deny all other Layer 3 and Layer 4 traffic in 
!--- accordance with existing security policies and 
!--- configurations.  Permit all other traffic to transit the
!--- device.

access-list 150 permit ip any any

!--- Apply access-list to all interfaces (only one example
!--- shown)

interface serial 2/0
 ip access-group 150 in

White Paper の "Protecting Your Core: Infrastructure Protection Access Control Lists"は、 アクセスリストによってインフラストラクチャ デバイスを守るためのガイドラインと、 推奨される導入方法が記載されています:http://www.cisco.com/cisco/web/support/JP/100/1006/1006441_iacl-j.html

Control Plane Policing

警告: この脆弱性における機能は UDPをその転送手段として使用しているため、送信元の IPアドレスを偽ることも考えられ、これらの UDPポート宛の、信用された送信元IPアドレスのみを許可するようなACLでは防ぎきれない場合もあります。より有効な緩和策としてユニキャスト RPFを併用することもお勧めします。

Control Plane Policing(CoPP) は、機器宛ての 信用されていないUDPトラフィック をブロックするのに使用することができます。 CoPP 機能は、Cisco IOS ソフトウェアリリース 12.0S、12.2SX、12.2S、12.3T、12.4、 および 12.4T にてサポートされています。 管理およびコントロールプレーンを保護するために CoPP を機器に設定し、 既存のセキュリティーポリシーとコンフィギュレーションに従って 認定されたトラフィックだけがインフラストラクチャデバイス宛に 送信されることを明示的に許可することで、 インフラストラクチャへの直接攻撃のリスクとその効果を最小限に抑えることができます。 下記の CoPP の例はインフラストラクチャ IP アドレスの範囲内にある IP アドレス を持つ全ての機器を保護するために定義される CoPP の一部として含まれるべき項目です:

!---
!--- Only sections pertaining to features enabled on the device
!--- need be configured.
!---

!---
!--- Feature: IP SLAs UDP Responder
!---

access-list 150 deny udp TRUSTED_SOURCE_ADDRESSES MASK 
     any eq 1967

!---
!--- Deny IP SLAs UDP Responder traffic from all other sources 
!--- destined to the device control plane.
!---

access-list 150 permit udp any any eq 1967

!---
!--- Feature: Session Initiation Protocol (SIP)
!---

access-list 150 deny udp TRUSTED_SOURCE_ADDRESSES MASK 
    any eq 5060

!---
!--- Deny SIP traffic from all other sources destined
!--- to the device control plane.
!---

access-list 150 permit udp any any eq 5060

!---
!--- Feature: H.323 Call Signaling
!---


access-list 150 deny udp TRUSTED_SOURCE_ADDRESSES MASK
    any eq 2517

!---
!--- Deny H.323 call signaling traffic from all other sources 
!--- destined to the device control plane.
!---

access-list 150 permit udp any any eq 2517

!---
!--- Feature: Media Gateway Control Protocol (MGCP)
!---

access-list 150 deny udp TRUSTED_SOURCE_ADDRESSES MASK 
     any eq 2427

!---
!--- Deny MGCP traffic from all other sources destined
!--- to the device control plane.
!---

access-list 150 permit udp any any eq 2427

!---
!--- Permit (Police or Drop)/Deny (Allow) all other Layer3 and 
!--- Layer4 traffic in accordance with existing security policies
!--- and configurations for traffic that is authorized to be sent
!--- to infrastructure devices
!--- Create a Class-Map for traffic to be policed by
!--- the CoPP feature
!---

class-map match-all drop-udp-class
 match access-group 150

!---

!--- Create a Policy-Map that will be applied to the
!--- Control-Plane of the device.
!---

policy-map drop-udp-traffic
 class drop-udp-class
  drop

!---
!--- Apply the Policy-Map to the 
!--- Control-Plane of the device
!---


control-plane
 service-policy input drop-udp-traffic

上記の CoPP の例では、"permit" アクションである アクセスコントロールリストエントリ(ACE)に該当し、 攻撃である可能性のあるパケットは、policy-map の "drop" 機能により廃棄されますが、 一方、"deny" アクション(記載されていません)に該当するパケットは、 policy-map の "drop" 機能の影響を受けません。 policy-map の構文は、12.2S と 12.0S Cisco IOS トレインでは異なるので注意が必要です:

policy-map drop-udp-traffic
class drop-udp-class
police 32000 1500 1500 conform-action drop exceed-action drop

CoPP の設定と使用法についての追加情報については、以下のリンクの "Control Plane Policing Implementation Best Practices" および "Cisco IOS Software Releases 12.2S - Control Plane Policing" を参照下さい。http://www.cisco.com/web/about/security/intelligence/coppwp_gs.html http://www.cisco.com/en/US/docs/ios/12_3t/12_3t4/feature/guide/gtrtlimt.html

ネットワーク内の Cisco 機器に適用可能な他の緩和策は、 このアドバイザリの付属ドキュメントである Cisco Applied Mitigation Bulletin にて参照できますhttp://www.cisco.com/en/US/products/products_applied_mitigation_bulletin09186a0080a90428.html

不正利用の検出

インターフェース キューがブロックされたことを Cisco IOS Embedded Event Manager (EEM) ポリシー により検知することができます。 EEM は Cisco IOS デバイスにおけるイベント検知と対応アクション機能を提供します。 EEM は 管理者に対してインターフェースがブロックされたことを email, syslogメッセージ または Simple Network Management Protocol (SNMP) trap により警告することができます。

インターフェースがブロックされたことを管理者に syslogで警告することができる サンプル EEM ポリシーを EEM 専門のオンラインコミュニティ Cisco Beyond で入手することが出来ます。 サンプル スクリプトは次のリンクで入手可能です: http://forums.cisco.com/eforum/servlet/EEM?page=eem&fn=script&scriptId=981

EEM についての追加情報は、次の Cisco.com へのリンクより入手可能です:http://www.cisco.com/en/US/products/ps6815/products_ios_protocol_group_home.html

修正済みソフトウェアの入手

Cisco はこれらの脆弱性に対応するための無償ソフトウェア アップデートを提供しています。 ソフトウェアの導入を行う前にお客様のメンテナンスプロバイダーにご相談いただくか、 ソフトウェアのフィーチャーセットの互換性および お客様のネットワーク環境に特有の問題に関してご確認下さい。

お客様がインストールしたり、サポートを受けたりできるのは、 ご購入いただいたフィーチャーセットに対してのみとなります。 そのようなソフトウェア アップグレードをインストール、ダウンロード、 アクセスまたはその他の方法で使用した場合、お客様は http://www.cisco.com/en/US/docs/general/warranty/English/EU1KEN_.html に記載の Cisco のソフトウェア ライセンスの条項または、 Cisco.com Downloads の http://www.cisco.com/public/sw-center/sw-usingswc.shtml に説明のあるその他の条項に従うことに同意したことになります。

ソフトウェアのアップグレードに関し、"psirt@cisco.com" もしくは "security-alert@cisco.com" に お問い合わせいただくことはご遠慮ください。

サービス契約をお持ちのお客様

契約をお持ちのお客様は、通常のアップデート チャネルから アップグレード ソフトウェアを入手してください。 ほとんどのお客様は、Cisco のワールドワイドウェブサイト上の ソフトウェアセンターからアップグレードを入手することができます。 http://www.cisco.com

サードパーティのサポート会社をご利用のお客様

シスコ パートナー、正規販売代理店、サービス プロバイダーなど、 サードパーティのサポート会社と以前に契約していたか、または現在契約しており、 その会社から Cisco製品の提供または保守を受けているお客様は、 該当するサポート会社に連絡し、本脆弱性に関する適切な処置について指示と支援を受けてください。

回避策の効果は、使用製品、ネットワークトポロジー、トラフィックの性質や 組織の目的などのお客様の状況に依存します。影響製品が多種多様であるため、 回避策を実際に展開する前に、対象とするネットワークで適用する回避策が最適であるか、 お客様のサービスプロバイダーやサポート組織にご相談ください。

サービス契約をご利用でないお客様

Cisco から直接購入したが Cisco のサービス契約をご利用いただいていない場合、 また、サードパーティ ベンダーから購入したが修正済みソフトウェアを購入先から入手できない場合は、 Cisco Technical Assistance Center(TAC)に連絡してアップグレードを入手してください。 TAC の連絡先は次のとおりです。

  • +1 800 553 2447 (北米内からのフリー ダイヤル)
  • +1 408 526 7209 (北米以外からの有料通話)
  • 電子メール: tac@cisco.com

無料アップグレードの対象であることをご証明いただくために、 製品のシリアル番号を用意し、このお知らせのURLを知らせてください。 サポート契約をご利用でないお客様に対する無料アップグレードは、 TAC 経由でご要求いただく必要があります。

さまざまな言語向けの各地の電話番号、説明、電子メール アドレスなどの、 この他の TAC の連絡先情報については、 http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html を参照してください。

不正利用事例と公式発表

Cisco PSIRT では、本アドバイザリに記載されている脆弱性の不正利用事例とその公表は確認しておりません。

この脆弱性は内部テストで Ciscoにより発見されました。

この通知のステータス: FINAL

本アドバイザリは無保証のものとしてご提供しており、いかなる種類の保証を示唆するものでもありません。 本アドバイザリの情報およびリンクの使用に関する責任の一切はそれらの使用者にあるものとします。 また Cisco Systems はいつでも本ドキュメントの変更や更新を実施する権利を有します。

後述する情報配信の URL を省略し、本アドバイザリの記述内容に関して、単独の転載や意訳を実施した場合には、 事実誤認ないし重要な情報の欠落を含む統制不可能な情報の伝搬が行われる可能性があります。

情報配信

本アドバイザリーは、以下のシスコのワールドワイドウェブサイト上に掲載されます。

http://www.cisco.com/warp/public/707/cisco-sa-20090325-udp.shtml

ワールドワイドのウェブ以外にも、次の電子メールおよび Usenet ニュースの受信者向けに、この通知のテキスト版がシスコ PSIRT PGP キーによるクリア署名つきで投稿されています。

  • cust-security-announce@cisco.com
  • first-bulletins@lists.first.org
  • bugtraq@securityfocus.com
  • vulnwatch@vulnwatch.org
  • cisco@spot.colorado.edu
  • cisco-nsp@puck.nether.net
  • full-disclosure@lists.grok.org.uk
  • comp.dcom.sys.cisco@newsgate.cisco.com

このアドバイザリに関する今後の更新は、いかなるものも Cisco のワールドワイドウェブに掲載される予定です。 しかしながら、前述のメーリングリストもしくは ニュースグループに 対し積極的に配信されるとは限りません。 この問題に関心があるお客様は上記 URL にて最新情報をご確認いただくことをお勧めいたします。

更新履歴

Revision 1.5

2009-June-26

Removed references to the March/09 combined fixed software table.

Revision 1.4

2009-June-1

Updated expected public availability date for release 12.4(23a).

Revision 1.3

2009-May-1

Updated expected public availability date for release 12.4(23a).

Revision 1.2

2009-March-30

Specifically called out Wireless Products as not affected

Revision 1.1

2009-March-25

Revised procedure for disabling affected listening ports; see Workarounds.

Revision 1.0

2009-March-25

Initial public release.

シスコセキュリティ手順

Cisco製品におけるセキュリティの脆弱性の報告、セキュリティ事故に関する支援、およびCiscoからセキュリティ情報を入手するための登録方法について詳しく知るには、Ciscoワールドワイドウェブサイトの http://www.cisco.com/en/US/products/products_security_vulnerability_policy.html にアクセスしてください。 このページにはCiscoのセキュリティ通知に関してメディアが問い合わせる際の指示が掲載されています。 全てのCiscoセキュリティアドバイザリは http://www.cisco.com/go/psirt で確認することができます。