スイッチ : Cisco Catalyst 6500 シリーズ スイッチ

Catalyst スイッチの Microsoft Network Load Balancing 用の設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2009 年 5 月 26 日) | 英語版 (2015 年 10 月 6 日) | フィードバック

概要

このドキュメントでは、Microsoft Network Load Balancing(NLB)と相互対話するために Cisco Catalyst スイッチを設定する方法について説明しています。

著者:Ambrose Taylor、Dale Miller、および Shashank Singh、Cisco TAC エンジニア

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS® ソフトウェア リリース 15.1(1)SY1 が稼働する、Supervisor Engine 2T(Sup2T)を搭載した Cisco Catalyst 6500 シリーズ スイッチ

  • Cisco IOS ソフトウェア バージョン 15.0(2)SG7 が稼働する Cisco Catalyst 4948 シリーズ スイッチ

  • Microsoft Windows Server

: 他の Cisco プラットフォームでこれらの機能をイネーブルにするために使用されるコマンドの適切な設定ガイドを参照してください。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

NLB の技術は、一連のサーバにクライアント要求を分散するのに使用できます。 クライアントに対して許容できるパフォーマンス レベルを常に提供する目的で、IIS ベースの Web サーバなどのステートレス アプリケーションの規模の拡大に対応して、クライアントの負荷が増加する場合には Microsoft Windows NLB が追加サーバを追加できます。 また、誤作動が発生したサーバによるダウンタイムも減少します。

Microsoft Windows NLB は、すべての Windows 2000 Server および Windows 2003 のサーバ ファミリのオペレーティング システムの一部として提供されるクラスタリング技術です。 これは、クラスタ全体の宛先 IP アドレスとしてすべてのクライアントに単一の仮想 IP アドレスを提供します。

次の 3 つのモードのいずれかで動作するように NLB を設定できます。

  • ユニキャスト モード
  • マルチキャスト モード
  • インターネット グループ管理プロトコル(IGMP)モード

ユニキャスト モード

ユニキャスト モードの NLB の使用について注意事項を次に示します:

  • ユニキャスト モードでは、NLB は、クラスタの各サーバの実際のメディア アクセス コントロール(MAC)アドレスを共通 NLB MAC アドレスに置き換えます。 クラスタ内のすべてのサーバには同じ MAC アドレスが設定され、そのアドレスに転送されたすべてのパケットはクラスタのすべてのメンバへ送信されます。 NLB は架空の MAC アドレスを作成し、これを NLB クラスタ内の各サーバに割り当てます。 各 NLB サーバには、メンバのホスト ID に基づいたそれぞれ異なる架空の MAC アドレスが NLB によって割り当てられます。 このアドレスはイーサネット フレーム ヘッダー内に表示されます。

  • MAC アドレスは、イーサネット ヘッダーではなくアドレス解決プロトコル(ARP)ヘッダーで使用されます。 スイッチでは、ARP ヘッダーではなく、イーサネット ヘッダー内の MAC アドレスが使用されます。 これにより、パケットが宛先 MAC アドレスをクラスタの MAC アドレス 00-bf-ac-10-00-01 として指定して NLB クラスタに送信されると、問題が発生します。 スイッチは MAC アドレス 00-bf-ac-10-00-01 の Content Addressable Memory(CAM)テーブルを確認し、NLB クラスタの MAC アドレス 00-bf-ac-10-00-01 に登録されているポートがないため、フレームがスイッチ ポートすべてに配信されます。 これによりユニキャスト フラッディングが発生します。 フラッディングを回避するために、シスコではフラッディングを抑制するように NLB 専用の VLAN を使用することを推奨します。

マルチキャスト モード

マルチキャスト モードの NLB の使用について注意事項を次に示します:

  • マルチキャスト モードでは、システム管理者が Microsoft NLB 設定 GUI 内の [Multicast] ボタンをクリックします。 この選択により、0300.5e01.0101 などのマルチキャストの MAC アドレスを使用してこれらの仮想アドレスに対する ARP に応答するように、クラスタ メンバに指示が出されます。

  • ARP プロセスではマルチキャストの MAC アドレスを完了しません(これは RFC 1812 に反します)。 スタティック MAC アドレスはローカル サブネット外部のクラスタに到達するために必要です。

  • 仮想 IP アドレスは 10.100.1.99 で、マルチキャスト MAC アドレスは 0300.5e01.0101 です。 ARP テーブルに静的にデータ入力するには、次のコマンドを入力してください:
    arp 10.100.1.99 0300.5e01.0101
  • ただし、着信パケットにはユニキャスト宛先 IP アドレスおよびマルチキャスト宛先 MAC アドレスが与えられているため、シスコ デバイスではこのエントリが無視され、ユニキャストはクラスタにバインドされた各パケットをフラッディングします。 このフラッディングを回避するには、ハードウェア内でクラスタにバインドされたパケットを切替えるために、以下に示すように静的な mac-address-table entry を挿入します:
    mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
    TenGigabitEthernet1/5

: 複数のポートに MAC アドレスを静的にマッピングする場合は、Cisco Catalyst 4500 シリーズ スイッチのソフトウェアだけでサポートされます。 また、Catalyst 4500 シリーズのスイッチでこの設定を使用すると、CPU の使用率が高くなる可能性があります。 この問題を回避するために、特定の VLAN に NLB を切り離して、スタティック ARP エントリだけを追加し、その VLAN でフラッディングを可能にします。

IGMP モード

IGMP モードでの NLB の使用について注意事項を次に示します:

  • IGMP モードでの NLB の使用には最小限の手動設定が必要です。 仮想 MAC アドレスは、Internet Assigned Numbers Authority(IANA)の範囲に該当し、0100.5exx.xxxx から開始します。 MAC アドレスが IANA の仕様に準拠するようになったため、シスコ スイッチは、IGMP スヌーピングを使用して MAC アドレスを動的にプログラムできます。 これにより、VLAN へのフラッディングを防止するためにマルチキャスト モードで必要なポート マップに MAC アドレスを手動でプログラムする必要がなくなります。

  • IGMP スヌーピングは、スイッチがクラスタのメンバからメンバーシップ レポートを受信すると、ユーザの仮想 MAC アドレスをプログラムします。 マルチキャスト ルータのポートも、Protocol Independent Multicast(PIM)または IGMP クエリア機能を使用して NLB VLAN にプログラムする必要があります。

  • 仮想 IP アドレスはマルチキャストの MAC アドレスを使用するため、ローカル サブネットの外部へ到達不能です。 これを解決するには、クラスタ VLAN のレイヤ 3(L3)インターフェイスを使用して、各デバイスでスタティック ARP エントリを設定する必要があります。 マルチキャスト モードでの方法と同じ方法でこれを実行します。 たとえば、仮想 IP アドレスが 10.100.1.99 で、マルチキャスト MAC アドレスが 0100.5e01.0101 の場合、ARP テーブルに静的にデータ入力するには次のコマンドを使用します。
    arp 10.100.1.99 0100.5e01.0101

警告

IGMP モードで NLB を使用する場合に注意する重要な注意事項を次に示します:

  • Cisco Bug ID CSCsw72680 で追跡されるように、特定のバージョンのコードの NLB VLAN のスイッチ仮想インターフェイス(SVI)で PIM を使用できません。 この問題に対処するコード リリースのバグの詳細を参照するか、IGMP スヌーピング クエリア機能を使用してください。

  • Cisco Bug ID CSCsy62709 で追跡されるように、パケットは IGMP モードの NLB サーバにルーティングされたすべてのトラフィック用に複製されます。 該当するコード バージョンのバグの詳細を参照してください。

  • Cisco Bug ID CSCug49149 によって追跡されるハードウェアの制限により、スイッチが PFC3B モードまたは PFC3C モードで動作するときに NLB トラフィックは同じラインカード 6708 で分散 EtherChannel 経由で送信できません。 ポート チャネルは、メンバ リンクがすべて同じフォワーディング エンジン上にあるようにケーブル接続する必要があります。

設定

このセクションでは、マルチキャスト モードまたは IGMP モードで動作する Cisco Catalyst 6500 および 4948 シリーズのプラットフォームに NLB を設定する方法について説明します。

ネットワーク図

マルチキャスト モードの設定

このセクションでは、マルチキャスト モードで動作する Cisco Catalyst 6500 および 4948 シリーズのプラットフォームに NLB を設定する方法を説明しています。

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
interface TenGigabitEthernet1/4
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface TenGigabitEthernet1/5
switchport
switchport trunk allowed vlan 1,100,200
switchport mode trunk
!
interface Vlan100
ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.88 0300.5e01.0101 ARPA
!
!
mac address-table static 0300.5e01.0101 vlan 200 interface TenGigabitEthernet1/4
TenGigabitEthernet1/5 TenGigabitEthernet5/5

!
end

この設定についての重要な項目を次に示します:

  • interface Vlan100 ip address 値がユーザ VLAN を設定します。

  • interface Vlan200 ip address 値が NLB クラスタ VLAN を設定します。 このアドレスに Microsoft サーバのデフォルト ゲートウェイを設定することが重要です。

  • arp 10.100.1.88 0300.5e01.0101 ARPA は VLAN にすべての L3 インターフェイスを含む、NLB クラスタ サーバの仮想 IP アドレスです。

  • mac address-table static 0300.5e01.0101 vlan 200 interface は、マルチキャスト仮想 MAC アドレスのスイッチでポート マッピングにスタティック MAC エントリを作成します。

: NLB クラスタでマルチキャスト モードを使用していることを確認してください。 Cisco では、IGMP 設定との競合が確認されているため、01 で開始されるマルチキャスト MAC アドレスを使用しないことを推奨いたします。

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
mac address-table static 0300.5e01.0101 vlan 200 interface Gi1/1 Te1/49 Te1/50
!
!
end

mac address-table static 0300.5e01.0101 vlan 200 interface は、マルチキャスト仮想 MAC アドレスのスイッチ上でスタティック エントリを作成します。 スイッチ間の NLB トラフィックを伝送するトランク インターフェイスすべてを追加する必要がある点に留意することが重要です。 スタティック MAC アドレスが定義されると、フラッディングが抑制されます。 インターフェイスを含むことを忘れると、NLB クラスタが中断します。 

IGMP モードの設定

このセクションでは、IGMP モードで動作する Cisco Catalyst 6500 および 4948 シリーズのプラットフォームに NLB を設定する方法を説明しています。

6500-1#show running-config
Building configuration...
!
hostname 6500-1
!
boot system flash disk0:s2t54-adventerprisek9-mz.SPA.151-1.SY1
!
ip igmp snooping querier
!
!
vlan configuration 1,100
 no ip igmp snooping querier
!        
vlan configuration 200
ip igmp snooping querier address 10.200.1.1
!
!
interface TenGigabitEthernet1/4
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/5
 switchport
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
!
interface Vlan100
 ip address 10.100.1.1 255.255.255.0

!
!        
interface Vlan200
 ip address 10.200.1.1 255.255.255.0

!
!
arp 10.100.1.99 0100.5e01.0101 ARPA
!
!
end

この設定についての重要な項目を次に示します:

  • ip igmp snooping querier はスヌーピング クエリア機能をイネーブルにします。

  • ip igmp snooping querier address 10.200.1.1 は、NLB VLAN のスヌーピング クエリアを設定します。

  • ユーザ VLAN は interface Vlan100 です。

  • NLB クラスタの VLAN は interface Vlan200 です。 このアドレス (ip address 10.200.1.1 255.255.255.0)に Microsoft サーバのデフォルト ゲートウェイを設定することが重要です。

  • arp 10.100.1.99 0100.5e01.0101 ARPA は NLB クラスタ サーバの仮想 IP アドレスです。 スタティック ARP は VLAN の L3 インターフェイスすべてに存在する必要があります。

4948-1#show running-config
Building configuration...
!
hostname 4948-1
!
boot system bootflash:cat4500-entservices-mz.150-2.SG7
!
interface GigabitEthernet1/1
 switchport access vlan 200
!
interface TenGigabitEthernet1/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
interface TenGigabitEthernet1/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,200
 switchport mode trunk
!
end

: スタティック エントリを設定する必要はありません。IGMP スヌーピングがこのモードでこれを動的に実行するためです。 また、ダウンストリームのレイヤ 2(L2)のスイッチでこのモードの特別な設定は必要ありません。

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

マルチキャスト モードの確認

ARP のキャッシュを表示するには、show ip arp コマンドを入力してください:

6500-1#show ip arp
Protocol Address         Age (min) Hardware Addr   Type   Interface
Internet 10.100.1.99            -   0300.5e01.0101  ARPA

特定のインターフェイスまたは VLAN の特定の MAC アドレス テーブルのスタティックおよびダイナミック エントリまたは MAC アドレス テーブルのスタティックおよびダイナミック エントリを確認するには、show mac address-table static コマンドを入力してください:

6500-1#show mac address-table static add 0300.5e01.0101

vlan   mac address    type   learn    age      ports
----+---------------+-------+-----+------+-----------------
200 0300.5e01.0101   static   No       -  Te1/4 Te1/5 Te5/5
4948-1#show mac address-table static add 0300.5e01.0101

Multicast Entries
vlan    mac address     type   ports
------+---------------+-------+--------------------
200    0300.5e01.0101   static Gi1/1,Te1/49,Te1/50

IGMP モードの確認

ARP のキャッシュを表示するには、show ip arp コマンドを入力してください:

6500-1#show ip arp

Protocol Address       Age (min) Hardware Addr   Type   Interface
Internet 10.100.1.99         -   0100.5e01.0101  ARPA

アップストリームのスヌーピング クエリアから受信されるクエリーによってプログラミングされたマルチキャスト ルータ ポートを表示するには、show ip igmp snooping mrouter を入力してください:

4948-1#show ip igmp snooping mrouter

Vlan    ports
----    -----
 200   Te1/49(dynamic)

IGMP スヌーピングとメンバ ポートから学習されるダイナミック追加された MAC アドレスを確認するには、show mac address-table multicast igmp-snooping を入力してください:

4948-1#show mac address-table multicast igmp-snooping

Multicast Entries
 vlan   mac address     type    ports
------+---------------+------+-------------
 200   0100.5e01.0101  igmp Gi1/1,Te1/49

マルチキャスト グループに参加したクラスタ メンバのポート リストを確認するには、show ip igmp snooping groups を入力してください:

4948-1#show ip igmp snooping groups

Vlan      Group      Version    Port List
-----------------------------------------
200       239.1.1.1   v2         Gi1/1

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 107995