セキュリティ : Cisco ASA 5500-X シリーズ次世代型ファイアウォール

PIX/ASA 7.x: CAC - Cisco VPN Client のスマートカードの認証

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、認証に Common Access Card(CAC)を使用してネットワークのリモート アクセスに関して Cisco 適応型セキュリティ アプライアンス(ASA)を設定する例を紹介します。

この資料のスコープは適応性がある Security Device Manager (ASDM)、Cisco VPN Client および Microsoft Active Directory (AD) /Lightweight ディレクトリアクセスプロトコル(LDAP)で Cisco ASA の設定をカバーします。

このガイドの設定は Microsoft AD/LDAP サーバを使用します。 この資料はまた OCSP および LDAP アトリビュートのような進んだ機能を、マップ取り扱っています。

前提条件

要件

Cisco ASA、Cisco VPN Client、Microsoft AD/LDAP、および公開鍵インフラストラクチャ (PKI)の基本的な知識は完全なセットアップを理解して有利です。 AD 団体会員およびユーザ プロパティーとの習熟度、また認証属性と AD/LDAP オブジェクト間の許可 プロセスを関連させる LDAP オブジェクト ヘルプ。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 5500 シリーズその適応性があるセキュリティ アプライアンス モデル(ASA)は実行しますソフトウェア バージョンを 7.2(2)

  • Cisco Adaptive Security Device Manager (ASDM)バージョン 5.2(1)

  • Cisco VPN Client 4.x

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

Cisco ASA の設定

このセクションは Cisco ASA によって ASDM の設定をカバーします。 それは IPSec接続によって VPN リモートアクセストンネルを配置するために必要な ステップをカバーします。 CAC 認証は認証のために使用され、認証のユーザー プリンシパル名(UPN)アトリビュートは許可のためのアクティブ ディレクトリで読み込まれます。

導入に関する考慮事項

  • このガイドはインターフェイスのような基本設定を、DNS、NTP、ルーティング、デバイスアクセス、または ASDM アクセス、先祖などカバーしません ネットワーク オペレータはこれらの設定をよく理解しているものとします。

    詳細については、多機能セキュリティ アプライアンス モデルを参照して下さい。

  • いくつかのセクションは基本 VPN アクセスのために必要とされる必須コンフィギュレーションです。 たとえば、VPN トンネルは OCSP チェックなしで CAC カードと LDAP マッピング チェックします設定することができます。 DoD は設定される OCSP なしで、トンネル作業のチェックする OCSP 統治を委任します。

  • 必要な基本 ASA/PIX イメージが 7.2(2) および ASDM 5.2(1) ですが、このガイドは 7.2.2.10 および ASDM 5.2.2.54 の暫定ビルドを使用します。

  • LDAP スキーマ変更は必要ではないです。

  • ポリシーを強制するための LDAP およびダイナミック アクセス ポリシーのマッピングの例については、付録 A を参照してください。

  • LDAP オブジェクトを MS でチェックする方法については、付録 D を参照してください。

  • RFC のリストについては「関連情報」セクションを参照して下さい。

認証、許可、アカウンティング(AAA)設定

ユーザは自身の組織の DISA 認証局 (CA) サーバまたは CA サーバによるよくあるアクセス カード(CAC)の認証と認証されます。 証明書はネットワークへのリモート アクセス用に有効である必要があります。 認証に加えて、ユーザはまた Microsoft Active Directory または Lightweight Directory Access Protocol (LDAP) オブジェクトと許可する必要があります。 米国国防総省(DoD)は認証の認証対象代替名(SAN)セクションの一部である許可のためにユーザー プリンシパル名(UPN)アトリビュートの使用を必要とします。 UPN か EDI/PI はこの形式に– 1234567890@mil ある必要があります。 下記の設定は許可のための LDAPサーバで ASA の AAAサーバを設定する方法を示します。 LDAP の追加コンフィギュレーションについては付録 A がマッピングに反対するのを参照して下さい。

LDAP サーバの設定

次の手順に従ってください。

  1. > AAAサーバグループは設定されるリモートアクセス VPN > AAA に行きます。

  2. AAA サーバ グループ 表で、『Add』 をクリック して下さい。

  3. サーバグループ名前を入力し、Protocol オプション・ ボタンの LDAP を選択して下さい。 図 1 を参照してください。

  4. 選択したグループ表のサーバでは、『Add』 をクリック して下さい。 この表で強調表示される作成するサーバことを確かめて下さい。

  5. 編集 AAAサーバ ウィンドウで、図 2.参照して下さい。

    注: この接続のタイプに LDAP および AD が設定されている場合、[Enable LDAP over SSL] オプションを選択してください。

    1. LDAP があるインターフェイスを選択して下さい。 このガイドは内部インターフェイスを示します。

    2. サーバの IP アドレスを入力します。

    3. サーバポートを入力して下さい。 デフォルトの LDAP ポートは 389 です。

    4. サーバタイプを選択して下さい。

    5. ベース DN を入力して下さい。 これらの値は AD/LDAP 管理者に問い合わせてください。

      図 1: サーバグループを追加して下さい

      http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-1.gif

    6. スコープ オプションの下で、適切であるものはどれでも選択して下さい。 これはベース DN に依存しています。 AD/LDAP 管理者に連絡して支援を求めてください。

    7. ネーム属性フィールドでは、userPrincipalName を入力して下さい。 このアトリビュートは AD/LDAP サーバでユーザ許可のために利用します。

    8. ログイン DN フィールドでは、管理者 DN を入力して下さい。

      注: ユーザ オブジェクトおよび団体会員が含まれている管理権限か権限/検索表示するために LDAP 構造ユーザーのニーズ。

    9. ログインパスワード フィールドでは、管理者のパスワードを入力して下さい。

    10. LDAP 属性は [None] のままにします。

      図 2

      http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-2.gif

      このオプションを設定 許可のための他の AD/LDAP オブジェクトを追加するあとで使用します。

    11. [OK] をクリックします。

  6. [OK] をクリックします。

Trustpoints を管理して下さい

ASA で認証をインストールする 2 つのステップがあります。 最初に、必要な CA 証明書(ルートおよび追加の認証局)をインストールします。 2 番目に、ASA を仕様 CA に登録し、ID証明を得て下さい。 DoD PKI はこれらの認証を利用します: CA2、クラス 3 ルートを、ASA が登録される CA## 中間物、ASA ID 認証および OCSP 認証を定着させて下さい。 OCSP を使用しないために選択する場合 OCSP 認証はインストールされる必要はありません。

注: デバイスの ID証明のために登録する方法に関する原証明、また手順を得るためにセキュリティ POC に連絡して下さい。 SSL 認証はリモートアクセスの ASA のために十分である必要があります。 デュアル SAN 証明書は必要ありません

注: インストールされるクライアントのローカルマシンはまた DoD CA チェーンがなければなりません。 認証は Internet Explorer を通した Microsoft 証明書ストアで表示することができます。 DoD はマシンに自動的にすべての CA を追加するバッチファイルを生成 しました。 詳細については、お客様の PKI POC にお問い合わせください。

注: DoD CA2 およびクラス 3 は(、また ASA 認証を発行した ASA ID および通常 CA 中間物)ですユーザ認証のために必要とされる唯一の CA 定着します。 すべての電流 CA 中間物は CA2 およびクラス 3 ルート チェーンの下で CA2 およびクラス 3 ルートが追加される限り落ち、信頼されます。

キーの生成

次の手順に従ってください。

  1. リモートアクセス VPN > Certificate Management > ID証明 > Add に行って下さい。

  2. 新しい ID 認証を『Add』 を選択 し、次にキーペア オプションによって『New』 を選択 して下さい。

  3. Add 鍵ペア ウィンドウで、キー名(DoD-1024)を入力して下さい; New 鍵を追加するために無線をクリックして下さい。 図 3 を参照してください。

    図3

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-3.gif

  4. キーのサイズを選択して下さい。

  5. 一般目的に使用方法を保存して下さい。

  6. 生成する Now ボタンをクリックして下さい。

    注: DoD ルートCA 2 は 2048 ビット キーを使用します。 第 2 キーはこの CA を使用できるために 2048 ビット キーペアを使用する生成する必要があります。 第 2 キーを追加するために上記のステップに従って下さい。

CA Trustpoints をインストールして下さい

次の手順に従ってください。

  1. Configuration > Properties > Certificate > Trustpoint > Configuration の順に進んで下さい。 図 4 を参照してください。

  2. トラストポイント Name フィールドで名前を入力して下さい。

  3. 登録 Settings タブで、矢印をクリックするとき前のステップで生成されるキーを選択して下さい。 ルートCA 2 トラストポイントのための 2048 キーを選択して下さい。

  4. 登録モードセクションで、使用 手動登録をOK 選択し、適用して下さい

    図 4: 原証明をインストールして下さい

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-57.gif

    注: ステップを追加したいと思うトラストポイント毎に 1-4 繰り返して下さい。 これがデバイスのメモリに完全に基づいているのでインストールできる trustpoints の数のためのハードな数がありません。 DoD PKI はこれらのそれぞれのためにトラストポイントを必要とします: ルートCA 2、クラス 3 ルート、CA## 中間物および OCSP サーバ。 OCSP トラストポイントは OCSP を使用しない場合必要ではないです。

原証明をインストールして下さい

次の手順に従ってください。

  1. 設定 > Properties > 認証 > 認証に行って下さい。

  2. トラストポイント Name フィールドで、前の手順で設定されるトラストポイントを選択して下さい。

  3. 認証テキスト セクションでは、ファイルの認証をインポートするか、または base64 によって符号化されるテキストをカット アンド ペーストして下さい(コントロール C および V)。

    注: インポートはこのコードのバージョンの .txt ファイルだけを受け入れますが、CA 管理者から受け取るファイルは .cer 形式にあります。 また .txt に拡張を変更でき、ファイルを開くためにそしてテキストボックスのテキストをカット アンド ペーストして下さい。

    図 5: CA の認証

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-58.gif

  4. [Authenticate] をクリックします。

ASA の登録と ID 証明書のインストール

次の手順に従ってください。

  1. 設定 > Properties > 認証 > 登録に行って下さい。

  2. トラストポイントを選択して下さい。 ASA デバイスを登録することを望む中間トラストポイントを選択するためにオプション ボタンの下 矢印をクリックして下さい。

  3. [Edit] ボタンをクリックします。

  4. 編集トラストポイントの設定 ウィンドウで、パラメータを『Certificate』 をクリック して下さい。

  5. 認証 パラメータ ウィンドウで、使用をどれも FQDN のためのオプション選択しないし、サブジェクト DN で『Edit』 をクリック して下さい。 図 6.参照して下さい。

    図 6: ID 証明書パラメータ

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-7.gif

  6. [Certificate Subject DN] ウィンドウで、デバイスの情報を入力します。 例については図 7 参照して下さい。

  7. [OK] をクリックします。

    図 7: DN の編集

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-8.gif

    注: サブジェクト DN を追加するときは、システム内で設定されているデバイスのホスト名を使用するようにします。 PKI POC は必要となる Mandatory フィールドを告げることができます。

  8. 認証 パラメータ ウィンドウで『OK』 をクリック し、編集トラストポイントの設定 ウィンドウで『OK』 をクリック して下さい。

  9. 登録ウィンドウで、『Enroll』 をクリック して下さい。

  10. 登録要求 ウィンドウからの情報をカット アンド ペーストして下さい; それを Notepad に保存し、『OK』 をクリック して下さい。 ASA のために ID証明を要求するために CA 管理者に送信 される必要があるこれは情報です。 図 8 を参照してください。

    図 8: 証明書要求

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-10.gif

  11. CA 管理者から認証を受け取ったら、設定 > Properties > 認証 > 輸入 証明書に行って下さい。

  12. 輸入 証明書 ウィンドウで、ASA デバイスを登録したトラストポイントを選択して下さい。

  13. 認証テキストでは、CA 管理者から受け取ったファイルをインポートするか、または base64 をか DER によって符号化されるファイルをカット アンド ペーストして下さい。 図 9.参照して下さい。

    図 9: 認証をインポートして下さい

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-59.gif

    注: インポートはこのコードのバージョンの .txt ファイルだけを受け入れますが、CA 管理者から受け取るファイルは .cer 形式にあります。 また .txt に拡張を変更できファイルを開き、次にテキストボックスのテキストをカット アンド ペーストします。

  14. 『Import』 を選択 して下さい。

    注: フラッシュ メモリの設定を保存するために SAVE ボタンをクリックして下さい。

VPN の設定

これは別の方式を使用すれば DHCP のようなオプション、です。

  1. > IPアドレス管理 > IP プール Configuration > VPN の順に進んで下さい。

  2. [Add] をクリックします。

  3. 追加 IPプール ウィンドウで、IP アドレスを開始し、終了する IPプールの名前を入力しサブネット マスクを選択して下さい。 図 10.参照して下さい。

    図 10: IPプールを追加して下さい

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-13.gif

  4. [OK] をクリックします。

  5. > IPアドレス管理 > 割り当て Configuration > VPN の順に進んで下さい。

  6. 適切な IP アドレス 割り当て 方式を選択して下さい。 このガイドでは、内部アドレス プールを使用します。 図 11 を参照してください。

    図 11: IP アドレス割り当て方法

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-12.gif

  7. [Apply] をクリックします。

トンネル グループおよびグループ ポリシーの作成

注: トンネル グループを作成し、ポリシーをグループ化する前に、> 全般 > VPN システムオプション Configuration > VPN の順に進み、ボックスがイネーブル インバウンドIPSec…オプションがあるように確認されることを確かめて下さい。

グループ ポリシー

注: 新しいポリシーを作成したいと思わない場合グループ ポリシーで構築されるデフォルトを使用できます。

  1. Configuration > VPN > General > Group Policy の順に進んで下さい。

  2. [Add] をクリックして、[Internal Group Policy] を選択します。

  3. [Add Internal Group Policy] ウィンドウで、[Name] テキスト ボックスにグループ ポリシーの名前を入力します。 図 12 参照して下さい。

    図 12: 内部グループ ポリシーを追加して下さい

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-60.gif

    1. General タブで、トンネリング プロトコル オプションの IPsec を選択して下さい。

    2. [Servers] セクションで、[inherit] チェック ボックスのチェックを外し、DNS サーバおよび WINS サーバの IP アドレスを入力します。 DHCP スコープを、該当する場合入力して下さい。

    3. IPSec タブでは、デフォルト設定にそれらをすべて残して下さい: 受継いで下さい。 適切な変更を、必要ならば行なって下さい。

    4. Client Configuration タブでは、全般クライアント パラメータで、デフォルト ドメインの受継チェックボックスのチェックを外し、適切なドメイン名を入力して下さい。

    5. Client Configuration タブでは、全般クライアント パラメータで、アドレス プール セクションの受継チェックボックスのチェックを外し、前のステップで作成されるアドレス プールを追加して下さい。 アドレス プールの名前をクリックし、次に『Add』 をクリック して下さい。 IP アドレス 割り当ての別の方式を使用する場合、これをように受継ぎます残し、適切な変更を行なって下さい。

    6. 他の Configuration タブはすべてデフォルト設定で残っています。

  4. [OK] をクリックします。

トンネル グループ インターフェイスおよびイメージの設定

注: 新しいグループを作成しない場合、デフォルトの組み込みグループを使用できます。

  1. Configuration > VPN > General > Tunnel Group の順に進んで下さい。 図 13 を参照してください。

    図 13: トンネル グループを追加して下さい

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-61.gif

    注: ASDM は認証のためのオプションで自動的にどれも選択されない場合ローカルを設定します。 メッセージが時この設定の終わりに良く見つかるが表示されます。

    ERROR: The authentication-server-group none command has been
    			 deprecated. 

    注: どれも ipsec 属性で命じない isakmp ikev1-user-authentication は代りに使用する必要があります。 どれもに認証モードを設定 しない で下さい。 図 14 参照して下さい。

  2. リモートアクセスのために『Add』 をクリック し、『IPSec』 を選択 して下さい。

  3. 追加 Profile ウィンドウでは、ネーム テキストボックスでトンネル グループの名前を入力して下さい。

  4. 追加 Tunnel Group ウィンドウで、General タブを > 基本的なタブ選択し、前のステップで作成されるグループ ポリシーを選択して下さい。

  5. Authentication タブをクリックし、省略時 の オプションですべてを残して下さい。

  6. 追加 Tunnel Group ウィンドウで、IPSec タブをクリックして下さい。

    図 14: IPSec 認証 モード

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-62.gif

  7. トラストポイント名前オプションで、前のセクションで作成されるトラストポイントを選択して下さい。

  8. 上記のメモに言及されているようにどれもに認証モードを設定 しない で下さい。 図 14 参照して下さい。

  9. [OK] をクリックします。

  10. 許可タブをクリックして下さい。 許可 サーバグループで、より早いステップで作成される LDAPサーバ グループを選択しユーザがあるようにボックスを許可 データベースで接続するために存在 しなければなりません確認して下さい。

    図 15: UPN 設定

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-63.gif

  11. セカンダリ DN フィールドのプライマリ DN フィールドおよびどれもUPN を選択しないで下さい。 図 15 参照して下さい。

  12. [OK] をクリックします。

注: フラッシュ メモリの設定を保存するために SAVE ボタンをクリックして下さい。

IKE/ISAKMP パラメータを設定して下さい

次の手順に従ってください。

  1. > IKE > グローバル な パラメータ Configuration > VPN の順に進んで下さい。

  2. イネーブル IKE セクションでは、outside インターフェイスが Enabled カラムで YES を示すことを確かめて下さい。 そうでなかったら、outside インターフェイスを強調表示し、『Enable』 をクリック し、デフォルトとして他のすべてを残して下さい。

  3. 設定 > IKE > ポリシーに行って下さい。

  4. [Add] をクリックします。 プライオリティ番号のための 10 を入力して下さい、暗号化のためのトリプル DES、ハッシュのための sha、認証のための rsa-sig、および DH グループのための 2 つを選択して下さい; デフォルトでライフタイムを残して下さい。 例については図 16 参照して下さい。

  5. [OK] をクリックします。

    図 16: IKE/ISAKMP ポリシーを追加して下さい

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-19.gif

    注: もし必要なら複数の IKE/ISAKMP ポリシーを追加できます。

  6. > 一致する IKE > 認証 グループ > ポリシー Configuration > VPN の順に進んで下さい。 図 17 参照して下さい。

  7. ポリシー セクションでは、使用を除いてすべてのチェックボックスのグループに認証を一致させる設定されたルール チェックを外して下さい。

  8. > 一致する IKE > 認証 グループ > ルール Configuration > VPN の順に進んで下さい。

  9. 上表で『Add』 をクリック して下さい。

    図 17: ポリシーと一致する認証 グループ

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-64.gif

  10. 追加認証一致規則ウィンドウで、これらの手順に従って下さい:

    1. マップ セクションで既存のマップ DefaultCertificateMap を保存して下さい。

    2. ルール優先順位として 10 を保存して下さい。

    3. マッピング された グループの下で、オプション ボタンをクリックするときより早いセクションで作成されるトンネル グループを選択して下さい。 図 18 を参照してください。

    4. [OK] をクリックします。

      図 18: 認証一致規則を追加して下さい

      http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-21.gif

  11. 下の表にある [Add] をクリックします。

  12. ウィンドウ追加認証一致規則基準のでは、これらの手順に従って下さい:

    図 19: 証明書の照合ルールの基準

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-22.gif

    1. 服従するためにフィールド列セットを保存して下さい。

    2. Component カラムを全フィールドに設定 しておいて下さい。

    3. [Operator] カラムを [Does Not Equal] に変更します。

    4. Value 列では、2 つの二重引用符を入力して下さい(「」)。

    5. [OK]、[Apply] の順にクリックします。 例については図 19 参照して下さい。

IPSecパラメータを設定して下さい

次の手順に従ってください。

  1. > IPSec > IPSec ルール Configuration > VPN の順に進んで下さい。

  2. [Add] をクリックします。

  3. 作成 IPSec ルール ウィンドウで、基本的なタブで、これらの手順に従って下さい:

    1. インターフェイスのために『outside』 を選択 して下さい。

    2. ポリシーの種類のためのダイナミックを選択して下さい。

    3. プライオリティ番号を入力して下さい。

    4. transform-set を選択し、『Add』 をクリック して下さい。 このガイドは ESP-AES-256-SHA を使用します。 もし必要なら多重 transform-set を追加できます。

  4. トラフィック選択タブをクリックして下さい。

  5. インターフェイスおよび処理 セクションで、インターフェイスのために『outside』 を選択 し、処理のために保護して下さい

  6. ソース セクションで、選択して下さい。

  7. 宛先 セクションで、プールによって作成されるより早い orany の IP アドレスを選択して下さい。

  8. [OK] をクリックします。

  9. [Apply] をクリックします。

    図 20: IPSec ルールを追加して下さい

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-65.gif

OCSP の設定

OCSP レスポンダ証明書の設定

OCSP 設定は OCSP 応答側 ベンダーに依存を変えることができます。 詳細についてはベンダーの手動を読んで下さい。

  1. OCSP レスポンダから自己生成された証明書を取得します。

  2. 以前に述べられる手順に従い、OCSP サーバのための認証をインストールして下さい。

    注: 失効チェックがどれもに設定 されないことを確かめて下さい。 OCSP チェックは実際の OCSP サーバで起こる必要はありません。

OCSP を使用するための CA の設定

次の手順に従ってください。

  1. Configuration > Properties > Certificate > Trustpoint > Configuration の順に進んで下さい。

  2. 表でそれを強調表示するとき OCSP を使用するために設定するように CA を選択して下さい。

  3. [Edit] をクリックします。

  4. 失効チェック タブをクリックし、失効方式の OCSP を強調表示し、それから『Add』 をクリック して下さい。 [Revocation Methods] セクションで、OCSP を追加します。 図 21 を参照してください。

  5. 厳密な OCSP チェックに続きたいと思う場合考慮認証 有効なが…チェックを外される取得することができないようにして下さい。

    図 21: OCSP 失効チェック

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-66.gif

    注: 失効のために OCSP を使用するすべての CA サーバを設定して下さい/編集して下さい。

  6. これらのタブにすべての省略時 の オプションを残して下さい: CRL 検索ポリシー、CRL 検索方式および OCSP ルール。

  7. [Advanced] タブをクリックします。

    1. CRL オプションの実施次の CRL アップデートのチェックを外して下さい。

    2. ディセーブル 臨時 拡張をチェックを外される残して下さい。

    3. すべてのその他のオプションをチェックされる残して下さい。

  8. [OK] をクリックします。

OCSP ルールの設定

注: これらの手順に従う前にポリシーと一致する認証 グループが作成される OCSP 応答側が設定されることを確認すれば。

注: すべての CA が OCSP サーバを除いて OCSP ルール自体で設定されることを確かめて下さい。

注:  いくつかの OCSP 実装では、DNS および PTR レコードは ASA のために必要です。 このチェックは ASA が .mil サイトからあることを確認するためにされます。

  1. Configuration > Properties > Certificate > Trustpoint > Configuration の順に進んで下さい。

  2. 表でそれを強調表示するとき OCSP を使用するために設定するようにトラストポイントを選択して下さい。

  3. [Edit] をクリックします。

  4. [OCSP Rule] タブをクリックします。

  5. [Add] をクリックします。

  6. 追加 OCSP ルール ウィンドウで、これらの手順に従って下さい: 図 22 参照して下さい。

    図 22: OCSP ルールを追加して下さい

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-25.gif

    1. 認証 マップ オプションで、IKE/ISAKMP パラメータ セクションで作成されるマップを選択して下さい: DefaultCertificateMap

    2. 認証 オプションで、OCSP 応答側を選択して下さい。

    3. [Index] オプションに、10 と入力します。

    4. [URL] オプションに、OCSP レスポンダの IP アドレスまたはホスト名を入力します。 ホスト名を使用する場合、DNSサーバが ASA で設定されることを確かめて下さい。)

    5. [OK] をクリックします。

    6. [Apply] をクリックします。

Cisco VPN Client の設定

このセクションは Cisco VPN Client の設定をカバーします。

前提条件: Cisco VPN Client およびミドルウェア アプリケーションはホスト PC に既にインストールされています。 Cisco VPN Client はこれらのミドルウェア アプリケーションをサポートします: GemPLUS (GemSAFE ワークステーション 2.0 またはそれ以降leavingcisco.com )、Activcard (Activcard 金バージョン 2.0.1 または それ 以降leavingcisco.com )、および Aladdin (ランタイム環境(RTE)バージョン 2.6 または それ 以降を eTokenleavingcisco.com )。

Cisco VPN Client を開始して下さい

ホスト PC から、Start > Programs > Cisco Systems VPN Client > VPN Client の順にクリック して下さい。

新規接続

次の手順に従ってください。

  1. エントリを『Connection』 をクリック して下さい。

  2. VPN サーバの接続および IP アドレス または ホスト名の説明を『New』 をクリック し、次に入力して下さい。 図 23 参照して下さい。

  3. Authentication タブの下で、『Certificate Authentication』 を選択 して下さい。

  4. ネーム オプションで、シグニチャ 認証を選択し、送信 CA 認証 チェーンをチェックして下さい。 (通常失敗した場合選択された作業である、認証を他の試みることができますデフォルト認証。)

  5. [Save] をクリックします。

    図 23: 新しい VPN 接続を作成して下さい

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-26.gif

リモート アクセスの開始

次の手順に従ってください。

  1. 前の手順で作成されるエントリをダブルクリックして下さい。

  2. ピンナンバーを入力して下さい。

  3. [OK] をクリックします。

付録 A – LDAP マッピング

ASA/PIX を使うと 7.1(x) を、LDAP マッピングと呼ばれる機能導入されましたリリースして下さい。 これは Cisco 属性と LDAP オブジェクトまたは属性の間のマッピングを提供する高度な機能で、LDAP スキーマ変更が不要になります。 CAC 認証を実装する場合、これはリモート アクセス接続への追加のポリシー適用をサポートすることができます。 LDAP マッピングの例は下記にあります。 AD/LDAP サーバの変更を行なう管理者権限を必要とすることに注意して下さい。

シナリオ 1: リモートアクセス許可 ダイヤルインとのアクティブ ディレクトリ適用–割り当て/拒否アクセス

この例は Cisco アトリビュート cVPN3000-Tunneling-Protocol に AD アトリビュート msNPAllowDailin をマッピング します。

  • AD 属性の値: TRUE = 許可、 FALSE = 拒否

  • Cisco 属性値: 1 = 偽、4 (IPSec)または 20 (4 IPSec + 16 WebVPN) = TRUE

割り当て状態に関しては、マッピング します

  • TRUE = 20

拒否ダイヤルイン状態に関しては、マッピング します

  • FALSE = 1

注: TRUE および FALSE はすべて大文字です。 Cisco 属性に関する詳細については、セキュリティ アプライアンス モデル ユーザ許可のための外部サーバの設定を参照して下さい。

Active Directory の設定

次の手順に従ってください。

  1. Active Directory サーバで、[Start] > [Run] をクリックします。

  2. 開いたテキストボックスでは、型 dsa.msc はそれから『OK』 をクリック し これで Active Directory 管理コンソールが起動します。

  3. アクティブ ディレクトリ マネジメントコンソールで、Active Directory Users and Computers を拡張するプラス記号をクリックして下さい。

  4. ドメイン名を拡張するプラス記号をクリックして下さい。

  5. ユーザ向けに作成される OU がある場合すべてのユーザを表示するために OU を拡張して下さい; ユーザ フォルダですべてのユーザに割り当ててもらう場合、それらを表示するためにそのフォルダを開いて下さい。 図 A1 を参照してください。

    図 A1: Active Directory 管理コンソール

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-40.gif

  6. 編集したいと思うユーザをダブルクリックして下さい。

    ユーザ プロパティー ページの Dial-in タブをクリックし、割り当てるか、または否定しますクリックして下さい。 図 A2 を参照してください。

    図 A2: ユーザのプロパティ

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-41.gif

  7. [OK] をクリックします。

ASA の設定

次の手順に従ってください。

  1. ASDM では、マップは設定 > Properties > AAA > LDAP アトリビュートに行きます。

  2. [Add] をクリックします。

  3. 追加 LDAP アトリビュート Map ウィンドウでは、これらの指示に従って下さい: 図 A3 を参照してください。

    図 A3 LDAP アトリビュート マップを追加して下さい

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-42.gif

    1. 名のテキスト ボックスで名前を入力して下さい。

    2. マップネーム タブでは、顧客名 テキストボックスの msNPAllowDialin を入力して下さい。

    3. マップネーム タブで、Cisco 名前のドロップダウン オプションのトンネリング プロトコルを選択して下さい。

    4. [Add] をクリックします。

    5. [Map Value] タブをクリックします。

    6. [Add] をクリックします。

    7. 追加では顧客名 テキストボックスの LDAP Map 値 ウィンドウ、タイプ TRUE、および Cisco 値 テキストボックスのタイプ 20 を帰因させて下さい。

    8. [Add] をクリックします。

    9. 顧客名 テキストボックスの、および Cisco 値 テキストボックスのタイプ 1 をタイプして下さい。 図 A4 を参照してください。

      http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-43.gif

    10. [OK] をクリックします。

    11. [OK] をクリックします。

    12. [APPLY] をクリックします。

    13. 図 A5 のように設定見え。

      図 A5: LDAP 属性マップの設定

      http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-67.gif

  4. Configuration > Properties > AAA Setup > AAA Server Groups の順に進んで下さい。 図 A6 を参照してください。

    図 A6: AAA サーバ グループ

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-68.gif

  5. 編集したいと思うサーバグループをクリックして下さい。 選択したグループ セクションのサーバでは、サーバのIPアドレスホスト名を選択し、次に『Edit』 をクリック して下さい。

  6. で AAAサーバ ウィンドウを、LDAP アトリビュート マップ テキストボックスで、選択しますドロップダウン ボタンで作成される LDAP アトリビュート マップを編集して下さい。 図 A7 を参照して下さい。

    図 A7: LDAP アトリビュート マップを追加して下さい

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-46.gif

  7. [OK] をクリックします。

注: 確認するためにきちんとマッピング して いるかどうか LDAP バインディングおよびアトリビュート作業をテストする間、LDAP デバッグをつけて下さい。 トラブルシューティング コマンドについては付録 C を参照してください。

シナリオ 2: 割り当てるべき団体会員/拒否アクセスのアクティブ ディレクトリ適用

この例は LDAP アトリビュート memberOf を状態として団体会員を確立するために Cisco トンネリング プロトコル アトリビュートにマッピング するのに使用します。 このポリシーを機能させるには、次の条件が必要です。

  • 現存するグループを使用するか、または割り当て状態の ASA VPN ユーザ向けの新しいグループを作成して下さい。

  • 現存するグループを使用するか、または拒否状態の非 ASA ユーザ向けの新しいグループを作成して下さい。

  • グループのための正しい DN があること LDAP ビューアをチェックインすることを確かめて下さい。 詳細は、「付録 D」を参照してください。 DN が正しくない場合、マッピングは正しく動作しません。

注: ASA がこのリリースの memberOf アトリビュートの一線級選手しか読まないことができることに注意して下さい。 作成される新しいグループがリストの上にあることを確かめて下さい。 その他のオプションはので特殊文字の AD 外観最初に名前の前の特殊文字を置くことです。 この警告を回避するために、複数のグループを検知 するのに 8.x ソフトウェアで DAP を使用して下さい。

注: memberOf が ASA に常に送返されるようにユーザが拒否グループまたは少なくとも 1 他のグループの一部であることを確かめて下さい。 偽拒否状態を規定 する必要がありませんが最良 の 方法はそうすることです。 現存するグループ名はか新しいグループ名が領域がはいっている場合、アトリビュートをこのように入力して下さい: 「CN=Backup オペレータ、CN=Builtin、DC=ggsgseclab、DC=org」。

マッピング

  • AD 属性値

    • memberOf CN=ASAUsers,CN=Users,DC=ggsgseclab,DC=org

    • memberOf CN=TelnetClients,CN=Users,DC=labrat,DC=com

  • Cisco 属性の値: 1 = 偽、20 = TRUE

割り当て状態に関しては、マップ

  • memberOf CN=ASAUsers,CN=Users,DC=ggsgseclab,DC=org= 20

拒否状態に関しては、マップ

  • memberOf CN=TelnetClients,CN=Users,DC=ggsgseclab,DC=org = 1

注: 将来のリリースでは、接続を許可し、否定する Cisco アトリビュートがあります。 Cisco アトリビュートに関する詳細については、セキュリティ アプライアンス モデル ユーザ許可のための外部サーバの設定を参照して下さい。

Active Directory の設定

次の手順に従ってください。

  1. Active Directory サーバで、[Start] > [Run] をクリックします。

  2. 開いたテキストボックスでは、dsa.msc を入力し、『OK』 をクリック して下さい これで Active Directory 管理コンソールが起動します。

  3. アクティブ ディレクトリ マネジメントコンソールで、Active Directory Users and Computers を拡張するプラス記号をクリックして下さい。 図 A8 を参照して下さい。

    図 A8 Active Directory グループ

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-47.gif

  4. ドメイン名を拡張するプラス記号をクリックして下さい。

  5. ユーザ フォルダを右クリックし、> グループ 『New』 を選択 して下さい。

  6. グループ名を、入力して下さいたとえば: ASAUsers。

  7. [OK] をクリックします。

  8. ユーザ フォルダをクリックし、次にちょうど作成したグループをダブルクリックして下さい。

  9. Members タブをクリックし、次に『Add』 をクリック して下さい。

  10. 追加したいと思うユーザの名前を入力し次に『OK』 をクリック して下さい。

ASA の設定

次の手順に従ってください。

  1. ASDM では、マップは設定 > Properties > AAA > LDAP アトリビュートに行きます。

  2. [Add] をクリックします。

  3. 追加 LDAP アトリビュート Map ウィンドウでは、これらの指示に従って下さい: 図 A9 を参照して下さい。

    1. 名のテキスト ボックスで名前を入力して下さい。

    2. マップネーム タブでは、顧客名 テキストボックス c.の memberOf を入力して下さい。

    3. マップネーム タブで、Cisco 名前のドロップダウン オプションのトンネリング プロトコルを選択して下さい。

    4. [Add] をクリックします。

    5. [Map Value] タブをクリックします。

    6. [Add] をクリックします。

    7. 追加では LDAP Map 値 ウィンドウを、タイプ CN=ASAUsers、CN=Users、DC=ggsgseclab、Cisco 値 テキストボックスの顧客名 テキストボックスおよびタイプ 20DC=org 帰因させて下さい。

    8. [Add] をクリックします。

    9. CN=TelnetClients を、CN=Users、DC=ggsgseclab、Cisco 値 テキストボックスの顧客名 テキストボックスおよびタイプ 1 の DC=org タイプして下さい。 図 A9 を参照して下さい。

    10. [OK] をクリックします。

    11. [OK] をクリックします。

    12. [Apply] をクリックします。

    13. 図 A9 のように設定見え。

      図 A9: LDAP アトリビュート マップ

      http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-55.gif

  4. Configuration > Properties > AAA Setup > AAA Server Groups の順に進んで下さい。

  5. 編集したいと思うサーバグループをクリックして下さい。 選択したグループ セクションのサーバでは、サーバのIPアドレスホスト名を選択し、次に『Edit』 をクリック して下さい。

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-49.gif

  6. で AAAサーバ ウィンドウを、LDAP アトリビュート マップ テキストボックスで、選択しますドロップダウン ボタンで作成される LDAP アトリビュート マップを編集して下さい。

  7. [OK] をクリックします。

注: LDAP バインディングおよびアトリビュート マッピングはきちんとはたらくことを確認するためにテストする間、LDAP デバッグをつけて下さい。 トラブルシューティング コマンドについては付録 C を参照してください。

付録 B:ASA CLI 設定

ASA 5510
ciscoasa#show running-config
ASA Version 7.2(2)10
!
hostname lab-asa
domain-name lab.army.mil
names
dns-guard
!
interface GigabitEthernet0/0
nameif outside
security-level 0
ip address 172.18.120.224 255.255.255.128
!
interface GigabitEthernet0/1
nameif inside
security-level 100
ip address 10.10.10.1 255.255.255.0
!
boot system disk0:/asa722-10-k8.bin
ftp mode passive
dns server-group DefaultDNS
domain-name lab.army.mil
--------------ACL's-------------------------------------------------
access-list out extended permit ip any any
--------------------------------------------------------------------
---------------VPN Pool---------------------------------------------
ip local pool CAC-USERS 192.168.1.1-192.168.1.254 mask 255.255.255.0
--------------------------------------------------------------------
icmp unreachable rate-limit 1 burst-size 1
icmp permit any outside
asdm image disk0:/asdm522-54.bin
no asdm history enable
arp timeout 14400
access-group out in interface outside
route outside 0.0.0.0 0.0.0.0 172.18.120.129 1
!
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
--------------------------LDAP Maps ---------------------------
ldap attribute-map memberOf
map-name memberOf cVPN3000-Tunneling-Protocols
map-value memberOf CN=ASAUsers,CN=Users,DC=ggsgseclab,DC=org 20
map-value memberOf CN=TelnetClinets,CN=Users,DC=ggsgseclab,DC=org 1
ldap attribute-map msNPAllowDialin
map-name msNPAllowDialin cVPN3000-Tunneling-Protocols
map-value msNPAllowDialin FALSE 1
map-value msNPAllowDialin TRUE 20
--------------------------------------------------------------------
--------------------LDAP Server-------------------------------------
aaa-server AD-LDAP protocol ldap
aaa-server AD-LDAP (outside) host 172.18.120.160
ldap-base-dn CN=Users,DC=ggsgseclab,DC=org
ldap-scope onelevel
ldap-naming-attribute userPrincipalName
ldap-login-password *
ldap-login-dn CN=Administrator,CN=Users,DC=ggsgseclab,DC=org
-----------------------VPN Policy------------------------------------
group-policy CAC-USERS internal
group-policy CAC-USERS attributes
vpn-tunnel-protocol IPSec
address-pools value CAC-USERS
--------------------------------------------------------------------
!
---------------------IPsec------------------------------------------
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto dynamic-map outside_dyn_map 1 set transform-set 
   ESP-DES-SHA ESP-3DES-MD5 ESP-AES-192-SHA ESP-AES-256-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
--------------------------------------------------------------------
----------------CA Trustpoints--------------------------------------
crypto ca trustpoint CA-13-JITC
revocation-check ocsp
enrollment terminal
fqdn none
subject-name CN=lab-asa,OU=PKI,OU=DoD,O=U.S. Government,C=US
keypair DoD-1024
match certificate DefaultCertificateMap override 
   ocsp trustpoint DISA-OCSP 10 url http://ocsp.disa.mil
crl configure
no enforcenextupdate
crypto ca trustpoint Class3Root
revocation-check ocsp
enrollment terminal
keypair DoD-1024
match certificate DefaultCertificateMap override 
   ocsp trustpoint DISA-OCSP 10 url http://ocsp.disa.mil
crl configure
no enforcenextupdate
crypto ca trustpoint DoD-CA2
revocation-check ocsp
enrollment terminal
keypair DoD-2048
match certificate DefaultCertificateMap override 
   ocsp trustpoint DISA-OCSP 10 url http://ocsp.disa.mil
crl configure
no enforcenextupdate
crypto ca trustpoint DISA-OCSP
enrollment terminal
keypair DoD-1024
crl configure
no enforcenextupdate
--------------------------------------------------------------------
-------------------Certificate Map-------------------------------
crypto ca certificate map DefaultCertificateMap 10
subject-name ne ""
--------------------CA Certificates (Partial Cert is Shown)------------
crypto ca certificate chain CA-13-JITC
certificate 311d
308203fd 30820366 a0030201 02020231 1d300d06 092a8648 86f70d01 01050500
305c310b 30090603 55040613 02555331 18301606 0355040a 130f552e 532e2047
6f766572 6e6d656e 74310c30 0a060355 040b1303 446f4431 0c300a06 0355040b
certificate ca 37
3082044c 30820334 a0030201 02020137 300d0609 2a864886 f70d0101 05050030
60310b30 09060355 04061302 55533118 30160603 55040a13 0f552e53 2e20476f
crypto ca certificate chain Class3Root
certificate ca 04
30820267 308201d0 a0030201 02020104 300d0609 2a864886 f70d0101 05050030
61310b30 09060355 04061302 55533118 30160603 55040a13 0f552e53 2e20476f
crypto ca certificate chain DoD-CA2
certificate ca 05
30820370 30820258 a0030201 02020105 300d0609 2a864886 f70d0101 05050030
5b310b30 09060355 04061302 55533118 30160603 55040a13 0f552e53 2e20476f
c3ad60a4
crypto ca certificate chain DISA-OCSP
certificate ca 00
30820219 30820182 a0030201 02020100 300d0609 2a864886 f70d0101 05050030
3a310b30 09060355 04061302 7573310d 300b0603 55040a13 0441726d 79310d30
-------------------------ISAKMP-------------------------------------
crypto isakmp enable outside
crypto isakmp policy 10
authentication rsa-sig
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp nat-traversal 20
-----------------------VPN Group/Tunnel Policy--------------------
tunnel-group CAC-USERS type ipsec-ra
tunnel-group CAC-USERS general-attributes
authorization-server-group AD-LDAP
default-group-policy CAC-USERS
authorization-required
authorization-dn-attributes UPN
tunnel-group CAC-USERS ipsec-attributes
trust-point CA-13-JITC
isakmp ikev1-user-authentication none
tunnel-group-map enable rules
no tunnel-group-map enable ou
no tunnel-group-map enable ike-id
no tunnel-group-map enable peer-ip
tunnel-group-map DefaultCertificateMap 10 CAC-USERS
no vpn-addr-assign aaa
no vpn-addr-assign dhcp
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map global_policy
class inspection_default
inspect ftp
inspect h323 h225
inspect h323 ras
inspect netbios
inspect rsh
inspect rtsp
!
service-policy global_policy global
prompt hostname context

付録 C:トラブルシューティング

AAA および LDAP のトラブルシューティング

  • デバッグ LDAP 255 – LDAP 交換を表示する

  • デバッグ AAA 公有地 10 – AAA 交換を表示する

例 1: 正しい属性マッピングによる接続の許可

下記の例は付録 A で示されているシナリオ 2 の接続の成功の内でよくあるデバッグ LDAP およびデバッグ AAA の出力を示します

注: トンネリング グループは IPSec接続だけ可能にするために設定されます。 LDAP のメンバー グループ化は/割り当て IPSec である 4 という値にマッピング されます。 このマッピングはそれに割り当て状態を与えるものがです。 拒否状態に関しては、その値は PPTP のための 1 です。

図 C1: debug LDAP および debug aaa common の出力:正しいマッピング
AAA API: In aaa_open
AAA session opened: handle = 39
AAA API: In aaa_process_async
aaa_process_async: sending AAA_MSG_PROCESS
AAA task: aaa_process_msg(1a87a64) received message type 0
AAA FSM: In AAA_StartAAATransaction
AAA FSM: In AAA_InitTransaction

Initiating authorization query (Svr Grp: AD-LDAP)
------------------------------------------------
AAA FSM: In AAA_BindServer
AAA_BindServer: Using server: 172.18.120.160
AAA FSM: In AAA_SendMsg
User: 1234567890@mil
Pasw: 1234567890@mil
Resp:
[78] Session Start
[78] New request Session, context 0x26f1c44, reqType = 0
[78] Fiber started
[78] Creating LDAP context with uri=ldap:// 172.18.120.160:389
[78] Binding as administrator
[78] Performing Simple authentication for Administrator to 172.18.120.160
[78] Connect to LDAP server: ldap:// 172.18.120.160, status = Successful
[78] LDAP Search:
     Base DN = [CN=Users,DC=ggsgseclab,DC=org]
     Filter = [userPrincipalName=1234567890@mil]
     Scope = [SUBTREE]
[78] Retrieved Attributes:
[78] objectClass: value = top
[78] objectClass: value = person
[78] objectClass: value = organizationalPerson
[78] objectClass: value = user
[78] cn: value = Ethan Hunt
[78] sn: value = Hunt
[78] userCertificate: value = 0..50........../........60...*.
H........0@1.0.....&...,d....com1.0.....&...,d...
[78] userCertificate: value = 0..'0........../..t.....50...*.
H........0@1.0.....&...,d....com1.0.....&...,d...
[78] givenName: value = Ethan
[78] distinguishedName: value = CN=Ethan Hunt,OU=MIL,DC=labrat,DC=com
[78] instanceType: value = 4
[78] whenCreated: value = 20060613151033.0Z
[78] whenChanged: value = 20060622185924.0Z
[78] displayName: value = Ethan Hunt
[78] uSNCreated: value = 14050 
[78] memberOf: value = CN=ASAUsers,CN=Users,DC=ggsgseclab,DC=org
[78] mapped to cVPN3000-Tunneling-Protocols: value = 20
[78] uSNChanged: value = 14855
[78] name: value = Ethan Hunt
[78] objectGUID: value = ..9...NJ..GU..z.
[78] userAccountControl: value = 66048
[78] badPwdCount: value = 0
[78] codePage: value = 0
[78] countryCode: value = 0
[78] badPasswordTime: value = 127954717631875000
[78] lastLogoff: value = 0
[78] lastLogon: value = 127954849209218750
[78] pwdLastSet: value = 127946850340781250
[78] primaryGroupID: value = 513
[78] objectSid: value = ................q......mY...
[78] accountExpires: value = 9223372036854775807
[78] logonCount: value = 25
[78] sAMAccountName: value = 1234567890
[78] sAMAccountType: value = 805306368
[78] userPrincipalName: value = 1234567890@mil
[78] objectCategory: value =
[78] mail: value = Ethan.Hunt@labrat.com
callback_aaa_task: status = 1, msg =
AAA FSM: In aaa_backend_callback
aaa_backend_callback: Handle = 39, pAcb = 2ae115c
[78] Fiber exit Tx=147 bytes Rx=4821 bytes, status=1
[78] Session End
AAA task: aaa_process_msg(1a87a64) received message type 1
AAA FSM: In AAA_ProcSvrResp
Back End response:
------------------
Authorization Status: 1 (ACCEPT)
AAA FSM: In AAA_NextFunction
AAA_NextFunction: i_fsm_state = IFSM_AUTHORIZE, auth_status = ACCEPT
AAA_NextFunction: authen svr = <none>, author svr = AD-LDAP, 
user pol = , tunn pol = CAC-USERS
AAA_NextFunction: New i_fsm_state = IFSM_TUNN_GRP_POLICY,
AAA FSM: In AAA_InitTransaction
aaai_policy_name_to_server_id(CAC-USERS)
Got server ID 0 for group policy DB
Initiating tunnel group policy lookup (Svr Grp: GROUP_POLICY_DB)
------------------------------------------------
AAA FSM: In AAA_BindServer
AAA_BindServer: Using server: <Internal Server>
AAA FSM: In AAA_SendMsg
User: CAC-USER
Pasw:
Resp:
grp_policy_ioctl(12f1b20, 114698, 1a870b4)
grp_policy_ioctl: Looking up CAC-USERS
callback_aaa_task: status = 1, msg =
AAA FSM: In aaa_backend_callback
aaa_backend_callback: Handle = 39, pAcb = 2ae115c
AAA task: aaa_process_msg(1a87a64) received message type 1
AAA FSM: In AAA_ProcSvrResp
Back End response:
------------------
Tunnel Group Policy Status: 1 (ACCEPT)
AAA FSM: In AAA_NextFunction
AAA_NextFunction: i_fsm_state = IFSM_TUNN_GRP_POLICY, auth_status = ACCEPT
AAA_NextFunction: authen svr = <none>, author svr = AD-LDAP, 
user pol = , tunn pol = CAC-USERS
AAA_NextFunction: New i_fsm_state = IFSM_DONE,
AAA FSM: In AAA_ProcessFinal
Checking time simultaneous login restriction for user 1234567890@mil
AAA FSM: In AAA_Callback
user attributes: 1 Tunnelling-Protocol(4107) 20 20
user policy attributes:
None
tunnel policy attributes:
1 Primary-DNS(4101) 4 IP: 10.0.10.100
2 Secondary-DNS(4102) 4 IP: 0.0.0.0
3 Tunnelling-Protocol(4107) 4 4
4 Default-Domain-Name(4124) 10 "ggsgseclab.org"
5 List of address pools to assign addresses from(4313) 10 "CAC-USERS"
Auth Status = ACCEPT
AAA API: In aaa_close
AAA task: aaa_process_msg(1a87a64) received message type 3
In aaai_close_session (39)
AAA API: In aaa_send_acct_start
AAA API: In aaa_send_acct_stop

CAC-Test#

例 2: 不適切に設定された Cisco アトリビュート マッピング することの許可された接続

下記の例は付録 A で示されているシナリオ 2 の許可された接続の内でよくあるデバッグ LDAP およびデバッグ AAA の出力を示します

両方の属性のためのマッピングが不正確である同じ値と一致することに注目して下さい。

図 C2: debug LDAP および debug aaa common の出力:誤ったマッピング
AAA API: In aaa_open
AAA session opened: handle = 41
AAA API: In aaa_process_async
aaa_process_async: sending AAA_MSG_PROCESS
AAA task: aaa_process_msg(1a87a64) received message type 0
AAA FSM: In AAA_StartAAATransaction
AAA FSM: In AAA_InitTransaction

Initiating authorization query (Svr Grp: AD-LDAP)
------------------------------------------------
AAA FSM: In AAA_BindServer
AAA_BindServer: Using server: 172.18.120.160
AAA FSM: In AAA_SendMsg
User: 1234567890@mil
Pasw: 1234567890@mil
Resp:

[82] Session Start
[82] New request Session, context 0x26f1c44, reqType = 0
[82] Fiber started
[82] Creating LDAP context with uri=ldap://172.18.120.160:389
[82] Binding as administrator
[82] Performing Simple authentication for Administrator to
172.18.120.160

[82] Connect to LDAP server: ldap:// 172.18.120.160:389, status =
Successful
[82] LDAP Search:
   Base DN = [CN=Users,DC=ggsgseclab,DC=org]
   Filter = [userPrincipalName=1234567890@mil]
   Scope = [SUBTREE]

[82] Retrieved Attributes:
[82] objectClass: value = top
[82] objectClass: value = person
[82] objectClass: value = organizationalPerson
[82] objectClass: value = user
[82] cn: value = Ethan Hunt
[82] sn: value = Hunt
[82] userCertificate: value =
0..50........../........60...*.H........0@1.0.....&...,d....com1.0.....
&...,d...
[82] userCertificate: value =
0..'0........../..t.....50...*.H........0@1.0.....&...,d....com1.0.....
&...,d...
[82] givenName: value = Ethan
[82] distinguishedName: value = CN=Ethan
Hunt,OU=MIL,DC=labrat,DC=com
[82] instanceType: value = 4
[82] whenCreated: value = 20060613151033.0Z
[82] whenChanged: value = 20060622185924.0Z
[82] displayName: value = Ethan Hunt
[82] uSNCreated: value = 14050
[82] memberOf: value = CN=ASAUsers,CN=Users,DC=ggsgseclab,DC=org
[82] mapped to cVPN3000-Tunneling-Protocols: value =
CN=ASAUsers,CN=Users,DC=ggsgseclab,DC=org
[82] uSNChanged: value = 14855
[82] name: value = Ethan Hunt
[82] objectGUID: value = ..9...NJ..GU..z.
[82] userAccountControl: value = 66048
[82] badPwdCount: value = 0
[82] codePage: value = 0
[82] countryCode: value = 0
[82] badPasswordTime: value = 127954717631875000
[82] lastLogoff: value = 0
[82] lastLogon: value = 127954849209218750
[82] pwdLastSet: value = 127946850340781250
[82] primaryGroupID: value = 513
[82] objectSid: value = ................q......mY...
[82] accountExpires: value = 9223372036854775807
[82] logonCount: value = 25
[82] sAMAccountName: value = 1234567890
[82] sAMAccountType: value = 805306368
[82] userPrincipalName: value = 1234567890@mil
[82] objectCategory: value =
CN=Person,CN=Schema,CN=Configuration,DC=ggsgseclab,DC=org
[82] mail: value = Ethan.Hunt@labrat.com
callback_aaa_task: status = 1, msg =
AAA FSM: In aaa_backend_callback
aaa_backend_callback: Handle = 41, pAcb = 2ae115c
[82] Fiber exit Tx=147 bytes Rx=4821 bytes, status=1
[82] Session End
AAA task: aaa_process_msg(1a87a64) received message type 1
AAA FSM: In AAA_ProcSvrResp
Back End response:
------------------
Authorization Status: 1 (ACCEPT)
AAA FSM: In AAA_NextFunction
AAA_NextFunction: i_fsm_state = IFSM_AUTHORIZE, auth_status = ACCEPT
AAA_NextFunction: authen svr = <none>, author svr = AD-LDAP, user pol =
, tunn pol = CAC-USERS
AAA_NextFunction: New i_fsm_state = IFSM_TUNN_GRP_POLICY,
AAA FSM: In AAA_InitTransaction
aaai_policy_name_to_server_id(USAFE)
Got server ID 0 for group policy DB
Initiating tunnel group policy lookup (Svr Grp: GROUP_POLICY_DB)
------------------------------------------------
AAA FSM: In AAA_BindServer
AAA_BindServer: Using server: <Internal Server>
AAA FSM: In AAA_SendMsg
User: CAC-USERS
Pasw:
Resp:
grp_policy_ioctl(12f1b20, 114698, 1a870b4)
grp_policy_ioctl: Looking up CAC-USERS
callback_aaa_task: status = 1, msg =
AAA FSM: In aaa_backend_callback
aaa_backend_callback: Handle = 41, pAcb = 2ae115c
AAA task: aaa_process_msg(1a87a64) received message type 1
AAA FSM: In AAA_ProcSvrResp
Back End response:
------------------
Tunnel Group Policy Status: 1 (ACCEPT)
AAA FSM: In AAA_NextFunction
AAA_NextFunction: i_fsm_state = IFSM_TUNN_GRP_POLICY, auth_status =
ACCEPT
AAA_NextFunction: authen svr = <none>, author svr = AD-LDAP, user pol =
, tunn pol = CAC-USERS
AAA_NextFunction: New i_fsm_state = IFSM_DONE,
AAA FSM: In AAA_ProcessFinal
Checking time simultaneous login restriction for user 1234567890@mil
AAA FSM: In AAA_Callback
user attributes:
1 Tunnelling-Protocol(4107) 20 0
user policy attributes:
None
tunnel policy attributes:
1 Primary-DNS(4101) 4 IP: 10.0.10.100
2 Secondary-DNS(4102) 4 IP: 0.0.0.0
3 Tunnelling-Protocol(4107) 4 4
4 Default-Domain-Name(4124) 10 "ggsgseclab.org"
5 List of address pools to assign addresses from(4313) 10
"CAC-USERS"
Auth Status = ACCEPT
AAA API: In aaa_close
AAA task: aaa_process_msg(1a87a64) received message type 3
In aaai_close_session (41)
AAA API: In aaa_send_acct_start
AAA API: In aaa_send_acct_stop

認証局および OCSP のトラブルシューティング

  • debug crypto ca 3

  • クラス カリフォルニア コンソール(かバッファ)デバッグを記録 する コンフィギュレーションモードでは

下記の例はポリシーと一致する OCSP 応答側の正常な認証の検証および壊れる認証 グループを示します。

図 C3 はポリシーと一致する検証された認証およびはたらく認証 グループがあるデバッグ 出力を示します。

図 C4 はポリシーと一致する不適切に設定された認証 グループのデバッグ 出力を示します。

図 C5 は、無効になった証明書を持つユーザのデバッグ出力を示します。

図 C3: OCSP デバッグ:成功した証明書検証
CRYPTO_PKI: Attempting to find tunnel group for cert with serial number:
 2FB5FC74000000000035,
 subject name: cn=Ethan Hunt,ou=MIL,dc=ggsgseclab,dc=com, issuer_name: 
cn=ggsgseclab,dc=ggsgseclab,dc=org.
CRYPTO_PKI: Processing map rules for DefaultCertificateMap.
CRYPTO_PKI: Processing map DefaultCertificateMap sequence 10...
CRYPTO_PKI: Match of subject-name field to map PASSED. 
Peer cert field: = cn=Ethan Hunt,ou=MIL,dc=ggsgseclab,dc=org, 
map rule: subject-name ne "".
CRYPTO_PKI: Peer cert has been authorized by map: DefaultCertificateMap 
sequence: 10.
Tunnel Group Match on map DefaultCertificateMap sequence # 10.
Group name is CAC-USERS
CRYPTO_PKI: Checking to see if an identical cert is
already in the database...
CRYPTO_PKI: looking for cert in handle=2467668, digest=
CRYPTO_PKI: Cert record not found, returning E_NOT_FOUND
CRYPTO_PKI: Cert not found in database.
CRYPTO_PKI: Looking for suitable trustpoints...
CRYPTO_PKI: Found a suitable authenticated trustpoint trustpoint0.
CRYPTO_PKI: Certificate validation: Successful, status: 0. Attempting 
to retrieve revocation status if necessary
CRYPTO_PKI: Attempting to find OCSP override for peer cert: 
serial number: 2FB5FC74000000000035, subject name: 
cn=Ethan Hunt,ou=MIL,dc=ggsgseclab,dc=org, issuer_name: cn=ggsgseclab,
dc=ggsgseclab,dc=org.
CRYPTO_PKI: Processing map rules for DefaultCertificateMap.
CRYPTO_PKI: Processing map DefaultCertificateMap sequence 10...
CRYPTO_PKI: Match of subject-name field to map PASSED. 
Peer cert field: = cn=Ethan Hunt,ou=MIL,dc=ggsgseclab,
dc=org, map rule: subject-name ne "".
CRYPTO_PKI: Peer cert has been authorized by map: DefaultCertificateMap
 sequence: 10.
CRYPTO_PKI: Found OCSP override match. Override URL: http://ocsp.disa.mil,
 Override trustpoint: OCSP
CRYPTO_PKI: crypto_pki_get_cert_record_by_subject()
CRYPTO_PKI: Found a subject match CRYPTO_PKI:Certificate validated.
serial number: 2FB5FC74000000000035, subject name: cn=Ethan Hunt,ou=MIL,
dc=ggsgseclab,dc=org.
CRYPTO_PKI: Certificate validated
CRYPTO_PKI: looking for cert in handle=2467668, digest=
CRYPTO_PKI: looking for cert in handle=2467668, digest=
CRYPTO_PKI: looking for cert in handle=2467668, digest=
CRYPTO_PKI: crypto_pki_get_cert_record_by_subject()
CRYPTO_PKI: Found a subject match
CRYPTO_PKI: looking for cert in handle=2467668, digest=
CRYPTO_PKI: looking for cert in handle=2467668, digest=

図 C4: 失敗した証明書グループ照合ポリシーの出力

図 C4: 失敗した証明書グループ照合ポリシーの出力
CRYPTO_PKI: Attempting to find tunnel group for cert with serial number: 
2FB5FC74000000000035, subject name: cn=Ethan Hunt,ou=MIL,dc=ggsgseclab,
dc=org, issuer_name: cn=ggsgseclab,dc=ggsgseclab,dc=org.
CRYPTO_PKI: Processing map rules for DefaultCertificateMap.
CRYPTO_PKI: Processing map DefaultCertificateMap sequence 10...
CRYPTO_PKI: Match of subject-name field to map FAILED. 
Peer cert field: = cn=Ethan Hunt,ou=MIL,dc=ggsgseclab,dc=org, 
map rule: subject-name eq "".
CRYPTO_PKI: Peer cert could not be authorized with map: DefaultCertificateMap.
No Tunnel Group Match for peer certificate.
Unable to locate tunnel group map

図 C5: 無効になった証明書の出力
n %PI=X-3-7E17t02h7a Certinf icaHtue cnhta,in faioled 
uvalidation=. CMertifiIcLa,ted ccha=inl ais eibtrhaer tin,valdid cor =noct 
oamuthori,zed.
map rule: subject-name ne "".
CRYPTO_PKI: Peer cert has been authorized by map: DefaultCertificateMap 
sequence: 10.
Tunnel Group Match on map DefaultCertificateMap sequence # 10.
Group name is CAC-USERS
CRYPTO_PKI: Checking to see if an identical cert is
already in the database...
CRYPTO_PKI: looking for cert in handle=2467668, digest=
CRYPTO_PKI: Cert record not found, returning E_NOT_FOUND
CRYPTO_PKI: Cert not found in database.
CRYPTO_PKI: Looking for suitable trustpoints...
CRYPTO_PKI: Found a suitable authenticated trustpoint trustpoint0.
CRYPTO_PKI: Certificate validation: Successful, status: 0. 
Attempting to retrieve revocation status if necessary
CRYPTO_PKI: Attempting to find OCSP override for peer cert:
 serial number: 2FB5FC74000000000035, subject name: cn=Ethan Hunt,
ou=MIL,dc=ggsgseclab,dc=org, issuer_name: cn=ggsgseclab,dc=ggsgseclab,dc=org.
CRYPTO_PKI: Processing map rules for DefaultCertificateMap.
CRYPTO_PKI: Processing map DefaultCertificateMap sequence 10...
CRYPTO_PKI: Match of subject-name field to map PASSED. 
Peer cert field: = cn=Ethan Hunt,ou=MIL,dc=ggsgseclab,dc=org, map rule: 
subject-name ne "".
CRYPTO_PKI: Peer cert has been authorized by map: DefaultCertificateMap
 sequence: 10.
CRYPTO_PKI: Found OCSP override match. Override URL: http://ocsp.disa.mil, 
Override trustpoint: OCSP
CRYPTO_PKI: crypto_pki_get_cert_record_by_subject()
CRYPTO_PKI: Found a subject match
ERROR: Certificate validation failed, Certificate is revoked, 
serial number: 2FB5FC74000000000035, subject name: cn=Ethan Hunt,ou=MIL,
dc=ggsgseclab,dc=org
CRYPTO_PKI: Certificate not validated

IPSEC のトラブルシューティング

  • debug crypto isakmp – IKE/ISAKMP ネゴシエーションフェーズを表示する

  • debug crypto ipsec – IPSec ネゴシエーションフェーズを表示する

  • debug crypto engine – IPSecメッセージを表示する

  • debug crypto ca メッセージ– PKI メッセージを表示する

  • debug crypto ca トランザクション– PKI トランザクションを表示する

付録 D:MS 内の LDAP オブジェクトの確認

Microsoft サーバ 2003 CD では、LDAP 構造を表示するためにインストールすることができる、また LDAP オブジェクト/属性があります追加ツール。 これらのツールをインストールするには、CD の Support ディレクトリに移動し、Tools ディレクトリを選択します。 SUPTOOLS.MSI をインストールします。

LDAP Viewer

次の手順に従ってください。

  1. インストールの後で、Start > Run の順に進んで下さい。

  2. ldp を入力し、次に『OK』 をクリック して下さい。 これで LDAP Viewer が始動します。

  3. > 接続応答 『Connection』 をクリック して下さい。

  4. サーバ名を入力し、次に『OK』 をクリック して下さい。

  5. > バインド『Connection』 をクリック して下さい。

  6. ユーザ名とパスワードを入力します。

    注: 管理者権限が必要です。

  7. [OK] をクリックします。

  8. LDAP オブジェクトを表示します。 図 D1 を参照してください。

    図 D1: LDAP Viewer

    http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-56.gif

Active Directory サービス インターフェイス エディタ

  • アクティブディレクトリサーバでは、Start > Run の順に進んで下さい。

  • adsiedit.msc と入力します。 これでエディタが始動します。

  • オブジェクトを右クリックし、『Properties』 をクリック して下さい。

このツールは特定のオブジェクトのためのすべての属性を示します。 図 D2 を参照してください。

図 D2: ADSI の編集

http://www.cisco.com/c/dam/en/us/support/docs/security/asa-5500-x-series-next-generation-firewalls/107273-CAC-VPN-Client-54.gif

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 107273