ルータ : Cisco 800 シリーズ ルータ

NAT を使用する PPPoE クライアントとしての Cisco 827 ルータの設定

2008 年 12 月 18 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 2 月 26 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      ネットワーク ダイアグラム
      設定例
確認
トラブルシューティング
      PPPoE クライアントのデバッグ
      PPPoE サーバのデバッグ
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

Cisco IOS(R) ソフトウェア リリース 12.1(3)XG には、Cisco 827 ルータ用の PPP over Ethernet(PPPoE)クライアント機能が導入されています。この機能を使用すると、PPPoE の機能をルータに追加できます。Cisco 827 の背後には、複数の PC をインストールできます。それらのトラフィックが PPPoE セッションに送信される前に、トラフィックの暗号化やフィルタ処理などが可能です。また、Network Address Translation(NAT; ネットワーク アドレス変換)も実行できます。

このドキュメントでは、Cisco 827 ルータの ATM インターフェイス(DSL インターフェイス)上での PPPoE クライアントの設定について説明しています。この設定は、Asymmetric Digital Subscriber Line(ADSL; 非対称デジタル加入者線)対応の WAN Interface Card(WIC; WAN インターフェイス カード)を搭載した Cisco 1700 ルータにも使用可能です。

Cisco 6400 Node Route Processor(NRP; ノード ルート プロセッサ)の設定は、アグリゲータとして動作しているルータや ATM インターフェイスを搭載しているルータにも使用可能です。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供しています。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

827pppoe_client.gif

設定例

このドキュメントでは、次の設定を使用しています。

Cisco 827 ルータに PPPoE を設定するには、Virtual Private Dial Network(VPDN; バーチャル プライベート ダイヤル ネットワーク)コマンドを使用します。まず最初に VPDN コマンドを設定するということを確認してください。

注:Maximum Transmission Unit(MTU; 最大伝送ユニット)のサイズ変更についての詳細は、『PPPoE ダイヤル接続の MTU サイズのトラブルシューティング』を参照してください。

Cisco 827 ルータ

! 
vpdn enable 
no vpdn logging


!--- これがデフォルトです。

! 
vpdn-group pppoe 
 request-dialin     
 
!--- これは、集約ユニット(6400 NRP)とのセッションの確立を  
!--- 要求する PPPoE クライアントです。 
 
  protocol pppoe 
! 


!--- これは内部イーサネット ネットワークです。
 
! 
interface Ethernet0 
 ip address 10.92.1.182 255.255.255.0 
 ip nat inside 
  


!--- DSL インターフェイスです。
 
! 
interface ATM0 
 no ip address 
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in
 
!--- すべてデフォルトです。

  


!--- PPPoE は AAL5SNAP の上で動作しています。ただし、 
!--- encap aal5snap コマンドは使用しません。
  
! 
interface ATM0.1 point-to-point 
 pvc 1/1 
  pppoe-client dial-pool-number 1 
  
!--- pvc 1/1 はサンプル値で、ISP が使用する値に 
  !--- 変更する必要があります。 

 ! 



!--- PPPoE クライアント コードは、バーチャルアクセス インターフェイスが複製される、  
!--- ダイヤラ インターフェイスに結びつけられます。  

! 
interface Dialer1 
 ip address negotiated 
 ip mtu 1492
 
!--- イーサネット MTU のデフォルトは 1500(1492 + PPPoE ヘッダー = 1500)です。

 ip nat outside 
 encapsulation ppp 
 dialer pool 1
 
!--- ATM インターフェイスに結びつけられます。
  
 ppp authentication chap callin 
 ppp chap hostname <username> 
 ppp chap password <password> 
! 

!--- 注:!--- 使用する認証タイプについては、 
!--- ISP から指示されます。 
!--- PPP CHAP から PPP PAP の認証タイプに変えるには、次を置き換えます。
!--- ppp authentication chap callin 
!--- ppp chap hostname <username> 
!--- ppp chap password <password>   
!--- 上記を ppp authentication pap callin
!--- ppp pap sent-username <username> password <password> にします。




!--- NAT を使用する場合は、ダイヤラの IP アドレスが変わる場合があるので、 
!--- Dialer1 インターフェイスに overload を実行し、デフォルトの送信ルートを追加します。 
  
ip nat inside source list 1 interface Dialer1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 
no ip http server 
! 
access-list 1 permit 10.92.1.0 0.0.0.255


!--- NAT 用。

! 

Cisco 6400 NRP

*** local ppp user 


!--- または、AAA を使用します。


username <username> password <password>



!--- VPDN コマンドから始めます。 
!--- ここでは、ATM インターフェイス上ではなく、 
!--- バーチャルテンプレートに PPPoE がバインドされていることに注意してください。 
!--- この時点では、VPDN コマンドによって開始した PPPoE には、 
!--- 複数のバーチャルテンプレート(または VPDN グループ)  
!--- を使用できません。 

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
 accept-dialin
 
!--- PPPoE サーバ モード。
 
  protocol pppoe 
  virtual-template 1 
! 
! 
interface ATM0/0/0 
 no ip address 
 no atm ilmi-keepalive 
 hold-queue 500 in 



!--- バーチャル テンプレート インターフェイスへのバインディングが 
!--- VPDN グループで設定されています。
  
! 
interface ATM0/0/0.182 point-to-point 
 pvc 1/82 
  encapsulation aal5snap
  
!--- サーバ側でコマンドが必要です。 

  protocol pppoe 
 ! 
! 



!--- ダイヤラ インターフェイスの代わりに、バーチャルテンプレートが使用されます。
 
! 
interface Virtual-Template1 
 ip unnumbered Loopback10 
 ip mtu 1492 
 peer default ip address pool ippool 
 ppp authentication chap 
! 
! 
interface Loopback10 
 ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5 

確認

現在のところ、この設定を確認する手順はありません。

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を提供しています。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

注:debug コマンドを発行する前に、『debug コマンドの重要な情報』を参照してください。

PPPoE クライアントのデバッグ

Cisco 827 ルータまたは Cisco 6400 NRP 上で PPPoE クライアントをデバッグするには、プロトコル スタックを考慮する必要があります。トラブルシューティングは、スタックの底から開始できます。

1. DSL 物理層

回線がアップおよび確立されていることを確認します。

show interface atm0 

ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Alcatel ADSL Module) 
 
show dsl interface atm0 

!--- 最初の数行で「Showtime」を探します。


                ATU-R (DS)                      ATU-C (US) 
Modem Status:    Showtime (DMTDSL_SHOWTIME) 

2. ATM 層

ATM インターフェイスがアップ状態であれば、debug atm packet コマンドを使用して、ISP からの受信の有無を確認します。

注:パケットの処理方法が異なるので、このコマンドでは発信パケットは表示されません。

同じ TypeSAPCTL、および OUI のフィールドが含まれ、着信した ATM パケットが AAL5SNAP であることが示されている、次のような出力が表示される必要があります。

debug atm packet 
03:21:32: ATM0(I): 
VCD:0x2 VPI:0x1 VCI:0x1 Type:0x0 SAP:AAAA CTL:03 OUI:0080C2 
TYPE:0007 Length:0x30 
03:21:32: 0000 0050 7359 35B7 0001 96A4 84AC 8864 1100 0001 
000E C021 09AB 000C 0235 
03:21:32: 279F 0000 0000 
03:21:32: 

3. イーサネット層

完全なイーサネット フレームは、AAL5SNAP パケットに含まれます。debug イーサネット パケット コマンドはありません。ただし、PPPoE フレームを参照するために、VPDN デバッグをいくらか行う必要があります。

PPPoE フレームであるイーサネット フレームには、次の 2 つの Ethertypes のどちらかが含まれることを参考にしてください。

  • 0x8863 Ethertype = PPPoE 制御パケット(PPPoE セッションを処理する)。

  • 0x8864 Ethertype = PPPoE データ パケット(PPP パケットを含む)。

PPPoE には 2 つのセッションが存在することに注意することが重要です。PPPoE セッションは、VPDN L2TP タイプのセッションであり、PPP セッションでもあります。そのため、PPPoE を確立するために、PPPoE セッション確立フェーズと PPP セッション確立フェーズがあります。

終端には、通常、PPP 終端フェーズと PPPoE 終端フェーズの両方が関係しています。

PPPoE 確立フェーズでは、PPPoE クライアントとサーバの識別(MAC アドレス)およびセッション ID の割り当てが行われます。このフェーズが完了すると、他の PPP 接続と同様に、通常の PPP の確立が開始されます。

デバッグのため、VPDN PPPoE デバッグを使用して、PPPoE 接続フェーズが成功したかどうかを確認します。

#debug vpdn pppoe-events 

06:17:58: Sending PADI: vc=1/1

!--- ブロードキャスト イーサネット フレーム(この例では ATM にカプセル化されている)で 
!---「PPPoE サーバがどこかにあるか」を問い合せて PPPoE サーバを要求します。 


06:18:00:  PPPOE: we've got our pado and the pado timer went off 

!--- PPPoE サーバからのユニキャスト応答です 
!---(DHCP オファーに非常によく似ています)。


06:18:00: OUT PADR from PPPoE tunnel

!--- オファーを受け入れるユニキャスト応答です。


06:18:00: IN PADS from PPPoE tunnel

!--- これは確認です。確立が完了します。

他の PPP の始動と同様に、PPP の確立が開始されます。PPPoE セッションが確立された後、状態を確認するには show vpdn コマンドを使用します。

#show vpdn
%No active L2TP tunnels 
%No active L2F tunnels 

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information
SID  RemMAC           LocMAC      Intf  VASt  OIntf   VC 
1  0050.7359.35b7  0001.96a4.84ac  Vi1  UP     AT0    1   1

パケット カウント情報を得るには、show vpdn session all コマンドを使用します。

show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1

session id: 1
local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
    1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

その他の debug コマンド

  • debug vpdn pppoe-data

  • debug pppoe-errors

  • debug pppoe-packets

PPP 層

PPPoE セッションが確立されたら、PPP デバッグは、その他の PPP 設定の場合と同じです。

同じ debug ppp negotiation および debug ppp authentication コマンドを使用します。次に、出力例を示します。

注:次の例では、ホスト名は「client1」で、リモートの Cisco 6400 NRP の名前は「nrp-b」です。

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up

PPPoE サーバのデバッグ

Cisco 6400(PPPoE サーバ)をデバッグするには、Cisco 827 ルータ(クライアント)に使用したものと同じボトムアップ手順を使用します。ただし、今回は、DSL 物理層で DSL Access Multiplexer(DSLAM; デジタル加入者線アクセス マルチプレクサ)をチェックする必要がある点が異なります。

1. DSL 物理層

DSL 物理層をチェックするには、DSLAM の DSL 統計情報を確認する必要があります。Cisco DSLAM の場合は、show dsl interface コマンドを使用します。

2. ATM 層

Cisco 6400 側でも、debug atm packet コマンドを使用できます。また、特定の Permanent Virtual Circuit(PVC; 相手先固定接続)に Cisco 6400 を使用可能にします。

debug atm packet interface atm 0/0/0.182 vc 1/82

同じ TypeSAPCTL、および OUI のフィールドが含まれ、着信した ATM パケットが AAL5SNAP であることが示されている、次のような出力が表示される必要があります。

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

注:パケットの処理方法が異なるので、このコマンドでは発信パケットは表示されません。

3. イーサネット層

Cisco 827 ルータと同様に、Cisco 6400 NRP でも、PPPoE 確立の確認に同じ VPDN show コマンドdebug が使用できます。

#debug vpdn pppoe-events

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel
#show vpdn
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1    82
nrp-b#show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

その他の debug コマンド

  • debug vpdn pppoe-data

  • debug pppoe-errors

  • debug pppoe-packets

4. PPP 層

次に、Cisco 6400 NRP からの PPP debug の出力を示します。これは、前述した Cisco 827 ルータからのデバッグに対応しています。

debug ppp negotiation and debug ppp authentication
4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, 
changed state to up 

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 8514