音声とユニファイド コミュニケーション : Cisco Unity

Unity IP ファックス発信ゲートウェイの設定例

2008 年 12 月 18 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 1 月 31 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
背景説明
ゲートウェイの設定
      完全な設定例
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

発信ファックス機能は Unity IP Fax Configuration Wizard によってサポートされ、Cisco Unity 4.04 および Cisco IOS(R) ソフトウェア リリース 12.3(7)T 以降から実装されたサービスです。このサービスを利用すると、ユーザは通常の電子メールを介してファックスを送信できるようになります。宛先ファックス電話番号は電子メールの件名行に含まれ、Unity IP Fax サービスによりチェックされるメールボックスに送信されます。IP Fax サービスはメッセージを再フォーマットし、すべての添付ファイルを適切な形式にレンダリングし、アドレスを再設定して、メッセージを送信します。メッセージは Simple Mail Transfer Protocol(SMTP; シンプル メール転送プロトコル)を介して、T.37 オフランプ機能が設定された IOS ゲートウェイに送信され、宛先電話番号にファックスが送信されます。このドキュメントでは、Cisco IOS ゲートウェイの設定手順について説明しています。

前提条件

要件

このドキュメントを読むには、SMTP に関する基本的な知識が必要です。また、Cisco IOS の VoIP 設定に精通している必要もあります。完全に機能するシステムを構築するには、このドキュメントで定義されているゲートウェイ設定とともに、Unity IP Fax Configuration Wizard バージョン 2.0.0.19 以降がインストールされた稼働中の Cisco Unity サーバを使用する必要があります。IOS ゲートウェイ側では、パートナー メッセージ ストアとして Microsoft Exchange 2000 または 2003 を使用する Cisco Unity バージョン 4.04 以降とともに、T.37 オフランプ機能と Cisco IOS ソフトウェア リリース 12.3(7)T 以降をサポートする Cisco IOS ルータが必要です。IP Fax 設定の Cisco Unity 部分についての詳細は、『Unity IP Fax Configuration Wizard』を参照してください。

注:T.37 オフランプは、MGCP ネットワーク上ではサポートされません。T.37 を使用するためのプラットフォームとその他の制限事項についての詳細は、『T.37 ストア アンド フォワード ファックス設定ガイド』を参照してください。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • IOS ゲートウェイとして Cisco 3725

  • Cisco IOS ソフトウェア リリース 12.3(8)T4

注:ゲートウェイは Cisco 37xx プラットフォームだけに限定されません。IP PLUS と Cisco IOS ソフトウェア リリース 12.3(7)T がインストールされていれば、任意の音声ゲートウェイを使用できます。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

ユーザが IP Fax サービス メールボックスに電子メールを送信する際には、件名に [FAXPHONE=####] が含まれます(#### は宛先ファックス機の番号です)。IP Fax サービスは、次の役割を担います。

  • 送信する添付ファイルが有効であり、TIF タイプ F ファイル形式にレンダリングされていることを確認します。

  • アドレスを設定し、新しい TIF 添付ファイルを含む電子メールを FAX=####@gateway.com に送信します。

  • ゲートウェイから受信した Delivery Status Notification(DSN)を解釈して、適切な処理を実行します。これらの処理には、ゲートウェイへのメッセージの再送信(ビジー信号が返された場合、または応答がなかった場合)や、エンドユーザへの通知の送信(番号が間違っていた場合)などがあります。

Microsoft Exchange は、次の役割を担います。

  • gateway.com 宛ての電子メールを IOS ゲートウェイに配信します。

  • エンドユーザと IP Fax メールボックスの間、および IOS ゲートウェイと IP Fax メールボックスの間でメールを配信します。エンドユーザからゲートウェイへのメッセージ、またはゲートウェイからエンドユーザへのメッセージは送信されません。

IOS ゲートウェイは、次の役割を担います。

  • FAX=####@gateway.com を解釈し、#### にコールを発信し、標準の G3 ファックス プロトコル(T.30 および T.4)を使用してファックスを送信します。

  • ファックス コールが発信されるたびに「恒久的なエラー」のフラグが付いた Delivery Status Notification(DSN)を IP Fax メールボックスに送信します。これにより、IP Fax サービスは、ファックスが正しく送信されたこと、または問題(話中、応答なし、など)があったかどうかを認識できます。IP Fax サービスは、メール システムの設定に依存せずに、再試行を処理し、送信元にフィードバックを送信する役割をすべて担います。

ゲートウェイの設定

このアプリケーションが機能するためには、Cisco IOS の設定にいくつかのコマンドを追加する必要があります。これらのコマンドの一部は、着信ファックス(オンランプ)機能に必要な設定コマンドと重複します。これらのシナリオを別々に扱うと、内容の理解やトラブルシューティングが容易になります。

  • fax interface-type fax-mail:このコマンドをゲートウェイで設定します。このコマンドを設定すると、T.37 ストア アンド フォワード ファックス コールがゲートウェイで処理されるようになります。このコマンドが設定されていないと Exchange/Unity サーバからの着信ファックス電子メールが失敗し、このコマンドを追加するまで T.37 ルータ デバッグを利用できません。このコマンドを設定した後は、ルータをリロードする必要があることに注意してください。

    vnt-3725-51(config)#fax interface-type fax-mail
    You must reload the router
    
  • T.37 ファックス オフランプを実行するには、Cisco ゲートウェイで追加のソフトウェアが必要になります。このソフトウェアは、ファックス オフランプ機能で必要になった場合にゲートウェイで実行される TCL スクリプトです。このスクリプト ソフトウェアは、ルータの内部フラッシュにロードすることも、TFTP サーバからロードすることもできます。ファックス オフランプを使用するためにダウンロードする必要があるファイルは、Cisco Software Center にある app-faxmail-offramp.2.0.1.1.zip ファイル登録ユーザ専用)です。このファイルは、ゲートウェイからアクセス可能な場所に配置する必要があります。次の出力例では、十分な空き領域があるので、ルータの内部フラッシュにこのファイルをロードしています。
    一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

    vnt-3725-51#show flash
    System CompactFlash directory:
    File Length Name/status
    1 23454000 c3725-ipvoice-mz.123-8.T4.bin 
    [23454064 bytes used, 104734348 available, 128188412 total]
    125184K bytes of ATA System CompactFlash (Read/Write)
    vnt-3725-51#copy tftp flash:
    Address or name of remote host []? 172.18.106.4
    Source filename []? app_faxmail_offramp.2.0.1.1.tcl
    Destination filename [app_faxmail_offramp.2.0.1.1.tcl]?
    Accessing tftp://172.18.106.4/app_faxmail_offramp.2.0.1.1.tcl...
    Erase flash: before copying? [confirm]n
    Loading app_faxmail_offramp.2.0.1.1.tcl from 172.18.106.4 (via FastEthernet0/0): !
    [OK - 5095 bytes]
    Verifying checksum... OK (0xB729)
    5095 bytes copied in 0.076 secs (67039 bytes/sec)
    vnt-3725-51#show flash
    System CompactFlash directory:
    File Length Name/status
    1 23454000 c3725-ipvoice-mz.123-8.T4.bin 
    2 5095 app_faxmail_offramp.2.0.1.1.tcl 
    [23459224 bytes used, 104729188 available, 128188412 total]
    125184K bytes of ATA System CompactFlash (Read/Write)
    

    このファイルに関する情報と、このファイルが配置されている場所をルータに伝達する必要があります。これを行うには、call application voice offramp flash:app_faxmail_offramp.2.0.1.1.tcl グローバル設定コマンドを使用します。

    フラッシュ内ではなく TFTP サーバ上にファイルが配置されている場合、このコマンドは次のようになります。

    call application voice offramp tftp://172.18.106.4/app_faxmail_offramp.2.0.1.1.tcl
    
  • mta receive maximum <recipients>:このコマンドでは、ゲートウェイ上の SMTP 接続の同時受信者数を指定します。このコマンドを使用すると、ゲートウェイのリソース使用率を制限できます。このコマンドのデフォルト値は 0 であることに注意してください。このコマンドが 0 よりも大きい値に設定されていない場合、ゲートウェイはすべての SMTP 要求に応答しません。そのため、すべてのオフランプ トランザクションがただちに失敗します。

  • mta receive aliases <string>:このコマンドでは、オフランプ ファックス発信用の SMTP エイリアスとして受け入れられる有効なホスト名が識別されるので、このコマンドは重要です。このコマンドの <string> では、IP アドレスまたは DNS タイプ ホスト名を指定できます。「rcpt to:」フィールドのドメインと、このコマンドでエイリアスとして設定した文字列が完全に一致しない場合は、すべての SMTP 接続に失敗するので、このコマンドは非常に重要です。つまり、ゲートウェイは、着信メールの宛先ホスト名と、このコマンドで設定したエイリアスが一致する場合にだけ、着信メールを受け入れます。複数のエイリアス(最大 10 個)を設定すると、複数のドメイン名だけでなく IP アドレスにも対応できます。たとえば、IP Fax サービスによって「FAX=####@gateway.com」にメッセージが送信される場合、このコマンドは次のようになります。

    mta receive aliases gateway.com
    
  • mta receive generate permanent-error:このコマンドが設定されていないと一部の DSN メッセージが IP Fax サービス メールボックスに返されなくなるため、このコマンドは必須です。DSN メッセージは SMTP 仕様の一部であるため、メール サーバ(Microsoft Exchange)は「恒久的」なエラーを除くすべてのものを処理してから、送信元(この場合は IP Fax サービス メールボックス)にメッセージを返す必要があります。user busy などのメッセージには、(デフォルトでは)「一時的」な DSN エラーのフラグが付けられます。Exchange では、長時間にわたり単独でメッセージの再送信が試みられます。mta receive generate permanent-error コマンドを設定すると、ルータによってすべての DSN メッセージに恒久的なエラーのフラグが付けるようになります。その結果、すべての DSN メッセージが送信元(IP Fax サービス メールボックス)へただちに返されるようになります。IP Fax サービスでは、(ユーザ設定に基づいて)ビジーまたは応答なしの場合に再試行を何回行うかを決定できます。このコマンドは Cisco IOS ソフトウェア リリース 12.3(7)T 以降でのみ使用できます。このコマンドがルータに存在しない場合は、これよりも古い Cisco IOS リリースが稼働している可能性があります。

  • mta send server <exchange server> port 25:このコマンドでは、ファックス メールボックスにメッセージ(DSN など)を返すために使用するサーバを指定します。このコマンドでは、Exchange サーバの IP アドレスまたは DNS 名を指定する必要があります。DNS 名を指定する場合は、DNS で名前を解決できるように ip name-server <ip address> コマンドを設定する必要があります。

  • 着信 SMTP メッセージをファックス番号に関連付けて、コールを発信テレフォニー回線にルーティングするには、着信ダイヤルピアと発信ダイヤルピアを設定する必要があります。次に例を示します。

    dial-peer voice 5590 pots
    destination-pattern 991....
    port 2/0:23
    forward-digits all
    prefix 9
    !
    dial-peer voice 2 mmoip
    description off-ramp inbound VoiP from Unity
    application offramp
    information-type fax
    incoming called-number 991
    dsn delayed
    dsn success
    dsn failure
    !
    

    POTS ダイヤルピア自体は、特別なものではありません。これは、ルータから回線に音声コールをルーティングするために必要なダイヤルピアです。ここで重要な項目は MMOIP ダイヤルピアです。このダイヤルピアの設定には「application offramp」が含まれています。これは TCL スクリプト(「call application voice offramp flash:app_faxmail_offramp.2.0.1.1.tcl」)に関連付けられた名前です。また、このダイヤルピアに一致するコールがファックス コールであることをシステムに認識させるためには、「information-type fax」も必要になります。さらに、incoming called-number 文も必要です。これは、着信番号をダイヤルピアに関連付ける最も簡単な方法です。destination-pattern がないことに注意してください。このダイヤルピアは(VoIP 側からの)着信コールだけに使用されるので、destination-pattern は不要です。この例の場合、991 で始まる任意の番号のファックス コールがルータで受け入れられます。SMTP メッセージの宛先は「991XXXX@gateway.com」に設定されている必要があります(XXXX は任意の 4 桁の番号に一致します)。「destination-pattern 991....」が設定されているので、POTS ダイヤルピアは番号の先頭に 9 を付加して PRI(ポート 2/0:23)にコールを送信します。したがって、「9912345@gateway.com」宛てのメッセージが届くと、ポート 2/0 の PRI で番号 99912345(prefix 9 コマンドがあるため)にコールが発信されます。

    MMOIP ダイヤルピアで DSN コマンドが受信されると、すべての状態に関する配信ステータスが送信されます(delayed/success/failure)。ただし、これだけでは不十分です。これらすべての DSN メッセージを、一時的なエラーではなく Error ステータスで送信するには、mta receive generate permanent-error コマンドも必要です。一時的なエラーは(当分の間)IP Fax サービス メールボックスに返されなくなります。

    製品とコマンドについての詳細は、IP 上での Cisco のファックス サービスのアプリケーション ガイドの「T.37 ストア アンド フォワード ファックスの設定」セクションを参照してください。Cisco Unity サーバに接続された稼働中の T.37 ゲートウェイの完全な設定は、このドキュメントの「完全な設定例」セクションに掲載されています。Cisco Unity サーバからの SMTP コールは、ゲートウェイのファースト イーサネット ポートで受信された後、ISDN T1 PRI 2/0:23 からルーティングされます。

完全な設定例

次の設定は、Cisco Unity の発信ファックス機能を使用するために最小限必要な Cisco IOS 設定の例です。最も重要な設定コマンドは太字で示されています。

vnt-3725-51#show run
Building configuration...
Current configuration : 1608 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname vnt-3725-51
!
boot-start-marker
boot-end-marker
!
no network-clock-participate slot 2
no network-clock-participate aim 0
no network-clock-participate aim 1
voice-card 2
dspfarm
!
no aaa new-model
ip subnet-zero
ip cef
! 
no ftp-server write-enable
isdn switch-type primary-ni
!
fax interface-type fax-mail
mta send server 14.84.31.12 port 25
mta receive aliases vnt-3725-51.gateway.com
mta receive maximum-recipients 10
mta receive generate permanent-error
! 
controller T1 2/0
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 2/1
framing sf
linecode ami
!
interface FastEthernet0/0
ip address 14.80.51.14 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
ip default-gateway 14.80.51.1
ip classless
ip route 0.0.0.0 0.0.0.0 14.80.51.1
ip http server
!
control-plane
!
call application voice offramp flash:app_faxmail_offramp.2.0.1.1.tcl
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 2/0:23
!
dial-peer voice 5590 pots
destination-pattern 991....
port 2/0:23
forward-digits all
prefix 9
!
dial-peer voice 2 mmoip
description off-ramp inbound SMTP from Unity
application offramp
information-type fax
incoming called-number 991
dsn delayed
dsn success
dsn failure
! 
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end
vnt-3725-51#

確認

現在のところ、この設定を確認する手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 62995