IP : IP ルーティング

IS-IS での MTU の不一致に関する問題

2008 年 10 月 15 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2012 年 6 月 18 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次


概要

Intermediate System-to-Intermediate System(IS-IS)の HELLO パケットは、maximum transmission unit(MTU; 最大伝送ユニット)の最大限の大きさまでパディングされます。IS-IS の HELLO パケット(IIH)を MTU の最大サイズまでパディングすることの利点は、大規模なフレームの転送によるエラーや、近接インターフェイス間での MTU の不一致によるエラーを早期に検出できるようになることです。

IIH のパディングは、ルータ上のすべてのインターフェイスでオフにすることができます(Cisco IOS(R) ソフトウェア リリース 12.0[5]T および 12.0[5]S)。これを行うには、ルータの設定モードで IS-IS ルーティング プロセスに対して no hello padding コマンドを実行します。また IIH のパディングは、ポイントツーポイントまたはマルチポイントのインターフェイスに対して、選択的にオフにすることもできます。この場合は、ルータの設定モードで IS-IS ルーティング プロセスに対して no hello padding multi-point または no hello padding point-to-point コマンドを実行します。no isis hello padding インターフェイス設定コマンドを使用すると、個々のインターフェイスに対して HELLO パケットのパディングをオフにすることができます。

この文書では、IS-IS が稼働している接続された 2 台のルータのインターフェイスで、MTU の不一致がある場合に発生する問題について説明します。ルータ F の MTU は、インターフェイス設定コマンドの mtu 2000 によって、デフォルト値の 1500 バイトから 2000 バイトに変えられています。このシリアル インターフェイスはすでに「フラップ」されているので、新しい MTU 値を有効にするためには、Serial 0 を shutdown コマンドで一度無効にし、no shutdown コマンドで再度有効にする必要があります。

ネットワーク ダイアグラムと設定は次のとおりです。

ルータ H ルータ F
clns routing

  !

 

  interface Serial0

   no ip address

   no ip directed-broadcast

   no ip mroute-cache

   encapsulation frame-relay

   frame-relay lmi-type ansi

  !

  interface Serial0.1

 

   ip address 10.10.10.4 255.255.255.0

   no ip directed-broadcast

   ip router isis

   clns router isis

   frame-relay map clns 132 broadcast

   frame-relay map clns 131 broadcast

   frame-relay map ip 10.10.10.1 132 broadcast

   frame-relay map ip 10.10.10.3 131 broadcast

  !

  interface Serial0.2 point-to-point

   ip address 10.20.20.4 255.255.255.0

   no ip directed-broadcast

   ip router isis

   clns router isis

   frame-relay interface-dlci 130

  !

  router isis

   passive-interface Ethernet0

   net 49.0001.4444.4444.4444.00

   is-type level-1

 

 clns routing

 

 !

 interface Serial2

 mtu 2000

  no ip address

  no ip directed-broadcast

  encapsulation frame-relay

  frame-relay lmi-type ansi

 !

 interface Serial2.1 point-to-point

  ip address 10.20.20.2 255.255.255.0

  no ip directed-broadcast

  ip router isis 

  clns router isis 

  frame-relay interface-dlci 103   

 !

 router isis 

  net 49.0001.2222.2222.2222.00

  is-type level-1

 

両方のルータで show clns neighbors コマンドを使用すると、ルータ F とルータ H との隣接関係の状態を見ることができます。ルータ F での出力には、ルータ H との隣接関係は INIT 状態であると表示されます。ルータ H の出力では、ルータ F との隣接関係のタイプは IS で、プロトコルは End System-to Intermediate System(ES-IS)であると表示されます。この出力によって、Connectionless Network Service(CLNS; コネクションレス型ネットワーク サービス)の隣接関係に問題があることが分かります。


 Router_H#show clns neighbors

 

 System Id      SNPA                Interface   State  Holdtime  Type Protocol

 Router_F       DLCI 130            Se0.2       Up     294       IS   ES-IS

 Router_G       DLCI 131            Se0.1       Up     7         L1   IS-IS

 Router_E       DLCI 132            Se0.1       Up     27        L1   IS-IS

 

 

 Router_F#show clns neighbors

 

 System Id      Interface   SNPA                State  Holdtime  Type Protocol

 Router_H       Se2.1       DLCI 103            Init   26        L1   IS-IS

 

 

debug isis adj-packet コマンドで IS-IS 隣接関係パケットのデバッグを有効にすると、ルータ F では Serial 2.1 のサブインターフェイスで IIH の送信と受信の両方を行っていることが分かります。


 Router_F#debug isis adj-packets

 IS-IS Adjacency related packets debugging is on

 ISIS-Adj: Sending serial IIH on Serial2.1

 ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00

 ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT

 ISIS-Adj: Action = GOING UP, new type = L1

 ISIS-Adj: Sending serial IIH on Serial2.1

 ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00

 ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT

 ISIS-Adj: Action = GOING UP, new type = L1

 ISIS-Adj: Sending serial IIH on Serial2.1

 ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00

 ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT

 ISIS-Adj: Action = GOING UP, new type = L1

 ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1,cir id 00

 ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT

 ISIS-Adj: Action = GOING UP, new type = L1

 ISIS-Adj: Sending serial IIH on Serial2.1

 

次の出力からは、ルータ H はルータ F から Serial 0.2 の IIH を受信しておらず、そのため IS-IS 隣接関係が構築されていないことが分かります。この場合、隣接関係は End System(ES)になっています。


 Router_H#debug isis adj-packets

 IS-IS Adjacency related packets debugging is on

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Sending L1 IIH on Serial0.1

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Sending serial IIH on Serial0.2

 ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Sending L1 IIH on Serial0.1

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01

 ISIS-Adj: Sending serial IIH on Serial0.2

 ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

 

問題の原因

ルータ H では、ルータ F からの HELLO パケットを受信していません。これは、IIH がリンクの MTU の最大サイズまでパディングされているのに対し、ES の HELLO パケットは MTU のサイズまでパディングされていないためです。この原因は、ルータ F では MTU は 2000 と考えられているために 2000 バイトの HELLO パケットを送信しますが、これがルータ H では無視されるためです。

ソリューション

この問題のソリューションとしては、リンクの両側で同じ MTU が設定されていることを確認するか、あるいはルータで IIH が MTU の最大サイズまでパディングされないように設定されていることを確認します。


 Router_F#configure terminal

 Enter configuration commands, one per line.  End with CNTL/Z.

 Router_F(config)#interface serial 2

 Router_F(config-if)#mtu 1500

 Router_F(config-if)#shutdown

 Router_F(config-if)#no shutdown

 Router_F(config-if)#^Z

 Router_F#

これにより、ルータ H とルータ F が隣接関係になり、互いのトラフィックをルートするようになります。


 Router_H#show clns neighbors

 

 System Id      SNPA                Interface   State  Holdtime  Type Protocol

 Router_F       DLCI 130            Se0.2       Up     28        L1   IS-IS

 Router_G       DLCI 131            Se0.1       Up     8         L1   IS-IS

 Router_E       DLCI 132            Se0.1       Up     29        L1   IS-IS

 

 

 Router_F#show clns neighbors

 

 System Id      Interface   SNPA                State  Holdtime  Type Protocol

 Router_H       Se2.1       DLCI 103            Up     24        L1   IS-IS

 

Cisco サポート コミュニティ - 特集対話

Cisco サポート コミュニティでは、フォーラムに参加して情報交換することができます。現在、このドキュメントに関連するトピックについて次のような対話が行われています。


関連情報