ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

Cisco 1700ルータの設定および1700ルータがEthernet WIC搭載によりNAT機能を持つPPPoEクライアントとして動作する場合

2003 年 2 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 2 月 26 日) | フィードバック

目次


概要

この資料では、イーサネットWANインターフェイス カード(WIC-1ENET)を使用し、Network Address Translation(NAT)機能を持つPoint-to-Point Protocol over Ethernet (PPPoE) クライアントとして、Cisco 1700を設定する方法について説明します。WIC-1ENETは、Cisco 1700シリーズ ルータ用に開発された10BASE-Tカードです。WIC-1ENETによりCisco 1700に第2のイーサネット インターフェイスが提供されるので、任意のDigital Subscriber Line(DSL;デジタル加入者回線)またはケーブルモデムを使用して、Cisco IOSRソフトウェアの豊富な機能を利用することができます。

PPPoEクライアント機能により、ルータでPPPoE機能を使用できるようになります。Cisco 1700ファストイーサネットインターフェイスの背後に複数のPCを設置し、このPCのトラフィックに暗号化およびフィルタリングなどの処理を行い、PPPoEセッションに送信できます。NATもサポートされます。ルータでPPPoEを実行できるので、PCでPPPoEクライアントソフトウェアを実行する必要はありません。

ハードウェアとソフトウェアのバージョン

  • Cisco 1700 WIC-1ENETをサポートするには、Cisco IOS Software Release 12.1(3) XT1以上が必要です。
  • この資料のコンフィギュレーション例では、Cisco 6400 Universal Access Concentrator-Node Route Processor (UAC-NRP)上でCisco IOS Software Release 12.1(3)DC1を実行しています。

PPPoEをサポートするには、ADSL Plusフィーチャ セットが必要です。ADSLのみのフィーチャ セットでは、Cisco 1700上でPPPoEをサポートできません。

プロセッサ要件

MPC 860マイクロプロセッサRevision B5が必要です。1999年11月21日以降に出荷されたCisco 1700シリーズ ルータはすべて、このプロセッサを採用しています。シリアル番号がJAB0347XXXXで始まるCisco 1700には、MPC 860マイクロプロセッサRevision B5が搭載されています。

シリアル番号は、日付コードを含むLLLYYWWSSSSという形式で表します。

    LLL : 装置が製造された場所
    YY : 装置が製造された年(1997=01、1998=02、1999=03、2000=04)
    WW : 装置が製造された週
    SSSS : シリアル番号

プロセッサのバージョン情報は、起動時に表示されます。また、Router#プロンプトに show version コマンドを入力すると、プロセッサのバージョンを確認できます。

メモリ要件

Cisco 1700 IOSイメージでCisco WIC-1ENETをサポートするには、ルータに最低容量のフラッシュメモリおよびDRAMが必要です。各イメージに必要なメモリ容量の詳細については、『Cisco IOS Release 12.1(3)XT1用Cisco 1700シリーズ ルータ リリース ノート』を参照してください。

WIC-1ENETの制限およびサポートされない機能

  • WIC-1ENETは、Cisco 1700以外のプラットフォームではサポートされません。
  • ツイストペアRJ-45接続だけがサポートされます。AUIまたはBNCインターフェイスはサポートされません。
  • 半二重モードと全二重モードの自動ネゴシエーション(自動検知)はサポートされません。
  • ホストがROMMONモードの場合、WIC-1ENETでTFTPによるファイルのダウンロードはできません。
  • ROMMONモードでは、Cisco 1700はWIC-1ENETを認識しません。
  • Cisco IOSは現在、Cisco 1700のスロット0に搭載されたWIC-1ENETだけをサポートします。

ネットワーク ダイアグラム

Network Diagram

設定例

VPDNコマンドを使用して、Cisco 1700上にPPPoEクライアントを設定します。これらのコマンドは、必ず最初に設定してください。

注:Maximum Transmission Unit(MTU;最大伝送ユニット)のサイズ変更の詳細は、PPPoE ダイヤルイン接続でのMTU サイズのトラブルシューティングを参照してください。

Cisco 1700

  ! 

  vpdn enable 

  no vpdn logging

  !--- デフォルト

  ! 

  vpdn-group pppoe 

   request-dialin     

   !--- アグリゲーション ユニット(6400 NRP)とのセッション 

   !--- の確立を要求するPPPoEクライアント  

    protocol pppoe 

  ! 

  int Dialer1

   ip address negotiated

   encapsulation ppp

   ip mtu 1492

   !--- イーサネットMTUはデフォルトで1500  

   !--- (1492 + PPPoE ヘッダー = 1500)

   ip nat outside

   dialer pool 1

   !--- インターフェイスEthernet0に接続

   dialer-group 1

   ppp authentication chap callin

   ppp chap hostname <username>

   ppp chap password <password>

  !

  !--- 使用する認証タイプについては、  

  !--- ISPの指示に従ってください。

  !--- PPP CHAPからPPP PAPに変更するには、 

  !--- 次の3行を、

  !--- ppp authentication chap callin

  !--- ppp chap hostname 

  !--- ppp chap password 

  !--- 次の2行に変更します。

  !--- ppp authentication pap callin

  !--- ppp pap sent-username <username> password <password>

  !

  dialer-list 1 protocol ip permit

  !

  !--- 内部イーサネット ネットワーク

  interface FastEthernet0

   ip address 10.0.0.1 255.255.255.0

   ip nat inside

  !

  interface Ethernet0

   pppoe enable

   pppoe-client dial-pool-number 1

   !--- PPPoEクライアント コードは、ダイヤラ 

   !--- インターフェイスに接続し、そこで仮想アクセス  

   !--- インターフェイスが複製されます。

  !

  !--- IPアドレスは変更される可能性があるので、NAT用に

  !--- Dialer1インターフェイスをオーバーロードし、

  !--- Dialer1インターフェイスからのデフォルト 

  !--- ルートを追加します。

  ip nat inside source list 1 interface Dialer1 overload

  ip classless

  ip route 0.0.0.0 0.0.0.0 dialer1

  no ip http server

  !

  dialer-list 1 protocol ip permit

  access-list 1 permit 10.0.0.0 0.0.0.255

  !--- NAT用

  !

  

Cisco 6400
*** local ppp user 

  !--- aaaを使用してもかまいません。

  username <username> password <password> 

  

  !--- VPDNコマンドを最初に指定します。

  !--- ここでは、ATMインターフェイスではなく  

  !--- 仮想テンプレートにPPPoEをバインドします。  

  !--- (この段階では)VPDNコマンドで始まる  

  !--- PPPoE用の仮想テンプレート(vpdnグループ)を  

  !--- 複数使用することはできません。

  vpdn enable 

  no vpdn logging 

  ! 

  vpdn-group pppoe 

   accept-dialin

   !--- PPPoEサーバ モード 

   protocol pppoe 

   virtual-template 1 

  ! 

  ! 

  interface ATM0/0/0 

   no ip address 

   no atm ilmi-keepalive 

   hold-queue 500 in 

   !--- vpdnグループに、仮想テンプレート インターフェイス

   !--- へのバインディングを設定します。  

  ! 

  interface ATM0/0/0.182 point-to-point 

   pvc 1/82 

    encapsulation aal5snap

    !--- サーバ側のコマンドが必要です。 

    protocol pppoe 

   ! 

  ! 

  !--- ダイヤラ インターフェイスの代わりに仮想テンプレートを使用

  ! 

  interface Virtual-Template1 

   ip unnumbered Loopback10 

   ip mtu 1492 

   peer default ip address pool ippool 

   ppp authentication chap 

  ! 

  ! 

  interface Loopback10 

   ip address 8.8.8.1 255.255.255.0 

  ! 

  ip local pool ippool 9.9.9.1 9.9.9.5

  


PPPoEクライアントのデバッグ

Cisco 1700(PPPoEクライアント)でデバッグを実行する場合には、プロトコル スタックに注意する必要があります。トラブルシューティングは下位レイヤから行いますが、DSLおよびATMレイヤはCustomer Premises Equipment(CPE;顧客宅内機器)に含まれるので、Cisco 1700でトラブルシューティングを行う必要があるのは、イーサネット レイヤおよびPPPレイヤだけです。

    4. PPP レイヤ
    3. イーサネット レイヤ
    2. ATM レイヤ
    1. DSL物理レイヤ

3. イーサネット レイヤ

イーサネット フレームはすべてAAL5SNAPパケットで転送されます。イーサネット パケットのデバッグ コマンドはありませんが、VPDNデバッグを使用してPPPoEフレームを確認できます。

PPPoEフレームであるイーサネット フレームには、次のいずれかのEthertypeが含まれています。

  • 0x8863 Ethertype = PPPoE 制御パケット(PPPoEセッションを処理)
  • 0x8864 Ethertype = PPPoE データ パケット(PPPパケットを含む)

重要なのは、PPPoEでは2つのセッション、すなわちVPDN L2TPタイプのPPPoEセッションと、PPPセッションが実行されるということです。つまり、PPPoEを確立するには、PPPoEセッション確立フェーズとPPPセッション確立フェーズが必要になります。

終了する場合も、通常、PPP終了フェーズとPPPoE終了フェーズが実行されます。

PPPoEセッション確立フェーズでは、PPPoEのクライアントとサーバのMACアドレスを識別し、セッションIDを割り当てます。これが完了すると、他のPPP接続と同様に標準PPPセッションの確立が行われます。

デバッグを実行するには、VPDN PPPoEデバッグを使用して、PPPoE接続フェーズが正常に完了したかどうかを確認します。


  #debug vpdn pppoe-events 

  

  06:17:58: Sending PADI: vc=1/1

  !--- ブロードキャスト イーサネット フレーム(この場合、ATMでカプセル化) 

  !--- PPPoEサーバを要求中「PPPoEサーバはありませんか?」

  

  06:18:00:  PPPOE: we've got our pado and the pado timer went off 

  !--- PPPoEサーバからのユニキャスト応答(DHCPオファーに類似)

  

  06:18:00: OUT PADR from PPPoE tunnel

  !--- オファーを受け入れるユニキャスト応答

  

  06:18:00: IN PADS from PPPoE tunnel

  !---確認。セッションの確立が終了。

  

次に、他のPPP接続と同様に、PPPセッション確立が開始されます。PPPoEセッションが確立された後は、show vpdnコマンドを使用してステータスを確認します。


  #show vpdn

  %No active L2TP tunnels 

  %No active L2F tunnels 

  

  PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

  

  PPPoE Tunnel Information

  

  Session count: 1

  

  PPPoE Session Information

  SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC 
1       0050.7359.35b7  0001.96a4.84ac  Vi1     UP     AT0    1    1

show vpdn session all コマンドを使用して、パケット カウント情報を表示します。


  

  show vpdn session all

  %No active L2TP tunnels

  %No active L2F tunnels

  

  PPPoE Session Information Total tunnels 1 sessions 1

  

  session id: 1

  local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 

  virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 

      1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

  

その他のdebugコマンド:

    debug vpdn pppoe-data
    debug pppoe-errors
    debug pppoe-packets

4. PPPレイヤ

PPPoEセッション確立後は、他のPPP接続と同様にPPPセッションのデバッグを実行します。

debug ppp negotiation コマンドおよび debug ppp authentication コマンドを使用します。次に、出力例を示します。

注:この例では、ホスト名は"client1"、リモートCisco 6400の名前は"nrp-b"です。


  06:36:03: Vi1 PPP: Treating connection as a callout

  06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]

  06:36:03: Vi1 PPP: No remote authentication for call-out

  06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10

  06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 

  06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10

  06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 

  06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15

  06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)

  06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 

  06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15

  06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)

  06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 

  06:36:05: Vi1 LCP: State is Open

  06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]

  06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 

  06:36:05: Vi1 CHAP: Using alternate hostname client1

  06:36:05: Vi1 CHAP: Username nrp-b not found

  06:36:05: Vi1 CHAP: Using default password

  06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"

  06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4

  06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]

  06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]

  06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]

  06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10

  06:36:05: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)

  06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4

  06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10

  06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)

  06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)

  06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)

  06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10

  06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)

  06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 

  06:36:05: Vi1 CDPCP: State is Closed

  06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10

  06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)

  06:36:05: Vi1 IPCP: State is Open

  06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2

  06:36:05: Di1 IPCP: Install route to 8.8.8.1

  06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

  


PPPoEサーバのデバッグ

Cisco 6400(PPPoEサーバ)のデバッグも、Cisco 1700(PPPoEクライアント)の場合と同様に、下位レイヤから実行します。サーバ側では、Digital Subscriber Line Access Multiplexer(DSLAM;デジタル加入者回線アクセス マルチプレクサ)のDSLレイヤおよびCisco 6400のATMレイヤのトラブルシューティングも行います。

    4. PPPレイヤ
    3. イーサネットレイヤ
    2. ATM レイヤ
    1. DSL物理レイヤ

1. DSL物理レイヤ

DSL物理レイヤのデバッグを実行するには、DSLAM上でDSL統計情報を確認する必要があります。Cisco DSLAMでは、show dsl interface コマンドを使用します。

2. ATMレイヤ

Cisco 6400で debug atm packet コマンドを使用し、Cisco 6400で特定のPVCをイネーブルにします。

debug atm packet interface atm 0/0/0.182 vc 1/82

次のような出力が表示されます。Type、SAP、CTL、およびOUIフィールドにより、着信ATMパケットがAAL5SNAPであることが示されます。


  4d04h: ATM0/0/0.182(I):

  VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30

  4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3

  4d04h: 15E5 0000 0000

  

注:パケットの処理方法が異なるので、このコマンドで発信パケットを確認することはできません。

3. イーサネット レイヤ

Cisco 1700と同様に、Cisco 6400でVPDN show コマンドおよび debug コマンドを実行し、PPPoEセッションの確立を確認します。


  #debug vpdn pppoe-events

  

  4d04h: IN PADI from PPPoE tunnel

  

  4d04h: OUT PADO from PPPoE tunnel

  

  4d04h: IN PADR from PPPoE tunnel

  

  4d04h: PPPoE: Create session

  4d04h: PPPoE: VPN session created.

  

  4d04h: OUT PADS from PPPoE tunnel

  

  

  

  #show vpdn

  %No active L2TP tunnels

  %No active L2F tunnels

  

  PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

  

  PPPoE Tunnel Information

  

  Session count: 1

  PPPoE Session Information

  SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC

  1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1   82

  

  

  

  #show vpdn session all

  

  

  

  nrp-b#show vpdn session all

  %No active L2TP tunnels

  %No active L2F tunnels

  

  PPPoE Session Information Total tunnels 1 sessions 1

   

  session id: 1

  local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac

  virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82

      30 packets sent, 28 received, 422 bytes sent, 395 received

  

その他の debug コマンド:

    debug vpdn pppoe-data
    debug pppoe-errors
    debug pppoe-packets

4. PPPレイヤ

次に、Cisco 6400でのPPPデバッグの出力例を示します。前述のCisco 1700でのデバッグに対応しています。

debug ppp negotiation および debug ppp authenticationの出力例


  4d04h: Vi2 PPP: Treating connection as a dedicated line 

  4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 

  4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 

  4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 

  4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 

  4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 

  4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 

  4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 

  4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 

  4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 

  4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 

  4d04h: Vi2 LCP: TIMEout: State ACKsent 

  4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 

  4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 

  4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 

  4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 

  4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 

  4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 

  4d04h: Vi2 LCP: State is Open 

  4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 

  4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 

  4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 

  4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 

  4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 

  4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 

  4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 

  4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 

  4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 

  4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 

  4d04h: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000) 

  

  4d04h: Vi2 IPCP: Pool returned 9.9.9.2 

  4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 

  4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 

  4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 

  4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 

  4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 

  4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 

  4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 

  4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 

  4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 

  4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 

  4d04h: Vi2 IPCP: State is Open 

  4d04h: Vi2 IPCP: Install route to 9.9.9.2 

  4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up 

  

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12956