ダイヤルとアクセス : 非同期接続

PRI 回線での DNIS およびモデム プーリング

2003 年 12 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 9 月 9 日) | フィードバック

目次


概要

この文書の設定例では、一次群速度インターフェイス(PRI)の Digital Number Identification Service(DNIS)サポートの設定方法および、モデム プーリングのセットアップ方法を示します。次の 3 つの設定について説明します。

  1. プール範囲内に定義された複数モデムのモデム プーリング
  2. プール範囲内の 1 モデムのモデム プーリング
  3. プール範囲設定のない場合外のモデル プーリング

この設定を実装するには、次が必要です。

  • Cisco IOS® ソフトウェア リリース 11.3(1.1)T 以降
  • DNIS機能をサポートする通信会社供給 PRI
  • Cisco AS5x00 シリーズ ルータ

:モデム プーリングは、Cisco 3600 シリーズ ルータ上では行えません。

Remote Dial-In User Service(RADIUS)を認証プロトコルとして使用している場合は、 RADIUS(IETF)アカウンティング アトリビュート 30(ステーション ID)が必要です。

ステーション ID を使うと、ネットワーク アクセス サーバ(NAS)は、ユーザがコールした番号を、アクセス要求パケットの一部に含めて送信します(DNIS または同様の技術を使用)。ISDN、および、PRI回線を使用したCisco AS5x00におけるモデム呼び出しにかぎり、ステーションIDが使用できます。

 

ネットワーク ダイアグラム

 

設定 1:プール範囲内の複数モデム

設定の要点

お客様が 5557528 をダイヤルすると、プール範囲 3 〜 5 内のモデムに接続します。ルータ プロンプト(>)でログイン ユーザ ID とパスワードを入力すると、特定の IP アドレスに対してユーザがアクセスできるように autocommand telnet を設定しています。

注意:called-number 機能を設定して、max-conn 番号を入力しない場合は、Cisco ルータは、プール内のモデム数をデフォルト値にします。この設定例では、モデム 3 〜 5 に対して、 called-number コマンドの最後に max-conn 3 と入るような設定を、Cisco IOS ソフトウェアが認識するようになっています。

プール内のモデム数を変更する場合は、手動で max-conn の数を変更する必要があります。

この設定例では、ローカル認証を使用します。

プール範囲内の複数モデム
Current configuration: 

! 

version 11.3 

service timestamps debug datetime msec 

service password-encryption 



service udp-small-servers 

service tcp-small-servers 

! 

hostname isdn2-2 

! 



aaa new-model 

! 

username cisco password 7 xxxxxxxxx 

! 

modem-pool tito 

 pool-range 3-5 

 called-number 5557528 max-conn 3 

ip domain-name cisco.com 

isdn switch-type primary-5ess 

clock timezone PST -8 

clock summer-time PDT recurring 

! 

! 

controller T1 0 

 framing esf 

 clock source line primary 

 linecode b8zs 

 pri-group timeslots 1-24 

 description 5557528 pri 

! 

controller T1 1 

 framing esf 

 clock source line secondary 

 linecode b8zs 

! 

interface Loopback0 

 ip address 10.1.1.1 255.0.0.0 

! 

interface Ethernet0 

 ip address 172.16.25.52 255.255.255.240 

! 

interface Serial0 

 no ip address 

 shutdown 

! 

interface Serial1 

 no ip address 

 shutdown 

! 

interface Serial0:23 

 no ip address 

 no ip mroute-cache 

 isdn incoming-voice modem 

 no cdp enable 

! 

interface Group-Async1 

 no ip address 

 group-range 1 24 

! 

router eigrp 202 

 network 172.16.0.0 

 distance 90 172.16.25.49 0.0.0.0 

 distance 255 0.0.0.0 255.255.255.255 

 no auto-summary 

! 

ip default-gateway 172.16.25.49 

ip classless 

ip route 0.0.0.0 0.0.0.0 172.16.25.49 

! 

line con 0 

 exec-timeout 0 0 

line 1 2 

 modem InOut 

line 3 5 

 modem InOut 

 autocommand telnet 10.1.1.1 

line 6 24 

 modem InOut 

line aux 0 

line vty 0 4 

 password 7 xxxxx 

! 

end 

 

isdn2-2# 

デバッグおよび検証のヒント

設定が正しく機能することを確認するには、show および debug コマンドを使用します。これらのコマンドによる出力は、次のようになります。

isdn2-2#show ver 

Cisco Internetwork Operating System Software 

IOS (tm) 5200 Software (C5200-D-L), Version 11.3(1.1)T, MAINTENANCE INTERIM SOFTWARE 

Copyright (c) 1986-1998 by cisco Systems, Inc. 

Compiled Sun 11-Jan-98 07:12 by ccai 

Image text-base: 0x03034CD4, data-base: 0x00005000 

 

ROM: System Bootstrap, Version 11.1(473), SOFTWARE 

 

isdn2-2 uptime is 18 hours, 41 minutes 

System restarted by reload 

System image file is "bootflash:c5200-d-l.113-1.1.T", booted via flash 

 

cisco AS5200 (68030) processor (revision 0x00) with 16384K/8192K bytes of memory. 

Processor board ID 03676053 

Bridging software. 

X.25 software, Version 3.0.0. 

Primary Rate ISDN software, Version 1.0. 

Mother board without terminator card. 

1 Ethernet/IEEE 802.3 interface(s) 

26 Serial network interface(s) 

24 terminal line(s) 

2 Channelized T1/PRI port(s) 

128K bytes of non-volatile configuration memory. 

8192K bytes of processor board System flash (Read/Write) 

8192K bytes of processor board Boot flash (Read ONLY) 

 

Configuration register is 0x2101 

 

isdn2-2# 

ユーザが接続していない時の show modem-pool

モデム、3、4、および 5 は "tito" という名前のモデム プールに設定されていて、まだモデムからダイヤルしていません。定義済みのモデム プールに設定されていない番号をダイヤルするユーザのために、デフォルト プールが存在します。

isdn2-2#show modem-pool 

modem-pool: System-def-Mpool

! -- デフォルトのプール

modems in pool: 21 active conn: 0 

 3 no free modems in pool 

 

modem-pool: tito

! -- 'tito' という名前のモデム プール

modems in pool: 3 active conn: 0 

 0 no free modems in pool 

 called_party_number: 5557528 

  max conn allowed: 3, active conn: 0 

  0 max-conn exceeded, 0 no free modems in pool 

1 ユーザが接続している show modem-pool

1 ユーザがダイヤルインし、モデム 5 に接続しています。 show modem-pool コマンドでは、プール内のどのモデムが使用されたか表示されません。

show modem-pool 

     ------------- 

modem-pool: tito 

modems in pool: 3 active conn: 1 

 0 no free modems in pool 

 called_party_number: 5557528 

  max conn allowed: 3, active conn: 1 

  0 max-conn exceeded, 0 no free modems in pool 

show line コマンドは、モデム 5 が使用されていることを示します。

     ---------------------------------------- 

isdn2-2#show line 

 Tty Typ   Tx/Rx   A Modem Roty AccO AccI Uses  Noise  Overruns 

* 0 CTY        -  -   -  -  -   0    0    0/0 

  1 TTY 115200/115200 - inout   -  -  -   0    0    0/0 

  2 TTY 115200/115200 - inout   -  -  -   0    0    0/0 

  3 TTY 115200/115200 - inout   -  -  -   0    0    0/0 

  4 TTY 115200/115200 - inout   -  -  -   1    0    0/0 

* 5 TTY 115200/115200 - inout   -  -  -   1    0    0/0 

  6 TTY 115200/115200 - inout   -  -  -   0    0    0/0 

  7 TTY 115200/115200 - inout   -  -  -   0    0    0/0 

  8 TTY 115200/115200 - inout   -  -  -   0    0    0/0 

  9 TTY 115200/115200 - inout   -  -  -   0    0    0/0 

 10 TTY 115200/115200 - inout   -  -  -   0    0    0/0 

 11 TTY 115200/115200 - inout   -  -  -   0    0    0/0 

 12 TTY 115200/115200 - inout   -  -  -   0    0    0/0



[省略]

debug isdn q931 コマンドの使用方法

リモート ユーザがダイヤルしている番号に注意してください。この番号は、モデムプール tito で設定された番号と一致していなければいけません。このユーザの電話番号は、このシナリオでは重要ではありません。

*Mar 1 18:54:31.951:     Called Party Number i = 0xC1, '4085557528' 

 

:次のデバッグ出力行のいくつかは、印刷の都合上、複数行に分かれています。

isdn2-2# 

*Mar 1 18:54:31.935: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x2B 

*Mar 1 18:54:31.939:     Bearer Capability i = 0x9090A2 

*Mar 1 18:54:31.939:     Channel ID i = 0xA98393 

*Mar 1 18:54:31.943:     Progress Ind i = 0x8381 - Call not end-to-end ISDN,

   may have in-band info 

*Mar 1 18:54:31.947:     Calling Party Number i = '!', 0x83, '4085559486' 

*Mar 1 18:54:31.951:     Called Party Number i = 0xC1, '4085557528' 

*Mar 1 18:54:31.963: ISDN Se0:23: Incoming call id = 0xA 

*Mar 1 18:54:31.987: ISDN Se0:23: TX -> CALL_PROC pd = 8 callref = 0x802B 

*Mar 1 18:54:31.991:     Channel ID i = 0xA98393 

*Mar 1 18:54:32.023: ISDN Se0:23: TX -> ALERTING pd = 8 callref = 0x802B 

*Mar 1 18:54:33.067: ISDN Se0:23: TX -> CONNECT pd = 8 callref = 0x802B 

*Mar 1 18:54:33.143: ISDN Se0:23: RX <- CONNECT_ACK pd = 8 callref = 0x2B 

isdn2-2# 

isdn2-2# 

isdn2-2# 

debug isdn Q931 および debug modem csm の出力

ユーザは回線 5 またはモデム 5 ,モデム (slot/port)=0/4 に接続されています。コール処理は、ラウンドロビンなっています。最初に使用されるモデムは3 で、次に 4、最後に 5 の順になります。最初のモデムが利用可能であるかどうかは関係ありません。

isdn2-2# show line 5 

     

 TTY Typ   TX/Rx   A Modem Roty AccO AccI Uses  Noise  Overruns 

* 5 TTY 115200/115200 - inout   -  -  -   1    0    0/0 

 

Line 5, Location: "", Type: "" 

Length: 24 lines, Width: 80 columns 

Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits 

Status: Ready, Active, No Exit Banner 

Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out 

 Modem Callout, Modem RI is CD 

Modem state: Ready 

 modem(slot/port)=0/4, state=CONNECTED 

 dsx1(slot/unit/channel)=2/0/18, status=VDEV_STATUS_ACTIVE_CALL. 

Modem hardware state: CTS DSR DTR RTS 

Special Chars: Escape Hold Stop Start Disconnect Activation 

        ^^x  none  -   -    none 

Timeouts:   Idle EXEC  Idle Session  Modem Answer Session  Dispatch 

        00:10:00    never            none   not set 

              Idle Session Disconnect Warning 

               never 

Modem type is unknown. 

Session limit is not set. 

Time since activation: 00:01:35 

Editing is enabled. 

History is enabled, history size is 10. 

DNS resolution in show commands is enabled 

Full user help is disabled 

Allowed transports are pad telnet rlogin mop. Preferred is telnet. 

Automatically execute command "telnet 10.1.1.1" 

No output characters are padded 

No special data dispatching characters 

isdn2-2# 

デバッグ出力

isdn2-2# 

%SYS-5-CONFIG_I: Configured from console by console 

*Mar 1 19:00:07.227: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x2D 

*Mar 1 19:00:07.227:     Bearer Capability i = 0x9090A2 

*Mar 1 19:00:07.231:     Channel ID i = 0xA98393 

*Mar 1 19:00:07.235:     Progress Ind i = 0x8381 - Call not end-to-end ISDN,

   may have in-band info 

*Mar 1 19:00:07.239:     Calling Party Number i = '!', 0x83, '4085559444' 

*Mar 1 19:00:07.243:     Called Party Number i = 0xC1, '4085557528' 

*Mar 1 19:00:07.255: ISDN Se0:23: Incoming call id = 0xC 

*Mar 1 19:00:07.259: EVENT_FROM_ISDN::dchan_idb=0x25B660, call_id=0xC, ces=0x1 

  bchan=0x12, event=0x1, cause=0x0 

*Mar 1 19:00:07.263: VDEV_ALLOCATE: slot 0 and port 4 is allocated. 

*Mar 1 19:00:07.263: EVENT_FROM_ISDN:(000C): DEV_INCALL at slot 0 and port 4 

*Mar 1 19:00:07.267: CSM_PROC_IDLE: CSM_EVENT_ISDN_CALL at slot 0, port 4 

*Mar 1 19:00:07.267: Fast Ringing On at modem slot 0, port 4 

*Mar 1 19:00:07.291: ISDN Se0:23: TX -> CALL_PROC pd = 8 callref = 0x802D 

*Mar 1 19:00:07.291:     Channel ID i = 0xA98393 

*Mar 1 19:00:07.343: ISDN Se0:23: TX -> ALERTING pd = 8 callref = 0x802D 

*Mar 1 19:00:08.367: Fast Ringing Off at modem slot 0, port 4 

*Mar 1 19:00:08.367: CSM_PROC_IC1_RING: CSM_EVENT_MODEM_OFFHOOK at slot 0, port 4 

*Mar 1 19:00:08.379: ISDN Se0:23: TX -> CONNECT pd = 8 callref = 0x802D 

*Mar 1 19:00:08.451: ISDN Se0:23: RX <- CONNECT_ACK pd = 8 callref = 0x2D 

*Mar 1 19:00:08.463: EVENT_FROM_ISDN::dchan_idb=0x25B660, call_id=0xC, ces=0x1 

   bchan=0x12, event=0x4, cause=0x0 

*Mar 1 19:00:08.467: EVENT_FROM_ISDN:(000C): DEV_CONNECTED at slot 0 and port 4 

*Mar 1 19:00:08.471: CSM_PROC_IC4_WAIT_FOR_CARRIER: CSM_EVENT_ISDN_CONNECTED at

   slot 0, port 4 

*Mar 1 19:00:20.939: TTY5: DSR came up 

*Mar 1 19:00:20.947: tty5: Modem: IDLE->READY 

*Mar 1 19:00:20.951: TTY5: EXEC creation  

モデムが使用可能でない場合の show modem-pool

次の出力は、ビジーのすべてのモデム、また ISDN コール セットアップにより拒否されたコールを示します。

-------------------------------------- 
modem-pool: System-def-Mpool 

modems in pool: 21 active conn: 0 

 3 no free modems in pool 

 

modem-pool: tito 

modems in pool: 3 active conn: 0 

     3 no free modems in pool

! -- プールからのモデム割り当てに失敗した回数。

! -- プール内のモデム数ではありません。

called_party_number: 5557528 

     max conn allowed: 3, active conn: 0

! -- 3 は、プール tito 内に設定されたモデム数。アクティブなものはありません。

0 max-conn exceeded, 3 no free modems in pool 

! -- このプールにおいてモデムを割り当てるのに 3 度失敗しました。
------------------------------------------  
isdn2-2#debug isdn events 

ISDN events debugging is on 

isdn2-2# 

*Mar 1 19:11:26.471: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x2F 

*Mar 1 19:11:26.475:     Bearer Capability i = 0x9090A2 

*Mar 1 19:11:26.479:     Channel ID i = 0xA98393 

*Mar 1 19:11:26.479:     Progress Ind i = 0x8381 - Call not end-to-end ISDN, may have in-band info 

*Mar 1 19:11:26.483:     Calling Party Number i = '!', 0x83, '4085559445' 

*Mar 1 19:11:26.487:     Called Party Number i = 0xC1, '4085557528' 

*Mar 1 19:11:26.499: ISDN Se0:23: Incoming call id = 0xE 

*Mar 1 19:11:26.503: CCPRI, state = 0, serv = 0, int_id = 0, lo_chan = 19, type = 3, Dsl_Id = 0, callid = E 

*Mar 1 19:11:26.507: CCPRI in a Glare situation state 0 serv 0 

*Mar 1 19:11:26.511: ISDN Se0:23: received CALL_INCOMING 

*Mar 1 19:11:26.511:  extracted channel ie[0-8]= 18 3 A9 83 93 38 34 33 32 

*Mar 1 19:11:26.515: 

*Mar 1 19:11:26.519: ISDN Se0:23: Event: Received a Voice call from 4085559445 on B19 at 64 Kb/s 

*Mar 1 19:11:26.519: ISDN Se0:23: CALL_INCOMING: MODEM ERROR 2C: bchan 18, call id E 

*Mar 1 19:11:26.535: in CCPRI_ReleaseCall bchan is 13 dsl is 0 

*Mar 1 19:11:26.539: leaving CCPRI_ReleaseCall, Allocated CCBs = 0 

*Mar 1 19:11:26.543: ISDN Se0:23: entering process_rxstate, CALL_CLEARED 

*Mar 1 19:11:26.615: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x802F 

*Mar 1 19:11:26.615:     Cause i = 0x80AC - Requested channel not available 

isdn2-2# 

設定 2:プール内の 1 モデム
プール内の 1 モデム
enable password 7 XXXXXXXXXX 

! 

username cisco password 7 xxxxxxxxxxxx 

! 

modem-pool tito 

 pool-range 3

! -- モデム #3 だけ設定されています。

 called-number 5557528 max-conn 1       

ip domain-name cisco.com 

isdn switch-type primary-5ess 

clock timezone PST -8 

clock summertime PDT recurring 

! 

!

デバッグおよび検証のヒント

設定が正しく機能することを確認するには、show コマンドを使用します。これらのコマンドからの出力は、下記のようなものになります。

モデムが1つの場合のshow modem-pool

次の出力は、モデム プールに1つのモデムしかない場合を示しています。2 ユーザが同時にダイヤルし、一方のユーザが接続しています。

isdn2-2# show modem-pool 

 modem-pool: System-def-Mpool 

  modems in pool: 23 active conn: 0 

  3 no free modems in pool 

     

 modem-pool: tito 

  modems in pool: 1 active conn: 1 

  4 no free modems in pool 

  called_party_number: 5557528 

  max conn allowed: 1, active conn: 1 

  0 max-conn exceeded, 1 no free modems in pool 

isdn2-2# show modem-pool 

modem-pool: System-def-Mpool 

modems in pool: 23 active conn: 0 

 3 no free modems in pool 

 

modem-pool: tito 

modems in pool: 1 active conn: 1 

 4 no free modems in pool 

 called_party_number: 5557528 

  max conn allowed: 1, active conn: 1 

  0 max-conn exceeded, 1 no free modems in pool 

 

isdn2-2#  

次の出力では、最初のユーザが接続したまま、2 番目のユーザが同時にダイヤル インしてコール障害が起こっています。

isdn2-2# 

isdn2-2# 

*Mar 1 19:38:57.103: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x33 

*Mar 1 19:38:57.107:     Bearer Capability i = 0x9090A2 

*Mar 1 19:38:57.111:     Channel ID i = 0xA98394 

*Mar 1 19:38:57.111:     Progress Ind i = 0x8381 - Call not end-to-end ISDN, may have in-band info 

*Mar 1 19:38:57.115:     Calling Party Number i = '!', 0x83, '4085559474' 

*Mar 1 19:38:57.119:     Called Party Number i = 0xC1, '4085557528' 

*Mar 1 19:38:57.135: ISDN Se0:23: Incoming call id = 0x12 

*Mar 1 19:38:57.139: ISDN Se0:23: CALL_INCOMING: MODEM ERROR 2C: bchan 19, call id 12 

*Mar 1 19:38:57.235: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8033 

*Mar 1 19:38:57.239:     Cause i = 0x80AC - Requested channel not available 

isdn2-2# 

isdn2-2# 

isdn2-2# 

isdn2-2#show modem-pool 

modem-pool: System-def-Mpool 

modems in pool: 23 active conn: 0 

 3 no free modems in pool 

 

modem-pool: tito 

modems in pool: 1 active conn: 1 

 4 no free modems in pool 

 called_party_number: 5557528 

  max conn allowed: 1, active conn: 1 

  1 max-conn exceeded, 1 no free modems in pool 

 

 

isdn2-2# 

2 番目のユーザは、再度ダイヤル インを試行して失敗します。2 max-conn exceeded 文に注意します。

isdn2-2# 

*Mar 1 19:40:34.143: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x34 

*Mar 1 19:40:34.147:     Bearer Capability i = 0x9090A2 

*Mar 1 19:40:34.147:     Channel ID i = 0xA98394 

*Mar 1 19:40:34.151:     Progress Ind i = 0x8381 - Call not end-to-end ISDN,

   may have in-band info 

*Mar 1 19:40:34.155:     Calling Party Number i = '!', 0x83, '4085559486' 

*Mar 1 19:40:34.159:     Called Party Number i = 0xC1, '4085557528' 

*Mar 1 19:40:34.171: ISDN Se0:23: Incoming call id = 0x13 

*Mar 1 19:40:34.179: ISDN Se0:23: CALL_INCOMING: MODEM ERROR 2C: bchan 19,

   call id 13 

*Mar 1 19:40:34.267: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8034 

*Mar 1 19:40:34.271:     Cause i = 0x80AC - Requested channel not available 

isdn2-2# 

isdn2-2# 

isdn2-2# 

isdn2-2# 

isdn2-2#show modem-pool 

modem-pool: System-def-Mpool 

modems in pool: 23 active conn: 0 

 3 no free modems in pool 

 

modem-pool: tito 

modems in pool: 1 active conn: 1 

 4 no free modems in pool 

 called_party_number: 5557528 

  max conn allowed: 1, active conn: 1 

  2 max-conn exceeded, 1 no free modems in pool 

 

 

isdn2-2# 

最初のユーザが非アクティブのため、タイムアウトした場合の show modem-pool

isdn2-2#show modem-pool 

modem-pool: System-def-Mpool 

modems in pool: 23 active conn: 0 

 3 no free modems in pool 

 

modem-pool: tito 

modems in pool: 1 active conn: 0 

 4 no free modems in pool 

 called_party_number: 5557528 

  max conn allowed: 1, active conn: 0 

  2 max-conn exceeded, 1 no free modems in pool 

  
modem-pool: System-def-Mpool 

 ! -- デフォルトのモデム プール

modems in pool: 23 active conn: 0 

 ! -- このアクセス サーバにインストールされているモデム数は 24 です。

 ! -- デフォルト プールでは 23 モデムが使用可能で、

 ! -- 他のモデムはモデムプール tito に限り使用できます。

 3 no free modems in pool 

 ! -- ダイヤル イン ユーザにプールからのモデム割り当てを 3 度失敗しました。
modem-pool: tito 

! -- tito という名前のプール

modems in pool: 1 active conn: 0 

! -- プール内に設定されている 1 つのモデム。

! -- プール内ではモデムのアクティブ接続は 0 です。



 4 no free modems in pool 

! -- ダイヤル イン ユーザへのモデム割り当てに 4 度失敗しました。



called_party_number: 5557528 

! -- リモート ユーザがダイヤルした Cisco アクセスサーバ

 max conn allowed: 1, active conn: 0 

! -- プールあたりの最大接続。アクティブは 0

 2 max-conn exceeded, 1 no free modems in pool 

! -- ユーザへのモデム割り当てを 2 度失敗しました。

! -- そのプールの接続数を超えたためです。

 

isdn2-2# 

設定 3:プール範囲設定のない場合のモデム プーリング


プール範囲設定のない場合のモデム プーリング

pool-range 3-5 コマンドおよび max-conn 引数を除き、この設定は、 プール範囲内の複数モデムの設定と同じです。

! 

modem-pool tito 

 called-number 5557528 max-conn 0 

ip domain-name cisco.com 

isdn switch-type primary-5ess 

!

デバッグおよび検証のヒント

設定が正しく機能することを確認するには、show コマンドを使用します。このコマンドからの出力は、次のようになります。

最初のダイヤル前の show modem-pool

isdn2-2#show modem-pool 

modem-pool: System-def-Mpool 

modems in pool: 24 active conn: 1 

 3 no free modems in pool 

  

modem-pool: tito 

modems in pool: 0 active conn: 0 

 4 no free modems in pool 

 called_party_number: 5557528 

  max conn allowed: 0, active conn: 0 

  0 max-conn exceeded, 0 no free modems in pool 

ユーザがダイヤルして、接続に失敗した後の show modem-pool および debug

isdn2-2#debug isdn q931 

ISDN Q931 packets debugging is on 

isdn2-2#debug modem 

Modem control/process activation debugging is on 

isdn2-2# 

*Mar 1 19:56:50.827: ISDN Se0:23: RX <- SETUP pd = 8 callref = 0x38 

*Mar 1 19:56:50.827:     Bearer Capability i = 0x9090A2 

*Mar 1 19:56:50.831:     Channel ID i = 0xA98393 

*Mar 1 19:56:50.835:     Progress Ind i = 0x8381 - Call not end-to-end

   ISDN, may have in-band info 

*Mar 1 19:56:50.839:     Calling Party Number i = '!', 0x83, '4085559474' 

*Mar 1 19:56:50.843:     Called Party Number i = 0xC1, '4085557528' 

*Mar 1 19:56:50.851: ISDN Se0:23: Incoming call id = 0x17 

*Mar 1 19:56:50.859: ISDN Se0:23: CALL_INCOMING: MODEM ERROR 2C: bchan 18,

   call id 17 

*Mar 1 19:56:50.947: ISDN Se0:23: TX -> RELEASE_COMP pd = 8 callref = 0x8038 

*Mar 1 19:56:50.951:     Cause i = 0x80AC - Requested channel not available 

isdn2-2# 



isdn2-2#show modem-pool 

modem-pool: System-def-Mpool 

modems in pool: 24 active conn: 0 

 3 no free modems in pool 

  

modem-pool: tito 

modems in pool: 0 active conn: 0 

 4 no free modems in pool 

 called_party_number: 5557528 

  max conn allowed: 0, active conn: 0 

  1 max-conn exceeded, 0 no free modems in pool 


関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 10383