WAN : ポイントツーポイント プロトコル(PPP)

外部モデムによる PPP ダイヤルインの設定

2002 年 3 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2010 年 2 月 4 日) | フィードバック

目次


概要

この文書では、外部モデムを使った Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)ダイヤルイン設定を説明します。

Terminal Access Controller Access Controller System(TACACS+)または Remote Authentication Dial-in User Service(RADIUS)サーバがないユーザに対して、ダイヤルインを可能にするために、ユーザ名およびパスワードを設定する必要があります。すべての IP アドレスはプール内からクライアントに渡されます。この設定には、以下が必要です。

  • クライアントに使用させるユーザ名およびパスワード(後で TACACS+ または RADIUS を追加する予定であっても、回線をテストするためにルータに名前をいくつか追加します)

  • プール作成用、およびスタティック ルーティング用の IP アドレッシング方式

ネットワークダイヤグラム

pppdialup

設定例

Cisco 2511
Current configuration:
 !
 version 11.2
 service timestamps debug datetime msec
 no service password-encryption
 no service udp-small-servers
 no service tcp-small-servers
 !
 hostname router1
 !
 enable secret <deleted>
 !
 username jason password foo
 username laura password letmein
 username russ password opensesame
 username syed password bar
 username tito password knockknock
 !--- 着信コールを行うクライアントのユーザ名およびパスワード
 !
 interface Ethernet0
  ip address 192.168.39.1 255.255.255.0
 !
 interface Serial0
  no ip address
 !
 interface Serial1
  no ip address
 !
 interface Group-Async1
 !--- 外部モデム用の非同期設定
  ip unnumbered ethernet0
  encapsulation ppp
  async mode interactive
  peer default ip address pool dialup
  !---「dialup」プールからの着信コール用の IP アドレスを割り当てる
  no cdp enable
  ppp authentication chap
  group-range 1 16
 !--- Group-Async1 インターフェイスに回線 1〜16 を入れる
 !
 ip local pool dialup 192.168.39.239 192.168.39.254
 !---「dialup」プールに利用可能な IP アドレスの範囲を定義する
 !
 line con 0
  login
 line 1 16
 !--- 外部モデム用の回線設定
  login local
  !--- ルータに設定されたユーザ名およびパスワードで着信コールを
  !--- ローカルに認証する
  autoselect during-login
  autoselect ppp
  !--- クライアントから PPP パケットが受信されたときに PPP を起動する
  modem InOut
  !--- 着信コールおよび発信コールを許可する
  transport input all
 line aux 0
 line vty 0 4
  exec-timeout 20 0
  password letmein
  login
 !
 end
 

debug および show コマンド

  • debug ppp negotiation - クライアントが PPP ネゴシエーションを渡しているかを確認するためのものです(アドレス ネゴシエーションをチェックするとき)。

  • debug ppp authentication - クライアントが認証を渡しているかどうかを確認するためのものです。

  • debug ppp error - PPP 接続ネゴシエーションおよびオペレーションに関係するプロトコル エラーおよびエラー統計を表示するためのものです。

  • debug modem - ルータがモデムから正しい信号を受信しているかどうかを確認するためのものです。

  • show line [# tty line] - モデムのハードウェア状態を探すためのものです。

上記の debug コマンドを試す前に、「デバッグ コマンドの重要な情報」を参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 9581