WAN : ポイントツーポイント プロトコル(PPP)

2 つのシリアル物理層非同期インターフェイス間での Multilink PPP

2002 年 3 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2010 年 2 月 4 日) | フィードバック

ルータ 1 はコールを受信するようにのみ設定されており、ルータ 2 はコールを発信し、ルータ 1 に接続します。両方のルータは Multilink PPP で設定されています。接続が発生すると、マスター バンドルが作成され、バーチャル アクセス インターフェイスのもとで両 B チャネルがバンドルされます。

ルータ 1 のインターフェイス 4 および 5 は、非同期コールを受信するだけです。 インターフェイス 4 および 5 は group-async 1 の一部であるときには通常は確認できません。マルチリンク バーチャル テンプレートを必ず作成してください。作成しなかった場合、最初のチャネルで接続することは可能ですが、トラフィックを通しません(IP Control Protocol(IPCP)がクローズ)。バーチャル テンプレートおよび Multilink PPP がない場合、この設定は 一方の非同期接続に対して機能し、両方に対しては機能しません。

ルータ 2 のインターフェイス 3 および 5 は、physical-layer async コマンドが設定され、multilink PPP コマンドを受け付けます。これらのインターフェイスは、dialer rotary-group の一部になると自動的に取り除かれます。dialer rotary-group 1 コマンドを入力するとすぐに、シリアル ppp multilink コマンドが設定から削除されます。その代わりに、インターフェイス ダイヤラ 3 のもとで ppp multilink コマンドを使用します。

この設定には、次の条件が必要です。

  • Cisco IOS(R) Software Release 11.0(3) 以上

     

  • ルータ 1 で multilink virtual-template number を作成します。

     

  • 両ルータのインターフェイスのもとで ppp multilink を設定します。

     

  • 両ルータのインターフェイスのもとで認証を設定します。

 

ネットワークダイヤグラム

設定例

ルータ 1(WATER)
Current configuration:
  
  !
  version 11.2
  !
  hostname WATER 
  !
  username LAND password 0 xxxxxx
   
  !
  multilink virtual-template 1
  ! 
  interface Virtual-Template1
   ip address x.x.x.10 x.x.x.x
   no ip mroute-cache
   ppp authentication chap
   ppp multilink
  !
  interface Serial0
  !
  interface Serial1
  !
  interface Serial2
  !
  interface Serial3
  !
  interface Serial6
  !
  interface Serial7
  !
  interface Serial8
  !
  interface Serial9
  !
  interface Group-Async1
   physical-layer async
   ip unnumbered Virtual-Template1
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   async default routing
   async mode dedicated
   no fair-queue
   no cdp enable
   ppp authentication chap
   ppp multilink
   group-range 4 5
  !
  router ospf 1
   redistribute connected subnets
   network X.X.X.X 0.0.0.X area 3
  !
  no ip classless
  !
  dialer-list 1 protocol ip permit
  !
  line con 0
  line 4 5
   modem InOut
   transport input all
   autohangup
   stopbits 1
   rxspeed 115200
   txspeed 115200
   flowcontrol hardware
  line 9
   modem InOut
   transport input all
   flowcontrol hardware
  line aux 0
  line vty 0 4
   password xxxxxx
   login
  !
  end
  
  WATER#
  
ルータ 2(LAND)
Current configuration:
  
  !
  version 11.2
  !
  hostname LAND
  !
  username WATER password xxxxxxxx
  chat-script test "" "ATDT\T" TIMEOUT 120 CONNECT \c
   !
  interface Serial0
  !
  interface Serial1
  !
  interface Serial2
  !
  interface Serial3
   physical-layer async
   no ip address
   encapsulation ppp
   async mode dedicated
   dialer in-band
   dialer rotary-group 3
   no fair-queue
   no cdp enable
  !
  interface Serial4
  !
  interface Serial5
   physical-layer async
   no ip address
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   async default routing
   async mode dedicated
   dialer in-band
   dialer rotary-group 3
   dialer-group 1
   no fair-queue
   no cdp enable
  !
  interface Serial6
  !
  interface Serial7
  !
  interface Serial8
  !
  interface Serial9
  !
  interface BRI0
  !
  interface Dialer3
   ip address x.x.x.9 x.x.x.x
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer in-band
   dialer idle-timeout 500
   dialer map ip x.x.x.10 name WATER modem-script test broadcast
  9,5551122
   dialer map ip x.x.x.10 name WATER modem-script test broadcast
  9,5551123
   dialer hold-queue 15
   dialer load-threshold 5 either
   dialer-group 1
   no fair-queue
   no cdp enable
   ppp authentication chap
   ppp multilink
  !
  router ospf 1
   redistribute connected subnets
   network X.X.X.X 0.0.0.X area 0
   network X.X.X.X 0.0.0.X area 3 
  !
  no ip classless
  !
  dialer-list 1 protocol ip permit
  !
  line con 0
  line 3
   modem InOut
   transport input all
   autohangup
   stopbits 1
   rxspeed 115200
   txspeed 115200
   flowcontrol hardware
  line 5
   modem InOut
   transport input all
   autohangup
   stopbits 1
   rxspeed 115200
   txspeed 115200
   flowcontrol hardware
  line 6
  ! 
  line aux 0
   password xxxxxxxxx
   login
   modem InOut
   transport input all
  line vty 0 4
   password xxxxxxxx
   login
  !
  end
  
  LAND# 
  

show コマンド

LAND#sh ppp mul
  LAND#sh ppp multilink 
  
  Bundle WATER, 2 members, Master link is Virtual-Access1
  Dialer Interface is Dialer3
    0 lost fragments, 11 reordered, 0 unassigned, sequence 0x7B/0x8F
  
  rcvd/sent
    0 discarded, 0 lost received, 1/255 load
  
  Member Links: 2
  Serial5
  Serial3

debug および検証のヒント

  • debug ppp negotiation - クライアントが PPP ネゴシエーションを渡しているかどうかを確認するために、このコマンドを使ってアドレス ネゴシエーションをチェックします。
  • debug ppp authentication - クライアントが認証を渡しているかどうかを確認するためのものです。11.2 以前の Cisco IOS(R) Software Release を使用している場合、上のコマンドの代わりに debug ppp chap コマンドを使用します。
  • debug ppp error - PPP 接続ネゴシエーションおよびオペレーションに関係するプロトコル エラーおよびエラー統計を表示するためのものです。
  • debug ppp multilink - PPP マルチリンク イベントのデバッグを確認するためのものです。
  • show ppp multilink - マルチリンク バンドルのメンバを確認するためのものです。
上記のdebug コマンドを試す前に、「デバッグコマンドに関する重要な情報」を参照してください。 Router 2 (LAND) Router 1 (WATER)


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 10380