ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

ISDN を経由した PPP コールバックの設定

2002 年 11 月 12 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 11 月 3 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
     背景理論
設定
     ネットワーク ダイアグラム
     設定
確認
トラブルシューティング
     トラブルシューティング用のコマンド
     デバッグ出力例
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この設定例では、Integrated Services Digital Network(ISDN)の Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)コールバックについて説明します。コールバックを使用する目的には、次のようなものがあります。

  • 電話料金請求の整理統合と集中化

  • 市外通話のコスト節減

  • アクセス制御

はじめに

表記法

文書の表記法の詳細は、「シスコ テクニカル ティップス:表記法」を参照してください。

前提条件

この設定を実装するには、次のソフトウェアが必要です。

  • Cisco IOS(R) ソフトウェア リリース 11.0(3) 以降

使用するコンポーネント

これらの設定は、次の機器を使用してテストしました。

  • Cisco IOS ソフトウェア リリース 12.0(5)XK1 がインストールされた Cisco 3640(maui-nas-04)

  • Cisco IOS ソフトウェア リリース 12.0(4)T がインストールされた Cisco 1604(maui-soho-01)

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。また、この文書で使用するデバイスは、すべて初期(デフォルト)の設定で起動しています。実稼動中のネットワークで作業をしている場合、実際にコマンドを使用する前に、その潜在的な影響について理解しておく必要があります。

背景理論

この設定例では、コールバックで PPP と RFC 1570 leaving  cisco.comで指定されているファシリティを使用します。ISDN PPP コールバックは次の順序で実行されます。

  1. ルータ A がルータ B への回線交換接続を開始します。

  2. ルータ A とルータ B の間で PPP Link Control Protocol(LCP; リンク制御プロトコル)がネゴシエートされます。ルータ A がコールバックを要求するか、またはルータ B がコールバックを開始します。 

  3. ルータ A がルータ B に対して、PPP Password Authentication Protocol(PAP; パスワード認証プロトコル)または Challenge Handshake Authentication Protocol(CHAP)を使用して自己認証します。オプションで、ルータ B がルータ A に対して自己認証することもできます。

  4. 双方のルータが回線交換接続を解除します。

  5. ルータ B がルータ A への回線交換接続を開始します。

設定

この項では、この文書で説明する機能の設定に必要な情報を提供します。

注:この文書に使用されるコマンドに関するその他の情報を検索するには、Command Lookup ツールを使用してください。

ネットワーク ダイアグラム

この文書では、下図に示すネットワーク設定を使用します。

isdn-ppp-callback.gif

設定

この文書で使用する設定を次に示します。

maui-soho-01:コールバック クライアント

version 12.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname maui-soho-01

!

aaa new-model

aaa authentication login default local

aaa authentication ppp default local



!--- PPP コール用の基本的な AAA 設定



!

username maui-nas-04 password 0 happy



!--- リモート ルータ(maui-nas-04)のユーザ名と共有シークレット パスワード

!--- 共有シークレット(CHAP 認証で使用)は両側とも同じにする必要があります。



username admin password 0 <deleted>

!

ip subnet-zero

!

isdn switch-type basic-ni

!

interface Ethernet0

 ip address 172.22.85.1 255.255.255.0

 no ip directed-broadcast

!

interface BRI0

 ip address 172.22.82.2 255.255.255.0

 no ip directed-broadcast

 encapsulation ppp

 dialer map ip 172.22.82.1 name maui-nas-04 20007



!--- リモート ルータ用のダイヤラ マップ文

!--- この名前は、リモート ルータで使用されている識別名と一致する必要があります。



 dialer-group 1



!--- dialer-list 1 から対象トラフィックの定義を適用します。





 isdn switch-type basic-ni

 isdn spid1 20009

 ppp callback request



!--- サーバからの PPP コールバックを要求します。



 ppp authentication chap



!--- CHAP 認証を使用します。



!

no ip http server

ip classless

ip route 172.22.80.0 255.255.255.0 172.22.82.1

!

dialer-list 1 protocol ip permit



!--- 対象トラフィックの定義

!--- これは dialer-group 1 を使用する BRI0 に適用されます。





line con 0

 transport input none

 stopbits 1

line vty 0 4

!

end

maui-nas-04:コールバック サーバ

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname maui-nas-04

!

aaa new-model

aaa authentication login default local

aaa authentication ppp default local

!

username admin password <deleted>

username maui-soho-01 password happy



!--- リモート ルータ(maui-soho-01)のユーザ名と共有シークレット パスワード

!--- 共有シークレット(CHAP 認証で使用)は両側とも同じにする必要があります。



!

ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-ni

!

process-max-time 200

!

interface Ethernet0/0

 ip address 172.22.80.4 255.255.255.0

 no ip directed-broadcast

!

interface BRI1/1

 no ip address

 no ip directed-broadcast

 encapsulation ppp

 dialer rotary-group 10



!--- BRI 1/1 を rotary-group 10 に割り当てます。

!--- rotary-group のプロパティは interface dialer 10 で定義されています。





 isdn switch-type basic-ni

 isdn spid1 20007

!

interface dialer10



!--- dialer rotary-group 10 設定のインターフェイス



 ip address 172.22.82.1 255.255.255.0

 no ip directed-broadcast

 encapsulation ppp

 dialer in-band

 dialer callback-secure



!--- コールバックが適切に設定されていないコールの接続を解除します。

!--- 設定解除されたダイヤルイン ユーザがあればその接続を解除します。 



dialer map ip 172.22.82.2 name maui-soho-01 class dial1 20009



!--- コールバック用のダイヤラ マップ文

!--- この名前は、リモート ルータで使用されている識別名と一致する必要があります。

!--- この接続には map-class dialer dial1 を使用します。



 dialer-group 1

 ppp callback accept



!--- リモート ホストへのコールバック要求をインターフェイスが受け入れるようにします。



 ppp authentication chap

!

ip classless

ip route 172.22.85.0 255.255.255.0 172.22.82.2

no ip http server

!

map-class dialer dial1



!--- このマップ クラスはコールバック用のダイヤラ マップ文で使用されます。



 dialer callback-server username



!--- 認証されたユーザ名を使用して、返信コールのダイヤル ストリングを識別します。.



dialer-list 1 protocol ip permit

!

line con 0

 transport input none

line 65 70

line aux 0

line vty 0 4

!

end

確認

この項では、設定が正常に動作しているかどうかを確認する際に使用する情報を示します。

特定の show コマンドは Output Interpreter ツールでサポートされており、これによって show コマンド出力の分析を表示できます。

  • show dialer interface type number - Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)用に設定されているインターフェイスについての、一般的な診断情報を表示します。ダイヤリングを開始したパケットのソース アドレスと宛先アドレスが、dial reason 行に表示されます。このコマンドでは、接続タイマーも表示されます。

  • show isdn status - ルータが ISDN スイッチと適切に通信していることを確認します。出力結果で Layer 1 Status is ACTIVE(レイヤ 1 のステータスがアクティブ)になっているか確認し、Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED が表示されていることを確認してください。このコマンドは、通信中のコールの数も表示します。

  • dialer enable-timeout seconds -コールバック サーバのタイムアウトを有効にし、コール接続解除からコールバック開始までの時間を設定します。

  • dialer hold-queue - コールバック クライアントとコールバック サーバが、接続が確立されるまでリモートの宛先へのパケットを保留できるようにします。

トラブルシューティング

この項では、設定のトラブルシューティングに使用する情報を説明します。

トラブルシューティング用のコマンド

特定の show コマンドは Output Interpreter ツールでサポートされており、これによって show コマンド出力の分析を表示できます。

注:debug コマンドを発行する前に、「debug コマンドに関する重要な情報」を参照してください。

  • debug ppp[ packet | negotiation | error | authentication ] - PPP を実装するインターネットワークでのトラフィックや交換に関する情報を表示する EXEC コマンド。

    • packet - 送受信される PPP パケットを表示する。(このコマンドは、下位レベルのパケット ダンプを表示します。)

    • negotiation - PPP の開始時に送信される PPP パケットを表示します。PPP の開始時には PPP オプションがネゴシエートされます。

    • error - PPP 接続のネゴシエーションと操作に対応するプロトコル エラーとエラー統計を表示する。

    • authentication - CHAP パケット交換や PAP 交換などの認証プロトコル メッセージを表示します。

  • debug isdn q931 - ISDN ネットワーク接続(レイヤ 3)のコール セットアップとティアダウンを表示します。

  • debug isdn q921 - ルータと ISDN スイッチを結ぶ D チャネル上の、データリンク層メッセージ(レイヤ 2)を表示します。show isdn status コマンドでレイヤ 1 とレイヤ 2 がアクティブと表示されない場合は、この debug コマンドを使用します。

  • debug dialer [events | packets ] - ダイヤラ インターフェイスで受信したパケットに関する DDR デバッグ情報を表示します。

デバッグ出力例




!--- maui-soho-01(コールバック クライアント:172.22.82.2)が maui-nas-04(コールバック サーバ:172.22.80.4

!--- イーサネット インターフェイス)にPING し、コールバック プロセスを開始します。

!--- デバッグは maui-soho-01 で収集されています。







maui-soho-01#debug dialer events 

maui-soho-01#show debugging

Dial on demand:

  Dial on demand events debugging is on

maui-soho-01#ping 172.22.80.4

   Type escape sequence to abort.

   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds:

   *Mar 8 23:13:02.117: BRI0 DDR: Dialing cause ip (s=172.22.82.2, d=172.22.80.4)

   *Mar 8 23:13:02.117: BRI0 DDR: Attempting to dial 20007

   *Mar 8 23:13:02.333: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

   *Mar 8 23:13:02.353: isdn_call_connect: Calling lineaction of BRI0:1

   *Mar 8 23:13:02.417: BRI0:1 DDR: Callback negotiated - waiting for server disconnect 

   *Mar 8 23:13:02.493: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down.

   *Mar 8 23:13:02.509: DDR: Callback client for maui-nas-04 20007 created

   *Mar 8 23:13:02.509: isdn_call_disconnect: Calling lineaction of BRI0:1

   *Mar 8 23:13:02.513: BRI0:1 DDR: disconnecting call.... 

   Success rate is 0 percent (0/5)



   

!--- 数秒後、maui-soho-01 が maui-nas-04 からのコールバックを受信します。 





   maui-soho-01#

   *Mar 8 23:13:17.537: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

   *Mar 8 23:13:17.553: isdn_call_connect: Calling lineaction of BRI0:1

   *Mar 8 23:13:19.697: BRI0:1 DDR: No callback negotiated

   *Mar 8 23:13:19.717: BRI0:1 DDR: dialer protocol up

   *Mar 8 23:13:19.717: BRI0:1 DDR: Callback received from maui-nas-04 20007

   *Mar 8 23:13:19.721: DDR: Freeing callback to maui-nas-04 20007

   *Mar 8 23:13:20.697: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,

       changed state to up

   *Mar 8 23:13:23.553: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to

       20007 maui-nas-04

   

!--- 接続が成功したことを確認しています。





maui-soho-01#ping 172.22.80.4

   Type escape sequence to abort.

   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds:

   !!!!!

   Success rate is 100 percent (5/5), round-trip min/avg/max = 36/36/36 ms

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 9575