ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

ISDN を使用してブリッジするためのダイヤラプロファイルの設定

2002 年 3 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2010 年 2 月 4 日) | フィードバック

次のトポロジ内のルータをクリックすると、それぞれの設定が表示されます。
dialprofbridge

始める前に

この設定では、ISDN を経由する 2 つの異なるサイトを、サイトごとに 1 つの B チャネルを使用してブリッジングします。そのために、ダイヤラプロファイルを使用します。

ダイヤラプロファイルを使用すると、コールに必要な物理インターフェイスの設定を、論理的設定に切り離すことができます。ダイヤラプロファイルにより、論理的設定と物理的設定がコール毎に動的にバインドされます。

注:一方の B チャネルでブリッジし、もう一方の B チャネルでルーティングすることはできません。

必要事項
この方法では、ISDN サービス プロバイダーから次の情報を収集する必要があります。

  • ISDN スイッチ タイプ。

  • ISDN Service Profile Identifier(SPID; サービス プロファイル識別子)と Local Directory Number(LDN; 市内電話番号)(該当する場合)。
    日本におけるISDN環境では必要ありません。

この方法では、次のネットワーク情報も収集する必要があります。

  • Point-to-Point Protocol(PPP)ホスト名 - 両方のデバイスに PPP クライアント名を割り当てる必要があります。

  • PPP 認証タイプ - Challenge Handshake Authentication Protocol(CHAP)認証が一般的であり、この例でも CHAP を使用します。

  • PPP パスワード - すべてのロケーションに PPP パスワードを割り当てる必要があります。

  • IP アドレス情報 - IP ネットワーク設計を作成する必要があります。

  • 電話番号 - 両方のロケーションの ISDN 電話番号。

  • ユーザ名とパスワード。

ルータ 1
Current configuration:

  !

  version 11.2

  service udp-small-servers

  service tcp-small-servers

  !

  hostname Router1

  no ip routing

  !

  enable password foo

  !

  username Router2 password bar

  username Router3 password bar

  isdn switch-type basic-5ess

  !

  interface Ethernet0

   ip address 10.1.1.1 255.255.255.0

   media-type 10BaseT

   bridge-group 1

  !

  interface BRI0

   no ip address

   no ip mroute-cache

   encapsulation ppp

   no ip route-cache

   dialer pool-member 1

   ppp authentication chap

  !

  interface Dialer0

   no ip address

   no ip mroute-cache

   encapsulation ppp

   no ip route-cache

   dialer remote-name Router2

   dialer string 5552323

   dialer pool 1

   dialer-group 2

   no fair-queue

   no cdp enable

   ppp authentication chap

   bridge-group 1

  !

  interface Dialer1

   no ip address

   no ip mroute-cache

   encapsulation ppp

   no ip route-cache

   dialer remote-name Router3

   dialer string 5553434

   dialer pool 1

   dialer-group 2

   no cdp enable

   ppp authentication chap

   bridge-group 1

  !

  dialer-list 2 protocol bridge permit

  bridge 1 protocol ieee

  end

  

ルータ 2
Current configuration:

  !

  version 11.2

  service udp-small-servers

  service tcp-small-servers

  !

  hostname Router2

  no ip routing

  !

  enable password foo

  !

  username Router1 password bar

  isdn switch-type basic-5ess

  !

  interface Ethernet0

   ip address 10.1.1.2 255.255.255.0

   no ip route-cache

   bridge-group 1

  !

  interface BRI0

   no ip address

   encapsulation ppp

   no ip route-cache

   dialer pool-member 1

  !

  interface Dialer0

   no ip address

   encapsulation ppp

   no ip route-cache

   dialer remote-name Router1

   dialer string 5551212

   dialer pool 1

   dialer-group 2

   no fair-queue

   no cdp enable

   ppp authentication chap

   bridge-group 1

  !

  dialer-list 2 protocol bridge permit

  bridge 1 protocol ieee

  !

  end

  

ルータ 3
Current configuration:

  !

  version 11.2

  service udp-small-servers

  service tcp-small-servers

  !

  hostname Router3

  no ip routing

  !

  username Router1 password bar

  isdn switch-type basic-5ess

  !

  interface Ethernet0

   ip address 10.1.1.3 255.255.255.0

   no ip route-cache

   bridge-group 1

  !

  interface BRI0

   no ip address

   encapsulation ppp

   no ip route-cache

   dialer pool-member 1

   ppp authentication chap

  !

  interface Dialer0

   no ip address

   encapsulation ppp

   no ip route-cache

   dialer remote-name Router1

   dialer string 5551212

   dialer pool 1

   dialer-group 2

   no cdp enable

   ppp authentication chap

   bridge-group 1

  !

  dialer-list 2 protocol bridge permit

  bridge 1 protocol ieee

  !

  end

  

トラブルシューティングに使用する debug および show コマンド
  • debug ppp authentication - クライアントが認証を通過しているかを確認します。Cisco IOS リリース 11.2 より前のバージョンを使用している場合は、debug ppp chap コマンドを代わりに使用します。

  • debug ppp negotiation - クライアントが PPP ネゴシエーションを通過しているかを確認します。このコマンドは、アドレス ネゴシエーションをチェックする際に使用します。

  • debug ppp error - PPP 接続のネゴシエーション及びオペレーションに関するプロトコル エラーとエラー統計情報を表示します。

  • debug isdn q931 - ISDN コール時にどのような処理が行われているかを確認するために、ユーザがダイヤルインする際の ISDN 接続をチェックします(たとえば、接続が解除される場合など)。

  • show isdn status - ステータスは次のようになっている必要があります。
     layer 1 = active
    
       layer 2 = MULTIPLE_FRAMES_ESTABLISHED

    レイヤ 1 がアクティブでない場合は、配線アダプタまたはポートが不良であるか、または接続されていない可能性があります。レイヤ 2 が TEI_Assign の状態にある場合は、ルータがスイッチと通信できていません。

  • show bridge - ブリッジ フォワーディング データベース内のエントリのクラスを表示します。

  • show span - ルータにとって既知のスパニングツリー トポロジを表示します。

上記の debug コマンドを使用する前に、「Important Information on Debug Commands」を参照してください。

その他の情報

  • その他の設定について調べる場合は、「Access Dial Cookbook」の

    目次

    をチェックします。
  • 関連情報を探す場合は、索引を利用します。
  • Access-Dial Technical Tips

  • 関連するシスコ サポート コミュニティ ディスカッション

    シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


    Document ID: 6429