ダイヤルとアクセス : 非同期接続

AUX ポートによるルータの Back-To-Back 接続

2002 年 3 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2010 年 2 月 4 日) | フィードバック

目次


概要

この設定例は、モデムまたはその他の Data Communication Equipment(DCE; データ通信機器)デバイスを使用せずに 2 台のルータを直接接続する方法を示します。AUX ポートまたはコンソール ポートでモデムを設定する方法の詳細は、Modem-Router Connection Guide またはAccess-Dial Technical Tips を参照してください。

この設定では、ヌルモデム ケーブル(ロールオーバー ケーブル)を使用した非同期 AUX ポートによって、2 台の Cisco ルータが Back-To-Back 接続されています。2 台のルータの AUX ポートは、ロールオーバー ケーブルを使用して直接接続されており、そのリンク上では Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)が実行されています。AUX ポートは Data Terminal Equipment(DTE; データ端末装置)デバイスです。DTE を DTE デバイスに接続するには、ヌルモデム ケーブル(ロールオーバー ケーブル)が必要です。

フラットサテン ロールオーバー(ヌルモデム)ケーブル(部品番号 CAB-500RJ=)は通常、すべての Cisco ルータに付属しており、RJ-45 コンソール接続に対応します。AUX ポートが DB-25 の場合は、ヌルモデム ケーブル(ロールオーバー ケーブル)とともに "terminal" のラベルが付いた RJ-45-to-DB-25 アダプタを使用します。

:EIA/TIA-232(旧 RS-232)制限があるため、ケーブルの長さは 50 フィート未満にしてください。

ケーブル接続の詳細については、Cabling Guide for RJ-45 Console and AUX Ports、および RJ-45 Cables を参照してください。

DB-25 AUX ポートを備えたルータ

DB-25 AUX ポートを備えたルータ(Cisco 4500、7200、および 7500 など)の場合、DB-25-to-DB-25 ヌルモデム ケーブルが必要です。このケーブルは、大半の電子機器店で購入できます。

注:両端に RJ-45-to-DB-25 アダプタが付いているロール型 RJ-45-to-RJ-45 フラット サテン ケーブル(部品番号 CAB-25AS-MMOD)は、信号ペアが間違っているため使用できません。

DB-25-to-DB-25 ヌルモデム ケーブルに次のピン接続があることを確認してください。

DB-25
DB-25
RxD
2
3
TXD
TxD
3
2
RxD
CTS
4
5
RTS
RTS
5
4
CTS
DTR
6
20
CD
DSR
8
CD
20
6
DTR
8
DSR
GND
7
7
GND

規定

詳細については、Cisco Technical Tips Conventions を参照してください。

ネットワーク ダイアグラム

ネットワーク ダイアグラム

設定例

この接続は、固定接続をするために AUX ポート上の IP アドレスを使用して設定されています。

ルータ 1
version 11.1

      service udp-small-servers

      service tcp-small-servers

      !

      hostname Router1

      !

      interface Ethernet0

       no ip address

       shutdown

      !

      interface Serial0

       no ip address

       shutdown

      !

      interface Serial1

       no ip address

       shutdown

      !

      interface Async1

      !--- AUX ポートに対応する非同期インターフェイス

      !--- AUX ポートに対応する非同期インターフェイスを判断するには、show line コマンドを

      !--- 使用します。ip address 192.168.10.1 255.255.255.0

      !--- 両方のルータの AUX ポート上の IP アドレスは同じサブネットです。

       encapsulation ppp

      !--- PPP をカプセル化として設定します。

       async dynamic routing

      !--- リンク上のルーティング プロトコルを許可します。

       async mode dedicated

      !

      no ip classless

      ip route 0.0.0.0 0.0.0.0 Async1

  

      !--- デフォルト ルートは Async1(AUX ポート)インターフェイスを指定します。

      logging buffered

      !

      line con 0

       exec-timeout 0 0

      line aux 0

      !--- AUX ポートのライン設定

       modem InOut

       transport input all

       !--- すべてのプロトコルでラインを使用できるようにします。

       rxspeed 38400

       !--- Rx 速度を設定します。(もう一方のルータの TX 速度と同じ)

       txspeed 38400

       !--- Tx 速度を設定します。(もう一方のルータの RX 速度と同じ)

       flowcontrol hardware

      line vty 0 4

       login

      !

      end
ルータ 2
version 11.1

     

      service udp-small-servers

      service tcp-small-servers

      !

      hostname Router2

      !

      interface Ethernet0

       ip address 10.1.1.1 255.255.255.0

      !

      interface Serial0

       no ip address

       shutdown

      !

      interface Serial1

       no ip address

       shutdown

      !

      interface Async1

      !--- AUX ポートに対応する非同期インターフェイス

      !--- AUX ポートに対応する非同期インターフェイスを判断するには、show line コマンドを

      !--- 使用します。

       ip address 192.168.10.2 255.255.255.0

       !--- 両方のルータの AUX ポート上の IP アドレスは同じサブネットです。

       encapsulation ppp

       !--- PPP をカプセル化として設定します。

       async dynamic routing

       !--- リンク上のルーティング プロトコルを許可します。

       async mode dedicated

      !

      no ip classless

      ip route 0.0.0.0 0.0.0.0 Ethernet0

      !--- このデフォルト ルートはインターフェイス Ethernet0 を指定します。

      logging buffered

      !

      line con 0

       exec-timeout 0 0

      line aux 0

      !--- AUX ポートのライン設定

       modem InOut

       transport input all

      !--- すべてのプロトコルでラインを使用できるようにします。

       rxspeed 38400

      !--- Rx 速度を設定します。(もう一方のルータの TX 速度と同じ)

       txspeed 38400

      !--- Tx 速度を設定します。(もう一方のルータの RX 速度と同じ)

       flowcontrol hardware

      line vty 0 4

       login

      !

      end

デバッグ コマンドと表示コマンドによる設定のトラブルシューティング

デバッグ コマンドを発行する前に、Important Information on Debug Commands を参照してください。

  1. AUX ポートの非同期インターフェイスを判別するには、show line コマンドを使用します。大半のルータには interface async 1 として AUX ポートがありますが、アクセス サーバには tty 回線の後に AUX ポート インターフェイスがあります。たとえば、ルータに 16 の非同期またはモデム回線があり、AUX ポートは回線 17 とします。このような場合で、AUX ポートは interface async 17 と設定する必要があります。show line コマンドの出力に基づいて、AUX ポートを設定します。次の例では、ルータの AUX ポート設定が interface Async1 上にあることを確認しています。

    Router1#show line
    
          Tty Typ     Tx/Rx     A Modem  Roty AccO AccI  Uses    Noise   Overruns
    
         *  0 CTY               -    -      -    -    -     0        0        0/0
    
         A  1 AUX  38400/38400  - inout     -    -    -     0        0        0/0
    
            2 VTY               -    -      -    -    -     0        0        0/0
    
            3 VTY               -    -      -    -    -     0        0        0/0
    
            4 VTY               -    -      -    -    -     0        0        0/0
    
            5 VTY               -    -      -    -    -     0        0        0/0
    
            6 VTY               -    -      -    -    -     0        0        0/0
    
         
  2. show line aux 0 コマンドを実行します。

  3. すべての信号が動作していることを確認します(Clear To Send(CTS)、Request To Send(RTS; 送信要求)、Data Terminal Ready(DTR; データ端末レディ)、および Carrier Detect(CD; キャリア検知)など)。信号の隣に何も表示されていない場合、信号は動作しています。信号の隣に "No" が表示されている場合(No-CTS など)は、信号が停止していることを示します。信号が停止している場合は、それぞれの側の設定を確認してください。(上記のように)AUX ポートの非同期インターフェイスと回線が設定されていることを確認します。

    :show line コマンドの出力が、DSR が動作していないことを示す(noDSR)場合は、DB-25-to-DB-25 ヌルモデム ケーブルのそれぞれの側に、反対側のピン 20 に物理的に接続されたピン 6 と 8 があることを確認します。正しいピン割り当てについては、上記の表を参照してください。

    Router1#show line aux 0
    
          Tty Typ     Tx/Rx     A Modem  Roty AccO AccI  Uses    Noise   Overruns
    
         A  1 AUX  38400/38400  - inout     -    -    -     0        0        0/0
    
         
    
         Line 1, Location: "", Type: ""
    
         Length: 24 lines, Width: 80 columns
    
         Baud rate (TX/RX) is 38400/38400, no parity, 2 stopbits, 8 databits
    
         Status: Ready, Active, Async Interface Active
    
         Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
    
           Modem Callout, Modem RI is CD, Line is permanent async interface
    
         Modem state: Ready
    
         Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
    
                         ^^x    none   -     -       none
    
         Timeouts:      Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
    
                        00:10:00        never                        none     not set
    
         Modem type is unknown.
    
         Session limit is not set.
    
         Time since activation: 00:00:30
    
         Editing is enabled.
    
         History is enabled, history size is 10.
    
         Full user help is disabled
    
         Allowed transports are pad v120 telnet.  Preferred is telnet.
    
         No output characters are padded
    
         No special data dispatching characters
    
         Line is running PPP for address 192.168.10.2.
    
         0 output packets queued, 1 input packets.
    
          Async Escape map is 00000000000000000101000000000000
    
         Modem hardware state: CTS* DSR*  DTR RTS
    
         
  1. 構成設定が正しいと思われる場合は、ルータ間のロールオーバー ケーブルを交換します。

  2. 接続をリセットするには、非同期インターフェイスで shutdown コマンドと no shutdown コマンドを使用します。

    リンクが正しく起動ことを確認するには、次のデバッグ コマンドを使用します。

    • debug ppp negotiation - Link Control Protocol(LCP; リンク制御プロトコル)、認証、および Network Control Protocol(NCP)をネゴシエートするときの PPP トラフィックや交換に関する情報を表示する。正常な PPP ネゴシエーションは、LCP 状態を開いてから認証を行い、最後に NCP をネゴシエートします。CONFREQ が送信されていて、CONFACK が受信されていない場合は、ケーブル接続が正しいか、正しい回線(interface async x)が設定されているかどうかをチェックしてください。
    • debug ppp authentication - Challenge Handshake Authentication Protocol(CHAP)パケット交換や Password Authentication Protocol(PAP; パスワード認証プロトコル)交換を含む、PPP 認証プロトコル メッセージを表示する(認証が設定されている場合)。この設定では認証は設定されていないため、このデバッグ コマンドは必要ありません。
    • debug ppp error - PPP 接続ネゴシエーションと操作に関するプロトコル エラーとエラー統計を表示する。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10365