ダイヤルとアクセス : 非同期接続

アクセス サーバと PC 間の非同期 PPP コールバック

2002 年 3 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 1 月 29 日) | フィードバック

目次

概要

この構成例では、モデム非同期 PPP コールバックを示しています。コールバックは、次の目的で使用されます。

  • 電話課金の統合と集中化
  • 長距離電話のコスト削減
  • アクセス制御

クライアントは RFC 1570 leaving cisco.com で指定された PPP コールバックを使用します。PPP コールバックは、次の順序で実行します。

  1. PC ユーザ(クライアント)は、Cisco アクセス サーバに接続します。
  2. コールバック プロセスは、PPP Link Control Protocol(LCP; リンク制御プロトコル)フェーズでネゴシエートされます。
  3. PPP 認証が実行されます。
  4. Cisco IOS(R) ソフトウェアは、このユーザや回線のコールバック ルールを検証し、コールバックに備えて回線を切断します。
  5. Cisco アクセス サーバは、クライアントにダイヤルします。

ハードウェアとソフトウェアのバージョン

コールバック構成を実装するには、次のことを実行する必要があります。

Cisco IOS ソフトウェア リリース 11.0(3)以降

:Windows 95 のコールバックが機能するには、Cisco IOS ソフトウェア リリース 11.3(2)T 以降が必要です。

この文書の情報は、実環境とは独立しているラボ環境から取得されました。この情報を使用する前に、ネットワーク上でのコマンドの潜在的な影響を理解するようにしてください。

この構成は、Cisco AS5300 および Cisco IOS ソフトウェア リリース 12.0(7)T を使用してテストされました。

ネットワーク ダイアグラム
ネットワーク ダイアグラム

構成

以下の手順は、Windows 95 および Windows 95 のダイヤルアップ ネットワークを実行している PC を使用してテストされました。

maui-nas-03:コールバック サーバ(Cisco AS5300)
version 12.0

  service timestamps debug datetime msec

  service timestamps log datetime msec

  service password-encryption

  !

  hostname maui-nas-03

  !

  aaa new-model

  aaa authentication login default local

  aaa authentication ppp default local

  aaa authorization network default local

  !--- ネットワーク関連サービス要求の認証(PPP など)を実行します。

  !--- AAA サーバ実装の場合は、上記の文中で、"local" を tacacs+ または radius に

  !--- 置き換えます。

  enable secret <deleted>

  !

  username admin password <deleted>

  username austin-01 callback-dialstring 50005 password <deleted>

  username austin-02 callback-dialstring "" password <deleted>

  !-- モバイル ユーザの場合。クライアントはコールバック番号を指定します。

  !-- RADIUS サーバが使用される場合、この情報はサーバにオフロードできます。

  !

  spe 1/0 1/7

   firmware location system:/ucode/mica_port_firmware

  spe 2/0 2/7

   firmware location system:/ucode/mica_port_firmware

  !

  resource-pool disable

  !

  ip subnet-zero

  !

  isdn switch-type primary-ni

  isdn voice-call-failure 0

  chat-script mod ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 30 CONNECT \c

  !--- コールバック接続に使用されるチャット スクリプト "mod" 

  !

  chat-script offhook "" "ATH1" OK \c

  partition flash 2 24 8

  !

  controller T1 0

   framing esf

   clock source line primary

   linecode b8zs

   pri-group timeslots 1-24

   description "NAS phone number: 10001"

  !

  interface Loopback0

   ip address 172.22.87.3 255.255.255.255

   no ip directed-broadcast

  !

  interface Loopback1

    ip address 172.22.83.1  255.255.255.0

    no ip directed-broadcast

  !

  interface Ethernet0

   no ip address

   no ip directed-broadcast

   shutdown

  !

  interface Serial0:23

   no ip address

   no ip directed-broadcast

   isdn switch-type primary-ni

   isdn incoming-voice modem

  !-- ISDN 音声コールの着信が、オンボード モデムに切り替えられます。

   fair-queue 64 256 0

   no cdp enable

  !

  interface FastEthernet0

   ip address 172.22.80.3 255.255.255.0

   no ip directed-broadcast

   duplex auto

   speed auto

  !

  interface Group-Async1

   ip unnumbered Loopback0

   no ip directed-broadcast

   encapsulation ppp

   async mode interactive

   peer default ip address pool addr-pool

   ppp callback accept

  !-- group-async がリモート ホストへのコールバック要求を受け入れるようにします。

   ppp authentication pap

   group-range 1 23

  !

  router eigrp 69

   network 172.22.0.0

  !

  ip local pool addr-pool 172.22.83.2  172.22.83.24

  ip classless

  no ip http server

  !

  line con 0

   transport input none

  line 1 23

   autoselect during-login

   autoselect ppp

   script callback mod

  !--- コールバックの試行中にモデムに AT コマンドを発行するチャット スクリプトを

  !--- 指定します。

   modem InOut

   transport preferred none

   transport input all

   transport output none

  line 24 192

   transport input all

  line aux 0

  line vty 0 4

  !

  end

  

Windows クライアントの構成

Windows 95/98 クライアントの構成

Windows 95/98 の PC の場合、コールバックのためにクライアント側で特別な構成をする必要はありません。アクセス サーバが接続のコールバック機能を処理します。Windows 9x の PC は、コールバックが進行中であることを示す、「コールバックの待機中」というメッセージを表示します。

Windows NT/2000 クライアントの構成

これらのプラットフォームは、コールバックを要求するように構成する必要があります。構成するには、次の手順を使用します。

  1. [スタート] メニュー、[プログラム]、[アクセサリ]、[通信]、[ネットワークとダイヤルアップ接続] の順に選択します。

  2. [詳細設定] メニューで [ダイヤルアップの基本設定] を選択します。

  3. 次に示すコールバック機能のメニューにアクセスするには、[コールバック] タブをクリックします。

  4. コールバック機能を使用しない場合は、[コールバックしない] ボタンをクリックします。

  5. サーバからコールバックの提供があった時点で対応を決定するには、[コールバックの確認をサーバから受けてから決める] ボタンをクリックします。

  6. コールバックの提供を自動的に受け入れるには、[常に次の番号にコールバックする] ボタンをクリックして、下のリストから使用するデバイスを選択します。

  7. コールバックする電話番号を変更するには、デバイスを選択して [編集] ボタンをクリックします。

  8. 次に示すように [電話番号] フィールドに番号を入力して、[コールバック番号] ダイアログボックスの [OK] ボタンをクリックします。

  9. 完了したら、[ダイヤルアップ設定] ダイアログボックスの [OK] ボタンをクリックします。

チューニング コマンド
  • callback force-wait seconds - コールバック チャット スクリプトが発信ターゲット回線に適用される前に、さらに待機させる回線コマンド。これにより、サーバ モデム接続の時間がクリアーされます。デフォルトは 4 秒です。

  • username username [callback-dialstring phone #] [callback-line line #] [callback-rotary #] password password

    • コールバックする回線を指定するには、[callback-line line #] コマンド オプションを使用します。
    • コールバックするロータリー グループを指定するには、[callback-rotary #] コマンド オプションを使用します。

検証と簡単なトラブルシューティングのコマンド

デバッグ コマンドを発行する前に、Important Information on Debug Commands を参照してください。

デバッグ コマンドの詳細については、Debug Command Reference を参照してください。

  • debug callback - ターミナル回線でコールバックするためにルータがモデムとチャット スクリプトを使用しているときに、コールバック イベントを表示する。

  • debug modem - アクセス サーバでモデム回線のアクティビティを監視する EXEC コマンド。

  • debug ppp[ packet | negotiation | error | authentication ] - PPP を実装するインターネットワークでのトラフィックや交換に関する情報を表示する EXEC コマンド。

    • packet - 送受信される PPP パケットを表示する。(このコマンドは、下位レベルのパケット ダンプを表示します)。
    • negotiation - PPP の始動時に送信される PPP パケットを表示する。PPP パケットでは、PPP オプションがネゴシエートされます。
    • error - PPP 接続ネゴシエーションと操作に対応するプロトコル エラーとエラー統計を表示する。
    • authentication - Challenge Handshake Authentication Protocol(CHAP)パケット交換や Password Authentication Protocol(PAP; パスワード認証プロトコル)交換を含む、認証プロトコル メッセージを表示する。
  • debug chat - このシナリオでは、モデムにダイヤルアウトを指示しているときに、アクセス サーバと内部モデム間で発生するハンドシェイクを表示するために使用する。チャット スクリプトは、Data Terminal Equipment(DTE; データ端末装置)と Data Communications Equipment(DCE; データ通信機器)デバイス間のハンドシェイクを定義する、expect-send 文字列ペアのセットです。

  • debug isdn q931 - ISDN Q.931(D チャネル)のコール セットアップとティアダウンおよびデバッグ メッセージを表示する。このシナリオでは、モデム コールは Public Switched Telephone Network(PSTN; 公衆交換電話網)による音声ベアラ サービスとして実行されます。

  • debug modem csm - 内部デジタル モデムを使用してルータの Call Switching Module(CSM)問題をトラブルシューティングする EXEC コマンド。このコマンドを使用して、着信コールと発信コールの切り替えのシーケンスを完全にトレースできます。

デバッグ出力の例

Windows 95 の PC は、AS53000 にダイヤルしてコールバック プロセスを開始します。次のデバッグは、AS5300 で収集されました。

maui-nas-03#show debug

  PPP: PPP authentication debugging is on

  Chat Scripts: Chat scripts activity debugging is on

  Callback: Callback activity debugging is on

  ! -- AS5300 は Async5 上の PC 接続を受信します。

  *May 22 22:27:43.163: %LINK-3-UPDOWN: Interface Async5, changed state to up

  *May 22 22:27:43.163: As5 PPP: Treating connection as a dedicated line

  *May 22 22:27:47.275: As5 PAP: I AUTH-REQ id 1 len 20 from "Austin-01"

  *May 22 22:27:47.275: As5 PAP: Authenticating peer Austin-01 

  *May 22 22:27:47.279: As5 PAP: O AUTH-ACK id 1 Len 5

  *May 22 22:27:48.279: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async5,

   changed state to up

  ! -- コールバック プロセスが作成され、NAS はリモート クライアントを切断します。

  *May 22 22:28:03.975: TTY5 Callback PPP process creation

  *May 22 22:28:03.975: TTY5 script callback offhook automatically added to this line

  *May 22 22:28:03.975: TTY5: Callback script exists - no script creation necessary

  *May 22 22:28:03.975: TTY5 Callback process initiated, user: dialstring 50005 

  *May 22 22:28:04.659: %ISDN-6-DISCONNECT: Interface Serial0:0 disconnected

   from unknown , call lasted 54 seconds

  *May 22 22:28:04.691: %LINK-3-UPDOWN: Interface Serial0:0, changed state to down

  *May 22 22:28:04.975: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async5,

   changed state to down

  *May 22 22:28:06.975: %LINK-5-CHANGED: Interface Async5, changed state to reset

  *May 22 22:28:09.975: TTY5 Callback forced wait = 4 seconds 

  *May 22 22:28:11.975: %LINK-3-UPDOWN: Interface Async5, changed state to down 

  *May 22 22:28:13.975: CHAT5: Matched chat script offhook to string offhook

  *May 22 22:28:13.975: CHAT5: Asserting DTR

  *May 22 22:28:13.975: CHAT5: Chat script offhook started

  *May 22 22:28:13.975: CHAT5: Sending string: ATH1

  *May 22 22:28:13.975: CHAT5: Expecting string: OK

  *May 22 22:28:14.011: CHAT5: Completed match for expect: OK

  *May 22 22:28:14.011: CHAT5: Chat script offhook finished, status = Success

  !--- NAS は mod コールバック スクリプトを実行して、リモートの

  !--- Windows 95 PC クライアントに接続します。 

  *May 22 22:28:14.011: CHAT5: Matched chat script mod to string mod

  *May 22 22:28:14.011: CHAT5: Asserting DTR

  *May 22 22:28:14.011: CHAT5: Chat script mod started

  *May 22 22:28:14.015: CHAT5: Sending string: AT

  *May 22 22:28:14.015: CHAT5: Expecting string: OK

  *May 22 22:28:14.059: CHAT5: Completed match for expect: OK

  *May 22 22:28:14.059: CHAT5: Sending string: ATDT \T<50005>

  *May 22 22:28:14.059: CHAT5: Expecting string: CONNECT

  *May 22 22:28:29.927: CHAT5: Completed match for expect: CONNECT

  *May 22 22:28:29.927: CHAT5: Sending string: \c

  *May 22 22:28:29.927: CHAT5: Chat script mod finished, status = Success 

  *May 22 22:28:29.935: TTY5: Callback starting PPP directly with Invalid auth info

  *May 22 22:28:29.959: As5 PPP: Treating connection as a dedicated line

  *May 22 22:28:29.959: %LINK-3-UPDOWN: Interface Async5, changed state to up

  *May 22 22:28:33.111: As5 PAP: I AUTH-REQ id 1 Len 20 from "austin-01"

  *May 22 22:28:33.111: As5 PAP: Authenticating peer Austin-01

  *May 22 22:28:33.115: As5 PAP: O AUTH-ACK id 1 Len 5

  *May 22 22:28:34.115: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async5,

   changed state to up

  


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 9554