ダイヤルとアクセス : 非同期接続

Microsoft Windows クライアントからの非同期マルチリンク PPP ダイヤルアップ

2002 年 3 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 1 月 29 日) | フィードバック

目次


概要

Multilink PPP(MPPP; マルチリンク PPP)では、仮想リンクを実装することにより、複数のマルチプル ポイントツーポイント データ リンクを経由して、デバイスから同一の宛先へデータを送信できるようになります。MPPP 接続は、コンポーネント リンクの帯域幅の合計に等しい最大帯域幅を備えています。MPPP は、ISDN やフレーム リレー、あるいは複数の非同期回線など、多重化されたリンクへ設定することができます。

非同期マルチリンク PPP は、単一のアナログ接続を経由するよりも速い通信速度でリモート クライアントを接続する場合に使用できます。非同期 MPPP では、リモート クライアントが中央のルータにダイヤルインしてネットワークにアクセスするために複数のモデム、すなわち複数の電話回線が使用されます。複数の電話回線の方が ISDN Basic Rate Interface(BRI; 基本速度インターフェイス)サービスよりも安価であることが多いため、非同期 MPPP では、コストを抑える一方で、リモート ユーザへの接続速度を向上する効果的な方法を用意しています。また、非同期 MPPP は、ISDN でのサービスを行えない遠隔地へのアクセス速度を向上させる効率的な手段でもあります。

非同期 MPPP には、アクセス サーバへのモデム接続も別途、バンドルされています。各ピアにある PPP ソフトウェアによってパケットが細片化され、その細片が複数のアナログ接続を通じて他のサイトへ転送されます。受信側ではそれぞれの接続からパケットを収集し、これらに埋め込まれた PPP 情報に基づいて細片を正しいデータパケットに再構成します。このようにして、高い帯域幅を持つエンドツーエンドの仮想リンクが提供されます。非同期 MPPP は、2 台のルータ間、またはルータとクライアント PC 間のいずれかで設定できます。

クライアント PC からはマルチリンク接続用の 2 台以上のモデムを使用することが可能ですが、PC 上でのパケットの細分化と再構築の結果として生じるオーバーヘッドにより、得られた帯域幅の利点が失われる場合もあります。

この非同期マルチリンク PPP 設定では、Microsoft Windows 95/98 PC を使用しているリモート ダイヤルイン ユーザが、利用可能なアクセス速度を向上させるために複数のモデムを使用します。また、非同期マルチリンク PPP は、Linux や Apple Macintosh など、適切なクライアント PPP ソフトウェアを備えた他のクライアントで設定することもできます。マルチリンク PPP 用のルータ設定は、クライアント PC のプラットフォームに依存しません。

ネットワーク ダイアグラム

NAS の設定

注: この文書に記述された情報は、Cisco IOS(R) Software Release 12.07(T) が実行されている Cisco AS5300 をベースとしています。

この設定では、AS5300 サーバと T1 Primary Rate Interface(PRI; 一次群速度インターフェイス)接続が、アナログ ユーザ ダイヤルイン Network Access Server(NAS; ネットワーク アクセス サーバ)として使用されています。この NAS 上に他の T1 コントローラが設定されていないため、このアクセス サーバが非同期ダイヤルアップ専用として使用されています。この AS5300 設定では、仮想テンプレートを使用して、着信コールに対して仮想アクセス インターフェイスのクローンを作成しています。マルチリンク PPP バンドルにより、このインターフェイス パラメータが仮想テンプレート定義から複製されます

基本的な Authentication, Authorization, and Accounting(AAA; 認証、許可、アカウンティング)コマンドが、最も一般的な方法の例として含まれています。ダイヤルイン ユーザのユーザ名とパスワードは、このルータでlocalに設定します。ダイヤルイン ユーザに割り当てられる IP アドレスは、アドレス プールから提供されます。

Cisco AS5300
bobslake-nas-01#show running-config

Building configuration...



Current configuration:

!

! Last configuration change at 16:01:01 UTC Wed Jun 28 2000

! NVRAM config last updated at 15:30:28 UTC Wed Jun 28 2000

!

version 12.0

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service tcp-small-servers

!

hostname bobslake-nas-01

!

logging buffered 10000 debugging

aaa new-model

aaa authentication login default local

aaa authentication ppp default if-needed local

! -- ログイン時に認証されていない場合、PPP に対する認証を実行します。

!-- PPP を開始するためにダイヤルした後、ユーザにターミナル ウィンドウを許可します。

!

username admin password <deleted> 

username charlie password <deleted> 



spe 1/0 1/7

 firmware location system:/ucode/mica_port_firmware

!

resource-pool disable

!

ip subnet-zero

no ip source-route

ip domain-name the.net

!

multilink virtual-template 1

! -- マルチリンク接続のため、仮想テンプレート 1 を使用します。

async-bootp dns-server 172.22.53.210

isdn switch-type primary-5ess

isdn voice-call-failure 0

!

controller T1 0

 framing esf

 clock source line primary

 linecode b8zs

 pri-group timeslots 1-24

!

controller T1 1

 framing esf

 linecode b8zs

 pri-group timeslots 1-24

!

controller T1 2

 framing esf

 linecode b8zs

 pri-group timeslots 1-24

!

controller T1 3

 framing esf

 clock source line secondary 3

 linecode b8zs

 pri-group timeslots 1-24

!

interface Loopback0

 ip address 172.21.10.10 255.255.255.255

 no ip directed-broadcast

!

interface Loopback1

 ip address 172.21.104.254 255.255.255.0

! -- アドレス プールのアドレスを要約

! -- Loopback 1 は、アドレス プールと同じサブネットに属します。

 no ip directed-broadcast

!

interface Ethernet0

 no ip address

 no ip directed-broadcast

 shutdown

!

interface Virtual-Template1

 description Template for Multilink Users

 ip unnumbered Loopback0

 no ip directed-broadcast

 peer default ip address pool addr-pool

! -- 着信コールに対し、addr-pool と呼ばれる ip プールを使用します。

 ppp authentication chap

! -- チャレンジ ハンドシェイク認証プロトコル(CHAP)を使用した認証

 ppp multilink

!

! -- PRI 上で D チャネルを設定します。

interface Serial0:23

 description Headquarters 324-1939 active PRI line

 no ip address

 no ip directed-broadcast

 isdn switch-type primary-5ess

 isdn incoming-voice modem

 fair-queue 64 256 0

 no cdp enable

!

interface Serial1:23

 no ip address

 no ip directed-broadcast

 no logging event link-status

 no snmp trap link-status

 isdn switch-type primary-5ess

 isdn incoming-voice modem

 fair-queue 64 256 0

 no cdp enable

!

interface Serial2:23

 no ip address

 no ip directed-broadcast

 no logging event link-status

 no snmp trap link-status

 isdn switch-type primary-5ess

 isdn incoming-voice modem

 fair-queue 64 256 0

 no cdp enable

!

interface Serial3:23

 no ip address

 no ip directed-broadcast

 no logging event link-status

 no snmp trap link-status

 isdn switch-type primary-5ess

 isdn incoming-voice modem

 fair-queue 64 256 0

 no cdp enable

!

interface FastEthernet0

 ip address 172.21.101.23 255.255.255.0

 no ip directed-broadcast

 duplex auto

 speed auto

!

interface Group-Async1

! -- すべての非同期インターフェイス設定に対するテンプレート 

 ip unnumbered Loopback0

 no ip directed-broadcast

 encapsulation ppp

! -- PPP カプセル化を使用します。

 dialer in-band

 dialer-group 5

 async mode interactive

 peer default ip address pool addr-pool

! -- 着信コールに対し、addr-pool と呼ばれる IP プールを使用

 no fair-queue

 no cdp enable

 ppp authentication chap callin

! -- ダイヤルイン ユーザだけに対する CHAP 認証

 ppp multilink

 group-range 1 48

! -- モデム 1-48 を Group-Async 1 設定テンプレートに割り当てます。

router eigrp 1

 network 172.21.0.0

!

ip local pool addr-pool 172.21.104.1 172.21.104.48

! -- ダイヤルイン クライアントに対する IP アドレス プールを定義します。 

ip classless

no ip http server

!



access-list 105 permit ip any any

dialer-list 5 protocol ip list 105

!

line con 0

 exec-timeout 0 0

 transport input none

line 1 48

 autoselect during-login

! -- ダイヤルインの後、ユーザのログインメッセージの表示を許可します。

 autoselect ppp

! -- 回線上で自動的に PPP を起動

 modem InOut

! -- ダイヤルインとダイヤルアウトのためにモデムを使用します。

! -- NAS が着信コールだけを処理する場合、InOutDialin で置き換えます。

 transport preferred none

 transport output telnet

line aux 0

line vty 0 4

 transport preferred none

 transport input telnet

 transport output telnet

!

ntp clock-period 17180374

ntp update-calendar

ntp server 172.22.255.1 prefer

end



bobslake-nas-01#

Windows 9x クライアントの設定

次に示す手順は、Windows 9x クライアントに MPPP の設定をする場合の簡単な概略です。わかりにくい場合は、Microsoft の Web サイトleaving cisco.comを参照してください。

Microsoft Windows 9x クライアントに対して MPPP の設定を行うには、Dial Up Networking leaving cisco.comのバージョン 1.3 以降がインストールされていることを確認してください。

詳細と、Dial Up Networking(DUN; ダイヤルアップ ネットワーク)の最新バージョンのダウンロードについては、Microsoft の Web サイト leaving cisco.comを参照してください。

  1. 各モデムに対する接続と設定を個別に行います。

    Windows の [コントロール パネル] の [ハードウェアの追加] ユーティリティを使用して、このクライアントにモデムを接続します。モデムの接続の際に問題が生じた場合、トラブルシューティングの手順については PC のベンダーか Microsoft にお問い合せください。各モデムが正しく接続され、オペレーティング システムに認識されていることを確認してください。モデムが正常に動作していることを確認するには、ターミナル エミュレータも使用できます。

  2. 新規のダイヤルアップ接続を作成します。

    Windows 上で [マイ コンピュータ] のアイコンをダブルクリックし、[ダイヤルアップ ネットワーク] にナビゲートします。次に [新しい接続] をダブルクリックします。説明に従って、プライマリ モデムを使用するダイヤルアップ接続を作成します。マルチリンク機能は後で設定します。サービス プロバイダーにダイヤルして、接続をテストします。

  3. ダイヤルアップ接続にマルチリンク機能を追加します。

    [マイ コンピュータ] のアイコンをダブルクリックし、[ダイヤルアップ ネットワーク] にナビゲートします。設定した接続アイコンを右クリックします。表示されるメニューから [プロパティ] を選択します。

    [マルチリンク] タブをクリックし、[追加デバイスを使う] を選択して [追加] ボタンをクリックします。追加するモデムをドロップダウン メニューから選択し、アクセス サーバの電話番号の 7 桁だけを入力するか、表示された番号をそのまま受け入れます。追加デバイスを設定する際には、長距離電話の場合でもエリア コードを入力しないでください。この接続では、最初のモデムに対して設定されたエリア コードが自動的に使用されます。[OK] を 2 回クリックして、設定を完了します。

    Windows でのマルチリンクの設定画面を次に示します。

           

  4. アクセス サーバへのモデム接続を起動します。

    作成したダイヤルアップ接続のアイコンをダブルクリックします。ルータに設定されているユーザ名とパスワードを入力し、[接続] ボタンをクリックします。ダイヤルアップ ネットワークにより、この接続のプライマリ モデムに設定された電話番号へダイヤルされます。最初の接続が確立されると、ダイヤルアップ ネットワークは追加デバイスのリストで指定された追加モデムを使用してダイヤルを実行します。

すべての接続が確立されたら、タスクバーの [Communicating Computers] アイコンをダブルクリックしてリンクに関するステータス情報を表示するか、その接続を切断します。[Details] をクリックして、この接続に複数のデバイスが使用されたことを確認します。リスト ボックス内のデバイスを選択すると、[Suspend] または [Resume] ボタンが表示されます。[Suspend] ボタンが表示された場合、そのデバイスは現在使用中で、マルチリンク接続に「バンドル」されていることを示しています。[Suspend] ボタンをクリックしてその回線を切断し、バンドルされていた接続からその回線を除外します。[Resume] ボタンが表示された場合、これをクリックしてその接続にダイヤルし、その回線をバンドルします。この接続を破棄することなく、マルチリンクを動的に中止または再開させることができます。

検証とトラブルシューティング

MPPP 接続の検証およびトラブルシューティングを行うには、次の項目を参照してください。

  • 外線に発信する前に 9 を使用するなどのプレフィクスがクライアント PC で正確に設定されていることを確認します。これが正確に設定されていない場合、ダイヤルするとすぐに話中信号が聞こえます。
  • 各モデムに対して、個別の DUN クライアントを作成し、サービス プロバイダーに完全な接続性があることを確認します。マルチリンク接続のトラブルシューティングに進む前に、各モデムを個別に使用してください。
  • モデムへの接続を確認するために、ターミナル エミュレータを使用します。atdt コマンドを使用して、NAS の電話番号にダイヤルします。たとえば、ハイパー ターミナルの場合は atdt 55511111 と入力します。モデムから正確にダイヤルされ、NAS に接続されることを確認します。モデムから接続できない場合は、そのモデムのトラブルシューティングを行います。クライアント モデムのトラブルシューティングに関する情報については、Microsoft の Web サイトにある Using Basic AT Modem Commands leaving cisco.comを参照してください。
  • プライマリ接続が正しく接続されているが、2 番目のダイヤルアップ接続からは話中信号が聞こえる場合、その追加モデムの電話番号が DUN に正しく設定されているかどうかを確認してください。追加デバイスの設定にはエリア コードを付加しないことに注意してください。上記の Windows 9x クライアントの設定セクションを参照してください。

次のコマンドは、NAS 上で MPPP 接続のトラブルシューティングおよび検証するために使用します。

  • show ppp multilink - アクティブ状態にあるマルチリンクのバンドルに関する情報を表示。このコマンドはマルチリンク接続を検証するために使用します。

  • show caller - 個々のユーザに関する情報と、NAS 上で消費されているリソースに関する情報を表示。このコマンドでは、大規模な接続のプールに対するアクティブなコールの統計を表示し、各ユーザの絶対時間とアイドル時間を表示します。
  • show caller user - 特定のユーザに関するパラメータを表示。たとえば、使用している TTY 回線、非同期インターフェイス(シェルフ/スロット/ポート)、DS0 チャネル番号、モデム番号、割り当てられる IP アドレス、PPP および PPP のバンドル パラメータなどです。

  • debug vtemplate - 仮想アクセス インターフェイスのクローンに関する情報を仮想テンプレートでクローン化された時間から、終了までの時間についての表示。

  • debug ppp multilink events - マルチリンクのバンドルに影響を与えたイベントに関する情報を表示。

  • debug ppp negotiation - Link Control Protocol(LCP; リンク制御プロトコル)、認証、および Network Control Protocol(NCP; ネットワーク制御プロトコル)がネゴシエーションをしている間の PPP トラフィックとやり取りに関する情報を表示。成功した PPP ネゴシエーションが最初に LCP 状態をオープンし、次に認証、最後に NCP のネゴシエーションを行います。

  • debug ppp authentication - PPP 認証プロトコル メッセージを表示。これには、Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェイク認証プロトコル)のパケット交換と、Password Authentication Protocol(PAP; パスワード認証プロトコル)の交換が含まれます。

  • debug ppp error - PPP の接続ネゴシエーションや動作に関連するプロトコル エラーおよびエラーの統計を表示。

  • debug modem - アクセス サーバ上のモデムのアクティビティを表示。

show および debug の出力

AS5300 からの show および debug 出力の一部を示します。簡潔にするためにデバッグの一部を割愛しています。太字の部分と、出力内のコメントに注意してください。

発信者は認証が済むまで Async5 および Async6 に接続されていることに注意してください。発信者に対して一時的な IP アドレスがアドレス プールから与えられます。その後、その呼は仮想化され、既存の仮想バンドルに関連付けられます。これは、アクセス サーバで、発信者が確立された仮想バンドルに属しているかどうかを判別するために、発信者について知る必要があるためです。発信者がバンドルに関連付けられると、一時的な IP アドレスは削除され、発信者は仮想バンドルの IP アドレスを使用します。

bobslake-nas-01#

bobslake-nas-01#show ppp multilink



Virtual-Access1, bundle name is charlie

  0 lost fragments, 0 reordered, 0 unassigned, sequence 0x29/0x17 rcvd/sent

  0 discarded, 0 lost received, 1/255 load

  Member links: 2 (max not set, min not set)

    Async5

    Async6



! -- バンドルにより、マルチリンクのために非同期回線の 5 と 6 が使用されていることに注意します。 

bobslake-nas-01#show caller

                                                Active    Idle

  Line         User               Service       Time      Time

  con 0        admin              Host connect  1w4d      16:50:19

  tty 5        charlie             Async         00:04:34  00:01:54

  tty 6        charlie             Async         00:02:00  00:00:57

  vty 1        admin              VTY           00:13:43  00:00:00

  As5          charlie             PPP           00:04:25  00:00:00

  As6          charlie             PPP           00:01:53  00:00:00

  Vi1          charlie             PPP   Bundle  00:04:25  00:00:57



! -- charlie が非同期回線を 2 本、tty を 2 つ、および仮想インターフェイスのバンドルを 1 つ所有します。

bobslake-nas-01#show caller user charlie



  User: charlie, line tty 5, service Async

! -- ユーザ charlie に対するハードウェア レベルの設定を表示します。 (first connection)



        Active time 00:04:43, Idle time 00:00:06

  Timeouts:            Absolute  Idle      Idle

                                 Session   Exec

      Limits:          -         -         00:10:00

      Disconnect in:   -         -         -

  TTY: Line 5, running PPP on As5

! -- ユーザ charlie が tty 5 を使用します。

  DS0: (slot/unit/channel)=0/0/0

  Line: Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits

  Status: Ready, Active, No Exit Banner, Async Interface Active

          HW PPP Support Active

  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out

                Modem Callout, Modem RI is CD,

                Line usable as async interface, Integrated Modem

  Modem State: Ready



  User: charlie, line tty 6, service Async



! -- ユーザ charlie に対するハードウェア レベルの設定を表示します。 (second connection)

        Active time 00:02:09, Idle time 00:01:06

  Timeouts:            Absolute  Idle      Idle

                                 Session   Exec

      Limits:          -         -         00:10:00

      Disconnect in:   -         -         -

  TTY: Line 6, running PPP on As6

! -- ユーザ charlie が tty 6 を使用します。

  DS0: (slot/unit/channel)=0/0/1

  Line: Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits

  Status: Ready, Active, No Exit Banner, Async Interface Active

          HW PPP Support Active

  Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out

                Modem Callout, Modem RI is CD,

                Line usable as async interface, Integrated Modem

  Modem State: Ready



  User: charlie, line As5, service PPP

! -- ユーザ charlie に対する PPP 設定(最初の接続)

        Active time 00:04:34, Idle time 00:00:00

  Timeouts:            Absolute  Idle

      Limits:          -         -

      Disconnect in:   -         -

  PPP: LCP Open, multilink Open, CHAP (<- AAA)

! -- MPPP ステートがオープンします。

  Dialer: Connected, inbound

          Type is IN-BAND ASYNC, group Async5

  IP: Local 172.21.10.10

  Bundle: Member of charlie, last input 00:00:00

  Counts: 54 packets input, 4110 bytes, 0 no buffer

          1 input errors, 1 CRC, 0 frame, 0 overrun

          73 packets output, 4150 bytes, 0 underruns

          0 output errors, 0 collisions, 0 interface resets

! -- パケットが接続を通して送られます。

  User: charlie, line As6, service PPP

! -- ユーザ charlie に対する PPP 設定(2 番目の接続)

        Active time 00:02:02, Idle time 00:00:00

  Timeouts:            Absolute  Idle

      Limits:          -         -

      Disconnect in:   -         -

  PPP: LCP Open, multilink Open, CHAP (<- AAA)

! -- MPPP ステートがオープンします。

  Dialer: Connected, inbound

          Type is IN-BAND ASYNC, group Async6

  IP: Local 172.21.10.10

  Bundle: Member of charlie, last input 00:00:00

  Counts: 6 packets input, 462 bytes, 0 no buffer

          1 input errors, 1 CRC, 0 frame, 0 overrun

          20 packets output, 1129 bytes, 0 underruns

          0 output errors, 0 collisions, 0 interface resets

! -- パケットが接続を通して送られます。

  

  User: charlie, line Vi1, service PPP Bundle



! -- ユーザ charlie のバンドル情報

        Active time 00:04:34, Idle time 00:00:06

  Timeouts:            Absolute  Idle

      Limits:          -         -

      Disconnect in:   -         -

  PPP: LCP Open, multilink Open, IPCP

  IP: Local 172.21.104.254, remote 172.21.104.2

! -- リモートの IP アドレスを IP プールから取得します。

  Counts: 50 packets input, 4034 bytes, 0 no buffer

          0 input errors, 0 CRC, 0 frame, 0 overrun

          80 packets output, 8750 bytes, 0 underruns

          0 output errors, 0 collisions, 0 interface resets

 

bobslake-nas-01#debug vtemplate 

Virtual Template debugging is on

bobslake-nas-01#debug ppp multilink events

Multilink events debugging is on

bobslake-nas-01#debug ppp negotiation

PPP protocol negotiation debugging is on

bobslake-nas-01#debug ppp authentication

PPP authentication debugging is on

bobslake-nas-01#debug ppp error 

PPP protocol errors debugging is on

bobslake-nas-01#debug modem

Modem control/process activation debugging is on

bobslake-nas-01#show debug

General OS:

  Modem control/process activation debugging is on

PPP:

  PPP authentication debugging is on

  PPP protocol errors debugging is on

  PPP protocol negotiation debugging is on

  Multilink events debugging is on

VTEMPLATE:

  Virtual Template debugging is on
bobslake-nas-01#

Jun 28 15:41:46.281 UTC: TTY5: DSR came up

Jun 28 15:41:46.281 UTC: tty5: Modem: IDLE->(unknown)

! -- 

モデムが最初のダイヤルイン接続に応答します。

Jun 28 15:41:46.281 UTC: TTY5: EXEC creation

...

Jun 28 15:41:48.537 UTC: TTY5 Autoselect cmd:  ppp negotiate

Jun 28 15:41:48.537 UTC: TTY5: EXEC creation

...

Jun 28 15:41:48.545 UTC: As5 IPCP: Install route to 172.21.104.4

! -- 最初のリンクに対する IP アドレスをアドレス プールから取得します。

! -- 後でリンクが仮想化されたとき、ルートは削除されます。 

Jun 28 15:41:50.541 UTC: As5 PPP: Treating connection as a callin

Jun 28 15:41:50.541 UTC: As5 PPP: Phase is ESTABLISHING, Passive Open

Jun 28 15:41:50.541 UTC: As5 LCP: State is Listen

! -- LCP ネゴシエーション開始

Jun 28 15:41:51.549 UTC: As5 LCP: I CONFREQ [Listen] id 3 len 46

...

Jun 28 15:41:51.549 UTC: Unthrottle 5

Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREQ [Listen] id 1 len 47

...

Jun 28 15:41:51.549 UTC: As5 LCP: O CONFREJ [Listen] id 3 len 7

...

Jun 28 15:41:53.549 UTC: As5 LCP: O CONFREQ [REQsent] id 2 len 47

Jun 28 15:41:53.549 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)

Jun 28 15:41:53.549 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)

Jun 28 15:41:53.549 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)

Jun 28 15:41:53.549 UTC: As5 LCP:    PFC (0x0702)

Jun 28 15:41:53.549 UTC: As5 LCP:    ACFC (0x0802)

Jun 28 15:41:53.549 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

! -- Max-Receive-Reconstructed-Unit:ピアが再構築できるパケットの最大サイズ

! -- 両サイドでのパケットサイズへの合意が必要です。(MRRU)

Jun 28 15:41:53.549 UTC: As5 LCP:    EndpointDisc 1 Local

Jun 28 15:41:53.549 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)

Jun 28 15:41:53.549 UTC: As5 LCP:     (0x3031)

Jun 28 15:41:53.789 UTC: As5 LCP: I CONFACK [REQsent] id 2 len 47

Jun 28 15:41:53.789 UTC: As5 LCP:    ACCM 0x000A0000 (0x0206000A0000)

Jun 28 15:41:53.789 UTC: As5 LCP:    AuthProto CHAP (0x0305C22305)

Jun 28 15:41:53.789 UTC: As5 LCP:    MagicNumber 0x56E3C73E (0x050656E3C73E)

Jun 28 15:41:53.789 UTC: As5 LCP:    PFC (0x0702)

Jun 28 15:41:53.789 UTC: As5 LCP:    ACFC (0x0802)

Jun 28 15:41:53.789 UTC: As5 LCP:    MRRU 1524 (0x110405F4)

! -- Max-Receive-Reconstructed-Unit :ピアが再構築できるパケットの最大サイズ

Jun 28 15:41:53.789 UTC: As5 LCP:    EndpointDisc 1 LocalJun 28 15:41:53.789 UTC: As5 LCP:     (0x131201626F62736C616B652D6E61732D)

Jun 28 15:41:53.789 UTC: As5 LCP:     (0x3031)

Jun 28 15:41:54.541 UTC: As5 LCP: I CONFREQ [ACKrcvd] id 4 len 46

...

Jun 28 15:41:54.541 UTC: As5 LCP: O CONFREJ [ACKrcvd] id 4 len 7

...

Jun 28 15:41:54.717 UTC: As5 LCP: I CONFREQ [ACKrcvd] id 5 len 43

...

Jun 28 15:41:54.717 UTC: As5 LCP: O CONFACK [ACKrcvd] id 5 len 43

...

Jun 28 15:41:54.721 UTC: As5 LCP: State is Open

! -- LCP ネゴシエーションが完了 

Jun 28 15:41:54.721 UTC: As5 PPP: Phase is AUTHENTICATING, by this end

! -- CHAP 認証開始

Jun 28 15:41:54.721 UTC: As5 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"

Jun 28 15:41:54.909 UTC: As5 CHAP: I RESPONSE id 1 len 27 from "charlie"

Jun 28 15:41:54.909 UTC: As5 CHAP: O SUCCESS id 1 len 4

! --- CHAP 認証が成功します。

Jun 28 15:41:54.909 UTC: As5 MLP: Multilink up event pending

Jun 28 15:41:54.913 UTC: As5 PPP: Phase is VIRTUALIZED

! -- 認証の後、コールを仮想化   

Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Reuse Vi1, recycle queue size 0

Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Hardware address 0010.7b4d.7046

Jun 28 15:41:54.913 UTC: Vi1 PPP: Phase is DOWN, Setup

Jun 28 15:41:54.913 UTC: Vi1 MLP: VP: Clone from Vtemplate 1 block=1

Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Has a new cloneblk vtemplate, now it hae

Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: ************* CLONE VACCESS1 ***********

Jun 28 15:41:54.913 UTC: Vi1 VTEMPLATE: Clone from Virtual-Template1

! -- 仮想テンプレートからのクローン化

interface Virtual-Access1

default ip address

no ip address

encap ppp

description Template for Multilink Users

ip unnumbered Loopback0

no ip directed-broadcast

no logging event link-status

no snmp trap link-status

peer default ip address pool addr-pool

ppp authentication chap

ppp multilink

ip unnum loop 1

end

Jun 28 15:41:55.005 UTC: Vi1 PPP: Treating connection as a dedicated line

Jun 28 15:41:55.005 UTC: Vi1 PPP: Phase is ESTABLISHING, Active Open

Jun 28 15:41:55.005 UTC: Vi1 LCP: O CONFREQ [Closed] id 1 len 37

...

Jun 28 15:41:55.009 UTC: Vi1 PPP: Phase is UP

Jun 28 15:41:55.009 UTC: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10

Jun 28 15:41:55.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)

Jun 28 15:41:55.009 UTC: As5 MLP: charlie, multilink up, first link

! -- ユーザ charlie に対するマルチリンク バンドルでの最初のリンクが活動化します。

Jun 28 15:41:55.009 UTC: As5 IPCP: Remove route to 172.21.104.4

! -- リンクが仮想化されたため、最初のリンクのテンポラリ ルートを削除します。

Jun 28 15:41:55.069 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 40

...

Jun 28 15:41:55.069 UTC: Vi1 IPCP: Pool returned 172.21.104.2

! -- 仮想バンドルの IP アドレスをアドレス プールから取得します。

Jun 28 15:41:55.069 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 1 len 22

...

Jun 28 15:41:55.085 UTC: Vi1 CCP: I CONFREQ [Not negotiated] id 1 len 15

Jun 28 15:41:55.085 UTC: Vi1 CCP:    MS-PPC supported bits 0x00000001 (0x120600)

...

Jun 28 15:41:55.181 UTC: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10

Jun 28 15:41:55.181 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)

Jun 28 15:41:57.009 UTC: Vi1 IPCP: TIMEout: State ACKrcvd

Jun 28 15:41:57.009 UTC: Vi1 IPCP: O CONFREQ [ACKrcvd] id 2 len 10

Jun 28 15:41:57.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)

Jun 28 15:41:59.009 UTC: Vi1 IPCP: TIMEout: State REQsent

Jun 28 15:41:59.009 UTC: Vi1 IPCP: O CONFREQ [REQsent] id 3 len 10

Jun 28 15:41:59.009 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)

Jun 28 15:41:59.617 UTC: Vi1 IPCP: I CONFREQ [REQsent] id 2 len 34

...

Jun 28 15:41:59.617 UTC: Vi1 IPCP: O CONFREJ [REQsent] id 2 len 16

...

Jun 28 15:41:59.633 UTC: Vi1 PPP: Replace IPCP code 2 id 3 with id 3

Jun 28 15:41:59.633 UTC: Vi1 IPCP: I CONFACK [REQsent] id 3 len 10

Jun 28 15:41:59.633 UTC: Vi1 IPCP:    Address 172.21.104.254 (0x0306AC1568FE)

Jun 28 15:41:59.777 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 3 len 22

...

Jun 28 15:41:59.777 UTC: Vi1 IPCP: O CONFNAK [ACKrcvd] id 3 len 22

...

Jun 28 15:41:59.937 UTC: Vi1 IPCP: I CONFREQ [ACKrcvd] id 4 len 22

Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 (0x0306AC156802)

! -- 仮想バンドルの IP アドレスを前もってアドレス プールから取得します。

Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)

Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)

Jun 28 15:41:59.937 UTC: Vi1 IPCP: O CONFACK [ACKrcvd] id 4 len 22

Jun 28 15:41:59.937 UTC: Vi1 IPCP:    Address 172.21.104.2 (0x0306AC156802)

Jun 28 15:41:59.937 UTC: Vi1 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)

Jun 28 15:41:59.937 UTC: Vi1 IPCP:    SecondaryDNS 171.68.10.70 (0x8306AB440A46)

Jun 28 15:41:59.937 UTC: Vi1 IPCP: State is Open

Jun 28 15:41:59.941 UTC: Vi1 IPCP: Install route to 172.21.104.2

! -- 仮想バンドルへのルートをルーティング テーブルに追加します。

Jun 28 15:42:44.383 UTC: TTY51: timer type 1 expired

Jun 28 15:42:44.383 UTC: TTY51:  Exec timer (continued)

! -- マルチリンク接続のためにモデムが始動します。

Jun 28 15:44:20.385 UTC: TTY6: DSR came up

! -- 2 番目の接続のために Async 6 が使用されます。

Jun 28 15:44:20.385 UTC: tty6: Modem: IDLE->(unknown)

Jun 28 15:44:20.385 UTC: TTY6: EXEC creation

...

Jun 28 15:44:20.529 UTC: TTY6 Autoselect cmd:  ppp negotiate

Jun 28 15:44:20.529 UTC: TTY6: EXEC creation

...

Jun 28 15:44:20.661 UTC: As6 IPCP: Install route to 172.21.104.5

! -- 2 番目のリンクに対する IP アドレスをアドレス プールから取得します。

! -- リンクが MPPP バンドルに追加されたとき、ルートは削除されます。

Jun 28 15:44:22.661 UTC: As6 PPP: Treating connection as a callin

Jun 28 15:44:22.661 UTC: As6 PPP: Phase is ESTABLISHING, Passive Open

! -- LCP ネゴシエーション開始

Jun 28 15:44:22.661 UTC: As6 LCP: State is Listen

Jun 28 15:44:23.521 UTC: As6 LCP: I CONFREQ [Listen] id 2 len 46

...

Jun 28 15:44:23.525 UTC: Unthrottle 6

Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREQ [Listen] id 1 len 47

...

Jun 28 15:44:23.525 UTC: As6 LCP: O CONFREJ [Listen] id 2 len 7

Jun 28 15:44:23.525 UTC: As6 LCP:    Callback 6  (0x0D0306)

Jun 28 15:44:25.525 UTC: As6 LCP: TIMEout: State REQsent

Jun 28 15:44:25.525 UTC: As6 LCP: O CONFREQ [REQsent] id 2 len 47

...

Jun 28 15:44:25.765 UTC: As6 LCP: I CONFACK [REQsent] id 2 len 47

...

Jun 28 15:44:26.533 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 3 len 46

...

Jun 28 15:44:26.533 UTC: As6 LCP: O CONFREJ [ACKrcvd] id 3 len 7

Jun 28 15:44:26.533 UTC: As6 LCP:    Callback 6  (0x0D0306)

Jun 28 15:44:26.741 UTC: As6 LCP: I CONFREQ [ACKrcvd] id 4 len 43

...

Jun 28 15:44:26.741 UTC: As6 LCP: O CONFACK [ACKrcvd] id 4 len 43

...

Jun 28 15:44:26.741 UTC: As6 LCP: State is Open

! -- LCP ネゴシエーション完了 

! -- CHAP 認証開始

Jun 28 15:44:26.745 UTC: As6 PPP: Phase is AUTHENTICATING, by this end

Jun 28 15:44:26.745 UTC: As6 CHAP: O CHALLENGE id 1 len 36 from "bobslake-nas-01"

Jun 28 15:44:26.981 UTC: As6 CHAP: I RESPONSE id 1 len 27 from "charlie"

Jun 28 15:44:26.981 UTC: As6 CHAP: O SUCCESS id 1 len 4

! -- CHAP 認証が成功します。

Jun 28 15:44:26.981 UTC: As6 MLP: Multilink up event pending

Jun 28 15:44:26.981 UTC: As6 PPP: Phase is VIRTUALIZED

! -- リンクが仮想化

Jun 28 15:44:26.985 UTC: As6 MLP: charlie, multilink up

! -- マルチリンク接続が活動化します。

Jun 28 15:44:26.985 UTC: As6 IPCP: Remove route to 172.21.104.5

! -- 前もってバンドルに割り当てられた IP アドレスを使用します。(この場合、172.21.104.2)

bobslake-nas-01#


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 9553