ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

シリアル回線のバックアップとしての非同期インターフェイスの設定

2003 年 12 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 9 月 14 日) | フィードバック

目次


概要

一般に、WAN 回線には、ダイヤルオンデマンド(DDR)回路を持つシリアル、専用回線、フレームリレーなどの冗長なパスを使用します。通常、非同期モデムおよび回線交換一般電話サービス(POTS)回線は WAN インターフェイスのバックアップに使用します。ダイヤル バックアップ シナリオは注意深く設計する必要があります。バックアップ リンクのトラフィック、障害が発生しやすいリンクの数、バックアップ回線をサポートするためのポート容量の計画などの要素を考慮する必要があります。

WAN リンクをバックアップするには、一般に次の 3 つの方法を使用します。

  • バックアップ インターフェイス:バックアップ インターフェイスは、プライマリ リンクがダウンするまでスタンバイ状態のままです。その後バックアップ リンクがアクティブになり、2 つのサイト間の接続を再確立します。
  • ダイヤラ監視:ダイヤラ監視は、セントラル ルータで発信コールをトリガーするための対象トラフィックの定義だけに依存することなく、信頼性の高い接続を提供します。ダイヤラ監視は特定のルートを監視し、それらのネットワークに到達不能になるとセカンダリ リンクを始動します。
  • フローティングスタティック ルート:フローティングスタティック ルートは、アドミニストレーティブ ディスタンスがダイナミック ルートのアドミニストレーティブ ディスタンスより大きいスタティック ルートです。アドミニストレーティブ ディスタンスはスタティック ルートで設定できるため、スタティック ルートよりダイナミック ルートの方が有効です。したがって、ダイナミック ルートが使用可能な場合はスタティック ルートは使用しません。しかし、ダイナミック ルートが失われた場合は、スタティック ルートがその役割を引き継ぎ、この代替ルートでトラフィックを送信できます。

このシナリオでは、バックアップ インターフェイスを使用して、バックアップを実行します。バックアップ インターフェイスの詳細については、DDR バックアップ インターフェイス、フローティング スタティック ルート、およびダイヤラ ウォッチの比較を参照してください。

バックアップ インターフェイスの設定については、DDR バックアップの設定およびトラブルシューティング(English)を参照してください。
この文書には、バックアップ方法の選択方法や設定情報が記載されています。

以下の設定情報に進む前に、この 2 つの文書を読むことを推奨します。

設定

このセクションでは、この文書に記載した機能を設定するための情報を示します。

注: この文書で使用しているコマンドについては、IOS 文書検索ツールを使用してください。このツールへのリンクは、この文書のツール情報のセクションに記載されています。

この設定で使用するコンポーネント

この設定は、次のバージョンのソフトウェアおよびハードウェアを使用して開発およびテストされています。

  • Cisco 2500 ルータ プラットフォーム

  • ルータ gaugin では Cisco IOS® ソフトウェア リリース 12.1(2)T

  • ルータ sphinx では Cisco IOS ソフトウェア リリース 12.0(7)

  • ルータのシリアル ポートに接続した外部モデム

: ルータと非同期インターフェイス(または内蔵モデム)を使用する場合、この文書の情報に変更が必要になる場合があります。バックアップ インターフェイス(この例ではシリアル 2 インターフェイス)の設定は、"interface Async x" になります。

この文書に示す情報は、特定の研究環境のデバイスから作成されたものです。この文書で使用しているすべてのデバイスは、クリアな(デフォルトの)設定で開始されました。実際に稼動しているネットワークで行う場合は、コマンドが及ぼす影響について理解してからコマンドを使用してください。

ネットワークダイヤグラム

設定

この設定では、2 台の Cisco ルータ(gaugin および sphinx)を使用し、これらをシリアル 0 インターフェイスによって専用回線経由で接続します。シリアル 2 インターフェイスは、公衆電話交換網(PSTN)回線を経由して非同期モデムで接続し、専用回線のバックアップとして使用します。

注: デフォルトでは、これらのインターフェイスは同期モードで動作します。したがって、非同期モードで動作させる場合には、physical-layer async コマンドを実行して、非同期モードでの実行を設定する必要があります。

show version コマンドを使用すると、これらのインターフェイスが非同期モードで動作しているかどうかを確認できます。これに関連して show version コマンドで表示される情報を次に示します。

2 Low-speed serial(sync/async) network interfaces

 ! --- 非同期モードで動作中

設定が終わったら、モデム接続が可能なことを確認してください。これを行うには、モデムに逆 telnet し、いくつかのリモート モデムを呼び出します。

注: モデム タイプに応じてモデム機能(modemcap)も使用する必要があります。 詳細については、モデム-ルータ間接続ガイドを参照してください。

gaugin (Cisco 2500) - 呼び出し側ルータ
gaugin#show running-config
Building configuration...
Current configuration:

 hostname gaugin
username sphinx password 0 cisco

 !-- CHAP 認証のユーザ名と共有秘密情報

 !

 chat-script CALLOUT "" "atdt\T" TIMEOUT 60 CONNECT \c

 ! -- ダイヤルアウトに使用する chat スクリプト

 modemcap entry usr:MSC=&FS0=1&C1&D2&H1&R2&B1&W

 ! -- 外部モデム用 modemcap

 ! -- 詳細についてはモデム-ルータ間接続ガイドを参照してください。

 interface Loopback1

 ip address 1.1.1.1 255.255.255.255

 !

 interface Serial0

 ! -- プライマリ リンク

  ip address 3.3.3.1 255.255.255.0

 ! -- リモート ピア シリアル インターフェイスが同じサブネット内に存在します

  backup interface serial 2

 ! -- シリアル 2 インターフェイスをバックアップ インターフェイスに指定します

 !

 interface Serial2

 ! -- バックアップ インターフェイス。

 
! -- このインターフェイスは、シリアル(プライマリ)インターフェイスの回線プロトコル ! -- が停止するまでスタンバイ状態になります。
physical-layer async ! -- 非同期モードを許可 ip unnumbered Loopback1 encapsulation ppp dialer in-band dialer map ip 2.2.2.1 name sphinx modem-script CALLOUT 8029 ! -- ピアのダイヤラ マップ。IP アドレス、名前(認証されたユーザ名と一致)、 ! -- ダイヤルに使用された chat スクリプトと番号に注意してください dialer-group 1 ! -- ダイヤルアウトの対象トラフィックを定義します async mode dedicated no peer default ip address ! -- ピアに IP アドレスを指定しません。これは、すでに設定されています。 no fair-queue ppp authentication chap callin ! -- 一方向の chap 認証を使用します
! ip route 2.2.2.1 255.255.255.255 Serial0 ip route 2.2.2.1 255.255.255.255 Serial2 ! -- ピアの同等ルート。IP アドレスとダイヤラ マップ IP が一致しています。 ! -- プライマリがアップすると、バックアップがスタンバイ状態になります。 ! -- シリアル 2 を使用したルートは使用されません。バックアップがスタンバイ状態から抜けると、 ! -- シリアル 2 が使用され、シリアル 0 は削除される(リンクが down/down のため) ! -- 他のネットワークのルートを作成するには、ip route <network> <mask> 2.2.2.1を実行。
dialer-list 1 protocol ip permit

 ! -- 対象トラフィックの定義。 バックアップがスタンバイ状態から抜けると、

 ! -- ルータが対象トラフィックを受信した後で、ダイヤルアウトだけが開始します。
line 2

 ! -- シリアル 2 インターフェイスのモデムの回線設定

 script dialer CALLOUT

 ! -- CALLOUT スクリプトを使用

 modem InOut

 modem autoconfigure type usr

 ! --設定済みの "usr" を指定して modemcap を実行します

 transport input all

 speed 115200

 ! -- DTE-DCE 速度

 flowcontrol hardware
sphinx (Cisco 2500) - 呼び出し先ルータ
sphinx#show running-config
Building configuration...
Current configuration:

 !

 version 12.0

 service timestamps debug uptime

 service timestamps log uptime

 no service password-encryption

 !

 hostname sphinx

 username gaugin password 0 cisco

 !-- CHAP 認証のユーザ名と共有秘密情報

 modemcap entry usr:MSC=&FS0=1&C1&D2&H1&R2&B1&W

 !

 interface Loopback1

 ip address 2.2.2.1 255.255.255.255

 no ip directed-broadcast

 !

 interface Serial0

 ! -- プライマリ インターフェイス

 ! -- プライマリに障害が発生するまで、ルータはバックアップを開始しません。

 ! -- 接続の開始はピアに依存します

 ip address 3.3.3.2 255.255.255.0

 !

 interface Serial2

 ! -- バックアップ用インターフェイス

 ! -- 呼び出しのみを受け入れるため、ダイヤラ マップ/ダイヤラ ストリングは存在しません

 ! -- このインターフェイスは、プライマリ実行時に Up/Up(スプーフィング)モデムになります。

 ! -- パケットの消失を防ぐために、フローティングスタティック ルートを設定する必要があります

 physical-layer async

 ip unnumbered Loopback1

 no ip directed-broadcast

 encapsulation ppp

 dialer in-band

 dialer-group 1

 async mode dedicated

 no peer default ip address

 no fair-queue

 no cdp enable

 ppp authentication chap

 
ip route 1.1.1.1 255.255.255.255 Serial0

 ip route 1.1.1.1 255.255.255.255 Serial2 2 

 
! -- 2 の指定により、ルートがフローティングスタティックになります。 ! -- 非同期インターフェイスは、プライマリの実行中スプーフィング モードになるため、 ! -- この設定は重要です。 ! -- ここで 2 を設定しないと、リターン パスのパケットの半分を失うことになります。 ! -- これは、ルータが 2 つのリンク間で負荷分散を行うためです。 ! -- 負荷分散はバックアップがダウンしていても実行されます。 ! -- 他のネットワークのルートを作成するには、ip route <network> <mask> 1.1.1.1を実行します。 line 2 modem InOut modem autoconfigure type usr transport input all speed 115200 flowcontrol hardware

検証

このセクションでは、設定が正常に機能しているかどうかを確認するための情報について説明します。

出力インタープリタ ツールでは特定の show コマンドがサポートされており、show コマンドの出力を分析表示できます。このツールへのリンクは、この文書のツール情報のセクションを参照してください。

  • show interface serial:シリアル インターフェイスに関する情報を表示する。

  • show ip route :ルーティング テーブルの現在のステートを表示する。

  • show line:端末回線のパラメータを表示する。

トラブルシューティング

このセクションでは、設定のトラブルシューティングに使用できる情報について説明します。

バックアップ インターフェイスのトラブルシューティングについては、DDR バックアップの設定およびトラブルシューティング(English)を参照してください。

トラブルシューティング コマンド

上記のセクションで説明した show コマンドに加え、次のコマンドも設定のトラブルシューティングに使用できます。

注:上記の debug コマンドを実行する前に、デバッグ コマンドに関する重要事項を参照してください。

  • show dialer :ダイヤラ インターフェイスに関する情報を表示する。

  • ping:接続をテストする。

  • debug modem :アクセス サーバのモデム回線のアクティビティを監視する。

  • debug ppp negotiation:PPP トラフィックに関する情報を表示するとともに、リンク制御プロトコル(LCP)、認証、およびネットワーク制御プロトコル(NCP)などの PPP コンポーネントとのネゴシエーションに関する情報を表示する。PPP ネゴシエーションに成功すると、最初に LCP ステートがオープンされ、認証が行われ、最後に NCP とのネゴシエートが行われます。

  • debug ppp authentication:Challenge Authentication Protocol(CHAP)パケットの交換やパスワード認証プロトコル(PAP)交換などの PPP 認証プロトコル メッセージを表示する。障害が発生している場合は、chap ユーザ名およびパスワードが正しく設定されていることを確認してください。

  • debug chat :チャット スクリプトのアクティビティを表示する。
  • debug dialer :ダイヤラ インターフェイスで受信したパケットに関する DDR デバッグ情報を表示する。

上記の出力例では、gaugin(呼び出し先のルータ)のメイン シリアル接続(シリアル 0) に問題が発生し、接続が切断されたため、バックアップ インターフェイス(シリアル 2)が起動し、バックアップ接続が開始しています。この例では、バックアップ リンクをテストするために、ケーブルを外しています。

注意: プライマリ インターフェイスで shutdown コマンドを実行しても、バックアップはダイヤルを実行しません。シャットダウン コマンドを発行してプライマリ接続を停止した場合、Cisco IOSソフトウェアは、バックアップ接続を自動的に開始しません。バックアップ インターフェイスを開始するには、ケーブルを取り外すか、または同等の方法でプライマリ接続を物理的に切断する必要があります。

   gaugin#

    *Mar 1 00:57:25.127: %LINK-3-UPDOWN: Interface Serial0, changed state to down

    *Mar 1 00:57:26.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,

     changed state to down

     ! -- プライマリ リンクが停止。

     ! -- バックアップ リンク(シリアル 2 インターフェイス)がスタンバイ状態から抜けます

    *Mar 1 00:57:37.143: %LINK-3-UPDOWN: Interface Serial2, changed state to down

    ! -- バックアップ リンクがスタンバイ状態から停止状態になります

    *Mar 1 00:57:37.147: Se2 LCP: State is Closed..

    *Mar 1 00:57:40.019: TTY2: restoring DTR

    *Mar 1 00:57:41.019: TTY2: autoconfigure probe started

    *Mar 1 00:57:52.147: Se2 DDR: re-enable timeout.

    *Mar 1 00:57:55.067: Se2 DDR: Dialing cause ip (s=1.1.1.1, d=2.2.2.1)

    ! -- ピアの対象トラフィックにより、ダイヤルアウトが実行されます

    *Mar 1 00:57:55.071: Se2 DDR: Attempting to dial 8029

    *Mar 1 00:57:55.071: CHAT2: Attempting async line dialer script

    *Mar 1 00:57:55.075: CHAT2: Dialing using Modem script: CALLOUT & System

     script: none

    ! -- CALLOUT という名前の chat スクリプトを使用

    *Mar 1 00:57:55.083: CHAT2: process started

    *Mar 1 00:57:55.083: CHAT2: Asserting DTR

    *Mar 1 00:57:55.087: CHAT2: Chat script CALLOUT started

    *Mar 1 00:57:55.087: CHAT2: Sending string: atdt\T<8029>

    *Mar 1 00:57:55.091: CHAT2: Expecting string: CONNECT.........

    *Mar 1 00:58:12.859: CHAT2: Completed match for expect: CONNECT

    *Mar 1 00:58:12.859: CHAT2: Sending string: \c

    *Mar 1 00:58:12.863: CHAT2: Chat script CALLOUT finished, status = Success

    *Mar 1 00:58:12.867: TTY2: no timer type 1 to destroy

    *Mar 1 00:58:12.867: TTY2: no timer type 0 to destroy

    *Mar 1 00:58:12.875: Se2 IPCP: Install route to 2.2.2.1.

    *Mar 1 00:58:14.871: %LINK-3-UPDOWN: Interface Serial2, changed state to up

        Dialer state change to up Serial2 Dialer call has been placed Serial2

    *Mar 1 00:58:14.891: Se2 PPP: Treating connection as a callout

     ! -- PPP LCP ネゴシエーションが開始します

    *Mar 1 00:58:14.891: Se2 PPP: Phase is ESTABLISHING, Active Open

    *Mar 1 00:58:14.895: Se2 PPP: No remote authentication for call-out

    *Mar 1 00:58:14.899: Se2 LCP: O CONFREQ [Closed] id 10 len 20

    *Mar 1 00:58:14.899: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    *Mar 1 00:58:14.903: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)

    *Mar 1 00:58:14.907: Se2 LCP: PFC (0x0702)

    *Mar 1 00:58:14.907: Se2 LCP: ACFC (0x0802).

    *Mar 1 00:58:16.895: Se2 LCP: TIMEout: State REQsent

    *Mar 1 00:58:16.899: Se2 LCP: O CONFREQ [REQsent] id 11 len 20

    *Mar 1 00:58:16.899: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    *Mar 1 00:58:16.903: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)

    *Mar 1 00:58:16.907: Se2 LCP: PFC (0x0702)

    *Mar 1 00:58:16.907: Se2 LCP: ACFC (0x0802)

    *Mar 1 00:58:17.063: Se2 LCP: I CONFACK [REQsent] id 11 len 20

    *Mar 1 00:58:17.067: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    *Mar 1 00:58:17.067: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)

    *Mar 1 00:58:17.071: Se2 LCP: PFC (0x0702)

    *Mar 1 00:58:17.075: Se2 LCP: ACFC (0x0802)

    *Mar 1 00:58:17.083: Se2 LCP: I CONFREQ [ACKrcvd] id 32 len 25

    *Mar 1 00:58:17.083: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    *Mar 1 00:58:17.087: Se2 LCP: AuthProto CHAP (0x0305C22305)

    *Mar 1 00:58:17.091: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)

    *Mar 1 00:58:17.095: Se2 LCP: PFC (0x0702)

    *Mar 1 00:58:17.095: Se2 LCP: ACFC (0x0802)

    *Mar 1 00:58:17.099: Se2 LCP: O CONFACK [ACKrcvd] id 32 len 25

    *Mar 1 00:58:17.103: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    *Mar 1 00:58:17.103: Se2 LCP: AuthProto CHAP (0x0305C22305)

    *Mar 1 00:58:17.107: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)

    *Mar 1 00:58:17.111: Se2 LCP: PFC (0x0702)

    *Mar 1 00:58:17.111: Se2 LCP: ACFC (0x0802)

    *Mar 1 00:58:17.115: Se2 LCP: State is Open

     ! -- LCP ネゴシエーションが完了します

    *Mar 1 00:58:17.115: Se2 PPP: Phase is AUTHENTICATING, by the peer

    *Mar 1 00:58:17.263: Se2 CHAP: I CHALLENGE id 4 len 27 from "sphinx"

    *Mar 1 00:58:17.271: Se2 CHAP: O RESPONSE id 4 len 27 from "gaugin"

    *Mar 1 00:58:17.391: Se2 CHAP: I SUCCESS id 4 len 4

    *Mar 1 00:58:17.395: Se2 PPP: Phase is UP

    *Mar 1 00:58:17.399: Se2 IPCP: O CONFREQ [Closed] id 4 len 10

    *Mar 1 00:58:17.399: Se2 IPCP: Address 1.1.1.1 (0x030601010101)

    *Mar 1 00:58:17.407: Se2 CDPCP: O CONFREQ [Closed] id 4 len 4

    *Mar 1 00:58:17.411: Se2 IPCP: I CONFREQ [REQsent] id 5 len 10

    *Mar 1.00:58:17.415: Se2 IPCP: Address 2.2.2.1 (0x030602020201)

    *Mar 1 00:58:17.419: Se2 IPCP: O CONFACK [REQsent] id 5 len 10

    *Mar 1 00:58:17.423: Se2 IPCP: Address 2.2.2.1 (0x030602020201)

    *Mar 1 00:58:17.527: Se2 IPCP: I CONFACK [ACKsent] id 4 len 10

    *Mar 1 00:58:17.531: Se2 IPCP: Address 1.1.1.1 (0x030601010101)

    *Mar 1 00:58:17.535: Se2 IPCP: State is Open

    *Mar 1 00:58:17.543: Se2 LCP: I PROTREJ [Open] id 33 len 10 protocol

    CDPCP (0x820701040004)

    *Mar 1 00:58:17.547: Se2 CDPCP: State is Closed

    *Mar 1 00:58:17.547: Se2 DDR: dialer protocol up

    *Mar 1 00:58:18.075: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2,

     changed state to up

    ! -- 接続に成功します。バックアップ リンクがアクティブになります。
   gaugin#show ip route 2.2.2.1

    Routing entry for 2.2.2.1/32

    Known via "connected", distance 0, metric 0 (connected, via interface)

    Routing Descriptor Blocks:

    * directly connected, via Serial2

    ! -- ピアのルートがバックアップ リンクを使用。

    ! -- プライマリ リンクのスタティック ルートが削除されます(リンクが down/down になったため)

    Route metric is 0, traffic share count is 1
   gaugin#show dialer

    Se2 - dialer type = IN-BAND ASYNC NO-PARITY

    Idle timer (120 secs), Fast idle timer (20 secs)

    Wait for carrier (30 secs), Re-enable (15 secs)

    Dialer state is data link layer up

    Dial reason: ip (s=1.1.1.1, d=2.2.2.1)

    Time until disconnect 108 secs

    Connected to 8029

 

    Dial String Successes Failures Last     DNIS  Last status

    8029        4           0      00:01:00       successful

 

    gaugin#show interface serial 2

    Serial2 is up, line protocol is up

    ! -- バックアップ リンクがアップしているかどうかを検査します

    Hardware is CD2430 in async mode

    Interface is unnumbered. Using address of Loopback1 (1.1.1.1)

    MTU 1500 bytes, BW 115 Kbit, DLY 100000 usec, 
...
...
   gaugin#ping 2.2.2.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 2.2.2.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 128/132/136 ms

 
次に、呼び出しの受信側になる sphinx から、同じプロセスをみてみましょう。
   sphinx#

    00:57:29: TTY2: DSR came up

    ! --最初に、受信呼び出しにより、モデム DSR が起動します。

    00:57:29: TTY2: destroy timer type 1

    00:57:29: TTY2: destroy timer type 0

    00:57:29: tty2: Modem: IDLE->(unknown)

    00:57:31: Se2 LCP: I CONFREQ [Closed] id 10 len 20

    ! -- LCP ネゴシエーションが開始します

    00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    00:57:31: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)

    00:57:31: Se2 LCP: PFC (0x0702)

    00:57:31: Se2 LCP: ACFC (0x0802)

    00:57:31: Se2 LCP: Lower layer not up, Fast Starting

    00:57:31: Se2 PPP: Treating connection as a callin

    00:57:31: Se2 PPP: Phase is ESTABLISHING, Passive Open

    00:57:31: Se2 LCP: State is Listen

    00:57:31: Se2 LCP: O CONFREQ [Listen] id 31 len 25

    00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    00:57:31: Se2 LCP: AuthProto CHAP (0x0305C22305)

    00:57:31: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)

    00:57:31: Se2 LCP: PFC (0x0702)

    00:57:31: Se2 LCP: ACFC (0x0802)

    00:57:31: Se2 LCP: O CONFACK [Listen] id 10 len 20

    00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    00:57:31: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)

    00:57:31: Se2 LCP: PFC (0x0702)

    00:57:31: Se2 LCP: ACFC (0x0802)

    00:57:31: %LINK-3-UPDOWN: Interface Serial2, changed state to upDialer statechange

    to up Serial2

    00:57:31: Serial2 DDR: Dialer received incoming call from <unknown>

    00:57:33: Se2 LCP: I CONFREQ [ACKsent] id 11 len 20

    00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    00:57:33: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)

    00:57:33: Se2 LCP: PFC (0x0702)

    00:57:33: Se2 LCP: ACFC (0x0802)

    00:57:33: Se2 LCP: O CONFACK [ACKsent] id 11 len 20

    00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    00:57:33: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)

    00:57:33: Se2 LCP: PFC (0x0702)

    00:57:33: Se2 LCP: ACFC (0x0802)

    00:57:33: Se2 LCP: TIMEout: State ACKsent

    00:57:33: Se2 LCP: O CONFREQ [ACKsent] id 32 len 25

    00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    00:57:33: Se2 LCP: AuthProto CHAP (0x0305C22305)

    00:57:33: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)

    00:57:33: Se2 LCP: PFC (0x0702)

    00:57:33: Se2 LCP: ACFC (0x0802)

    00:57:33: Se2 LCP: I CONFACK [ACKsent] id 32 len 25

    00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)

    00:57:33: Se2 LCP: AuthProto CHAP (0x0305C22305)

    00:57:33: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)

    00:57:33: Se2 LCP: PFC (0x0702)

    0:57:33: Se2 LCP: ACFC (0x0802)

    00:57:33: Se2 LCP: State is Open

    ! -- LCP ネゴシエーションが完了します

    00:57:33: Se2 PPP: Phase is AUTHENTICATING, by this end

    00:57:33: Se2 CHAP: O CHALLENGE id 4 len 27 from "sphinx"

    00:57:33: Se2 CHAP: I RESPONSE id 4 len 27 from "gaugin"

    00:57:33: Se2 CHAP: O SUCCESS id 4 len 4

    ! -- CHAP 認証に成功します

    00:57:33: Serial2 DDR: Authenticated host gaugin with no matching dialer map

    00:57:33: Se2 PPP: Phase is UP

    00:57:33: Se2 IPCP: O CONFREQ [Closed] id 5 len 10

    00:57:33: Se2 IPCP: Address 2.2.2.1 (0x030602020201)

    00:57:33: Se2 IPCP: I CONFREQ [REQsent] id 4 len 10

    00:57:33: Se2 IPCP: Address 1.1.1.1 (0x030601010101)

    00:57:33: Se2 IPCP: O CONFACK [REQsent] id 4 len 10

    00:57:33: Se2 IPCP: Address 1.1.1.1 (0x030601010101)

    00:57:33: Se2 CDPCP: I CONFREQ [Not negotiated] id 4 len 4

    00:57:33: Se2 LCP: O PROTREJ [Open] id 33 len 10 protocol CDPCP (0x820701040004)

    00:57:33: Se2 IPCP: I CONFACK [ACKsent] id 5 len 10

    00:57:33: Se2 IPCP: Address 2.2.2.1 (0x030602020201)

    00:57:33: Se2 IPCP: State is Open

    00:57:33: Serial2 DDR: dialer protocol up

    00:57:33: Se2 IPCP: Install route to 1.1.1.1

    ! -- ピアに対するルートがインストールされます

    00:57:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2, changed state

    to up

    ! -- バックアップ リンクがアップします

 

    sphinx#ping 1.1.1.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 132/142/152 ms
   sphinx#show ip route 1.1.1.1

    Routing entry for 1.1.1.1/32

    Known via "connected", distance 0, metric 0 (connected, via interface)

    Routing Descriptor Blocks:

    * directly connected, via Serial2

    ! -- フローティングスタティック ルートがインストールされます

    Route metric is 0, traffic share count is 1
   sphinx#show dialer

 
   Serial2 - dialer type = IN-BAND ASYNC NO-PARITY

    Idle timer (120 secs), Fast idle timer (20 secs)

    Wait for carrier (30 secs), Re-enable (15 secs)

    Dialer state is data link layer up

    Time until disconnect 119 secs (gaugin)

ここで、プライマリ リンクのケーブルを接続してみます。gauging で、プライマリ リンクが Up/Up 状態になり、バックアップ リンク(シリアル2)はスタンバイ状態に戻ります(backup interface serial 2 コマンドにより)。これにより、モデム リンクが切断され、sphinx のシリアル 2 インターフェイスも停止します。

次に、gaugin でのデバッグ プロセスを見てみましょう。

   gaugin#

    *Mar 1 00:59:38.859: %LINK-3-UPDOWN: Interface Serial0, changed state to up

    *Mar 1 00:59:39.875: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,

    changed state to up

    ! -- プライマリ リンクが再確立されます

    *Mar 1 00:59:59.315: TTY2: Async Int reset: Dropping DTR

    *Mar 1 01:00:00.875: TTY2: DSR was dropped

    *Mar 1 01:00:00.875: tty2: Modem: READY->(unknown)

    *Mar 1 01:00:01.315: %LINK-5-CHANGED: Interface Serial2, changed state to standby

    mode

    ! -- バックアップ リンクがスタンバイ状態に戻ります。モデム接続が終了します。

    *Mar 1 01:00:01.331: Se2 IPCP: State is Closed

    *Mar 1 01:00:01.335: Se2 PPP: Phase is TERMINATING

    *Mar 1 01:00:01.335: Se2 LCP: State is Closed

    *Mar 1 01:00:01.339: Se2 PPP: Phase is DOWN

    *Mar 1 01:00:01.343: Se2 IPCP: Remove route to 2.2.2.1

    *Mar 1 01:00:01.883: TTY2: dropping DTR, hanging up

    *Mar 1 01:00:01.883: tty2: Modem: HANGUP->(unknown)

    *Mar 1 01:00:02.315: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2,

    changed state to down

    *Mar 1 01:00:02.899: TTY2: cleanup pending. Delaying DTR

    *Mar 1 01:00:03.927: TTY2: cleanup pending. Delaying DTR

    *Mar 1 01:00:04.323: TTY2: no timer type 0 to destroy

    *Mar 1 01:00:04.323: TTY2: no timer type 1 to destroy

    *Mar 1 01:00:04.327: TTY2: no timer type 3 to destroy

    *Mar 1 01:00:04.327: TTY2: no timer type 4 to destroy

    *Mar 1 01:00:04.327: TTY2: no timer type 2 to destroy

    *Mar 1 01:00:04.331: Serial2: allowing modem_process to continue hangup!

 
次に、sphinx で同じトランザクションをみてみましょう。
   sphinx#

    00:58:54: %LINK-3-UPDOWN: Interface Serial0, changed state to up

    00:58:55: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state

    to up

    ! -- プライマリ リンクがアップします

    00:59:16: TTY2: DSR was dropped

    ! -- ピアによりモデム接続が終了します

    00:59:16: tty2: Modem: READY->(unknown)

    00:59:17: TTY2: dropping DTR, hanging up

    00:59:17: TTY2: Async Int reset: Dropping DTR

    00:59:17: tty2: Modem: HANGUP->(unknown)

    00:59:18: TTY2: cleanup pending. Delaying DTR

    00:59:19: %LINK-5-CHANGED: Interface Serial2, changed state to reset

    ! -- バックアップ インターフェイス(シリアル 2)がリセットされます

    00:59:19: Se2 IPCP: State is Closed

    00:59:19: Se2 PPP: Phase is TERMINATING

    00:59:19: Se2 LCP: State is Closed

    00:59:19: Se2 PPP: Phase is DOWN

    00:59:19: TTY2: cleanup pending. Delaying DTR

    00:59:19: Se2 IPCP: Remove route to 1.1.1.1

    ! -- シリアル 2 を使用する 1.1.1.1 へのルートが削除されます

    ! -- (アドミニストレーティブ ディスタンスが 2 以上になったため)

    00:59:20: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2, changed state

    to down

    00:59:20: TTY2: cleanup pending. Delaying DTR

    00:59:21: TTY2: cleanup pending. Delaying DTR

    00:59:22: TTY2: destroy timer type 0

    00:59:22: TTY2: destroy timer type 1

    00:59:22: TTY2: destroy timer type 3

    00:59:22: TTY2: destroy timer type 4

    00:59:22: TTY2: destroy timer type 2

    00:59:22: Serial2: allowing modem_process to continue hangup

    00:59:22: TTY2: restoring DTR

    00:59:22: TTY2: autoconfigure probe started

    00:59:24: %LINK-3-UPDOWN: Interface Serial2, changed state to down

    00:59:24: Se2 LCP: State is Closed

    sphinx(config-if)#

ツール情報

補足情報については、シスコの アクセスダイヤル技術に関する TAC ツールを参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報

関連トピックス

参考文書


Document ID: 14281