ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

着信の非同期コールおよび ISDN コールについて、PRI(一次群速度インターフェイス)の備わったアクセス サーバの設定

2002 年 3 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 1 月 29 日) | フィードバック

目次


概要

ほとんどの環境では、非同期および ISDN の両方のユーザから着信コールを受けられるようにアクセス サーバを設定しておく必要があります。アクセス サーバが設定されていると、どちらのユーザも物理的に接続されているかのようにスムーズにネットワークに接続できます。このような設定は、Small Office-Home Office(SOHO)サイトに対してだけではなく、移動中のユーザや在宅勤務のユーザなど、ネットワーク経由で接続する場合などにもよく使用します。

この文書では、着信の非同期および ISDN のコールを ISDN T1 PRI 回線で受信できるようにアクセス サーバを設定する方法を説明します。この設定には、コール受信のために最小限必要な network access server(NAS; ネットワーク アクセス サーバ)のセットアップが含まれています。必要に応じて、この設定に機能を追加できます。

設定

この項では、この文書で説明する機能を設定するために必要な情報を示します。

注:この文書で使用するコマンドの追加情報を探すには、IOS コマンドの Lookup ツールを使用します。このツールのリンク先については、この文書の「ツール情報」の項を参照してください。

この設定で使用するコンポーネント

この設定は、次のコンポーネントを使用して、開発およびテストされています。

  • Cisco AS5300(192 ライン分の MICA モデムと 8 T1 ポート、 および Cisco IOS(R) ソフトウェア リリース 12.2(5)が動作)

  • 2 つの T1 PRI

  • Microsoft Windows が稼動する PC。この PC には、アナログのモデムと、Public Switch Telephone Network(PSTN; 公衆電話交換網)に対する電話接続が搭載されています。PC から AS5300 に接続された T1 PRI にダイヤルします。

  • ISDN BRI(基本速度インターフェイス)回線を搭載した Cisco 800 および 1600 シリーズのルータ。これらのルータは、ISDN ダイヤルイン クライアントです。Cisco 1600 用の設定が示されます。このクライアント コンフィギュレーションは、BRI インターフェイスを備えているどのルータにも適用できます。

    注:Cisco 800 ルータの設定は、Cisco 1600 のものと類似しているので、この文書では取り上げません。

  • ローカルにて Authentication, Authorization and Accounting(AAA)を使用。AAA Radius または Tacacs+ のサーバを所有している場合には、どちらかのサーバを使用して着信コールに AAA を提供できます。詳細は、「Implementing the Server-Based AAA Subsystem」を参照してください。

注:この文書の記載情報は、特定の実験環境にあるデバイスを使用して作成したものです。この文書内で使用するデバイスの設定は、すべてクリアーされた状態(デフォルト)になっています。実環境のネットワークで作業するときは、すべてのコマンドについて、そのコマンドが与える影響について十分に理解してからコマンドを使用してください。

関連製品

この設定は、T1 または PRI のどちらかのカードと内部デジタル モデム(MICA、NextPort または Microcom など)を搭載しているどのルータにも使用できます。そのため、T1 または PRI のいずれかのカードとデジタル モデムを搭載した AS5xxx シリーズのルータにも、この設定の概念を使用できます。Cisco 2600 シリーズのルータは内部デジタル モデムをサポートしていないので、ISDN コールの受信用のみの設定になります。ただし、ISDN コールを受信する場合にも、T1、PRI WIC、またはネットワーク モジュールが必要です。一方、Cisco 3600 シリーズのルータの場合は、ISDN とモデムの両方のコールをサポートしますが、T1、PRI WIC、またはネットワーク モジュールのいずれかと NM-xDM デジタル モデム ネットワーク モジュールが必要になります。

この設定を変更すると、E1 または PRI のどちらかのポートを備えたルータにも使用できるようになります。Telco が提供するラインコーディング、フレーミング、およびその他の物理的な特性を備えた E1 コントローラを設定します。D チャネルの設定(E1 コントローラに対してインターフェイス シリアル x:15 を使用)は、ここで説明した設定と類似しています。

ネットワークダイヤグラム

ネットワーク図

設定例

maui-nas-02(5300)
maui-nas-02#show running-config 

    Building configuration...

    

    Current configuration : 3671 bytes

    !

    ! No configuration change since last restart

    !

    version 12.2

    service timestamps debug datetime msec

    service timestamps log datetime msec

    service password-encryption

    !

    hostname maui-nas-02

    !

    boot system flash:c5300-i-mz.122-5.bin

    aaa new-model

    aaa authentication login default local

    aaa authentication login NO_AUTHEN none

    aaa authentication ppp default local

    aaa authorization network default local

    ! -- ppp 認証とネットワーク認証はローカルです。

    ! -- AAA サーバを使用している場合には、localradius または tacacs に置き換えます。

    enable secret 5 <deleted>

    !

    username admin password 7 <deleted>

    username async_user password 7 <deleted>

    username travis_isdn password 7 <deleted>

    username austin_isdn password 7 <deleted>

    ! -- コールのローカル認証についてユーザ名を入力します。

    ! -- クライアントがユーザ名およびパスワードを入力すると、NAS によってピアが認証されます。

    spe 1/0 1/8

     firmware location mica-modem-pw.2.7.3.0.bin

    spe 2/0 2/7

     firmware location mica-modem-pw.2.7.3.0.bin

    !

    ip subnet-zero

    ip domain-name maui-onions.com

    ! -- DNS ルックアップを修飾する方法を NAS に指定します。

    ! -- この例では、各ルックアップ名の後ろに maui-onions.com が

    ! -- 付けられます。

    ip name-server 172.22.53.210

    ! -- プライマリ ネーム サーバを指定します。

    !

    async-bootp dns-server 172.22.53.210

    ! -- ドメイン ネーム サーバの IP アドレスを(非同期のクライアントに対して)指定します。 

    isdn switch-type primary-ni

    ! -- この NAS のスイッチ タイプ。この情報については、Telco から入手してください。

    !

    controller T1 0

    ! -- 最初の T1 PRI。

     framing esf

    ! -- この T1 のフレーミングは、Extended Super Frame(ESF)です。この情報については、

    ! -- Telco から入手してください。.

     clock source line primary

    ! -- T1 0 は、この NAS に対するプライマリのクロック ソースです。

    ! -- T1 キャリアのタイミングと同期について、

    ! -- クロック ソースが指定される必要があります。

     linecode b8zs

    ! -- この T1 に対するラインコーディング。この情報については、Telco から入手してください。

     pri-group timeslots 1-24

    ! -- T1 PRI シナリオについて、24 個のすべての T1 タイムスロットが

    ! -- ISDN PRI チャネルとして割り当てられます。その結果、ルータにより自動的に

    ! -- 対応する D チャネル:インターフェイス シリアル 0:23 が作成されます。.

    !

    controller T1 1

    ! -- 2 番目の T1 PRI。

     framing esf

    ! -- この T1 のフレーミングは、Extended Super Frame(ESF)です。この情報については、

    ! -- Telco から入手してください。

     clock source line secondary 1

    ! -- T1 1 は、この NAS に対する最初のセカンダリのクロック ソースとなっています。

    ! -- プライマリのクロックが故障した場合には、このセカンダリのクロックが動作し始めます。

     linecode b8zs

    ! -- この T1 に対するラインコーディング。この情報については、Telco から入手してください。

     pri-group timeslots 1-24

    ! -- T1 PRI シナリオについて、24 個すべての T1 タイムスロットは

    ! -- ISDN PRI チャネルとして割り当てられます。その結果、ルータにより自動的に

    ! -- 対応する D チャネル:インターフェイス シリアル 1:23 が作成されます。

    !

    controller T1 2

    ! -- この T1 は使用されません。

     framing sf

     clock source line secondary 2

     linecode ami

    !

    !-- 使用されないインターフェイスの設定は、ここでは省略します。

    !

    interface Loopback0

     ip address 172.22.60.1 255.255.255.0

    ! -- 非同期ユーザの ip プールは、このサブネットにあります。

    ! -- このようにして、非同期クライアントのルートはすべて要約されて、

    ! -- 254 ルートの代わりにバックボーンに伝搬されます。

    !

    interface Loopback1

     ip address 172.22.61.1 255.255.255.0

    ! -- isdn ユーザの ip プールは、このサブネットにあります。

    ! -- このようにして、isdn クライアントのルートはすべて要約されて、

    ! -- 254 ルートの代わりにバックボーンに伝搬されます。

    !

    interface Ethernet0

     ip address 172.22.53.140 255.255.255.0

    !

    ! -- 使用されないインターフェイスの設定は、ここでは省略します。

    !

    interface Serial0:23

    ! -- T1 0 に対する D チャネルの設定

     no ip address

     encapsulation ppp

    ! -- このインターフェイスでの ppp カプセル化

     dialer rotary-group 10

    ! -- T1 0 ロータリー グループ 10 のメンバーです。

    ! -- ロータリー グループの設定は、インターフェイス ダイヤラ 10 にあります。

     isdn switch-type primary-ni

     isdn incoming-voice modem

    ! -- この T1 で受けた着信音声コールは、すべてモデムに送られます。

    ! -- このコマンドは、この T1 が非同期コールを受ける場合に必要です。

     no cdp enable

     ppp authentication chap

     ppp multilink

    !

    interface Serial1:23

    ! -- T1 1 に対する D チャネルの設定

     no ip address

     encapsulation ppp

    ! -- このインターフェイス上での ppp カプセル化

     dialer rotary-group 10

    -- T1 1 は、ロータリー グループ 10 のメンバーです。

    !--- ロータリー グループの設定は、インターフェイス ダイヤラ 10 にあります。

     isdn switch-type primary-ni

     isdn incoming-voice modem

    !-- この T1 で受ける着信音声コールは、すべてモデムに送られます。

    !-- このコマンドは、この T1 が非同期コールを受ける場合に必要です。

     no cdp enable

     ppp authentication chap

     ppp multilink

    !

    interface Group-Async0

    ! -- このグループ非同期のインターフェイスは、全モデムに対する設定のテンプレートです。

    ! -- 管理しているコピーが 1 つある場合には、そのコピーを複製できるので、

    ! -- 非同期インターフェイスを個々に設定する必要はありません。

     ip unnumbered Loopback0

    ! -- ループバック インターフェイスは常に活動化しているので、,

    ! -- インターフェイスを番号未指定にすると、安定した状態になります。

     encapsulation ppp

     dialer in-band

     dialer idle-timeout 900

     dialer-group 5

    ! -- 対象トラフィックの定義が、次のダイヤラリスト 5 に指定されます。

    ! -- 注:特定の dialer-group番号は、

    ! -- dialer-list の番号と同一であることが必要です。この例では、「5」と指定される必要があります。

     async mode interactive

    ! -- ユーザはダイヤルインして、その回線上のシェルまたは PPP セッションに到達することができます。

    ! -- 回線の設定で、このコマンドをautoselect pppとともに使用すると、

    ! -- 接続タイプを自動検知できます。

     peer default ip address pool ASYNC

    ! -- クライアントは、ASYNC という名前の ip アドレス プールから、アドレスを割り当てられます。

     no fair-queue

     ppp authentication chap

    ! -- chap 認証を使用します。

     ppp multilink

     group-range 1 192

    ! -- モデム 1 から 192 までは、この非同期インターフェイス グループのメンバーになっています。

    !

    interface Dialer10

    !--- ロータリー グループ 10 に対する設定

    !--- ダイヤラ インターフェイス番号 (10) は、物理インターフェイス上で、

    !--- ロータリー グループの番号と正確に一致しなければなりません。

     ip unnumbered Loopback1

    ! -- ループバック インターフェイスは常に活動化しているので、

    ! -- インターフェイスを番号未指定にすると安定した状態になります。

     encapsulation ppp

     dialer in-band

    ! -- このインターフェイスで V.25bis を使用可能にします。

     dialer idle-timeout 900

    ! -- 着信コールのアイドル タイムアウトは、900 秒(15 秒)です。

     dialer-group 5

    !--- ダイヤラリスト 5 から対象トラフィックの定義を適用します。

    ! -- 注:特定の dialer-group番号は、

    ! -- dialer-list の番号と同一であることが必要です。この例では、「5」と定義される必要があります。

     peer default ip address pool ISDN

    ! -- クライアントは、ISDN という名前の ip アドレス プールから、アドレスを割り当てられます。

     ppp authentication chap

     ppp multilink

    !

    router eigrp 69

     network 172.22.0.0

     auto-summary

     no eigrp log-neighbor-changes

    !

    ip local pool ASYNC 172.22.60.2 172.22.60.254

    ip local pool ISDN 172.22.61.2 172.22.61.254

    ! -- ダイヤルインのクライアントに対する IP アドレス プール

    ip classless

    no ip http server

    !

    access-list 101 remark Interesting Traffic Definition to be used in dialer-list 5

    access-list 101 deny   eigrp any any

    access-list 101 permit ip any any

    dialer-list 5 protocol ip list 101

    !-- 対象トラフィックは、アクセスリスト 101 により定義されます。

    !-- これは、インターフェイス ダイヤラ 10 およびダイヤラグループ 5 を使用する Group-Async 0 に適用されます。

    !-- 注:特定の dialer-list番号は、 

    !-- dialer-group  番号と同一であることが必要です。この例では、「5」と定義される必要があります。

    !

    line con 0

     exec-timeout 0 0

     login authentication NO_AUTHEN

    ! -- 以前に設定した AAA リストの NO_AUTHEN を適用します。そのリストには「none」という方法が含まれています。

    ! -- したがって、コンソール ポートでも認証が行われません。

    line 1 192

     modem InOut

    ! -- 着信モデム コールおよび発信モデム コールがサポートされます。

     transport input all

     autoselect during-login

    ! -- モデムが接続した段階で、ユーザ名:パスワードのプロンプトが表示されます。

     autoselect ppp

    ! -- ルータが着信の PPP パケットを検出すると、自動的に ppp が起動します。

    ! -- このコマンドを使用しない場合は、ダイヤルイン クライアントは Exec モードから手動で

    ! -- ppp を起動しなければなりません。 

    line aux 0

    line vty 0 4

    !

    ntp clock-period 17180107

    ntp server 172.22.53.1

    end

    

maui-soho-01(1600)
maui-soho-01#show running-config

    Building configuration...

    

    Current configuration : 1609 bytes

    !

    version 12.1

    no service single-slot-reload-enable

    service timestamps debug datetime msec

    service timestamps log datetime msec

    service password-encryption

    !

    hostname maui-soho-01

    !

    logging rate-limit console 10 except errors

    !

    username admin password 7 <deleted>

    ip subnet-zero

    no ip finger

    !

    isdn switch-type basic-ni

    ! -- BRI 回線のスイッチタイプ。この情報については、Telco から入手してください。

    !

    interface Ethernet0

     ip address 10.0.0.1 255.255.255.0

     no keepalive

    !

    interface Serial0

     no ip address

     shutdown

    !

    interface BRI0

    ! -- BRI 物理インターフェイスの設定

     no ip address

    ! -- IP アドレスは、ダイヤラ プールに含まれているので、

    ! -- BRI 物理インターフェイスでは必要ありません。

    ! -- IP アドレッシング機能は、インターフェイス ダイヤラ 1(ダイヤラ プール)に含まれています。

     encapsulation ppp

     dialer pool-member 1

    ! -- ダイヤラ インターフェイスが必要に応じてチャネルを引き出す、

    ! -- ダイヤラ プール 1 にインターフェイスを配置します。

    ! -- 物理インターフェイスを論理ダイヤラ インターフェイスとリンクします。

    ! -- ダイヤラ プール 1 は、インターフェイス ダイヤラ 1 に定義されています。

     isdn switch-type basic-ni

     isdn spid1 51255511110101 5551111

     isdn spid2 51255511120101 5551112

    ! -- Service Profile IDentifiers(SPID; サービス プロファイル識別子)は主に北米で使用されています。

    ! -- SPID は、特定のスイッチ タイプでは必要ありませんが、

    ! -- 詳細はご利用の Telco にお問い合せください。Telco により SPID が必要ないことが確認された場合は、

    ! -- 前述の 2 つの spid コマンドは使用しないでください。

     ppp authentication chap callin

    ! -- 片方向の chap 認証を実行します。

     ppp multilink

    ! -- この BRI インターフェイスでマルチリンクを実行します。

    !

    interface Dialer1

    ! -- このダイヤラは、ダイヤラ プールの論理インターフェイスです。

     ip address negotiated

    ! -- このインターフェイスの IP アドレスは、

    ! -- IP Control Protocol (IPCP) ネゴシエーションにおいて NAS から取得されます。その他にも、現行のインターフェイスに対して、

    ! -- このインターフェイスを番号未指定にする(ethernet 0 など)という方法があります。

     encapsulation ppp

     dialer pool 1

    ! -- ダイヤラ プール 1 を定義します。

    ! -- BRI 0 は、このプールのメンバーです。

     dialer idle-timeout 900

    ! -- このリンクのアイドル タイムアウトは、900 秒(15 分)です。

    ! -- 対象となるトラフィックが 900 秒間存在しないと、リンクは接続解除されます。

     dialer string 81560 class 56k

    ! -- 81560 にダイヤルして、次に定義されるマップクラス「56k」を使用します。

     dialer load-threshold 1 outbound

    ! -- トラフィックの送信負荷レベルが設定されます。

    ! -- このトラフィックには、MP バンドルの負荷レベルに別の接続が追加されます。

    ! -- レベルの値は、1(負荷のない状態)から 255(最も負荷がかかっている状態)までの範囲となります。

    ! -- しきい値が 1 の場合には、

    ! -- 追加のリンクがすぐに始動して、バンドルに追加されます。

     dialer-group 1

    ! -- ダイヤラリスト 1 から対象トラフィックの定義を適用します。

     ppp authentication chap callin

    ! -- 片方向の ppp の chap 認証を実行します。

     ppp chap hostname austin_isdn

    ! -- chap のユーザ名、austin_isdn を使用して、他のルータに対して認証を行います。

     ppp chap password 7 <deleted>

    ! -- この chap のパスワードを使用して、他のルータに対して認証を行います。

     ppp multilink

    ! -- ダイヤラ プロファイルのマルチリンクを許可します。

    ! -- このコマンドを使用しないと、マルチリンクはネゴシエートできません。

    !

    !

    ip classless

    ip route 0.0.0.0 0.0.0.0 Dialer1

    ! -- デフォルトのルートをインターフェイス ダイヤラ 1(ダイヤラ プール)に設定します。

    ! -- トラフィックがインターフェイス ダイヤラ 1 に送信されると、ダイヤラ プールのメンバー(インターフェイス BRI 0)にダイヤルされます。

    no ip http server

    !

    !

    map-class dialer 56k

    ! -- インターフェイス ダイヤラ 1 のダイヤラ文字列と一緒に使用された「56k」という名前のマップクラス

     dialer isdn speed 56

    ! -- コールの速度を 56k(デフォルトは 64 k)に設定します。

    ! -- この設定作業は、接続のタイプによっては必要ない場合があります。

    ! -- ダイヤルの速度を 56k に設定すべきかどうかは、ご利用の Telco にお問い合せください。

    access-list 101 remark Interesting traffic for dialer-list 1

    access-list 101 deny   udp any any eq ntp

    access-list 101 permit ip any any

    ! -- 対象外として、ntp トラフィックを定義します。

    ! -- 定義することで、定期的な ntp トラフィックが無期限にリンクアップしないようにします。

    ! -- その他の IP トラフィックは、すべて対象とします。

    ! -- この定義は、各ユーザのトラフィック ニーズによって変更してください。

    dialer-list 1 protocol ip list 101

    ! -- 対象トラフィックは、アクセスリスト 101 によって定義されま。

    ! -- dialer-group 1 コマンドを使用して、この定義をインターフェイス ダイヤラ 1 に適用します。

    ! -- 注:特定の dialer-list番号は、 

    ! -- dialer-group  の番号と同一であることが必要です。この例では、「1」と定義される必要があります。

    !

    line con 0

     transport input none

    line vty 0 4

     login

    !

    ntp clock-period 17042429

    ntp server 172.22.53.1

    end

    

検証

この項では、設定が正常に動作していることを検証する場合に役立つ情報を提供します。

特定のshowコマンドは、Output Interpreter ツールによりサポートされているため、 これらのツールを使用するとshowコマンドの出力を分析して見れます。このツールのリンク先については、この文書の「ツール情報」の項に記載されています。

次のコマンドを使用して、トラブルシューティングを行い接続を検証します。

  • show isdn status:ルータが正常に ISDN の交換機と接続していることを確認します。接続状態が表示されたら、「Layer 1 Status is ACTIVE」と、「Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED」というメッセージが表示されることを確認します。このコマンドを使用すると、通信中のコール数も表示できます。詳細は、「Using the show isdn status Command for BRI Troubleshooting」を参照してください。

  • show ppp multilink:通信中のマルチリンクのバンドルに関する情報が表示されます。このコマンドは、マルチリンクの接続状態を確認するときに使用します。

  • show dialer [interface タイプ 番号]:DDR に設定されたインターフェイスについて、一般的な診断情報が表示されます。ダイヤラが正常に始動すると、「Dialer state is data link layer up」というメッセージが表示されます。「physical layer up」というメッセージが表示された場合は、回線プロトコルは始動したものの、NCP(ネットワーク コントロールプロトコル)は始動しなかったという意味です。.ダイヤリングを始動したパケットの発信元および宛先のアドレスは、「Dial reason」の行に表示されます。このshowコマンドを使用すると、タイマーの設定内容、および時間が接続のタイムアウト前に表示できます。

  • show caller user ユーザ名detail:特定ユーザのパラメータ(割り当てられた IP アドレス、PPP、および PPP バンドル パラメータなど)が表示されます。所有している Cisco IOS ソフトウェアがこのコマンドをサポートしない場合には、show user コマンドを使用します。

  • show dialer map:設定したダイナミックおよびスタティックのダイヤラ マップが表示されます。このコマンドは、ダイナミック ダイヤラ マップが作成済みかどうかを確認するときに使用できます。ダイヤラ マップがないと、パケットを送信できません。

次に、成功したコールに対するshow コマンドの出力を示します。太字で書かれている部分とコメントに注意してください。自分が得た出力と、次に示される出力とを比べてください。

概要

maui-nas-02#show users

      Line         User       Host(s)              Idle       Location

    * 0 con 0                 idle                 00:00:00

      97 tty 97    async_user Async interface      00:06:36   PPP: 172.22.60.2

    ! --  非同期のユーザ。ピアの IP アドレスが表示されます。

    

      Interface    User        Mode                Idle     Peer Address

      Vi1          austin_isd Virtual PPP (Bundle) 00:03:35 172.22.61.2

      Vi2          travis_isd Virtual PPP (Bundle) 00:00:20 172.22.61.3

    ! -- 2 人のマルチリンク PPP ユーザに対する仮想アクセス インターフェイス

      Se0:1        austin_isd Sync PPP                    -   Bundle: Vi1

      Se0:2        austin_isd Sync PPP                    -   Bundle: Vi1

    ! -- austin_isdn というユーザが、2 つの B チャネル(マルチリンク PPP)を使用して接続されました。

    ! -- 2 つの B チャネルが、仮想アクセス 1(Vi1)のインターフェイスによって制御されます。

      Se0:3        travis_isd Sync PPP                    -   Bundle: Vi2

      Se0:4        travis_isd Sync PPP                    -   Bundle: Vi2

    ! -- ユーザ travis_isdn が、2 つの B チャネル(マルチリンク PPP)を使用して接続されました。

    ! -- 2 つの B チャネルが、仮想アクセス 2(Vi2)のインターフェイスによって制御されます。

    

    maui-nas-02#show dialer map

    ! -- 各ダイヤルイン クライアントに対して作成されたダイナミック ダイヤラ マップに注意してください。

    Dynamic dialer map ip 172.22.60.2 name async_user () on As97

    Dynamic dialer map ip 172.22.61.2 name austin_isdn () on Di10

    Dynamic dialer map ip 172.22.61.3 name travis_isdn () on Di10

アナログ コールの場合

maui-nas-02#show caller user async_user detail

    

      User: async_user, line tty 97, service Async

    ! -- ユーザ async_user について、ハードウェアのレベル設定が表示されます。

            Active time 00:00:34, Idle time 00:00:16

      Timeouts:            Absolute  Idle      Idle

                                     Session   Exec

          Limits:          -         -         00:10:00

          Disconnect in:   -         -         -

      TTY: Line 97, running PPP on As97

    ! -- コールは、インターフェイス Async 97 で終端しました。

    ! -- このインターフェイスは、Group-Async の設定に含まれます。

      Location: PPP: 172.22.60.2

    ! -- ピアの IP アドレス。このアドレスは、「ASYNC」という IP プールで取得しました。

      DS0: (slot/unit/channel)=0/0/2

    ! -- 着信を受けた T1 チャネル。コールは、T1 0 のチャネル 0 に着信しました。

      Line: Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits

      Status: Ready, Active, No Exit Banner, Async Interface Active

              HW PPP Support Active

      Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out

                    Modem Callout, Modem RI is CD,

                    Line usable as async interface, Integrated Modem

      Modem State: Ready

    

      User: async_user, line As97, service PPP

    ! -- ユーザ async_user に対する PPP 設定

    ! -- コールがインターフェイス Async97 で終端したことに注意してください。

            Active time 00:00:32, Idle time 00:00:30

      Timeouts:            Absolute  Idle

          Limits:          -         00:15:00

          Disconnect in:   -         00:14:28

      PPP: LCP Open, multilink Closed, CHAP (<- AAA), IPCP

    ! -- LCP 状態がオープンになっています。LCP 状態がオープンでない場合には、

    ! -- debug ppp negotiation コマンドを使用して LCP の問題を切り分けします。

      LCP: -> peer, ACCM, AuthProto, MagicNumber, PCompression, ACCompression

           <- peer, ACCM, MagicNumber, PCompression, ACCompression

      NCP: Open IPCP

    ! -- IPCP の状態はオープンです。IPCP 状態がオープンでない場合には、

    ! -- -- debug ppp negotiation コマンドを使用して IPCP の問題を切り分けします。

      IPCP: <- peer, Address

            -> peer, Address

      Dialer: Connected, inbound

              Idle timer 900 secs, idle 31 secs

              Type is IN-BAND ASYNC, group As97

      IP: Local 172.22.60.1, remote 172.22.60.2

    ! -- IP アドレスだけでなく NAS IP アドレスもピアに割り当てられました。

      Counts: 27 packets input, 1545 bytes, 0 no buffer

              1 input errors, 1 CRC, 0 frame, 0 overrun

              14 packets output, 347 bytes, 0 underruns

              0 output errors, 0 collisions, 0 interface resets

    ! -- パケットが接続を通して送られます。

    

ISDN コールの場合

maui-nas-02#show caller user austin_isdn detail 

    ! -- ユーザ austin_isdn は、2 つの PPP リンクと 1 つの仮想インターフェイス バンドルを持っています。

    

      User: austin_isdn, line Se0:3, service PPP

    ! -- ユーザ austin_isdn が所有する最初のチャネルの PPP レイヤ 設定が表示されます。

            Active time 00:04:01, Idle time 00:00:00

      Timeouts:            Absolute  Idle

          Limits:          -         -

          Disconnect in:   -         -

      PPP: LCP Open, multilink Open, CHAP (<- AAA)

    ! -- LCP 状態がオープンになっています。LCP 状態がオープンでない場合には、

    ! -- debug ppp negotiation コマンドを使用して LCP の問題を切り分けします。

      LCP: -> peer, AuthProto, MagicNumber, MRRU, EndpointDisc

           <- peer, MagicNumber, MRRU, EndpointDisc

      Dialer: Connected, inbound

              Type is ISDN, group Di10

    ! -- 着信コールによって、インターフェイス ダイヤラ 10 のロータリー グループが使用されました。

      IP: Local 172.22.61.1

    ! -- インターフェイス ループバック 1 の IP アドレス

    ! -- インターフェイス ダイヤラ 1 はループ 1 に対して番号未指定であったことに注意してください。

    ! -- リモートの IP アドレスが、仮想インターフェイスの下に表示されます。

      Bundle: Member of austin_isdn, last input 00:00:00

      Counts: 55 packets input, 1635 bytes, 0 no buffer

              0 input errors, 0 CRC, 0 frame, 0 overrun

              82 packets output, 3479 bytes, 0 underruns

              0 output errors, 0 collisions, 0 interface resets

    

      User: austin_isdn, line Se0:4, service PPP

    ! -- ユーザ austin_isdn が所有する、2 番目のチャネルの PPP レイヤ設定が表示されます。

            Active time 00:03:59, Idle time 00:00:00

      Timeouts:            Absolute  Idle

          Limits:          -         -

          Disconnect in:   -         -

      PPP: LCP Open, multilink Open, CHAP (<- AAA)

      LCP: -> peer, AuthProto, MagicNumber, MRRU, EndpointDisc

           <- peer, MagicNumber, MRRU, EndpointDisc

      Dialer: Connected to , inbound

              Type is ISDN, group Di10

      IP: Local 172.22.61.1

      Bundle: Member of austin_isdn, last input 00:00:00

      Counts: 50 packets input, 1589 bytes, 0 no buffer

              0 input errors, 0 CRC, 0 frame, 0 overrun

              77 packets output, 3429 bytes, 0 underruns

              0 output errors, 0 collisions, 0 interface resets

    

      User: austin_isdn, line Vi1, service PPP Bundle

    ! -- 接続を制御する仮想アクセス インターフェイス バンドルを表示します。

            Active time 00:04:02, Idle time 00:04:01

      Timeouts:            Absolute  Idle

          Limits:          -         00:15:00

          Disconnect in:   -         00:10:58

      PPP: LCP Open, multilink Open, IPCP, CDPCP

      LCP: -> peer, MagicNumber, MRRU, EndpointDisc

           <- peer

      NCP: Open IPCP, CDPCP

    ! -- IPCP の状態はオープンです。

    ! -- IPCP の状態がオープンでない場合は、debug ppp negotiation コマンドを使用して、IPCP の問題を切り分けします。

      IPCP: <- peer, Address

            -> peer, Address

      Dialer: Connected, inbound

              Idle timer 900 secs, idle 1 secs

              Type is IN-BAND SYNC, group Di10

      IP: Local 172.22.61.1, remote 172.22.61.2

    ! -- IP アドレスだけでなく、ダイヤラ インターフェイス(ローカル)の IP アドレスもピアに割り当てられました。

      Bundle: First link of austin_isdn, 2 links, last input 00:00:01

      Counts: 12 packets input, 1712 bytes, 0 no buffer

              0 input errors, 0 CRC, 0 frame, 0 overrun

              67 packets output, 5030 bytes, 0 underruns

              0 output errors, 0 collisions, 0 interface resets

    

トラブルシューティング

この項では、設定をトラブルシューティングする場合に役立つ情報を提供します。

トラブルシューティングのリソース

必要に応じて、次のトラブルシューティングのリソースを使用してください。

debug コマンド

特定の show コマンドは、Output Interpreter ツールのサポート対象となっているため、そのようなツールを使用することによって show コマンドの出力を分析して見れます。このツールのリンク先については、この文書の「ツール情報」の項に記載されています。

注:debug コマンドを実行する前に、「Important Information on Debug Commands」を参照してください。

  • debug dialer:ダイヤラ インターフェイスで受信するパケットに関して、DDR のデバッグ情報が表示されます。この情報により、ダイヤラ インターフェイスを使用できる対象トラフィックが存在することを確認できます。

  • debug isdn q931:ISDN ネットワーク接続(レイヤ 3)のコールのセットアップとティアダウンが表示されます。

  • debug modem:アクセス サーバ上のモデム回線のアクティビティが表示されます。モデム回線の状態が変化すると出力が表示されます。

  • debug modem csm:内部デジタル モデムを搭載するルータ上で発生した、Call Switching Module(CSM; コール スイッチング モジュール)の問題をトラブルシューティングする EXEC コマンドです。このコマンドを使用すると、着信および発信のコールのスイッチングについて、完全なシーケンスをトレースできます。

  • debug ppp negotiation:Link Control Protocol(LCP; リンク コントロール プロトコル)、認証、および Network Control Protocol(NCP; ネットワーク コントロール プロトコル)にネゴシエートしている間の PPP トラフィックと交換に関する情報が表示されます。成功した PPP ネゴシエーションにより、まず LCP 状態、次に認証がオープンとなり、最後に NCP とのネゴシエートが行われます。LCP ネゴシエーションの間に、Maximum Receive Reconstructed Unit(MRRU)などのマルチリンク パラメータが設定されます。

  • debug ppp authentication:CHAP パケット交換および Password Authentication Protocol(PAP; パスワード認証プロトコル)交換などを含む、PPP 認証のプロトコル メッセージが表示されます。

  • debug ppp error:PPP 接続のネゴシエーションとオペレーションに関するプロトコル エラーとエラーの統計が表示されます。

次に、成功したコールに対する debug コマンドの出力を示します。太字で書かれている部分とコメントに注意してください。自分が得た出力と、次に示される出力とを比べてください。

アナログ コールの場合

maui-nas-02#debug isdn q931

    ISDN Q931 packets debugging is on

    maui-nas-02#debug modem

    Modem control/process activation debugging is on

    maui-nas-02#debug modem csm

    Modem Management Call Switching Module debugging is on

    maui-nas-02#debug ppp negotiation

    PPP protocol negotiation debugging is on

    maui-nas-02#debug ppp authentication

    PPP authentication debugging is on

    

    maui-nas-02#

    Sep 28 13:13:28.369: ISDN Se0:23: RX <-  SETUP pd = 8  callref = 0x5285

    

    ! --  Q.931 SETUP 着信メッセージ。着信コールが表示されます。

    ! -- Q.931 の詳細は、文書を参照してください。

    ! -- Troubleshooting ISDN BRI Layer 3 using the debug isdn q931 Command

    Sep 28 13:13:28.369:   Bearer Capability i = 0x9090A2

    Sep 28 13:13:28.369:   Channel ID i = 0xA18383

    Sep 28 13:13:28.369:   Progress Ind i = 0x8183 - Origination address is non-ISDN

    Sep 28 13:13:28.369:   Called Party Number i = 0xA1, '81560', Plan:ISDN, Type:National

    Sep 28 13:13:28.373: VDEV_ALLOCATE: 2/0 is allocated

    ! -- コール スイッチ モジュール(CSM)に、コールの着信が知らされます。

    ! -- CSM によって、着信コールにモデム 2/0 が割り当てられます。

    Sep 28 13:13:28.373: EVENT_FROM_ISDN::dchan_idb=0x618569F4, call_id=0x28,

    ces=0x0 bchan=0x2, event=0x1, cause=0x0

    Sep 28 13:13:28.373:  dev in call to isdn : set dnis_collected & fap_notify

    Sep 28 13:13:28.373: EVENT_FROM_ISDN:(0028): DEV_INCALL at slot 2 and port 0

    Sep 28 13:13:28.373:  EVENT_FROM_ISDN: decode:calling 0ct3 0x0, called oct3

    0xA1, oct3a 0x0,mask 0x3C

    Sep 28 13:13:28.373:  EVENT_FROM_ISDN: csm_call_info:calling 0ct3 0x0,

    called oct3 0xA1, oct3a 0x0,mask 0x3C

    Sep 28 13:13:28.377: CSM_PROC_IDLE: CSM_EVENT_ISDN_CALL at slot 2, port 0

    Sep 28 13:13:28.377: Mica Modem(2/0): Configure(0x1 = 0x0)

    Sep 28 13:13:28.377: Mica Modem(2/0): Configure(0x23 = 0x0)

    Sep 28 13:13:28.377: Mica Modem(2/0): Call Setup

    ! -- CSM によって、コール セットアップ メッセージがモデム 2/0 に送信されます。

    ! -- モデムはこの段階で、オフフック状態にならなければなりません。

    Sep 28 13:13:28.377: csm_connect_pri_vdev: TS allocated at bp_stream 0,

    bp_Ch 0,vdev_common 0x6141BB68

    Sep 28 13:13:28.377: ISDN Se0:23: TX ->  CALL_PROC pd = 8  callref = 0xD285

    Sep 28 13:13:28.377:         Channel ID i = 0xA98383

    ! -- コール設定受付メッセージが、D チャネルを通して送られました。

    Sep 28 13:13:28.377: ISDN Se0:23: TX ->  ALERTING pd = 8  callref = 0xD285

    Sep 28 13:13:28.445: Mica Modem(2/0): State Transition to Call Setup

    ! -- モデムの状態は、コール セットアップに移行します。

    ! -- MICA モデムの状態に関する詳細は、「MICA Modem States」を参照してください。

    Sep 28 13:13:28.445: Mica Modem(2/0): Went offhook

    ! -- モデムがオフフック状態になったことが、CSM に通知されます。

    Sep 28 13:13:28.445: CSM_PROC_IC2_RING: CSM_EVENT_MODEM_OFFHOOK at slot 2, port 0

    Sep 28 13:13:28.445: ISDN Se0:23: TX ->  CONNECT pd = 8  callref = 0xD285

    ! -- D チャネルによって CONNECT が送信されました。

    Sep 28 13:13:28.461: ISDN Se0:23: RX <-  CONNECT_ACK pd = 8  callref = 0x5285

    ! -- Q.931 CONNECT_ACK が受信されました。

    Sep 28 13:13:28.461: ISDN Se0:23: CALL_PROGRESS: CALL_CONNECTED call id 0x28,

    bchan 2, dsl 0

    Sep 28 13:13:28.461: EVENT_FROM_ISDN::dchan_idb=0x618569F4, call_id=0x28,

    ces=0x0 bchan=0x2, event=0x4, cause=0x0

    Sep 28 13:13:28.461: EVENT_FROM_ISDN:(0028): DEV_CONNECTED at slot 2 and port 0

    Sep 28 13:13:28.461: CSM_PROC_IC6_WAIT_FOR_CONNECT:

    CSM_EVENT_ISDN_CONNECTED at slot 2, port 0

    Sep 28 13:13:28.465: Mica Modem(2/0): Link Initiate

    ! -- Q.931 CONNECT_ACK メッセージが受信されると、リンク開始メッセージが

    ! -- MICA モデムに送信され、

    ! -- リモート モデムとの接続がネゴシエートされます。

    Sep 28 13:13:28.465: %ISDN-6-CONNECT: Interface Serial0:2 is now connected to N/A N/A

    Sep 28 13:13:29.557: Mica Modem(2/0): State Transition to Connect

    ! -- モデムの状態は、「Connect」に変わります。

    Sep 28 13:13:34.073: Mica Modem(2/0): State Transition to Link

    Sep 28 13:13:45.478: Mica Modem(2/0): State Transition to Trainup

    Sep 28 13:13:53.642: Mica Modem(2/0): State Transition to EC Negotiating

    Sep 28 13:13:54.122: Mica Modem(2/0): State Transition to Steady State

    ! -- モデムは、「Steady State」に変わりました。

    Sep 28 13:13:54.266: TTY97: DSR came up

    ! -- モデムのトレインアップが終了したことが表示されました。

    Sep 28 13:13:54.266: tty97: Modem: IDLE->(unknown)

    Sep 28 13:13:54.266: TTY97: EXEC creation

    Sep 28 13:13:54.266: TTY97: set timer type 10, 30 seconds

    Sep 28 13:13:57.202: TTY97: Autoselect(2) sample 7E

    Sep 28 13:13:57.202: TTY97: Autoselect(2) sample 7EFF

    Sep 28 13:13:57.202: TTY97: Autoselect(2) sample 7EFF7D

    Sep 28 13:13:57.202: TTY97: Autoselect(2) sample 7EFF7D23

    Sep 28 13:13:57.202: TTY97 Autoselect cmd:  ppp negotiate

    ! -- ルータによって PPP パケットが検知され、自動的に PPP が起動します。

    Sep 28 13:13:57.206: TTY97: EXEC creation

    Sep 28 13:13:57.206: TTY97: create timer type 1, 600 seconds

    Sep 28 13:13:57.334: TTY97: destroy timer type 1

    Sep 28 13:13:57.334: TTY97: no timer type 0 to destroy

    Sep 28 13:13:57.334: As97 IPCP: Install route to 172.22.60.2

    Sep 28 13:13:59.334: %LINK-3-UPDOWN: Interface Async97, changed state to up

    Sep 28 13:13:59.334: As97 PPP: Treating connection as a callin

    Sep 28 13:13:59.334: As97 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0 load]

    Sep 28 13:13:59.334: As97 LCP: State is Listen

    ! -- LCP のネゴシエーションが開始します。

    Sep 28 13:14:00.214: As97 LCP: I CONFREQ [Listen] id 3 len 23

    ! -- LCP CONFREQ の着信

    ! -- PPP デバッグの解釈については、文書を参照してください。

    ! -- Dialup Technology:Troubleshooting Techniques

    Sep 28 13:14:00.214: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)

    Sep 28 13:14:00.214: As97 LCP:    MagicNumber 0x0F7CD34A (0x05060F7CD34A)

    Sep 28 13:14:00.214: As97 LCP:    PFC (0x0702)

    Sep 28 13:14:00.214: As97 LCP:    ACFC (0x0802)

    Sep 28 13:14:00.214: As97 LCP:    Callback 6  (0x0D0306)

    Sep 28 13:14:00.214: Unthrottle 97

    Sep 28 13:14:00.214: As97 LCP: O CONFREQ [Listen] id 1 len 43

    Sep 28 13:14:00.214: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)

    Sep 28 13:14:00.214: As97 LCP:    AuthProto CHAP (0x0305C22305)

    Sep 28 13:14:00.214: As97 LCP:    MagicNumber 0x3090DE31 (0x05063090DE31)

    Sep 28 13:14:00.214: As97 LCP:    PFC (0x0702)

    Sep 28 13:14:00.214: As97 LCP:    ACFC (0x0802)

    Sep 28 13:14:00.214: As97 LCP:    MRRU 1524 (0x110405F4)

    Sep 28 13:14:00.214: As97 LCP:    EndpointDisc 1 Local (

    0x130E016D6175692D6E61732D3032)

    Sep 28 13:14:00.214: As97 LCP: O CONFREJ [Listen] id 3 len 7

    Sep 28 13:14:00.214: As97 LCP:    Callback 6  (0x0D0306)

    Sep 28 13:14:00.342: As97 LCP: I CONFREQ [REQsent] id 4 len 20

    Sep 28 13:14:00.342: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)

    Sep 28 13:14:00.342: As97 LCP:    MagicNumber 0x0F7CD34A (0x05060F7CD34A)

    Sep 28 13:14:00.342: As97 LCP:    PFC (0x0702)

    Sep 28 13:14:00.342: As97 LCP:    ACFC (0x0802)

    Sep 28 13:14:00.342: As97 LCP: O CONFACK [REQsent] id 4 len 20

    Sep 28 13:14:00.342: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)

    Sep 28 13:14:00.342: As97 LCP:    MagicNumber 0x0F7CD34A (0x05060F7CD34A)

    Sep 28 13:14:00.342: As97 LCP:    PFC (0x0702)

    Sep 28 13:14:00.342: As97 LCP:    ACFC (0x0802)

    Sep 28 13:14:02.214: As97 LCP: TIMEout: State ACKsent

    Sep 28 13:14:02.214: As97 LCP: O CONFREQ [ACKsent] id 2 len 43

    Sep 28 13:14:02.214: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)

    Sep 28 13:14:02.214: As97 LCP:    AuthProto CHAP (0x0305C22305)

    Sep 28 13:14:02.214: As97 LCP:    MagicNumber 0x3090DE31 (0x05063090DE31)

    Sep 28 13:14:02.214: As97 LCP:    PFC (0x0702)

    Sep 28 13:14:02.214: As97 LCP:    ACFC (0x0802)

    Sep 28 13:14:02.214: As97 LCP:    MRRU 1524 (0x110405F4)

    Sep 28 13:14:02.214: As97 LCP:    EndpointDisc 1 Local

    (0x130E016D6175692D6E61732D3032)

    Sep 28 13:14:02.326: As97 LCP: I CONFREJ [ACKsent] id 2 len 22

    Sep 28 13:14:02.326: As97 LCP:    MRRU 1524 (0x110405F4)

    Sep 28 13:14:02.326: As97 LCP:    EndpointDisc 1 Local

    (0x130E016D6175692D6E61732D3032)

    Sep 28 13:14:02.326: As97 LCP: O CONFREQ [ACKsent] id 3 len 25

    Sep 28 13:14:02.326: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)

    Sep 28 13:14:02.326: As97 LCP:    AuthProto CHAP (0x0305C22305)

    Sep 28 13:14:02.326: As97 LCP:    MagicNumber 0x3090DE31 (0x05063090DE31)

    Sep 28 13:14:02.326: As97 LCP:    PFC (0x0702)

    Sep 28 13:14:02.326: As97 LCP:    ACFC (0x0802)

    Sep 28 13:14:02.518: As97 LCP: I CONFACK [ACKsent] id 3 len 25

    Sep 28 13:14:02.518: As97 LCP:    ACCM 0x000A0000 (0x0206000A0000)

    Sep 28 13:14:02.518: As97 LCP:    AuthProto CHAP (0x0305C22305)

    Sep 28 13:14:02.518: As97 LCP:    MagicNumber 0x3090DE31 (0x05063090DE31)

    Sep 28 13:14:02.518: As97 LCP:    PFC (0x0702)

    Sep 28 13:14:02.518: As97 LCP:    ACFC (0x0802)

    Sep 28 13:14:02.518: As97 LCP: State is Open

    ! -- LCP のネゴシエーションが終了します。

    Sep 28 13:14:02.518: As97 PPP: Phase is AUTHENTICATING,

    by this end [0 sess, 0 load]

    Sep 28 13:14:02.518: As97 CHAP: O CHALLENGE id 1 len 32 from "maui-nas-02"

    Sep 28 13:14:02.646: As97 CHAP: I RESPONSE id 1 len 31 from "async_user"

    Sep 28 13:14:02.646: As97 AUTH: Started process 0 pid 34

    Sep 28 13:14:02.650: As97 CHAP: O SUCCESS id 1 len 4

    ! -- CHAP 認証が成功しました。

    ! -- 認証が失敗した場合は、ユーザ名とパスワードが正しいことを確認します。

    ! -- 「">Dialup Technology:Troubleshooting Techniques」を参照してください。

    Sep 28 13:14:02.650: As97 PPP: Phase is UP [0 sess, 0 load]

    Sep 28 13:14:02.650: As97 IPCP: O CONFREQ [Closed] id 1 len 10

    ! -- IPCP のネゴシエーションが開始します。

    Sep 28 13:14:02.650: As97 IPCP:    Address 172.22.60.1 (0x0306AC163C01)

    Sep 28 13:14:02.758: As97 IPCP: I CONFREQ [REQsent] id 1 len 40

    Sep 28 13:14:02.758: As97 IPCP:    CompressType VJ 15 slots CompressSlotID

    (0x0206002D0F01)

    Sep 28 13:14:02.758: As97 IPCP:    Address 0.0.0.0 (0x030600000000)

    Sep 28 13:14:02.758: As97 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)

    Sep 28 13:14:02.758: As97 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000)

    Sep 28 13:14:02.758: As97 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)

    Sep 28 13:14:02.758: As97 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000)

    Sep 28 13:14:02.758: As97 AAA/AUTHOR/IPCP: Start.

    Her address 0.0.0.0, we want 172.22.60.2

    Sep 28 13:14:02.758: As97 AAA/AUTHOR/IPCP: Done.

    Her address 0.0.0.0, we want 172.22.60.2

    ! -- 「Async」という名前のアドレス プールからアドレスを取得しました。

    Sep 28 13:14:02.758: As97 IPCP: O CONFREJ [REQsent] id 1 len 28

    Sep 28 13:14:02.758: As97 IPCP:    CompressType VJ 15 slots CompressSlotID

    (0x0206002D0F01)

    Sep 28 13:14:02.758: As97 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000)

    Sep 28 13:14:02.758: As97 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)

    Sep 28 13:14:02.758: As97 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000)

    Sep 28 13:14:02.802: As97 CCP: I CONFREQ [Not negotiated] id 1 len 15

    Sep 28 13:14:02.802: As97 CCP:    MS-PPC supported bits 0x00000001

    (0x120600000001)

    Sep 28 13:14:02.802: As97 CCP:    Stacker history 1 check mode EXTENDED

    (0x1105000104)

    Sep 28 13:14:02.802: As97 LCP: O PROTREJ [Open] id 4 len 21 protocol CCP

    Sep 28 13:14:02.802: As97 LCP:  (0x80FD0101000F12060000000111050001)

    Sep 28 13:14:02.802: As97 LCP:  (0x04)

    Sep 28 13:14:02.802: As97 IPCP: I CONFACK [REQsent] id 1 len 10

    Sep 28 13:14:02.802: As97 IPCP:    Address 172.22.60.1 (0x0306AC163C01)

    Sep 28 13:14:04.650: As97 IPCP: TIMEout: State ACKrcvd

    Sep 28 13:14:04.650: As97 IPCP: O CONFREQ [ACKrcvd] id 2 len 10

    Sep 28 13:14:04.650: As97 IPCP:    Address 172.22.60.1 (0x0306AC163C01)

    Sep 28 13:14:04.758: As97 IPCP: I CONFACK [REQsent] id 2 len 10

    Sep 28 13:14:04.758: As97 IPCP:    Address 172.22.60.1 (0x0306AC163C01)

    Sep 28 13:14:05.750: As97 IPCP: I CONFREQ [ACKrcvd] id 2 len 34

    Sep 28 13:14:05.750: As97 IPCP:    Address 0.0.0.0 (0x030600000000)

    Sep 28 13:14:05.750: As97 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)

    Sep 28 13:14:05.750: As97 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000)

    Sep 28 13:14:05.750: As97 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)

    Sep 28 13:14:05.750: As97 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000)

    Sep 28 13:14:05.750: As97 AAA/AUTHOR/IPCP: Start.

    Her address 0.0.0.0, we want 172.22.60.2

    Sep 28 13:14:05.750: As97 AAA/AUTHOR/IPCP: Done.

    Her address 0.0.0.0, we want 172.22.60.2

    Sep 28 13:14:05.750: As97 IPCP: O CONFREJ [ACKrcvd] id 2 len 22

    Sep 28 13:14:05.750: As97 IPCP:    PrimaryWINS 0.0.0.0 (0x820600000000)

    Sep 28 13:14:05.754: As97 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)

    Sep 28 13:14:05.754: As97 IPCP:    SecondaryWINS 0.0.0.0 (0x840600000000)

    Sep 28 13:14:05.878: As97 IPCP: I CONFREQ [ACKrcvd] id 3 len 16

    Sep 28 13:14:05.878: As97 IPCP:    Address 0.0.0.0 (0x030600000000)

    Sep 28 13:14:05.878: As97 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)

    Sep 28 13:14:05.878: As97 AAA/AUTHOR/IPCP: Start.

    Her address 0.0.0.0, we want 172.22.60.2

    Sep 28 13:14:05.878: As97 AAA/AUTHOR/IPCP: Done.

    Her address 0.0.0.0, we want 172.22.60.2

    Sep 28 13:14:05.878: As97 IPCP: O CONFNAK [ACKrcvd] id 3 len 10

    Sep 28 13:14:05.878: As97 IPCP:    Address 172.22.60.2 (0x0306AC163C02)

    Sep 28 13:14:05.990: As97 IPCP: I CONFREQ [ACKrcvd] id 4 len 16

    Sep 28 13:14:05.990: As97 IPCP:    Address 172.22.60.2 (0x0306AC163C02)

    Sep 28 13:14:05.990: As97 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)

    Sep 28 13:14:05.990: As97 AAA/AUTHOR/IPCP: Start.

    Her address 172.22.60.2, we want 172.22.60.2

    Sep 28 13:14:05.990: As97 AAA/AUTHOR/IPCP: Reject 172.22.60.2, using 172.22.60.2

    Sep 28 13:14:05.990: As97 AAA/AUTHOR/IPCP: Done.

    Her address 172.22.60.2, we want 172.22.60.2

    Sep 28 13:14:05.994: As97 IPCP: O CONFACK [ACKrcvd] id 4 len 16

    Sep 28 13:14:05.994: As97 IPCP:    Address 172.22.60.2 (0x0306AC163C02)

    Sep 28 13:14:05.994: As97 IPCP:    PrimaryDNS 172.22.53.210 (0x8106AC1635D2)

    Sep 28 13:14:05.994: As97 IPCP: State is Open

    ! -- IPCP のネゴシエーションが終了します。これでユーザは接続されました。

    

ISDN コールの場合

maui-nas-02#debug isdn q931

    ISDN Q931 packets debugging is on

    maui-nas-02#debug ppp negotiation

    PPP protocol negotiation debugging is on

    maui-nas-02#debug ppp authentication

    PPP authentication debugging is on

    

    Sep 28 13:25:02.630: ISDN Se0:23: RX <-  SETUP pd = 8  callref = 0x5346

    ! -- Q.931 SETUP 着信メッセージ。

    Sep 28 13:25:02.630:         Bearer Capability i = 0x8890218F

    Sep 28 13:25:02.630:         Channel ID i = 0xA18384

    Sep 28 13:25:02.630:         Called Party Number i = 0xA1, '81560',

    Plan:ISDN, Type:National

    Sep 28 13:25:02.634: %LINK-3-UPDOWN: Interface Serial0:3, changed state to up

    Sep 28 13:25:02.638: Se0:3 PPP: Treating connection as a callin

    Sep 28 13:25:02.638: Se0:3 PPP: Phase is ESTABLISHING,

    Passive Open [0 sess, 1 load]

    Sep 28 13:25:02.638: Se0:3 LCP: State is Listen

    

    Sep 28 13:25:02.638: ISDN Se0:23: TX ->  CALL_PROC pd = 8  callref = 0xD346

    Sep 28 13:25:02.638:         Channel ID i = 0xA98384

    Sep 28 13:25:02.638: ISDN Se0:23: TX ->  CONNECT pd = 8  callref = 0xD346

    Sep 28 13:25:02.638:         Channel ID i = 0xA98384

    Sep 28 13:25:02.658: ISDN Se0:23: RX <-  CONNECT_ACK pd = 8  callref = 0x5346

    

    Sep 28 13:25:02.658: ISDN Se0:23: CALL_PROGRESS: 

    CALL_CONNECTED call id 0x2B, bchan 3, dsl 0

    ! -- コールは接続されました。

    Sep 28 13:25:02.886: Se0:3 LCP: I CONFREQ [Listen] id 61 len 28

    Sep 28 13:25:02.886: Se0:3 LCP:    MagicNumber 0x1EB88B1C (0x05061EB88B1C)

    Sep 28 13:25:02.886: Se0:3 LCP:    MRRU 1524 (0x110405F4)

    Sep 28 13:25:02.886: Se0:3 LCP:    EndpointDisc 1 Local

    (0x130E0161757374696E5F6973646E)

    Sep 28 13:25:02.886: Se0:3 LCP: O CONFREQ [Listen] id 1 len 33

    Sep 28 13:25:02.886: Se0:3 LCP:    AuthProto CHAP (0x0305C22305)

    Sep 28 13:25:02.886: Se0:3 LCP:    MagicNumber 0x309AFABD (0x0506309AFABD)

    Sep 28 13:25:02.886: Se0:3 LCP:    MRRU 1524 (0x110405F4)

    Sep 28 13:25:02.886: Se0:3 LCP:    EndpointDisc 1 Local

    (0x130E016D6175692D6E61732D3032)

    Sep 28 13:25:02.886: Se0:3 LCP: O CONFACK [Listen] id 61 len 28

    Sep 28 13:25:02.886: Se0:3 LCP:    MagicNumber 0x1EB88B1C (0x05061EB88B1C)

    Sep 28 13:25:02.886: Se0:3 LCP:    MRRU 1524 (0x110405F4)

    Sep 28 13:25:02.886: Se0:3 LCP:    EndpointDisc 1 Local

    (0x130E0161757374696E5F6973646E)

    Sep 28 13:25:02.922: Se0:3 LCP: I CONFACK [ACKsent] id 1 len 33

    Sep 28 13:25:02.922: Se0:3 LCP:    AuthProto CHAP (0x0305C22305)

    Sep 28 13:25:02.922: Se0:3 LCP:    MagicNumber 0x309AFABD (0x0506309AFABD)

    Sep 28 13:25:02.922: Se0:3 LCP:    MRRU 1524 (0x110405F4)

    Sep 28 13:25:02.922: Se0:3 LCP:    EndpointDisc 1 Local

    (0x130E016D6175692D6E61732D3032)

    Sep 28 13:25:02.922: Se0:3 LCP: State is Open

    ! -- LCP のネゴシエーションが終了します。

    Sep 28 13:25:02.922: Se0:3 PPP:

    Phase is AUTHENTICATING, by this end [0 sess, 1 load]

    Sep 28 13:25:02.922: Se0:3 CHAP: O CHALLENGE id 1 len 32 from "maui-nas-02"

    Sep 28 13:25:02.954: Se0:3 CHAP: I RESPONSE id 1 len 32 from "austin_isdn"

    Sep 28 13:25:02.954: Se0:3 CHAP: O SUCCESS id 1 len 4

    ! -- PPP CHAP 認証が成功しました。

    Sep 28 13:25:02.958: Se0:3 PPP: Phase is VIRTUALIZED [0 sess, 1 load]

    Sep 28 13:25:02.958: Vi1 PPP: Phase is DOWN, Setup [0 sess, 1 load]

    Sep 28 13:25:02.982: Vi1 PPP: Phase is DOWN, Setup [0 sess, 1 load]

    Sep 28 13:25:02.982: Se0:3 IPCP:

    Packet buffered while building MLP bundle interface

    Sep 28 13:25:02.986: %LINK-3-UPDOWN: Interface Virtual-Access1,

    changed state to up

    ! -- 仮想アクセス インターフェイスが活動状態です。

    ! -- このインターフェイスによって、着信コールが制御されます。

    Sep 28 13:25:02.986: Vi1 PPP: Treating connection as a callin

    Sep 28 13:25:02.986: Vi1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 1 load]

    Sep 28 13:25:02.986: Vi1 LCP: State is Listen

    Sep 28 13:25:02.986: Vi1 PPP: Phase is UP [0 sess, 1 load]

    Sep 28 13:25:02.986: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10

    Sep 28 13:25:02.986: Vi1 IPCP:    Address 172.22.61.1 (0x0306AC163D01)

    Sep 28 13:25:02.990: Vi1 MLP: Added first link Se0:3 to bundle austin_isdn

    Sep 28 13:25:02.990: Vi1 PPP: Pending ncpQ size is 1

    Sep 28 13:25:02.990: Se0:3 IPCP: Redirect packet to Vi1

    Sep 28 13:25:02.990: Vi1 IPCP: I CONFREQ [REQsent] id 45 len 10

    Sep 28 13:25:02.990: Vi1 IPCP:    Address 10.0.0.1 (0x03060A000001)

    Sep 28 13:25:02.990: Vi1 AAA/AUTHOR/IPCP: Start.

    Her address 10.0.0.1, we want 0.0.0.0

    Sep 28 13:25:02.990: Vi1 AAA/AUTHOR/IPCP: Reject 10.0.0.1, using 0.0.0.0

    Sep 28 13:25:02.990: Vi1 AAA/AUTHOR/IPCP: Done.

    Her address 10.0.0.1, we want 0.0.0.0

    Sep 28 13:25:02.990: Vi1 IPCP: O CONFNAK [REQsent] id 45 len 10

    Sep 28 13:25:02.990: Vi1 IPCP:    Address 172.22.61.2 (0x0306AC163D02)

    ! -- ピアの IP アドレスが、「ISDN」という名前の IP プールから割り当てられます。

    Sep 28 13:25:02.990: Se0:3 CDPCP: MLP bundle interface is built,

    process packets now

    Sep 28 13:25:02.990: Se0:3 CDPCP: Redirect packet to Vi1

    Sep 28 13:25:02.990: Vi1 CDPCP: I CONFREQ [Not negotiated] id 23 len 4

    Sep 28 13:25:02.990: Vi1 LCP: O PROTREJ [Open] id 1 len 10 protocol CDPCP

    (0x820701170004)

    Sep 28 13:25:03.010: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10

    Sep 28 13:25:03.010: Vi1 IPCP:    Address 172.22.61.1 (0x0306AC163D01)

    Sep 28 13:25:03.010: Vi1 IPCP: I CONFREQ [ACKrcvd] id 46 len 4

    Sep 28 13:25:03.010: Vi1 IPCP: O CONFACK [ACKrcvd] id 46 len 4

    Sep 28 13:25:03.010: Vi1 IPCP: State is Open

    ! -- IPCP のネゴシエーションが終了します。-- これでコールは接続されました。

    Sep 28 13:25:03.014: Di10 IPCP: Install route to 172.22.61.2

    Sep 28 13:25:03.958: %LINEPROTO-5-UPDOWN:

    Line protocol on Interface Serial0:3, changed state to up

    Sep 28 13:25:03.986: %LINEPROTO-5-UPDOWN:

    Line protocol on Interface Virtual-Access1, changed state to up

    Sep 28 13:25:04.146: ISDN Se0:23: RX <-  SETUP pd = 8  callref = 0x5409

    ! -- マルチリンク接続の 2 番目のリンクが到着しています。

    Sep 28 13:25:04.150:         Bearer Capability i = 0x8890218F

    Sep 28 13:25:04.150:         Channel ID i = 0xA18385

    Sep 28 13:25:04.150:         Called Party Number i = 0xA1, '81560', Plan:ISDN,

    Type:National

    Sep 28 13:25:04.154: %LINK-3-UPDOWN: Interface Serial0:4, changed state to up

    Sep 28 13:25:04.154: %ISDN-6-CONNECT: Interface Serial0:3 is now connected to

    austin_isdn

    Sep 28 13:25:04.154: Se0:4 PPP: Treating connection as a callin

    Sep 28 13:25:04.154: Se0:4 PPP: Phase is ESTABLISHING,

    Passive Open [0 sess, 1 load]

    Sep 28 13:25:04.154: Se0:4 LCP: State is Listen

    Sep 28 13:25:04.158: ISDN Se0:23: TX ->  CALL_PROC pd = 8  callref = 0xD409

    Sep 28 13:25:04.158:         Channel ID i = 0xA98385

    Sep 28 13:25:04.158: ISDN Se0:23: TX ->  CONNECT pd = 8  callref = 0xD409

    Sep 28 13:25:04.158:         Channel ID i = 0xA98385

    Sep 28 13:25:04.178: ISDN Se0:23: RX <-  CONNECT_ACK pd = 8  callref = 0x5409

    

    Sep 28 13:25:04.178: ISDN Se0:23: CALL_PROGRESS:

    CALL_CONNECTED call id 0x2C, bchan 4, dsl 0

    Sep 28 13:25:04.394: Se0:4 LCP: I CONFREQ [Listen] id 51 len 28

    Sep 28 13:25:04.394: Se0:4 LCP:    MagicNumber 0x1EB8910D (0x05061EB8910D)

    Sep 28 13:25:04.394: Se0:4 LCP:    MRRU 1524 (0x110405F4)

    Sep 28 13:25:04.394: Se0:4 LCP:    EndpointDisc 1 Local

    (0x130E0161757374696E5F6973646E)

    Sep 28 13:25:04.394: Se0:4 LCP: O CONFREQ [Listen] id 1 len 33

    Sep 28 13:25:04.394: Se0:4 LCP:    AuthProto CHAP (0x0305C22305)

    Sep 28 13:25:04.394: Se0:4 LCP:    MagicNumber 0x309B00A6 (0x0506309B00A6)

    Sep 28 13:25:04.394: Se0:4 LCP:    MRRU 1524 (0x110405F4)

    Sep 28 13:25:04.394: Se0:4 LCP:    EndpointDisc 1 Local

    (0x130E016D6175692D6E61732D3032)

    Sep 28 13:25:04.394: Se0:4 LCP: O CONFACK [Listen] id 51 len 28

    Sep 28 13:25:04.394: Se0:4 LCP:    MagicNumber 0x1EB8910D (0x05061EB8910D)

    Sep 28 13:25:04.394: Se0:4 LCP:    MRRU 1524 (0x110405F4)

    Sep 28 13:25:04.394: Se0:4 LCP:    EndpointDisc 1 Local

    (0x130E0161757374696E5F6973646E)

    Sep 28 13:25:04.430: Se0:4 LCP: I CONFACK [ACKsent] id 1 len 33

    Sep 28 13:25:04.430: Se0:4 LCP:    AuthProto CHAP (0x0305C22305)

    Sep 28 13:25:04.430: Se0:4 LCP:    MagicNumber 0x309B00A6 (0x0506309B00A6)

    Sep 28 13:25:04.430: Se0:4 LCP:    MRRU 1524 (0x110405F4)

    Sep 28 13:25:04.430: Se0:4 LCP:    EndpointDisc 1 Local

    (0x130E016D6175692D6E61732D3032)

    Sep 28 13:25:04.430: Se0:4 LCP: State is Open

    Sep 28 13:25:04.430: Se0:4 PPP: Phase is AUTHENTICATING,

    by this end [0 sess, 1 load]

    Sep 28 13:25:04.430: Se0:4 CHAP: O CHALLENGE id 1 len 32 from "maui-nas-02"

    Sep 28 13:25:04.462: Se0:4 CHAP: I RESPONSE id 1 len 32 from "austin_isdn"

    Sep 28 13:25:04.466: Se0:4 CHAP: O SUCCESS id 1 len 4

    Sep 28 13:25:04.466: Se0:4 PPP: Phase is VIRTUALIZED [0 sess, 1 load]

    Sep 28 13:25:04.466: Vi1 MLP: Added link Se0:4 to bundle austin_isdn

    ! -- 既存の仮想インターフェイス バンドルに、別のリンクが今、追加されました。

    Sep 28 13:25:05.466: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:4,

    changed state to up

    Sep 28 13:25:10.154: %ISDN-6-CONNECT:

    Interface Serial0:4 is now connected to austin_isdn

    ! -- 2 番目のコールが接続されました。マルチリンク バンドルは終了します。 

    maui-nas-02# 

ツール情報

アクセスダイヤル テクノロジーのツールにアクセスするには、ここをクリックします。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 6310