音声 : テレフォニー シグナリング

VoIP と共通線信号方式(CCS)

2005 年 9 月 9 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 11 月 20 日) | フィードバック

目次


概要

この文書では、下記のトポロジの 2 台のルータがデジタル PRI 経由の共通線信号(CCS)および VoIP によって通信するために必要な設定を示します。

下記の設定では、 IP セグメントを経由して 2 台のルータをback-to-backで接続しています。しかし、ほとんどの実環境では音声対応のルータを任意の場所に配置しています。通常、音声ルータ はLAN経由で 他のWANルータに接続して使用します。特に、音声ルータが専用線などのWANに直接接続されていない場合、WANに関わる全ての 設定コマンドは WAN ルータ に設定することに注意してください。

この設定例では Cisco 3640 および Cisco AS5300 を使用しますが、この設定は Cisco 2600 シリーズのルータにも使用できます。

注:下記の設定では QoS は実装されていません。下記の設定は説明用のものであり、実際のネットワークでは適切に QoS を実装する必要があります。

T1 シグナリング:CAS および CCS

電話網で使用するシグナリングは、回線状態の監視および通知などの機能を提供し、呼接続の時に相手デバイス を呼び出したり、呼のルーティングやアドレッシングを行います。

T1 における信号方式には次の 2 種類があります。

  • 共通信号方式(CCS)
  • 個別線信号方式(CAS)

CCS

CCS は、アウトバンドによるシグナリング情報の伝送方式です。このシグナリング方式の中でも特に広く使用されているものは ISDN です。 ISDN の一次群速度インターフェイス(PRI)を使用するときの欠点として、 1 つの DS0(この場合は音声チャネル)がシグナリングチャネルとして占有されることがあげられます。したがって、1 つの T1 には、ユーザ のデータ伝送チャネルとして23ch の DSO(B チャネル)と、シグナリング用に 1 つの DSO(D チャネル)があります。また、Non Facility Associated Signaling(NFAS)を使用することにより、 1 つの D チャネルで複数の PRI を制御できるため、 NFAS グループに他の PRI を設定し、B チャネルとして 24 の DSO を使用することも可能です。 PRI シグナリングを使用すると、特に 56K モデムの出現により、非常に高速な接続を実現 することができます。これが ISDN の純粋なチャネル容量です。

上記のトポロジで CCS を使用する欠点として、上記の PBX に、E&M シグナリング カードより高価なデジタル T1 PRI カードが必要な点もあげられます。 PBXが個別線信号信号方式(CAS)を使用している場合は、 代わりにE&M カード を使用することも可能です。

CAS

CCS は、帯域内でシグナリング情報を伝送します(インバンド シグナリング)。この場合、音声信号と共に回線状態、番号、および呼び出し信号などが同じチャネルで伝送されます。フル T1 回線には 24 のチャネルがあり、 CAS は音声信号の間にシグナリング の情報を割り込ませるため、音声用に24 チャネルすべてを使用できます。

T1 では各種の CAS シグナリングを使用できます。最も一般的な形式の CAS シグナリングは、ループスタート、グラウンドスタート、および E&M シグナリングです。 CAS シグナリングの欠点としては、音声信号の一部のビットを 利用してシグナリングを転送するため、IPパケット化に対するロスが発生します。このため、CAS シグナリングは、 ロブド ビット シグナリング とも呼ばれます。

モデムで可能な最高の接続速度を必要とする場合には CAS は適していません。ほとんどのモデムは信号品質に適合でき、高速度でも信頼性の高い接続を行うことができます。しかし、CAS 回線で 56K モデムを使用すると、 CAS シグナリングを使用するトランクにより、通信のダウンストリームで接続速度が約 2K 低下します。

準備

Cisco ルータにVoIPの設定をするには、 Cisco IOS ソフトウェアにおける QoS 機能の概念を理解する必要があります。 QoS 機能については、CCO の Cisco IOS Quality of Service ページに記載されているキューイング、トラフィック シェーピング、およびフィルタリングおよび QoS シグナリングを参照してください。

Cisco 3640 San Jose
sanjose3640A#sh run
  Building configuration...
   
  Current configuration:
  !
  version 12.0
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname 3640
  !
  logging buffered 60000 debugging
  enable password cisco
  !
  no ip subnet-zero
  !
  !
  !
  !
  voice-port 1/0/0
  !
  voice-port 1/0/1
  !
  voice-port 3/0/0
   operation 4-wire
  !
  voice-port 3/0/1
   operation 4-wire
  !
  voice-port 3/1/0
  !
  voice-port 3/1/1
  !
  dial-peer voice 1 pots         <--ダイヤルピアの詳細
   destination-pattern 4552468
   port 1/0/1
  !
  dial-peer voice 2 voip
   destination-pattern 3006
   session target ipv4:10.2.1.2
  !
  dial-peer voice 3 pots
   destination-pattern 5551234
   port 1/0/0
  !
  dial-peer voice 4 voip
   destination-pattern 4005
   fax-rate 9600
   session target ipv4:10.2.1.2
  !
  interface Ethernet0/0
   ip address 10.2.1.1 255.255.255.0
   no ip directed-broadcast
  !
  interface Serial2/0
   no ip address
   no ip directed-broadcast
   no ip mroute-cache
   shutdown
   no fair-queue
   clockrate 64000
  !
  interface Serial2/1
   no ip address
   no ip directed-broadcast
   shutdown
   clockrate 38000
  !
  interface Serial2/2
   no ip address
   no ip directed-broadcast
   shutdown
  !
  interface Serial2/3
   no ip address
   no ip directed-broadcast
   shutdown
  !
  ip classless
  no ip http server
  !
  !
  !
  line con 0
   transport input none
  line aux 0
  line vty 0 4
   password cisco
   login
  !
  end
  
  
   

 

Cisco AS5300 Raleigh
AS5300#sh run
  Building configuration...
   
  Current configuration:
  !
  version 11.3
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname AS5300
  !
  boot system flash c5300-js-mz_113-6_na2.bin
  enable password cisco
  !
  isdn switch-type primary-dms100
  !
  !
  controller T1 0
   framing esf
   clock source line primary
   linecode b8zs
   pri-group timeslots 1-24
  !
  controller T1 1
   clock source internal
  !
  controller T1 2
   clock source internal
  !
  controller T1 3
   clock source internal
  !
  !
  dial-peer voice 1 voip               <--ダイヤルピアの詳細
   destination-pattern 4552468
   session target ipv4:10.2.1.1
  !
  dial-peer voice 2 pots
   destination-pattern 3...
   direct-inward-dial
   port 0:D
   prefix 3
  !
  dial-peer voice 4 pots
   destination-pattern 4...
   direct-inward-dial
   port 0:D
   prefix 4
  !
  dial-peer voice 3 voip
   destination-pattern 5551234
   fax-rate 9600
   session target ipv4:10.2.1.1
  !
  !
  voice-port 0:D
  !
  interface Ethernet0
   ip address 10.2.1.2 255.255.255.0
  !
  interface Serial0:23
   no ip address
   isdn switch-type primary-dms100
   isdn tei-negotiation first-call
   isdn incoming-voice modem
   no cdp enable
  !
  interface FastEthernet0
   no ip address
   shutdown
  !
  ip classless
  !
  logging buffered 60000 debugging
  !
  !
  line con 0
  line aux 0
  line vty 0 4
   password cisco
   login
  !
  end
  

デバッグおよび表示コマンドを使用したトラブルシューティング

上記の debug コマンドを実行する前に、デバッグ コマンドに関する重要事項を参照してください。


関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 14079