音声 : ゲートウェイ プロトコル

LLQ、PPP LFI、および cRTP を使用したフレームリレー ATM インターワーキングの VoIP QOS

2002 年 10 月 30 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 2 月 2 日) | フィードバック

目次


概要

この文書は、Multilink PPP over ATM and Frame Relay Interworking(MLPoATM / MLPoFR)を使用した Voice over IP(VoIP)の設定例を示しています。設定例では、ATM/フレームリレー インターワーキング WAN 全体を通じて音声を適切にサポートする Quality of Service(QOS)のプロビジョニングを中心に取り上げています。また、Cisco IOS(R) ソフトウェア リリース 12.2(2)T 以降で ATM についてサポートされている compressed Real Time Protocol(cRTP)の使用例も示しています。

この文書だけで、設定に関するガイドライン、設定例、およびネットワーク構築時に使用する検証用コマンドについて調べることができます。ATM/フレームリレー インターワーキングの使用に関する特定の問題については、背景情報もあわせて記載されています。VoIP over Frame Relay または PPP の QOS に関する背景情報については、次の文書を参照してください。

表記法

文書表記の詳細については、「シスコ テクニカル ティップスの表記法」を参照してください。

背景理論

ATM/フレームリレー インターワーキング ネットワーク全体を通じて VoIP のエンドツーエンドの遅延を最小化し、ジッタを回避するためには、次のような問題が重要になります。

  • 音声トラフィックの完全優先権(Low Latency Queueing(LLQ; 低遅延キューイング))
  • Link Fragmentation and Interleaving(LFI; リンク断片化およびインターリービング)
  • 音声の Frame Relay Traffic Shaping(FRTS; フレームリレー トラフィック シェーピング)
  • ATM トラフィック シェーピング

さらに詳しい背景情報については、次の文書を参照してください。

設定

この項では、この文書に記載されている機能を設定するための情報を示します。

注:この文書で使用されているコマンドの詳細を調べるには、IOS Command Lookup ツールを使用してください。

前提条件

この文書の設定を利用するには、次のテクノロジー領域についての知識が必要です。

  • アクセス コントロール リスト
  • ATM Permanent Virtual Circuit(PVC; 相手先固定接続)
  • フレームリレー PVC(Data-Link Connection Identifier(DLCI; データリンク接続識別子)
  • 帯域幅管理
  • LLQ
  • LFI
  • 仮想テンプレートと仮想アクセス インターフェイス
  • MLPPP
  • cRTP

使用するコンポーネント

これらの設定は、次の機器を使用してテストしました。

  • ATM ルータとして Cisco 3640
  • フレームリレー ルータとして Cisco 2620
  • Cisco IOS ソフトウェア リリース 12.2(8)T(IP Plus)

注:一般的なガイドラインとして、MLPoATM/FR を使用するためには、最新の Cisco IOS 12.2 メインライン メンテナンス リリースの使用が推奨されます。cRTP を使用する場合は、ATM ルータに Cisco IOS ソフトウェア リリース 12.2T が必要です。

関連する各機能が導入された Cisco IOS リリースは次のとおりです。

  • LFI は Cisco IOS ソフトウェア リリース 11.3 で導入されました。
  • LLQ は Cisco IOS ソフトウェア リリース 12.0(7)T で導入されました。
  • フレームリレーおよび ATM での PVC 単位の LLQ は Cisco IOS ソフトウェア リリース 12.1(2)T で導入されました。
  • フレームリレーおよび ATM 仮想回線でのマルチリンク PPP LFI は Cisco IOS ソフトウェア リリース 12.1(5)T で導入されました。
  • ATM での cRTP は Cisco IOS ソフトウェア リリース 12.2(2)T で導入されました。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。この文書内で使用されているデバイスはすべて、クリアーな状態(デフォルト)から設定作業を始めています。コマンドを実行する前に、実稼動中のネットワークに与える影響について理解しておいてください。

ネットワーク ダイアグラム

この文書では次の図に示すネットワーク設定を使用しています。

設定

この文書では次に示す設定を使用しています。

注:下記の設定で注意すべき点は、2 台のルータがフレームリレー ATM インターネットワーキング スイッチを通じてバックツーバックで接続されている点です。ただし、ほとんどのトポロジで、音声対応ルータは任意の場所に配置できます。通常、音声ルータは LAN 接続を使用して、ATM/フレーム WAN に接続されている他のルータに接続します。このようなケースでは、下記の設定に示されているように、音声ゲートウェイではなく、WAN、フレームリレー、および ATM に接続されたルbータで LLQ、LFI、および MLPPP を設定し、QOS を提供する必要があります。

フレームリレー接続ルータ



!--- 注:この設定のコメントと番号は、コマンドを入力すべき順序に

!--- 従っています。





version 12.2

service timestamps debug datetime msec

service timestamps log uptime

no service password-encryption

!

hostname FR

!

enable password cisco

!

username ATM password 0 cisco

voice-card 0

dspfarm

!

ip subnet-zero

!

!

!

!
access-list 105 permit ip any any dscp ef 1
access-list 105 permit udp any any range 16384 32767
access-list 105 permit ip any any precedence critical
! class-map match-all voice 2
match access-group 105
! !--- 1 Differentiated Services Code Point(DSCP)が 40 に設定されているすべてのトラフィックが !--- このアクセスリストに分類されることを指定します。 !--- 2 この class-map コマンドは「voice」という名前のトラフィック クラスを定義します。
!
!
policy-map VOIP 3
class voice 4
priority 48 5
class class-default 6
fair-queue 7 !--- 3 この policy-map コマンドは「VOIP」という名前の LLQ 用のポリシーを定義し、 !--- 4「voice」クラスを「VOIP」ポリシーにマップします。 !--- 5プライオリティ キュー用に予約された帯域幅の量を定義します。 !--- 6デフォルト クラスもこのポリシーにマップされます。 !--- 7他のトラフィックはすべて WFQ で処理されるように指定します。
!--- 注:PQ にはさまざまなタイプのリアルタイム トラフィックを !--- 入れることができますが、シスコでは PQ に !--- 音声トラフィックのみを入れることを推奨しています。 !--- ビデオや音声などのリアルタイム トラフィックは、 !--- 遅延の変動をもたらす可能性があります。1 つの PVC で !--- 音声とビデオを流さないように注意してください。 !--- (PQ は First In, First Out(FIFO; 先入れ先出し)キューです)。 !--- 音声トラフィックでは、ジッタを避けるために !--- 遅延を一定にする必要があります。 !--- 注:priority 文と bandwidth 文の !--- 値の合計はリンク帯域幅の !--- 75% 以下であることが必要です。 !--- そうでなければ、service-policy をリンクに !--- 割り当てることができません。 !--- 64 Kbps リンクで VoIP を設定して !--- 2 つの音声コールをサポートする場合は、 !--- 一般にリンク帯域幅の 75%(48 Kbps)より !--- 大きい値を PQ に割り当てます。このような場合は、コマンド !--- max-reserved-bandwidth <#%> を使用して、 !--- 使用可能な帯域幅を 75% より大きい値に増やすことができます。

! !
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
interface Loopback0
ip address 10.1.1.2 255.255.255.0
!

!
interface FastEthernet0/0
ip address 172.17.111.16 255.255.255.224
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay IETF
no ip route-cache
no ip mroute-cache
frame-relay traffic-shaping
!
interface Serial0/0.1 point-to-point 18
no ip route-cache
no ip mroute-cache
frame-relay interface-dlci 16 ppp Virtual-Template1 19
class mlp 20 !--- 19 仮想インターフェイスに関連付けるフレームリレー インターフェイス !--- を選択します。仮想テンプレートは !--- 物理インターフェイスにも同様に関連付けること !--- ができます。 !--- 20 下の 8 で定義されている仮想テンプレート インターフェイスをフレームリレー DLCI に関連付けます。 !--- 21 Associates a Frame Relay map class with a DLCI.
!
interface Virtual-Template1 8
bandwidth 64 9
ip unnumbered loopback0 ip rtp header-compression 9b
no ip route-cache
load-interval 30
max-reserved-bandwidth 99
service-policy output VOIP 10
ppp multilink 11
ppp multilink fragment-delay 10 12
ppp multilink interleave 13
! !--- 8 interface コマンドによって「Virtual-Template1」という !--- 名前の仮想テンプレートを作成します。 !--- 9 このテンプレート インターフェイスに 64 Kbps の !--- 帯域幅を割り当てます。この帯域幅は、下の 13 に記載されている方法 !--- に従ってデータ断片化サイズを算出するために IOS によって使用されます。 !--- 9b cRTP は ATM/フレームリレー インターワーキング環境でサポート !--- されています。これを使用するには、ATM ルータに Cisco IOS ソフトウェア リリース 12.2(2)T が !--- 必要です。 !--- 10 前に作成した VoIP ポリシーをこのインターフェイスの !--- 発信方向に割り当てます。 !--- 11 PPP マルチリンクを有効にし、 !--- 12 セグメントごとの最大遅延を指定します。この帯域幅は、 !--- 下の 13 に記載されている方法に従ってデータ断片化サイズを算出するために !--- IOS によって使用されます。
!---
13 音声パケットを高速に転送するために、PPP セグメントの !--- インターリービングを有効にします。 !--- 音声パケットは、 !--- 先にキューイングされたデータ パケット全体が終了するまで待つのではなく、 !--- データ パケットの 1 つのセグメントの処理を待つだけで済みます !--- (10 ミリ秒などの短い遅延になります)。 !--- IOS は次の公式に従って !--- データ断片化サイズを算出します。 !--- 断片化サイズ = 遅延 x 帯域幅/8
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.111.1
no ip http server
ip pim bidir-enable
!
!
!
map-class frame-relay mlp
14
no frame-relay adaptive-shaping 15
frame-relay cir 64000 16
frame-relay bc 640 17
frame-relay be 0 18 !--- 14 「mlp」という名前のマップ クラスを作成します。 !--- 15 適応シェーピングを無効にします。トラフィックが !--- CIR を超過し、なおかつフレームリレー ネットワーク内に音声パケット !--- がキューイングされている状況は避ける必要があります。 !--- BECN の到達を待つことで !--- この状況を解決する方法をとると、結果的に音声品質が低下します。 !--- 16 このコマンドを設定すると、ルータはポートの !--- 回線レートではなく、指定された CIR でトラフィックを !--- 伝送します。 !--- 17Tc(シェーピング間隔)値が 10 ミリ秒になるように !--- Bc 値を設定します。 !--- Bc 値の計算には次の公式を使用します。Tc = Bc/CIR。 !--- Tc 値を小さくすると、音声パケットが送信時に待機する !--- 間隔が短くなります。 !--- 18 フレームリレー ネットワークで保証されていないバースト !--- の一部として音声が送信されないようにするため、 !--- Be 値をゼロに設定します。
!
call rsvp-sync
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 123 voip
destination-pattern 123
session target ipv4:10.1.1.1
ip qos dscp cs5 media
ip qos dscp cs5 signaling
no vad
!
dial-peer voice 456 pots
destination-pattern 456
port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!
!
end
ATM 接続ルータ
!--- 注:この設定では、上記のフレームリレー ルータ

!--- の設定にはない追加での注意が必要な箇所にのみ、

!--- コメントが記載されています。



version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname ATM
!
enable password cisco
!
username FR password 0 cisco
memory-size iomem 25
ip subnet-zero
!
!
!
access-list 105 permit ip any any dscp ef 2
access-list 105 permit udp any any range 16384 32767
access-list 105 permit ip any any precedence critical

!
class-map match-all voice
match access-group 105
!
!
!--- 注:ネットワークのフレームリレー ルータ側のコマンドと合わせます。
!
!
policy-map VOIP
class voice
priority 48
class class-default
fair-queue
!--- 注:ネットワークのフレームリレー ルータ側のコマンドと合わせます。
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller T1 2/0
framing sf
linecode ami
!
!
!
!
interface ATM0/0
no ip address
ip route-cache
no atm ilmi-keepalive
!
interface ATM0/0.1 point-to-point 22
ip route-cache
pvc 10/100 23 cbr 64 24
encapsulation aal5snap 25
protocol ppp Virtual-Template1 26 !--- 22 ATM サブインターフェイスを選択します。 !--- 物理インターフェイスでも同様に使用できます。 !--- 23 ATM PVC を作成します。
!--- 24 VBR PVC は別の例ですでに定義されています。 !--- その例では VBR 非リアルタイムを使用し、バースティングを !--- 回避するために Sustained Cell Rate(SCR; 平均セルレート)を !--- Peak Cell Rate(PCR; ピーク セルレート)と同じ値にしています。 !--- ATM にはセル タックスがあり、さらに断片/セルの !--- 不正確な調整によって ATM 帯域幅が増大する可能性があるため、 !--- ATM 側の PCR/SCR がフレームリレー側の !--- CIR と等しいものであると !--- 見なすことはできません。 !--- SCR(この例では 64kbps)を定義するために、 !--- シスコではフレームリレー側 !--- の CIR の値を維持します。フレーム側の CIR が ATM の !--- SCR と正確に一致していないため、ネットワークによっては、 !--- この値は微調整が必要となる場合がありますが、 !--- ほとんどの場合、概算としては十分役立ちます。 !--- このトピックの詳しい説明については、 !--- 次の文書を参照してください。 !--- フレームリレーおよび ATM でのマルチリンク PPP の設計および導入 !--- 25 AAL5SNAP カプセル化が必要です。 !--- 26 仮想テンプレートを ATM PVC に関連付けます。
!
!
interface loopback0 ip address 10.1.1.1 255.255.255.0 !

interface Ethernet3/0
ip address 172.17.111.15 255.255.255.224
half-duplex
!
interface Ethernet3/1
no ip address
shutdown
half-duplex
!
interface Virtual-Template1
bandwidth 64 ip unnumbered loopback0
ip rtp header-compression
no ip route-cache
load-interval 30
max-reserved-bandwidth 99
service-policy output VOIP
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave !--- 注:仮想テンプレートは、ネットワークの !--- フレームリレー ルータ側とまったく同じ方法で !--- 作成されます。 !--- ATM ルータでは、もう 1 つの注意事項として、 !--- 整数個の ATM セルが収まるように !--- 断片化サイズを最適化する必要があります。 !--- この問題の詳しい説明については、 !--- 「フレームリレーおよび ATM でのマルチリンク PPP の設計および導入 」 !--- を参照してください。

!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.111.1
ip http server
ip pim bidir-enable
!
!
call rsvp-sync
!
voice-port 1/0/0
description FXS
!
voice-port 1/0/1
!
voice-port 1/1/0
description FXO
!
voice-port 1/1/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 456 voip
destination-pattern 456
session target ipv4:10.1.1.2
ip qos dscp cs5 media
ip qos dscp cs5 signaling
no vad
!
dial-peer voice 123 pots
destination-pattern 123
port 1/1/0
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!
!
end

検証

この項では、設定が正しく動作していることを確認する方法について説明します。

一部の show コマンドは、show コマンド出力の分析を表示する Output Interpreter ツールでサポートされています。

次の show コマンドは、ATM/フレームリレー インターワーキング環境の動作ステータス、たとえば、DLCI と PVC の統計情報、物理インターフェイスと仮想インターフェイスのステータス、ポリシー(QOS)の適用、cRTP 情報などを確認する際に役立ちます。

  • show ppp multilink interface interface-name - バンドルの状態(アップまたはダウン)、どの仮想アクセス インターフェイスがバンドル(MLPPP バンドル)か、およびどれがメンバ(PPP リンク)かを確認します。また、キャリアがセル/フレームを廃棄しているかどうかも確認できます(損失フラグメント <> 0)。許容されるフラグメント損失は、Cyclic Redundancy Check(CRC; 巡回冗長検査)エラーが原因のものに限られます。
  • show user - 仮想アクセス インターフェイスに関連付けられている番号を表示します。このコマンドまたは show ppp multilink コマンドの情報を使用して、インターフェイスについての統計情報を表示したり、インターフェイスをクリアーしたりできます。
  • show frame-relay pvc dlci - トラフィック シェーピング パラメータ、断片化値、廃棄されたパケットなどの情報を表示します。また、物理インターフェイスが仮想インターフェイスにバインドされているかどうかも表示されます。
  • show atm pvc pvc - アクティブなすべての ATM PVC とトラフィックに関する情報を表示します。
  • show policy-map interface interface-name - PQ でのすべての LLQ 処理と廃棄を表示します。このコマンドの各種フィールドの詳細については、「show policy-map interface で出力されるパケット カウンタの理解」を参照してください。
  • 注:virtual-access2 インターフェイスには常にファンシー キューイングが適用されます。その他のインターフェイスでは FIFO キューイングが使用されます。

  • show ip rtp header-compression - RTP ヘッダー圧縮に関する統計情報を表示します(設定されている場合)。表示される統計情報は、バンドル インターフェイスである virtual-access2 インターフェイスに属する点に注意してください。

次に、これらのコマンドの例を示します。

FR#show ppp multilink interface virtual-access 2 Virtual-Access2, bundle name is ATM Bundle up for 00:22:42 0 lost fragments, 0 reordered, 0 unassigned 0 discarded, 0 lost received, 231/255 load 0x2E5 received sequence, 0x10C31 sent sequence Member links: 1 (max not set, min not set) Virtual-Access1, since 00:22:42, last rcvd seq 0002E4 160 weight

次の出力は、フレームリレー ルータでの show users を示します。

FR#show users Line User Host(s) Idle Location 67 vty 1 idle 00:00:00 10.1.1.1 Interface User Mode Idle Peer Address Vi1 Virtual PPP (FR ) - Vi2 Virtual PPP (Bundle) 00:00:00 10.1.1.1 FR#

次の出力は、ATM ルータでの show users を示します。

ATM#show users Line User Host(s) Idle Location 131 vty 1 idle 00:00:00 64.104.207.95 Interface User Mode Idle Peer Address Vi1 Virtual PPP (ATM ) - Vi2 Virtual PPP (Bundle) 00:00:02 10.1.1.2 ATM#

次の出力は show frame-relay pvc コマンドを示します。

FR#show frame-relay pvc 16 PVC Statistics for interface Serial0/0 (Frame Relay DTE) DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1 input pkts 2301 output pkts 2295 in bytes 152266 out bytes 151891 dropped pkts 0 in FECN pkts 0 in BECN pkts 0 out FECN pkts 0 out BECN pkts 0 in DE pkts 0 out DE pkts 0 out bcast pkts 0 out bcast bytes 0 5 minute input rate 9000 bits/sec, 9 packets/sec 5 minute output rate 9000 bits/sec, 9 packets/sec pvc create time 23:46:56, last time pvc status changed 00:22:56 Bound to Virtual-Access1 (up, cloned from Virtual-Template1) !--- PPP リンク インターフェイス cir 64000 bc 640 be 0 byte limit 80 interval 10 mincir 64000 byte increment 80 Adaptive Shaping none pkts 2296 bytes 152053 pkts delayed 9 bytes delayed 375 shaping active traffic shaping drops 0 Queueing strategy: fifo Output queue 0/40, 0 drop, 0 dequeued FR#

次の出力は、ATM ルータでの show atm pvc 10/100 コマンドを示します。

ATM#show atm pvc 10/100 ATM0/0.1: VCD: 1, VPI: 10, VCI: 100 CBR, SusRate: 128 AAL5-LLC/SNAP, etype:0x0, Flags: 0x820, VCmode: 0x0 OAM frequency: 0 second(s), OAM retry frequency: 1 second(s) OAM up retry count: 3, OAM down retry count: 5 OAM Loopback status: OAM Disabled OAM VC state: Not Managed ILMI VC state: Not Managed InARP frequency: 15 minutes(s) Transmit priority 1 InPkts: 729, OutPkts: 729, InBytes: 49700, OutBytes: 51158 InPRoc: 0, OutPRoc: 729 InFast: 729, OutFast: 0, InAS: 0, OutAS: 0 InPktDrops: 0, OutPktDrops: 0/0/0 (holdq/outputq/total) CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0 OAM cells received: 0 F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0 F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0 OAM cells sent: 0 F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0 F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0 OAM cell drops: 0 Status: UP PPP: Virtual-Access2 from Virtual-Template1 !--- MLPPP バンドル インターフェイス
ATM#

次の出力は、フレームリレー ルータでの show policy-map を示します。

FR#show policy-map interface Virtual-Access2 Service-policy output: VoIP Class-map: voice (match-all) 15483 packets, 959502 bytes 30 second offered rate 24000 bps, drop rate 0 bps Match: ip dscp 40 Weighted Fair Queueing Strict Priority !--- 音声用の LLQ 完全優先キュー Output Queue: Conversation 24 Bandwidth 48(kbps) Burst 1500 (Bytes) (pkts matched/bytes matched) 15536/962784 (total drops/bytes drops) 0/0 !--- 音声キューでの廃棄はありません。 Class-map: class-default (match-any) 139 packets, 19481 bytes 30 second offered rate 1000 bps, drop rate 0 bps Match: any Weighted Fair Queueing Flow Based Fair Queueing Maximum Number of Hashed Queues 16 (total queued/total drops/no-buffer drops) 0/0/0
The following output shows the show policy map command on the ATM router.
ATM#show policy-map interface Virtual-Access2 Service-policy output: VOIP Class-map: voice (match-all) 11293 packets, 699718 bytes 30 second offered rate 24000 bps, drop rate 0 bps Match: ip dscp 40 Weighted Fair Queueing Strict Priority !--- 音声用の LLQ 完全優先キュー Output Queue: Conversation 24 Bandwidth 48 (kbps) Burst 1500 (Bytes) (pkts matched/bytes matched) 11352/703376 (total drops/bytes drops) 0/0 !--- 音声キューでの廃棄はありません。 Class-map: class-default (match-any) 63 packets, 9772 bytes 30 second offered rate 0 bps, drop rate 0 bps Match: any Weighted Fair Queueing Flow Based Fair Queueing Maximum Number of Hashed Queues 16 (total queued/total drops/no-buffer drops) 0/0/0 ATM#

次の出力は、フレームリレー ルータでの show ip rtp header-compression コマンドを示します。

FR#show ip rtp header-compression RTP/UDP/IP header compression statistics: Interface Virtual-Access1: Rcvd: 0 total, 0 compressed, 0 errors 0 dropped, 0 buffer copies, 0 buffer failures Sent: 0 total, 0 compressed, 0 bytes saved, 0 bytes sent Connect: 16 rx slots, 16 tx slots, 0 long searches, 0 misses 0 collisions Interface Virtual-Template1: Rcvd: 0 total, 0 compressed, 0 errors 0 dropped, 0 buffer copies, 0 buffer failures Sent: 0 total, 0 compressed, 0 bytes saved, 0 bytes sent Connect: 16 rx slots, 16 tx slots, 0 long searches, 0 misses 0 collisions Interface Virtual-Access2: Rcvd: 23682 total, 23681 compressed, 0 errors 0 dropped, 0 buffer copies, 0 buffer failures Sent: 327 total, 233 compressed, 8821 bytes saved, 5159 bytes sent 2.70 efficiency improvement factor Connect: 16 rx slots, 16 tx slots, 0 long searches, 94 misses 0 collisions 71% hit ratio, five minute miss rate 0 misses/sec, 0 max

次の出力は、ATM ルータでの show ip rtp header-compression コマンドを示します。

ATM#show ip rtp header-compression RTP/UDP/IP header compression statistics: Interface Virtual-Access1: Rcvd: 0 total, 0 compressed, 0 errors 0 dropped, 0 buffer copies, 0 buffer failures Sent: 0 total, 0 compressed, 0 bytes saved, 0 bytes sent Connect: 16 rx slots, 16 tx slots, 0 long searches, 0 misses 0 collisions, 0 negative cache hits Interface Virtual-Template1: Rcvd: 0 total, 0 compressed, 0 errors 0 dropped, 0 buffer copies, 0 buffer failures Sent: 0 total, 0 compressed, 0 bytes saved, 0 bytes sent Connect: 16 rx slots, 16 tx slots, 0 long searches, 0 misses 0 collisions, 0 negative cache hits Interface Virtual-Access2: Rcvd: 283 total, 233 compressed, 0 errors 0 dropped, 0 buffer copies, 0 buffer failures Sent: 25341 total, 25340 compressed, 955537 bytes saved, 564463 bytes sent 2.69 efficiency improvement factor Connect: 16 rx slots, 16 tx slots, 0 long searches, 1 misses 0 collisions, 100 negative cache hits 99% hit ratio, five minute miss rate 0 misses/sec, 0 max

トラブルシューティング

この項では、MLP LFI の理解を深めるため、および設定のトラブルシューティングに実際に役立つ例として、いくつかのデバッグ例を示します。

トラブルシューティング用のコマンド

一部の show コマンドは、show コマンド出力の分析を表示する Output Interpreter ツールでサポートされています。

注:debug コマンドを使用する前に、「debug コマンドに関する重要な情報」を参照してください。

  • debug ppp negotiation - PPP と PPP バンドル リンクを表すために 2 つの仮想アクセス インターフェイスをコピーするプロセスを具体的に示します。仮想アクセス インターフェイス 1(Vi1)は、(ATM またはフレーム)PVC がバインドされている PPP リンクです。仮想インターフェイス 2(Vi2)は、キューイング ポリシーが適用されている PPP バンドル リンクです。
  • debug ppp multilink fragment - 大きなデータ パケットが小さな音声パケットにインターリーブされる概念を具体的に示します。バンドル インターフェイスにファンシー キューイングが割り当てられているため、インターリービングは Vi2 インターフェイス(MLP レベル)で実行されます。

debug ppp negotiation コマンドのコマンド出力を次に示します。

FR(config-if)#no shut FR(config-if)#^Z FR# FR# 6d23h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up *Mar 7 23:20:42.842: Vi1 PPP: Treating connection as a dedicated line !--- Vi1 は PVC がバインドされている PPP リンクです。 *Mar 7 23:20:42.842: Vi1 PPP: Phase is ESTABLISHING, Active Open *Mar 7 23:20:42.842: Vi1 LCP: O CONFREQ [Closed] id 197 len 19 *Mar 7 23:20:42.842: Vi1 LCP: MagicNumber 0xF44128D2 (0x0506F44128D2) *Mar 7 23:20:42.842: Vi1 LCP: MRRU 1524 (0x110405F4) *Mar 7 23:20:42.842: Vi1 LCP: EndpointDisc 1 FR (0x1305014652) !--- PPP ディスカバリの一方の端にあるルータ FR *Mar 7 23:20:42.858: Vi1 LCP: I CONFREQ [REQsent] id 14 len 20 *Mar 7 23:20:42.858: Vi1 LCP: MagicNumber 0x294819D4 (0x0506294819D4) *Mar 7 23:20:42.858: Vi1 LCP: MRRU 1524 (0x110405F4) *Mar 7 23:20:42.858: Vi1 LCP: EndpointDisc 1 ATM (0x13060141544D) !--- PPP ディスカバリのもう一方の端にあるルータ ATM *Mar 7 23:20:42.858: Vi1 LCP: O CONFACK [REQsent] id 14 len 20
*Mar 7 23:20:42.862: Vi1 LCP: MagicNumber 0x294819D4 (0x0506294819D4) *Mar 7 23:20:42.862: Vi1 LCP: MRRU 1524 (0x110405F4) *Mar 7 23:20:42.862: Vi1 LCP: EndpointDisc 1 ATM (0x13060141544D) *Mar 7 23:20:42.870: Vi1 LCP: I CONFACK [ACKsent] id 197 len 19 *Mar 7 23:20:42.870: Vi1 LCP: MagicNumber 0xF44128D2 (0x0506F44128D2) *Mar 7 23:20:42.870: Vi1 LCP: MRRU 1524 (0x110405F4) *Mar 7 23:20:42.870: Vi1 LCP: EndpointDisc 1 FR (0x1305014652) *Mar 7 23:20:42.870: Vi1 LCP: State is Open *Mar 7 23:20:42.870: Vi1 PPP: Phase is FORWARDING, Attempting Forward *Mar 7 23:20:42.874: Vi1 PPP: Phase is ESTABLISHING, Finish LCP *Mar 7 23:20:42.874: Vi1 PPP: Phase is VIRTUALIZED *Mar 7 23:20:42.942: Vi2 PPP: Phase is DOWN, Setup *Mar 7 23:20:43.222: Vi1 IPCP: Packet buffered while building MLP bundle interface 6d23h: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up !--- MLP レベル キューイング *Mar 7 23:20:43.226: Vi2 PPP: Treating connection as a dedicated line *Mar 7 23:20:43.226: Vi2 PPP: Phase is ESTABLISHING, Active Open *Mar 7 23:20:43.226: Vi2 LCP: O CONFREQ [Closed] id 1 len 19 *Mar 7 23:20:43.226: Vi2 LCP: MagicNumber 0xF4412A53 (0x0506F4412A53) *Mar 7 23:20:43.226: Vi2 LCP: MRRU 1524 (0x110405F4) *Mar 7 23:20:43.230: Vi2 LCP: EndpointDisc 1 FR (0x1305014652) *Mar 7 23:20:43.230: Vi2 MLP: Added first link Vi1 to bundle ATM !--- PVC がバンドルを構成します。 *Mar 7 23:20:43.230: Vi2 PPP: Phase is UP *Mar 7 23:20:43.230: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 *Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.2 (0x03060A010102) *Mar 7 23:20:43.234: Vi2 PPP: Pending ncpQ size is 1 *Mar 7 23:20:43.234: Vi1 IPCP: Redirect packet to Vi1 *Mar 7 23:20:43.234: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 *Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101) *Mar 7 23:20:43.234: Vi2 IPCP: O CONFACK [REQsent] id 1 len 10 *Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101) *Mar 7 23:20:43.266: Vi2 IPCP: I CONFACK [ACKsent] id 1 len 10 *Mar 7 23:20:43.266: Vi2 IPCP: Address 10.1.1.2 (0x03060A010102) *Mar 7 23:20:43.266: Vi2 IPCP: State is Open *Mar 7 23:20:43.266: Vi2 IPCP: Install route to 10.1.1.1 *Mar 7 23:20:43.270: Vi2 IPCP: Add link info for cef entry 10.1.1.1

debug ppp multilink fragment コマンドのコマンド出力を次に示します。

*Mar 7 23:16:08.034: Vi2 MLP: Packet interleaved from queue 24 *Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 *Mar 7 23:16:08.038: Vi2 MLP: Packet interleaved from queue 24 *Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 *Mar 7 23:16:08.038: Vi2 MLP: Packet interleaved from queue 24 *Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 *Mar 7 23:16:08.038: Vi1 MLP: O frag 0000829B size 160 *Mar 7 23:16:08.042: Vi1 MLP: I ppp IP (0021) size 64 direct *Mar 7 23:16:08.046: Vi1 MLP: I ppp IP (0021) size 64 direct

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 22383