IBM テクノロジー : IBM ネットワーキング

基本的な DLSw+ 構成

2002 年 6 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 1 月 28 日) | フィードバック

目次


概要

DLSw は、Data Link Switching(DLS; データリンク スイッチング)の短縮形です。DLSw は、IBM Systems Network Architecture(SNA; システム ネットワーク アーキテクチャ)と IBM NetBIOS トラフィックを IP ネットワーク上で転送するときに使用するスイッチ間プロトコルです。このプロトコルは完全なルーティングを行うものではなく、インターネット上での転送の際に、SNA データリンク層のスイッチングと TCP/IP でのカプセル化を提供します。

DLSw+ は、シスコ独自の DLSw 実装です。DLSw+ には、DLSw 標準に加えて次の機能があります。

  • 転送オプションの選択(TCP、Fast-Sequenced Transport(FST)、および直接カプセル化など)

  • スケーラビリティの向上(ピア グループ、オンデマンド ピア、探索ファイアウォール、ロケーション ラーニングなどによる)

  • ローカルおよびリモートの LAN と SDLC またはイーサネットの間のメディア変換

この文書は、次のネットワーク シナリオの基本的な構成について説明します。

DLSw 標準について

DLSw 標準の詳細は、RFC 1795 を参照してください(RFC 1795 の登場により、RFC 1434 は廃止されました)。要約すると、RFC 1795 では、DLSw 接続の確立、リソースの位置確認、データの転送、フロー制御の処理、およびエラーの復旧などを行うために、ルータ間で使用される Switch-to-Switch Protocol(SSP; スイッチ間プロトコル)について説明しています。また、Data Link Control(DLC; データリンク コントロール層)接続をローカルで終端する方法、および DLC 接続を DLSw 回線にマッピングする方法についても説明しています。DLC 接続がローカルで終端されると、DLSw では次の問題が処理されます。

  • DLC のタイムアウト
  • WAN 上での DLC の確認応答
  • フローおよび輻輳の制御
  • 検索パケットのブロードキャスト制御
  • ソース ルート ブリッジングのホップ カウントの制限

FC 1795 には、RFC 2166 で改良された箇所があります。RFC 2166 では、DLSw のスケーラビリティの問題を取り上げ、RFC 1795 をより詳細に説明しています。ただし、RFC 2166 によって RFC 1795 が廃止されたわけではなく、両方を合わせて使用する必要があります。

構成例

ここでは、DLSw+ のサポートに必要な、一部の構成について説明します。IP や他のプロトコルのサポートに必要な構成は含まれません。DLSw+ は、TCP/IP に依存しているので(FST または直接カプセル化を使用する場合は除く)、IP ネットワークがすでに起動して稼動していることを想定しています。

1  WAN 上でのトークン リング間の接続

ringwan


  RouterA:

  

  !

  source-bridge ring-group 2000

  dlsw local-peer peer-id 150.150.1.1

  dlsw remote-peer 0 tcp 150.150.2.1

  !

  interface Loopback0

   ip address 150.150.1.1 255.255.255.0

  !

  interface Serial0

   ip address 150.150.100.1 255.255.255.0

  !

  interface TokenRing0

   ip address 150.150.10.1 255.255.255.0

   ring-speed 16

   source-bridge 1 1 2000

   source-bridge spanning

   !--- ルータは 1 つのルート探索フレームを転送できます。

  

  RouterB:

  

  !

  source-bridge ring-group 2000

  dlsw local-peer peer-id 150.150.2.1

  dlsw remote-peer 0 tcp 150.150.1.1

  !

  interface Loopback0

   ip address 150.150.2.1 255.255.255.0

  !

  interface Serial0

   ip address 150.150.100.2 255.255.255.0

  !

  interface TokenRing0

   ip address 150.150.20.2 255.255.255.0

   ring-speed 16

   source-bridge 2 1 2000

   source-bridge spanning

   !--- ルータは 1 つのルート探索フレームを転送できます。

この例では、1 つの仮想リング(リング番号 2000)を選んで、2 つのグループ間に簡単に接続を確立しました。ただし、Routing Information Field(RIF; ルーティング情報フィールド)は DLSw+ ルータで終端するので、ルータごとに別の仮想リング番号を選択できます。
しかし、リング番号を選択するときには注意が必要です。ソースルート ブリッジングに適用したのと同じ規則に従う必要があります。
シスコでは、現在、ルータごとに 1 つの仮想リングだけをサポートしています。

dlsw local-peer コマンドは、ローカル ルータに DLSw+ IP アドレスを定義するときに使用します。上の例では、DLSw+ が動作中の実際の物理インターフェイスに依存しなくても済むように、ループバック インターフェイスの IP アドレスを使用しています。

dlsw remote-peer コマンドは、リモート ルータの IP アドレスを定義します。remote-peer キーワードの後ろにある数字の 0 は、リングリスト の番号です。一般的に、フルメッシュ構造のネットワークを使用する場合は、番号 0 を使用します。リングリストの番号を使用するのは、ネットワークをセグメント化して探索フレームのフラッディングを制御する場合です(リングリストの実際の例については、「例 2」を参照してください)。

2  リングリストによるトークン リング間の接続

ringlist


  Router A

  
!

  source-bridge ring-group 2000

  dlsw local-peer peer-id 150.150.1.1

  dlsw remote-peer 0 tcp 150.150.2.1

  !

  interface Loopback0

   ip address 150.150.1.1 255.255.255.0

  !

  interface Serial0

   ip address 150.150.100.1 255.255.255.0

  !

  interface TokenRing0

   ip address 150.150.10.1 255.255.255.0

   ring-speed 16

   source-bridge 3 1 2000

   source-bridge spanning

   !--- ルータは 1 つのルート探索フレームを転送できます。

  
Router B

  !

  source-bridge ring-group 2000

  dlsw local-peer peer-id 150.150.2.1

  dlsw remote-peer 1 tcp 150.150.1.1

  dlsw ring-list 1 rings 1

  !

  interface Loopback0

   ip address 150.150.2.1 255.255.255.0

  !

  interface Serial0

   ip address 150.150.100.2 255.255.255.0

  !

  interface TokenRing0

   ip address 150.150.20.2 255.255.255.0

   ring-speed 16

   source-bridge 1 1 2000

   source-bridge spanning

   !--- ルータは 1 つのルート探索フレームを転送できます。

  !

  interface TokenRing1

  ip address 150.150.30.1 255.255.255.0

  ring-speed 16

  source-bridge 2 1 2000

  source bridge spanning

  !--- ルータは 1 つのルート探索フレームを転送できます。

この例では、リング 3 上の全ワークステーションは、リング 1 上の端末とはセッションを確立できますが、リング 2 の端末とはできません。反対方向に接続する場合も同様です。リング 1 の端末とリング 2 の端末は、両方ともルータ B とローカルで接続しているので、互いに通信ができます。

これは、リング 2 からルータ A に配送されるブロードキャストがまったくないことを意味します。WAN 上でブロードキャスト トラフィックを制御する場合には、dlsw ring-listport-list、およびbgroup-list などの文が役立ちます。

3  WAN 上でのトークン リングとイーサネット間の接続

ringether

この例では、デバイスのあるメディアが混在しているので、探索テスト パケットを開始するセカンダリ デバイスによってホストの MAC アドレスが符号化される前に、このアドレスをビットスワップする必要があります。詳細は、「ソースルート トランスレーショナル ブリッジングの概要とトラブルシューティング」も参照してください。

Router A

  

  !

  source-bridge ring-group 2000

  dlsw local-peer peer-id 150.150.1.1

  dlsw remote-peer 0 tcp 150.150.2.1

  !

  interface Loopback0

   ip address 150.150.1.1 255.255.255.0

  !

  interface Serial0

   ip address 150.150.100.1 255.255.255.0

  !

  interface TokenRing0

   ip address 150.150.10.1 255.255.255.0

   ring-speed 16

   source-bridge 1 1 2000

   source-bridge spanning

   !--- ルータは 1 つのルート探索フレームを転送できます。

  

次の例では、イーサネット セグメント上の端末が、トークン リング セグメント上の端末と通信できます。DLSw+ ルータは、イーサネット形式からトークン リング形式への変換を行います。 dlsw bridge-group コマンドは、source-bridge 文が仮想のリンググループによってトークン リングのセグメントと DLSw+ を接続するようのと同じように、イーサネット セグメントを DLSw+ プロセスに接続します。ルータ B にトークン リングのインターフェイスがなく、このトークン リングの端末とイーサネットの端末間の通信が必要でない場合、SRT/LB を構成する必要はありません。「例 6」を参照してください。

:ルータ B 上では、source-bridge ring-group は必要ありません。

Router B

  !

  dlsw local-peer peer-id 150.150.2.1

  dlsw remote-peer 0 tcp 150.150.1.1

  dlsw bridge-group 1

  !

  interface Loopback0

   ip address 150.150.2.1 255.255.255.0

  !

  interface Serial0

   ip address 150.150.100.2 255.255.255.0

  !

  interface Ethernet0

   ip address 150.150.30.1 255.255.255.0

   bridge-group 1

  !

  bridge 1 protocol dec

  !

4  WAN 上でのイーサネット間の接続

etherwan

Router A

  !

  dlsw local-peer peer-id 150.150.1.1

  dlsw remote-peer 0 tcp 150.150.2.1

  dlsw bridge-group 1

  !

  interface Loopback0

   ip address 150.150.1.1 255.255.255.0

  !

  interface Serial0

   ip address 150.150.100.1 255.255.255.0

  !

  interface Ethernet0

   ip address 150.150.30.1 255.255.255.0

   bridge-group 1

  !

  bridge 1 protocol dec

  !

  
Router B:

  !

  dlsw local-peer peer-id 150.150.2.1

  dlsw remote-peer 0 tcp 150.150.1.1

  dlsw bridge-group 1

  !

  interface Loopback0

   ip address 150.150.2.1 255.255.255.0

  !

  interface Serial0

   ip address 150.150.100.2 255.255.255.0

  !

  interface Ethernet0

   ip address 150.150.40.1 255.255.255.0

   bridge-group 1

  !

  bridge 1 protocol dec

source-bridge ring-group は、どちらのルータにも必要ありません。

5  同じルータでのトークン リンクとイーサネット間の接続

tokenether

イーサネットとトークン リング間に位置しており、ルータに対してローカルである端末を接続する必要がある場合は、SR/TLB(トランスレーショナル ブリッジング)を使用する必要があります。イーサネットとトークン リング間のローカル DLSw はサポートされません。

Router A:

  

  source-bridge ring-group 2000

  source-bridge transparent 2000 1000 1 1

  
interface Ethernet0

   ip address 150.150.40.1 255.255.255.0

   bridge-group 1

  !

  interface TokenRing0

   ip address 150.150.10.1 255.255.255.0

   ring-speed 16

   source-bridge 1 1 2000

   source-bridge spanning

   !--- ルータは 1 つのルート探索フレームを転送できます。

  !

  bridge 1 protocol ieee

次にsource-bridge transparent 2000 1000 1 1 コマンドを説明します。

  • 2000 は、source-bridge ring-group 2000 によって設定する仮想リング番号です。
  • 1000 は、イーサネット ドメインに提供される仮のリング番号です。
  • 1 は、透過型ブリッジング ドメインと接続しているブリッジのブリッジ番号です。
  • 1 は、ソースルート ブリッジング ドメインと接続する、透過的なbridge-group の番号です。

インターフェイスの IP アドレスは、SRT/LB には必要ありません。

6  SR/TLB と DLSw+ の混在

srtlb


  Router A:

  source-bridge ring-group 2000

  source-bridge transparent 2000 1000 1 1

  dlsw local-peer peer-id 150.150.1.1

  dlsw remote-peer 0 tcp 150.150.2.1

  dlsw bridge-group 1

  !

  interface Loopback0

   ip address 150.150.1.1 255.255.255.0

  !

  interface Ethernet0

   ip address 150.150.40.1 255.255.255.0

   bridge-group 1

  !

  interface TokenRing0

   ip address 150.150.10.1 255.255.255.0

   ring-speed 16

   source-bridge 1 1 2000

   source-bridge spanning

   !--- ルータは 1 つのルート探索フレームを転送できます。

  !

  bridge 1 protocol dec

  


  Router B:

  source-bridge ring-group 2000

  dlsw local-peer peer-id 150.150.2.1

  dlsw remote-peer 0 tcp 150.150.1.1

  !

  interface Loopback0

   ip address 150.150.2.1 255.255.255.0

  !

  interface TokenRing0

   ip address 150.150.11.1  255.255.255.0

   ring-speed 16

   source-bridge 2 1 2000

   source-bridge spanning

   !--- ルータは 1 つのルート探索フレームを転送できます。

上の例では、DLSw と SRT/LTB の両方が構成されています。SRT/LB が必要になるのは、トークン リング上の端末が同じルータ(ルータ A)上のイーサネットの端末と通信する必要がある場合だけです。ルータ A 上のイーサネットの端末がルータ B のリモート トークン リング端末と通信する必要があるだけなら、 dlsw bridge-group 1 により実行できます。

7  WAN 上でのトークン リングと SDLC 間の接続

tokensdlc


  Router A

  !

  source-bridge ring-group 2000

  dlsw local-peer peer-id 150.150.1.1

  dlsw remote-peer 0 tcp 150.150.2.1

  !

  interface Loopback0

   ip address 150.150.1.1 255.255.255.0

  !

  interface Serial0

   ip address 150.150.100.1 255.255.255.0

  !

  interface TokenRing0

   ip address 150.150.10.1 255.255.255.0

   ring-speed 16

   source-bridge 1 1 2000

   source-bridge spanning

   !--- !--- ルータは 1 つのルート探索フレームを転送できます。

  

  

  Router B

  

  dlsw local-peer peer-id 150.150.2.1

  dlsw remote-peer 0 tcp 150.150.1.1

  !

  interface Loopback0

   ip address 150.150.2.1 255.255.255.0

  !

  interface Serial0

   ip address 150.150.100.2 255.255.255.0

  !

  interface Serial 1

   no ip address

   encapsulation sdlc

   no keepalive

   clockrate 9600

   sdlc role primary

   !--- コントローラに対する SDLC 端末の役割をセカンダリと仮定します。

   sdlc vmac 4000.9999.0100

   !--- コントローラに割り当てられる仮想 MAC アドレス

   !--- コントローラには SDLC アドレス(01)が付加されます。

   sdlc address 01

   !--- コントローラの構成から取得した SDLC アドレス

   sdlc xid 01 05D20001

   !--- 01 は SDLC アドレスで、IDBLK/IDNUM は、

   !--- ホストのスイッチ メジャー ノードの SDLC アドレスと一致する必要があります。

   sdlc partner 4000.1020.1000 01

   !--- 4000.1020.1000 はホストの MAC アドレスで、

   !--- 01 は SDLC アドレスです。 

   sdlc dlsw 1

  !

  

注:DLSw 回線の接続は、4000.9999.0101 および 4000.1020.1000 の間になります。さらに、上の例では、PU2.0 コントローラを想定しています。その他の PU タイプについては、「DLSw SDLC トラブルシューティング ガイド」を参照してください。

上の構成例は、一般的なネットワーク シナリオです。DLSw+ では多くのことができますが、前述の構成例では、基本を説明しています。DLSw+ は拡張 RSRB であり、この製品には、RFC 1745 および 2166 に準拠する、他のルータとの相互運用性の機能が追加されていることに留意してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12411