LAN スイッチング : レイヤ 3 スイッチングとフォワーディング

IRB 機能によるルータでの VLAN ルーティングおよびブリッジングの理解と設定

2010 年 10 月 6 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2009 年 8 月 31 日) | フィードバック

目次

概要
はじめに
      表記法
      前提条件
      使用するコンポーネント
      背景説明
IRB による VLAN ルーティングおよびブリッジングの概念
IRB の設定例
      ネットワーク ダイアグラム
      設定
      show コマンド出力
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、IP のルーティング、IP のブリッジング、および Integrated Routing and Bridging(IRB)により IP のブリッジングを行うルータを使用する VLAN の実装について説明します。また、このドキュメントでは、ルータでの IRB 機能の設定例も紹介します。

注:IRB は、Catalyst 6500 シリーズ スイッチと Cisco 7600 シリーズ ルータでは意図的に無効化されています。詳細については、『Catalyst 6000 および Cisco 7600 の Supervisor Engine および MSFC の Cisco IOS リリース 12.1 E に関するリリース ノート』の「一般の制約および制限事項」セクションを参照してください。

はじめに

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



前提条件

このドキュメントに関する特別な要件はありません。



使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼動中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。



背景説明

VLAN でルータを使用するには、ルータが VLAN ヘッダーを維持した状態で、1 つのインターフェイスから別のインターフェイスにフレームを転送できる必要があります。ルータがレイヤ 3(ネットワーク層)プロトコルをルーティングするために設定される場合、フレームを受信するインターフェイスで VLAN と MAC レイヤが終端します。MAC レイヤのヘッダーは、ルータがネットワーク層プロトコルをブリッジングする場合に維持することができます。ただし、通常のブリッジングでは VLAN ヘッダーは終端されます。Cisco IOS® リリース 11.2 以降の IRB 機能を使用すると、同じインターフェイスの同じネットワーク層プロトコルをルーティングし、ブリッジングするようにルータを設定できます。これにより、VLAN ヘッダーは、1 つのインターフェイスから別のインターフェイスにルータを通過する間、フレームで維持されるようになります。IRB は、ブリッジ グループ仮想インターフェイス(BVI)により、ブリッジド ドメインとルーテッド ドメイン間でルーティングする機能を提供します。BVI は、ルータ内の仮想インターフェイスであり、ブリッジングをサポートしないが、ルータ内のルーテッド インターフェイスに相当するブリッジ グループを代表する、正常なルーテッド インターフェイスのように動作します。BVI のインターフェイス番号は、仮想インターフェイスが代表するブリッジ グループの番号です。この番号が BVI とブリッジ グループ間のリンクになります。

BVI のルーティングを設定し有効化すると、ブリッジ グループのセグメント上のホストが宛先の、ルーテッド インターフェイスで受信したパケットは、BVI にルーティングされます。BVI から、パケットはブリッジング エンジンに転送されます。これは、ブリッジド インターフェイスを経由して転送されます。これは MAC アドレスの宛先に基づいて転送されます。同様に、ブリッジド インターフェイスで受信するパケットでルーテッド ネットワークのホスト宛のものは、最初に BVI に向かいます。次に、BVI はルーティング エンジンにパケットを転送してから、ルーテッド インターフェイスからパケットを送信します。単一の物理インターフェイスで、IRB は 2 つの VLAN サブインターフェイス(802.1Q タギング)で作成することができます。1 つの VLAN サブインターフェイスにはルーティングのために使用する IP アドレスがあります。もう 1 つの VLAN サブインターフェイスは、ルーティングのために使用するサブインターフェイスとルータ上の他の物理インターフェイスの間にブリッジを設定します。

BVI はルーテッド インターフェイスとしてブリッジ グループを代表するので、ネットワーク レイヤ アドレスのようなレイヤ3(L3)特性のみにより設定する必要があります。同様に、プロトコルのブリッジング用に設定されたインターフェイスは、どの L3 特性によっても設定されてはなりません。



IRB による VLAN ルーティングおよびブリッジングの概念

図 I では、PC A および PC B がルータによって分離された VLAN に接続されています。この図では、単一の VLAN が、中間でルータベースの接続を持てるという、一般的な誤解を示しています。

/image/gif/paws/17054/router_vlan1.gif

この図では、PC A から PC B へのリンクを行き来するフレームの 3 層のヘッダーのフローも示しています。

フレームがスイッチを通る場合、接続がトランク リンクであるため、VLAN ヘッダーが適用されます。トランクを通して通信する VLAN はいくつかある可能性があります。

ルータは VLAN レイヤおよび MAC レイヤを終端します。ルータは、宛先 IP アドレスを検査して、フレームを適切に転送します。この場合、IP のフレームはポートから PC B 宛に転送されます。これもまた VLAN トランクであるため、VLAN ヘッダーが適用されます。

ルータにスイッチ 2 を接続する VLAN は、スイッチ 1 を接続する VLAN と同じ番号でコールできますが、実際には同じ VLAN ではありません。フレームがルータに達すると、オリジナルの VLAN ヘッダーは削除されます。フレームがルータから送出されるときに、新しいヘッダーが適用される場合があります。この新しいヘッダーには、フレームを受信したときに除去された VLAN ヘッダーで使用したのと同じ VLAN 番号が含まれていることがあります。これは、VLAN ヘッダーが添付されていないルータを経由して IP フレームが移動し、VLAN ID フィールドではなく、IP 宛先アドレスのフィールドの内容に基づいて転送されたという事実によって示されます。

これは、2 つの VLAN トランクがそれぞれルータの反対側に位置するため、別の IP サブネットにする必要があるためです。

2 つの PC が同じサブネットアドレスを持つには、ルータがインターフェイスで IP をブリッジングする必要があります。ただし、サブネットを共有する VLAN にデバイスがあっても、それは同じ VLAN にあるということにはなりません。

図 II に、VLAN トポロジの構成を示します。

/image/gif/paws/17054/router_vlan2.gif

VLAN を接続するルータのいくつか、あるいはすべてのインターフェイスで、IP をブリッジングすることによって、移動中に IP 端末の宛先を変更する必要性は回避できます。ただし、ネットワーク レイヤでブロードキャストを制御するためにルータベース ネットワークを構築する利点はすべてなくなります。 図 III は、ルータで IP のブリッジングを設定した場合、どのような変化が生じるかを示しています。図 IV は、ルータで IRB を使用して IP のブリッジングを設定した場合、何が起こるかを示しています。

図 III は、ルータがここで IP をブリッジングしていることを示しています。両方の PC は現在同じサブネットにあります。

注:ルータ(ブリッジ)はここで送信先インターフェイスへ MAC レイヤ ヘッダーを転送します。ルータは、フレームを PC B へ送信する前に、VLAN ヘッダーを取り除いて新しいヘッダーを適用しています。

/image/gif/paws/17054/router_vlan3.gif

図 IV は、IRB が設定された場合、何が起こるかを示しています。VLAN はここでルータを使用し、VLAN ヘッダーはフレームがルータを通過するときに、維持されます。

/image/gif/paws/17054/router_vlan4.gif



IRB の設定例

この設定は、IRB の例です。この設定を行うと、2 つのイーサネット インターフェイス間の IP をブリッジングし、Bridged Virtual Interface(BVI)を使用してブリッジされたインターフェイスから IP をルーティングすることができます。次のネットワーク ダイアグラムでは、PC_A が PC_B への接続を試行した場合、ルータ R1 は同じサブネットで宛先(PC_B)の IP アドレスを検出します。したがって、パケットは E0 および E1 のインターフェイス間のルータ R1 によってブリッジされます。PC_A あるいは PC_B が PC_C への接続を試行した場合、ルータ R1 は異なるサブネットで宛先(PC_C)の IP アドレスを検出し、パケットは BVI によりルーティングされます。このように、IP プロトコルは同じルータでルーティングおよびブリッジされます。



ネットワーク ダイアグラム

router_vlan5.gif



設定

設定例

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
ip subnet-zero
no ip domain-lookup
bridge irb

!-- このコマンドは、このルータでの IRB 機能を有効にします。 

!
!
!
interface Ethernet0
no ip address
no ip directed-broadcast
bridge-group 1

!-- インターフェイス E0 は、ブリッジ グループ 1 にあります。

!
Interface Ethernet1
no ip address
no ip directed-broadcast
bridge-group 1

!-- インターフェイス E1 は、ブリッジ グループ 1 にあります。

!
Interface Serial0
ip address 10.10.20.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface BVI1
ip address 10.10.10.1 255.255.255.0

!-- IP アドレスはルーティングのため論理 BVI に割り当てられています。


!-- ブリッジド インターフェイスとルーテッド インターフェイス間の IP

no ip directed-broadcast
!
ip classless
ip route 10.10.30.0 255.255.255.0 10.10.20.2
!
bridge 1 protocol ieee

!-- このコマンドは、このルータ上のブリッジングを有効にします。 

bridge 1 route ip

!-- このコマンドは IP プロトコルのルーティングと同時に、ブリッジングを有効にします。

!
line con 0
transport input none
line aux 0
line vty 0 4
!
end



show コマンド出力

show interfaces [interface] irb

このコマンドは、指定したインターフェイスに対してルーティングまたはブリッジングできるプロトコルを、次のように表示します。

R1#show interface e0 irb

Ethernet0

Routed protocols on Ethernet0:
ip
    
Bridged protocols on Ethernet0:
ip         ipx

!-- IP プロトコルはブリッジングおよびルーティングされます。 


Software MAC address filter on Ethernet0
 Hash Len    Address      Matches  Act      Type
 0x00:  0 ffff.ffff.ffff     0     RCV  Physical broadcast
 0x2A:  0 0900.2b01.0001     0     RCV  DEC spanning tree
 0x9E:  0 0000.0c3a.5092     0     RCV  Interface MAC address
 0x9E:  1 0000.0c3a.5092     0     RCV  Bridge-group Virtual Interface
 0xC0:  0 0100.0ccc.cccc    157    RCV  CDP
 0xC2:  0 0180.c200.0000     0     RCV  IEEE spanning tree
 0xC2:  1 0180.c200.0000     0     RCV  IBM spanning tree
R1#


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 17054