LAN スイッチング : バーチャル LAN/VLAN トランキング プロトコル(VLAN/VTP)

Cisco ルータでの ISL トランクの設定

2002 年 12 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 30 日) | フィードバック

目次

概要
始める前に
     表記法
     前提条件
     使用するコンポーネント
     背景説明
実際の設定
     H3 手順
デバッグおよびトラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書は、Cisco ルータでの ISL トランクの設定について説明しています。

始める前に

表記法

文書表記の詳細については、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

この文書に関する前提条件は特にありません。

使用するコンポーネント

この文書は、特定のソフトウェアやハードウェアのバージョンに限定されていません。

背景説明

Virtual LAN(VLAN; バーチャル LAN)は論理的なブロードキャスト ドメインです。Open System Interconnection(OSI; 開放型システム間相互接続)7 層モデルによって定義されるルーティングおよびブリッジングの規則によれば、2 つの VLAN(またはブロードキャスト ドメイン)の間をデータが通過できるためには、VLAN 間のルーティングにレイヤ 3 デバイスを使用する必要があります。このルーティングを行うためには、外部ルータ(Cisco 2500、Cisco 4000、Cisco 7000 など)、内部ルータ(つまり Route Switch Module(RSM; ルート スイッチ モジュール))、またはルーティング ソフトウェアを搭載した外部デバイス(つまり routed または gated が動作する UNIX ホスト)を使用します。以前は、各 VLAN に接続されたルータにそれぞれ異なる物理ポートを用意する方式がとられていました。この方式では、VLAN の数が増加するにつれて必要なコストも増えます。しかし、より優れた方法が存在します。ネットワーク内の VLAN の数が増加するにつれて、ネットワーク管理者は、VLAN ごとにルータ インターフェイスを用意するのか、それとも VLAN トランキングを使用して複数の VLAN を単一のルーテッド インターフェイスに割り当てるのかを決める必要があります。100 MB 以上の高速なイーサネット ポートを備え、適切なソフトウェア(後述します)を搭載したルータのみが、このような VLAN トランキングを実現できます。

VLAN トランキングでは、100 Mb ファースト イーサネットまたは 1000 Mb ギガビット イーサネット インターフェイスで、パケットが属する VLAN を識別するタグをパケットに付加できます。このタグ付きパケットが Inter-Switch Link(ISL; スイッチ間リンク)トランクのもう一方の端で受信されると、そこで適切な VLAN に転送されます。ISL タグは、ファースト イーサネット フレームに付加される 30 バイトのヘッダーです。このため、ISL はポイントツーポイント テクノロジーであり、100 Mb ファースト イーサネットまたは 1000 Mb ギガビット イーサネット インターフェイスで ISL をサポートする、2 台の Cisco デバイス(スイッチまたはルータ)間でのみ機能します。ISL パケットおよびヘッダーの詳細については、「ISL 機能仕様」を参照してください。次の図は、ISL トランクについて視覚的に説明したものです。

24a.gif

ISL VLAN タギングは、Cisco IOS バージョン 11.1 以降の Cisco ルータで使用できます。Cisco IOS バージョン 11.1 および 11.2 では、802.3(Novell-Ether)カプセル化を使用する IP および IPX のみが ISL でサポートされていました。現在の Cisco IOS 11.3 では、他のカプセル化およびプロトコルも ISL でサポートされます。Cisco IOS 11.3 までは、IP または IPX 802.3 以外のカプセル化プロトコルが必要な場合、Cisco IOS 11.2 IOS から使用可能になった Integrated Routing and Bridging(IRB)と呼ばれる機能を使用できました。Cisco IOS 11.1 では、ISL をサポートするために Enterprise 機能セットが必要です。Cisco IOS 11.2 以降では、Plus(つまり、IP Plus、Desktop Plus)機能セットのみが必須です。ISL VLAN トランキングは、ルータの任意のファースト イーサネットまたはギガビット イーサネット インターフェイスでサポートされます。

実際の設定

注:一部のネットワーク モジュールを搭載したルータ モデルは、ISL トランキングをサポートするために必要な最低限の Cisco IOS バージョンが異なります。すべてのルータ ファミリに関する最低限のサポート ソフトウェアの詳細については、Hardware-Software Compatibility Matrix およびそのルータ プラットフォームのリリース ノートを参照してください。

H3 手順

Catalyst 5000 スイッチでの設定は、別の Catalyst 5000 スイッチに接続されている場合とまったく同じです。ここでは、Cisco ルータの設定を中心に説明します。

  1. 適切なケーブル(ストレート型カテゴリ 5、または光ファイバ)を使用し、ISL 対応ポート経由でスイッチにルータを接続します。

  2. Catalyst 5000 スイッチで VLAN が作成され、Catalyst 5000 ポートが ISL トランク ポートに設定されていることを確認します。

    これを確認するには、Catalyst 5000 スイッチで show vlan および show trunk コマンドを使用します。

  3. これらの準備が完了したら、ルータでの VLAN の定義を開始できます。設定するレイヤ 2 および レイヤ 3 情報(つまり、IP アドレス、IPX ネットワーク番号など)を、VLAN ごとに把握していることを確認します。

version 11.3

 

 no service password-encryption

 

 !

 

 hostname lt-4500-static

 

 !

 

 enable secret 5 $1$XqiP$3ADCgrFMC21pwyVQIkith.

 

 !

 

 no ip domain-lookup

 

 appletalk routing

 

 ipx routing 0000.0c0b.f2f5

 

 !

 

 !

 

 interface FastEthernet0

 

 !--- ここでは レイヤ 1 のみが設定されます。

 

 

  no ip address

 

  full-duplex

 

 !

 

 interface FastEthernet0.1

 

 !--- レイヤ 2/レイヤ 3 はすべてサブインターフェイス上にあります。

 

 

  encapsulation isl 1

 

 !--- ISL カプセル化および VLAN# を定義します。

 

 

  ip address 10.6.1.220 255.255.255.0

 

  no ip redirects

 

  appletalk cable-range 100-100 100.149

 

  appletalk zone cisco

 

  ipx network ABC encapsulation SAP

 

 !

 

 interface FastEthernet0.2

 

  encapsulation isl 2

 

  ip address 10.7.1.220 255.255.255.0

 

  no ip redirects

 

  appletalk cable-range 200-200 200.135

 

  appletalk zone cisco1

 

  ipx network DEADBEEF encapsulation ARPA

 

 !

 

 interface FastEthernet0.3

 

  encapsulation isl 3

 

  ip address 10.8.1.220 255.255.255.0

 

  no ip redirects

 

  appletalk cable-range 300-300 300.69

 

  appletalk zone cisco2

 

  ipx network 1234 encapsulation SNAP

 

 !

 

 ip classless

 

 !

 

 line con 0

 

 line aux 0

 

 line vty 0 4

 

  password cisco

 

  login

 

 !

 

 end

 

 

他のレイヤ 2/レイヤ 3 情報を設定するためには、あらかじめ encapsulation isl <vlan#> コマンドが設定されている必要があります。サブインターフェイスの VLAN id# は必ずしも一致させる必要はありませんが、VLAN の管理と問題発生時のトラブルシューティングを容易にするために一致させることをお勧めします。

サブインターフェイスを使用しなければならない理由は、サブインターフェイスを使用しなければ、トラフィックを受信したインターフェイスからそのトラフィックが送り返されるという、スプリットホライズン ルールの違反が発生するためです。この方法は、WAN 環境でフレームリレーにポイントツーポイント サブインターフェイスを使用する方法とよく似ています。

デバッグおよびトラブルシューティング

設定、Cisco IOS、およびハードウェア プラットフォームが正しいことが確認されたら、すべてが正しく機能するかどうかを確認する必要があります。動作の確認および問題のトラブルシューティングには、次のコマンドを使用します。

  • show vlan - このコマンドは、各 VLAN に設定されたレイヤ 2 またはレイヤ 3 情報を示します。

    lt-4500-static#show vlan
    
     
    
     
    
     
    
     Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
    
     
    
     
    
     
    
        vLAN Trunk Interface:   FastEthernet0.1
    
     
    
     
    
     
    
        Protocols Configured:   Address:              Received:        Transmitted:
    
     
    
                IP              10.6.1.220                   0                   0
    
     
    
            IPX (SAP)        ABC.0000.0c0b.f2f5              0                   8
    
     
    
              AppleTalk           100.149                    0                  22
    
     
    
     
    
     
    
     Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
    
     
    
     
    
     
    
        vLAN Trunk Interface:   FastEthernet0.2
    
     
    
     
    
     
    
        Protocols Configured:   Address:              Received:        Transmitted:
    
     
    
                IP              10.7.1.220                   0                   0
    
     
    
         IPX (ARPA)     DEADBEEF.0000.0c0b.f2f5              0                   8
    
     
    
              AppleTalk           200.135                    0                  22
    
     
    
     
    
     
    
     Virtual LAN ID:  3 (Inter Switch Link Encapsulation)
    
     
    
     
    
     
    
        vLAN Trunk Interface:   FastEthernet0.3
    
     
    
     
    
     
    
        Protocols Configured:   Address:              Received:        Transmitted:
    
     
    
                IP              10.8.1.220                   0                   0
    
     
    
            IPX (SNAP)      1234.0000.0c0b.f2f5              0                   9
    
     
    
              AppleTalk           300.69                     0                  23
    
     
    
     
  • show interface - このコマンドは、インターフェイス(およびサブインターフェイス)の状態、およびサブインターフェイスの VLAN カラー(VLAN# と同じ)を示します。

    lt-4500-static#show interface
    
     
    
     FastEthernet0 is up, line protocol is up
    
     
    
       Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
    
     
    
       MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
    
     
    
       Encapsulation ARPA, loopback not set, keepalive set (10 sec)
    
     
    
       Full-duplex, 100Mb/s, 100BaseTX/FX
    
     
    
       ARP type: ARPA, ARP Timeout 04:00:00
    
     
    
       Last input 00:00:00, output 00:00:03, output hang never
    
     
    
       Last clearing of "show interface" counters 00:04:25
    
     
    
       Queueing strategy: fifo
    
     
    
       Output queue 0/40, 0 drops; input queue 0/75, 0 drops
    
     
    
       5 minute input rate 0 bits/sec, 1 packets/sec
    
     
    
       5 minute output rate 0 bits/sec, 0 packets/sec
    
     
    
          415 packets input, 25392 bytes, 0 no buffer
    
     
    
          Received 415 broadcasts, 0 runts, 0 giants, 0 throttles
    
     
    
          0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    
     
    
          0 watchdog, 0 multicast
    
     
    
          0 input packets with dribble condition detected
    
     
    
          137 packets output, 12378 bytes, 0 underruns
    
     
    
          0 output errors, 0 collisions, 0 interface resets
    
     
    
          0 babbles, 0 late collision, 0 deferred
    
     
    
          0 lost carrier, 0 no carrier
    
     
    
          0 output buffer failures, 0 output buffers swapped out
    
     
    
     FastEthernet0.1 is up, line protocol is up
    
     
    
       Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
    
     
    
       Internet address is 10.6.1.220/24
    
     
    
       MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
    
     
    
       Encapsulation ISL Virtual LAN, Color 1.
    
     
    
       ARP type: ARPA, ARP Timeout 04:00:00
    
     
    
     FastEthernet0.2 is up, line protocol is up
    
     
    
       Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
    
     
    
       Internet address is 10.7.1.220/24
    
     
    
       MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
    
     
    
       Encapsulation ISL Virtual LAN, Color 2.
    
     
    
       ARP type: ARPA, ARP Timeout 04:00:00
    
     
    
     FastEthernet0.3 is up, line protocol is up
    
     
    
       Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
    
     
    
       Internet address is 10.8.1.220/24
    
     
    
       MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
    
     
    
       Encapsulation ISL Virtual LAN, Color 3.
    
     
    
       ARP type: ARPA, ARP Timeout 04:00:00
    
     
    
     
  • show ip|ipx|appletalk route - このコマンドは、ルーティング情報が正しい ISL サブインターフェイスを経由して学習または送信されていることを示します。

    lt-4500-static#show ip route
    
     
    
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    
     
    
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    
     
    
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    
     
    
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    
     
    
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
    
     
    
            U - per-user static route, o - ODR
    
     
    
     
    
     
    
     Gateway of last resort is not set
    
     
    
     
    
     
    
          10.0.0.0/24 is subnetted, 3 subnets
    
     
    
     C       10.8.1.0 is directly connected, FastEthernet0.3
    
     
    
     C       10.7.1.0 is directly connected, FastEthernet0.2
    
     
    
     C       10.6.1.0 is directly connected, FastEthernet0.1
    
     
    
     
    
     
    
     
    
     
    
     
    
     
    
     lt-4500-static#show appletalk route
    
     
    
     Codes: R - RTMP derived, E - EIGRP derived, C - connected, A - AURP
    
     
    
            S - static  P - proxy
    
     
    
     3 routes in internet
    
     
    
     
    
     
    
     The first zone listed for each entry is its default (primary) zone.
    
     
    
     
    
     
    
     C Net 100-100 directly connected, Fa0.1, zone cisco
    
     
    
     C Net 200-200 directly connected, Fa0.2, zone cisco1
    
     
    
     C Net 300-300 directly connected, Fa0.3, zone cisco2
    
     
    
     
    
     
    
     
    
     
    
     lt-4500-static#show ipx rout
    
     
    
     Codes: C - Connected primary network,    c - Connected secondary network
    
     
    
            S - Static, F - Floating static, L - Local (internal), W - IPXWAN
    
     
    
            R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
    
     
    
            s - seconds, u - uses, U - Per-user static
    
     
    
     
    
     
    
     3 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
    
     
    
     
    
     
    
     No default route known.
    
     
    
     
    
     
    
     C        ABC (ISL vLAN),      Fa0.1
    
     
    
     C       1234 (ISL vLAN),      Fa0.3
    
     
    
     C   DEADBEEF (ISL vLAN),      Fa0.2
    
     
    
     
  • debug vlan packet - このコマンドは、ISL トランク上のパケットが正しく設定されていない、あるいは誤った ISL サブインターフェイスで送信/受信されているといった問題がないかどうかを示します。

    Note: Always be careful when using any debugging as it could cause severe performance issues on the router. To disable debugging, use the undebug all command.

    lt-4500-static#debug vlan pack
    
     
    
     Virtual LAN packet information debugging is on
    
     
    
     lt-4500-static#
    
     
    
     vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
    
     
    
           on interface FastEthernet0.2 which is not configured to
    
     
    
           route or bridge this packet type.
    
     
    
     
    
     
    
     vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
    
     
    
           on interface FastEthernet0.1 which is not configured to
    
     
    
           route or bridge this packet type.
    
     
    
     
    
     
    
     vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 3
    
     
    
           on interface FastEthernet0.3 which is not configured to
    
     
    
           route or bridge this packet type.
    
     
    
     
    
     
    
     vLAN: ISL packet received bearing colour ID 4 on FastEthernet0
    
     
    
           which has no subinterface configured to route or bridge ID 4.
    
     
    
     
    
     
    
     vLAN: ISL packet received bearing colour ID 5 on FastEthernet0
    
     
    
           which has no subinterface configured to route or bridge ID 5.
    
     
    
     
    
     
    
     vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
    
     
    
           on interface FastEthernet0.1 which is not configured to
    
     
    
           route or bridge this packet type.
    
     
    
     
    
     
    
     vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
    
     
    
           on interface FastEthernet0.2 which is not configured to
    
     
    
           route or bridge this packet type.
    
     
    
     

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 17051