ダイヤルとアクセス : 非同期接続

AUX ポート上のモデムを使用したダイヤルアウトの設定

2010 年 7 月 13 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 3 月 2 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      ネットワーク ダイアグラム
      設定
確認
      Show コマンドの出力例
トラブルシューティング
      外部モデムの設定およびトラブルシューティング作業
      トラブルシューティングのためのコマンド
      デバッグの出力例
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、AUX ポート上のモデムを使用したダイヤルアウトの設定方法について説明しています。このシナリオでは、AUX ポート上にモデムを接続したルータが、中央サイト ルータの Primary Rate Interface(PRI; 一次群速度インターフェイス)にダイヤルします。

注:ここではバックアップのシナリオについては説明しておらず、AUX ポート上にモデムを接続したルータ間の Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)ダイヤルアップについてのみ説明しています。



前提条件

要件

この設定を行う前に、AUX ポート上のモデムに関連するさまざまな問題について、十分に理解していることを確認してください。これらの問題に関する詳細については、『モデム-ルータ間接続ガイド』を参照してください。



使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS® ソフトウェア リリース 12.1(2) が動作している Cisco 2600 シリーズ ルータ

  • Cisco IOS ソフトウェア リリース 12.0(7)T が動作している Cisco AS5300 ルータ

注:この設定は、AUX ポートを持つ任意のルータに適用でき、またコンソール ポートを持つルータにも適用できます。ただし、RS232 のモデム制御問題およびいくつかのセキュリティに関連した問題のため、モデムをコンソール ポートに接続することは推奨できません。詳細については、『モデム-ルータ間接続ガイド』を参照してください。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼動中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。



表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



設定

このセクションでは、このドキュメントで説明する機能の設定に必要な情報を提供します。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことをご了承ください。



ネットワーク ダイアグラム

このドキュメントでは次の図に示すネットワーク設定を使用しています。

mod-aux-dialout.gif



設定

このドキュメントでは、次の設定を使用します。

  • maui-slt-01(2600)

  • maui-nas-03(5300)

次の設定では、maui-slt-01(2600)が AUX ポート上のモデムを使用して maui-nas-03(AS5300)の PRI にダイヤルします。NAS(maui-nas-03)は、内部デジタル モデムにコールを送信するように設定されています。

maui-slt-01(2600)

maui-slt-01#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-slt-01
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- これは PPP コールのための基本的な AAA コンフィギュレーションです。

enable secret 5 <deleted>
!
username admin password 0 <deleted>
username maui-nas-03 password 0 cisco

!--- リモート ルータ(maui-nas-03)用のユーザ名と共有秘密パスワード 
!--- を定義します。共有秘密鍵(CHAP 認証で使用)は両側で
!--- 同じにする必要があります。

!
memory-size iomem 30
ip subnet-zero
!
chat-script Dialout ABORT ERROR ABORT BUSY "" 
"AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c

!--- aux 0 でのダイヤルアウト接続に使用するチャット スクリプト「Dialout」を設定します。

modemcap entry MY_USR_MODEM:MSC=&F1S0=1

!--- modemcap(MY_USR_MODEM)は AUX ポートの回線インターフェイスに適用されます。
!--- この modemcap は次のコマンドを使用して作成されました。
!--- modemcap edit MY_USR_MODEM miscellaneous &F1S0=1
!--- 詳細については、『モデム-ルータ間接続ガイド』を参照してください。

!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 no keepalive
 duplex auto
 speed auto
!

!--- 無関係な出力は削除されています。

!
interface Async65

!--- AUX ポートに対応する非同期インターフェイス。 
!--- これは、show line コマンドを使用して確認しました。
!--- 詳細については、「外部モデムの設定およびトラブルシューティング作業」を参照してください。

 no ip address
 encapsulation ppp

!--- このリンクで PPP カプセル化を使用します。

 dialer in-band
 dialer pool-member 20

!--- Async65 を dialer pool 20 のメンバとして指定します。
!--- インターフェイス Dialer 10 で dialer pool 20 コマンドが指定されています。

 async default routing

!--- これにより、非同期インターフェイスを経由するルーティングが許可されます。
!--- これは非同期リンクでルーティング プロトコルを使用するために必要です。

 ppp authentication chap callin
!
interface Dialer10

!---Dialer 10 は Dialer Pool 20 の論理インターフェイスです。

 ip unnumbered Loopback0

!--- Loopback 0 IP アドレスを使用します。

 encapsulation ppp
 ip ospf demand-circuit
 dialer remote-name maui-nas-03

!--- リモート ルータ名を指定します。 
!--- この名前は、リモート ルータで認証に使用されている識別名と 
!--- 一致することが必要です。

 dialer pool 20

!--- Async 65 はこのプールのメンバです。

 dialer idle-timeout 900
 dialer string 81690

!--- 宛先ルータの電話番号を定義します。

 dialer max-call 4096
 dialer-group 1

!--- dialer-list 1 から対象トラフィックの定義を適用します。


 ppp authentication chap callin

!--- 着信コールに対して CHAP 認証を使用します。

!
router ospf 5
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0

!--- ルータ間で OSPF が使用されます。
!--- 適切なスタティック ルートを設定する場合は、ルーティング プロトコルは不要です。

!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer10

!--- デフォルト ルートがインターフェイス Dialer 10 を指しています。 
!--- これが必要なのは、OSPF がデフォルト ルートを送信するように設定されていないためです。

no ip http server
!
access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- 対象トラフィックの定義にアクセス リスト 101 を使用します。
!--- これは dialer-group 1 を使用するインターフェイス Dialer 10 に適用されます。

!
line con 0
 login authentication NO_AUTHEN
 transport input none
!
line aux 0

!--- AUX ポートの回線インターフェイス。

 exec-timeout 0 0

!--- インターフェイスでの exec のタイムアウトを無効にします。

 script dialer Dialout

!--- チャット スクリプト「Dialout」を使用します。

 modem InOut

!--- 着信および発信コールを有効にします。

 modem autoconfigure type MY_USR_MODEM

!--- 前に設定した modemcap MY_USR_MODEM を適用します。

 transport input all
 stopbits 1

!--- 非同期フレーミング オーバーヘッドの減少によりスループットが向上します。 

 speed 115200

!--- 2600 の AUX ポートが速度 115200 をサポートします。
!--- 注:AUX ポート経由でルーティングを行う場合は、文字ごとに 
!--- プロセッサ割り込みが発生し、CPU の負荷が異常に高くなります。 
!--- これを解決するには、低速な AUX ポート速度を使用します。

 flowcontrol hardware

!--- RTS/CTS フローを設定します。

line vty 0 4
!
no scheduler allocate
end

maui-nas-03(5300)

maui-nas-03#show running-config 
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-03
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- これは PPP コールのための基本的な AAA コンフィギュレーションです。

enable secret 5 <deleted>
!
username admin password 0 <deleted>
username maui-slt-01 password 0 cisco

!--- リモート ルータ(maui-slt-01)用のユーザ名と共有秘密パスワードを定義します。
!--- 共有秘密鍵(CHAP 認証で使用)は両側で同じにする必要があります。

spe 1/0 1/7
firmware location system:/ucode/mica_port_firmware
!
ip subnet-zero
!
isdn switch-type primary-ni
mta receive maximum-recipients 0
!
controller T1 0

!--- プライマリ T1。

 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!

!--- 無関係な出力は削除されています。

!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 172.22.53.105 255.255.255.0
 no ip directed-broadcast
 no keepalive
!

!--- 無関係な出力は削除されています。

!
interface Serial0:23

!--- T1 0 用の D チャネル。

 no ip address
 no ip directed-broadcast
 encapsulation ppp
 isdn switch-type primary-ni
 isdn incoming-voice modem

!--- これにより、モデムに着信非同期コールが送信されます。

 fair-queue 64 256 0
 ppp authentication chap
!         

!--- 無関係な出力は削除されています。

!
interface Group-Async0

!--- Group-Async インターフェイスはモデムを集約するために使用されます。

 ip unnumbered Loopback0
 no ip directed-broadcast
 encapsulation ppp
 ip ospf network point-to-point

!--- これにより OSPF ネットワークのタイプが識別されます。 

 async default routing

!--- これにより、非同期インターフェイスを経由するルーティングが許可されます。
!--- これは非同期リンクでルーティング プロトコルを実行するために必要です。

 async mode interactive
 peer default ip address pool clientpool

!--- これにより、「clientpool」と名付けられたプールから、IP アドレスが
!--- 着信コールに割り当てられます。

 ppp authentication chap
 group-range 1 96
!
router ospf 5
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
!
ip local pool clientpool 172.22.1.2 172.22.1.30

!--- ダイヤルイン コールのための IP アドレスがこのプールから与えられます。

ip classless
no ip http server
!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 1 96
 autoselect ppp
 modem InOut
 transport preferred lat pad telnet rlogin udptn v120 lapb-ta
 transport output lat pad telnet rlogin udptn v120 lapb-ta
line aux 0
line vty 0 4
!
end

注:maui-nas-03 は、maui-slt-01(クライアント)からのコールだけを受け入れるようには設定されていません。NAS(maui-nas-03)の観点から見た場合、着信コールは単なる別のダイヤルイン クライアントにすぎません。この設定は、多数のリモート クライアントが中央サイト NAS の PRI にダイヤルし、企業ネットワークに接続する場合に使用できます。



確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことをご了承ください。



Show コマンドの出力例

show ip route コマンドを使用して、ダイヤラまたは非同期インターフェイスへの経路が存在するかどうかを確認します。非同期またはダイヤラ インターフェイスへの経路がない場合、ダイヤリングを開始できません。このため、必要に応じて、スタティック ルートを設定します。

    maui-slt-01#show ip route
    Codes:C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
          D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
          N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
          E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
          i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
          * - candidate default, U - per-user static route, o - ODR
          P - periodic downloaded static route

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

         172.17.0.0/24 is subnetted, 1 subnets
    C       172.17.1.0 is directly connected, Loopback0
         172.16.0.0/24 is subnetted, 1 subnets
    C       172.16.1.0 is directly connected, FastEthernet0/0
    S*   0.0.0.0/0 is directly connected, Dialer10

注:ダイヤラ インターフェイスへのデフォルト ルートが存在します。

次にルータはダイヤルを開始し、接続、PPP のネゴシエート、および OSPF データベースの交換を行います。このプロセスの詳細については、下記のデバッグ情報を参照してください。

接続が成功した後に、show ip route コマンドを使用します。このシナリオでは、ルーティング プロトコル OSPF が使用されています。ルーティング テーブルに OSPF 経路が追加されたことを確認してください。

    maui-slt-01#show ip route
    Codes:C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
          D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
          N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
          E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
          i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
          * - candidate default, U - per-user static route, o - ODR
          P - periodic downloaded static route

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

         172.17.0.0/24 is subnetted, 1 subnets
    C       172.17.1.0 is directly connected, Loopback0
         172.16.0.0/24 is subnetted, 1 subnets
    C       172.16.1.0 is directly connected, FastEthernet0/0
         172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
   O       172.22.53.0/24 [110/1795] via 172.22.1.1, 00:00:03, Dialer10
    C       172.22.1.1/32 is directly connected, Dialer10
    S*   0.0.0.0/0 is directly connected, Dialer10


トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を紹介します。



外部モデムの設定およびトラブルシューティング作業

外部モデムを設定し、モデムが正しく機能していることを確認します。ルータで正しくダイヤルして、このモデムのヘルプに接続できることを確認すると、必要な DDR 設定、PPP 設定およびその他の高レベルのプロトコル設定をルータのダイヤルアウト時に実行できます。このセクションでは、コールを受けるルータが上記のとおり正しく設定されていることを前提にしています。

  1. 適切なケーブルを AUX ポートからモデムに接続します。ケーブル接続オプションの詳細については、『モデム-ルータ間接続ガイド』を参照してください。

  2. show line コマンドを使用して、AUX ポートの非同期インターフェイスを調べます。ほとんどのルータには、interface async 1 として AUX ポートがありますが、アクセス サーバには TTY 回線の後に AUX ポートがあります。たとえば、ルータに 16 の非同期またはモデム回線がある場合、AUX ポートはライン 17 です。このような場合、interface async 17 に AUX ポートを設定する必要があります。show line 出力に基づいて、AUX ポートを設定します。この例では、maui-slt-01 で interface Async65 に AUX ポートが設定されていることを確認します。

        maui-slt-01#show line
           Tty Typ   Tx/Rx    A Modem  Roty AccO AccI  Uses  Noise  Overruns  Int
        *    0 CTY            -    -      -    -    -     0      0     0/0      -
          65 AUX 9600/9600  -    -      -    -    -     0      1     0/0      -
             66 VTY            -    -      -    -    -     0      0     0/0      -
             67 VTY            -    -      -    -    -     0      0     0/0      -
             68 VTY            -    -      -    -    -     0      0     0/0      -
             69 VTY            -    -      -    -    -     0      0     0/0      -
             70 VTY            -    -      -    -    -     0      0     0/0      -
    
        Line(s) not in async mode -or- with no hardware support: 
        1-64
  3. AUX ポートに接続されたモデムのモデムキャップを設定します。モデム プラットフォームで使用する適切な初期化文字列については、『モデム-ルータ間接続ガイド』を参照してください。初期化(init)文字列を含む新しいモデムキャップを作成します。新しいモデムキャップ(MY_USR_MODEM)の例を次に示します。

        maui-slt-01(config)#modemcap edit MY_USR_MODEM miscellaneous &F1S0=1

    上のモデムキャップの設定で &F1S0=1 が init 文字列です。モデムに適した init 文字列に関する特定の情報については、「modemcap の作成」を参照してください。

  4. モデムキャップを AUX ポートに適用します。AUX ポートがライン 65 にあることを事前に確認しました。

        maui-slt-01(config)#line 65
        maui-slt-01(config-line)#modem autoconfigure type MY_USR_MODEM

    モデム接続用の AUX ポート回線も設定する必要があります。回線の設定の詳細については、『モデム-ルータ間接続ガイド』を参照してください。前に示した maui-slt-01 の設定例にも必要なコマンドが含まれています。

    debug confmodem を使用して、モデムキャップが正しく適用されているかどうか確認します。モデムの電源を入れ直した後、ルータが自動的にモデムを設定します。

        maui-slt-01#debug confmodem
        Modem Configuration Database debugging is on
        maui-slt-01#
    
        !--- モデムの電源を入れ直します。
    
        *Mar  1 06:58:10.118: TTY65: detection speed (115200) response ---OK---
        *Mar  1 06:58:10.122: TTY65: Modem command: --AT&F1S0=1--
    
        !--- モデムキャップで指定された init 文字列を適用します。
    
        *Mar  1 06:58:10.758: TTY65: Modem configuration succeeded
    
        !--- モデムは正しく設定されました。
    
        *Mar  1 06:58:10.758: TTY65: Detected modem speed 115200
        *Mar  1 06:58:10.758: TTY65: Done with modem configuration
        maui-slt-01#
  5. show line aux 0 または show line aux-line コマンドを発行します。すべての信号が動作していることを確認します。たとえば、CTS、RTS、DTR、CD などです。これらの信号の横に何も表示されていなければ、信号は動作しています。信号の横に「No」と表示される場合(たとえば、「No CTS」)、信号が停止していることを示します。信号が停止している場合、ケーブルおよびルータの設定を確認してください。また、非同期インターフェイスがあるか、および AUX ポートの回線が正しく設定されているかも確認してください。ケーブル接続の詳細については、『モデム-ルータ間接続ガイド』を参照してください。接続の問題の解決方法については、『ダイヤルイン接続のトラブルシューティング』を参照してください。次に例を示します。

        maui-slt-01#show line 65
            Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
        A   65 AUX 115200/115200- inout     -    -    -      8       1     1/0       -
          Ready
    
        Line 65, Location: "PPP: 172.22.1.1", Type: ""
        Length: 24 lines, Width: 80 columns
        Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
        Status: Ready, Active, No Exit Banner, Async Interface Active
          Modem Detected, CTS Raised, Modem Signals Polled
        Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
          Modem Callout, Modem RI is CD, Modem Autoconfigure
        Modem state: Ready
        Group codes:    0
        Line is running PPP routing for address 172.22.1.1.
        0 output packets queued, 1 input packets.
         Async Escape map is 00000000000000000101000000000000
        Modem hardware state: CTS* DSR*  DTR RTS
    
        !--- すべての信号が動作しています。
    
         TTY NUMBER 65
        Parity Error = 0 Framing Error = 536 Receive Error = 536 Overrun = 1
        Outcount = 0 totalout = 40615 incount = 0 totalin = 49805
        , Modem Configured
        Special Chars:Escape  Hold  Stop  Start  Disconnect  Activation
                       ^^x    none   -     -       none                   
        Timeouts:Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
                 00:10:00        never                        none    not set
                              Idle Session Disconnect Warning
                                 never 
                              Login-sequence User Response
                               00:00:30
                              Autoselect Initial Wait
                                not set 
        Modem type is MY_USR_MODEM.
    
        !--- モデムキャップは MY_USR_MODEM です。
    
        Session limit is not set.
        Time since activation: never
        Editing is enabled.
        History is enabled, history size is 10.
        DNS resolution in show commands is enabled
        Full user help is disabled
        Allowed transports are lat pad v120 mop telnet rlogin nasi. 
        Preferred is lat.
        No output characters are padded
        No special data dispatching characters
        maui-slt-01# 
  6. AUX ポートから モデムへリバース Telnet を実行し、AT コマンド set to manually dial を使用して、リモート デバイスに接続します。このコマンドを使用して、モデムのハードウェアと電話回線が正しく機能していることを確認できます。この例では、AUX ポートがライン 65 にあるので、ルータ上のポート 2065 にリバース Telnet する必要があります。リバース Telnet についての詳細は、『モデムとのリバース Telnet セッションの確立』を参照してください。

        maui-slt-01#telnet 172.17.1.1 2065 
        Trying 172.17.1.1, 2065 ...Open
    
        User Access Verification
    
        Username: admin Password:
    
        !--- リバース Telnet のためにローカル ルータによって認証が実行されました。
    
        at
        OK
        atdt 81690 
    
        !--- モデムがダイヤルし(81690)、接続します。 
        !--- このプロセスには約 30 〜 45 秒かかかります。
    
        CONNECT 31200/ARQ/V34/LAPM/V42BIS
    
        !--- ネゴシエーションされた接続速度とプロトコル。
    
        User Access Verification
     
        Username:maui-slt-01
        Password:
    
        !--- リモート ルータによって着信コールのために実行された認証。
    
    
    
        maui-nas-03>
    
        !--- リモート ルータ上のプロンプト。
    
    

    上記のように、モデムにリバース Telnet を実行し、at コマンドを使用して、モデムが応答するか確認します。「OK」を受信したら、atdt number コマンドを使用して、リモート番号をダイヤルします。コールが実行され、リモートデバイスに接続します。リモート ルータは次に着信コールを認証します。外部モデムがダイヤルしないことに気づいた場合は、ケーブル接続が正しいか、外部モデムが故障していないか、電話回線が正常に機能しているかを確認してください。詳細は、『モデム サポートおよびその他の非同期機能の設定』および『ダイヤルイン接続のトラブルシューティング』を参照してください。

    上記の作業と手順を完了したら、ルータが自動的にダイヤルアップ接続を起動できるかテストできます。詳細は、『AUX ポート上のモデムを使用したダイヤルアウトの設定』ドキュメントの「show コマンドの出力例」および「debug コマンドの出力例」セクションを参照してください。



トラブルシューティングのためのコマンド

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことをご了承ください。

注:debug コマンドを発行する前に、『debug コマンドの重要な情報』を参照してください。

  • debug dialer:ダイヤラ インターフェイスで受信されたパケットのデバッグ情報が表示されます。インターフェイスで DDR が有効になっている場合、コールの理由(ダイヤリングを呼び出した理由)に関する情報も表示されます。詳細は、「debug clns - debug fras」の debug dialer コマンドの項を参照してください。

  • debug modem:モデム回線の動作、モデム制御およびプロセス アクティベーション メッセージがルータ上に表示されます。

  • debug chat :非同期/POT ダイヤリングが開始されると、チャット スクリプトの実行を監視します。詳細は、「非同期発信コール:チャット スクリプトの動作の確認」セクション(『ダイヤルアップ テクノロジー:トラブルシューティング テクニック』)を参照してください。

  • debug ppp negotiation:Link Control Protocol(LCP; リンク コントロール プロトコル)、認証、および Network Control Protocol(NCP; ネットワーク コントロール プロトコル)などの PPP コンポーネントとネゴシエーションするときに、PPP トラフィックに関する情報を表示して、交換します。正しい PPP のネゴシエーションでは、最初に LCP の状態が開示され、次いで認証が行われ、最後に NCP のネゴシエーションが行われます。

  • debug ppp authentication:Challenge Authentication Protocol(CHAP)パケット交換や Password Authentication Protocol(PAP; パスワード認証プロトコル)交換などの PPP 認証プロトコル メッセージを表示します。



デバッグの出力例

debug コマンドを使用して、接続のトラブルシューティングを実行します。

    maui-slt-01#debug dialer
    Dial on demand events debugging is on
    maui-slt-01#debug chat
    Chat scripts activity debugging is on
    maui-slt-01#debug modem
    Modem control/process activation debugging is on
    maui-slt-01#debug ppp negotiation
    PPP protocol negotiation debugging is on
    maui-slt-01#debug ppp authentication
    PPP authentication debugging is on       
    maui-slt-01#
    maui-slt-01#show debug
    General OS:
      Modem control/process activation debugging is on
    Dial on demand:
      Dial on demand events debugging is on
    PPP:
      PPP authentication debugging is on
      PPP protocol negotiation debugging is on
    Chat Scripts:
      Chat scripts activity debugging is on
    maui-slt-01#
    maui-slt-01#ping 172.22.53.105

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.22.53.105, timeout is 2 seconds:

    *Mar  1 05:37:44.858: As65 DDR: rotor dialout [priority]
    *Mar  1 05:37:44.858: As65 DDR: Dialing cause ip (s=172.17.1.1, d=172.22.53.105)

    !--- ダイヤルする理由。

    *Mar  1 05:37:44.858: As65 DDR: Attempting to dial 81690

    !--- ダイヤルされた電話番号。

    *Mar  1 05:37:44.858: CHAT65: Attempting async line dialer script
    *Mar  1 05:37:44.858: CHAT65: Dialing using Modem script: Dialout
    & System script:none

    !--- チャット スクリプト「Dialout」を使用します。

    *Mar  1 05:37:44.862: CHAT65: process started
    *Mar  1 05:37:44.862: CHAT65: Asserting DTR
    *Mar  1 05:37:44.862: TTY65: Set DTR to 1
    *Mar  1 05:37:44.862: CHAT65: Chat script Dialout started

    !--- チャット スクリプト「Dialout」を開始しました。

    *Mar  1 05:37:44.862: CHAT65: Sending string: AT
    *Mar  1 05:37:44.862: CHAT65: Expecting string: OK
    *Mar  1 05:37:44.990: CHAT65: Completed match for expect: OK
    *Mar  1 05:37:44.990: CHAT65: Sending string: ATDT \T<81690>
    *Mar  1 05:37:44.990: CHAT65: Expecting string: CONNECT
    *Mar  1 05:38:02.774: CHAT65: Completed match for expect: CONNECT
    *Mar  1 05:38:02.774: CHAT65: Sending string: \c
    *Mar  1 05:38:02.774: CHAT65: Chat script Dialout finished, status = Success

    !--- チャット スクリプトが正しく完了しました。 
    !--- Expect/Send 属性および経過時間に注意してください。

    *Mar  1 05:38:02.774: TTY65: destroy timer type 1
    *Mar  1 05:38:02.778: TTY65: destroy timer type 0
    *Mar  1 05:38:04.778: %LINK-3-UPDOWN: Interface Async65, changed state to up
    *Mar  1 05:38:04.778: Async65 DDR: Dialer statechange to up
    *Mar  1 05:38:04.778: %DIALER-6-BIND: Interface As65 bound to profile Di10
    *Mar  1 05:38:04.782: Async65 DDR: Dialer call has been placed
    *Mar  1 05:38:04.782: As65 PPP: Treating connection as a callout

    !--- PPP LCP ネゴシエーションが始まります。

    *Mar  1 05:38:04.782: As65 PPP: Phase is ESTABLISHING, Active Open
    *Mar  1 05:38:04.782: As65 PPP: No remote authentication for call-out
    *Mar  1 05:38:04.782: As65 LCP: O CONFREQ [Closed] id 43 len 20
    *Mar  1 05:38:04.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
    *Mar  1 05:38:04.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
    *Mar  1 05:38:04.786: As65 LCP:    PFC (0x0702)
    *Mar  1 05:38:04.786: As65 LCP:    ACFC (0x0802)
    *Mar  1 05:38:06.782: As65 LCP: TIMEout: State REQsent
    *Mar  1 05:38:06.782: As65 LCP: O CONFREQ [REQsent] id 44 len 20
    *Mar  1 05:38:06.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
    *Mar  1 05:38:06.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
    *Mar  1 05:38:06.782: As65 LCP:    PFC (0x0702)
    *Mar  1 05:38:06.782: As65 LCP:    ACFC (0x0802)
    *Mar  1 05:38:08.782: As65 LCP: TIMEout: State REQsent
    *Mar  1 05:38:08.782: As65 LCP: O CONFREQ [REQsent] id 45 len 20
    *Mar  1 05:38:08.782: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
    *Mar  1 05:38:08.782: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
    *Mar  1 05:38:08.782: As65 LCP:    PFC (0x0702)
    *Mar  1 05:38:08.782: As65 LCP:    ACFC (0x0802)

    !--- 2 つの送信 CONFREQ がタイムアウトしたことがわかります。
    !--- 受信 CONFREQ なしで、このような状況が見られる場合は、コールを受信する 
    !--- ルータで autoselect ppp または async mode dedicated コマンドが
    !--- 設定されていることを確認してください。

    *Mar  1 05:38:08.934: As65 LCP: I CONFREQ [REQsent] id 2 len 25
    *Mar  1 05:38:08.934: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
    *Mar  1 05:38:08.934: As65 LCP:    AuthProto CHAP (0x0305C22305)
    *Mar  1 05:38:08.934: As65 LCP:    MagicNumber 0x515A1AC7 (0x0506515A1AC7)
    *Mar  1 05:38:08.938: As65 LCP:    PFC (0x0702)
    *Mar  1 05:38:08.938: As65 LCP:    ACFC (0x0802)
    *Mar  1 05:38:08.938: As65 LCP: O CONFACK [REQsent] id 2 len 25
    *Mar  1 05:38:08.938: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
    *Mar  1 05:38:08.938: As65 LCP:    AuthProto CHAP (0x0305C22305)
    *Mar  1 05:38:08.938: As65 LCP:    MagicNumber 0x515A1AC7 (0x0506515A1AC7)
    *Mar  1 05:38:08.938: As65 LCP:    PFC (0x0702)
    *Mar  1 05:38:08.938: As65 LCP:    ACFC (0x0802)
    *Mar  1 05:38:08.942: As65 LCP: I CONFACK [ACKsent] id 45 len 20
    *Mar  1 05:38:08.946: As65 LCP:    ACCM 0x000A0000 (0x0206000A0000)
    *Mar  1 05:38:08.946: As65 LCP:    MagicNumber 0x314EFEBB (0x0506314EFEBB)
    *Mar  1 05:38:08.946: As65 LCP:    PFC (0x0702)
    *Mar  1 05:38:08.946: As65 LCP:    ACFC (0x0802)
    *Mar  1 05:38:08.946: As65 LCP: State is Open
    *Mar  1 05:38:08.946: As65 PPP: Phase is AUTHENTICATING, by the peer
    *Mar  1 05:38:09.066: As65 CHAP: I CHALLENGE id 1 len 32 from "maui-nas-03"
    *Mar  1 05:38:09.066: As65 CHAP: O RESPONSE id 1 len 32 from "maui-slt-01"
    *Mar  1 05:38:09.206: As65 CHAP: I SUCCESS id 1 len 4

    !--- CHAP 認証が成功しました。

    *Mar  1 05:38:09.206: As65 PPP: Phase is UP
    *Mar  1 05:38:09.210: As65 IPCP: O CONFREQ [Not negotiated] id 13 len 10
    *Mar  1 05:38:09.210: As65 IPCP:    Address 172.17.1.1 (0x0306AC110101)
    *Mar  1 05:38:09.218: As65 IPCP: I CONFREQ [REQsent] id 1 len 10
    *Mar  1 05:38:09.218: As65 IPCP:    Address 172.22.1.1 (0x0306AC160101)
    *Mar  1 05:38:09.218: As65 IPCP: O CONFACK [REQsent] id 1 len 10
    *Mar  1 05:38:09.218: As65 IPCP:    Address 172.22.1.1 (0x0306AC160101)
    *Mar  1 05:38:09.350: As65 IPCP: I CONFNAK [ACKsent] id 13 len 10
    *Mar  1 05:38:09.350: As65 IPCP:    Address 172.22.1.9 (0x0306AC160109)
    *Mar  1 05:38:09.350: As65 IPCP: O CONFREQ [ACKsent] id 14 len 4
    *Mar  1 05:38:09.478: As65 IPCP: I CONFACK [ACKsent] id 14 len 4
    *Mar  1 05:38:09.478: As65 IPCP: State is Open

    !--- IPCP ネゴシエーションが完了しました。

    *Mar  1 05:38:09.482: As65 DDR: dialer protocol up
    *Mar  1 05:38:09.482: Di10 IPCP: Install route to 172.22.1.1
    *Mar  1 05:38:10.206: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65,
    changed state to up

    !--- インターフェイスが動作しています。



関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報




Document ID: 5465