ダイヤルとアクセス : バーチャル プライベート ダイヤルアップ ネットワーク(VPDN)

NAS から LNS までの間で複数のホップを実行するための L2TP マルチホップの設定方法

2003 年 12 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 11 月 19 日) | フィードバック

概要

VPDN(Multihop Virtual Private Dialup Network)環境では、NAS/LAC から、HGW(home gateway)または LNS(L2TP Network Server)までの間に複数のホップを設定できます。サポートされるホップは最大4つまでです。VPDN では、それぞれのホップ内でトンネルをいったん終了してから次ホップの宛先へのトンネルを再構築します。このプロセスによってトンネルスイッチングが可能になり、リンクを L2TP や L2F 用に設定することも可能になります。マルチホッピングを各 ISP 間で使用すれば、ホールセール型アクセス VPN(Virtual Private Network)サービスの提供も可能になります。

次の例では L2F と L2TP の両方がサポートされますが、現在 L2TP が業界標準になりつつあるるため、この文書では L2TP に焦点を合わせて説明します。

ハードウェアとソフトウェアのバージョン

この構成は次のバージョンのソフトウェアおよびハードウェアを使用して設定およびテストされました。

  • Cisco IOS® バージョン 12.0(7)T - 12.1(1)

  • LAC(L2TP Access Concentrator):Cisco AS5300 アクセスサーバ

  • LNS(L2TP Network Server):Cisco 7200 および 2500 ルータ

  • クライアント:Cisco 800 シリーズ ルータ 

この例では、NAS/LAC と宛先 LNS の間に最大 3 つのルータを使用することにより、最大 4 つの L2F または L2TP ホップがサポートされています。

  1. リモートクライアントが LAC にダイヤルします。LAC は LCP(link control protocol)をネゴシエートし、ユーザーをプレ認証します。セッションが次ホップ LNS1 に送られます。セッションがまだ作成されていない場合は、SCCRQ(Start-Control-Connection-Request)を通じてトンネルが設定されます。

  2. 最初のホップである LNS1 は、LAC からICRQ(Incoming-Call-Request)を受け取り、セッションのネゴシエーションを完了します。

  3. 同じユーザのドメイン名を使用して 2 番目の宛先へのトンネルを開いている VPDN グループが他に設定されていなければ、LNS1 はそれ自身が宛先 LNS であると判断し、PPP(Point-to-Point Protocol)を終了します。

  4. 異なる VPDN グループ内に同じドメインを使用した別の宛先が設定されている場合は、2 番目の宛先(LNS2)に対して新しいセッションが起動されます。他のセッションがまだ開設されていない場合は、2 番目の宛先へのトンネルが最初に作成されます。

  5. LNS2 は、同じドメインを使用して 3 番目の宛先を設定している別の VPDN グループが存在していないかどうかをチェックします。もし存在する場合は、それが宛先 LNS であると判断し、クライアントからの PPP を終了します。

ネットワーク図

network

設定
Cisco AS5300 (LAC)
vpdn enable

  vpdn multihop

  no vpdn logging

  !

  vpdn-group 1

   request-dialin

    protocol l2tp

    domain cisco.com

   initiate-to ip 10.200.20.14

Cisco 7200 (LNS1)
Current configuration:

  !

  version 12.0

  service timestamps debug uptime

  service timestamps log uptime

  no service password-encryption

  !

  hostname fifi

  !

  !

  username fifi password 0 cisco

  username po password 0 cisco

  username joe@cisco.com password 0 test

  !

  !

  ip subnet-zero

  no ip domain-lookup

  ip host romeo 10.200.20.36

  ip host rund 172.17.247.195

  !

  vpdn enable

  vpdn multihop

  !

  vpdn-group 1

   accept-dialin

    protocol l2tp

    virtual-template 1

   terminate-from hostname po

  !

  vpdn-group 2

   request-dialin

    protocol l2tp

    domain cisco.com

   initiate-to ip 10.200.20.36

  !

  !

  interface Ethernet1/0

   ip address 10.200.20.14 255.255.248.0

   no ip directed-broadcast

  !

  interface Ethernet1/1

   no ip address

   no ip directed-broadcast

   shutdown

  !

  interface Ethernet1/2

   no ip address

   no ip directed-broadcast

   shutdown

  !

  interface Ethernet1/3

   no ip address

   no ip directed-broadcast

   shutdown

  !

  interface Virtual-Template1

   ip unnumbered Ethernet1/0

   no ip directed-broadcast

   no peer default ip address

   ppp authentication chap pap callin

   ppp multilink

  !

  ip local pool default 10.10.10.10 10.10.10.20

  ip classless

  ip route 0.0.0.0 0.0.0.0 10.200.20.1

  no ip http server

  !

  !

  line con 0

   exec-timeout 0 0

   transport input none

  line aux 0

  line vty 0 4

   login

  !

  end

Cisco 2500 (LNS2)
Current configuration:

  !

  version 12.0

  service timestamps debug uptime

  service timestamps log uptime

  no service password-encryption

  !

  hostname romeo

  !

  !

  username fifi password 0 cisco

  username po password 0 cisco

  username joe@cisco.com password 0 test

  username romeo password 0 cisco

  !

  !

  !

  !

  ip subnet-zero

  no ip domain-lookup

  ip host fifi 10.200.20.14

  ip host rund 172.17.247.195

  !

  vpdn enable

  vpdn multihop

  !

  vpdn-group 1

   accept-dialin

    protocol l2tp

    virtual-template 1

   terminate-from hostname fifi

  !

  isdn voice-call-failure 0

  cns event-service server

  !

  !

  !

  interface Ethernet0

   ip address 10.200.20.36 255.255.248.0

   no ip directed-broadcast

  !

  interface Virtual-Template1

   ip unnumbered Ethernet0

   no ip directed-broadcast

   peer default ip address pool default

   ppp authentication chap pap callin

   ppp multilink

  !

  interface Serial0

   no ip address

   no ip directed-broadcast

   no ip mroute-cache

   shutdown

   no fair-queue

  !

  interface Serial1

   no ip address

   no ip directed-broadcast

   shutdown

  !

  interface Serial2

   no ip address

   no ip directed-broadcast

   shutdown

  !

  interface Serial3

   no ip address

   no ip directed-broadcast

   shutdown

  !

  interface BRI0

   no ip address

   no ip directed-broadcast

   shutdown

   isdn guard-timer 0 on-expiry accept

  !

  ip local pool default 10.10.10.21 10.10.10.30

  ip classless

  ip route 0.0.0.0 0.0.0.0 10.200.20.1

  no ip http server

  !

  !

  !

  line con 0

   exec-timeout 0 0

   transport input none

  line aux 0

  line vty 0 4

  !

  end

Cisco 2500 (LNS2)
Current configuration:

  !

  version 12.0

  service timestamps debug uptime

  service timestamps log uptime

  no service password-encryption

  !

  hostname romeo

  !

  !

  username STACK password 0 cisco

  username fifi password 0 cisco

  username po password 0 cisco

  username joe@cisco.com password 0 test

  username romeo password 0 cisco

  !

  !

  !

  !

  ip subnet-zero

  no ip domain-lookup

  ip host fifi 10.200.20.14

  ip host rund 172.17.247.195

  !

  !

  sgbp group STACK

  sgbp member fifi 10.200.20.14

  sgbp ppp-forward

  vpdn enable

  vpdn multihop

  !

  vpdn-group 1

   accept-dialin

    protocol l2tp

    virtual-template 1

   terminate-from hostname po

  !

  multilink virtual-template 1

  isdn voice-call-failure 0

  cns event-service server

  !

  !

  !

  interface Ethernet0

    ip address 10.200.20.36 255.255.248.0

    no ip directed-broadcast

  !

  interface Virtual-Template1

    ip unnumbered Ethernet0

    no ip directed-broadcast

    peer default ip address pool default

    ppp authentication chap pap callin

    ppp multilink

  !

  interface Serial0

    no ip address

    no ip directed-broadcast

    no ip mroute-cache

    shutdown

    no fair-queue

  !

  interface Serial1

    no ip address

    no ip directed-broadcast

    shutdown

  !

  interface Serial2

    no ip address

    no ip directed-broadcast

    shutdown

  !

  interface Serial3

    no ip address

    no ip directed-broadcast

    shutdown

  !

  interface BRI0

    no ip address

    no ip directed-broadcast

    shutdown

    isdn guard-timer 0 on-expiry accept

  !

  ip local pool default 10.10.10.21 10.10.10.30

  ip classless

  ip route 0.0.0.0 0.0.0.0 10.200.20.1

  no ip http server

  !

  !

  !

  line con 0

  exec-timeout 0 0

  transport input none

  line aux 0

  line vty 0 4

  !

  end

show および debug のアウトプット例

Cisco 7200 (LNS1)
fifi#show debug

  Generic IP:

    IP peer address activity debugging is on

  VPN:

    L2X control packets debugging is on

  PPP:

    PPP authentication debugging is on

    PPP protocol negotiation debugging is on

  fifi#

  22:41:05: L2X: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  22:41:05: L2X: Parse SCCRQ

  22:41:05: L2X: Parse  AVP 2, len 8, flag 0x0x8000 (M)

  22:41:05: L2X: Protocol Ver 256

  22:41:05: L2X: Parse  AVP 3, len 10, flag 0x0x8000 (M)

  22:41:05: L2X: Framing Cap 0x0x3

  22:41:05: L2X: Parse  AVP 4, len 10, flag 0x0x8000 (M)

  22:41:05: L2X: Bearer Cap 0x0x3

  22:41:05: L2X: Parse  AVP 6, len 8, flag 0x0x0 

  22:41:05: L2X: Firmware Ver 0x0x1130

  22:41:05: L2X: Parse  AVP 7, len 8, flag 0x0x8000 (M)

  22:41:05: L2X: Hostname po

  22:41:05: L2X: Parse  AVP 8, len 25, flag 0x0x0 

  22:41:05: L2X: Vendor Name Cisco Systems, Inc.

  22:41:05: L2X: Parse  AVP 9, len 8, flag 0x0x8000 (M)

  22:41:05: L2X: Assigned Tunnel ID 28

  22:41:05: L2X: Parse  AVP 10, len 8, flag 0x0x8000 (M)

  22:41:05: L2X: Rx Window Size 800

  22:41:05: L2X: Parse  AVP 11, len 22, flag 0x0x8000 (M)

  22:41:05: L2X: Chlng 6D85457377BB75408695B0FE8E002567

  22:41:05: L2X: No missing AVPs in SCCRQ

  22:41:05: L2X: I SCCRQ, flg TLF, ver 2, len 127, tnl 0, cl 0, ns 0, nr 0

   contiguous pak, size 127

           C8 02 00 7F 00 00 00 00 00 00 00 00 80 08 00 00

           00 00 00 01 80 08 00 00 00 02 01 00 80 0A 00 00

           00 03 00 00 00 03 80 0A 00 00 00 04 00 00 00 ...

  22:41:05: L2TP: I SCCRQ from po tnl 28

  22:41:05: Tnl 15 L2TP: O SCCRP  to po tnlid 28

  22:41:05: Tnl 15 L2TP: O SCCRP, flg TLF, ver 2, len 151, tnl 28, cl 0, ns 0, nr 1

  22:41:05: contiguous buffer, size 151

           C8 02 00 97 00 1C 00 00 00 00 00 01 80 08 00 00

           00 00 00 02 80 08 00 00 00 02 01 00 80 0A 00 00

           00 03 00 00 00 03 80 0A 00 00 00 04 00 00 00 ...

  22:41:05: Tnl 15 L2TP: Clean Queue packet 0

  22:41:05: Tnl 15 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  22:41:05: Tnl 15 L2TP: Parse SCCCN

  22:41:05: Tnl 15 L2TP: Parse  AVP 13, len 22, flag 0x0x8000 (M)

  22:41:05: Tnl 15 L2TP: Chlng Resp 562FD0C9AA8B5698AE90EB2921CB883D

  22:41:05: Tnl 15 L2TP: No missing AVPs in SCCCN

  22:41:05: Tnl 15 L2TP: I SCCCN, flg TLF, ver 2, len 42, tnl 15, cl 0, ns 1, nr 1

   contiguous pak, size 42

           C8 02 00 2A 00 0F 00 00 00 01 00 01 80 08 00 00

           00 00 00 03 80 16 00 00 00 0D 56 2F D0 C9 AA 8B

           56 98 AE 90 EB 29 21 CB 88 3D

  22:41:05: Tnl 15 L2TP: O ZLB ctrl ack, flg TLF, ver 2, len 12, tnl 28, cl 0, ns 1, nr 2

  22:41:05: contiguous buffer, size 12

           C8 02 00 0C 00 1C 00 00 00 01 00 02

  22:41:05: Tnl 15 L2TP: I SCCCN from po tnl 28

  22:41:05: Tnl 15 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  22:41:05: Tnl 15 L2TP: Parse ICRQ

  22:41:05: Tnl 15 L2TP: Parse  AVP 14, len 8, flag 0x0x8000 (M)

  22:41:05: Tnl 15 L2TP: Assigned Call ID 29

  22:41:05: Tnl 15 L2TP: Parse  AVP 15, len 10, flag 0x0x8000 (M)

  22:41:05: Tnl 15 L2TP: Serial Number 

  22:41:05: Tnl 15 L2TP: Parse  AVP 18, len 10, flag 0x0x8000 (M)

  22:41:05: Tnl 15 L2TP: Bearer Type 1

  22:41:05: Tnl 15 L2TP: Parse  AVP 21, len 9, flag 0x0x8000 (M)

  22:41:05: Tnl 15 L2TP: Dialed Number 215

  22:41:05: Tnl 15 L2TP: Parse  AVP 22, len 10, flag 0x0x8000 (M)

  22:41:05: Tnl 15 L2TP: Dialing Number 6101

  22:41:05: Tnl 15 L2TP: Parse Cisco AVP 100, len 15, flag 0x0x0 

  22:41:05: Tnl 15 L2TP: Client NAS Port Serial0:2

  22:41:05: Tnl 15 L2TP: No missing AVPs in ICRQ

  22:41:05: Tnl 15 L2TP: I ICRQ, flg TLF, ver 2, len 82, tnl 15, cl 0, ns 2, nr 1

   contiguous pak, size 82

           C8 02 00 52 00 0F 00 00 00 02 00 01 80 08 00 00

           00 00 00 0A 80 08 00 00 00 0E 00 1D 80 0A 00 00

           00 0F 00 00 00 1D 80 0A 00 00 00 12 00 00 00 ...

  22:41:05: Tnl 15 L2TP: I ICRQ from po tnl 28

  22:41:05: Tnl/Cl 15/21 L2TP: O ICRP to po 28/29

  22:41:05: Tnl/Cl 15/21 L2TP: O ICRP, flg TLF, ver 2, len 28, tnl 28, cl 29, ns 1, nr 3

  22:41:05: contiguous buffer, size 28

           C8 02 00 1C 00 1C 00 1D 00 01 00 03 80 08 00 00

           00 00 00 0B 80 08 00 00 00 0E 00 15

  22:41:05: Tnl 15 L2TP: Clean Queue packet 1

  22:41:05: Tnl/Cl 15/21 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  22:41:05: Tnl/Cl 15/21 L2TP: Parse ICCN

  22:41:05: Tnl/Cl 15/21 L2TP: Parse  AVP 24, len 10, flag 0x0x8000 (M)

  22:41:05: Tnl/Cl 15/21 L2TP: Connect Speed 64000

  22:41:05: Tnl/Cl 15/21 L2TP: Parse  AVP 38, len 10, flag 0x0x0 

  22:41:05: Tnl/Cl 15/21 L2TP: Rx Speed 64000

  22:41:05: Tnl/Cl 15/21 L2TP: Parse  AVP 19, len 10, flag 0x0x8000 (M)

  22:41:05: Tnl/Cl 15/21 L2TP: Framing Type 2

  22:41:05: Tnl/Cl 15/21 L2TP: Parse  AVP 27, len 17, flag 0x0x0 

  22:41:05: Tnl/Cl 15/21 L2TP: Last Sent LCPREQ 0305C22305050614146035

  22:41:05: Tnl/Cl 15/21 L2TP: Parse  AVP 28, len 12, flag 0x0x0 

  22:41:05: Tnl/Cl 15/21 L2TP: Last Rx LCPREQ 050615A9BD55

  22:41:05: Tnl/Cl 15/21 L2TP: Parse  AVP 31, len 22, flag 0x0x0 

  22:41:05: Tnl/Cl 15/21 L2TP: Proxy Auth Chal DEBDE17A2431F601F6122C976EDB78BA

  22:41:05: Tnl/Cl 15/21 L2TP: Parse  AVP 32, len 8, flag 0x0x0 

  22:41:05: Tnl/Cl 15/21 L2TP: Proxy Auth ID 2

  22:41:05: Tnl/Cl 15/21 L2TP: Parse  AVP 30, len 19, flag 0x0x0 

  22:41:05: Tnl/Cl 15/21 L2TP: Proxy Auth Name joe@cisco.com

  22:41:05: Tnl/Cl 15/21 L2TP: Parse  AVP 33, len 22, flag 0x0x8000 (M)

  22:41:05: Tnl/Cl 15/21 L2TP: Proxy Auth Resp 5EA6819A8952F01551993B451B6F8082

  22:41:05: Tnl/Cl 15/21 L2TP: Parse  AVP 29, len 8, flag 0x0x0 

  22:41:05: Tnl/Cl 15/21 L2TP: Proxy Auth Type 2

  22:41:05: Tnl/Cl 15/21 L2TP: No missing AVPs in ICCN

  22:41:05: Tnl/Cl 15/21 L2TP: I ICCN, flg TLF, ver 2, len 158, tnl 15, cl 21, ns 3, nr 2

   contiguous pak, size 158

           C8 02 00 9E 00 0F 00 15 00 03 00 02 80 08 00 00

           00 00 00 0C 80 0A 00 00 00 18 00 00 FA 00 00 0A

           00 00 00 26 00 00 FA 00 80 0A 00 00 00 13 00 ...

  22:41:05: Tnl/Cl 15/21 L2TP: O ZLB ctrl ack, flg TLF, ver 2, len 12, tnl 28, cl 29, ns 2, nr 4

  22:41:05: contiguous buffer, size 12

           C8 02 00 0C 00 1C 00 1D 00 02 00 04

  22:41:05: Tnl/Cl 15/21 L2TP: I ICCN from po tnl 28, cl 29

  22:41:05: Vi2 PPP: Phase is DOWN, Setup

  22:41:05: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up

  22:41:05: Vi2 PPP: Treating connection as a dedicated line

  22:41:05: Vi2 PPP: Phase is ESTABLISHING, Active Open

  22:41:05: Vi2 LCP: O CONFREQ [Closed] id 1 len 26

  22:41:05: Vi2 LCP:    AuthProto CHAP (0x0305C22305)

  22:41:05: Vi2 LCP:    MagicNumber 0xE5DC5CE3 (0x0506E5DC5CE3)

  22:41:05: Vi2 LCP:    MRRU 1524 (0x110405F4)

  22:41:05: Vi2 LCP:    EndpointDisc 1 Local (0x13070166696669)

  22:41:05: Vi2 PPP: Treating connection as a dedicated line

  22:41:05: Vi2 LCP: I FORCED CONFREQ len 11

  22:41:05: Vi2 LCP:    AuthProto CHAP (0x0305C22305)

  22:41:05: Vi2 LCP:    MagicNumber 0x14146035 (0x050614146035)

  22:41:05: Vi2 PPP: Phase is AUTHENTICATING, by this end

  22:41:05: Vi2 CHAP: O CHALLENGE id 3 len 25 from "fifi"

  22:41:05: Vi2 CHAP: I RESPONSE id 2 len 34 from "joe@cisco.com"

  22:41:05: Vi2 PPP: Phase is FORWARDING

  22:41:05: Tnl 16 L2TP: O SCCRQ 

  22:41:05: Tnl 16 L2TP: O SCCRQ, flg TLF, ver 2, len 129, tnl 0, cl 0, ns 0, nr 0

  22:41:05: contiguous buffer, size 129

           C8 02 00 81 00 00 00 00 00 00 00 00 80 08 00 00

           00 00 00 01 80 08 00 00 00 02 01 00 80 0A 00 00

           00 03 00 00 00 03 80 0A 00 00 00 04 00 00 00 ...

  22:41:05: Tnl 16 L2TP: Clean Queue packet 0

  22:41:05: Tnl 16 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  22:41:05: Tnl 16 L2TP: Parse SCCRP

  22:41:05: Tnl 16 L2TP: Parse  AVP 2, len 8, flag 0x0x8000 (M)

  22:41:05: Tnl 16 L2TP: Protocol Ver 256

  22:41:05: Tnl 16 L2TP: Parse  AVP 3, len 10, flag 0x0x8000 (M)

  22:41:05: Tnl 16 L2TP: Framing Cap 0x0x3

  22:41:05: Tnl 16 L2TP: Parse  AVP 4, len 10, flag 0x0x8000 (M)

  22:41:05: Tnl 16 L2TP: Bearer Cap 0x0x3

  22:41:05: Tnl 16 L2TP: Parse  AVP 6, len 8, flag 0x0x0 

  22:41:05: Tnl 16 L2TP: Firmware Ver 0x0x1120

  22:41:05: Tnl 16 L2TP: Parse  AVP 7, len 11, flag 0x0x8000 (M)

  22:41:05: Tnl 16 L2TP: Hostname romeo

  22:41:05: Tnl 16 L2TP: Parse  AVP 8, len 25, flag 0x0x0 

  22:41:05: Tnl 16 L2TP: Vendor Name Cisco Systems, Inc.

  22:41:05: Tnl 16 L2TP: Parse  AVP 9, len 8, flag 0x0x8000 (M)

  22:41:05: Tnl 16 L2TP: Assigned Tunnel ID 15

  22:41:05: Tnl 16 L2TP: Parse  AVP 10, len 8, flag 0x0x8000 (M)

  22:41:05: Tnl 16 L2TP: Rx Window Size 300

  22:41:05: Tnl 16 L2TP: Parse  AVP 11, len 22, flag 0x0x8000 (M)

  22:41:05: Tnl 16 L2TP: Chlng EB437DE2E08B5BDA953B9AFA993AA494

  22:41:05: Tnl 16 L2TP: Parse  AVP 13, len 22, flag 0x0x8000 (M)

  22:41:05: Tnl 16 L2TP: Chlng Resp D6E660153A8ED711086915EB24841301

  22:41:05: Tnl 16 L2TP: No missing AVPs in SCCRP

  22:41:05: Tnl 16 L2TP: I SCCRP, flg TLF, ver 2, len 152, tnl 16, cl 0, ns 0, nr 1

   contiguous pak, size 152

           C8 02 00 98 00 10 00 00 00 00 00 01 80 08 00 00

           00 00 00 02 80 08 00 00 00 02 01 00 80 0A 00 00

           00 03 00 00 00 03 80 0A 00 00 00 04 00 00 00 ...

  22:41:05: Tnl 16 L2TP: I SCCRP from romeo

  22:41:05: Tnl 16 L2TP: O SCCCN  to romeo tnlid 15

  22:41:05: Tnl 16 L2TP: O SCCCN, flg TLF, ver 2, len 42, tnl 15, cl 0, ns 1, nr 1

  22:41:05: contiguous buffer, size 42

           C8 02 00 2A 00 0F 00 00 00 01 00 01 80 08 00 00

           00 00 00 03 80 16 00 00 00 0D 55 E9 6B 43 08 4A

           AE 79 19 05 21 46 62 1A 37 DA

  22:41:05: Vi2 Tnl/Cl 16/22 L2TP: O ICRQ to romeo 15/0

  22:41:05: Vi2 Tnl/Cl 16/22 L2TP: O ICRQ, flg TLF, ver 2, len 96, tnl 15, cl 0, ns 2, nr 1

  22:41:05: contiguous buffer, size 96

           C8 02 00 60 00 0F 00 00 00 02 00 01 80 08 00 00

           00 00 00 0A 80 08 00 00 00 0E 00 16 80 0A 00 00

           00 0F 00 00 00 05 80 0A 00 00 00 12 00 00 00 ...

  22:41:05: Tnl 16 L2TP: Clean Queue packet 1

  22:41:05: Tnl 16 L2TP: Clean Queue packet 2

  22:41:05: Tnl 16 L2TP: I ZLB ctrl ack, flg TLF, ver 2, len 12, tnl 16, cl 0, ns 1, nr 2

  22:41:05: Tnl 16 L2TP: Clean Queue packet 2

  22:41:05: Vi2 Tnl/Cl 16/22 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  22:41:05: Vi2 Tnl/Cl 16/22 L2TP: Parse ICRP

  22:41:05: Vi2 Tnl/Cl 16/22 L2TP: Parse  AVP 14, len 8, flag 0x0x8000 (M)

  22:41:05: Vi2 Tnl/Cl 16/22 L2TP: Assigned Call ID 17

  22:41:05: Vi2 Tnl/Cl 16/22 L2TP: No missing AVPs in ICRP

  22:41:05: Vi2 Tnl/Cl 16/22 L2TP: I ICRP, flg TLF, ver 2, len 28, tnl 16, cl 22, ns 1, nr 3

   contiguous pak, size 28

           C8 02 00 1C 00 10 00 16 00 01 00 03 80 08 00 00

           00 00 00 0B 80 08 00 00 00 0E 00 11

  22:41:05: Vi2 Tnl/Cl 16/22 L2TP: O ICCN to romeo 15/17

  22:41:05: Vi2 Tnl/Cl 16/22 L2TP: O ICCN, flg TLF, ver 2, len 158, tnl 15, cl 17, ns 3, nr 2

  22:41:05: contiguous buffer, size 158

           C8 02 00 9E 00 0F 00 11 00 03 00 02 80 08 00 00

           00 00 00 0C 80 0A 00 00 00 18 00 00 FA 00 00 0A

           00 00 00 26 00 00 FA 00 80 0A 00 00 00 13 00 ...

  22:41:05: Tnl 16 L2TP: Clean Queue packet 3

  22:41:05: Tnl 16 L2TP: I ZLB ctrl ack, flg TLF, ver 2, len 12, tnl 16, cl 22, ns 2, nr 4

  22:41:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up

  22:41:08: Vi2 Tnl/Cl 16/22 L2TP: I FS OUT from LAC

  22:41:08: Vi2 Tnl/Cl 15/21 L2TP: O FS failed

  22:41:08: Vi2 Tnl/Cl 16/22 L2TP: I FS OUT from LAC

  22:41:08: Vi2 Tnl/Cl 15/21 L2TP: O FS failed

  22:41:08: Vi2 Tnl/Cl 16/22 L2TP: O FS failed

  22:41:08: Vi2 Tnl/Cl 15/21 L2TP: I FS OUT from LNS

  22:41:08: Vi2 Tnl/Cl 15/21 L2TP: I FS OUT from LNS

  22:41:08: Vi2 Tnl/Cl 15/21 L2TP: I FS OUT from LNS

  22:41:08: Vi2 Tnl/Cl 16/22 L2TP: I FS OUT from LAC

  22:41:08: Vi2 Tnl/Cl 15/21 L2TP: O FS failed

  22:41:08: Vi2 Tnl/Cl 16/22 L2TP: I FS OUT from LAC

  22:41:08: Vi2 Tnl/Cl 15/21 L2TP: O FS failed

  22:41:08: Vi2 Tnl/Cl 15/21 L2TP: I FS OUT from LNS

  22:41:08: Vi2 Tnl/Cl 16/22 L2TP: I FS OUT from LAC

  22:41:08: Vi2 Tnl/Cl 15/21 L2TP: O FS failed

  22:41:10: Vi2 Tnl/Cl 15/21 L2TP: I FS OUT from LNS

  22:41:10: Vi2 Tnl/Cl 16/22 L2TP: I FS OUT from LAC

  22:41:10: Vi2 Tnl/Cl 15/21 L2TP: O FS failed

  22:41:11: Vi2 Tnl/Cl 15/21 L2TP: I FS OUT from LNS

  22:41:11: Vi2 Tnl/Cl 16/22 L2TP: I FS OUT from LAC

  22:41:11: Vi2 Tnl/Cl 15/21 L2TP: O FS failed

  22:41:11: Tnl 15 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  22:41:11: Tnl 15 L2TP: Parse ICRQ

  22:41:11: Tnl 15 L2TP: Parse  AVP 14, len 8, flag 0x0x8000 (M)

  22:41:11: Tnl 15 L2TP: Assigned Call ID 30

  22:41:11: Tnl 15 L2TP: Parse  AVP 15, len 10, flag 0x0x8000 (M)

  22:41:11: Tnl 15 L2TP: Serial Number 

  22:41:11: Tnl 15 L2TP: Parse  AVP 18, len 10, flag 0x0x8000 (M)

  22:41:11: Tnl 15 L2TP: Bearer Type 1

  22:41:11: Tnl 15 L2TP: Parse  AVP 21, len 9, flag 0x0x8000 (M)

  22:41:11: Tnl 15 L2TP: Dialed Number 215

  22:41:11: Tnl 15 L2TP: Parse  AVP 22, len 10, flag 0x0x8000 (M)

  22:41:11: Tnl 15 L2TP: Dialing Number 6101

  22:41:11: Tnl 15 L2TP: Parse Cisco AVP 100, len 15, flag 0x0x0 

  22:41:11: Tnl 15 L2TP: Client NAS Port Serial0:3

  22:41:11: Tnl 15 L2TP: No missing AVPs in ICRQ

  22:41:11: Tnl 15 L2TP: I ICRQ, flg TLF, ver 2, len 82, tnl 15, cl 0, ns 4, nr 2

   contiguous pak, size 82

           C8 02 00 52 00 0F 00 00 00 04 00 02 80 08 00 00

           00 00 00 0A 80 08 00 00 00 0E 00 1E 80 0A 00 00

           00 0F 00 00 00 1E 80 0A 00 00 00 12 00 00 00 ...

  22:41:11: Tnl 15 L2TP: I ICRQ from po tnl 28

  22:41:11: Tnl/Cl 15/23 L2TP: O ICRP to po 28/30

  22:41:11: Tnl/Cl 15/23 L2TP: O ICRP, flg TLF, ver 2, len 28, tnl 28, cl 30, ns 2, nr 5

  22:41:11: contiguous buffer, size 28

           C8 02 00 1C 00 1C 00 1E 00 02 00 05 80 08 00 00

           00 00 00 0B 80 08 00 00 00 0E 00 17

  22:41:11: Tnl 15 L2TP: Clean Queue packet 2

  22:41:11: Tnl/Cl 15/23 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  22:41:11: Tnl/Cl 15/23 L2TP: Parse ICCN

  22:41:11: Tnl/Cl 15/23 L2TP: Parse  AVP 24, len 10, flag 0x0x8000 (M)

  22:41:11: Tnl/Cl 15/23 L2TP: Connect Speed 64000

  22:41:11: Tnl/Cl 15/23 L2TP: Parse  AVP 38, len 10, flag 0x0x0 

  22:41:11: Tnl/Cl 15/23 L2TP: Rx Speed 64000

  22:41:11: Tnl/Cl 15/23 L2TP: Parse  AVP 19, len 10, flag 0x0x8000 (M)

  22:41:11: Tnl/Cl 15/23 L2TP: Framing Type 2

  22:41:11: Tnl/Cl 15/23 L2TP: Parse  AVP 27, len 17, flag 0x0x0 

  22:41:11: Tnl/Cl 15/23 L2TP: Last Sent LCPREQ 0305C22305050614147845

  22:41:11: Tnl/Cl 15/23 L2TP: Parse  AVP 28, len 12, flag 0x0x0 

  22:41:11: Tnl/Cl 15/23 L2TP: Last Rx LCPREQ 050615A9D55E

  22:41:11: Tnl/Cl 15/23 L2TP: Parse  AVP 31, len 22, flag 0x0x0 

  22:41:11: Tnl/Cl 15/23 L2TP: Proxy Auth Chal 5A6592DC17F8258DF6122C97D9CAD890

  22:41:11: Tnl/Cl 15/23 L2TP: Parse  AVP 32, len 8, flag 0x0x0 

  22:41:11: Tnl/Cl 15/23 L2TP: Proxy Auth ID 2

  22:41:11: Tnl/Cl 15/23 L2TP: Parse  AVP 30, len 19, flag 0x0x0 

  22:41:11: Tnl/Cl 15/23 L2TP: Proxy Auth Name joe@cisco.com

  22:41:11: Tnl/Cl 15/23 L2TP: Parse  AVP 33, len 22, flag 0x0x8000 (M)

  22:41:11: Tnl/Cl 15/23 L2TP: Proxy Auth Resp 619A19E7A86CCAC9EA7D9A7E2DFD5D7C

  22:41:11: Tnl/Cl 15/23 L2TP: Parse  AVP 29, len 8, flag 0x0x0 

  22:41:11: Tnl/Cl 15/23 L2TP: Proxy Auth Type 2

  22:41:11: Tnl/Cl 15/23 L2TP: No missing AVPs in ICCN

  22:41:11: Tnl/Cl 15/23 L2TP: I ICCN, flg TLF, ver 2, len 158, tnl 15, cl 23, ns 5, nr 3

   contiguous pak, size 158

           C8 02 00 9E 00 0F 00 17 00 05 00 03 80 08 00 00

           00 00 00 0C 80 0A 00 00 00 18 00 00 FA 00 00 0A

           00 00 00 26 00 00 FA 00 80 0A 00 00 00 13 00 ...

  22:41:11: Tnl/Cl 15/23 L2TP: O ZLB ctrl ack, flg TLF, ver 2, len 12, tnl 28, cl 30, ns 3, nr 6

  22:41:11: contiguous buffer, size 12

           C8 02 00 0C 00 1C 00 1E 00 03 00 06

  22:41:11: Tnl/Cl 15/23 L2TP: I ICCN from po tnl 28, cl 30

  22:41:11: Vi1 PPP: Phase is DOWN, Setup

  22:41:11: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

  22:41:11: Vi1 PPP: Treating connection as a dedicated line

  22:41:11: Vi1 PPP: Phase is ESTABLISHING, Active Open

  22:41:11: Vi1 LCP: O CONFREQ [Closed] id 1 len 26

  22:41:11: Vi1 LCP:    AuthProto CHAP (0x0305C22305)

  22:41:11: Vi1 LCP:    MagicNumber 0xE5DC74DE (0x0506E5DC74DE)

  22:41:11: Vi1 LCP:    MRRU 1524 (0x110405F4)

  22:41:11: Vi1 LCP:    EndpointDisc 1 Local (0x13070166696669)

  22:41:11: Vi1 PPP: Treating connection as a dedicated line

  22:41:11: Vi1 LCP: I FORCED CONFREQ len 11

  22:41:11: Vi1 LCP:    AuthProto CHAP (0x0305C22305)

  22:41:11: Vi1 LCP:    MagicNumber 0x14147845 (0x050614147845)

  22:41:11: Vi1 PPP: Phase is AUTHENTICATING, by this end

  22:41:11: Vi1 CHAP: O CHALLENGE id 3 len 25 from "fifi"

  22:41:11: Vi1 CHAP: I RESPONSE id 2 len 34 from "joe@cisco.com"

  22:41:11: Vi1 PPP: Phase is FORWARDING

  22:41:11: Vi1 Tnl/Cl 16/24 L2TP: O ICRQ to romeo 15/0

  22:41:11: Vi1 Tnl/Cl 16/24 L2TP: O ICRQ, flg TLF, ver 2, len 96, tnl 15, cl 0, ns 4, nr 2

  22:41:11: contiguous buffer, size 96

           C8 02 00 60 00 0F 00 00 00 04 00 02 80 08 00 00

           00 00 00 0A 80 08 00 00 00 0E 00 18 80 0A 00 00

           00 0F 00 00 00 06 80 0A 00 00 00 12 00 00 00 ...

  22:41:11: Vi2 Tnl/Cl 15/21 L2TP: I FS OUT from LNS

  22:41:11: Tnl 16 L2TP: Clean Queue packet 4

  22:41:11: Vi1 Tnl/Cl 16/24 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  22:41:11: Vi1 Tnl/Cl 16/24 L2TP: Parse ICRP

  22:41:11: Vi1 Tnl/Cl 16/24 L2TP: Parse  AVP 14, len 8, flag 0x0x8000 (M)

  22:41:11: Vi1 Tnl/Cl 16/24 L2TP: Assigned Call ID 18

  22:41:11: Vi1 Tnl/Cl 16/24 L2TP: No missing AVPs in ICRP

  22:41:11: Vi1 Tnl/Cl 16/24 L2TP: I ICRP, flg TLF, ver 2, len 28, tnl 16, cl 24, ns 2, nr 5

   contiguous pak, size 28

           C8 02 00 1C 00 10 00 18 00 02 00 05 80 08 00 00

           00 00 00 0B 80 08 00 00 00 0E 00 12

  22:41:11: Vi1 Tnl/Cl 16/24 L2TP: O ICCN to romeo 15/18

  22:41:11: Vi1 Tnl/Cl 16/24 L2TP: O ICCN, flg TLF, ver 2, len 158, tnl 15, cl 18, ns 5, nr 3

  22:41:11: contiguous buffer, size 158

           C8 02 00 9E 00 0F 00 12 00 05 00 03 80 08 00 00

           00 00 00 0C 80 0A 00 00 00 18 00 00 FA 00 00 0A

           00 00 00 26 00 00 FA 00 80 0A 00 00 00 13 00 ...

  22:41:11: Vi2 Tnl/Cl 16/22 L2TP: I FS OUT from LAC

  22:41:11: Vi2 Tnl/Cl 15/21 L2TP: O FS failed

  22:41:11: Tnl 16 L2TP: Clean Queue packet 5

  22:41:11: Tnl 16 L2TP: I ZLB ctrl ack, flg TLF, ver 2, len 12, tnl 16, cl 24, ns 3, nr 6

  22:41:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
fifi#show user

      Line       User       Host(s)              Idle       Location

  *  0 con 0                idle                 00:00:00   

    Vi1          joe@cisco. Virtual PPP (L2TP  ) 00:00:42 

    Vi2          joe@cisco. Virtual PPP (L2TP  ) 00:00:48 

  

    Interface  User      Mode                     Idle Peer Address

  

  fifi#show ip route

  Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

         D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

         N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

         E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

         i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

         * - candidate default, U - per-user static route, o - ODR

         P - periodic downloaded static route

  

  Gateway of last resort is 10.200.20.1 to network 0.0.0.0

  

       10.0.0.0/21 is subnetted, 1 subnets

  C       10.200.16.0 is directly connected, Ethernet1/0

  S*   0.0.0.0/0 [1/0] via 10.200.20.1

  fifi#  

Cisco 2500 (LNS2)
romeo#show debug

  Generic IP:

    IP peer address activity debugging is on

  VPN:

    L2X control packets debugging is on

  PPP:

    PPP authentication debugging is on

    PPP protocol negotiation debugging is on

  romeo#

  16:54:05: L2X: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  16:54:05: L2X: Parse SCCRQ

  16:54:05: L2X: Parse  AVP 2, len 8, flag 0x0x8000 (M)

  16:54:05: L2X: Protocol Ver 256

  16:54:05: L2X: Parse  AVP 3, len 10, flag 0x0x8000 (M)

  16:54:05: L2X: Framing Cap 0x0x3

  16:54:05: L2X: Parse  AVP 4, len 10, flag 0x0x8000 (M)

  16:54:05: L2X: Bearer Cap 0x0x3

  16:54:05: L2X: Parse  AVP 6, len 8, flag 0x0x0 

  16:54:05: L2X: Firmware Ver 0x0x1130

  16:54:05: L2X: Parse  AVP 7, len 10, flag 0x0x8000 (M)

  16:54:05: L2X: Hostname fifi

  16:54:05: L2X: Parse  AVP 8, len 25, flag 0x0x0 

  16:54:05: L2X: Vendor Name Cisco Systems, Inc.

  16:54:05: L2X: Parse  AVP 9, len 8, flag 0x0x8000 (M)

  16:54:05: L2X: Assigned Tunnel ID 16

  16:54:05: L2X: Parse  AVP 10, len 8, flag 0x0x8000 (M)

  16:54:05: L2X: Rx Window Size 3000

  16:54:05: L2X: Parse  AVP 11, len 22, flag 0x0x8000 (M)

  16:54:05: L2X: Chlng 15457FDB391D342211CAB71E84D08BB9

  16:54:05: L2X: No missing AVPs in SCCRQ

  16:54:05: L2X: I SCCRQ, flg TLF, ver 2, len 129, tnl 0, cl 0, ns 0, nr 0

   contiguous pak, size 129

           C8 02 00 81 00 00 00 00 00 00 00 00 80 08 00 00

           00 00 00 01 80 08 00 00 00 02 01 00 80 0A 00 00

           00 03 00 00 00 03 80 0A 00 00 00 04 00 00 00 ...

  16:54:05: L2TP: I SCCRQ from fifi tnl 16

  16:54:05: Tnl 15 L2TP: O SCCRP  to fifi tnlid 16

  16:54:05: Tnl 15 L2TP: O SCCRP, flg TLF, ver 2, len 152, tnl 16, cl 0, ns 0, nr 1

  16:54:05: contiguous buffer, size 152

           C8 02 00 98 00 10 00 00 00 00 00 01 80 08 00 00

           00 00 00 02 80 08 00 00 00 02 01 00 80 0A 00 00

           00 03 00 00 00 03 80 0A 00 00 00 04 00 00 00 ...

  16:54:05: Tnl 15 L2TP: Clean Queue packet 0

  16:54:05: Tnl 15 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  16:54:05: Tnl 15 L2TP: Parse SCCCN

  16:54:05: Tnl 15 L2TP: Parse  AVP 13, len 22, flag 0x0x8000 (M)

  16:54:05: Tnl 15 L2TP: Chlng Resp 55E96B43084AAE7919052146621A37DA

  16:54:05: Tnl 15 L2TP: No missing AVPs in SCCCN

  16:54:05: Tnl 15 L2TP: I SCCCN, flg TLF, ver 2, len 42, tnl 15, cl 0, ns 1, nr 1

   contiguous pak, size 42

           C8 02 00 2A 00 0F 00 00 00 01 00 01 80 08 00 00

           00 00 00 03 80 16 00 00 00 0D 55 E9 6B 43 08 4A

           AE 79 19 05 21 46 62 1A 37 DA

  16:54:05: Tnl 15 L2TP: O ZLB ctrl ack, flg TLF, ver 2, len 12, tnl 16, cl 0, ns 1, nr 2

  16:54:05: contiguous buffer, size 12

           C8 02 00 0C 00 10 00 00 00 01 00 02

  16:54:05: Tnl 15 L2TP: I SCCCN from fifi tnl 16

  16:54:05: Tnl 15 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  16:54:05: Tnl 15 L2TP: Parse ICRQ

  16:54:05: Tnl 15 L2TP: Parse  AVP 14, len 8, flag 0x0x8000 (M)

  16:54:05: Tnl 15 L2TP: Assigned Call ID 22

  16:54:05: Tnl 15 L2TP: Parse  AVP 15, len 10, flag 0x0x8000 (M)

  16:54:05: Tnl 15 L2TP: Serial Number 

  16:54:05: Tnl 15 L2TP: Parse  AVP 18, len 10, flag 0x0x8000 (M)

  16:54:05: Tnl 15 L2TP: Bearer Type 1

  16:54:05: Tnl 15 L2TP: Parse  AVP 21, len 9, flag 0x0x8000 (M)

  16:54:05: Tnl 15 L2TP: Dialed Number 215

  16:54:05: Tnl 15 L2TP: Parse  AVP 22, len 10, flag 0x0x8000 (M)

  16:54:05: Tnl 15 L2TP: Dialing Number 6101

  16:54:05: Tnl 15 L2TP: Parse Cisco AVP 100, len 21, flag 0x0x0 

  16:54:05: Tnl 15 L2TP: Client NAS Port Virtual-Access2

  16:54:05: Tnl 15 L2TP: Parse Cisco AVP 101, len 8, flag 0x0x0 

  16:54:05: Tnl 15 L2TP: Hopcount 1

  16:54:05: Tnl 15 L2TP: No missing AVPs in ICRQ

  16:54:05: Tnl 15 L2TP: I ICRQ, flg TLF, ver 2, len 96, tnl 15, cl 0, ns 2, nr 1

   contiguous pak, size 96

           C8 02 00 60 00 0F 00 00 00 02 00 01 80 08 00 00

           00 00 00 0A 80 08 00 00 00 0E 00 16 80 0A 00 00

           00 0F 00 00 00 05 80 0A 00 00 00 12 00 00 00 ...

  16:54:05: Tnl 15 L2TP: I ICRQ from fifi tnl 16

  16:54:05: Tnl/Cl 15/17 L2TP: O ICRP to fifi 16/22

  16:54:05: Tnl/Cl 15/17 L2TP: O ICRP, flg TLF, ver 2, len 28, tnl 16, cl 22, ns 1, nr 3

  16:54:05: contiguous buffer, size 28

           C8 02 00 1C 00 10 00 16 00 01 00 03 80 08 00 00

           00 00 00 0B 80 08 00 00 00 0E 00 11

  16:54:05: Tnl 15 L2TP: Clean Queue packet 1

  16:54:05: Tnl/Cl 15/17 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  16:54:05: Tnl/Cl 15/17 L2TP: Parse ICCN

  16:54:05: Tnl/Cl 15/17 L2TP: Parse  AVP 24, len 10, flag 0x0x8000 (M)

  16:54:05: Tnl/Cl 15/17 L2TP: Connect Speed 64000

  16:54:05: Tnl/Cl 15/17 L2TP: Parse  AVP 38, len 10, flag 0x0x0 

  16:54:05: Tnl/Cl 15/17 L2TP: Rx Speed 64000

  16:54:05: Tnl/Cl 15/17 L2TP: Parse  AVP 19, len 10, flag 0x0x8000 (M)

  16:54:05: Tnl/Cl 15/17 L2TP: Framing Type 2

  16:54:05: Tnl/Cl 15/17 L2TP: Parse  AVP 27, len 17, flag 0x0x0 

  16:54:05: Tnl/Cl 15/17 L2TP: Last Sent LCPREQ 0305C22305050614146035

  16:54:05: Tnl/Cl 15/17 L2TP: Parse  AVP 28, len 12, flag 0x0x0 

  16:54:05: Tnl/Cl 15/17 L2TP: Last Rx LCPREQ 050615A9BD55

  16:54:05: Tnl/Cl 15/17 L2TP: Parse  AVP 31, len 22, flag 0x0x0 

  16:54:05: Tnl/Cl 15/17 L2TP: Proxy Auth Chal DEBDE17A2431F601F6122C976EDB78BA

  16:54:05: Tnl/Cl 15/17 L2TP: Parse  AVP 32, len 8, flag 0x0x0 

  16:54:05: Tnl/Cl 15/17 L2TP: Proxy Auth ID 2

  16:54:05: Tnl/Cl 15/17 L2TP: Parse  AVP 30, len 19, flag 0x0x0 

  16:54:05: Tnl/Cl 15/17 L2TP: Proxy Auth Name joe@cisco.com

  16:54:05: Tnl/Cl 15/17 L2TP: Parse  AVP 33, len 22, flag 0x0x8000 (M)

  16:54:05: Tnl/Cl 15/17 L2TP: Proxy Auth Resp 5EA6819A8952F01551993B451B6F8082

  16:54:05: Tnl/Cl 15/17 L2TP: Parse  AVP 29, len 8, flag 0x0x0 

  16:54:05: Tnl/Cl 15/17 L2TP: Proxy Auth Type 2

  16:54:05: Tnl/Cl 15/17 L2TP: No missing AVPs in ICCN

  16:54:05: Tnl/Cl 15/17 L2TP: I ICCN, flg TLF, ver 2, len 158, tnl 15, cl 17, ns 3, nr 2

   contiguous pak, size 158

           C8 02 00 9E 00 0F 00 11 00 03 00 02 80 08 00 00

           00 00 00 0C 80 0A 00 00 00 18 00 00 FA 00 00 0A

           00 00 00 26 00 00 FA 00 80 0A 00 00 00 13 00 ...

  16:54:05: Tnl/Cl 15/17 L2TP: O ZLB ctrl ack, flg TLF, ver 2, len 12, tnl 16, cl 22, ns 2, nr 4

  16:54:05: contiguous buffer, size 12

           C8 02 00 0C 00 10 00 16 00 02 00 04

  16:54:05: Tnl/Cl 15/17 L2TP: I ICCN from fifi tnl 16, cl 22

  16:54:05: Vi2 PPP: Phase is DOWN, Setup

  16:54:08: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up

  16:54:08: Vi2 PPP: Treating connection as a dedicated line

  16:54:08: Vi2 PPP: Phase is ESTABLISHING, Active Open

  16:54:08: Vi2 LCP: O CONFREQ [Closed] id 1 len 27

  16:54:08: Vi2 LCP:    AuthProto CHAP (0x0305C22305)

  16:54:08: Vi2 LCP:    MagicNumber 0xE3BED965 (0x0506E3BED965)

  16:54:08: Vi2 LCP:    MRRU 1524 (0x110405F4)

  16:54:08: Vi2 LCP:    EndpointDisc 1 Local (0x130801726F6D656F)

  16:54:08: Vi2 PPP: Treating connection as a dedicated line

  16:54:08: Vi2 LCP: I FORCED CONFREQ len 11

  16:54:08: Vi2 LCP:    AuthProto CHAP (0x0305C22305)

  16:54:08: Vi2 LCP:    MagicNumber 0x14146035 (0x050614146035)

  16:54:08: Vi2 PPP: Phase is AUTHENTICATING, by this end

  16:54:08: Vi2 CHAP: O CHALLENGE id 3 len 26 from "romeo"

  16:54:08: Vi2 CHAP: I RESPONSE id 2 len 34 from "joe@cisco.com"

  16:54:08: Vi2 PPP: Phase is FORWARDING

  16:54:08: Vi2 PPP: Phase is AUTHENTICATING

  16:54:08: Vi2 CHAP: O SUCCESS id 2 len 4

  16:54:08: Vi2 PPP: Phase is UP

  16:54:08: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10

  16:54:08: Vi2 IPCP:    Address 10.200.20.36 (0x03060AC81424)

  16:54:09: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4

  16:54:09: Vi2 LCP: O PROTREJ [Open] id 2 len 10 protocol CDPCP (0x820701010004)

  16:54:09: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10

  16:54:09: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000)

  16:54:09: Vi2: Pools to search : default

  16:54:09: Vi2: Pool default returned address = 10.10.10.21

  16:54:09: Vi2 IPCP: Pool returned 10.10.10.21

  16:54:09: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10

  16:54:09: Vi2 IPCP:    Address 10.10.10.21 (0x03060A0A0A15)

  16:54:09: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10

  16:54:09: Vi2 IPCP:    Address 10.200.20.36 (0x03060AC81424)

  16:54:09: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10

  16:54:09: Vi2 IPCP:    Address 10.10.10.21 (0x03060A0A0A15)

  16:54:09: Vi2: ip_get_pool validate address = 10.10.10.21

  16:54:09: Vi2: Pools to search : default

  16:54:09: Vi2: Pool default returned address = 10.10.10.21

  16:54:09: set_ip_peer_addr: Vi2: address = 10.10.10.21 (3) is redundant

  16:54:09: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10

  16:54:09: Vi2 IPCP:    Address 10.10.10.21 (0x03060A0A0A15)

  16:54:09: Vi2 IPCP: State is Open

  16:54:09: Vi2 IPCP: Install route to 10.10.10.21

  16:54:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up

  16:54:10: Vi2 LCP: TIMEout: State Open

  16:54:11: Tnl 15 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  16:54:11: Tnl 15 L2TP: Parse ICRQ

  16:54:11: Tnl 15 L2TP: Parse  AVP 14, len 8, flag 0x0x8000 (M)

  16:54:11: Tnl 15 L2TP: Assigned Call ID 24

  16:54:11: Tnl 15 L2TP: Parse  AVP 15, len 10, flag 0x0x8000 (M)

  16:54:11: Tnl 15 L2TP: Serial Number 

  16:54:11: Tnl 15 L2TP: Parse  AVP 18, len 10, flag 0x0x8000 (M)

  16:54:11: Tnl 15 L2TP: Bearer Type 1

  16:54:11: Tnl 15 L2TP: Parse  AVP 21, len 9, flag 0x0x8000 (M)

  16:54:11: Tnl 15 L2TP: Dialed Number 215

  16:54:11: Tnl 15 L2TP: Parse  AVP 22, len 10, flag 0x0x8000 (M)

  16:54:11: Tnl 15 L2TP: Dialing Number 6101

  16:54:11: Tnl 15 L2TP: Parse Cisco AVP 100, len 21, flag 0x0x0 

  16:54:11: Tnl 15 L2TP: Client NAS Port Virtual-Access1

  16:54:11: Tnl 15 L2TP: Parse Cisco AVP 101, len 8, flag 0x0x0 

  16:54:11: Tnl 15 L2TP: Hopcount 1

  16:54:11: Tnl 15 L2TP: No missing AVPs in ICRQ

  16:54:11: Tnl 15 L2TP: I ICRQ, flg TLF, ver 2, len 96, tnl 15, cl 0, ns 4, nr 2

   contiguous pak, size 96

           C8 02 00 60 00 0F 00 00 00 04 00 02 80 08 00 00

           00 00 00 0A 80 08 00 00 00 0E 00 18 80 0A 00 00

           00 0F 00 00 00 06 80 0A 00 00 00 12 00 00 00 ...

  16:54:11: Tnl 15 L2TP: I ICRQ from fifi tnl 16

  16:54:11: Tnl/Cl 15/18 L2TP: O ICRP to fifi 16/24

  16:54:11: Tnl/Cl 15/18 L2TP: O ICRP, flg TLF, ver 2, len 28, tnl 16, cl 24, ns 2, nr 5

  16:54:11: contiguous buffer, size 28

           C8 02 00 1C 00 10 00 18 00 02 00 05 80 08 00 00

           00 00 00 0B 80 08 00 00 00 0E 00 12

  16:54:11: Tnl 15 L2TP: Clean Queue packet 2

  16:54:11: Tnl/Cl 15/18 L2TP: Parse  AVP 0, len 8, flag 0x0x8000 (M)

  16:54:11: Tnl/Cl 15/18 L2TP: Parse ICCN

  16:54:11: Tnl/Cl 15/18 L2TP: Parse  AVP 24, len 10, flag 0x0x8000 (M)

  16:54:11: Tnl/Cl 15/18 L2TP: Connect Speed 64000

  16:54:11: Tnl/Cl 15/18 L2TP: Parse  AVP 38, len 10, flag 0x0x0 

  16:54:11: Tnl/Cl 15/18 L2TP: Rx Speed 64000

  16:54:11: Tnl/Cl 15/18 L2TP: Parse  AVP 19, len 10, flag 0x0x8000 (M)

  16:54:11: Tnl/Cl 15/18 L2TP: Framing Type 2

  16:54:11: Tnl/Cl 15/18 L2TP: Parse  AVP 27, len 17, flag 0x0x0 

  16:54:11: Tnl/Cl 15/18 L2TP: Last Sent LCPREQ 0305C22305050614147845

  16:54:11: Tnl/Cl 15/18 L2TP: Parse  AVP 28, len 12, flag 0x0x0 

  16:54:11: Tnl/Cl 15/18 L2TP: Last Rx LCPREQ 050615A9D55E

  16:54:11: Tnl/Cl 15/18 L2TP: Parse  AVP 31, len 22, flag 0x0x0 

  16:54:11: Tnl/Cl 15/18 L2TP: Proxy Auth Chal 5A6592DC17F8258DF6122C97D9CAD890

  16:54:11: Tnl/Cl 15/18 L2TP: Parse  AVP 32, len 8, flag 0x0x0 

  16:54:11: Tnl/Cl 15/18 L2TP: Proxy Auth ID 2

  16:54:11: Tnl/Cl 15/18 L2TP: Parse  AVP 30, len 19, flag 0x0x0 

  16:54:11: Tnl/Cl 15/18 L2TP: Proxy Auth Name joe@cisco.com

  16:54:11: Tnl/Cl 15/18 L2TP: Parse  AVP 33, len 22, flag 0x0x8000 (M)

  16:54:11: Tnl/Cl 15/18 L2TP: Proxy Auth Resp 619A19E7A86CCAC9EA7D9A7E2DFD5D7C

  16:54:11: Tnl/Cl 15/18 L2TP: Parse  AVP 29, len 8, flag 0x0x0 

  16:54:11: Tnl/Cl 15/18 L2TP: Proxy Auth Type 2

  16:54:11: Tnl/Cl 15/18 L2TP: No missing AVPs in ICCN

  16:54:11: Tnl/Cl 15/18 L2TP: I ICCN, flg TLF, ver 2, len 158, tnl 15, cl 18, ns 5, nr 3

   contiguous pak, size 158

           C8 02 00 9E 00 0F 00 12 00 05 00 03 80 08 00 00

           00 00 00 0C 80 0A 00 00 00 18 00 00 FA 00 00 0A

           00 00 00 26 00 00 FA 00 80 0A 00 00 00 13 00 ...

  16:54:11: Tnl/Cl 15/18 L2TP: O ZLB ctrl ack, flg TLF, ver 2, len 12, tnl 16, cl 24, ns 3, nr 6

  16:54:11: contiguous buffer, size 12

           C8 02 00 0C 00 10 00 18 00 03 00 06

  16:54:11: Tnl/Cl 15/18 L2TP: I ICCN from fifi tnl 16, cl 24

  16:54:11: Vi1 PPP: Phase is DOWN, Setup

  16:54:14: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

  16:54:14: Vi1 PPP: Treating connection as a dedicated line

  16:54:14: Vi1 PPP: Phase is ESTABLISHING, Active Open

  16:54:14: Vi1 LCP: O CONFREQ [Closed] id 1 len 27

  16:54:14: Vi1 LCP:    AuthProto CHAP (0x0305C22305)

  16:54:14: Vi1 LCP:    MagicNumber 0xE3BEF0CF (0x0506E3BEF0CF)

  16:54:14: Vi1 LCP:    MRRU 1524 (0x110405F4)

  16:54:14: Vi1 LCP:    EndpointDisc 1 Local (0x130801726F6D656F)

  16:54:14: Vi1 PPP: Treating connection as a dedicated line

  16:54:14: Vi1 LCP: I FORCED CONFREQ len 11

  16:54:14: Vi1 LCP:    AuthProto CHAP (0x0305C22305)

  16:54:14: Vi1 LCP:    MagicNumber 0x14147845 (0x050614147845)

  16:54:14: Vi1 PPP: Phase is AUTHENTICATING, by this end

  16:54:14: Vi1 CHAP: O CHALLENGE id 3 len 26 from "romeo"

  16:54:14: Vi1 CHAP: I RESPONSE id 2 len 34 from "joe@cisco.com"

  16:54:14: Vi1 PPP: Phase is FORWARDING

  16:54:14: Vi1 PPP: Phase is AUTHENTICATING

  16:54:14: Vi1 CHAP: O SUCCESS id 2 len 4

  16:54:14: Vi1 PPP: Phase is UP

  16:54:14: Vi1 IPCP: O CONFREQ [Not negotiated] id 1 len 10

  16:54:14: Vi1 IPCP:    Address 10.200.20.36 (0x03060AC81424)

  16:54:15: Vi1 CDPCP: I CONFREQ [Not negotiated] id 1 len 4

  16:54:15: Vi1 LCP: O PROTREJ [Open] id 2 len 10 protocol CDPCP (0x820701010004)

  16:54:15: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10

  16:54:15: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)

  16:54:15: Vi1: Pools to search : default

  16:54:15: Vi1: Pool default returned address = 10.10.10.22

  16:54:15: Vi1 IPCP: Pool returned 10.10.10.22

  16:54:15: Vi1 IPCP: O CONFNAK [REQsent] id 1 len 10

  16:54:15: Vi1 IPCP:    Address 10.10.10.22 (0x03060A0A0A16)

  16:54:15: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10

  16:54:15: Vi1 IPCP:    Address 10.200.20.36 (0x03060AC81424)

  16:54:15: Vi1 IPCP: I CONFREQ [ACKrcvd] id 2 len 10

  16:54:15: Vi1 IPCP:    Address 10.10.10.22 (0x03060A0A0A16)

  16:54:15: Vi1: ip_get_pool validate address = 10.10.10.22

  16:54:15: Vi1: Pools to search : default

  16:54:15: Vi1: Pool default returned address = 10.10.10.22

  16:54:15: set_ip_peer_addr: Vi1: address = 10.10.10.22 (3) is redundant

  16:54:15: Vi1 IPCP: O CONFACK [ACKrcvd] id 2 len 10

  16:54:15: Vi1 IPCP:    Address 10.10.10.22 (0x03060A0A0A16)

  16:54:15: Vi1 IPCP: State is Open

  16:54:15: Vi1 IPCP: Install route to 10.10.10.22

  16:54:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
romeo#show user

      Line       User       Host(s)              Idle       Location

  *  0 con 0                idle                 00:00:00   

    Vi1          joe@cisco. Virtual PPP (L2TP  ) 00:00:06 

    Vi2          joe@cisco. Virtual PPP (L2TP  ) 00:00:06 

  

    Interface  User      Mode                     Idle Peer Address

  

  romeo#show ip route

  Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

         D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

         N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

         E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

         i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

         * - candidate default, U - per-user static route, o - ODR

         P - periodic downloaded static route

  

  Gateway of last resort is 10.200.20.1 to network 0.0.0.0

  

       10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

  C       10.10.10.22/32 is directly connected, Virtual-Access1

  C       10.10.10.21/32 is directly connected, Virtual-Access2

  C       10.200.16.0/21 is directly connected, Ethernet0

  S*   0.0.0.0/0 [1/0] via 10.200.20.1

  romeo#  

debug および show コマンド

  • debug vpdn l2x-packet - トンネルやセッションの作成の際、NAS/LAC と HGW/LNS との間のダイアログを表示します。

  • debug ppp negotiation - クライアントが PPP ネゴシエーションをパスしているかどうかを表示します。これにより、ネゴシエートされているオプション(コールバックや MLP など)やプロトコル(IP や IPXなど)を参照できます。

  • debug ppp authentication - クライアントが認証をパスしているかどうかを表示します。CHAP(Challenge Handshake Authentication Protocol)や PAP(Password Authentication Protocol)をカバーします。

  • debug sgbp events - Multichassis や Multilink に関する詳細を表示します(SGBP のビッディングなど)。

上記の debug コマンドを使用する前に、『デバッグ コマンドに関する重要な情報』を参照してください。


関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 9497