ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

Cisco 3640 BRI に対するモデム接続の構成

2002 年 3 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 9 月 9 日) | フィードバック

目次


概要

この設定は、V.90 プロトコルを使用してアナログ ダイヤルアップ モデムでネットワークに接続するリモート ユーザ(一般家庭のユーザや営業担当者など)をサポートします。PC とアナログ モデムを使用して、ユーザはダイヤルアップ PPP を介して Cisco 3640 ルータ上の Basic Rate Interface(BRI)に接続します。BRI は高速のモデム接続を提供し、Primary Rate Interface(PRI; 一次群速度インターフェイス)よりも低コストです。

:BRI 上のチャネルに制限があるため、同時に 2 人の非同期ユーザしか 1 つの BRI に接続できません。

ハードウェアとソフトウェアのバージョン

この設定は、次のソフトウェアとハードウェアのバージョンを使用して開発およびテストされました。

  • Cisco 3640
  • Cisco BRI ネットワーク モジュール(次のいずれかを使用):
    • NM-4B-S/T - 4 ポート ISDN BRI ネットワーク モジュール、バージョン 800-01236-03 以上
    • NM-4B-U - 統合 NT-1 ネットワーク モジュールに対応した 4 ポート ISDN BRI、バージョン 800-01238-06 以上
    • NM-8B-S/T - 8 ポート ISDN BRI ネットワーク モジュール、バージョン 800-01237-03 以上
    • NM-8B-U - 統合 NT-1 ネットワーク モジュールに対応した 8 ポート ISDN BRI、バージョン 800-01239-06 以上

  • デジタル モデム ネットワーク モジュール(次のいずれかを使用:NM-6DM、NM-12DM、NM-18DM、NM-24DM、または NM-30DM)
  • LAN インターフェイス カード
  • Cisco IOS(R) ソフトウェア リリース 12.0(2)XC

ハードウェアとソフトウェアの最低要件(部品番号やリビジョン番号など)の詳細については、Cisco 3640 ルータの ISDN BRI のモデムのドキュメントを参照してください。

規定

この設定は、Cisco ルータのアクセス セキュリティにローカル ユーザ リストを使用します。

次に、この設定の実装に使用される Cisco IOS ソフトウェアのバージョンとモデム ファームウェアのバージョンを示します。これは show version コマンドの出力から関連セクションを抜き出したものです。

Cisco Internetwork Operating System Software IOS (tm) 3600 Software (C3640-I-M), Version 12.0(5)XK1, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
      System image file is "flash:c3640-i-mz.120-5.XK1"   
      MICA-6DM Firmware: CP ver 2310 - 6/3/1998, SP ver 2310 - 6/3/1998.

ルータにインストールされているハードウェアのタイプを判別するには、show diag EXEC コマンドを使用します。show diag コマンドは、バージョン番号と、ルータのハードウェア モジュールの部品番号を表示します。次に、show diag EXEC コマンドからの出力例の関連セクションを示します。

    maui-nas-04#show diag
       
       Slot 1:
       BRI (U) port adapter, 4 ports
       
       Serial number 17156199 Part number 800-01238-06
       

ネットワーク ダイアグラム

設定例

Cisco 3640
maui-nas-04#show run
   Building configuration...
   Current configuration:
   !
   ! Last configuration change at 10:11:43 CST Thu Apr 13 2000
   !
   version 12.0
   service timestamps debug uptime
   service timestamps log uptime
   service password-encryption
   !
   hostname maui-nas-04
   !
   aaa new-model
   AAA authentication login default group tacacs+ local
   AAA authentication ppp default if-needed group tacacs+ local
   !
   enable secret <deleted>
   !
   username admin privilege 15 password 7 0213100D52050024
   !
   modem country mica <country>
   !-- 設定が機能するためには国情報が必須です
   !
   clock timezone CST -6
   clock summer-time CST recurring
   !
   ip subnet-zero
   ip domain-name maui-onions.com
   ip name-server 172.22.53.210
   !
   isdn switch-type basic-ni
   ! --- グローバル ISDN スイッチタイプ(日本国内においては、basic-ni = ntt となります)
   !
   !
   process-max-time 200
   !
   interface Loopback0
    ip address 172.22.87.4 255.255.255.0
    no ip directed-broadcast
   !
   interface Loopback1
    no ip address
    no ip directed-broadcast
   !
   interface Ethernet0/0
    ip address 172.22.80.4 255.255.255.0
    no ip directed-broadcast
   !
   interface Ethernet0/1
    no ip address
    no ip directed-broadcast
    shutdown
   !
   interface BRI1/0
    no ip address
    no ip directed-broadcast
    shutdown
    isdn switch-type basic-ni
   !
   interface BRI1/1
    no ip address
    no ip directed-broadcast
    shutdown
    isdn switch-type basic-ni
   !
   interface BRI1/2
    no ip address
    no ip directed-broadcast
    shutdown
    isdn switch-type basic-ni
   !
   interface BRI1/3
   ! --- アクティブ BRI
    no ip address
    no ip directed-broadcast
    isdn switch-type basic-ni
    isdn spid1 51255511110101 5551111
    isdn spid2 51255522220101 5552222
! --- isdn spidの設定は、日本国内では不要です

    isdn incoming-voice modem
   ! --- 着信音声コールをモデムに送ります
   ! --- 上記のコマンドを、アナログ コールを受け入れるすべての BRI に追加します
   !
   interface Group-Async1
    ip unnumbered Loopback0
   ! --- Loopback0 が上記に割り当てられます
    no ip directed-broadcast
    encapsulation ppp
    async mode interactive
    peer default ip address pool default
   ! --- 下記で定義されるローカル プールを使用します
    ppp authentication pap
   ! --- PAP 認証を使用します
    group-range 65 66
   ! --- 下記で設定された、接続に使用するライン範囲を指定します
   !
   router eigrp 69
   network 172.22.0.0
   !
   ip local pool default 172.22.84.2 172.22.84.253
   ! --- IP アドレス プール設定
   ip default-gateway 172.22.80.1
   ip classless
   ip route 0.0.0.0 0.0.0.0 172.22.80.1
   ip http server
   ip http authentication local
   !
   tacacs-server host 172.22.53.201
   tacacs-server key <deleted>
   !
   line con 0
    transport input all
    line 65 66
   ! --- これは、Group-Async インターフェイスの group-range と一致している必要があります
   ! --- ダイヤルイン用に構成されるラインを確認するには、show line コマンドを使用します
    autoselect during-login
    autoselect ppp
    modem Dialin
   line 67 70
   line aux 0
   line vty 0 4
   password <deleted>
   !
   ntp clock-period 17179861
   ntp server 172.22.255.1 prefer
   
   end

debug コマンドとshowコマンド

  • debug modem - アクセス サーバのモデムのアクティビティを監視する。

  • debug modem csm - モデム上のコールの接続に使用されるコール状態マシンをデバッグする。

  • debug isdn Q931 - ユーザがダイヤルインする時に ISDN 接続をチェックして、ISDN コールに何が発生しているかを調べる(たとえば、接続がドロップされているかどうかなど)。

  • show isdn stat - ステータスは次のようになります。
layer 1 = active
   layer 2 = MULTIPLE_FRAMES_ESTABLISHED 
レイヤ 1 がアクティブではない場合、配線アダプタまたはポートが破損しているか、配線が接続されていない可能性があります。レイヤ 2 が TEI_Assign の状態の場合、ルータは回線の起動に失敗しています。
  • show line - ラインのパラメータを表示する。ダイヤルイン用に構成する必要があるラインを確認するには、show line コマンドを使用します。

  • show users - ライン番号、接続名、アイドル時間、およびターミナル位置を表示する。

  • show diag - ルータにインストールされているハードウェアのタイプを判別する。

上記のデバッグ コマンドを試行する前に、デバッグ コマンドに関する重要情報を参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報
Document ID: 10307