IP : IP ルーティング

BGP 最大プレフィクス機能の設定

2008 年 12 月 4 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 1 月 15 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      ネットワーク ダイアグラム
      設定例
      しきい値がしきい値の設定を超えた際に、警告だけのメッセージを送る場合の最大プレフィクスの設定
      しきい値がしきい値の設定を超えた際に、ネイバーとの関係をダウンさせる場合の最大プレフィクスの設定
確認とトラブルシューティング
      最大プレフィクス、警告のみ
      しきい値がしきい値設定を超えた際に、セッションをダウンさせるための最大プレフィクスの設定
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは Border Gateway Protocol(BGP; ボーダーゲートウェイ プロトコル)の最大プレフィクス機能の設定と、トラブルシューティングについて説明しています。

BGP の最大プレフィクス機能を使用すると、ネイバーから受信するプレフィクスの数を制御できるようになります。デフォルトでは、ピアから受信したプレフィクスの数が設定されている最大プレフィクスの制限値を超えたとき、この機能によってルータがピアをダウンさせることができるようになっています。この機能は、通常は外部の BGP ピアに対して使用されますが、内部の BGP ピアにも適用できます。

最大プレフィクス機能は、リモート ピアリング サイトでの発信ポリシーが変更され、ルータのメモリ量で対応できる以上のルートがルータで受信され始めた場合に役に立ちます。この同じルータが BGP を経由してピアリングを行い、さらにネットワーク内で重要なルーティング機能を実行している場合、このオーバーヘッドによって悪影響が生じる可能性があります。BGP の問題によって内部ネットワークの接続が中断される可能性があります。neighbor maximum-prefix コマンドを使用することによって、ルータをこの状況から保護することができます。

この機能の使用を計画する際には、次のキー ポイントを考慮してください。

  • リモートの BGP ピアリング ルータが通常送信しているルートの数を把握する。

  • 通常の動作の際に受信されると思われる BGP プレフィクスよりも少し高い値をしきい値に設定する。

  • リモートの BGP ピアから予測していた以上のプレフィクスを受信した場合に取るアクションを把握する。取ることのできるアクションは、セッションをダウンすること、clear ip bgp x.x.x.x コマンドの発行まで BGP ネイバーとの関係をダウン状態にしておくこと、または警告メッセージの記録のみを行うことのいずれかです。

注:Cisco IOS(R) ソフトウェア リリース 12.0(22)S および 12.2(15)T では、この機能が拡張されています。この機能拡張により、最大プレフィクスの制限を超えたためにダウン状態になったピアリング セッションをユーザが自動的に再確立できるようになりました。この機能が有効にされている場合、ネットワーク オペレータの操作は必要ありません。詳細は、『最大プレフィクスの制限を超えた後の BGP セッションの再開』を参照してください。

前提条件

要件

このドキュメントの読者は、次の項目の情報についての基本的な知識が必要です。

Cisco IOS IP コンフィギュレーション ガイド、リリース 12.2』の「BGP の実装」セクション

BGP の設定』の「BGP の設定」セクション

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

Cisco IOS(R) ソフトウェア リリース 12.2(27) が稼働する Cisco 2500 シリーズ ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定から作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

この機能で使用可能な Cisco IOS ソフトウェア バージョンを判断するには、Cisco Feature Navigator登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供しています。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

BGP 最大プレフィクス機能を設定するために使用するコマンドの構文は次のとおりです。

neighbor {ip-address | peer-group-name} maximum-prefix 
maximum [threshold] [restart restart-interval] [warning-only]

各記号の意味は次のとおりです。

  • maximum:ネイバーから受信できるプレフィクスの最大数を表します。

  • threshold:オプションで指定する整数値であり、maximum-value で設定した値に対するパーセンテージを指定します。このパーセンテージに達した時点で、ルータが警告メッセージを出し始めます。範囲は 1 〜 100 % で、デフォルトは 75 % です。

    たとえば、maximum-value が 20 に設定され、しきい値が 60 の場合、ネイバーから学習した BGP のルートが 20 ルートの 60 %(12 ルート)を超えると、ルータによって警告メッセージが生成されます。

    restart-interval:オプションの、ピアリング セッションが再確立される時間間隔(単位は分)です。範囲は 1 〜 65535 分です。

    warning-only:(オプション)最大プレフィクスの制限値を超えた場合、ピアリング セッションを終了するのではなく、ログ メッセージを生成することをルータに許可します。

使用方法をよりよく理解するために、次の例を参照してください。

neighbor 10.1.1.1 maximum-prefix 3000

!--- 3000 を超えるプレフィクスが送信された場合、 
!--- 10.1.1.1 へのピアリングをドロップします。


neighbor 10.1.1.1 maximum-prefix 3000 warning-only

!--- ピアによって 3000 を超えるプレフィクスが送信された場合、 
!--- 警告メッセージがログに記録されます。


neighbor 10.1.1.1 maximum-prefix 3000 50

!--- プレフィクスが 1500 送信された時点で警告メッセージをログに記録し、 
!--- 3000 を超えるプレフィクスが送信された場合にピアリングをドロップします。


neighbor 10.1.1.1 maximum-prefix 3000 50 warning-only

!--- 最初にプレフィクスが 1500 送信された時点で警告メッセージをログに記録し、 
!--- プレフィクスが 3000 送信された時点で別のメッセージを再度ログに記録します。
!--- ただし、BGP ピアは接続解除されません。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

bgp-maximum-prefix-01.gif

設定例

このドキュメントでは、次の設定を使用しています。

しきい値がしきい値の設定を超えた際に、警告だけのメッセージを送る場合の最大プレフィクスの設定

最大プレフィクスの警告のみを送る設定では、Router_B は、Router_A から受信するプレフィクスの数がしきい値の設定を超えた際に、警告メッセージのログへの記録のみを行うように設定されます。次の表に、両方のルータの設定を示します。warning-only というキーワードが neighbor コマンドで設定されていることに注意してください。

Router_A Router_B
hostname Router_A
! 
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Serial0 
 ip address 192.168.1.1 255.255.255.252
!
interface Serial1
 ip unnumbered Loopback0 
! 
router bgp 200
 no synchronization
 bgp router-id 10.0.0.1
 bgp log-neighbor-changes
 neighbor 192.168.1.2 local-as 100
 neighbor 10.0.0.2 remote-as 300
 neighbor 10.0.0.2 ebgp-multihop 2
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.2 version 4
 no auto-summary
!
ip route 10.0.0.2 255.255.255.252 Serial1
hostname Router_B 
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.252
!
interface Ethernet0 
 ip address 10.0.1.1 255.255.255.0 
!
interface Serial0
 ip unnumbered Loopback0
! 
router bgp 300
 no synchronization
 bgp router-id 10.0.0.2
 bgp log-neighbor-changes
 neighbor 10.0.0.1 remote-as 200
 neighbor 10.0.0.1 ebgp-multihop 2
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.1 version 4
 neighbor 10.0.0.1 maximum-prefix 10 80 warning-only

!--- ネイバー 10.0.0.1 から学習した BGP ルートの数が 
!--- 8 を超えたとき、警告メッセージのログが 
!--- 記録されるようにします。 

 no auto-summary
!
ip route 10.0.0.1 255.255.255.252 Serial0

このドキュメントの「確認とトラブルシューティング」セクションにある show コマンドと debug コマンドの出力では、Router_A から受信したプレフィクスの数がしきい値の設定を超えた際に Router_B で実際に生じる現象が報告されています。

しきい値がしきい値の設定を超えた際に、ネイバーとの関係をダウンさせる場合の最大プレフィクスの設定

ネイバー関係の設定をダウンさせる最大プレフィクスの設定では、Router_A から受信するプレフィクスの数がしきい値の設定を超えた際に、Router_B が警告メッセージを生成するように設定されます。また、Router_B は、最大プレフィクスの制限値を超えた際に、BGP ネイバーをダウンするようにも設定されます。次の表に、両方のルータの設定を示します。warning-only というキーワードが neighbor コマンドで設定されていないことに注意してください。

Router_A Router_B
hostname Router_A
! 
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Serial0 
 ip address 192.168.1.1 255.255.255.252
!
interface Serial1
 ip unnumbered Loopback0 
! 
router bgp 200
 no synchronization
 bgp router-id 10.0.0.1
 bgp log-neighbor-changes
 neighbor 192.168.1.2 local-as 100
 neighbor 10.0.0.2 remote-as 300
 neighbor 10.0.0.2 ebgp-multihop 2
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.2 version 4
 no auto-summary
!
ip route 10.0.0.2 255.255.255.252 Serial1
hostname Router_B 
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.252
!
interface Ethernet0 
 ip address 10.0.1.1 255.255.255.0 
!
interface Serial0
 ip unnumbered Loopback0
! 
router bgp 300
 no synchronization
 bgp router-id 10.0.0.2
 bgp log-neighbor-changes
 neighbor 10.0.0.1 remote-as 200
 neighbor 10.0.0.1 ebgp-multihop 2
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.1 version 4
 neighbor 10.0.0.1 maximum-prefix 10 80

!--- この設定により、ネイバーから学習した BGP の  
!--- ルートの数が 8 を超えたとき、ネイバーのセッションが 
!--- 強制的に停止されます。

 no auto-summary
!
ip route 10.0.0.1 255.255.255.252 Serial0

確認とトラブルシューティング」セクションにある show コマンドと debug コマンドの出力では、Router_A から受信したプレフィクスの数がしきい値の設定を超えた際に Router_B で実際に生じる現象が報告されています。

確認とトラブルシューティング

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を示しています。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

このドキュメントで使用されているコマンドの構文とデフォルトの機能については、『Cisco IOS IP ルーティング プロトコル コマンド リファレンス、リリース 12.4』の「BGP コマンド」のページを参照してください。

注:debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

最大プレフィクス、警告のみ

次の数値に注意してください。

  • 決められている最大プレフィクス: 10

  • 警告のしきい値:80 %(8)

受信されたプレフィクスがしきい値の設定(8)より高くならない限り、メッセージはログに記録されません。ネイバー 10.0.0.1 から学習した BGP ルートの数がしきい値の設定である 8 を超えると、Router_B では次のメッセージがログに記録されます。9 個のプレフィクスが送信された場合のメッセージを示します。

%BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0) reaches 9, max 10

状況がさらに悪くなり、最大プレフィクス数の設定である 10 を超過すると、ルータでは次のメッセージがログに記録されます。12 個のプレフィクスが送信された場合のメッセージを示します。

%BGP-3-MAXPFXEXCEED: No. of prefix received from 10.0.0.1 (afi 0): 11 exceed limit 10 

debug ip bgp updates in を有効にすると、現象をより詳細に理解できます。ただし、数千個のプレフィクスが送信される実稼働環境ではこのコマンドは使用しないでください。次の例では、Router_B にはピアリングが確立されているものとします。Router_A によって、6 個のプレフィクスが Router_B にアドバタイズされています。その後、3 個のプレフィクスが追加でピア Router_A によってアドバタイズされました。

Router_B# debug ip bgp updates in
*Mar 12 07:31:18.944: BGP(0): 10.0.0.1 rcvd UPDATE w/ attr: nexthop 10.0.0.1, or
igin i, metric 0, path 200
*Mar 12 07:31:18.948: BGP(0): 10.0.0.1 rcvd 10.0.1.0/24...duplicate ignored
*Mar 12 07:31:18.952: BGP(0): 10.0.0.1 rcvd 10.0.2.0/24...duplicate ignored
*Mar 12 07:31:18.960: BGP(0): 10.0.0.1 rcvd 10.0.3.0/24...duplicate ignored
*Mar 12 07:32:20.224: BGP(0): 10.0.0.1 rcvd 10.0.4.0/24...duplicate ignored
*Mar 12 07:32:20.228: BGP(0): 10.0.0.1 rcvd 10.0.5.0/24...duplicate ignored
*Mar 12 07:32:20.232: BGP(0): 10.0.0.1 rcvd 10.0.6.0/24...duplicate ignored
*Mar 12 07:34:19.768: BGP(0): 10.0.0.1 rcvd 10.0.7.0/24
*Mar 12 07:34:19.772: BGP(0): 10.0.0.1 rcvd 10.0.8.0/24
*Mar 12 07:34:19.780: BGP(0): 10.0.0.1 rcvd 10.0.9.0/24
*Mar 12 07:34:19.780: 
%BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0
) reaches 9, max 10

*Mar 12 07:34:19.792: BGP(0): Revise route installing 1 of 1 route for 10.0.7.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 07:34:19.796: BGP(0): Revise route installing 1 of 1 route for 10.0.8.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 07:34:19.804: BGP(0): Revise route installing 1 of 1 route for 10.0.9.0/
24 -> 10.0.0.1 to main IP table

Router_B#show ip bgp neighbor 10.0.0.1
BGP neighbor is 10.0.0.1,  remote AS 200, external link
  BGP version 4, remote router ID 10.0.0.1
  BGP state = Established, up for 00:13:22
  Last read 00:00:21, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
    IPv4 MPLS Label capability:
  Received 930 messages, 0 notifications, 0 in queue
  Sent 919 messages, 1 notifications, 0 in queue
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 30, neighbor version 30
  Index 1, Offset 0, Mask 0x2
  Route refresh request: received 0, sent 0
  9 accepted prefixes consume 432 bytes
  Prefix advertised 0, suppressed 0, withdrawn 0, maximum limit 10 (warning-only
)
  Threshold for warning message 80%

  Connections established 2; dropped 1
  Last reset 00:29:13, due to BGP Notification sent, update malformed
  Message received that caused BGP to send a Notification:
    FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
    003C0200 00001940 01010040 02040201
    00C84003 040A0000 01800404 00000000
    180A000A 180A000B 180A000C
  External BGP neighbor can be up to 2 hops away.
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Local host: 10.0.0.2, Local port: 15668
Foreign host: 10.0.0.1, Foreign port: 179

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x3A46EB54):
Timer          Starts    Wakeups            Next
Retrans            18          0             0x0
TimeWait            0          0             0x0
AckHold            22          9             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0

iss: 2047376434  snduna: 2047376784  sndnxt: 2047376784     sndwnd:  16035
irs:  821061364  rcvnxt:  821062116  rcvwnd:      16188  delrcvwnd:    196

SRTT: 279 ms, RTTO: 500 ms, RTV: 221 ms, KRTT: 0 ms
minRTT: 24 ms, maxRTT: 384 ms, ACK hold: 200 ms
Flags: higher precedence, nagle

Datagrams (max data segment is 536 bytes):
Rcvd: 33 (out of order: 0), with data: 22, total data bytes: 751
Sent: 29 (retransmit: 0, fastretransmit: 0), with data: 17, total data bytes: 349



Router_B#show ip bgp summary
BGP router identifier 10.0.0.2, local AS number 300
BGP table version is 30, main routing table version 30
9 network entries and 9 paths using 1341 bytes of memory
1 BGP path attribute entries using 60 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 36/101 prefixes, 36/27 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.1        4   200     932     921       30    0    0 00:15:08        9

Router_A からさらに 3 個のプレフィクスが送信され、合計数が 12 になったという、さらに状態が悪くなった場合を想定します。


Router_B# debug ip bgp updates in
*Mar 12 07:39:21.192: BGP(0): 10.0.0.1 rcvd UPDATE w/ attr: nexthop 10.0.0.1, origin i, metric 0, path 200
*Mar 12 07:39:21.196: BGP(0): 10.0.0.1 rcvd 10.0.10.0/24
*Mar 12 07:39:21.200: %BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0) reaches 10, max 10
*Mar 12 07:39:21.208: BGP(0): 10.0.0.1 rcvd 10.0.11.0/24
*Mar 12 07:39:21.212: %BGP-3-MAXPFXEXCEED: No. of prefix received from 10.0.0.1 (afi 0): 11 exceed limit 10
*Mar 12 07:39:21.216: BGP(0): 10.0.0.1 rcvd 10.0.12.0/24
*Mar 12 07:39:21.228: BGP(0): Revise route installing 1 of 1 route for 10.0.10.0/24 -> 10.0.0.1 to main IP table
*Mar 12 07:39:21.236: BGP(0): Revise route installing 1 of 1 route for 10.0.11.0/24 -> 10.0.0.1 to main IP table
*Mar 12 07:39:21.240: BGP(0): Revise route installing 1 of 1 route for 10.0.12.0/24 -> 10.0.0.1 to main IP table

Router_B# show ip bgp neighbors 10.0.0.1
BGP neighbor is 10.0.0.1,  remote AS 200, external link
  BGP version 4, remote router ID 10.0.0.1
  BGP state = Established, up for 00:19:56
  Last read 00:00:56, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
    IPv4 MPLS Label capability:
  Received 937 messages, 0 notifications, 0 in queue
  Sent 925 messages, 1 notifications, 0 in queue
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 33, neighbor version 33
  Index 1, Offset 0, Mask 0x2
  Route refresh request: received 0, sent 0
  12 accepted prefixes consume 576 bytes
  Prefix advertised 0, suppressed 0, withdrawn 0, maximum limit 10 (warning-only)
  Threshold for warning message 80%

  Connections established 2; dropped 1
  Last reset 00:35:47, due to BGP Notification sent, update malformed
  Message received that caused BGP to send a Notification:
    FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
    003C0200 00001940 01010040 02040201
    00C84003 040A0000 01800404 00000000
    180A000A 180A000B 180A000C
  External BGP neighbor can be up to 2 hops away.
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Local host: 10.0.0.2, Local port: 15668
Foreign host: 10.0.0.1, Foreign port: 179

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x3A4CEA98):
Timer          Starts    Wakeups            Next
Retrans            24          0             0x0
TimeWait            0          0             0x0
AckHold            29         16             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0

iss: 2047376434  snduna: 2047376898  sndnxt: 2047376898     sndwnd:  15921
irs:  821061364  rcvnxt:  821062290  rcvwnd:      16014  delrcvwnd:    370

SRTT: 290 ms, RTTO: 376 ms, RTV: 86 ms, KRTT: 0 ms
minRTT: 24 ms, maxRTT: 384 ms, ACK hold: 200 ms
Flags: higher precedence, nagle

Datagrams (max data segment is 536 bytes):
Rcvd: 40 (out of order: 0), with data: 29, total data bytes: 925
Sent: 42 (retransmit: 0, fastretransmit: 0), with data: 23, total data bytes: 463
Router_B#show ip bgp summary
BGP router identifier 10.0.0.2, local AS number 300
BGP table version is 33, main routing table version 33
12 network entries and 12 paths using 1788 bytes of memory
1 BGP path attribute entries using 60 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 39/101 prefixes, 39/27 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.1        4   200     939     927       33    0    0 00:21:28       12

上の例で見たように、ポリシーで許可している数よりも多いプレフィクスがネイバー ルータから送信された場合でも、BGP ネイバー関係は維持されています。結果としては、Router_B で警告メッセージのログが記録されただけです。Router_B ではこれ以外のアクションは行われません。

しきい値がしきい値設定を超えた際に、セッションをダウンさせるための最大プレフィクスの設定

このケースに必要な初期状態は、BGP ネイバーがアップ状態で動作しており、Router_A から Router_B へ 6 個のプレフィクスが送信されている状態です。例に示されるように、Router_A がより多くのプレフィクス(たとえば、9 個)をアドバタイズした場合、コマンドの出力は、すでに見た Router_B が警告メッセージのログを記録するようにのみに設定されている場合と同様の出力になります。送信するプレフィクスの数を増やし、Router_A が 12 個のルートをアドバタイズする場合は、Router_B によって Router_A とのネイバー関係が停止されます。


Router_B# debug ip bgp updates in
*Mar 12 08:03:27.864: BGP(0): 10.0.0.1 rcvd UPDATE w/ attr: nexthop 10.0.0.1, or
igin i, metric 0, path 200
*Mar 12 08:03:27.868: BGP(0): 10.0.0.1 rcvd 10.0.1.0/24...duplicate ignored
*Mar 12 08:03:27.876: BGP(0): 10.0.0.1 rcvd 10.0.2.0/24...duplicate ignored
*Mar 12 08:03:27.880: BGP(0): 10.0.0.1 rcvd 10.0.3.0/24...duplicate ignored
*Mar 12 08:03:27.884: BGP(0): 10.0.0.1 rcvd 10.0.4.0/24...duplicate ignored
*Mar 12 08:03:27.892: BGP(0): 10.0.0.1 rcvd 10.0.5.0/24...duplicate ignored
*Mar 12 08:03:27.896: BGP(0): 10.0.0.1 rcvd 10.0.6.0/24...duplicate ignored
*Mar 12 08:03:27.900: BGP(0): 10.0.0.1 rcvd 10.0.7.0/24
*Mar 12 08:03:27.908: BGP(0): 10.0.0.1 rcvd 10.0.8.0/24
*Mar 12 08:03:27.912: BGP(0): 10.0.0.1 rcvd 10.0.9.0/24
*Mar 12 08:03:27.916: %BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0
) reaches 9, max 10
*Mar 12 08:03:27.924: BGP(0): 10.0.0.1 rcvd 10.0.10.0/24
*Mar 12 08:03:27.932: BGP(0): 10.0.0.1 rcvd 10.0.11.0/24
*Mar 12 08:03:27.932: %BGP-3-MAXPFXEXCEED: No. of prefix received from 10.0.0.1
(afi 0): 11 exceed limit 10
*Mar 12 08:03:27.940: %BGP-5-ADJCHANGE: neighbor 10.0.0.1 Down BGP Notification
sent
*Mar 12 08:03:27.940: %BGP-3-NOTIFICATION: sent to neighbor 10.0.0.1 3/1 (update
 malformed) 0 bytes  FFFF FFFF FFFF FFFF FFFF FFFF FFFF FFFF 0060 0200 0000 1940
 0101 0040 0204 0201 00C8 4003 040A 0000 0180 0404 0000 0000 180A 0001 180A 0002
 180A 0003 180A 0004 180A 0005 180A 0006 180A 0007 180A 0008 180A 0009 180A 000A
 180A 000B 180A 000C
*Mar 12 08:03:28.024: BGP(0): Revise route installing 1 of 1 route for 10.0.7.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.032: BGP(0): Revise route installing 1 of 1 route for 10.0.8.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.036: BGP(0): Revise route installing 1 of 1 route for 10.0.9.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.044: BGP(0): Revise route installing 1 of 1 route for 10.0.10.0
/24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.148: BGP(0): no valid path for 10.0.1.0/24
*Mar 12 08:03:28.152: BGP(0): no valid path for 10.0.2.0/24
*Mar 12 08:03:28.156: BGP(0): no valid path for 10.0.3.0/24
*Mar 12 08:03:28.156: BGP(0): no valid path for 10.0.4.0/24
*Mar 12 08:03:28.160: BGP(0): no valid path for 10.0.5.0/24
*Mar 12 08:03:28.164: BGP(0): no valid path for 10.0.6.0/24
*Mar 12 08:03:28.168: BGP(0): no valid path for 10.0.7.0/24
*Mar 12 08:03:28.168: BGP(0): no valid path for 10.0.8.0/24
*Mar 12 08:03:28.172: BGP(0): no valid path for 10.0.9.0/24
*Mar 12 08:03:28.176: BGP(0): no valid path for 10.0.10.0/24
*Mar 12 08:03:28.184: BGP(0): nettable_walker 10.0.1.0/24 no best path
*Mar 12 08:03:28.188: BGP(0): nettable_walker 10.0.2.0/24 no best path
*Mar 12 08:03:28.192: BGP(0): nettable_walker 10.0.3.0/24 no best path
*Mar 12 08:03:28.196: BGP(0): nettable_walker 10.0.4.0/24 no best path
*Mar 12 08:03:28.200: BGP(0): nettable_walker 10.0.5.0/24 no best path
*Mar 12 08:03:28.204: BGP(0): nettable_walker 10.0.6.0/24 no best path
*Mar 12 08:03:28.208: BGP(0): nettable_walker 10.0.7.0/24 no best path
*Mar 12 08:03:28.212: BGP(0): nettable_walker 10.0.8.0/24 no best path
*Mar 12 08:03:28.212: BGP(0): nettable_walker 10.0.9.0/24 no best path
*Mar 12 08:03:28.216: BGP(0): nettable_walker 10.0.10.0/24 no best path



Router_B# show ip bgp summary
BGP router identifier 10.0.0.2, local AS number 300
BGP table version is 87, main routing table version 87

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.1        4   200     965     948        0    0    0 00:02:24 Idle (PfxCt)

Router_B# show ip bgp neighbors 10.0.0.1
BGP neighbor is 10.0.0.1,  remote AS 200, external link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Idle
  Last read 00:02:43, hold time is 180, keepalive interval is 60 seconds
  Received 965 messages, 0 notifications, 0 in queue
  Sent 948 messages, 2 notifications, 0 in queue
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 87, neighbor version 0
  Index 1, Offset 0, Mask 0x2
  Route refresh request: received 0, sent 0, maximum limit 10
  Threshold for warning message 80%

  Connections established 2; dropped 2
  Last reset 00:02:43, due to BGP Notification sent, update malformed
  Message received that caused BGP to send a Notification:
    FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
    00600200 00001940 01010040 02040201
    00C84003 040A0000 01800404 00000000
    180A0001 180A0002 180A0003 180A0004
    180A0005 180A0006 180A0007 180A0008
    180A0009 180A000A 180A000B 180A000C

  Peer had exceeded the max. no. of prefixes configured.
  Reduce the no. of prefix and clear ip bgp 10.0.0.1 to restore peering
  External BGP neighbor can be up to 2 hops away.
  No active TCP connection

注:ピア機能を復元するには、次のコマンドを使用します。

Router_B# clear ip bgp 10.0.0.1

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 25160