IP : IP ルーティング

BGP でプライベート AS 番号を削除するためのサンプル設定

2002 年 6 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 1 月 1 日) | フィードバック

概要

この文書では、プライベート autonomous system(AS;自律システム)番号を削除するためのサンプル設定を示します。プライベート AS 番号を使用すると、eBGP を通じて接続される複数の小さな AS に、大きな AS を分割できます。また、単一の ISP に接続している場合は、その ISP は AS 番号を節約するために、プライベート AS 番号を割り当てることができます。ただし、このような AS 番号は、グローバル BGP メッシュに更新を送信する前に削除する必要があります。プライベート AS 番号は、64512 〜 65535 の範囲です。

プライベート AS 番号の詳細については、「BGP でのプライベート自律システム番号の削除」を参照してください。

ネットワーク ダイアグラム

ネットワーク ダイアグラム

設定

ルータ 3
Current configuration :
  !
  interface Ethernet0
   ip address 10.0.0.1 255.255.255.0
  !
  interface Serial0
   ip address 172.16.0.1 255.255.255.0
  !
  router bgp 65000
   network 10.0.0.0 mask 255.255.255.0
   neighbor 172.16.0.2 remote-as 5
  !
  end
  
ルータ 2
Current configuration :
  !
  !
  interface Ethernet0
   ip address 172.30.1.1 255.255.0.0
  !
  interface Serial0
   ip address 172.16.0.2 255.255.255.0
  !
  interface Serial1
   ip address 192.168.0.1 255.255.255.0
  !
  router bgp 5
   network 172.30.0.0
   neighbor 172.16.0.1 remote-as 65000
   neighbor 192.168.0.2 remote-as 1
   neighbor 192.168.0.2 remove-private-AS
  !
  !
  end
  
ルータ 1
Current configuration :
  !
  version 12.2
  !
  !
  interface Serial0
   ip address 192.168.0.2 255.255.255.0
   !
  router bgp 1
   neighbor 192.168.0.1 remote-as 5
  !
  end
  

show コマンド

Router2#show ip bgp
  BGP table version is 3, local router ID is 192.168.0.1
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
  Origin codes: i - IGP, e - EGP, ? - incomplete
      Network         Next Hop      Metric  LocPrf Weight   Path
   *> 10.0.0.0/24     172.16.0.2         0              0   65000 i
   *> 172.30.0.0      0.0.0.0            0         32768    i
   
  
  Router1#show ip bgp
  BGP table version is 19, local router ID is 192.168.0.2
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
  Origin codes: i - IGP, e - EGP, ? - incomplete
      Network          Next Hop      Metric  LocPrf  Weight  Path
   *> 10.0.0.0/24      192.168.0.1                        0  5 i
   *> 172.30.0.0       192.168.0.1        0               0  5 i
  
  

ルータ 2 の BGP テーブルは、ネットワーク 10.0.0.0 が AS 65000 を起点としていることを示しています。ルータ 1 の BGP テーブルは、同じネットワークが AS 5 を起点としていることを示しています。これは、ルータ 2 の remove-private-as コマンドが、プライベート AS 番号を削除し、プライベート AS 番号がインターネットに到達することを防いでいるためです。このため、AS 1(ルータ 1)は、一貫して AS 5 をネットワーク 10.0.0.0/24 の起点と見なしています。


関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 13758