ダイヤルとアクセス : ダイヤルオンデマンド ルーティング(DDR)

DDR ダイヤラ マップを使用する BRI 間ダイヤルアップの設定

2003 年 12 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 12 月 16 日) | フィードバック

目次


概要

この文書では、BRI インターフェイスが装備された 2 つのルータ間のダイヤルオンデマンド ルーティング(DDR)の構成方法を説明します。 この設定では、スモール オフィス、ホーム オフィス(SOHO)ルータは、セントラル ネットワークにトラフィックを送信する必要が発生するたびにセントラル サイトのルータにダイヤルします。 この場合、ユーザが定義した期間にトラフィックが存在しなければコネクションは自動的に停止されます。 また、このネットワークは ip ospf demand-circuit コマンドで Open Shortest Path First(OSPF)ルーティング プロトコルを使用して、DDR リンクの停止時にリモート側のネットワークへのルートが削除されないようにします。 しかし、このリンク上でルーティング プロトコルを実行する必要はありません。

前提条件

次のポイントは、DDR リンクの構成に先立って決めなければならない設計要素を説明しています。

  • DDR の実装:ダイヤラ マップ(レガシー DDR)またはダイヤラ プロファイルを使用する。 この 2 つの実装の違いに関する詳細は、ダイヤラ プロファイルを使用した ISDN DDR の設定 を参照してください。 ここではダイヤラ マップを使用します。


  • 単一方向ダイヤリングまたは双方向ダイヤリング: お互いのルータにダイヤルして DDR リンクを起動するように各ルータを構成する、またはダイヤル コネクションを起動する一方向だけのルータ(通常 SOHO)を設定する。 使用するダイヤル方式を決める前に、トラフィック パターンを調べて次の情報を検討します。


    • 両方のルータがダイヤルする場合
      • 他のルータのネットワークに向けられたトラフィックがある場合、どちらのサイトもリンクを起動できる。
      • 両方のルータから同時にダイヤルできるが、この場合はビジー メッセージが発生する可能性がある。

    • ダイヤリングが SOHO ルータに制限されている場合
      • リンクが起動していない場合、SOHO ルータに向けられたセントラル サイトからのトラフィックは通過しない。
      • コールの「衝突」によるビジー メッセージを回避できる。

    : この例では、SOHO ルータだけが DDR リンクを起動します。

  • ルーティング プロトコル: リンク上で実行するルーティング プロトコルを選択できるが、定期的なトラフィックによりリンクが起動したままにならないように、hello に対象外のタグをつけることなどの配慮が必要です。 また、ルーティング プロトコルはルーティング テーブルを元のままの状態に保ち、いったんリンクが停止されてもルートを破棄しないようにする必要があります。 これは、ip ospf demand-circuit コマンドまたはスナップショット ルーティングで行えます。 ルーティング プロトコルを使用しない場合、ネクストホップをお互いのBRIインターフェースに指定するスタティックルートを設定できます。

  • 対象トラフィック: DDR 対象トラフィックを定義する際に注意が必要です。 どちらかで対象トラフィックが間違って定義されると、希望するときにリンクを起動することや早期にリンクを停止することができない状態、またはリンクがまったく停止できない状態になります。 たとえば、リンクをアップしたままにしないよう、すべてのルーティング プロトコル トラフィックに対象外のタグを付けます。

ハードウェアおよびソフトウェアのバージョン

この設定では、次のソフトウェアおよびハードウェアのバージョンを使用して開発とテストを行いました。

  • Cisco IOS ® ソフトウェア リリース 12.1(5)T が稼動する 1 つの BRI U インターフェイスが装備された Cisco 1604 SOHO ルータ
  • Cisco IOS 12.1(2) が稼動する NM-4B-U(4 つの BRI U インターフェイス)が装備された Cisco 3640 ルータ

ネットワークダイヤグラム

ネットワーク図

設定

:この文書の情報は、ラボ環境で取得したものです。 実際に稼動するネットワーク上でコマンドを使用する前に、コマンドの潜在的な影響を考慮する必要があります。

maui-soho-01 (1600)
maui-soho-01#show running-config

 Building configuration...

 

 Current configuration : 1656 bytes

 !

 version 12.1

 no service single-slot-reload-enable

 service timestamps debug datetime msec

 service timestamps log datetime msec

 

 !

 hostname maui-soho-01

 !

 logging rate-limit console 10 except errors

 aaa new-model

 aaa authentication login default local

 aaa authentication login NO_AUTHEN none

 aaa authentication ppp default local

 !--- PPP コールの基本的な AAA 設定

 enable secret 5 <deleted>

 !

 username admin password <deleted>

 username maui-nas-05 password cisco

 !--- リモート ルータのユーザ名(maui-nas-05)およびshared secret

 !---(CHAP 認証用に使用)

 !--- shared secretは両側で同一にする必要がある。

 ip subnet-zero

 !

 isdn switch-type basic-ni

 !

 interface Loopback0

  ip address 172.17.1.1 255.255.255.0

 !--- このループバック アドレスはOSPFのルータIDとして使用される。

 !

 interface Ethernet0

  ip address 172.16.1.1 255.255.255.0

 !

 interface Serial0

  no ip address

  shutdown

  no fair-queue

 !

 interface BRI0

 !--- DDR ダイヤルアウト用に使用される BRI インターフェイス

  ip address 172.20.10.2 255.255.255.0

 !--- IP アドレス

 !--- リモート アドレスは同じサブネットに存在する。

  encapsulation ppp

  ip ospf demand-circuit

 !--- DDR リンクの停止時に、OSPF にルーティング テーブルを元の状態のまま維持

 !--- させる。 この設定は、ポイントツーポイント

 !--- リンクの片方のルータだけに設定する。

  dialer idle-timeout 900

 !--- アイドル タイムアウトが 900 秒(15 分)に設定される。

 !--- 900 秒間対象トラフィックがない場合、このリンクは

 !--- 切断される。

  dialer map ip 172.20.10.1 name maui-nas-05 broadcast 5551111

  dialer map ip 172.20.10.1 name maui-nas-05 broadcast 5551112

 !--- リモート ルータ用のダイヤラ マップ ステートメント

 !--- name はリモート ルータ自身を識別するために、リモート ルータが使用する名前と一致させる

 !--- 必要がある。 broadcast キーワードは、(OSPF 用の)リンク上でブロードキャスト トラフィックを

 !--- 送信するために必要になる。 2 種類の電話番号は、

 !--- リモート側の複数のチャネルに対応する。 複数のステートメントによって、

 !--- 最初の番号が通話中の場合に

 !--- ルータは次の番号にダイヤルできるようになる。

  dialer load-threshold 80 outbound

 !--- これは、追加のコネクションがマルチリンク PPP バンドルに追加されるときに

 !--- トラフィックのロード レベルを設定する。
!--- ロード レベルの値の範囲は 1(未ロード)〜 255(すべてロード) !--- この場合のしきい値は 80/255 = 32%
dialer-group 1 !--- 対象トラフィックの定義をダイヤラリスト 1 から適用する。 isdn switch-type basic-ni isdn spid1 51255522220101 5552222 isdn spid2 51255522230101 5552223 ppp authentication chap !--- CHAP 認証を使用する。 ppp multilink !--- マルチリンクを使用して両方の BRI チャネルを始動する。 ! router ospf 5 log-adjacency-changes network 172.16.1.0 0.0.0.255 area 0 network 172.17.1.0 0.0.0.255 area 0 network 172.20.10.0 0.0.0.255 area 0 ! ip classless ip route 172.20.0.0 255.255.0.0 172.20.10.0 no ip http server ! access-list 101 remark Define Interesting Traffic access-list 101 deny ospf any any !--- OSPF を対象外としてタグ付けする。 !--- これにより OSPF の hello がリンクアップ状態で維持されないようにする。 access-list 101 permit ip any any dialer-list 1 protocol ip list 101 !--- access-list 101 で対象トラフィックが定義されている。 !--- これは dialer-group 1 を使用する BRI0 に適用される。 ! line con 0 exec-timeout 0 0 login authentication NO_AUTHEN transport input none line vty 0 4 ! end
maui-nas-05 (3640)
maui-nas-05#show running-config 

 Building configuration...

 

 Current configuration:

 !

 version 12.1

 service timestamps debug datetime msec

 service timestamps log datetime msec

 !

 hostname maui-nas-05

 !

 aaa new-model

 aaa authentication login default local

 aaa authentication login NO_AUTHEN none

 aaa authentication ppp default local

 !--- PPP コールの基本的な AAA 設定

 enable secret 5 <deleted>

 !

 username admin password 7 <deleted>

 username maui-soho-01 password 7 cisco

 !--- リモート ルータのユーザ名(maui-soho-01)および共有秘密

 !---(CHAP 認証用に使用)

 !--- 共有秘密は両側で同一にする必要がある。

 

 ip subnet-zero

 !

 isdn switch-type basic-ni

 !

 interface Loopback0

  ip address 172.22.1.1 255.255.255.0

 !--- このループバック アドレスはOSPFのルータIDとして使用される。

 !

 interface Ethernet0/0

  ip address 172.22.53.105 255.255.255.0

 !

 interface Ethernet0/1

  no ip address

  shutdown

 !

 interface BRI1/0

 !--- BRI インターフェイスはダイヤルインの受け入れに使用される。

  ip address 172.20.10.1 255.255.255.0

 !--- IP アドレス

 !--- リモート アドレスは同じサブネットに存在する。

  encapsulation ppp

  dialer idle-timeout 900

 !--- アイドル タイムアウトが 900 秒(15 分)に設定されている。

 !--- この値をクライアント側のアイドルタイムアウトと同等か、

 !--- またはそれ以上に設定する。 クライアント側のアイドルタイムアウト値より大きい値にしておくと、

 !--- クライアント側でリンクの停止時期を指定できる。

 !

  dialer map ip 172.20.10.2 name maui-soho-01 broadcast

 !--- リモート ルータの BRI インターフェイス用のダイヤラ マップ ステートメント

 !--- name はリモート ルータ自身を識別するために、

 !--- リモート ルータが使用する名前にする必要がある。 broadcast キーワードは、

 !---(OSPF 用の)リンク上でブロードキャスト トラフィックを

 !--- 送信するために必要になる。: こちら側がダイヤルするように構成していない場合、

 !--- 電話番号はない。 このルータにダイヤルさせる場合、

 !--- リモート側の電話番号をダイヤラ マップ ステートメントに追加する。

  dialer-group 1

 !--- 対象トラフィックの定義をダイヤラリスト 1 から適用する。

  isdn switch-type basic-ni

  isdn spid1 51255511110101 5551111

  isdn spid2 51255511120101 5551112

  ppp authentication chap

  ppp multilink

 !--- マルチリンク コネクションを許可。

 !

 ! <<使用されていないインターフェイス構成は省略しています。

 !

 router ospf 5

  network 172.20.10.0 0.0.0.255 area 0

  network 172.22.1.0 0.0.0.255 area 0

  network 172.22.53.0 0.0.0.255 area 0

  default-information originate always

 !--- OSPF デフォルト情報を転送する。

 !--- リモート ルータに BRI DDR リンクを使用させるために必要になる場合がある。

 !

 ip classless

 ip route 0.0.0.0 0.0.0.0 Ethernet0/0

 ip route 172.22.0.0 255.255.0.0 172.22.53.0

 no ip http server

 !

 dialer-list 1 protocol ip permit

 !--- すべての IP トラフィックが対象として定義される。

 !--- これは dialer-group 1を使用する BRI0 に適用される。

 !

 line con 0

  login authentication NO_AUTHEN

  transport input none

 line 97 102

 line aux 0

 line vty 0 4

 !

 end

 

:ルータが OSPF ポーントツーポイント トポロジ(2 つのルータ)の一部になっている場合、デマンド回線の一方の終端だけを ip ospf demand-circuit コマンドで構成する必要があります。 しかし、すべてのルータがロードされたエリア内にこの機能を備える必要があり、ip ospf demand-circuit コマンドをサポートする必要があります。 ルータが OSPF ポイントツーマルチポイント トポロジの一部になっている場合(たとえばハブおよびスポーク)、マルチポイントの終端だけをこのコマンドで構成する必要があります。

debug コマンドおよび show コマンド
  • show dialer [interface type number] :DDR 用に構成されたインターフェイスの一般的な診断情報、タイマー構成、およびコネクションがタイムアウトするまでの時間を表示する。 次のメッセージを確認します。
    • "Dialer state is data link layer up" :ダイヤラが正常に起動している。
      • "Physical layer up" :回線プロトコルは起動しているが、ネットワーク制御プログラム(NCP)が起動していない。
    • "Dial reason" :ダイヤリングを開始するパケットの発信元アドレスと宛先アドレスを表示する。

  • show isdn status :確実にルータと ISDN スイッチとを正常に通信させる。 このコマンドは、アクティブ コールの番号も表示します。次のメッセージを確認します。
    • "Layer 1 Status is ACTIVE",
    • "Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED"

    詳細については、show isdn status コマンドを使用しての BRI のトラブルシューティング を参照してください。

  • show caller user username detail :詳細な LCP ネゴシエート パラメータを表示。

  • debug isdn q931 :ISDN ネットワーク コネクション(レイヤ 3)のコール設定と解除を表示。
  • debug isdn q921 :ルータと ISDN スイッチ間の D チャネルにおけるデータ リンク層のメッセージ(レイヤ 2)を表示する。 show isdn status コマンドがレイヤ 1 およびレイヤ 2 の起動を表示しない場合に、このデバックを使用します。
  • debug dialer [events | packets] :ダイヤラ インターフェイスで受信されたパケットの DDR デバッグ情報を表示。
  • debug ppp negotiation :PPP トラフィックとエクスチェンジの情報を、リンク制御プロトコル(LCP)、認証、および NCP を含む PPP コンポーネントのネゴシエート中に表示する。 成功した PPP ネゴシエーションが最初に LCP ステートを開いて認証し、最後に NCP(通常 IPCP)をネゴシエートします。
  • debug ppp authentication :Challenge Authentication Protocol(CHAP)パケット エクスチェンジとパスワード認証プロトコル(PAP)エクスチェンジを含む PPP 認証プロトコルのメッセージを表示。
  • debug ppp error :PPP コネクションのネゴシエーションとオペレーションに関連したプロトコル エラーとエラー統計を表示。

この DDR コネクションのトラブルシューティングに関する詳細は、ダイヤルアップ テクノロジー:トラブルシューティング テクニックを参照してください。

show および debug の出力例
デバッグの出力は、リモート ルータの BRI インターフェイスに対する ICMP ping によって発生した DDR コールを表示します。 デバッグは、SOHO ルータのダイヤリング、セントラル サイトへの接続、PPP のネゴシエーション、および CHAP 認証の実行を表示します。
maui-soho-01#debug dialer

 Dial on demand events debugging is on

 maui-soho-01#debug ppp negotiation

 PPP protocol negotiation debugging is on

 maui-soho-01#debug ppp authentication

 PPP authentication debugging is on

 maui-soho-01#debug isdn q931

 ISDN Q931 packets debugging is on

 maui-soho-01#

 maui-soho-01#

 maui-soho-01#

 maui-soho-01#ping 172.20.10.1

 

 Type escape sequence to abort.

 Sending 5, 100-byte ICMP Echos to 172.20.10.1, timeout is 2 seconds:

 

 *Mar  1 21:57:42.625: BR0 DDR: Dialing cause ip (s=172.20.10.2, d=172.20.10.1)

 !--- 172.20.10.1 に向けられた ping は BRI にダイヤルする。

 *Mar  1 21:57:42.629: BR0 DDR: Attempting to dial 5551111

 !--- ダイヤルされたリモート ルータの電話番号。

 *Mar  1 21:57:42.653: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x09

 *Mar  1 21:57:42.661:         Bearer Capability i = 0x8890

 *Mar  1 21:57:42.669:         Channel ID i = 0x83

 *Mar  1 21:57:42.677:         Keypad Facility i = '5551111'

 *Mar  1 21:57:43.002: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x89

 *Mar  1 21:57:43.010:         Channel ID i = 0x89

 *Mar  1 21:57:43.189: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x89

 *Mar  1 21:57:43.216: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

 *Mar  1 21:57:43.236: BR0:1 PPP: Treating connection as a callout

 !--- PPP ネゴシエーション開始。

 *Mar  1 21:57:43.236: BR0:1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]

 *Mar  1 21:57:43.248: BR0:1 LCP: O CONFREQ [Closed] id 10 len 34

 *Mar  1 21:57:43.252: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)

 *Mar  1 21:57:43.256: BR0:1 LCP:    MagicNumber 0x153BEFE7 (0x0506153BEFE7)

 *Mar  1 21:57:43.260: BR0:1 LCP:    MRRU 1524 (0x110405F4)

 *Mar  1 21:57:43.268: BR0:1 LCP:    EndpointDisc 1 Local

  (0x130F016D6175692D736F686F2D3031)

 *Mar  1 21:57:43.280: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x09

 *Mar  1 21:57:43.300: BR0:1 LCP: I CONFREQ [REQsent] id 7 Len 33

 *Mar  1 21:57:43.304: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)

 *Mar  1 21:57:43.308: BR0:1 LCP:    MagicNumber 0x354AAC53 (0x0506354AAC53)

 *Mar  1 21:57:43.312: BR0:1 LCP:    MRRU 1524 (0x110405F4)

 *Mar  1 21:57:43.320: BR0:1 LCP:    EndpointDisc 1 Local

  (0x130E016D6175692D6E61732D3035)

 *Mar  1 21:57:43.327: BR0:1 LCP: O CONFACK [REQsent] id 7 Len 33

 *Mar  1 21:57:43.331: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)

 *Mar  1 21:57:43.335: BR0:1 LCP:    MagicNumber 0x354AAC53 (0x0506354AAC53)

 *Mar  1 21:57:43.339: BR0:1 LCP:    MRRU 1524 (0x110405F4)

 *Mar  1 21:57:43.347: BR0:1 LCP:    EndpointDisc 1 Local

  (0x130E016D6175692D6E61732D3035)

 *Mar  1 21:57:43.359: BR0:1 LCP: I CONFACK [ACKsent] id 10 Len 34

 *Mar  1 21:57:43.363: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)

 *Mar  1 21:57:43.367: BR0:1 LCP:    MagicNumber 0x153BEFE7 (0x0506153BEFE7)

 *Mar  1 21:57:43.371: BR0:1 LCP:    MRRU 1524 (0x110405F4)

 *Mar  1 21:57:43.379: BR0:1 LCP:    EndpointDisc 1 Local

  (0x130F016D6175692D736F686F2D3031)

 *Mar  1 21:57:43.383: BR0:1 LCP: State is Open

 *Mar  1 21:57:43.383: BR0:1 PPP: Phase is AUTHENTICATING, by both

  [0 sess, 1 load]

 !--- PPP 認証開始。

 *Mar  1 21:57:43.391: BR0:1 CHAP: O CHALLENGE id 6 Len 33 from "maui-soho-01"

 !--- リモート ルータへの発信チャレンジ。

 !--- このユーザ名は、リモート ルータのダイヤラ マップ ステートメントで

 !--- 設定されている必要があります。

 *Mar  1 21:57:43.399: BR0:1 CHAP: I CHALLENGE id 6 Len 32 from "maui-nas-05"

 !--- リモート ルータからの着信チャレンジ

 !--- このユーザ名は、自身のダイヤラ マップ ステートメントでOSPFのルータIDとして。

 *Mar  1 21:57:43.415: BR0:1 CHAP: O RESPONSE id 6 Len 33 from "maui-soho-01"

 *Mar  1 21:57:43.443: BR0:1 CHAP: I SUCCESS id 6 Len 4

 !--- 着信 CHAP 認証成功。

 *Mar  1 21:57:43.450: BR0:1 CHAP: I RESPONSE id 6 Len 32 from "maui-nas-05"

 *Mar  1 21:57:43.466: BR0:1 CHAP: O SUCCESS id 6 Len 4

 !--- 発信 CHAP 認証成功。

 *Mar  1 21:57:43.474: BR0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]

 *Mar  1 21:57:43.581: Vi1 PPP: Phase is DOWN, Setup [0 sess, 1 load]

 *Mar  1 21:57:43.601: BR0:1 IPCP: Packet buffered while building

  MLP bundle interface

 *Mar  1 21:57:43.605: BR0:1 CDPCP: Packet buffered while building

  MLP bundle interface

 *Mar  1 21:57:43.609: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

 !--- 仮想アクセス インターフェイスが自動生成される(マルチリンクに必要)。

 *Mar  1 21:57:43.613: Vi1 DDR: Dialer statechange to up

 *Mar  1 21:57:43.617: Vi1 DDR: Dialer call has been placed

 *Mar  1 21:57:43.625: Vi1 PPP: Treating connection as a callout

 *Mar  1 21:57:43.625: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]

 *Mar  1 21:57:43.637: Vi1 LCP: O CONFREQ [Closed] id 1 Len 34

 *Mar  1 21:57:43.641: Vi1 LCP:    AuthProto CHAP (0x0305C22305)

 *Mar  1 21:57:43.645: Vi1 LCP:    MagicNumber 0x153BF171 (0x0506153BF171)

 *Mar  1 21:57:43.649: Vi1 LCP:    MRRU 1524 (0x110405F4)

 *Mar  1 21:57:43.653: Vi1 LCP:    EndpointDisc 1 Local

  (0x130F016D6175692D736F686F2D3031)

 *Mar  1 21:57:43.665: Vi1 PPP: Phase is UP [0 sess, 1 load]

 *Mar  1 21:57:43.677: Vi1 IPCP: O CONFREQ [Closed] id 1 Len 10

 *Mar  1 21:57:43.681: Vi1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)

 *Mar  1 21:57:43.693: Vi1 CDPCP: O CONFREQ [Closed] id 1 Len 4

 *Mar  1 21:57:43.697: BR0:1 MLP: maui-nas-05, multilink up, first link

 *Mar  1 21:57:43.700: Vi1 PPP: Pending ncpQ size is 2

 *Mar  1 21:57:43.700: BR0:1 IPCP: Redirect packet to Vi1

 *Mar  1 21:57:43.708: Vi1 IPCP: I CONFREQ [REQsent] id 1 Len 10

 *Mar  1 21:57:43.712: Vi1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)

 *Mar  1 21:57:43.716: Vi1 IPCP: O CONFACK [REQsent] id 1 Len 10

 *Mar  1 21:57:43.724: Vi1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)

 *Mar  1 21:57:43.728: BR0:1 CDPCP: Redirect packet to Vi1

 *Mar  1 21:57:43.732: Vi1 CDPCP: I CONFREQ [REQsent] id 1 Len 4

 *Mar  1 21:57:43.736: Vi1 CDPCP: O CONFACK [REQsent] id 1 Len 4

 *Mar  1 21:57:43.744: Vi1 IPCP: I CONFACK [ACKsent] id 1 Len 10

 *Mar  1 21:57:43.752: Vi1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)

 *Mar  1 21:57:43.756: Vi1 IPCP: State is Open

 !--- IPCP ステートのオープン。

 *Mar  1 21:57:43.764: Vi1 CDPCP: I CONFACK [ACKsent] id 1 Len 4

 *Mar  1 21:57:43.768: Vi1 CDPCP: State is Open

 *Mar  1 21:57:43.772: Vi1 DDR: dialer protocol up

 *Mar  1 21:57:43.784: BR0 IPCP: Install route to 172.20.10.1

 !--- リモート側へのルートを設定する。

 *Mar  1 21:57:44.462: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,

  changed state to up

 *Mar  1 21:57:44.657: %LINEPROTO-5-UPDOWN: Line protocol on Interface

  Virtual-Access1, changed state to up

 *Mar  1 21:57:49.180: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to

  5551111 maui-nas-05

 !--- BRI ダイヤル オンデマンド ルーティング(DDR)リンクが稼動中。

 maui-soho-01#

 
show ip route コマンドは、DDR リンクの始動後に SOHO のルーティング テーブルを表示する。 リモート サイトからの OSPF ルートが設定されていることに注意する。
maui-soho-01#show ip route

 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

        i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area

        * - candidate default, U - per-user static route, o - ODR

        P - periodic downloaded static route

 

 Gateway of last resort is 172.20.10.1 to network 0.0.0.0

 

      172.17.0.0/24 is subnetted, 1 subnets

 C       172.17.1.0 is directly connected, Loopback0

      172.16.0.0/24 is subnetted, 1 subnets

 C       172.16.1.0 is directly connected, Ethernet0

      172.20.0.0/16 is variably subnetted, 3 subnets, 3 masks

 C       172.20.10.0/24 is directly connected, BRI0

 C       172.20.10.1/32 is directly connected, BRI0

 S       172.20.0.0/16 [1/0] via 172.20.10.0

      172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks

 O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:01:37, BRI0

 O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:01:37, BRI0

 O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:01:37, BRI0

 

:リモート サイトからの OSPF ルート(特にデフォルトのルート)がルーティング テーブルに追加されています。 これで、クライアント(maui-soho-01)はリンク上にトラフィックを送信する必要があるときに、いつでも BRI リンクにダイヤルできるようになります。 これが OSPF デマンド回線であるため、dialer idle-timeout の期限切れでリンクが停止してもルーティング テーブルの OSPF エントリは削除されません(古くなった状態)。

show caller user username detail の出力で、コネクションにアイドル タイムアウトを通知します。

maui-soho-01#show caller user maui-nas-05 detail

 

   User: maui-nas-05, line BR0:1, service PPP

         Active time 00:02:33, Idle time 00:00:00

   Timeouts:            Absolute  Idle

       Limits:          -         -

       Disconnect in:   -         -

   PPP: LCP Open, multilink Open, CHAP (AAA <--> AAA)

   LCP: -> peer, AuthProto, MagicNumber, MRRU, EndpointDisc

        <- peer, AuthProto, MagicNumber, MRRU, EndpointDisc

   NCP: Closed IPCP, CDPCP

   Dialer: Connected to 5551111, outbound

           Type is ISDN, group BR0

           Cause: ip (s=172.20.10.2, d=172.20.10.1)

   IP: Local 172.20.10.2/24

   Bundle: Member of maui-nas-05, last input 00:00:00

   Counts: 945 packets input, 147302 bytes, 0 no buffer

           0 input errors, 0 CRC, 0 frame, 0 overrun

           972 packets output, 150964 bytes, 0 underruns

           0 output errors, 0 collisions, 0 interface resets

 

   User: maui-nas-05, line Vi1, service PPP Bundle

         Active time 00:02:32, Idle time 00:02:32

   Timeouts:            Absolute  Idle

       Limits:          -         00:15:00

       Disconnect in:   -         00:12:26  

 !--- このコールが対象トラフィックを受信しなければ、この時間を過ぎると、

 !--- コールは切断される。

   PPP: LCP Open, multilink Open, IPCP, CDPCP

   LCP: -> peer, MagicNumber, MRRU, EndpointDisc

        <- peer

   NCP: Open IPCP, CDPCP

   IPCP: <- peer, Address

         -> peer, Address

   Dialer: Connected to 5551111, outbound

           Idle timer 900 secs, idle 153 secs

           Type is IN-BAND SYNC, group BR0

   IP: Local 172.20.10.2/24, remote 172.20.10.1

   Bundle: First link of maui-nas-05, 1 link, last input 00:02:33

   Counts: 20 packets input, 2916 bytes, 0 no buffer

           0 input errors, 0 CRC, 0 frame, 0 overrun

           23 packets output, 2683 bytes, 0 underruns

           0 output errors, 0 collisions, 0 interface resets

 


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報
Document ID: 10226