ブロードバンド ケーブル : ケーブル モデム

Cisco製ではないケーブル モデムに接続された Cisco ルータの設定方法

2002 年 6 月 5 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 5 月 23 日) | フィードバック

目次


概要

シスコ製ではない Cable Modem(CM; ケーブル モデム)を使用しており、この CM にブリッジング機能しかない環境下で、Cisco 806 などの Cisco ルータを、イーサネット インターフェイスを介してケーブル モデムに接続できます。この場合、ケーブル モデムの背後にある Cisco ルータによってルーティングが行われ、クライアント PC または Customer Premises Equipment(CPE; 顧客宅内機器)を Cisco ルータに接続できます。Network Address Translation(NAT; ネットワーク アドレス変換)は Cisco ルータで設定できます。下記のネットワーク ダイアグラムを参照してください。

背景理論

Cisco ルータがケーブル モデムに接続されている場合、最初に起こりうる問題として、Cisco ルータのイーサネット インターフェイスで IP アドレスを動的に取得できないことが考えられます。ほとんどの Internet Service Provider(ISP; インターネット サービス プロバイダー)は、ケーブル モデムの背後で 1 台のホストまたは PC のみの使用を許可しています。ホスト名に基づいて IP アドレスを PC に割り当てる ISP もあります。したがって、Cisco ルータをケーブル モデムの背後に設置する場合は、hostname コマンドを使用してルータのホスト名をISP によって与えられたホスト名と同一に設定する必要があります。

Cisco ルータで IP アドレスが動的に取得されない場合は、最初に、CM に接続されたイーサネット インターフェイスに次のインターフェイス設定コマンドが存在するかどうかを確認する必要があります。

ip address dhcp

このコマンドは、Cisco IOS(R) ソフトウェア リリース 12.1(2)T で初めて導入されました。

上記のコマンドが存在するにもかかわらず、CM の背後にある Cisco ルータが IP アドレスを取得しない場合は、CM の背後に PC を接続して、PC が IP アドレスを取得するかどうかを調べます。PC が IP アドレスを取得する場合は、DHCP サービスが正常に動作しています。ISP は通常 CM の背後で 1 台のホストのみの使用を許可するため、CM の背後にある PC から接続した場合は、これが 1 台目のホストとして数えられる点に注意してください。このエントリは ISP のデータベースに 24 時間残ります。したがって、CM の背後にある Cisco ルータから接続を試みた場合、ISP はこのルータを 2 台目のホストと見なして接続を拒否します。この場合は、Windows 2000 PC から次のコマンドを実行し、PC の IP アドレスの解放を試みます。

Start メニューから Run を選択し、cmd と入力してリターンを押します。プロンプトが表示されたら次のように入力します。

ipconfig/release

PC の IP アドレスが解放されたら、CM をリブートして再度接続を試みます。それでもうまくいかない場合は、ISP に連絡し、CMTS 上の最初のホスト エントリを削除するように依頼する必要があります。

もう 1 つの方法は、次のコマンドを使用して、CM に接続する Cisco ルータのイーサネット インターフェイスに、PC の MAC アドレスを設定する方法です。

mac-address ieee-address

CM に接続するイーサネット インターフェイスで PC と同じ MAC アドレスを使用すれば、ISP では 1 つのホストと 1 つの IP アドレスのみが存在すると認識されるため、Cisco ルータの背後から接続した後も PC が拒否されません。IP アドレスを変換するには、Cisco ルータで NAT を設定する必要があります。

設定

この設定で使用するコンポーネント

この設定は、次のバージョンのソフトウェアとハードウェアを使用して開発およびテストされています。
  • Cisco IOS リリース 12.2(2)XI が動作する Cisco 806 シリーズ ルータ

  • ブリッジとして動作するケーブル モデム ルータ

  • CPE として動作する、Windows 2000 が搭載された PC

  • uBR7246VXR CMTS
注:ここでは Cisco 806 ルータの設定のみを示します。CMTS の設定の詳細については、「ケーブル テクノロジーに関するテクニカル ティップス」を参照してください。

このドキュメントの情報は、特定のラボ環境にある装置に基づいて作成されています。このドキュメントで使用されている装置はすべて、クリアーな状態(デフォルト)から設定作業を始めています。稼働中のネットワークで作業する場合は、どのコマンドを使用する際にも、そのコマンドによって生じる可能性のある影響に充分注意してください。

ネットワーク ダイアグラム

ネットワーク ダイアグラム

設定例

注:!-- コメントは青で示します。
 
806 ルータの設定
Building configuration...

Current configuration : 1673 bytes

!

version 12.2

no parser cache

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

logging rate-limit console 10 except errors

enable secret 5 $1$1m1W$uRyUMZQpUAp31C9OM2HQR.

!

username Router password 7 08325C5C00170247425D5506382E2523

username Cisco privilege 15 password 7

134146563C5D020B6F2B793C060703061E2A16706F7E62470C3416

ip subnet-zero

ip name-server 24.29.99.81

ip name-server 24.29.99.82

ip dhcp excluded-address 10.10.10.1 !-- DHCP サーバによって IP アドレスが割り当てられないようにするため、ip dhcp excluded-address を使用します。

これにより、E0 の IP アドレスが除外されます。.

ip dhcp excluded-address 10.10.10.2

ip dhcp excluded-address 10.10.10.10

ip dhcp excluded-address 10.10.10.3

ip dhcp excluded-address 10.10.10.4

ip dhcp excluded-address 10.10.10.5

ip dhcp excluded-address 10.10.10.6

ip dhcp excluded-address 10.10.10.7

ip dhcp excluded-address 10.10.10.8

ip dhcp excluded-address 10.10.10.9

!

ip dhcp pool CLIENT !-- DHCP アドレス プールを設定します。  

import all

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 24.29.99.82

!

no ip dhcp-client network-discovery

lcp max-session-starts 0

!

!

!

interface Ethernet0 !-- このインターフェイスは CPE を含む内部ネットワークに接続します。

ip address 10.10.10.1 255.255.255.0

ip nat inside !-- IP NAT の設定。

no ip route-cache

no cdp enable

!

interface Ethernet1 !-- このインターフェイスは CM と同じイーサネット セグメントに接続します。 

ip address dhcp !-- このコマンドにより、ルータが IP アドレスを動的に取得できます。

ip nat outside !--IP NAT の設定。

no ip route-cache

no cdp enable

!

ip nat inside source list 102 interface Ethernet1 overload !--IP NAT の設定。

ip classless

ip route 0.0.0.0 0.0.0.0 66.108.112.1

!-- IP アドレス 66.108.112.1 はネクストホップ IP アドレスであり、デフォルト ゲートウェイとも呼ばれます。

!-- どの IP アドレスをネクストホップ アドレスとして設定すべきかについては、ISP から指示されます。

ip http server

!

access-list 102 permit ip 10.10.10.0 0.0.0.255 any

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 4

exec-timeout 30 0

login local

length 0

!

scheduler max-task-time 5000

end

Router#

検証

この項では、設定が正常に動作しているかどうかを確認する際に役立つ情報を示します。

Cisco 806 ルータがイーサネット E1 で動的に IP アドレスを取得したことを確認するため、show ip interface brief コマンドを発行します。

Router#show ip interface brief

Interface                  IP-Address      OK?Method Status Protocol
Ethernet0                  10.10.10.1      YES NVRAM  up    up
Ethernet1                  66.108.115.5    YES DHCP   up      up

ルーティング テーブルのエントリが正しいことを確認します。たとえば、次の表示には 66.108.112.1 へのデフォルト ルートが示されています。これは、ルータがイーサネット インターフェイスで IP アドレスを受け取ったときに、DHCP プロセスを通じてインストールされたルートです。

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 66.108.112.1 to network 0.0.0.0
66.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       66.0.0.0/8 is directly connected, Ethernet1
C       66.108.112.0/21 is directly connected, Ethernet1
10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 66.108.112.1

トラブルシューティング用のコマンド

注:debug コマンドを発行する前に、「debug コマンドに関する重要な情報」を参照してください。
  • debug dhcp detail

  • debug ip dhcp server [events] [linkage] [packet]
debug dhcp detail コマンドは、DHCP デバッグ情報を表示するために使用します。このデバッグ情報は、Cisco ルータがイーサネット インターフェイスの IP アドレスの取得に失敗した原因を調べるために利用できます。

debug ip dhcp server コマンドは、DHCP サーバのデバッグを表示するために使用します。これは、Cisco ルータに接続された PC が IP アドレスの取得に失敗した原因を調べるために利用できます。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 19268