マルチプロトコル ラベル スイッチング(MPLS) : MPLS

IS-IS を使用した MPLS の基本設定

2002 年 6 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 11 月 16 日) | フィードバック

概要

この設定例は、Virtual Private Network(VPN; バーチャル プライベート ネットワーク)や トラフィック エンジニアリングなどの後続の作業のために Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ネットワークをセットアップする方法について示しています(詳細については「MPLS に関するサポートページ」に掲載されている、これらの設定例を参照してください)。

メカニズム

一般に MPLS ネットワークは、Label Switch Router(LSR; ラベル スイッチ ルータ)と呼ばれる MPLS 対応のルータから成るバックボーン ネットワークです。通常このネットワークは、コア LSR とエッジ LSR から構成されており、エッジ LSR がパケットにラベルを付加します。

MPLS ネットワークのセットアップ メカニズムは次のとおりです。

  1. それぞれの LSR のルーティング テーブルが、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)を使用して計算されます。MPLS トラフィック エンジニアリングを導入する場合は、Open Shortest Path First(OSPF)や Intermediate System-to-Intermediate System(IS-IS)などのリンクステート プロトコルが必要です。

  2. Label Distribution Protocol(LDP; ラベル配布プロトコル)によって経路とラベルのバインディングがアドバタイズされます。これらのバインディングはルーティング テーブルと照らし合わせてチェックされます。LDP を通じて学習された経路(プレフィクス/マスクとネクストホップ)が、IGP を通じて学習されたルーティング テーブル内の経路と一致した場合は、LSR の Label Forwarding Information Base(LFIB; ラベル転送情報ベース)内にエントリが作成されます。

LSR の転送メカニズムは次のとおりです。

  1. エッジ LSR がラベルのないパケットを受信すると、Cisco Express Forwarding(CEF)テーブルがチェックされ、必要に応じてパケットにラベルが付加されます。この LSR を入力 LSR と呼びます。

  2. コア LSR の着信インターフェイスにラベル付きのパケットが到達すると、LFIB に基づいて発信インターフェイスと新しいラベルが提供され、発信パケットに関連付けられます。

  3. 最後の LSR の前に位置するルータ(ペナルティメイト ホップ)がラベルを取り除き、ラベルなしでパケットを送信します。最後のホップを出力 LSR と呼びます。

次の図は、このネットワークのセットアップの仕組みを示しています。

ネットワーク ダイアグラム

ハードウェアとソフトウェアのバージョン

この設定は、次のバージョンのソフトウェアとハードウェアを使用して開発、テストされています。

  • Cisco IOS(R) ソフトウェア リリース 12.0(11)S および 12.1(3a)T

  • Cisco 3600 ルータ

ネットワーク ダイアグラム

ネットワーク ダイアグラム

設定例

クイック コンフィギュレーション ガイド

  1. ネットワークを通常どおりセットアップします(MPLS では、転送ベースを作成するために標準の IP 接続が必要です)。

  2. ルーティング プロトコル(OSPF または IS-IS)が正常に動作していることを確認します。これらのコマンドには、下記の設定内で下線が引かれています。

  3. 一般設定モードで ip cef(使用可能ならば、 ip cef distributedを使用するとパフォーマンスを改善することができます。)を有効にします(下記の設定内で太字になっています)。

  4. 一般設定モードで各インターフェイスに対して mpls ip(古い IOS バージョンの場合は tag-switching ip)を有効にします(下記の設定内で太字になっています)。

注:LSR には、32 ビットのアドレス マスクを持つ(アップしている)ループバック インターフェイスが必要です。

コンフィギュレーション ファイル

Pomerol
Current configuration:

  !

  version 12.0

  !

  hostname Pomerol

  !

  ip cef

  !

  interface Loopback0

   ip address 10.10.10.3 255.255.255.255

   ip router isis

  !

  interface Serial0/1

   encapsulation frame-relay

  !

  interface Serial0/1.1 point-to-point

   ip address 10.1.1.6 255.255.255.252

   ip router isis

   tag-switching ip

   frame-relay interface-dlci 301

  !

  interface Serial0/1.2 point-to-point

   ip address 10.1.1.9 255.255.255.252

   ip router isis

   tag-switching ip

   frame-relay interface-dlci 303

  !

  interface Serial0/1.3 point-to-point

   ip address 10.1.1.21 255.255.255.252

   ip router isis

   tag-switching ip

   frame-relay interface-dlci 306

  !

  router isis

   net 49.0001.0000.0000.0003.00

   is-type level-1

  !

  ip classless

  !

  end

 
Pulligny
Current configuration:

  !

  version 12.1

  !

  hostname Pulligny

  !

  ip cef

  !

  interface Loopback0

   ip address 10.10.10.2 255.255.255.255

  !

  interface Serial0/1

   no ip address

   encapsulation frame-relay

  !

  interface Serial0/1.1 point-to-point

   ip address 10.1.1.2 255.255.255.252

   ip router isis

   tag-switching ip

   frame-relay interface-dlci 201

  !

  interface Serial0/1.2 point-to-point

   ip address 10.1.1.10 255.255.255.252

   ip router isis

   tag-switching ip

   frame-relay interface-dlci 203

  !

  router isis

   redistribute static ip

   passive-interface Loopback0

   net 49.0001.0000.0000.0002.00

   is-type level-1

  !

  ip classless

  !

  end

 
Pauillac
Current configuration : 2366 bytes

  !

  version 12.1

  !

  hostname pauillac

  !

  ip cef

  !

  interface Loopback0

   ip address 10.10.10.1 255.255.255.255

   ip router isis

  !

  interface Serial0/0

   no ip address

   encapsulation frame-relay

  !

  interface Serial0/0.1 point-to-point

   ip address 10.1.1.1 255.255.255.252

   ip router isis

   tag-switching ip

   frame-relay interface-dlci 102

  !

  interface Serial0/0.2 point-to-point

   ip address 10.1.1.5 255.255.255.252

   ip access-group 150 out

   ip router isis

   tag-switching ip

   frame-relay interface-dlci 103

  !

  interface Serial0/0.3 point-to-point

   bandwidth 512

   ip address 10.1.1.13 255.255.255.252

   ip router isis

   tag-switching ip

   frame-relay interface-dlci 104

  !

  interface Serial0/0.4 point-to-point

   ip address 10.1.1.17 255.255.255.252

   ip router isis

   tag-switching ip

   frame-relay interface-dlci 105

  !

  !

  router isis

   net 49.0001.0000.0000.0001.00

   is-type level-1

   metric-style wide

  !

  ip classless

  !

  end

 

debug および show コマンド

debug コマンドを実行する前に、「debug コマンドに関する重要な情報」を参照してください。

  • show tag-switching tdp neighbor

  • show tag-switching tdp bindings

  • show tag-switching forwarding-table

  • show tag-switching forwarding-table a.b.c.d detail

  • traceroute a.b.c.d

コマンドをすべて網羅したリストは、「MPLS コマンド リファレンス」に掲載されています。その他の show コマンドの例については、「OSPF を使用した MPLS の基本設定」を参照してください。

debug の出力例

次の出力は LDP に関する部分に注目しています。IOS に現在実装されている LDP は Tag Distribution Protocol(TDP; タグ配布プロトコル)です。TDP にはシスコ独自の拡張が含まれていますが、ラベル配布用の IETF 公式プロトコルである LDP とともに使用できます。TDP は将来 LDP に置き換えられる予定です。

TDP の状態を確認するには、show tag-switching tdp * コマンドを使用します。次のように show tag-switching tdp neighbor を使用すれば、近接ルータの TDP 状態を表示できます。

Pulligny#show tag-switching tdp neighbor

 Peer TDP Ident: 10.10.10.1:0; Local TDP Ident 10.10.10.2:0

         TCP connection: 10.10.10.1.711 - 10.10.10.2.11001

         State: Oper; PIEs sent/rcvd: 27907/27925; ; Downstream

         Up time: 2w2d

         TDP discovery sources:

           Serial0/1.1

         Addresses bound to peer TDP Ident:

           10.1.1.1        10.1.1.13       10.1.1.17       10.10.10.1

           10.1.1.5        10.200.28.89

 Peer TDP Ident: 10.10.10.3:0; Local TDP Ident 10.10.10.2:0

         TCP connection: 10.10.10.3.11001 - 10.10.10.2.711

         State: Oper; PIEs sent/rcvd: 22893/22874; ; Downstream

         Up time: 1w6d

         TDP discovery sources:

           Serial0/1.2

         Addresses bound to peer TDP Ident:

           10.200.28.91    10.1.1.6        10.1.1.9        10.1.1.21

           10.10.10.3

 

ラベルと経路の間に設定されているバインディングを表示するには、show tag-switching tdp bindings を使用します。

Pulligny#show tag-switching tdp bindings

 (...)

   tib entry: 10.10.10.4/32, rev 22

         local binding:  tag: 21

         remote binding: tsr: 10.10.10.1:0, tag: 22

         remote binding: tsr: 10.10.10.3:0, tag: 25

   tib entry: 10.10.10.6/32, rev 51

         local binding:  tag: 23

         remote binding: tsr: 10.10.10.3:0, tag: 18

         remote binding: tsr: 10.10.10.1:0, tag: 20

 (...)

 

どのバインディングを使用して LFIB が作成されているかを確認するには、show tag-switching forwarding-table を使用します。

Pulligny#show tag-switching forwarding-table

 Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop

 tag    tag or VC   or Tunnel Id      switched   interface

 16     Pop tag     10.1.1.4/30       0          Se0/1.2    point2point

        Pop tag     10.1.1.4/30       0          Se0/1.1    point2point

 17     Pop tag     10.1.1.12/30      0          Se0/1.1    point2point

 18     Pop tag     10.1.1.16/30      0          Se0/1.1    point2point

 19     Pop tag     10.10.10.1/32     1394       Se0/1.1    point2point

 20     Pop tag     10.1.1.20/30      0          Se0/1.2    point2point

 21     22          10.10.10.4/32     12103      Se0/1.1    point2point

 22     Pop tag     10.10.10.3/32     88         Se0/1.2    point2point

 23     18          10.10.10.6/32     0          Se0/1.2    point2point

 24     21          10.10.10.5/32     67         Se0/1.1    point2point

 25     19          10.10.10.20/32    0          Se0/1.2    point2point

 

当然、show tag-switching forwarding-table 10.10.10.4 detail を使用して特定の宛先の詳細をチェックすることもできます。

Pulligny#show tag-switching forwarding-table 10.10.10.4 detail

 Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop

 tag    tag or VC   or Tunnel Id      switched   interface

 21     22          10.10.10.4/32     12103      Se0/1.1    point2point

         MAC/Encaps=4/8, MTU=1500, Tag Stack{22}

         30918847 00016000

     Per-packet load-sharing

 

最後に、ネットワークで IP TTL 伝搬(詳細については mpls ip ttl propagate を参照)を行っている場合は、traceroute を実行してもホップを表示できます。

Pesaro#traceroute 10.10.10.4

 

 Type escape sequence to abort.

 Tracing the route to 10.10.10.4

 

   1 10.1.1.21 [MPLS: Label 25 Exp 0] 296 msec 256 msec 244 msec

   2 10.1.1.5 [MPLS: Label 22 Exp 0] 212 msec 392 msec 352 msec

   3 10.1.1.14 436 msec *  268 msec

 

Quality of Service のためにEXPフィールドを使用している場合は、出力に Exp 0 が表示される点に注意してください。


関連情報


Updated: Jun 1, 2002Document ID: 13735

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 13735