IP : IP ルーティング

トラブルシューティング:「%TUN-5-RECURDOWN」エラー メッセージと、GRE トンネル上での EIGRP/OSPF/BGP 近接ルータのフラッピング

2002 年 4 月 4 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2012 年 8 月 28 日) | フィードバック

目次


概要

エラー メッセージ「%TUN-5-RECURDOWN: Tunnel0 temporarily disabled due to recursive routing」は、Generic Routing Encapsulation(GRE)トンネル ルータが再帰的ルーティングの問題を検出したことを示しています。この状況は通常、次の 2 つのいずれかが原因で起こります。

  • 設定ミスのため、ルータがトンネル インターフェイス自体を使用してトンネルの宛先アドレスにルーティングしようとしている(再帰的ルーティング)。

  • ネットワーク内のどこかでルート フラッピングが発生しているため、一時的に不安定になっている。

トンネル インターフェイスのステータスはトンネルの宛先への IP 到達可能性によって決まります。ルータはトンネルの宛先に対する再帰的ルーティング障害を検出すると、その問題を引き起こした状況がルーティング プロトコルのコンバージェンスに伴って自然に解決するように、トンネル インターフェイスを数分間シャットダウンします。問題の原因が設定ミスの場合は、リンク がいつまでもフラッピングし続けるおそれがあります。

この問題のもう 1 つの症状は、Enhanced Interior Gateway Routing Protocol/Open Shortest Path First/Border Gateway Protocol(EIGRP/OSPF/BGP)近接ルータが GRE トンネル上にある場合、それらの近接ルータが継続的にフラッピングすることです。

このドキュメントは、EIGRP が動作しているトンネル インターフェイスが無期限のフラッピング状態に陥った場合のトラブルシューティングの例を示しています。

このドキュメントの情報は、特定のラボ環境にある装置に基づいて作成されています。このドキュメントで使用されている装置はすべて、クリアーな状態(デフォルト)から設定作業を始めています。稼働中のネットワークで作業する場合は、どのコマンドを使用する際にも、そのコマンドによって生じる可能性のある影響を事前に確実に理解してください。

ネットワーク ダイアグラム

ルータ 1(R1)とルータ 3(R3)はルータ 2(R2)に接続しています。R1 は R2 を経由して R3 のループバック インターフェイスに到達可能で、その逆も同様に到達できます。EIGRP は R1 と R3 のトンネル インターフェイス上で動作しています。R2 は EIGRP ドメインには参加していません。

設定例

R1
hostname R1

 !

 interface Loopback0

  ip address 10.1.1.1 255.255.255.0

 !

 interface Tunnel0

  ip address 192.168.1.1 255.255.255.0

  tunnel source Loopback0

  tunnel destination 10.3.3.3

 !

 interface Serial0

  ip address 172.16.15.1 255.255.255.0

  encapsulation ppp

 !

 router eigrp 1

  network 10.1.1.0 0.0.0.255

  network 192.168.1.0

  no auto-summary

 !

 ip route 0.0.0.0 0.0.0.0 172.16.15.2

 

R3
hostname R3

 !

 interface Loopback0

  ip address 10.3.3.3 255.255.255.0

 !

 interface Tunnel0

  ip address 192.168.1.3 255.255.255.0

  tunnel source Loopback0

  tunnel destination 10.1.1.1

 !

 interface Serial1

  ip address 172.16.25.3 255.255.255.0

 !

 router eigrp 1

  network 10.3.3.0 0.0.0.255

  network 192.168.1.0

  no auto-summary

 !

 ip route 0.0.0.0 0.0.0.0 172.16.25.2

 

観察

R1 と R3 で次のエラー メッセージが見られます。トンネル インターフェイスがアップとダウンを継続的に繰り返しています。

01:11:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up

 01:11:48: %TUN-5-RECURDOWN: Tunnel0 temporarily disabled due to recursive routing

 01:11:49: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down

 01:12:49: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up

 01:12:58: %TUN-5-RECURDOWN: Tunnel0 temporarily disabled due to recursive routing

 01:12:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to down

 

トラブルシューティング

次の出力は、トンネル インターフェイスがアップする前の、R1 でのトンネルの宛先 10.3.3.3 への経路を示しています。

R1#show ip route

 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

        * - candidate default, U - per-user static route, o - ODR

        P - periodic downloaded static route

 

 Gateway of last resort is 172.16.15.2 to network 0.0.0.0

 

      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

 C       172.16.15.2/32 is directly connected, Serial0

 C       172.16.15.0/24 is directly connected, Serial0

      10.0.0.0/24 is subnetted, 1 subnets

 C       10.1.1.0 is directly connected, Loopback0

 S*   0.0.0.0/0 [1/0] via 172.16.15.2

 

トンネルの宛先 10.3.3.3 には 172.16.15.2(Serial 0)を経由したデフォルト ルートを通じて到達できます。

次に、トンネル インターフェイスがアップした後のルーティング テーブルを示します。

R1#show ip route

 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

        * - candidate default, U - per-user static route, o - ODR

        P - periodic downloaded static route

 

 Gateway of last resort is 172.16.15.2 to network 0.0.0.0

 

      172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

 D       172.16.25.0/24 [90/297756416] via 192.168.1.3, 00:00:00, Tunnel0

 C       172.16.15.2/32 is directly connected, Serial0

 C       172.16.15.0/24 is directly connected, Serial0

      10.0.0.0/24 is subnetted, 2 subnets

 D       10.3.3.0 [90/297372416] via 192.168.1.3, 00:00:00, Tunnel0

 C       10.1.1.0 is directly connected, Loopback0

 C    192.168.1.0/24 is directly connected, Tunnel0

 S*   0.0.0.0/0 [1/0] via 172.16.15.2

 

トンネルの宛先 10.3.3.3 への経路は EIGRP を通じて学習されており、そのネクストホップはインターフェイス Tunnel 0 になっています。

この状況では、トンネルの宛先への最適パスはトンネル インターフェイスを経由します。その結果、次のことが起こります。

  1. パケットがトンネル インターフェイスの出力キューにキューイングされます。

  2. トンネル インターフェイスは GRE ヘッダーを付加し、そのパケットをトンネル インターフェイスの宛先アドレス宛てのトランスポート プロトコルにキューイングします。

  3. IP は宛先アドレスへの経路を探し、その経路がトンネル インターフェイスを経由することを学習します。

  4. これによってパケットはステップ 1 に戻り、再帰的なルーティング ループに陥ります。

ソリューション

R1 と R3 の両方で、トンネルの宛先に対してスタティック ルートを設定します。

R1(config)# ip route 10.3.3.3 255.255.255.255  serial 0

 R3(config)# ip route 10.1.1.1 255.255.255.255 serial 1

 

次に R1 の IP ルートを示します。

R1#show ip route

 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

        * - candidate default, U - per-user static route, o - ODR

        P - periodic downloaded static route

 

 Gateway of last resort is 172.16.15.2 to network 0.0.0.0

 

      172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

 D       172.16.25.0/24 [90/297756416] via 192.168.1.3, 00:01:08, Tunnel0

 C       172.16.15.2/32 is directly connected, Serial0

 C       172.16.15.0/24 is directly connected, Serial0

      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

 S       10.3.3.3/32 is directly connected, Serial0

 D       10.3.3.0/24 [90/297372416] via 192.168.1.3, 00:01:08, Tunnel0

 C       10.1.1.0/24 is directly connected, Loopback0

 C    192.168.1.0/24 is directly connected, Tunnel0

 S*   0.0.0.0/0 [1/0] via 172.16.15.2

 

トンネルの宛先に対して、限定性の低い EIGRP 学習経路(10.3.3.0/24)よりも限定性の高いスタティック ルート(10.3.3.3/32)が優先されています。このように、より限定性の高いスタティック ルートを設定することで、再帰的なルーティング ループとトンネル インターフェイスのフラッピングを回避し、結果的に EIGRP 近接ルータのフラッピングを防止できます。

R1#show interfaces tunnel 0

 Tunnel0 is up, line protocol is up

   Hardware is Tunnel

   Internet address is 192.168.1.1/24

   MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,

      reliability 255/255, txload 1/255, rxload 1/255

   Encapsulation TUNNEL, loopback not set

   Keepalive set (10 sec)

   Tunnel source 10.1.1.1 (Loopback0), destination 10.3.3.3

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 22327