サービス品質(QoS) : QoS ポリシング

フレームリレー PVC での Class-Based Weighted Fair Queuing(CBWFQ)の設定

2002 年 4 月 24 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次


概要

この文書では、フレームリレー インターフェイスに Class-Based Weighted Fair Queueing(CBWFQ)を設定するための構成例について説明します。CBWFQ は、モジュラ Quality of Service Command Line Interface(QoS CLI; Qos コマンド行インターフェイス)のコマンドを使用してポリシーマップに設定したとおりに、bandwidth コマンドによって有効化されます。

ハードウェアおよびソフトウェアのバージョン

CBWFQ は、プラットフォーム別に次の Cisco IOSョ ソフトウェア リリース以降でサポートされます。

  • Versatile Interface Processors(VIP)を搭載した Cisco 7500 シリーズ(分散 CBWFQ):12.1(5)T

  • Cisco 7200 シリーズ、2600/3600 シリーズ、および 7500 以外のシリーズのプラットフォーム:12.1(2)T


シェーピングおよびキューイング


  7500 シリーズ 7200、3600、2600、およびその他の非 VIP プラットフォーム
サポート対象のシェーピング メカニズム 分散トラフィック シェーピング(DTS) フレームリレー トラフィック シェーピング(フレームリレー TS)
設定コマンド ポリシーマップの shape コマンドを使用。 メイン インターフェイスで frame-relay traffic-shaping を使用、およびシェーピング パラメータの指定には map-class 設定コマンドを使用。
Distributed Cisco Express Forwarding(dCEF)の必要の有無 必要(show cef linecard コマンドにより確認)  不要

Cisco 7200、3600、2600 シリーズ

Cisco IOS 12.1(2)T では、Cisco 7200、2600/3600 および他のルート スイッチ プロセッサ(RSP)以外のプラットフォームにおいて CBWFQ がサポートされます。 (詳細は、「フレームリレー上での低遅延キューイング(LLQ)」を参照してください)。これらのプラットフォームでは、フレームリレー インターフェイス上の CBWFQ は、常にフレーム リレー TS に関連しています。frame-relay traffic-shaping コマンドを使用して、フレームリレー TS を有効化します。これらのプラットフォームでは、汎用トラフィック シェーピング(GTS)および shape コマンドによって、CBWFQ を使用できません。次に、構成例を示します。

Cisco 7200、3600、2600 シリーズ上での CBWFQ の構成例
 policy-map mypolicy

   class voice

    priority 16

   class priority-data

    bandwidth 16

 !-- ポリシーマップを作成し、帯域幅コマンドを

 !-- クラスに適用します。 

 !

  int s0/0

   encapsulation frame-relay IETF

   load-interval 30

   frame-relay traffic-shaping

 !-- フレームリレー TS を有効化します。 

 !

  interface Serial0/0.1 point-to-point

   frame-relay interface-dlci 100

     class frclass

 !-- フレームリレー PVC にマップクラスを適用します。 

 !

  map-class frame-relay frclass

   service-policy output mypolicy

   frame-relay cir 64000

   frame-relay bc 640

 !-- マップクラス内のサービスポリシーを適用します。

           

注:サービスポリシーをメイン インターフェイス上では有効化できても、マップクラス コマンド内で有効化できない場合は、インターフェイスに直接フレームリレー TS を適用できません。そのため、キューイング メカニズムは、Virtual Circuit(VC; 仮想回線)単位のキューではなく、1 つの大きなインターフェイス キューに適用されることに注意してください。


Cisco 7500 シリーズ

Cisco IOS 12.1(5)T では、RSP ベースの QoS がサポートされなくなったため、QoS ポリシーは VIP 上で分散モードで稼動する必要があります。したがって、7500 シリーズの場合、shape コマンドとモジュラ QoS CLI のその他のコマンドを使用して、VIP のフレームリレー インターフェイスに DTS を実装します。DTS は GTS とフレームリレー TS を統合します。構成例については、「分散トラフィック シェーピングの設定」および次に示します。

階層型ポリシーによる DTS の構成例
ip cef distributed

  !

  class-map 1

    match < >

    !-- 一致基準を定義します。 

  class-map 2

    match < >

    !-- 一致基準を定義します。

  !

  policy-map CBWFQ

    class 1

      bandwidth < >

      !-- kbps または % で値を定義します。 

    class 2

      priority < >

      !-- kbps または % で値を定義します。

  !

  Policy-map SHAPE

     class class-default

      shape average  

      service-policy CBWFQ

  !

  int s0/0/0

    encapsulation frame-relay

    ip route-cache distributed

  !

  int s0/0/0.1 point-to-point

    ip address a.b.c.d

    frame-relay interface-dlci xxx

     class cisco

  !

  map-class frame-relay cisco

    service-policy output SHAPE


サービスポリシーを適用する箇所の選択

CBWFQ を設定するときは、モジュラ QoS CLI コマンドを使用して、複数のトラフィック クラスおよび 1 つ以上の QoS 機能によってトラフィック ポリシー マップを作成します。IOS の現在のバージョンでは、フレームリレー インターフェイスは、service-policy コマンドによるインターフェイス、サブインターフェイス、および VC へのポリシーマップの適用をサポートします。正しく組み合わされたポリシーだけがサポートされます。次の表で、トラフィック シェーピングによって QoS ポリシーを適用できる場所を説明します。

  Cisco 7500 シリーズ Cisco 7200、2600/3600 シリーズ、および他のプラットフォーム
メイン インターフェイス   フレームリレー TS が有効化されておらず、キューイング メカニズムが 1 つのインターフェイス パイプに適用される場合に限りサポートされる。
サブインターフェイス フレームリレーのマップクラス内にサービスポリシーを設定。 サブインターフェイスにマップクラスを適用できます。 フレームリレーのマップクラス内にサービスポリシーを設定し、frame-relay traffic-shaping コマンドにより VC 単位のキューイングを有効化。 サブインターフェイスにマップクラスを適用できます。
VC レベル フレームリレーのマップクラス内にサービスポリシーを設定。 VC にマップクラスを適用できます。 フレームリレーのマップクラス内にサービスポリシーを設定し、frame-relay traffic-shaping コマンドにより VC 単位のキューイングを有効化。 VC にマップクラスを適用できます。


既知の問題

フレームリレー インターフェイスに CBWFQ を設定する場合は、次の事項に注意してください。

  • ルータがリロードされると、サービスポリシーのパケット マッチ カウンタは、ポリシーがメイン インターフェイスに適用されても増加しない場合があります。 この問題を解決するには、Weighted Fair Queueing(WFQ; 均等化キューイング)の分類フラグをメイン インターフェイスからサブインターフェイスにコピーします。

  • 物理インターフェイス レベルでは、LLQ およびフレームリレー TS を同時に設定できません。ルータは、リロードされると、稼動設定からサービスポリシーを取り除きます。 インターフェイス上でフレームリレー TS を有効化するときは、マップクラスにサービスポリシーを適用する必要があります。この組み合わせを設定しようとすると、次のエラー メッセージが表示されます。「CBWFQ:Not supported on this interface(このインターフェイスではサポートされません。)」

  • CBWFQ によるサービスポリシーを直接フレームリレーのメイン インターフェイス(非 VC 単位キューイングなど)に適用するときに、bandwidth 文をサブインターフェイスやメイン インターフェイス上で設定すると、ルータのリロード後にポリシーが除去される場合があります。ルータにより、次のようなログ メッセージが報告される場合があります。
        CBWFQ: Not enough available bandwidth for all classes Available 44 (kbps)
    
         Needed 1 00 (kbps)
    
         CBWFQ: Removing service policy on Serial1/0
    
     
    この問題を解決するには、サブインターフェイスで bandwidth コマンドを変更したときの通知を無視するように CBWFQ の動作を変更します。フレームリレーのマップクラス外で CBWFQ を設定できるのは、メイン インターフェイス レベルに限られるからです。 回避策としては、サブインターフェイスからbandwidth コマンドを除去します。サブインターフェイスで bandwidth を使用してルーティング メトリックに影響を与えるには、Open Shortest Path First(OSPF)のコストや Enhanced Interior Gateway Routing Protocol(EIGRP)の遅延などの、別の方法を使用してください。
構成ガイド
  • bandwidth および priority のコマンドにより、エンティティで使用可能な総帯域幅量を計算する場合は、エンティティが整形フレームリレーの Permanent Vitual Circuit(PVC; 相手先固定接続)であれば次のガイドラインが呼び出されます。
    • Minimum Acceptable Committed Information Rate(minCIR)が設定されていなければ、CIR は 2 で除算されます。
    • minCIR が設定されていれば、minCIR 設定が計算に使用されます。
    • 上で計算された総帯域幅は、帯域幅とプライオリティ クラスに割り当てられます。したがって、max-reserved-bandwidth コマンドは、フレームリレー PVC でサポートされません。ただし、総帯域幅はレイヤ 2 オーバーヘッドも確実に収容できる大きさに設定する必要はあります。  詳細は、「IP により ATM CoS キューイングにカウントされるバイト」を参照してください。

  • CIR または minCIR に、アクセス レートを設定しないでください。 設定すると、出力キューが積み上がって、CBWFQ クラスに大きな遅延が発生する場合があります。 これは、整形レートでは、フラグのオーバーヘッド バイトや Cyclic Redundancy Check(CRC; サイクリック冗長性検査)フィールドが考慮されないので、回線レートでのシェーピングは加入超過になり、インターフェイスの輻輳が発生するからです。アクセス レートでのシェーピングは、まったく意味がありません。トラフィックのシェーピングは通常、アクセス レートの 95 % で行う必要があります。つまり、より一般には、集約整形レートは常にアクセス レートの 95% 以下にする必要があります。

  • FRF 12 が設定されると、出力キューのサイズは、現在、分割されているバイト数を収容できるように拡張します。 つまり、パケット キューからフラグメント キューに移ります。

  • VC 単位の WFQ は、12.0(7)T に含まれます。

  • GTS による CBWFQ は、12.1(2)T に含まれます。
ツール情報


他のリソースについては、シスコの「ルーティング プロトコル テクノロジー用 TAC ツール」を参照してください。


関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 18661