IP : IP ルーティング

RIP に対してトリガされる拡張機能の設定例

2002 年 10 月 30 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 1 月 28 日) | フィードバック

目次


概要

この文書では、インターフェイス設定コマンドの ip rip triggered を使用した設定例について説明します。

Routing Information Protocol(RIP; ルーティング情報プロトコル)に対してトリガされる拡張機能により、ポイントツーポイントのシリアル リンクでの効率が向上します。この機能は、Cisco IOS(R) 12.0(1)T 以降が実行されているすべてのプラットフォームでサポートされています。トリガされる拡張機能により、RIP を使用して WAN に接続する際の一般的な 2 つの問題を回避できます。

  • RIP から送られる定期的なブロードキャスティングにより、WAN 回線を閉じることができなくなる場合がある問題。
  • 固定されているポイントツーポイントのリンクでも、定期的な RIP の送信の負荷により、通常のデータ転送が著しく阻害される問題。

この機能を有効にするには、リンクの両側でインターフェイス設定コマンドの ip rip triggered を使用します。設定例については、次の図の例を参照してください。

ネットワーク ダイアグラム

トポロジの例

設定

S3-3640 S3-3620

 interface Serial1/0

   ip address 172.16.1.1 255.255.255.0

   ip rip triggered

  !

  router rip

   network 172.16.0.0

 

 interface Loopback8

  ip address 172.19.1.1 255.255.255.0

 !

 interface Ethernet0/3

  ip address 172.18.1.1 255.255.255.0

 !

 interface Serial1/0

  ip address 172.16.1.2 255.255.255.0

  ip rip triggered

 !

 router rip

  network 172.16.0.0

  network 172.18.0.0

  network 172.19.0.0

 

デバッグと検証のヒント

S3-3640 に対するデバッグの出力を次に示します。


 S3-3640#debug ip rip events

 RIP: received v1 triggered request from 172.16.1.2 on Serial1/0

 RIP: start retransmit timer of 172.16.1.2

 RIP: received v1 triggered ack from 172.16.1.2 on Serial1/0

 RIP: Stopped retrans timer for 172.16.1.2

 RIP: sending v1 ack to 172.16.1.2 via Serial1/0 (172.16.1.1),

 

 S3-3640#show ip route

 C       172.16.1.0/24 is directly connected, Serial1/0

 R    172.19.0.0/16 [120/1] via 172.16.1.2, Serial1/0

 R    172.18.0.0/16 [120/1] via 172.16.1.2, Serial1/0

 

 S3-3640#show ip rip database

 172.18.0.0/16    auto-summary

 172.18.0.0/16

     [1] via 172.16.1.2, 00:02:44 (permanent), Serial1/0

 	* Triggered Routes:

      - [1] via 172.16.1.2, Serial1/0

 172.19.0.0/16    auto-summary

 172.19.0.0/16

     [1] via 172.16.1.2, 00:02:45 (permanent),Serial1/0

   	* Triggered Routes:

      - [1] via 172.16.1.2, Serial1/0

ip rip triggered で設定されたインターフェイスから学習したルートが、RIP データベースおよびルーティング テーブルの中で永続的なエントリとして表示されています。

最後に

トリガされる拡張機能を RIP に対して有効にする場合、WAN 上でのルーティング更新は次のイベントのいずれかが発生した場合にのみ送信されます。

  • ルータがルーティング更新に関する特別な要求を受信し、これによってデータベース全体が送信される場合。

  • 他のインターフェイスからの情報によってルーティング データベースが書き換えられ、これによって最新の変更が送信される場合。

  • インターフェイスがアップ状態またはダウン状態になり、データベースの一部が送信される場合。

  • 1 つの更新が送信できることを確認するためにルータの電源が初めてオンにされると、その結果、データベース全体が送信される場合。


ツール情報

その他のリソースについては、Cisco の「ルーティング プロトコル テクノロジーに関する TAC ツール」を参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13720