IP : IP ルーティング

フォワーディング アドレスのタイプ 5 LSA パス選択への影響

2003 年 1 月 7 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 3 月 28 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
タイプ 5 LSA フォワーディング アドレスがパス選択に影響する方法
     フォワーディング アドレスが両方の LSA に設定されない
     フォワーディング アドレスが片方の LSA にのみ設定され、他方の LSA には設定されない
結論
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、ルータが任意の外部ネットワーク用に 2 つのタイプ 5 link-state advertisement(LSA; リンクステート アドバタイズメント)を受信した場合の、Open Shortest Path First(OSPF)パス選択の動作について説明します。この例では、一方の LSA のフォワーディング アドレスはゼロ(0.0.0.0)に、他方の LSA のフォワーディング アドレスはゼロ以外に設定します。

はじめに

表記法

文書の表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

この文書の読者は、次の項目に関する知識が必要です。

  • IP ルーティング全般

  • OSPF ルーティング プロトコルの概念と条件

使用するコンポーネント

この文書は、特定のソフトウェアおよびハードウェアのバージョンには限定されません。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。また、この文書で使用するデバイスは、すべて初期(デフォルト)の設定で起動しています。実稼動中のネットワークで作業をしている場合、実際にコマンドを使用する前に、その潜在的な影響について理解しておく必要があります。

タイプ 5 LSA フォワーディング アドレスがパス選択に影響する方法

フォワーディング アドレスが両方の LSA に設定されない

OSPF タイプ 5 LSA のフォワーディング アドレスが、タイプ 5 LSA のパス選択にどのように影響するかについて、下記のトポロジを使用して説明します。

type5_lsa_01.gif

上記のダイアグラムで、すべてのルータがエリア 0 で OSPF を実行しています。この文書では、autonomous system boundary router(ASBR; 自律システム境界ルータ)がタイプ 5 LSA を生成するため、ルータ 3 とルータ 4 の設定が最も重要となります。下記に示すとおり、ルータ 3 とルータ 4 にはネットワーク 200.200.200.0 255.255.255.0 へのスタティック ルートがあり、これが OSPF に再配布されています。

ルータ 3

interface Ethernet0

  ip address 172.16.3.3 255.255.255.0

  ip ospf cost 15

 !

 interface Serial0

  ip address 172.16.2.3 255.255.255.0

 !

 router ospf 7

  redistribute static subnets

  network 172.16.2.0 0.0.0.255 area 0

 !

 ip route 200.200.200.0 255.255.255.0 172.16.3.8

 

ルータ 4

interface Ethernet0

  ip address 172.16.3.4 255.255.255.0

 !

 interface Serial0

  ip address 172.16.7.4 255.255.255.0

 !

 router ospf 7

  redistribute static subnets

  network 172.16.7.0 0.0.0.255 area 0

 !

 ip route 200.200.200.0 255.255.255.0 172.16.3.8

注:ルータ 3 とルータ 4 では、OSPF プロセスにネットワーク 172.16.3.0 255.255.255.0 が含まれません。したがって、両ルータで生成されるタイプ 5 LSA では、フォワーディング アドレスは 0.0.0.0 に設定されます。

この例では、ルータ 5 を使用して、外部 LSA を表示できます。外部 LSA を表示するには、ルータ 5 で show ip ospf database external コマンドを発行します。このコマンドの出力結果を次に示します。

ルータ 5

router-5#show ip ospf database external

 

             OSPF Router with ID (172.16.6.5) (Process ID 7)

 

                 Type-5 AS External Link States

 

   Routing Bit Set on this LSA

   LS age: 1514

   Options: (No TOS-capability, DC)

   LS Type: AS External Link

   Link State ID: 200.200.200.0 (External Network Number )

   Advertising Router: 172.16.3.3

   LS Seq Number: 80000030

   Checksum: 0x93C0

   Length: 36

   Network Mask: /24

         Metric Type: 2 (Larger than any link state path)

         TOS: 0

         Metric: 20

         Forward Address: 0.0.0.0

         External Route Tag: 0

 

   Routing Bit Set on this LSA

   LS age: 1922

   Options: (No TOS-capability, DC)

   LS Type: AS External Link

   Link State ID: 200.200.200.0 (External Network Number )

   Advertising Router: 172.16.7.4

   LS Seq Number: 80000027

   Checksum: 0x83D4

   Length: 36

   Network Mask: /24

         Metric Type: 2 (Larger than any link state path)

         TOS: 0

         Metric: 20

         Forward Address: 0.0.0.0

         External Route Tag: 0

 

 router-5#

上記を見てわかるとおり、ルータ 3 とルータ 4 の両方で生成されるタイプ 5 LSA のフォワーディング アドレスが、0.0.0.0 に設定されます。この場合、ルータ 5 のルーティング テーブルにインストールされる LSA は、LSA を生成している ASBR へのメトリックと比較して決定されます。ルータ 5 で show ip ospf border コマンドを発行すると、ルータ 5 の ASBR へのメトリックが表示されます。このコマンドの出力結果を次に示します。

ルータ 5

router-5#show ip ospf border

 

 OSPF Process 7 internal Routing Table

 

 Codes: i - Intra-area route, I - Inter-area route

 

 i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 14

 i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 14

 router-5#

上記に示すとおり、ルータ 5 が ASBR 172.16.3.3 に到達するためのメトリックは 64 であるのに対し、ASBR 172.16.7.4 に到達するためのメトリックは 74 です。したがって、ルータ 5 は ASBR 172.16.3.3 によって生成された LSA を選択し、これを自分のルーティング テーブルに追加します(下記参照)。

ルータ 5

router-5#show ip route

 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

        * - candidate default, U - per-user static route, o - ODR

        P - periodic downloaded static route

 

 Gateway of last resort is not set

 

 O E2 200.200.200.0/24 [110/20] via 172.16.2.3, 19:59:25, Serial0

      172.16.0.0/24 is subnetted, 3 subnets

 C       172.16.6.0 is directly connected, Ethernet0

 O       172.16.7.0 [110/74] via 172.16.6.6, 19:59:25, Ethernet0

 C       172.16.2.0 is directly connected, Serial0

 router-5#

フォワーディング アドレスが片方の LSA にのみ設定され、他方の LSA には設定されない

この文書のこの部分に関しては、上記と同じトポロジを使用します。ルータ 4 の設定も変更はありませんが、ルータ 3 の設定は、OSPF プロセスのエリア 0 にネットワーク 172.16.3.0 255.255.255.0 を含むように変更されています。ルータ 3 の設定は下記に示すとおりで、変更箇所は太字で強調表示されています。

ルータ 3

interface Ethernet0

  ip address 172.16.3.3 255.255.255.0

  ip ospf cost 15

 !

 interface Serial0

  ip address 172.16.2.3 255.255.255.0

 !

 router ospf 7

  redistribute static subnets

  network 172.16.2.0 0.0.0.255 area 0

  network 172.16.3.0 0.0.0.255 area 0

 !

 ip route 200.200.200.0 255.255.255.0 172.16.3.8

 

上記の設定変更を行った結果、ルータ 3 によって生成されるタイプ 5 LSA は、フォワーディング アドレスがルータ 8 の IP アドレスに設定されます。これは、ルータ 5 から抜粋される、下記のデータベースの出力に示すとおりです。

ルータ 5

router-5#show ip ospf database external

 

             OSPF Router with ID (172.16.6.5) (Process ID 7)

 

                 Type-5 AS External Link States

 

   Routing Bit Set on this LSA

   LS age: 270

   Options: (No TOS-capability, DC)

   LS Type: AS External Link

   Link State ID: 200.200.200.0 (External Network Number )

   Advertising Router: 172.16.3.3

   LS Seq Number: 80000033

   Checksum: 0x5138

   Length: 36

   Network Mask: /24

         Metric Type: 2 (Larger than any link state path)

         TOS: 0

         Metric: 20

         Forward Address: 172.16.3.8

         External Route Tag: 0

 

   Routing Bit Set on this LSA

   LS age: 258

   Options: (No TOS-capability, DC)

   LS Type: AS External Link

   Link State ID: 200.200.200.0 (External Network Number )

   Advertising Router: 172.16.7.4

   LS Seq Number: 80000029

   Checksum: 0x7FD6

   Length: 36

   Network Mask: /24

         Metric Type: 2 (Larger than any link state path)

         TOS: 0

         Metric: 20

         Forward Address: 0.0.0.0

         External Route Tag: 0

 

 router-5#

上記を見てわかるとおり、ルータ 3 によって生成されたタイプ 5 LSA のフォワーディング アドレスが 172.16.3.8 と設定されるのに対し、ルータ 4 によって生成されたタイプ 5 LSA のフォワーディング アドレスは 0.0.0.0 のままです。

この場合、ルータ 5 のルーティング テーブルにインストールされる LSA は、フォワーディング アドレス 0.0.0.0のLSAを生成した ASBR(ルータ 4)へのルータ5のメトリックと、フォワーディング アドレス 172.16.3.8 へ到達するためのルータ5のメトリックとを比較して決定されます。このアドレスは、ASBR(ルータ 3)によって生成される LSA 用に設定されたものです。

ASBR へのメトリックを表示するには、ルータ 5 で show ip ospf border コマンドを発行します。出力結果を次に示します。

ルータ 5

router-5#show ip ospf border

 

 OSPF Process 7 internal Routing Table

 

 Codes: i - Intra-area route, I - Inter-area route

 

 i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 15

 i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 15

 router-5#

上記の出力で、ルータ 4 へのメトリックは 74 です。このメトリックは、フォワーディング アドレス 172.16.3.8 に到達するために、ルータ 5 のメトリックと比較されます。ルータ 5 のメトリックは、show ip route 172.16.3.8 コマンドを使用して表示できます。このコマンドの出力結果を次に示します。

ルータ 5

router-5#show ip route 172.16.3.8

 Routing entry for 172.16.3.0/24

   Known via "ospf 7", distance 110, metric 79, type intra area

   Last update from 172.16.2.3 on Serial0, 00:30:49 ago

   Routing Descriptor Blocks:

   * 172.16.2.3, from 172.16.3.3, 00:30:49 ago, via Serial0

       Route metric is 79, traffic share count is 1

 

 router-5#

つまり、ASBR ルータ 4 に到達するためのメトリック(すなわち 74)が、(ルータ 3 によって生成される)フォワーディング アドレス 172.16.3.8 に到達するためのメトリック(すなわち 79)と比較されます。したがって、下記のルータ 5 の show ip route 出力結果に示されるとおり、ルーティング テーブルにインストールされた LSA は、ルータ 4 によって生成された LSA となります。

ルータ 5

router-5#show ip route

 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

        * - candidate default, U - per-user static route, o - ODR

        P - periodic downloaded static route

 

 Gateway of last resort is not set

 

 O E2 200.200.200.0/24 [110/20] via 172.16.6.6, 00:35:14, Ethernet0

      172.16.0.0/24 is subnetted, 4 subnets

 C       172.16.6.0 is directly connected, Ethernet0

 O       172.16.7.0 [110/74] via 172.16.6.6, 00:35:14, Ethernet0

 C       172.16.2.0 is directly connected, Serial0

 O       172.16.3.0 [110/79] via 172.16.2.3, 00:35:14, Serial0

 router-5#

結論

フォワーディング アドレスは、タイプ 5 LSA パス選択の動作を変更します。ルータが、宛先の同じ 2 つのタイプ 5 LSA を受信し、両方の LSA にフォワーディング アドレスが設定されている場合、このルータは、フォワーディング アドレスへのメトリックに基づいて比較を行います。これより小さいメトリックのフォワーディング アドレスを持つ LSA は、ルーティング テーブルの中に追加されます。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 25493