IBM テクノロジー : IBM ネットワーキング

データリンク スイッチング プラス

2014 年 1 月 31 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 6 月 6 日) | フィードバック

概要

データリンク スイッチング(DLSw)は、WAN 上での論理リンク制御(LLC)の転送をサポートする規格として IBM が実装したものです。DLSw はリモート ソースルート ブリッジング(RSRB)を発展させた規格で、ブリッジの対象が明確に定義されています。DLSw では、有効な LLC2 セッションまたは NetBIOS セッションをルータで転送する必要があります。

シスコのルータには、RFC 1795(DSLw 規格)と RFC 2166(DLSw バージョン 2)が実装されています。また、DLSw には他より多くのブロードキャスト制御機能が実装されており、WAN 上に転送される情報量が他の手法より少なくなります。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

一般的なコマンド

この項では、重要な DLSw コマンド(DLSw を設定するためのコマンドと DLSw のトラブルシューティングを行うためのコマンド)について説明します。

source-bridge ring-group

DLSw の設定で最初に行う手順は source-bridge ring-group コマンドの追加です。これにより、ソースルート ブリッジング(SRB)を行うトークンリング インターフェイスに接続されます。

タスク コマンド
リング グループの定義 source-bridge ring-group リング グループ [virtual-mac-address]

注: イーサネット インターフェイスのみを備えたルータで DLSw を実行する場合は、ring-group を設定する必要はありません。

ローカル ピア識別情報の定義

次のオプションは、ローカル ピア識別情報を定義するためのものです。これは同じボックス内の IP アドレスです。基本的にはこれによってルータで DLSw が開始されます。

タスク コマンド
DLSw+ ローカル ピアの定義 dlsw local-peer [peer-id ip アドレス] [group グループ] [border] [cost コスト] [lf size] [keepalive ] [passive] [promiscuous] [biu-segment]

DLSw の設定で最も基本的なオプションは local peer-id ip アドレスの設定です。コマンド パラメータの説明を次に示します。

  • group および border:ネットワーク内のボーダー ピアを作成するときに、この 2 つのコマンドを同時に発行します。

  • cost:同一ロケーションへのパスが複数ある場合にこのコマンドを発行します。最も低コストのパスを最初に使用してこれらのリモート サイトに到達する方法をルータに設定します。

  • lf:このピアが扱える最大フレーム サイズを決定します。サイズは次のとおりです。

    • 516:最大 516 バイトのフレーム サイズ

    • 1470:最大 1470 バイトのフレーム サイズ

    • 1500:最大 1500 バイトのフレーム サイズ

    • 2052:最大 2052 バイトのフレーム サイズ

    • 4472:最大 4472 バイトのフレーム サイズ

    • 8144:最大 8144 バイトのフレーム サイズ

    • 11407:最大 11407 バイトのフレーム サイズ

    • 11454:最大 11454 バイトのフレーム サイズ

    • 17800:最大 17800 バイトのフレーム サイズ

  • keepalive:キープアライブ パケットの間隔を定義します。この間隔は、0 〜 1200 秒の範囲で設定できます。ダイヤルオンデマンド ルーティング(DDR)に DLSw を設定する場合は、通常 0 に設定します。

  • passive:ルータからピアの起動が開始されないようにルータを設定します。

  • promiscuous:ピアの起動を要求するどのリモート ピアからの接続も受け入れるようにルータを設定します。コア ルータにすべてのリモート ピアを定義する必要がないため、多数のピアを抱える大規模なサイトに便利なコマンドです。

  • biu-segment:DLSw のオプションです。DLSw にシステム ネットワーク アーキテクチャ(SNA)レイヤ内で制御するセグメント サイズの拡大を許可し、 より大量のデータを送信可能であるとエンド ステーションに認識させることができます。

リモート ピアの定義

ローカル ピアを定義したら、リモート ピアを定義します。3 つのタイプのピアを定義できます。TCP、Fast-Sequenced Transport(FST)、直接ハイレベル データリンク コントロール(HDLC)とフレーム リレーです。リモート ピアを定義するときに発行するコマンドは次のとおりです。

タスク コマンド
フレームリレー上での直接カプセル化 dlsw remote-peer リスト番号 frame-relay interface serial 番号 dlci 番号 [backup-peer ip-address] [bytes-netbios-out バイトリスト名] [cost コスト] [dest-mac mac アドレス] [dmac-output-list アクセス リスト番号] [host-netbios-out ホスト リスト名] [keepalive ] [lf サイズ] [linger ] [lsap-output-list リスト] [pass-thru]
HDLC 上での直接カプセル化 dlsw remote-peer リスト番号 interface serial 番号 [backup-peer ip アドレス] [bytes-netbios-out バイト リスト名] [cost コスト] [dest-mac mac アドレス] [dmac-output-list アクセス リスト番号] [host-netbios-out ホスト リスト名] [keepalive ] [lf サイズ] [linger ] [lsap-output-list リスト] [pass-thru]
FST dlsw remote-peer リスト番号 fst ip アドレス [backup-peer ip アドレス] [bytes-netbios-out バイト リスト名] [cost コスト] [dest-mac mac アドレス] [dmac-output-list アクセス リスト番号] [host-netbios-out ホスト リスト名] [keepalive ] [lf サイズ] [linger ] [lsap-output-list リスト] [pass-thru]
TCP dlsw remote-peer リスト番号 tcp ip アドレス [backup-peer ip アドレス] [bytes-netbios-out バイト リスト名] [cost コスト] [dest-mac mac アドレス] [dmac-output-list アクセス リスト番号] [dynamic] [host-netbios-out ホスト リスト名] [inactivity ] [keepalive ] [lf サイズ] [linger ] [lsap-output-list リスト] [no-llc minutes] [priority] [tcp-queue-max サイズ] [timeout ][v2-single-tcp]

上の表のコマンド オプションの説明は次のとおりです。

  • backup peer:最初のピアが失敗した場合にこのピアをバックアップするピアを定義します。

  • cost:このピアのコストを定義します。宛先へのパスが複数ある場合や、優先される有効なシナリオが必要な場合に使用します。

  • dest-macdynamicno-llc および inactivity:このドキュメントの「バックアップ ピアとコスト ピア」の項を参照してください。

  • dmac-output-list:EXPLORER のトラフィックを許可(または拒否)するリモートの宛先 MAC アドレスをルータに指示するアクセス リストを定義します。

  • host-netbios-out:NetBIOS ホスト フィルタ名を適用します。

  • keepalive:キープアライブ間隔を秒単位で定義します。ほとんどは DDR の設定時に使用します。

  • lf:ピアに許可される最大サイズを指定します。

  • linger:(プライマリの障害が原因で)アクティブになったバックアップ ピアを、プライマリ リンクが再びアクティブになってからもオープンにしておく時間を指定します。

  • priority:DLSw トラフィックの優先付けをするための複数のピアを作成します。

  • tcp-queue-max:200 になっている TCP キューのデフォルト値を変更します。

  • timeout:TCP が確認応答を待機する秒数。指定の秒数を過ぎると接続が解除されます。

  • V2-single-tcpM:Network Address Translation(NAT)環境での使用を目的としたコマンド オプションです。各ピアは、TCP 接続のいずれかが各ピアによって切断されるのを防ぐために、より高い IP アドレスが設定されていると認識します。

DLSw で使用されるタイマー

DLSw で使用されるタイマーの説明は次のとおりです。

パラメータ 説明
icannotreach-block-time 到達不能なリソースがキャッシュされる期間。この期間中はこのリソースの検索がブロックされます。有効な値の範囲は 1 〜 86400 秒。デフォルトは 0(ディセーブル)です。
netbios-cache-timeout ローカルとリモートの両方の到達可能性キャッシュに NetBIOS 名のロケーションがキャッシュされる期間。有効な値の範囲は 1 〜 86400 秒。デフォルトは 16 分です。
netbios-explorer-timeout Cisco IOS® ソフトウェアが EXPLORER の応答を待機する時間。この時間を過ぎると、リソース(LAN および WAN)は到達不能とマーキングされます。有効な値の範囲は 1 〜 86400 秒。デフォルトは 6 秒です。
netbios-retry-interval NetBIOS の EXPLORER の再試行間隔(LAN のみ)。有効な値の範囲は 1 〜 86400 秒。デフォルト値は 1 秒です。
netbios-verify-interval キャッシュ エントリが作成されてからそのエントリが失効とマーキングされるまでの間隔。失効したキャッシュ エントリに対する検索要求が到着すると、エントリがまだ存在することを確認するための directed verify クエリが送信されます。有効な値の範囲は 1 〜 86400 秒。デフォルトは 4 分です。
sna-cache-timeout SNA MAC または サービス アクセス ポイント(SAP)のロケーション キャッシュ エントリが廃棄されるまでの時間(ローカルおよびリモート)。有効な値の範囲は 1 〜 86400 秒。デフォルトは 16 分です。
sna-explorer-timeout IOS ソフトウェアが EXPLORER の応答を待機する時間。この時間を過ぎると、リソース(LAN および WAN)は到達不能とマーキングされます。有効な値の範囲は 1 〜 86400 秒。デフォルトは 3 分です。
sna-retry-interval SNA エクスプローラの再試行間隔(LAN)。有効な値の範囲は 1 〜 86400 秒。デフォルトは、30 秒です。
sna-verify-interval キャッシュ エントリが作成されてからそのエントリが失効とマーキングされるまでの間隔。失効したキャッシュ エントリに対する検索要求が到着すると、エントリがまだ存在することを確認するための方向付き検証クエリが送信されます。有効な値の範囲は 1 〜 86400 秒。デフォルトは 4 分です。
explorer-wait-time ルータがすべての EXPLORER の応答を待機する時間(秒)。この時間を過ぎるまでに、使用するピアが決定されます。

これらのパラメータは非常に便利です。たとえば、ルータが EXPLORER を送信する間隔(秒)を変更できるため、 EXPLORER が送信される間隔を長くすることにより、ネットワーク内の EXPLORER の数を減らすことができます。また、ルータがキャッシュ エントリをタイムアウトする値も変更できます。

その他の DLSw コマンド

その他の重要な DLSw コマンドは次のとおりです。

  • dlsw allroute-sna/netbios:単一ルート EXPLORER ではなく全ルート EXPLORER が使用されるように DLSw の動作を変更するときに発行します。

  • dlsw bridge-group:DLSw でブリッジ ドメインを透過的に結合するときに発行します。このコマンドは、イーサネットで NetBIOS を設定するときに幅広く使用されます。

  • dlsw explorerq-depth:DLSw EXPLORER キューの値を設定します。このコマンドは、通常の source-bridge explorer-queue コマンドの後に発行されますが、処理が必要なすべての CANUREACH(CUR)フレームを参照します。このコマンドはイーサネットからのパケットをカバーしているため重要です。ただし、source-bridge explorerq-depth コマンドではカバーされていません。このコマンドについての詳細は、『ソースルート ブリッジングの説明とトラブルシューティング』を参照してください。

show コマンド

この項で説明する show コマンドとその出力結果は、DLSw のトラブルシューティングに役立ちます。

show dlsw peer

このコマンドはピアに関する情報を提供します。設定済みの各リモート ピアが、送信したパケット数と受信したパケット数も含めて表示されます。

Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 5.5.5.1         CONNECT          2         2  conf      0    0   0 00:00:06

表示される state の値は次のとおりです。

  • CONNECT:DLSw ピアは起動され、稼働中です。

  • DISCONNECT:ピアはダウンしているか、接続されていません。

  • CAP_EXG:DLSw はリモート ピアと機能情報を交換しています。

  • WAIT_RD:ピアを起動する最終段階です。このピアは、リモート ピアが読み取りポートを開くのを待機しています。 ピアが起動するタイミングおよび debug dlsw peer コマンドの発行方法についての詳細は、このドキュメントの「デバッグ」の項を参照してください。

  • WAN_BUSY:TCP 送信キューがフルで、パケットを転送できません。

show dlsw peer コマンドでは、ドロップ数、特定のピアを横断する回線数、TCP キュー、および稼働時間も表示されます。ドロップ カウンタは次の理由で増加します。

  • WAN インターフェイスが直接ピアに対応していない。

  • ピアが完全に接続される前(TCP イベントまたは機能情報イベントを待機中)に DLSw がパケットの送信を試行する。送信 TCP キューがフル状態になっている。

  • FST シーケンス番号カウントが一致しない。

  • slow switch FST パケットにバッファを取得できない。

  • CiscoBus コントローラのハイエンド上での障害(パケットを受信バッファから送信バッファへ、またはその逆へ移動できない)。

  • FST パケットの宛先 IP アドレスがローカル ピア ID と一致しない。

  • WAN インターフェイスが FST ピアに対応していない。

  • SRB のルート キャッシュ コマンドが設定されていない。

  • Madge リング バッファがローエンド システム上でいっぱいになっている(WAN から LAN への送信が速すぎる)。

show dlsw capabilities

DLSw: Capabilities for peer 5.5.5.1(2065)
  vendor id (OUI)         : '00C' (cisco)
  version number          : 1
  release number          : 0
  init pacing window      : 20
  unsupported saps        : none
  num of tcp sessions     : 1
  loop prevent support    : no
  icanreach mac-exclusive : no
  icanreach netbios-excl. : no
  reachable mac addresses : none
  reachable netbios names : none
  cisco version number    : 1
  peer group number       : 0
  border peer capable     : no
  peer cost               : 3
  biu-segment configured  : no
  local-ack configured    : yes
  priority configured     : no
  version string          :
Cisco Internetwork Operating System Software
IOS (tm) 4500 Software (C4500-J-M), Version 10.3(13), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1996 by cisco Systems, Inc.

show dlsw reachability

DLSw MAC address reachability cache list
Mac Addr        status     Loc.    peer/port            rif
0800.5a0a.c51d  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a49.1e38  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a95.3a13  FOUND      REMOTE  5.5.5.1(2065)
 
DLSw NetBIOS Name reachability cache list
NetBIOS Name    status     Loc.    peer/port            rif
PIN-PIN         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
QUENEPA         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
WIN95           FOUND      REMOTE  5.5.5.1(2065)

status フィールドは show dlsw reach コマンドの最も重要な部分です。表示され得る status の値は次のとおりです。

  • FOUND:ルータがデバイスを特定しました。

  • SEARCHING:ルータがリソースを検索しています。

  • NOT_FOUND:ネガティブ キャッシングがオンになっており、ステーションがクエリに応答していません。

  • UNCONFIRMED:ステーションは設定済みですが、DLSw では確認されていません。

  • VERIFY:キャッシュが失効したためキャッシュ情報を確認しています。または、ユーザ設定の確認中です。

show dlsw circuit

Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:32; Rx CW:20, Granted:32
        RIF = 06B0.0021.00F0

show dlsw circuit コマンドを発行するときはフロー制御に注意してください。フロー制御は 1 回線ごとに存在します。これは、2 つの DLSw ピアが回線に転送ウィンドウを割り当てるときに行われる通信です。この値は、回線内を移動するトラフィックの量によって増減します。値はクラウドの輻輳に応じて変わる可能性があります。

show dlsw circuit コマンドは、IOS 11.1 の時点でさらに拡張されています。サービス アクセスポイント(SAP)値または MAC 値で DLSw 回線を探せるようになっているため、トラブルシューティング時の回線の特定が簡単です。次に、出力例を示します。

ibu-7206#sh dlsw cir
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
ibu-7206#sh dls cir det ?
  <0-4294967295>  Circuit ID for a specific remote circuit
  mac-address     Display all remote circuits using a specific MAC
  sap-value       Display all remote circuits using a specific SAP
  <cr>
 
ibu-7206#show dlsw circuit detail mac 4000.0000.0001
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:29; Rx CW:20, Granted:29
        RIF = 06B0.0021.00F0
241-00  4000.0000.0001(04)  4001.68ff.0000(04) CONNECTED
        Port:To0          peer 5.5.7.1(2065)
        Flow-Control-Tx CW:20, Permitted:27; Rx CW:20, Granted:27
        RIF = 0630.00F1.0010
s5e#sh cls
DLU user: DLSWDLU
      SSap:0x63       type:  llc0   class:0
        DTE:0800.5a95.3a13 0800.5a0a.c51d F0 F0
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
 
        DTE:4000.0000.0001 4001.68ff.0000 04 04
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
TokenRing0 DTE: 4000.0000.0001 4001.68ff.0000 04 04 state NORMAL
   V(S)=23, V(R)=23, Last N(R)=22, Local window=7, Remote Window=127
   akmax=3, n2=8, Next timer in 1240
   xid-retry timer      0/0       ack timer    1240/1000
   p timer              0/1000    idle timer  10224/10000
   rej timer            0/3200    busy timer      0/9600
   akdelay timer        0/100     txQ count       0/200

トラブルシューティング

デフォルトでは、DLSw はルータで LLC セッションを終了します(ローカル確認応答)。さらに、ルーティング情報フィールド(RIF)も終了するため、他にも考慮すべき設計上の問題があります。DLSw に関する一般的な問題について、次の項で説明します。

ループ

DLSw に関して忘れてはいけない最も重要なことの 1 つは RIF の終了です。ネットワーク内にメジャー ループが簡単に作成されてしまうため、これが問題となります。次の図はループの一例です。

dlsw_1.gif

この例では、DLSw が RIF を終了するため、パケットは無期限に周回します。CUR フレームがピアからピアへ送信されるたびに、受信側のピアが新しい EXPLORER(NO RIF)を作成して送信するためです。EXPLORER の処理手順は次のとおりです。

  1. リング 11 内の 3174 が、ホストに到達するための EXPLORER を送信します。

  2. SF1 とブリッジの両方がこのフレームをコピーします。

  3. SF1 は(ピアである)LA1 に CUR フレームを作成して、LA1 に 3174 がホスト到達を要求していることを通知します。

  4. SF2 がパケットを受信すると、同じ処理が行われます。

  5. ここで LA1 と LA2 は EXPLORER を作成し、リングに送信します。

  6. LA1 と LA2 は、互いが作成した EXPLORER を受信します。

  7. 3174 はローカル接続されていると各サイドが認識しているため、ここで矛盾が生じます。

  8. つまり、3174 は各ルータのローカルとリモートの両方になるわけです。

  9. 各ルータから SF1 と SF2 にそれぞれ Icanreach フレームが送信され、そこでホストから 3174 への応答が作成されます。

  10. SF1 と SF2 の両方が EXPLORER の応答をトークン リングに配置し、ホストの MAC アドレスがローカルでもリモートでも到達可能であることをそれぞれが学習します。

  11. DLSw の到達可能性は EXPLORER の無限ループに対する実質的なファイアウォールです。ただし、非番号制情報(UI)フレームを使用する場合はループする可能性があり、CPU と回線の使用率が最大 100 % になる可能性があります。

この状況が発生した場合は、次の図に示すように、ルータ内の仮想リングがクラウドの両側でまったく同一であるかどうか確認してください。

dlsw_2.gif

このクラウドの両側にあるルータはまったく同じ仮想リング番号を持っています。そのため、すでにリングを通過した EXPLORER をいずれかのルータが送信した場合は、ルータによってドロップされます。SF1 で受信された CUR フレームの EXPLORER を LA1 が生成すると、その EXPLORER はすでにリング 1 を通過しているため LA2 によってドロップされます。このシナリオでは、パケットが同じリングに送信される場合はルータに異なるブリッジを設定していることが重要ですが、それはネットワークの LA 側の場合です。

同じシナリオでも、イーサネットの場合はピアを無効にする必要があります。次の図はその一例です。

dlsw_3.gif

イーサネット上のパケットには RIF が含まれないため、LAN 上の他のルータによって作成されたブロードキャストが他のルータからのものなのか発信元ステーションからのものなのかをルータで判別することができません。SNA の場合、パケットはローカルまたはリモートから発信されます。トークン リング環境から発信された EXPLORER は実質的に発信元と宛先の両方の MAC アドレスを持っているため、EXPLORER はイーサネット上のブロードキャストではなく、ステーションから別のステーションへの方向付きフレームです。

上の図で行われる処理について、次に説明します。

  1. 3174 からホストへ EXPLORER が送信されます。

  2. この EXPLORER は SF1 と SF2 の両方で受け入れられます。

  3. SF1 と SF2 はそれぞれ、他方の側の LA1 と LA2 に CUR を発信します。

  4. LA1 と LA2 が EXPLORER を発信し、これにホストが応答します。この EXPLORER は単一ルート EXPLORER であるため、応答には全ルート EXPLORER が使用されます。

  5. LA1 と LA2 の両方が SF1 と SF2 への CUR フレームを作成し、SF1 と SF2 は 3174 へのパケットを作成します。

  6. SF1 はイーサネットから着信するホストの MAC アドレスを読み取り、ホストはローカル LAN 上にあると認識します。しかし、SF1 のキャッシュに含まれるホスト ID はリモート ピアから応答しています。

  7. そのため、ルータには強制的にローカルとリモートのホストが設定されます。つまり、DLSw は破壊されます。

バックアップ ピアとコスト ピア

バックアップ ピアは、ピアが紛失した場合に DLSw に耐障害性を付加するものです。通常はコア環境にバックアップ ピアを設定し、コア ルータに障害があった場合は他のルータが障害のあるルータを受け入れられるようにします。この項に示す構成および図は、バックアップ ピアの設定例です。

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   cost 2 promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   cost 4 promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

dlsw_8.gif

DLSw コスト ピアについてまず注意する点は、ピアは両方ともアクティブであるという点です。ルータは 1 つのバックアップ ピアしか保持しません。linger を設定すれば、同時に 2 つ保持できます。前の図では、次の処理が行われます。

  1. D3A が EXPLORER を受信し、各リモート ピアに CUR フレームを送信してプロセスを開始します。

  2. D3B と D3C が CUR フレームを受信し、 それぞれがホストに向けて EXPLORER を発信し、ホストが D3B と D3C の両方に応答します。

  3. D3B と D3C の両方が D3A に Icanreach で応答します。

  4. D3A がエンド ステーションに EXPLORER の応答を送信します。

  5. リモート ステーションは、SNA の場合は交換識別子(XID)、NetBIOS の場合は拡張非同期平衡モード設定(SABME)を使用して、DLSw 回線を開始します。

  6. D3A は到達可能性情報の中からコストの低い方を選択します。

D3A にはタイマーがあり、すべての EXPLORER が D3A に戻るまでのルータの待機時間を設定できます。これにより、最初に戻ってきた EXPLORER をルータが使用する場合に発生するコストの問題を回避できます。このタイマーを設定するには、dlsw timer explorer-wait-time <秒> コマンドを発行します。

さらに、ボーダー ピアを実行している場合は、コストの最も低いピアに対して DLSw から 1 つだけ CUR フレームが送信されます。ボーダー ピアを実行する場合は、実行しない場合とはまったく異なる動作になります。

バックアップ ピアの動作は少し異なります。バックアップピアは、特定のピアのバックアップになるピア内で指定します。つまり、バックアップ ステートメントを持つピアが、バックアップ ピアそのものなのです。

linger オプションを指定すると、プライマリ ピアが復旧した場合でも、回線をすぐに切断できなくなります。これは、プライマリ ピアがアップしたりダウンしたりする場合に、障害のあるピアを使用したくないときに有効です。

次の例は、バックアップ ピアの構成例です。

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1 backup-peer 1.1.14.1 linger 5
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

show dlsw peer コマンドを発行すると、ピアが接続されていないことが表示されます。

d3a#sh dls peer
Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 1.1.14.1        CONNECT        464      1286  conf      0    0   0 03:17:02
 TCP 1.1.12.1        DISCONN          0         0  conf      0    0   -        -

ボーダー ピア

ボーダー ピアは、ネットワーク内のブロードキャスト制御の問題を解決できるため、DLSw の重要な機能となっています。次の例は、ボーダー ピアの構成方法とセッションが開始された場合の動作を示しています。

dlsw_6.gif

D3E
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3e
!
!
dlsw local-peer peer-id 1.1.11.1 group 1
   border promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
!
interface Loopback0
 ip address 1.1.11.1 255.255.255.0
!
interface Serial0
 ip address 1.1.3.1 255.255.255.0
!
interface Serial1
 ip address 1.1.2.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 ip address 10.17.1.189 255.255.255.0
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3C
Current configuration:
!
version 11.1

service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
dlsw local-peer peer-id 1.1.12.1 group 2
   border promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 no fair-queue
 clockrate 500000
!
interface Serial1
 ip address 1.1.3.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 no ip address
 shutdown
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3F
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3f
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.10.1 group 1
   promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.10.1 255.255.255.0
!
interface Serial0
 ip address 1.1.2.1 255.255.255.0
 no fair-queue
!!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1 group 2
   promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.2 255.255.255.0
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

ボーダー ピアの構成ではまず、不特定のピアを作成します。不特定のピアは、このルータでピアを開こうとするすべての DLSw ルータからの接続を受け入れます。たとえば、前の図では、D3A が D3F とピアを開く必要があります。ボーダー ピアがない場合は、ネットワーク内にスタティック ピアを設定する必要があります。これでも問題なく動作しますが、何百ものサイトがあるのにスタティック ピアを使用している場合は、ルータがリモートにステーションを見つける必要があるときにルータから各ピアへ CUR フレームを送信する必要があります。これは大量のオーバーヘッドを発生させる可能性があります。

一方、ボーダー ピアを使用している場合は、このリモート ルータからボーダー ピアに 1 つの要求を送信するだけですみます。この要求はその後グループを通じて伝搬され、リモート ルータは他のリモート ルータとピアを開いて回線を開始し、接続を確立します。このプロセスを示しているのが次の図です。

dlsw_7.gif

  1. EXPLORER を受信した D3A は、D3C にブロードキャストを送信します。D3C は D3A に接続されているボーダー ピアです。

  2. CUR フレームを受信した D3C は、グループ内のすべてのピアに CUR フレームを送信します。また、D3C はテスト フレームを送信するように設定してあるすべてのローカル インターフェイスにテスト フレームを送信し、他のグループに属するボーダー ピアに CUR フレームを送信します。

  3. D3E は別のグループに属する D3C から CUR を受信します。その後 D3E は、グループ内のすべてのピアと任意のローカル インターフェイスに CUR を送信して同じことを実行します。

  4. CUR フレームを受信した D3F は、ローカル インターフェイスにテスト ポーリングを送信します。他のルータを指すピアが D3F に設定されている場合は、D3F から他のルータにこの CUR フレームをエコーすることはできません。

  5. エンド ステーションへの応答を受信した D3F は、Icanreach フレームを D3E に返送します。

  6. D3E がこれを D3C に送信すると、D3C から D3A へ転送されます。D3A はデバイスにテスト応答を送信します。

  7. SNA の場合は XID、NetBIOS の場合は SABME を使用してエンド ステーションが DLSw 回線を開始すると、D3A は D3F とのピア接続を開始し、セッションを起動します。

このプロセスを実行したときの D3C と D3A の両方からのデバッグは、次のようになります。

d3a#
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 40
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 40 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 0
DLSw: sending bcast to BP peer 1.1.12.1(2065)

ルータがテスト フレームを受信しています。次に、ルータが D3C に CUR フレームを発信しています。D3C のアクティビティによる出力は次のとおりです。

DLSw: Pak from peer 1.1.13.1(2065) with op DLX_MEMBER_TO_BP
DLSw: recv_member_to_border() from peer 1.1.13.1(2065)
DLSw: passing pak to core originally from 1.1.13.1 in group 2
%DLSWC-3-RECVSSP: SSP OP = 3( CUR  ) -explorer from peer 1.1.13.1(2065)
DLSw: Pak from peer 1.1.11.1(2065) with op DLX_RELAY_RSP
DLSW: relaying pak to member 1.1.13.1 in group 2

D3A からパケットを受信した D3C は、そのパケットをコアに転送しています。その後、リモート ピアから応答があり、これが D3A にリレー バックされています。その後 D3A は、次のデバッグに示すとおり、リモート ピア D3F との接続(ピア オンデマンド)を開始します。

DLSw: Pak from peer 1.1.12.1(2065) with op DLX_RELAY_RSP
DLSW: creating a peer-on-demand for 1.1.10.1
DLSw: passing pak to core originally from 1.1.10.1 in group 1
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 1.1.10.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44
DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 4
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: action_a() attempting to connect peer 1.1.10.1(2065)
DLSw: action_a(): Write pipe opened for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state DISCONN, new state WAIT_RD
DLSw: passive open 1.1.10.1(11003) -> 2065
DLSw: action_c(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state WAIT_RD, new state CAP_EXG
DLSw: CapExId Msg sent to peer 1.1.10.1(2065)
DLSw: Recv CapExId Msg from peer 1.1.10.1(2065)
DLSw: Pos CapExResp sent to peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 1.1.10.1(2065)
DLSw: action_f(): for peer 1.1.10.1(2065)
DLSw: closing read pipe tcp connection for peer 1.1.10.1(2065)
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: START-FSM (1474380): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 106
DLSw: END-FSM (1474380): state:DISCONNECTED->LOCAL_RESOLVE

ルータは、ボーダー ピアからリレーされたパケットを受信した後、リモート ピア D3F (1.1.10.1) とのピア オンデマンドを開き、回線を開始します。

デバッグ

どの DLSw ネットワークでも、まずピアを始動します。ピアがなければデータは交換されません。DLSw ピア間での処理についての詳細は、RFC 1795 でほとんど説明されています。

注: DLSw を介してシスコ以外の機器と対話する場合は DLSw を使用してください。ただし、シスコのルータ同士の場合は DLSw+ を使用してください。

次の出力は debug dlsw peers を発行してから、2 つのシスコ ルータ間でピアを始動したときのものです。

DLSw: passive open 5.5.5.1(11010) -> 2065
DLSw: action_b(): opening write pipe for peer 5.5.5.1(2065)
DLSw: peer 5.5.5.1(2065), old state DISCONN, new state CAP_EXG
DLSw: CapExId Msg sent to peer 5.5.5.1(2065)
DLSw: Recv CapExId Msg from peer 5.5.5.1(2065)
DLSw: Pos CapExResp sent to peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
shSw: peer 5.5.5.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 5.5.5.1(2065)
DLSw: action_f(): for peer 5.5.5.1(2065)
DLSw: closing read pipe tcp connection for peer 5.5.5.1(2065)

この出力によると、ルータはピアを開始し、他のルータとの TCP セッションを開いています。次に、機能情報の交換を開始しています。機能情報の交換が成功すると、ピアが接続されます。RSRB とは対照的に、DLSw では活動(トラフィックなど)がない場合でもピアは閉じられた状態になりません。ピアは常に接続された状態を維持します。ピアが切断されている場合は debug dlsw peer を発行し、開けない理由を判別します。

起動中のセッションをトラブルシューティングする場合は debug dlsw core を発行してセッションの障害を監視し、回線が正常に動作しているかどうか確認します。

DLSw+ を介した 3174 通信制御装置からホストへのフローは次のとおりです。

dlsw_4.gif

次に示す debug dlsw の出力は、正常に起動されているセッションのフローです。

ibu-7206#debug dlsw
DLSw reachability debugging is on at event level for all protocol traffic
DLSw peer debugging is on
DLSw local circuit debugging is on
DLSw core message debugging is on
DLSw core state debugging is on
DLSw core flow control debugging is on
DLSw core xid debugging is on
ibu-7206#
DLSW Received-ctlQ : CLSI Msg : UDATA_STN.Ind   dlen: 208
CSM: Received CLSI Msg : UDATA_STN.Ind   dlen: 208 from TokenRing3/0
CSM:   smac 8800.5a49.1e38, dmac c000.0000.0080, ssap F0, dsap F0
CSM: Received frame type NETBIOS DATAGRAM from 0800.5a49.1e38, To3/0
DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
DLSw: Keepalive Request sent to peer 5.5.5.1(2065))
DLSw: Keepalive Response from peer 5.5.5.1(2065)
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 41
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 41 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 0

テスト フレームがステーション c001.68ff.0001 から MAC アドレス 4000.0000.0001 へ、LAN から(ローカルに)送信されてきています。各 .Ind は、パケットが LAN から送信されてきていることを意味します。ルータが LAN にパケットを送信している場合は .RSP を確認します。

DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 5.5.5.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44

ここで、リモート ピアにブロードキャストが送信され、初期セルレート(ICR)が戻っている様子を確認できます。これは、リモート ルータがそのステーションを到達可能と見なしたことを意味します。TEST_STN.Rsp は、ステーションにテスト応答を送信しているルータです。

DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 4

ステーションは、テスト応答を受信した後に最初の XID を送信します。これは、IS_STN.Ind で確認できます。ここでルータは、2 つの DLSw ルータ間でいくつかの項目をクリアするまで、このフレームをしばらく保持する必要があります。

DLSw: new_ckt_from_clsi(): TokenRing3/0 4001.68ff.0001:4->4000.0000.0001:4
DLSw: START-FSM (1622182940): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 108
DLSw: END-FSM (1622182940): state:DISCONNECTED->LOCAL_RESOLVE
 
DLSW Received-ctlQ : CLSI Msg : REQ_OPNSTN.Cfm CLS_OK dlen: 108
DLSw: START-FSM (1622182940): event:DLC-ReqOpnStn.Cnf state:LOCAL_RESOLVE
DLSw: core: dlsw_action_b()
CORE: Setting lf size to 30
%DLSWC-3-SENDSSP: SSP OP = 3(CUR)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:LOCAL_RESOLVE->CKT_START
 
%DLSWC-3-RECVSSP: SSP OP = 4(ICR)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCI 0 - s:0 so:0 r:0 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-ICR state:CKT_START
DLSw: core: dlsw_action_e()
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  ACK   - s:20 so:1 r:20 ro:1
%DLSWC-3-SENDSSP: SSP OP = 5(ACK)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_START->CKT_ESTABLISHED

これは、2 つのピア間の DLSw の内部フローです。これらのパケットは、セッション起動時に普通に見られるものです。最初の段階は、接続解除状態から CKT_ESTABLISHED 状態への移行です。両方のルータは回線自体に CUR フレームを転送します。これは、can u reach circuit setup(CURCS)と呼ばれます。CURCS フレームを開始したピアが ICRCS フレームを受信すると、確認応答を送信し、circuit established 状態に移行します。これで、DLSw ルータは両方とも XID 処理ができる状態になります。

DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
DLSw: 1622182940 sent FCA on  XID
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

ルータはステーションにテスト応答を送信した後、XID を受信します。ルータは、この XID を少しの間保存してから回線の向こうのピアに送信します。つまり、パケットに回線 ID をタグ付けして、ピアとの間で送受信していることになります。DLSw は 2 つのステーション間のアクティビティをこのようにして把握します。DLSw はクラウドの両側で論理リンク制御タイプ 2(LLC2)セッションを終了する点に注意してください。

%DLSWC-3-RECVSSP: SSP OP = 7(XID)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCA on  XID   - s:20 so:0 r:20 ro:0
DLSw: START-FSM (1622182940): event:WAN-XID state:CKT_ESTABLISHED
DLSw: core: dlsw_action_g()
DISP Sent : CLSI Msg : ID.Rsp   dlen: 12
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED
 
DLSW Received-ctlQ : CLSI Msg : ID.Ind   dlen: 39
DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

まず気付くのが、以前に送信された最初の XID への応答です。ID.Rsp で XID がステーションに送信され、ステーションがこれに ID.Ind で応答していることがわかります。次に示すのは、DLSw ピアに送信されたもう 1 つの XID です。

%DLSWC-3-RECVSSP: SSP OP = 8(CONQ)  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-CONQ state:CKT_ESTABLISHED

この部分は、もう一方のステーションが XID に SABME(CONQ)で応答したことを表しています。XID ネゴシエーションが終了し、ルータはセッションを開始できる状態になっています。

DLSw: core: dlsw_action_i()
DISP Sent : CLSI Msg : CONNECT.Req   dlen: 16

次に、ルータは SABME を CONNECT.Req でステーションに送信します。

DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CONTACT_PENDING
 
DLSW Received-ctlQ : CLSI Msg : CONNECT.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Connect.Cnf state:CONTACT_PENDING
DLSw: core: dlsw_action_j()
%DLSWC-3-SENDSSP: SSP OP = 9( CONR )  to peer 5.5.5.1(2065) success
DISP Sent : CLSI Msg : FLOW.Req   dlen: 0
DLSw: END-FSM (1622182940): state:CONTACT_PENDING->CONNECTED

その後、ステーションから非番号制確認(UA)を受信します。これは、CONNECT.Cfm メッセージ内に表示されます。これが CONR を介してリモート ピアに送信され、 相対レート(RR)プロセスが FLOW.Req で開始されます。

%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:20 so:0 r:19 ro:0
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 34
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED
 
DLSw: 1622182940 decr s - s:19 so:0 r:19 ro:0
DLSW Received-disp : CLSI Msg : DATA.Ind   dlen: 35
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  INFO  - s:19 so:0 r:39 ro:1
%DLSWC-3-SENDSSP: SSP OP = 10(INFO)  to peer 5.5.5.1(2065) success
%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:19 so:0 r:38 ro:1
DLSw: 1622182940 recv FCA on  INFO  - s:19 so:0 r:38 ro:0
DLSw: 1622182940 recv FCI 0 - s:19 so:0 r:38 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 28
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED

DATA.Req は、ルータが I-frame を転送したことを示します。DATA.Ind は、ルータが I-frame を受信したことを示します。この情報を使用して、DLSw ルータ間のパケット フローを判別できます。

DLSW Received-ctlQ : CLSI Msg : DISCONNECT.Ind   dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Disc.Ind state:CONNECTED

この部分には DISCONNECT.Ind が含まれています。.Ind は LAN から送信されたパケットを指します。この例では、ステーションが DISCONNECT を送信し、それを受けたルータは回線の切断を開始します。

DLSw: core: dlsw_action_n()
%DLSWC-3-SENDSSP: SSP OP = 14( HLTQ )  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CONNECTED->DISC_PENDING
 
%DLSWC-3-RECVSSP: SSP OP = 15( HLTR )  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-HLTR state:DISC_PENDING

ルータは、DISCONNECT を受信した後リモート ピアに HALT を送信し、応答を待ちます。残っている処理は、ステーションに UA を送信して回線を閉じることだけですが、その処理は次のデバッグに DISCONNECT.Rsp で示されています。

DLSw: core: dlsw_action_q()
DISP Sent : CLSI Msg : DISCONNECT.Rsp   dlen: 4
DISP Sent : CLSI Msg : CLOSE_STN.Req   dlen: 4
DLSw: END-FSM (1622182940): state:DISC_PENDING->CLOSE_PEND
 
DLSW Received-ctlQ : CLSI Msg : CLOSE_STN.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-CloseStn.Cnf state:CLOSE_PEND
DLSw: core: dlsw_action_y()
DLSw: 1622182940 to dead queue
DLSw: END-FSM (1622182940): state:CLOSE_PEND->DISCONNECTED

最後に DLSw は回線をデッド キューに入れます。この時点から、ポインタはクリーンアップされ、新しい回線に対応できる状態になります。

NetBIOS セッション

DLSw は異なる方法で NetBIOS セッションを制御しますが、そのデバッグ方法は類似しています。

dlsw_5.gif

注: XID は NetBIOS ステーションには送信されません。DLSw ルータが NetBIOS 名クエリ システム スイッチ プロセッサ(SSP)フレームを送信して、NetBIOS 名が認識されます。これが主な相違点です。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12249