Cisco Security Advisory: Cisco 10000, uBR10012, uBR7200 Series Devices IPC Vulnerability

2008 年 9 月 24 日 - ライター翻訳版
その他のバージョン: PDFpdf | 英語版 (2008 年 9 月 24 日) | フィードバック

Advisory ID: cisco-sa-20080924-ipc

http://www.cisco.com/cisco/web/support/JP/102/1021/1021563_cisco-sa-20080924-ipc-j.html

本翻訳は、原文の機械翻訳後に技術者が簡易レビューをしたものです。
日本語による情報は、英語による原文の非公式な翻訳であり、英語原文との間で内容の齟齬がある場合には、英語原文が優先します。

Revision 1.1

Last Updated 2009 April 16 2100 UTC (GMT)

For Public Release 2008 September 24 1600 UTC (GMT)


要約

Cisco 10000、uBR10012およびuBR7200シリーズデバイスは、User Datagram Protocol (UDP)をベースにしたInter-Process Communication (IPC)チャネルを使用しており、それが外部から到達可能です。攻撃者は、この脆弱性を不正に利用して、該当デバイスにてサービス拒絶(DoS)状態を引き起こすことができます。他のプラットフォームは影響はありません。

Ciscoはこの脆弱性に対処する無償のソフトアップデートをリリースしました。この脆弱性を軽減する対応策が存在します。

このアドバイザリは以下に掲載されます: http://www.cisco.com/cisco/web/support/JP/102/1021/1021563_cisco-sa-20080924-ipc-j.html

注: 2008年9月24日のIOSアドバイザリバンドル公開には12の Security Advisory が含まれています。そのうちの11のアドバイザリはCisco IOSソフトウェアの脆弱性に対処し、1 つのアドバイザリは Cisco Unified Communications Managerの脆弱性に対処します。各アドバイザリは、そのアドバイザリに記述された脆弱性を解決するリリースをリストします。

個々の公開リンクは下記にリストされています:

該当製品

影響を受けるバージョンを実行しているCisco 10000、uBR10012およびuBR7200シリーズデバイスが影響を受けます。

脆弱性のある製品

Cisco IOSのshow versionコマンドで、デバイスを識別することができます。次の例はCisco IOSソフトウェアリリース12.2(31)SB10eをインストールしたCisco 10000シリーズデバイスの出力です:

c10k#show version | include IOS
Cisco IOS Software, 10000 Software (C10K3-P11-M), Version 12.2(31)SB10e, RELEASE SOFTWARE (fc1)
c10k#

次の例はCisco IOSソフトウェアリリース12.3(17b)BC7をインストールしたCisco uBR10012シリーズデバイスの出力です:

ubr10k#show version | include IOS
IOS (tm) 10000 Software (UBR10K-K8P6U2-M), Version 12.3(17b)BC7, RELEASE SOFTWARE (fc1)
ubr10k#

次の例はCisco IOSソフトウェアリリース12.3(21a)BC2をインストールしたCisco uBR7200シリーズデバイスの出力です:

ubr7200#show version | include IOS
IOS (tm) 7200 Software (UBR7200-IK9SU2-M), Version 12.3(21a)BC2, RELEASE SOFTWARE (fc1)
ubr7200#

Cisco IOSリリースの命名規則のその他の情報は、以下のリンクの "White Paper: Cisco IOS Reference Guide"で確認できます: http://www.cisco.com/warp/public/620/1.html

下記の、"ソフトウエアバージョン及び修正" セクションにリストされている修正済みバージョン以前のCisco IOSバージョンはすべて脆弱性が存在します。

脆弱性が存在しない製品

Cisco uBR7100シリーズデバイスは影響を受けていません。

これ以外のシスコ製品において本アドバイザリーの影響を受けるものは現在確認されていません。

詳細

Cisco 10000、uBR10012およびuBR7200シリーズデバイスは、UDPベースのIPCチャネルを使用します。このチャネルは127.0.0.0/8の範囲、およびUDPポート1975のアドレスを使います。Cisco 10000、uBR10012およびuBR7200シリーズデバイスに影響を受けるバージョンが稼働している場合、Cisco IOSはデバイス外部からUDPポート1975に対して送信されたIPCメッセージの処理をします。この動作は、攻撃者によって、DoS状態をもたらし、さらにデバイスや、ラインカード、またはその両方のリロードを引き起こすために不正利用されるかもしれません。

127.0.0.0/8かUDPポート1975に向かう不正なトラフィックをフィルタリングすることがこの脆弱性を軽減します。この脆弱性は、CiscoバグID CSCsg15342 (登録ユーザのみ)およびCSCsh29217 (登録ユーザのみ)で文書化され、Common Vulnerabilities and Exposures(CVE) ID CVE-2008-3805が割り当てられています。

脆弱性スコア詳細

シスコは Common Vulnerability Scoring SystemCVSS)の Version 2.0に基づいた脆弱性のスコアリングを提供しています。

CVSSは、脆弱性、重要度を示唆するもので、優先度、緊急性を決定する手助けとなる標準ベースの評価法です。シスコは基本評価 (Base Score) および現状評価スコア (Temporal Score) を提供いたします。お客様はこれらを用いて環境評価スコア (Environmental Score) を算出し、個々のネットワークにおける脆弱性の影響度を導き出すことができます。シスコは以下の URLにてCVSSに関するFAQを提供しています。http://www.cisco.com/web/about/security/intelligence/cvss-qandas.html またシスコは個々のネットワークにおける環境影響度を算出するツールを以下のURLにて提供しています。http://intellishield.cisco.com/security/alertmanager/cvss

CSCsg15342 - IPC processing needs to be more robust

Calculate the environmental score of CSCsg15342
CVSS Base Score- 8.5
Access Vector Access Complexity Authentication Confidentiality Impact Integrity Impact Availability Impact
Network Low None None Partial Complete
CVSS Temporal Score- 7
Exploitability Remediation Level Report Confidence
Functional Official-Fix Confirmed
CSCsh29217 - IPC processing needs to be more robust

Calculate the environmental score of CSCsh29217
CVSS Base Score- 8.5
Access Vector Access Complexity Authentication Confidentiality Impact Integrity Impact Availability Impact
Network Low None None Partial Complete
CVSS Temporal Score- 7
Exploitability Remediation Level Report Confidence
Functional Official-Fix Confirmed

影響

脆弱性の不正な利用に成功した場合、にデバイスや、ラインカード、またはその両方のリロードを引き起こされ、結果として DoS状態となる可能性があります。

ソフトウエアバージョン及び修正

ソフトウェアのアップグレードを検討する際には、http://www.cisco.com/go/psirt およびそれ以降のアドバイザリも参照して、起こりうる障害と完全なアップグレード ソリューションを判断してください。

いずれの場合も、アップグレードする機器に十分なメモリがあること、および現在のハードウェアとソフトウェアの構成が新しいリリースで引き続き適切にサポートされていることの確認を十分に行ってください。情報が不明確な場合は、シスコ Technical Assistance Center(TAC) もしくは契約している保守会社にお問い合せください。Cisco IOSソフトウェアテーブル(下記)の各行はCisco IOSのリリーストレインを示します。あるリリーストレインが脆弱である場合、修正を含む最初のリリースは、表の "First Fixed Release" 列に示されます(入手可能予想日が示される場合もあります)。"Recommended Release" 列は、公開された全てのアドバイザリの修正を含むリリースを示します。実行しているリリースが、そのトレインで "First Fixed Release" 以前のものである場合、機器が脆弱であることが知られています。Ciscoはテーブルの "Recommended Releases" 列のリリース、またはそれ以降のリリースにアップグレードすることを推奨します。

Major Release

Availability of Repaired Releases

Affected 12.0-Based Releases

First Fixed Release

Recommended Release

12.0

Not Vulnerable

 

12.0DA

Not Vulnerable

 

12.0DB

Not Vulnerable

 

12.0DC

Not Vulnerable

 

12.0S

Releases prior to 12.0(32)S are vulnerable, release 12.0(32)S and later are not vulnerable;

12.0(32)S11

12.0(33)S1

12.0SC

Not Vulnerable

 

12.0SL

Vulnerable, migrate to 12.0S, 12.1

 

12.0SP

Not Vulnerable

 

12.0ST

Vulnerable, migrate to 12.0S, 12.1

 

12.0SX

Not Vulnerable

 

12.0SY

Not Vulnerable

 

12.0SZ

12.0(30)SZ4

12.0(32)S11

12.0(33)S1

12.0T

Not Vulnerable

 

12.0W

Not Vulnerable

 

12.0WC

Not Vulnerable

 

12.0WT

Not Vulnerable

 

12.0XA

Not Vulnerable

 

12.0XB

Not Vulnerable

 

12.0XC

Not Vulnerable

 

12.0XD

Not Vulnerable

 

12.0XE

Not Vulnerable

 

12.0XF

Not Vulnerable

 

12.0XG

Not Vulnerable

 

12.0XH

Not Vulnerable

 

12.0XI

Not Vulnerable

 

12.0XJ

Not Vulnerable

 

12.0XK

Not Vulnerable

 

12.0XL

Not Vulnerable

 

12.0XM

Not Vulnerable

 

12.0XN

Not Vulnerable

 

12.0XQ

Not Vulnerable

 

12.0XR

Not Vulnerable

 

12.0XS

Not Vulnerable

 

12.0XT

Not Vulnerable

 

12.0XV

Not Vulnerable

 

Affected 12.1-Based Releases

First Fixed Release

Recommended Release

There are no affected 12.1 based releases

Affected 12.2-Based Releases

First Fixed Release

Recommended Release

12.2

Not Vulnerable

 

12.2B

Not Vulnerable

 

12.2BC

Not Vulnerable

 

12.2BW

Not Vulnerable

 

12.2BX

Not Vulnerable

 

12.2BY

Not Vulnerable

 

12.2BZ

Not Vulnerable

 

12.2CX

Not Vulnerable

 

12.2CY

Not Vulnerable

 

12.2CZ

Not Vulnerable

 

12.2DA

Not Vulnerable

 

12.2DD

Not Vulnerable

 

12.2DX

Not Vulnerable

 

12.2EW

Not Vulnerable

 

12.2EWA

Not Vulnerable

 

12.2EX

Not Vulnerable

 

12.2EY

Not Vulnerable

 

12.2EZ

Not Vulnerable

 

12.2FX

Not Vulnerable

 

12.2FY

Not Vulnerable

 

12.2FZ

Not Vulnerable

 

12.2IRB

Not Vulnerable

 

12.2IXA

Not Vulnerable

 

12.2IXB

Not Vulnerable

 

12.2IXC

Not Vulnerable

 

12.2IXD

Not Vulnerable

 

12.2IXE

Not Vulnerable

 

12.2IXF

Not Vulnerable

 

12.2IXG

Not Vulnerable

 

12.2JA

Not Vulnerable

 

12.2JK

Not Vulnerable

 

12.2MB

Not Vulnerable

 

12.2MC

Not Vulnerable

 

12.2S

Not Vulnerable

 

12.2SB

12.2(31)SB13

12.2(33)SB1

12.2(33)SB2; Available on 26-SEP-08

12.2SBC

Not Vulnerable

 

12.2SCA

12.2(33)SCA1

12.2(33)SCA1

12.2SE

Not Vulnerable

 

12.2SEA

Not Vulnerable

 

12.2SEB

Not Vulnerable

 

12.2SEC

Not Vulnerable

 

12.2SED

Not Vulnerable

 

12.2SEE

Not Vulnerable

 

12.2SEF

Not Vulnerable

 

12.2SEG

Not Vulnerable

 

12.2SG

Not Vulnerable

 

12.2SGA

Not Vulnerable

 

12.2SL

Not Vulnerable

 

12.2SM

Not Vulnerable

 

12.2SO

Not Vulnerable

 

12.2SRA

Not Vulnerable

 

12.2SRB

Not Vulnerable

 

12.2SRC

12.2(33)SRC2

12.2(33)SRC2

12.2SU

Not Vulnerable

 

12.2SV

Not Vulnerable

 

12.2SVA

Not Vulnerable

 

12.2SVC

Not Vulnerable

 

12.2SVD

Not Vulnerable

 

12.2SW

Not Vulnerable

 

12.2SX

Not Vulnerable

 

12.2SXA

Not Vulnerable

 

12.2SXB

Not Vulnerable

 

12.2SXD

Not Vulnerable

 

12.2SXE

Not Vulnerable

 

12.2SXF

Not Vulnerable

 

12.2SXH

Not Vulnerable

 

12.2SY

Not Vulnerable

 

12.2SZ

Not Vulnerable

 

12.2T

Not Vulnerable

 

12.2TPC

Not Vulnerable

 

12.2XA

Not Vulnerable

 

12.2XB

Not Vulnerable

 

12.2XC

Not Vulnerable

 

12.2XD

Not Vulnerable

 

12.2XE

Not Vulnerable

 

12.2XF

Not Vulnerable

 

12.2XG

Not Vulnerable

 

12.2XH

Not Vulnerable

 

12.2XI

Not Vulnerable

 

12.2XJ

Not Vulnerable

 

12.2XK

Not Vulnerable

 

12.2XL

Not Vulnerable

 

12.2XM

Not Vulnerable

 

12.2XN

Not Vulnerable

 

12.2XNA

Not Vulnerable

 

12.2XNB

Not Vulnerable

 

12.2XO

Not Vulnerable

 

12.2XQ

Not Vulnerable

 

12.2XR

Not Vulnerable

 

12.2XS

Not Vulnerable

 

12.2XT

Not Vulnerable

 

12.2XU

Not Vulnerable

 

12.2XV

Not Vulnerable

 

12.2XW

Not Vulnerable

 

12.2YA

Not Vulnerable

 

12.2YB

Not Vulnerable

 

12.2YC

Not Vulnerable

 

12.2YD

Not Vulnerable

 

12.2YE

Not Vulnerable

 

12.2YF

Not Vulnerable

 

12.2YG

Not Vulnerable

 

12.2YH

Not Vulnerable

 

12.2YJ

Not Vulnerable

 

12.2YK

Not Vulnerable

 

12.2YL

Not Vulnerable

 

12.2YM

Not Vulnerable

 

12.2YN

Not Vulnerable

 

12.2YO

Not Vulnerable

 

12.2YP

Not Vulnerable

 

12.2YQ

Not Vulnerable

 

12.2YR

Not Vulnerable

 

12.2YS

Not Vulnerable

 

12.2YT

Not Vulnerable

 

12.2YU

Not Vulnerable

 

12.2YV

Not Vulnerable

 

12.2YW

Not Vulnerable

 

12.2YX

Not Vulnerable

 

12.2YY

Not Vulnerable

 

12.2YZ

Not Vulnerable

 

12.2ZA

Not Vulnerable

 

12.2ZB

Not Vulnerable

 

12.2ZC

Not Vulnerable

 

12.2ZD

Not Vulnerable

 

12.2ZE

Not Vulnerable

 

12.2ZF

Not Vulnerable

 

12.2ZG

Not Vulnerable

 

12.2ZH

Not Vulnerable

 

12.2ZJ

Not Vulnerable

 

12.2ZL

Not Vulnerable

 

12.2ZP

Not Vulnerable

 

12.2ZU

Not Vulnerable

 

12.2ZX

Vulnerable; first fixed in 12.2SB

12.2(33)SB2; Available on 26-SEP-08

12.2ZY

Not Vulnerable

 

12.2ZYA

Not Vulnerable

 

Affected 12.3-Based Releases

First Fixed Release

Recommended Release

12.3

Not Vulnerable

 

12.3B

Not Vulnerable

 

12.3BC

12.3(17b)BC6

12.3(21a)BC1

12.3(23)BC

12.3(23)BC4

12.3BW

Not Vulnerable

 

12.3EU

Not Vulnerable

 

12.3JA

Not Vulnerable

 

12.3JEA

Not Vulnerable

 

12.3JEB

Not Vulnerable

 

12.3JEC

Not Vulnerable

 

12.3JK

Not Vulnerable

 

12.3JL

Not Vulnerable

 

12.3JX

Not Vulnerable

 

12.3T

Note: Releases prior to 12.3(14)T3 are vulnerable, release 12.3(14)T3 and later are not vulnerable;

12.4(15)T7

12.4(18c)

12.3TPC

Not Vulnerable

 

12.3VA

Not Vulnerable

 

12.3XA

Not Vulnerable

 

12.3XB

Not Vulnerable

 

12.3XC

Not Vulnerable

 

12.3XD

Not Vulnerable

 

12.3XE

Not Vulnerable

 

12.3XF

Not Vulnerable

 

12.3XG

Not Vulnerable

 

12.3XI

12.3(7)XI10a

12.2(33)SB2; Available on 26-SEP-08

12.3XJ

Not Vulnerable

 

12.3XK

Not Vulnerable

 

12.3XL

Not Vulnerable

 

12.3XQ

Not Vulnerable

 

12.3XR

Not Vulnerable

 

12.3XS

Not Vulnerable

 

12.3XU

Not Vulnerable

 

12.3XW

Not Vulnerable

 

12.3XX

Not Vulnerable

 

12.3XY

Not Vulnerable

 

12.3XZ

Not Vulnerable

 

12.3YA

Not Vulnerable

 

12.3YD

Not Vulnerable

 

12.3YF

Not Vulnerable

 

12.3YG

Not Vulnerable

 

12.3YH

Not Vulnerable

 

12.3YI

Not Vulnerable

 

12.3YJ

Not Vulnerable

 

12.3YK

Not Vulnerable

 

12.3YM

Not Vulnerable

 

12.3YQ

Not Vulnerable

 

12.3YS

Not Vulnerable

 

12.3YT

Not Vulnerable

 

12.3YU

Not Vulnerable

 

12.3YX

Not Vulnerable

 

12.3YZ

Not Vulnerable

 

12.3ZA

Not Vulnerable

 

Affected 12.4-Based Releases

First Fixed Release

Recommended Release

12.4

Note: Releases prior to 12.4(3) are vulnerable, release 12.4(3) and later are not vulnerable;

12.4(18c)

12.4JA

Not Vulnerable

 

12.4JK

Not Vulnerable

 

12.4JL

Not Vulnerable

 

12.4JMA

Not Vulnerable

 

12.4JMB

Not Vulnerable

 

12.4JMC

Not Vulnerable

 

12.4JX

Not Vulnerable

 

12.4MD

Not Vulnerable

 

12.4MR

Not Vulnerable

 

12.4SW

Not Vulnerable

 

12.4T

Not Vulnerable

 

12.4XA

Not Vulnerable

 

12.4XB

Not Vulnerable

 

12.4XC

Not Vulnerable

 

12.4XD

Not Vulnerable

 

12.4XE

Not Vulnerable

 

12.4XF

Not Vulnerable

 

12.4XG

Not Vulnerable

 

12.4XJ

Not Vulnerable

 

12.4XK

Not Vulnerable

 

12.4XL

Not Vulnerable

 

12.4XM

Not Vulnerable

 

12.4XN

Not Vulnerable

 

12.4XP

Not Vulnerable

 

12.4XQ

Not Vulnerable

 

12.4XR

Not Vulnerable

 

12.4XT

Not Vulnerable

 

12.4XV

Not Vulnerable

 

12.4XW

Not Vulnerable

 

12.4XY

Not Vulnerable

 

12.4XZ

Not Vulnerable

 

12.4YA

Not Vulnerable

 

回避策

対応策は、127.0.0.0/8の範囲に送信されるパケット、およびポート1975に送信されるUDPパケットをフィルタリングすることです。

インターフェイス・アクセス・コントロール・リストの使用

ポート1975に向かうUDPパケットをフィルタリングするアクセス・リストをこの脆弱性を軽減するために使用することができます。ただし、UDPポート1975は、ある特定のアプリケーションが使用できる登録済みのポート番号です。UDPポート1975に向かうすべてのパケットをフィルタリングすることで、いくつかのアプリケーションが誤動作するかもしれません。したがって、UDP 1975パケットは、ルータ・インターフェイスのIPアドレス宛に送信されたパケットをすべてを明示的に拒否して、機器を通過するトラフィックには許可を与えるアクセス・リストである必要があります。そのアクセス・リストはすべてのインターフェイスで適用する必要があります。IPCチャネルは127.0.0.0/8の範囲のアドレスを使うので、この範囲を送信元か送信先にしたパケットをフィルタリングすることもまた必要です。例を次に示します:

access-list 100 deny udp any host <router-interface 1> eq 1975
access-list 100 deny udp any host <router-interface 2> eq 1975
access-list 100 deny udp any host <router-interface ...> eq 1975
access-list 100 deny ip 127.0.0.0 0.255.255.255 any
access-list 100 deny ip any 127.0.0.0 0.255.255.255
access-list 100 permit ip any any

interface Serial 0/0
  ip access-group 100 in

コントロール・プレーン・ポリシングの使用

影響を受けるデバイス向けの、信頼できないUDPポート1975アクセスをブロックするために、コントロール・プレーン・ポリシング(CoPP)を使用することができます。Cisco IOSソフトウェアリリース12.2BCおよび12.2SCAはCoPP機能をサポートします。CoPPをデバイスに設定することにより、既存のセキュリティーポリシーとコンフィギュレーションに従って、明示的に認定されたトラフィックだけがインフラストラクチャデバイス宛に送信されることを許可され、インフラストラクチャへの直接攻撃のリスクとその効果を最小限に抑え、管理およびコントロールプレーンが保護されます。以下の例がネットワークに適用できます。

注: CoPPはuBR10012シリーズデバイスでサポートされません。

!-- Permit all UDP/1975 traffic so that it
!-- will be policed and dropped by the CoPP feature
!
access-list 111 permit udp any any eq 1975
access-list 111 permit ip any 127.0.0.0 0.255.255.255
access-list 111 permit ip 127.0.0.0 0.255.255.255 any
!
!-- Permit (Police or Drop)/Deny (Allow) all other Layer 3 and
!-- Layer 4 traffic in accordance with existing security policies
!-- and configurations for traffic that is authorized to be sent
!-- to infrastructure devices
!
!-- Create a Class-Map for traffic to be policed by the CoPP
!-- feature
!
class-map match-all drop-IPC-class
  match access-group 111
!
!-- Create a Policy-Map that will be applied to the Control-Plane
!-- of the device
!
policy-map drop-IPC-traffic
  class drop-IPC-class
    drop
!
!-- Apply the Policy-Map to the Control-Plane of the device
!
control-plane
  service-policy input drop-IPC-traffic
!

上記のCoPPの設定例では、アクセス コントロール リストエントリー(ACE)のpermitアクションに一致し攻撃である可能性のあるパケットはpolicy-map "drop"によって破棄され、(表示されていない)denyアクションと一致するパケットはpolicy-map "drop"の影響を受けません。

Cisco IOS 12.2Sおよび12.0Sトレインでは、policy-mapの定義文が相違することに注意してください:

!
policy-map drop-IPC-traffic class drop-IPC-class
  police 32000 1500 1500 conform-action drop exceed-action drop
!

CoPP機能の設定、および使用に関するその他の情報はhttp://www.cisco.com/web/about/security/intelligence/coppwp_gs.htmlhttp://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6586/ps6642/prod_white_paper0900aecd804fa16a.htmlおよびhttp://www.cisco.com/en/US/docs/ios/12_3t/12_3t4/feature/guide/gtrtlimt.htmlで、確認することができます。

ネットワーク境界のインフラストラクチャACLの使用

ネットワークを通過するトラフィックをブロックすることは多くの場合困難ですが、基幹デバイスをターゲットにしたトラフィックを許可せずに、ネットワーク境界においてそのトラフィックをブロックすることは可能です。iACLsはネットワークセキュリティ最良の方法ですので、よいネットワークセキュリティ方法として長期的に適用することを考慮すべきです。また、特定の脆弱性の対応策にもなります。次のiACL例は、基幹デバイスのIPアドレスを含むIPアドレス範囲を保護するために、インフラストラクチャ・アクセスリストの一部として含まれるべき項目です:

!-- Note: IPC packets sent to UDP destination port 1975 must not
!--       be permitted from any trusted source as this traffic
!--       should only be sent and received internally by the
!--       affected device using an IP address allocated from the
!--       127.0.0.0/8 prefix.
!--
!--       IPC that traffic that is internally generated and sent
!--       and/or received by the affected device is not subjected
!--       to packet filtering by the applied iACL policy.
!
!-- Deny IPC (UDP port 1975) packets from all sources destined to
!-- all IP addresses configured on the affected device.
!
access-list 150 deny udp any host INTERFACE_ADDRESS#1 eq 1975
access-list 150 deny udp any host INTERFACE_ADDRESS#2 eq 1975
access-list 150 deny udp any host INTERFACE_ADDRESS#N eq 1975
!
!-- Deny all IP packets with a source or destination IP address 
!-- from the 127.0.0.0/8 prefix.
!
access-list 150 deny ip 127.0.0.0 0.255.255.255 any
access-list 150 deny ip any 127.0.0.0 0.255.255.255
!
!-- Permit/deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations.
!
!-- Permit all other traffic to transit the device.
!
access-list 150 permit ip any any
!
!-- Apply iACL to interfaces in the ingress direction.
!
interface GigabitEthernet0/0
  ip access-group 150 in
!

注: ポート1975に向かうUDPパケットをフィルタリングするアクセス・リストをこの脆弱性を軽減するために使用することができます。ただし、UDPポート1975は、ある特定のアプリケーションが使用できる登録済みのポート番号です。UDPポート1975に向かうすべてのパケットをフィルタリングすることで、いくつかのアプリケーションが誤動作するかもしれません。したがって iACLポリシーでは、ルータの全てのインターフェイスのIPアドレス宛に送信されるUDP宛先ポート 1975のパケットを明示的に拒否する必要があります。そして、その他のレイヤ3、ならびにレイヤ4トラフィックは、セキュリティ方針や定義にしたがって、認可したり拒否した上で、機器を通過するその他のトラフィックを許可する必要があります。iACLsが効果的に使用されるためには、すべてのインターフェイスに適用する必要があります。IPCチャネルは127.0.0.0/8の範囲のアドレスを使うので、上記の例のようにこの範囲を送信元か送信先にしたパケットをフィルタリングすることもまた必要です。

インフラストラクチャ・プロテクション・アクセス・リストのガイドライン、および推奨される設定技術については、"Protecting Your Core: Infrastructure Protection Access Control Lists" と名付けられた white paperを参照願います。このwhite paperは、こちらより入手できます: http://www.cisco.com/cisco/web/support/JP/100/1006/1006441_iacl-j.html

追加の軽減技術

ネットワーク内のCiscoデバイスで展開可能な、このアドバイザリの追加の軽減技術については、付属ドキュメントである Cisco Applied Mitigation Bulletinを参照ください:

http://www.cisco.com/en/US/products/products_applied_mitigation_bulletin09186a0080a01522.html

修正済みソフトウェアの入手

Ciscoはこれらの脆弱性対応用の無償ソフトウェアを提供しています。ソフトウェアの導入を行う前に、機能のソフトウェアの互換性およびお客様のネットワーク環境に特有の問題に関して確認いただくか、あるいはお客様のメンテナンスプロバイダーにご相談ください。

お客様がインストールしたり、サポートを受けたりできるのは、ご購入いただいたフィーチャーセットに対してのみとなります。そのようなソフトウェア アップグレードをインストール、ダウンロード、アクセスまたはその他の方法で使用した場合、お客様はhttp://www.cisco.com/en/US/docs/general/warranty/English/EU1KEN_.htmlにあるシスコのソフトウェア ライセンスの条項または http://www.cisco.com/public/sw-center/sw-usingswc.shtml にある Cisco.com のダウンロードに示されるその他の条項に従うことに同意したことになります。ソフトウェアのアップグレードに関し、"psirt@cisco.com" もしくは "security-alert@cisco.com" にお問い合わせいただくことはご遠慮ください。

ご契約を有するお客様

サービス契約をされているお客様は、通常のアップデート チャネルからアップグレード ソフトウェアを入手してください。ご契約を有するお客様は、通常の経路でそれを入手してください。ほとんどのお客様は、シスコのワールドワイドウェブサイト上の ソフトウェアセンターから入手することができます。http://www.cisco.com.

サードパーティのサポート会社をご利用のお客様

シスコ パートナー、正規販売代理店、サービス プロバイダーなど、サードパーティのサポート会社と以前に契約していたか、または現在契約しており、その会社からシスコ製品の提供または保守を受けている お客様は、該当するサポート会社に連絡し、本脆弱性に関する適切な処置について指示と支援を受けてください。

回避策の効果は、お客様の状況、使用製品、ネットワークトポロジー、トラフィックの性質や組織の目的に依存します。影響製品が多種多様であるため、回避策 を実際に展開する前に、対象とするネットワークで適用する回避策が最適であるか、お客様のサービスプロバイダーやサポート組織にご相談ください。

サービス契約をご利用でないお客様

シスコから直接購入したがシスコのサービス契約をご利用いただいていない場合、また、サードパーティ ベンダーから購入したが修正済みソフトウェアを購入先から入手できない場合は、シスコの Technical Assistance Center(TAC)に連絡してアップグレードを入手してください。TAC の連絡先は次のとおりです。

  • +1 800 553 2447(北米内からのフリー ダイヤル)
  • +1 408 526 7209(北米以外からの有料通話)
  • 電子メール: tac@cisco.com

無料アップグレードの対象であることをご証明いただくために、製品のシリアル番号を用意し、このお知らせのURLを知らせてください。サポート契約をご利用でないお客様に対する無料アップグレードは、TAC 経由でご要求いただく必要があります。

さまざまな言語向けの各地の電話番号、説明、電子メール アドレスなどの、この他の TAC の連絡先情報については、http://www.cisco.com/cisco/web/support/JP/cisco_worldwide_contacts.html を参照してください。

不正利用事例と公式発表

Cisco PSIRT では、本アドバイザリに記載されている脆弱性の不正利用事例とその公表は確認しておりません。

この脆弱性は内部で発見されました。

この通知のステータス: FINAL

本アドバイザリは無保証のものとしてご提供しており、いかなる種類の保証を示唆するものでもありません。本アドバイザリの情報およびリンクの使用に関する責任の一切はそれらの使用者にあるものとします。Ciscoはこの文書をいつでも変更するか、またはアップデートする権利を所有します。

後述する情報配信の URL を省略し、本アドバイザリの記述内容に関して、独自の複製・意訳を実施した場合には、事実誤認ないし重要な情報の欠落を含む統制不可能な情報の伝搬が行われる可能性があります。

情報配信

本アドバイザリーは、以下のシスコのワールドワイドウェブサイト上に掲載されます。

http://www.cisco.com/cisco/web/support/JP/102/1021/1021563_cisco-sa-20080924-ipc-j.html ワールドワイドのウェブ以外にも、次の電子メールおよび Usenet ニュースの受信者向けに、この通知のテキスト版がシスコ PSIRT PGP キーによるクリア署名つきで投稿されています。

  • cust-security-announce@cisco.com
  • first-bulletins@lists.first.org
  • bugtraq@securityfocus.com
  • vulnwatch@vulnwatch.org
  • cisco@spot.colorado.edu
  • cisco-nsp@puck.nether.net
  • full-disclosure@lists.grok.org.uk
  • comp.dcom.sys.cisco@newsgate.cisco.com

この通知に関する今後の最新情報は、いかなるものもシスコのワールドワイドウェブに掲載される予定です。しかしながら、前述のメーリングリストもしくは ニュースグループに 対し積極的に配信されるとは限りません。この問題に関心があるお客様は上記 URL にて最新情報をご確認いただくことをお勧めいたします。この問題について心配するユーザはあらゆるアップデートがあるように上のURLを確認するように勧められます。

更新履歴

Revision 1.1

2009-April-16

Removed references to the combined software table, as it is now outdated.

Revision 1.0

2008-Sep-24

Initial public release

シスコセキュリティ手順

Cisco製品におけるセキュリティの脆弱性の報告、セキュリティ事故に関する支援、およびCiscoからセキュリティ情報を入手するための登録方法について詳しく知るには、Ciscoワールドワイドウェブサイトの http://www.cisco.com/en/US/products/products_security_advisory09186a00809c2168.shtml にアクセスしてください。このページにはCiscoのセキュリティ通知に関してメディアが問い合わせる際の指示が掲載されています。全てのCiscoセキュリティアドバイザリは http://www.cisco.com/go/psirt で確認することができます。