IP : IP ルーティング

ループバック アドレスを使用する場合と使用しない場合の iBGP と eBGP の設定例

2008 年 9 月 17 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 5 月 11 日) | フィードバック

Author:Syed Faraz Shamim


目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      ネットワーク ダイアグラム
      iBGP の設定
      eBGP の設定
      ループバック アドレスを使用した iBGP の設定
      ループバック アドレスを使用した eBGP の設定
確認
      iBGP の設定の確認
      eBGP の設定の確認
      ループバック アドレスを使用した iBGP の設定の確認
      ループバック アドレスを使用した eBGP の設定の確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

BGP は Exterior Gateway Protocol(EGP)を指しており、TCP/IP ネットワークでドメイン間ルーティングを実行するために使用されます。BGP アップデートを交換できるようにするためには、BGP ルータが BGP ピアと(TCP ポート 179 で)接続を確立しておく必要があります。異なる Autonomous System(AS; 自律システム)に BGP ピアがある場合、この 2 つの BGP ピア間の BGP セッションを external BGP(eBGP)セッションと呼びます。同じ Autonomous System(AS; 自律システム)に BGP ピアがある場合、この 2 つの BGP ピア間の BGP セッションを internal BGP(iBGP)セッションと呼びます。

デフォルトでは、ピアのルータに一番近いインターフェイスの IP アドレスを使用してピア関係が確立されます。ただし、neighbor update-source登録ユーザ専用コマンドを使用すれば、ループバック インターフェイスを含む動作中の任意のインターフェイスを指定して TCP 接続を確立できます。BGP ピア間に複数のパスがあるときには、ループバック インターフェイスを使用するこのピアリング方法を使用すると BGP セッションがダウンしないので便利です。この方法を使用しない場合、セッションの確立に使用している物理インターフェイスがダウンすると、BGP セッションが切断されてしまいます。さらに、この方法では、複数のリンクがある BGP が動作するルータ間で、使用可能なパスを利用して負荷を分散することもできます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

このドキュメントの iBGP と eBGP の設定例には、ループバック アドレスを使用した場合と使用しない場合の両方があります。

注:隣接関係を確立するために、これらの設定例を使用できます。より複雑な設定については、『ドメイン間ルーティングのための Border Gateway Protocol の使用』を参照してください。

前提条件

要件

この設定を開始する前に、次の要件が満たされていることを確認してください。

  • BGP プロトコルに関する知識

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。このドキュメントに掲載されているコマンド出力は、IOS(R) バージョン 12.2(24a) が稼働する 2500 シリーズ ルータから採取されたものです。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、次の設定例を示しています。

このセクションでは、このドキュメントで説明されている機能を設定するための情報を提供しています。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

23a.gif

iBGP の設定

R1-AGS R6-2500
Current configuration:

!--- 出力を省略。

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 400

!--- 自律システム(AS)400 用に
!--- BGP をイネーブルにします。

 neighbor 10.10.10.2 remote-as 400
 
!--- リモート AS 400 で
 !--- ネイバー 10.10.10.2 を指定して、
 !--- これを iBGP 接続にします。  
!--- 出力を省略。

end
Current configuration:

!--- 出力を省略。

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 400

!--- 出力を省略。

end

上記の設定では、両方のルータは、ともに AS 番号 400 にあります。

eBGP の設定

R1-AGS R6-2500
Current configuration:

!--- 出力を省略。

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 300

!--- 自律システム(AS)300 用に
!--- BGP をイネーブルにします。

 neighbor 10.10.10.2 remote-as 400
 
!--- リモート AS 400 で
 !--- ネイバー 10.10.10.2 を指定して、
 !--- これを eBGP 接続にします。


!--- 出力を省略。

end
Current configuration:

!--- 出力を省略。

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 300

!--- 出力を省略。

end

eBGP を使用している場合、ピアは直接接続する必要があります。直接接続されていない場合、ルータが隣接関係を確立するためには、neighbor ebgp-multihop登録ユーザ専用コマンドを使用する必要があり、さらに IGP またはスタティック ルートを経由してピアに到達するパスが存在する必要があります。上記の設定では、R1-AGS のルータが AS 300 に属しているのに対し、R6-2500 のルータは AS 400 に属しています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ループバック アドレスを使用した iBGP の設定

このセクションに示すように、ループバック アドレス(または他の動作可能なインターフェイス)を使用して iBGP を設定できます。

R1-AGS R6-2500
Current configuration:


!--- 出力を省略。

interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 300
  neighbor 2.2.2.2 update-source Loopback0
  
!--- このコマンドでは、指定された外部ピアとの
  !--- TCP 接続をループバック インターフェイスの
  !--- アドレスを使用して確立する必要があることが
  !--- 指定されています。

 !
 ip route 2.2.2.2 255.255.255.255 10.10.10.2
 
!--- このスタティック ルートにより、 
 !--- ピアリングに使用されるリモート ピア アドレスへの
 !--- 到達性が確保されています。
!--- 出力を省略。

end
Current configuration:


!--- 出力を省略。

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 300
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1

!--- 出力を省略。

end

ループバック アドレスを使用した eBGP の設定

このセクションに示すように、ループバック アドレス(または他の動作可能なインターフェイス)を使用して eBGP を設定することもできます。複数のパスがあるネットワークで、ループバック インターフェイスをこのように使用して到達性を確保する方法は、『シングルホームおよびマルチホーム環境における、BGP を使用したロード シェアリングの設定例』の「BGP ネイバーとしてループバック アドレスを使用するロード シェアリング」セクションに示されています。

R1-AGS R6-2500
Current configuration:


!--- 出力を省略。


interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 400
  neighbor 2.2.2.2 ebgp-multihop 2
 
 !--- このコマンドでは、
  !--- 直接接続されていない外部 BGP ピアか、 
  !--- 直接接続されているインターフェイス以外の 
  !--- インターフェイスを使用している外部 BGP 
  !--- ピアにパケットが到達するように
  !--- ttl 値を変更しています。

  neighbor 2.2.2.2 update-source Loopback0
  
!--- このコマンドでは、ループバック インタフェイス上の
  !--- アドレスを使用して、外部 BGP ピアとの
  !--- TCP 接続が確立されるように
  !--- 指定しています。
 !

 ip route 2.2.2.2 255.255.255.255 10.10.10.2

 !--- このスタティック ルートにより、 
 !--- ピアリングに使用されるリモート ピア アドレスへの
 !--- 到達性が確保されています。


!--- 出力を省略。


end
Current configuration:


!--- 出力を省略。


interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1


!--- 出力を省略。


end

確認

このセクションでは、設定が正しく動作していることを確認するための情報を提供しています。特定の show コマンドは、アウトプットインタープリタ popup_icon.gif でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

iBGP の設定の確認

show ip bgp neighbors登録ユーザ専用コマンドを使用して、TCP と Border Gateway Protocol(BGP)の接続に関する情報を表示して、BGP ピアが確立されているかどうかを確認します。次の show ip bgp neighbors コマンドの出力は、BGP の状態が「Established」であることが示されています。これは、BGP のピア関係が正しく確立されていることを示しています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:04:20
  BGP table version 1, neighbor version 1
R1-AGS#

上記では、show ip bgp neighbors コマンドが | include BGP という修飾子とともに使用されています。このようにすれば、コマンド出力にフィルタがかかって関連するポートだけが表示されるので、出力が読みやすくなります。

さらに、show ip bgp summary登録ユーザ専用コマンドを使用して、すべての BGP 接続の状態を表示することもできます。次に例を示します。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 400     
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

eBGP の設定の確認

show ip bgp neighbors登録ユーザ専用コマンドを使用して、TCP と Border Gateway Protocol(BGP)の接続に関する情報を表示して、BGP ピアが確立されているかどうかを確認します。次の show ip bgp neighbors コマンドの出力は、BGP の状態が「Established」であることが示されています。これは、BGP のピア関係が正しく確立されていることを示しています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:17
  BGP table version 1, neighbor version 1

さらに、show ip bgp summary登録ユーザ専用コマンドを使用して、すべての BGP 接続の状態を表示することもできます。次に例を示します。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.10.10.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

ループバック アドレスを使用した iBGP の設定の確認

show ip bgp neighbors登録ユーザ専用コマンドを使用して、TCP と Border Gateway Protocol(BGP)の接続に関する情報を表示して、BGP ピアが確立されているかどうかを確認します。次の show ip bgp neighbors コマンドの出力は、BGP の状態が「Established」であることが示されています。これは、BGP のピア関係が正しく確立されていることを示しています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 300, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:28
  BGP table version 1, neighbor version 1
R1-AGS#

さらに、show ip bgp summary登録ユーザ専用コマンドを使用して、すべての BGP 接続の状態を表示することもできます。次に例を示します。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

R1-AGS(9)# show ip bgp summary
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

ループバック アドレスを使用した eBGP の設定の確認

show ip bgp neighbors登録ユーザ専用コマンドを使用して、TCP と Border Gateway Protocol(BGP)の接続に関する情報を表示して、BGP ピアが確立されているかどうかを確認します。次の show ip bgp neighbors コマンドの出力は、BGP の状態が「Established」であることが示されています。これは、BGP のピア関係が正しく確立されていることを示しています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:16
  BGP table version 1, neighbor version 1
  External BGP neighbor may be up to 2 hops away.

さらに、show ip bgp summary登録ユーザ専用コマンドを使用して、すべての BGP 接続の状態を表示することもできます。次に例を示します。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

R1-AGS(9)# show ip bgp summary
BGP router identifier 1.1.1.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

トラブルシューティング

トラブルシューティングについての情報は、『BGP 近隣ルータがアイドル、接続、アクティブ状態間を切り替わる理由』および『トラブルシューティング:BGP』を参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13751