ダイヤルとアクセス : ダイヤルオンデマンド ルーティング(DDR)

Easy IP と DHCP サーバを使用したダイヤルオンデマンド ルーティング(DDR)

2008 年 8 月 26 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 10 月 24 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
背景説明
      Easy IP のコンポーネント
      Easy IP の動作ステップ
設定
      ネットワーク ダイアグラム
      設定例
確認
      show コマンド
      show コマンドの出力例
トラブルシューティング
      debug コマンド
      debug コマンドの出力例
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、Cisco IOS(R) ソフトウェアの Easy IP 機能の使用方法について説明しています。Easy IP は、リモート サイト全体に対して IP アドレスを 1 つだけ割り当てているインターネット サービスプロバイダー(ISP)経由でサイト全体がインターネットに接続しているという場合に、役に立つものです。Easy IP ルータは、サービス プロバイダーの Network Access Server(NAS; ネットワーク アクセス サーバ)にダイヤルし、自身の WAN IP アドレスをネゴシエートします。次に Easy IP ルータは、このネゴシエートされたアドレスを使用してポート アドレス変換(PAT)によるネットワーク アドレス変換(NAT)を実行し、Inside クライアントに Outside アクセスを提供します。Easy IP ルータのもう 1 つのオプション機能は、LAN の Inside クライアントに対して DHCP サーバとしてして動作することです。Cisco Small Office, Home Office(SOHO)ルータは、一般にこのタイプの設定で使用されています。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Easy IP ルータ:イーサネット インターフェイス x 4 および BRI インターフェイス x 8 が搭載された Cisco 3620。Cisco IOS ソフトウェア リリース 12.0(7)XK2 を使用。

  • アクセス サーバ:イーサネット ポート x 1、ファースト イーサネット ポート x 1、およびチャネライズド T1/PRI ポート x 4 が搭載された Cisco AS5300。Cisco IOS ソフトウェア リリース 12.1(7) を使用。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

Easy IP のコンポーネント

  • Point-to-Point Protocol(PPP)/IP Control Protocol(IPCP):これは RFC 1332leavingcisco.com で定義されています。IPCP は、PPP 上で IP アドレスを動的に設定することを可能にします。Cisco IOS Easy IP ルータは、PPP/IPCP を使用して、中央のアクセス サーバまたは DHCP サーバ と正規の WAN インターフェイス IP アドレスを動的にネゴシエートします。

  • NAT:2 つ以上のネットワークを接続するルータで動作します。Easy IP では、これらのネットワークの少なくとも 1 つ(「Inside」または「LAN」と呼ばれる)にプライベート アドレスが割り当てられます。正規のネットワーク(「Outside」または「WAN」と呼ばれる)にパケットを転送するためには、このプライベート アドレスが正規アドレスに変換される必要があります。Easy IP のコンテキストでは、Port Address Translation(PAT; ポート アドレス変換)は、すべての内部プライベート アドレスを、単一の登録済み Outside IP アドレスに変換するために使用されます。

  • LAN クライアントに対する DHCP:これは Cisco Easy IP ルータのオプション機能で、Inside の LAN クライアントに IP アドレスを割り当てるために使用できます。クライアントに IP アドレスを割り当てるためには、静的な割り当てや DHCP PC サーバの使用など、他の方法も利用できます。

Easy IP の動作ステップ

  1. Easy IP ルータが DHCP サーバとして設定されている場合、LAN の Inside クライアントは電源投入時にこのルータからプライベート IP アドレスを受け取ります。Easy IP ルータが DHCP サーバとして設定されていない場合、クライアントは別の方法で IP アドレスを割り当てられる必要があります。

  2. ある LAN の Inside クライアントがダイヤルアップのために(アクセス コントロール リストで定義された)「対象」トラフィックを生成すると、Easy IP ルータは PPP/IPCP を使用して中央サイトのアクセス サーバにダイヤルし、単一の正規 IP アドレスを要求します。この接続が確立されると、他の LAN の Inside クライアントは、この回線をステップ 4 のように利用できます。

  3. 中央サイトのアクセス サーバはローカル IP アドレス プールからダイナミック グローバル アドレスを返し、このアドレスが Easy IP ルータの WAN インターフェイスに割り当てられます。

  4. Easy IP ルータは、PAT を使用して WAN インターフェイスの正規 IP アドレスを LAN の Inside クライアントのプライベート IP アドレスに自動的に変換します。これにより、中央サイトのアクセス サーバへの接続が確立されます。

Easy IP についての詳細は、ドキュメント『White Paper:Cisco IOS Easy IP』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供しています。

ネットワーク ダイアグラム

このドキュメントでは、次の図に示すネットワーク構成を使用しています。

ddreasyip.gif

設定例

このドキュメントでは、次に示す設定を使用しています。

Easy IP Router

EasyIP#show running-config
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname EasyIP
!
username ISP-AS password 0 ipnegotiate

! --- リモート ルータ(ISP-AS)のユーザ名と共有秘密鍵。
! --- 共有秘密鍵(CHAP で使用)は両側で同じにする必要があります。

ip subnet-zero
no ip domain-lookup
no ip dhcp conflict logging

! --- DHCP サーバでの DHCP アドレス競合の記録を無効にします。

ip dhcp excluded-address 10.0.0.1

! --- DHCP サーバがクライアントに割り当ててはならない IP アドレスを指定します。

ip dhcp pool soho

! --- DHCP アドレス プール名を設定し、DHCP プール設定モードに入ります。

 network 10.0.0.0 255.0.0.0

 ! --- DHCP アドレス プールのサブネット ネットワーク番号とマスクを指定します。

 default-router 10.0.0.1

 ! --- DHCP クライアント用のデフォルト ルータの IP アドレスを指定します。
 
 lease infinite

 ! --- リース時間の長さを指定します。

!
isdn switch-type basic-5ess
isdn voice-call-failure 0
!
interface Ethernet0/0
 ip address 10.0.0.1 255.0.0.0

 ! --- イーサネット インターフェイス用の IP アドレス。 

 no ip directed-broadcast
 ip nat inside

! --- インターフェイスをネットワーク アドレス変換の内側として定義します。

!

! 未使用のイーサネット インターフェイスは簡略化のために省略します。

!
interface BRI1/0
 ip address negotiated

! --- このインターフェイスに対する PPP/IPCP ネゴシエーションを有効にします。

 no ip directed-broadcast
 ip nat outside

! --- インターフェイスをネットワーク アドレス変換の外側として定義します。

 encapsulation ppp
 dialer idle-timeout 60

! --- この BRI インターフェイスのアイドル タイムアウト(秒)。

 dialer string 97771200

! --- 中央のアクセス サーバに到達するために必要な電話番号を指定します。

 dialer-group 1

! --- dialer-list 1 で定義されている対象トラフィックを適用します。

 isdn switch-type basic-5ess
 ppp authentication chap
!

!-- 未使用の BRI インターフェイスは簡略化のために省略します。

!
ip nat inside source list 100 interface BRI1/0 overload 

! --- アクセス リスト 100 によって識別されるアドレスに対して、
! --- (PAT による)ダイナミック ソース変換を確立します。

ip classless
ip route 0.0.0.0 0.0.0.0 BRI1/0 permanent

! --- デフォルト ルートは BRI1/0 を経由します。

no ip http server
!
access-list 100 permit ip 10.0.0.0 0.255.255.255 any

! --- 変換対象のアドレスを許可するアクセス リストを定義します。

dialer-list 1 protocol ip permit

! --- 対象トラフィックが dialer-list1 によって定義されます。
! --- これは dialer-group 1 を使用して BRI1/0 に適用されます。

line con 0
 transport input none
line aux 0
line vty 0 4
 login
!         
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を示しています。

show コマンド

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)によってサポートされています。これにより、show コマンド出力の分析を表示できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show ip interface brief:インターフェイスのステータスと、インターフェイスで設定されている IP アドレスを表示します。

  • show interfaces:特定のインターフェイスについて、インターフェイスのステータスに関する高次情報を提供します。

  • show ip nat statistics:ネットワーク アドレス変換(NAT)の統計情報を表示します。

  • show ip nat translations:アクティブな NAT 変換を表示します。

  • show isdn status:各 ISDN レイヤのステータスを表示します。ISDN レイヤ 1 および 2 が機能しているかを確認します。トラブルシューティング情報についての詳細は、ドキュメント『show isdn status コマンドを使用した BRI のトラブルシューティング』を参照してください。

  • show dialer:ダイヤラ情報を表示します。

show コマンドの出力例

次の show コマンド出力は、Easy IP Router が Central Site Access Server へのダイヤルアップ接続を開始する前に得られたものです。このコマンド出力は、BRI1/0 インターフェイスがアップしており、IP アドレスは割り当てられていませんが、IPCP を使用してネゴシエートされることを示しています。

EasyIP#show ip interface brief
Interface                  IP-Address      OK? Method Status                Prol
Ethernet0/0             10.0.0.1      YES manual up                up  
Ethernet0/1                unassigned      YES manual administratively down dow 
Ethernet0/2                unassigned      YES manual administratively down dow 
Ethernet0/3                unassigned      YES manual administratively down dow 
BRI1/0                  unassigned    YES IPCP  up                 up

! -- インターフェイスはアップしていますが、接続されていないため IP アドレスは割り当てられていません。

BRI1/0:1                   unassigned      YES unset  down                  dow 
BRI1/0:2                   unassigned      YES unset  down                  dow 

! -- 両方の B チャネルがダウンしています。

BRI1/1                     unassigned      YES manual administratively down dow 
BRI1/1:1                   unassigned      YES unset  administratively down dow 
BRI1/1:2                   unassigned      YES unset  administratively down dow

EasyIP#show interfaces bri1/0
BRI1/0 is up, line protocol is up (spoofing)
  Hardware is BRI with integrated NT1
Internet address will be negotiated using IPCP
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
   .
   .
EasyIP#

次の show コマンド出力は、Easy IP Router が Central Site Access Server へのダイヤルアップ接続を開始した後に得られたものです。このコマンド出力は、BRI1/0 インターフェイスが PPP/IPCP を使用して Central Site Access Server から IP アドレス 200.1.0.3 を受け取ったことを示しています。

EasyIP#show ip interface brief 
Interface                  IP-Address      OK? Method Status                Prorocol
Ethernet0/0             10.0.0.1      YES manual up                up  
Ethernet0/1                unassigned      YES manual administratively down dow 
Ethernet0/2                unassigned      YES manual administratively down dow 
Ethernet0/3                unassigned      YES manual administratively down dow 
BRI1/0                  200.1.0.3     YES IPCP   up                up  

! -- 接続がアップした後、インターフェイス BRI1/0 に登録 IP アドレスが割り当てられました。

BRI1/0:1                unassigned    YES unset  up                up  
BRI1/0:2                   unassigned      YES unset  down                  dow 

! -- 最初の B チャネル(BRI1/0:1)がアップします。

BRI1/1                     unassigned      YES manual administratively down dow 
BRI1/1:1                   unassigned      YES unset  administratively down dow 
BRI1/1:2                   unassigned      YES unset  administratively down dow
EasyIP#show interfaces bri1/0
BRI1/0 is up, line protocol is up (spoofing)
  Hardware is BRI with integrated NT1
Internet address is 200.1.0.3/32
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
  .
  . 
  EasyIP#

Inside のプライベート ネットワーク ホストが Central Site Access Server に接続できるかどうか、および NAT 機能が正しく動作しているかどうかをチェックする必要があります。これを行うには、拡張 ping ユーティリティを使用します。Easy IP Router で Central Site Access Server のイーサネット インターフェイスに ping し、ping の送信元として Easy IP Router の LAN(プライベート)アドレスを指定します。これにより、パケットが PAT によって処理されていること、および LAN のクライアントが中央サイトのネットワークと通信できることが確認されます。

EasyIP#ping
Protocol [ip]: 
Target IP address: 192.168.16.1

! -- Central Site Access Server のイーサネット インターフェイスの IP アドレス。

Repeat count [5]: 10
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: y
Source address or interface: 10.0.0.1

! --Easy IP ルータのイーサネット インターフェイスの IP アドレス(プライベート)。

Type of service [0]: 
Set DF bit in IP header? [no]: 
Validate reply data? [no]: 
Data pattern [0xABCD]: 
Loose, Strict, Record, Timestamp, Verbose[none]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 192.168.16.1, timeout is 2 seconds:
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 32/34/36 ms

上記の出力では、Success rate が 100 % であることが示されています。これは、NAT 機能が正常に動作しており、SOHO ホストが Central Site Access Server と通信できることを意味します。次の show コマンド出力から、NAT 変換に関するより詳細な情報が得られます。

EasyIP#show ip nat statistics 
Total active translations: 10 (0 static, 10 dynamic; 10 extended)
Outside interfaces:
  BRI1/0, BRI1/0:1, BRI1/0:2
Inside interfaces: 
  Ethernet0/0
Hits: 169  Misses: 185
Expired translations: 175
Dynamic mappings:
-- Inside Source
access-list 100 interface BRI1/0 refcount 10
EasyIP#show ip nat translations 
Pro Inside global   Inside local    Outside local    Outside global
icmp 200.1.0.3:32   10.0.0.1:32     192.168.16.1:32  192.168.16.1:32
icmp 200.1.0.3:33      10.0.0.1:33        192.168.16.1:33    192.168.16.1:33
icmp 200.1.0.3:34      10.0.0.1:34        192.168.16.1:34    192.168.16.1:34
icmp 200.1.0.3:35      10.0.0.1:35        192.168.16.1:35    192.168.16.1:35
icmp 200.1.0.3:36      10.0.0.1:36        192.168.16.1:36    192.168.16.1:36
icmp 200.1.0.3:37      10.0.0.1:37        192.168.16.1:37    192.168.16.1:37
icmp 200.1.0.3:38      10.0.0.1:38        192.168.16.1:38    192.168.16.1:38
icmp 200.1.0.3:39      10.0.0.1:39        192.168.16.1:39    192.168.16.1:39
icmp 200.1.0.3:40      10.0.0.1:40        192.168.16.1:40    192.168.16.1:40
icmp 200.1.0.3:41      10.0.0.1:41        192.168.16.1:41    192.168.16.1:41
EasyIP#

次の show isdn status コマンド出力には、各 ISDN レイヤのステータスが表示されています。Layer 1 および 2 が例のように表示されることを確認します。

EasyIP#show isdn status 
Global ISDN Switchtype = basic-5ess
ISDN BRI1/0 interface
        dsl 8, interface ISDN Switchtype = basic-5ess
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 64, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        1 Active Layer 3 Call(s)
    Activated dsl 8 CCBs = 1
        CCB:callid=8098, sapi=0, ces=1, B-chan=1, calltype=DATA
    The Free Channel Mask:  0x80000002

トラブルシューティング情報についての詳細は、ドキュメント『show isdn status コマンドを使用した BRI のトラブルシューティング』を参照してください。

次の show dialer 出力には、Inside プライベート ネットワークの IP アドレス(10.0.0.1 など)によってダイヤリングが開始されたことが示されています。

EasyIP#show dialer 

BRI1/0 - dialer type = ISDN

Dial String      Successes   Failures    Last DNIS   Last status
97771200                23          0    00:02:02       successful   Default
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI1/0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=10.0.0.1, d=192.168.16.1)
Time until disconnect 36 secs
Current call connected 00:02:03
Connected to 97771200 (ISP-AS)

BRI1/0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

トラブルシューティング

debug コマンド

注:debug コマンドを実行する前に、『debug コマンドの重要な情報』を参照してください。

  • debug ppp negotiation:PPP プロトコルのネゴシエーション プロセスに関する情報を提供します。

  • debug ip nat:IP ネットワーク アドレス変換(NAT)機能によって変換された IP パケットに関する情報を提供します。

  • debug isdn q921:q.921 メッセージのデータリンク レイヤのデバッグを提供します。

  • debug isdn q931:q.931 メッセージのネットワーク レイヤのデバッグを提供します。

  • debug dialer:発信コールに関する DDR 情報を提供します。

debug コマンドの出力例

次の debug ppp negotiation 出力は、PPP/IPCP プロトコルのネゴシエーション プロセスを示しています。

EasyIP#debug ppp negotiation 
PPP protocol negotiation debugging is on
.
.

2d07h: BR1/0:1 IPCP: O CONFREQ [Closed] id 223 len 10
2d07h: BR1/0:1 IPCP:    Address 0.0.0.0 (0x030600000000)
2d07h: BR1/0:1 CDPCP: O CONFREQ [Closed] id 63 len 4
2d07h: BR1/0:1 IPCP: I CONFREQ [REQsent] id 47 len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.1 (0x0306C8010001)
2d07h: BR1/0:1 IPCP: O CONFACK [REQsent] id 47 len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.1 (0x0306C8010001)
2d07h: BR1/0:1 CDPCP: I CONFREQ [REQsent] id 41 Len 4
2d07h: BR1/0:1 CDPCP: O CONFACK [REQsent] id 41 Len 4
2d07h: BR1/0:1 IPCP: I CONFNAK [ACKsent] id 223 Len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.3 (0x0306C8010003)
2d07h: BR1/0:1 IPCP: O CONFREQ [ACKsent] id 224 Len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.3 (0x0306C8010003)
2d07h: BR1/0:1 CDPCP: I CONFACK [ACKsent] id 63 Len 4
2d07h: BR1/0:1 CDPCP: State is Open
2d07h: BR1/0:1 IPCP: I CONFACK [ACKsent] id 224 Len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.3 (0x0306C8010003)
2d07h: BR1/0:1 IPCP: State is Open
2d07h: BR1/0 IPCP: Install negotiated IP interface address 200.1.0.3

! -- ネゴシエートされた WAN IP アドレスを Easy IP ルータがインストールします。

2d07h: BR1/0 IPCP: Install route to 200.1.0.1

! -- 中央サイトのアクセス サーバへのルートがインストールされます。

2d07h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI1/0:1, changed state Up
2d07h: %ISDN-6-CONNECT: Interface BRI1/0:1 is now connected to 97771200 ISP-AS
EasyIP#

debug ip nat 出力には、IP ネットワーク アドレス変換(NAT)機能によって変換された IP パケットに関する情報が表示されます。

EasyIP#debug ip nat detailed 
IP NAT detailed debugging is on
.
.
2d00h: NAT: o: icmp (10.0.0.1, 2015) -> (192.168.16.1, 2015) [909]
2d00h: NAT: i: icmp (10.0.0.1, 2015) -> (192.168.16.1, 2015) [909]
2d00h: NAT: ipnat_allocate_port: wanted 2015 got 2015
2d00h: NAT*: o: icmp (192.168.16.1, 2015) -> (200.1.0.3, 2015) [909]
2d00h: NAT: o: icmp (10.0.0.1, 2016) -> (192.168.16.1, 2016) [910]
2d00h: NAT: i: icmp (10.0.0.1, 2016) -> (192.168.16.1, 2016) [910]
2d00h: NAT: ipnat_allocate_port: wanted 2016 got 2016
2d00h: NAT*: o: icmp (192.168.16.1, 2016) -> (200.1.0.3, 2016) [910]
2d00h: NAT: o: icmp (10.0.0.1, 2017) -> (192.168.16.1, 2017) [911]
2d00h: NAT: i: icmp (10.0.0.1, 2017) -> (192.168.16.1, 2017) [911]
2d00h: NAT: ipnat_allocate_port: wanted 2017 got 2017
2d00h: NAT*: o: icmp (192.168.16.1, 2017) -> (200.1.0.3, 2017) [911]
2d00h: NAT: o: icmp (10.0.0.1, 2018) -> (192.168.16.1, 2018) [912]
2d00h: NAT: i: icmp (10.0.0.1, 2018) -> (192.168.16.1, 2018) [912]
.
.

EasyIP#undebug all 
All possible debugging has been turned off

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 15364