アプリケーション ネットワーキング サービス : Cisco CSS 11500 ???? Content Services Switches

CSS 11xxx でのボックスツーボックス冗長性の設定例

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2013 年 5 月 17 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、コンテンツ サービス スイッチ(CSS)11xxx のボックスツーボックス冗長性の設定例を紹介します。 ボックスツーボックス冗長性は、同一に設定された 2 つの CSS 間のシャーシ レベルの冗長性を提供します。

前提条件

要件

この設定を開始する前に、次の要件が満たされていることを確認してください。

  • この冗長性設定に使用する両方の CSS で、同じバージョンのコードが実行されていることが必要です。 別のバージョンのコードが実行されている場合、冗長性はサポートされません。

  • CSS の期待される動作はアクティブ(マスター)/スタンバイ(バックアップ)で、 マスター CSS プロセス フローだけ。

  • CSS 間には、仮想ルータ冗長プロトコル(VRRP)ハートビート専用のファスト イーサネット(FE)リンクを設定する必要があります。

  • 冗長性を持つ CSS ピアの間にレイヤ 2 デバイスを接続することが必要な場合、ボックスツーボックスを使用しないでください。 代わりに VIP 冗長性を使用してください。 詳細は、『VIP および仮想インターフェイス冗長性の設定』を参照してください。

使用するコンポーネント

このドキュメントの情報は、CSS 11150 SW バージョン 6.10 ビルド 107 に基づいています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

関連製品

この設定は、次のバージョンのハードウェアとソフトウェアにも使用できます。

  • Cisco CSS 11000 ~ 11500 シリーズのすべての CSS 製品

  • Cisco WebNS ソフトウェア リリース 5.0 以降

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

2 つの CSS の間に冗長リンクが定義されている場合、CSS は冗長性構成に参加します。 この冗長性リンクに使用されるプロトコルは VRRP で、マルチキャスト アドレス 224.0.0.18 を使用します。 CSS はこのリンクを使用して、相互スイッチ間の接点およびアクティビティ ステータスを維持します。 CSS 間でサポートされるクロス リンクは 1 つだけです。 クロス ケーブルを使用して、冗長 CSS の FE ポートを直接接続する必要があります。 2 つの CSS の間の冗長リンクには、レイヤ 2 デバイスを使用しないでください。 クロス ケーブルをギガビット イーサネット(GE)に取り付けないでください。 この設定はサポートされていません。

CSS ボックスツーボックス冗長性プロトコルは、ソフトウェア バージョン 7.10.1.02、7.20.0.01 およびそれ以降では、CSS 11501、CSS 11503、および CSS 11506 GE ポートで現在サポートされています。

2 つの CSS でマスター ステートとバックアップ ステートを駆動する冗長リンクでは、主に 2 つの状況が検出されます。

  • 最初の状況は、ハートビートの維持で、毎秒行われるアドバタイズメントです。 マスター CSS はこのハートビートを冗長リンクに生成し、バックアップ CSS はハートビートを 3 秒おきに追跡します(デフォルト)。 ハートビートがタイムアウトすると(たとえば、ハートビートがこの期間内に検出されなかった場合など)、バックアップがマスターになります。

    新しいマスター CSS は、冗長性プロトコル メッセージと gratuitous アドレス解決プロトコル(ARP)メッセージを送出して、隣接ノードの ARP テーブルと、接続されているブリッジング デバイス(レイヤ 2 スイッチなど)の転送テーブルを、新しいマスター CSS MAC アドレスで更新します。 CSS は、個々の gratuitous ARP 呼び出しについて、1 つの ARP 要求パケットと 1 つの ARP 応答パケットを送信します。

  • もう 1 つの状況は、VRRP スイッチの優先順位の変更です。 最優先順位をアドバタイジングする CSS は、マスターになるためにネゴシエートされます。 これは、フェールオーバー イベントを開始する目的で、アップリンク サービスや(下記で説明されている)一部の特殊なコマンドに使用されるメカニズムです。

CSS が誤って設定されている場合(2 つ以上の CSS が IP 冗長性マスターとして設定されるなど)、VRRP IP アドレスが最も大きい CSS がマスターを引き受けます。

Cisco WebNS ソフトウェアでは、次のことが可能です。

  • 複数のアップリンク サービスの設定

  • リンクがダウンした場合のフェールオーバーの使用

  • 設定の同期の使用。 詳細については『冗長性構成の同期 』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

ip redundancy コマンドを発行して、クロス ケーブルでインターフェイスされている 2 つの CSS 上で CSS 間の冗長性を有効にします。 デフォルトでは、このコマンドを両方の CSS 上で発行するまでは、CSS 上の冗長性は無効になっています。

このコマンドに master オプションを含めると、マスター CSS となる CSS を指定できます。 クロス ケーブルでインターフェイスされている 2 つの CSS を最初にブートするとき、どちらがマスターでどちらがバックアップになるかが決定されます。 最初にブートする CSS がマスター CSS です。 CSS が同時にブートした場合、IP アドレスの数字が大きい方の CSS がマスターになります。

CSS に対して ip redundancy master コマンドを発行すると、CSS はマスター CSS になります。 このコマンドは、現在のマスターまたはバックアップのどちら側でも実行できます。 バックアップ CSS 上で master オプションを付けて発行すると、この CSS がマスターになり、他方の CSS が自動的にバックアップになります。

マスター CSS を指定すると、その CSS がダウン後に再起動したとき、マスター ステータスを取り戻します。 たとえば、マスター CSS がダウンすると、バックアップ CSS がマスターになります。 ただし、以前指定されたマスター CSS が再起動すると、その CSS が再びマスターになります。

両方の CSS が稼働しているときに、一方の CSS をマスターとして指定する要件がない場合は、マスター CSS の冗長性を有効にするときに master オプションを含めないようにしてください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/50405/box_to_box_config.jpg

設定

このドキュメントでは、次の設定を使用します。

  • CSS 11150 FL

  • nws-4-5

CSS 11150 FL
CSS-11150-FL# sh running-config
!Generated on 03/22/2004 18:32:17
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 		


!--- Redundancy is enabled.


  app     			


!--- This is optional if you want to synchronize the configurations.

  app session 172.17.6.2   

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.1 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.2 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

CSS-11150-FL# 

nws-4-5
nws-4-5# sh running-config 
!Generated on 03/22/2004 18:53:37
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 	


!--- Redundancy is enabled.



  app 


!--- This is optional if you want to syncronize the configurations.

  app session 172.17.6.1 

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.2 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.1 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

nws-4-5# 


複数のアップリンク サービスのサポート

ルータの IP アドレスに関連付けられたサービスを作成することができます。 このサービスでは、マスター CSS がキープアライブ(ICMP)を使用してルータをモニタできます。 キープアライブが失敗すると、マスターが制御権を解放し、バックアップ CSS が制御を取得します。 type redundancy-up コマンドを発行することによって、複数のサービスを設定できます。 CSS はすべての冗長性アップリンクを使用してフェールオーバーを決定します。

CSS がアクティブで、redundancy-up に指定されているすべてのアップリンクを失うと、CSS はアクティブ状態を解放してバックアップになります。 CSS は冗長性プロトコルを使用して、別の CSS にアクティブになるよう通知します。 両方の CSS がアップリンクを失った場合は、1 つの CSS は 45 秒間アクティブ状態にとどまり、アップリンクがアップ状態になるのを待ちます。 45 秒経ってもアップ状態のアップリンクがない場合、その CSS はバックアップ モードとなり、もう一方のスイッチで試行されます。 これにより、1 分間に何度も CSS を置き変えることなく、アップリンクをテストする機会が両方の CSS に与えられます。

稼働中のアップリンク サービスがなくなると、CSS はフェールオーバーを開始します。

考慮事項

この機能は、ip redundancy master コマンドが発行された場合に無効になります。 ip redundancy master コマンドが発行されている場合、type redundancy-up コマンドを設定できません。 type redundancy-up コマンドを発行してサービスを設定している場合、ip redundancy master コマンドを発行できません。

設定

CSS11150# configure terminal
CSS11150(config)# service uplink1
CSS11150(config-service[uplink1])# type redundancy-up           

!--- If this upstream router goes down, then fail the switch over.

CSS11150(config-service[uplink1])# ip address 10.66.86.33
CSS11150(config-service[uplink1])# active

物理インターフェイス障害のフェールオーバーのサポート

冗長性が得られるように設定された物理インターフェイスの 1 つがダウンした場合、CSS が制御権を解放して、バックアップ CSS がすぐにマスターになります。 IP 接続に基づく redundancy-up サービスとは対照的に、この機能はリンク ステートに基づいています。 CSS はバックアップ モードのときにリンク ステートを判別できます。 バックアップ CSS のアップストリーム パスまたはダウンストリーム パスが、この同じインターフェイスを通過しないよう注意してください。 CSS ボックスによるマスター ステータスの所有権のフラッピングの原因となります。

考慮事項

この機能は、ip redundancy master コマンドを発行することによって無効になります。 ip redundancy master コマンドが発行されると、redundancy-phy interface コマンドが失敗します。 redundancy-phy interface コマンドが発行されると、ip redundancy master コマンドが失敗します。

設定

CSS-11150-FL# configure terminal
CSS-11150-FL(config)# interface e1
CSS-11150-FL(config-if[e1])# redundancy-phy

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • sh redundancy:このコマンドは、CSS が冗長性構成で実行されているかどうかを確認します。 このコマンドは、いずれの CSS がマスターでいずれがバックアップであるかということの他に、最後のフェールオーバーの理由も表示します。

    nws-4-5# sh redundancy
    Redundancy:               Enabled    Redundancy Protocol:      Running   
    Redundancy State:         Master     MasterMode:               No        
    Number of times redundancy state changed to Master:            2         
                                             to Backup:            2         
    Redundancy interface:     172.17.6.2
    Current State Duration:   1 day 02:54:04
    Last Fail Reason:         No Fail    
    VRID:                     128        Priority:                 100 
  • show log sys.log—:このコマンドは、CSS デバイス間のマスター資格に関する情報が含まれているメッセージを表示します。

    CSS-11150-FL# sh log sys.log
    
    APR 15 18:05:49 5/1 85 REDUNDANCY-4: Redundancy force master temporarily
    APR 15 18:05:52 5/1 86 REDUNDANCY-4: Transition to redundancy master
    APR 15 18:05:52 5/1 87 VRRP-4: Virtual router 128: master on interface 172.17.6.1
  • show app および show app session:このコマンドは、app セッションの状態を表示します。

    nws-4-5# sh app
    APP CONFIGURATION:
    Enabled PortNumber: 5001 MaxFrameSize: 10240
    
    nws-4-5# sh app session
    App Session Information 'no hostname':
    Session ID: 87df3710 IP Address: 172.17.6.1 State: APP_SESSION_UP

メンテナンス目的のためにバックアップを強制的にマスターにすることができます。 redundancy force-master コマンドを発行すると、バックアップ CSS を一時的なマスターに設定できます。 コマンドは実行コンフィギュレーションにコピーされないため、これは一時的な設定です。 このコマンドは、冗長性構成においてマスター CSS をメンテナンスまたはアップグレードのためにオフラインにする必要がある場合に役立ちます。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 50405