ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

Cisco DSL ルータの設定とトラブルシューティング ガイド - 固定 IP アドレスが割り当てられた PPPoE クライアントとして機能する Cisco DSL ルータ

2008 年 4 月 23 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 10 月 5 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
実行する作業
PC で必要な可能性がある設定手順
設定
      設定例
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

Cisco Digital Subscriber Line(DSL; デジタル加入者線)ルータには、Internet Service Provider(ISP; インターネット サービス プロバイダー)から単一の固定パブリック IP アドレスが割り当てられます。

ヒント:Cisco 製デバイスの設定に不慣れで、最初から最後まで手順を追った説明が必要な場合は、『固定 IP アドレスによる PPPoE の段階的設定』を参照してください。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

実行する作業

  • プライベート LAN の IP アドレス割り当て方式を設計します。

  • Cisco DSL ルータのイーサネット インターフェイスに IP アドレス、サブネット マスク、および TCP 最大セグメント サイズ(MSS)調整を設定します。

  • Cisco DSL ルータの ATM インターフェイス(Asymmetric Digital Subscriber Line(ADSL; 非対称デジタル加入者線)インターフェース)に ATM Permanent Virtual Circuit(PVC; 相手先固定接続)とカプセル化を設定します。

  • リリース 12.2(13)T より後の Cisco IOS(R) ソフトウェアを使用する場合は、Point-to-Point Protocol over Ethernet(PPPoE)Virtual Private Data Network(VPDN; バーチャル プライベート データ ネットワーク)グループを設定します。

  • 固定 IP アドレスを使用する PPPoE を利用するために Cisco DSL ルータのダイヤラ インターフェイスを作成して設定します。

  • Network Address Translation(NAT; ネットワーク アドレス変換)を使用する場合: ダイヤラ インターフェイスのダイナミック パブリック IP アドレスを共有できるように Cisco DSL ルータで NAT を設定します。

    • オプション:ISP から追加の IP アドレスを提供されている場合は NAT プール。

    • オプション:インターネット ユーザが内部サーバにアクセスする必要がある場合はスタティック NAT。

  • 各 PC クライアントで IP アドレス、サブネット マスク、デフォルト ゲートウェイ、Domain Name System(DNS; ドメイン ネーム システム)サーバを設定します。

    Dynamic Host Configuration Protocol(DHCP)を使用する場合:Cisco DSL ルータによって PC クライアントにダイナミック IP アドレスを割り当てる場合は、DHCP を使用して自動的に IP アドレスと DNS サーバを取得するように各 PC を設定します。

PC で必要な可能性がある設定手順

Cisco DSL ルータ ソフトウェアが ip tcp adjust-mss 1452 または ip adjust-mss 1452 設定コマンドをサポートしている場合、この後の作業は必要ないため、「設定」セクションに進んでください。

Cisco DSL ルータ ソフトウェアが ip tcp adjust-mss 1452 または ip adjust-mss 1452 設定コマンドをサポートしていない場合は、Cisco DSL ルータを介してインターネットにアクセスする LAN 内の各 PC で Maximum Transmission Unit(MTU; 最大伝送ユニット)サイズを変更する必要があります。 MTU サイズを変更するには次の手順を実行します。

  1. 最新バージョンの Dr. TCP ユーティリティを http://www.dslreports.com/front/drtcp.html leavingcisco.com からダウンロードします。

  2. 最新のページが表示されるようにブラウザ ページを更新します。

  3. Dr. TCP ユーティリティを実行します。

  4. メニューからイーサネット アダプタを選択します。

  5. MTU フィールドに 1492 と入力します。

  6. Apply をクリックして変更を保存した後、Exit をクリックします。

  7. PPPoE PC クライアントをリブートします。

レジストリの変更はこの手順が完了した時点で保存されます。 そのため、このユーティリティは各 PC につき 1 回だけ実行する必要があります。

設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供します。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

設定例

ヒント:Cisco 製デバイスの設定に不慣れで、最初から最後まで手順を追った説明が必要な場合は、『固定 IP アドレスによる PPPoE の段階的設定』を参照してください。

固定 IP アドレスが割り当てられた Cisco DSL ルータ

!--- コメントには説明と追加情報が含まれています。


service timestamps debug datetime msec
service timestamps log datetime msec
vpdn enable
 no vpdn logging
  vpdn-group pppoe
   request-dialin
    protocol pppoe

!--- これらのコマンドが必要なのは、リリース 12.2(13)T よりも古い Cisco IOS 
!--- ソフトウェアだけです。

!
!
ip subnet-zero
!

!--- DHCP の設定


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server> 
!
interface ethernet0  
 no shut  
 ip address <ip address> <subnet mask> 
 ip tcp adjust-mss 1452 
 
!--- ip tcp adjust-mss 1452 コマンドがサポートされていない場合は、
 !--- 設定文 ip adjust-mss 1452 を試してください。このコマンドが
 !--- 現在ご使用の Cisco DSL ルータ ソフトウェア リリースでサポートされていない場合は、
 !--- 最新の Cisco DSL ルータ ソフトウェアにアップグレードするか、
 !--- このドキュメントの「PC で必要な可能性がある設定手順」セクションの手順に
 !--- 従ってください。 


!--- NAT の設定

 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no ip address
 bundle-enable
 dsl operating-mode auto
!
interface atm0.1 point-to-point
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  pppoe-client dial-pool-number 1
 
!--- ISP によってサポートされる一般的な PVC 値は 0/35 または 8/35 です。
 !--- PVC 値は ISP に確認してください。

 !
!
interface dialer1
 ip address <ip address> <subnet mask>
 mtu 1492

!--- NAT の設定

 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username>
 ppp chap password <password>
 ppp pap sent-username <username> password <password>
!

!--- NAT の設定

ip nat inside source list 1 interface dialer1 overload

!--- ISP からパブリック IP アドレスのプール(範囲)を提供されている場合は
!--- NAT プールを使用できます。 
!--- ip nat inside source list 1 interface dialer1 overload
 
 

!--- 次の 2 つの設定文に置き換えます。
!--- ip nat inside source list 1 pool <NAT プール名> overload
!--- ip nat pool <NAT プール名> <最初の IP アドレス> <最後の IP アドレス> 
!---  netmask <サブネット マスク>




!--- インターネット ユーザが内部サーバにアクセスする必要がある場合は
!--- 次のスタティック NAT 設定文を追加できます。
!--- ip nat inside source static tcp <サーバの Inside IP アドレス> {80 または 25} 
!---  <サーバの outside well-known IP アドレス> {80 または 25} extendable
!--- 注:  この例では TCP ポート 80(HTTP/Web)と TCP ポート 25(SMTP/mail)を
!--- 使用していますが、必要に応じて別の TCP ポートまたは UDP ポートを開いても
!--- 問題ありません。

! 
ip classless
ip route 0.0.0.0 0.0.0.0 interface dialer1

!--- NAT の設定

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- この設定では、NAT 変換を行うアドレスを許可する標準アクセス リストを
!--- access-list 1 で定義しています。たとえば、
!--- プライベート IP ネットワークが 10.10.10.0 の場合、
!--- access-list 1 permit 10.10.10.0 0.0.0.255 と設定すると、
!--- 10.10.10.0 から 10.10.10.255 まで間の発信元アドレスを持つパケットを 
!--- NAT で変換できます。

!
end

確認

現在のところ、この設定を確認する手順はありません。

トラブルシューティング

DSL サービスが適切に動作しない場合は、『Cisco DSL ルータ PPPoE クライアントのトラブルシューティング』を参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 71122