IP : ネットワーク アドレス変換(NAT)

2 つの ISP 接続のための IOS NAT ロード バランシング

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2012 年 12 月 18 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この資料は Cisco IOS のための設定を説明したものですか。 2 つの ISP 接続を通してネットワーク アドレス変換(NAT)とインターネットにネットワークを接続するルータ。 Cisco IOS ソフトウェアの NAT では、特定の宛先までの等価コスト ルートが複数ある場合、複数のネットワーク接続を介して後続の TCP 接続および UDP セッションを分散できます。

/image/gif/paws/100658/ios-nat-load-balancing-2isp-01.gif

前提条件

要件

このドキュメントは、LAN および WAN 接続での作業を開始していることを前提としています。初期接続を確立するための設定やトラブルシューティングに関する情報は提供していません。 このドキュメントでは、ルート間を区別するメカニズムについては説明していません。 そのため、望ましくない接続より望ましい接続のほうを優先する方法はありません。

使用するコンポーネント

この設定は、Cisco IOS Software Release 12.4(15)T3 Advanced IP Services ソフトウェアを稼働する Cisco 1811 ルータを使用して開発されました。 他のソフトウェア バージョンを使用する場合は、一部の機能を使用できない場合や、コンフィギュレーション コマンドがこのドキュメントに示されているコマンドと異なる場合があります。 同様の設定はすべての Cisco IOS ルータ プラットフォームで使用できますが、多くの場合、インターフェイス設定はプラットフォームごとに異なります。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

特定のトラフィックが常に 1 つの ISP 接続を使用するようにするには、ポリシーベース ルーティングを追加する必要がある場合があります。 この動作を必要とするトラフィックの例には、IPSec VPN クライアント、VoIP テレフォニー トラフィック、および 1 つの ISP 接続オプションのみを使用して同じ IP アドレスに高速かつ低遅延で到達するその他のトラフィックが含まれます。

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用します。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/100658/ios-nat-load-balancing-2isp-02.gif

この設定例では、FastEthernet 0 で示される 1 つの ISP への DHCP 対応の IP 接続と、他の ISP 接続を経由する PPPoE 接続を使用するアクセス ルータについて説明しています。 接続タイプは設定に特定の影響を及ぼしませんが、一部の接続タイプが特定の失敗のシナリオでこの設定の有用性を妨げることがあります。特に、イーサネット接続された WAN サービス経由の IP 接続が使用されている場合、たとえば、追加デバイスが WAN 接続を終端しイーサネットを Cisco IOS ルータへ引き渡すようなケーブル モデムや DSL サービスで顕著です。 DHCP 割り当てアドレスや PPPoE とは逆に、静的 IP アドレス指定が適用され、イーサネット ポートが WAN 接続デバイスへのイーサネット リンクを留保してしまうといった WAN 障害が発生した場合、ルータは継続して正常な WAN 接続と不良な WAN 接続の両方に接続のロード バランスを試みます。 展開の中で、非アクティブなルートをロード バランシングの対象から削除する必要がある場合は、ルートの妥当性を監視するための Optimized Edge Routing の追加について説明したドキュメント『Optimized Edge Routing を使用した 2 つのインターネット接続に対する IOS NAT ロード バランシング』に掲載されている設定を参照してください。

設定

このドキュメントでは次の設定を使用しています。

interface FastEthernet0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
!
interface FastEthernet1
 no ip address
 pppoe enable
 no cdp enable
!
interface FastEthernet2
 no cdp enable
!


!
interface Vlan1
 description LAN Interface
 ip address 192.168.108.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452


!---Define LAN-facing interfaces with "ip nat inside".

!

!
Interface Dialer 0
 description PPPoX dialer
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss


!---Define ISP-facing interfaces with "ip nat outside".

!
ip route 0.0.0.0 0.0.0.0 dialer 0 track 123
!
 
!
ip nat inside source route-map fixed-nat interface Dialer0 overload
ip nat inside source route-map dhcp-nat interface FastEthernet0 overload
!

!--- Configure NAT overload (PAT) in order to use route-maps.

 
!
access-list 110 permit ip 192.168.108.0 0.0.0.255 any
!

!--- Define ACLs for traffic that are NATed to 
!--- the ISP connections.


!
route-map fixed-nat permit 10
 match ip address 110
 match interface Dialer0
!
route-map dhcp-nat permit 10
 match ip address 110
 match interface FastEthernet0


!--- Route-maps associate NAT ACLs with NAT outside on 
!--- the ISP-facing interfaces.

確認

このセクションでは、設定が正常に機能していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

  • show ip nat translation:NAT Inside ホストと NAT Outside ホストの間の NAT アクティビティを表示します。 このコマンドを使用すると、Inside ホストが両方の NAT Outside アドレスに変換されることを確認できます。

    Router#show ip nat translation
    Pro Inside global      Inside local       Outside local      Outside global
    tcp 172.16.108.44:54486 192.168.108.3:54486 172.16.104.10:22 172.16.104.10:22
    tcp 172.16.106.42:49620 192.168.108.3:49620 172.16.102.11:80 172.16.102.11:80
    tcp 172.16.108.44:1623 192.168.108.4:1623 172.16.102.11:445  172.16.102.11:445
    Router#
  • show ip route:インターネットへのルートが複数存在することを確認します。

    Router#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is 172.16.108.1 to network 0.0.0.0
    
    C    192.168.108.0/24 is directly connected, Vlan1
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.108.0 is directly connected, FastEthernet4
    C       172.16.106.0 is directly connected, Vlan106
    S*   0.0.0.0/0 [1/0] via 172.16.108.1
                   [1/0] via 172.16.106.1
    Router#

トラブルシューティング

ここでは、設定に関するトラブルシューティングについて説明します。

Cisco IOS ルータで NAT を設定した後に接続が機能しない場合は、次のことを確認してください。

  • Outside インターフェイスと Inside インターフェイスで NAT が適切に適用されている。

  • NAT 設定が完全であり、NAT を適用する必要があるトラフィックが ACL に反映されている。

  • インターネットおよび WAN への利用可能なルートが複数存在する。


関連情報


Document ID: 100658