ビデオ : Cisco uBR900 シリーズ ケーブル アクセス ルータ

シスコ製ケーブル モデムでの cable-modem dhcp-proxy nat コマンド

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2006 年 11 月 20 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは cable-modem dhcp-proxy nat コマンドの使用方法を説明します。 このコマンドの主要な機能は、インターネット プロバイダーの DHCP サーバから提供される IP アドレスによるネットワーク アドレス変換(NAT)アドレス プールを設定することです。

詳細については、ケーブル IOS Cmts コマンドcable-modem dhcp-proxy を参照して下さい。

注意 注意: Cisco IOS で固定される Cisco バグ ID CSCdt32356登録ユーザのみ)を理解しておいて下さい、か。 ソフトウェア リリース トレイン 12.2 およびそれ以降。 ケーブル インターフェイス コマンド cable-modem dhcp-proxy nat pool-name を使用したダイナミック NAT は正しく機能しません。 IP アドレス、サブネット マスク、およびデフォルト ゲートウェイが割り当てられたとしても、正しい割り当てが行われません。 NAT プールに割り当てられたアドレスが Address Resolution Protocol(ARP; アドレス解決プロトコル)に応答しません。 IP NAT プールが、Customer Premises Equipment(CPE; 宅内装置)ではなく、ケーブル モデムのスコープからのものであるため、NAT プールにルーティング不能 IP アドレスが生じます。 特に 12.1(5)T ことをことにこの問題発生する複数のケーブルモデムのための Cisco IOS ソフトウェア リリースに注意して下さい。 uBR924 の Cisco IOS ソフトウェア リリース トレイン 12.2 を使用する推奨し、uBR905 のためにリリース 12.2T、12.3、およびそれ以降トレイン、uBR925 および CVA モデムを使用しますことを。 詳細については、Cisco Bug ID CSCdt32356登録ユーザ専用)を参照してください。

注: また、次の点にも注意してください。

  1. uBR904 プラットフォームでは Cisco IOS ソフトウェア リリース 12.1(1)T がサポートされていないため、このプラットフォームでは cable-modem dhcp-proxy コマンドを設定できません。

  2. uBR924 で dhcp-proxy の機能を有効にする場合は、Cisco IOS ソフトウェア リリース 12.2(6j) の使用が一般的に推奨されています。

  3. CVA122 の場合、このコマンドは cable dhcp-proxy nat と表記されています。 このコマンドは uBR900 シリーズ ケーブル モデムの cable-modem dhcp-proxy nat コマンドと同等です。

    CVA122 からの出力を示します。

    Router(config)# interface cable 0
    
    Router(config-if)# cable?
    
    cable-modem

前提条件

要件

このドキュメントの読者は次のトピックについて理解している必要があります。

  • ネットワーク アドレス変換の基本的な知識とこれが利用される理由

  • Data-over-Cable Service Interface Specifications(DOCSIS; データオーバーケーブル サービス インターフェイス仕様)1.0 プロトコル

  • Cisco IOS ソフトウェアのコマンドライン インターフェイス

使用するコンポーネント

次の表に、各ケーブル モデム プラットフォームについて、このコマンドをサポートする Cisco IOS ソフトウェア リリースを示します。

cable-modem dhcp-proxy コマンドが導入されているリリース プラットフォーム
12.1(1)T uBR924
12.1(3)XL ubr905
12.2(2)XA ubr925
12.1(5)XU1 CVA122

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ダイナミック NAT とスタティック NAT

ダイナミック NAT の場合、変換対象のトラフィックをルータが受信するまでは、NAT 変換テーブルには変換エントリが存在しません。 ダイナミック変換にはタイムアウトの期間があり、タイムアウトを過ぎると変換テーブルから変換エントリが削除されます。 スタティック NAT の場合は、スタティック NAT コマンドを設定するとすぐに NAT 変換テーブルに変換エントリが記録され、スタティック NAT コマンド(1 つまたは複数)を削除しない限り、変換テーブル内に存続します。

ケーブル モデムにダイナミック NAT が設定されているかどうかを簡単に確認するには、ケーブル モデムの設定内で次のコマンドを探します。

ip nat inside source list 100 interface cable-modem0 overload

NAT のソースにアクセス リストを指定することで、NAT 変換テーブルを動的に構築できます。 cable-modem dhcp-proxy nat コマンドは、このダイナミック NAT 機能を使用しています。

cable-modem dhcp-proxy nat コマンドによる設定

cable-modem dhcp-proxy nat コマンドを使用するとき、NATプールに使用するアドレスは CATV事業者の DHCPサーバから自動的に割り当てられます。

このオプションを使用する場合、次の NAT 設定コマンドを含めます。

  • ip nat inside interface — 「内部」インターフェイスでイーサネットインターフェイスを設定するのに使用して下さい。

  • ip nat outside interface — 「外部」インターフェイスでケーブルインターフェイスを設定するのに使用して下さい。

  • 過負荷cable-modem dhcp-proxy nat コマンドによって作成される NATプールが 1 IP アドレスだけ含まれているので Ip nat global configuration コマンドでこのオプションを規定 して下さい。

cable-modem dhcp-proxy nat コマンドでルータを設定した後、ルータをリブートします。 DOCSIS プロビジョニング プロセスの間、ケーブル インターフェイスの IP アドレスを取得するため、ルータは DHCP クライアント要求を送信します。 DHCP 要求を送信します。 DHCP サーバは、ルータがループバック インターフェイスに動的に設定する 2 つ目の IP アドレスを応答します。このアドレスは、アドレスを 1 つだけ含む動的に設定された NAT プールを指しています。

DHCP の処理後に自動的に追加される設定の詳細については、このドキュメントの設定の出力を参照してください。

プールが動的に作成されるように NAT を設定するには、ルータで次のコマンドを発行します。 NAT を設定するには、ルータをルーティング モードにしておく必要があります。

Router# config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)# interface ethernet 0

Router(config-if)# ip address 192.168.1.1 255.255.255.0

!--- Assign an IP address to interface Ethernet 0.

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# ip nat inside

!--- Enable NAT inside for the Ethernet interface.

Router(config-if)# exit

Router(config)#

Router(config)# interface cable 0

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# no cable compliant bridge

!--- Remove bridging so that you can configure for routing.

Router(config-if)# ip nat outside

!--- Enable NAT outside for the cable interface.

Router(config-if)# cable-modem dhcp-proxy nat TEST_POOL

!--- Define dhcp-proxy nat for the TEST_POOL pool.

Router(config-if)# exit

Router(config)#

Router(config)# ip routing

!--- Enable routing.

Router(config)# ip nat inside source list 1 pool TEST_POOL overload

!--- Configure dynamic NAT.

Router(config)# access-list 1 permit 192.168.1.0 0.0.0.255

!--- Define interesting traffic for NAT.

次のような設定になります。

router# show run

Building configuration...
Current configuration : 953 bytes
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
!
ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

router#

太字のコマンドは入力した物です; 他はデフォルトです。 NAT プールはまだ作成されていません。 ケーブル モデムをリロードするか、shut コマンド、no shut コマンドを順に発行してケーブル インターフェイスをリセットする必要があります。

router# reload

Proceed with reload? [confirm]
133.CABLEMODEM.CISCO: 00:06:16: %SYS-5-RELOAD: Reload requested
System Bootstrap, Version 12.0(6r)T3, RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by Cisco Systems, Inc.
UBR924 platform with 16384 Kbytes of main memory
program load complete, entry point: 0x80010000, size: 0x398070
Self decompressing the image : #################################
################################################################
################################################################
################################################################
################################################################
################################################################
########################################################## [OK]

!--- Output suppressed.

Press RETURN to get started!

注: 設定の出力には、DHCP の処理後に自動的に追加される情報が注釈付きで示されています。

このドキュメントでは、例として uBR7114 と uBR924 を使用しています。 インストールされている Cisco IOS ソフトウェア リリースはそれぞれ、12.1(5)EC1 と 12.1(3a)T4 です。 次の図には接続と使用されている IP アドレスが示されています。

図 1: cable dhcp-proxy nat コマンドによる設定のダイアグラム

/image/gif/paws/12176/cable_dhcp_proxy1.gif

uBR924 —サービスプロバイダーの DHCPサーバによって供給される IP アドレスのネットワークアドレス交換 アドレス プールの設定
router# show run

Building configuration...
Current configuration : 1273 bytes
!
! Last configuration change at 13:12:52 - Tue Feb 29 2000
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
clock timezone - -8
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
!
interface Loopback0
 ip address 111.111.111.8 255.255.255.255

!--- Lookback interface added automatically by DHCP configuration.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
 cable-modem boot admin 2
 cable-modem boot oper 5
 cable-modem downstream saved channel 525000000 37 1
!
ip nat pool TEST_POOL 111.111.111.8 111.111.111.8 netmask 255.255.255.0

!--- NAT pool added automatically by DHCP configuration.

ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

設定の確認

このセクションでは、ケーブル モデムの設定を確認するための、show コマンドの出力の使用法を説明します。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

show arp コマンドを発行すると ARP テーブル内のエントリが表示されます。

router# show arp

Protocol  Address         Age (min) Hardware Addr   Type   Interface
Internet  111.111.111.111      56   0002.b9ff.8c1c  ARPA   cable-modem0
Internet  10.4.1.1             59   0002.b9ff.8c1c  ARPA   cable-modem0

!--- IP address of the interface cable 1/0
!--- of the cable modem termination system (CMTS).

Internet  192.168.1.1           -   0030.1976.771a  ARPA   Ethernet0
Internet  192.168.1.5          34   00a0.243c.eff5  ARPA   Ethernet0

!--- IP address of the PC behind the cable modem.

Internet  10.4.1.114            -   0030.1976.771b  ARPA   cable-modem0

ケーブル モデムの背後にある PC には、静的に設定された IP アドレス 192.168.1.5 が付与されています。 しかしそれは非常に容易 LAN ホストに動的に IP アドレスを割り当てるケーブルモデムに DHCPサーバをするためにです; この設定を使用して下さい:

ip dhcp excluded-address 192.168.1.1 
ip dhcp pool pool name


   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1

NAT が機能しているかどうかをテストするには、ケーブル モデムの背後に接続された PC から ping コマンドを発行し、ケーブル インターフェイスに到達できるかどうかを確認します。

NAT 変換テーブルを見ると、成功した変換を確認できます。

router# show ip nat translations

Pro  Inside global      Inside local       Outside local    Outside global
icmp 111.111.111.8:512  192.168.1.5:512    10.4.1.114:512   10.4.1.114:512

詳細については、ケーブル IOS Cmts コマンドcable-modem dhcp-proxy を参照して下さい。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12176