スイッチ : Cisco Catalyst 3750 シリーズ スイッチ

Catalyst 3750 でのマルチキャスト VLAN レジストレーション(MVR)の設定例

2008 年 2 月 21 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2011 年 8 月 1 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      関連製品
      表記法
設定
      ネットワーク ダイアグラム
      設定
確認
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

マルチキャスト VLAN ネットワークでは、マルチキャスト グループへのサブスクライバは複数の VLAN に存在できます。ネットワークでの VLAN 境界制限がレイヤ 2 スイッチで構成されている場合、同じ物理ネットワーク上にある場合であっても、異なるサブネットの同じグループにマルチキャスト ストリームを複製することが必要になる場合があります。マルチキャスト VLAN レジストレーション(MVR)では、マルチキャス送信元の VLAN で受信したパケットが、1 つ以上の受信 VLAN にルーティングされます。クライアントは受信 VLAN に存在し、マルチキャスト サーバは送信元 VLAN に存在します。MVR を有効にするときは、マルチキャスト ルーティングを無効にする必要があります。MVR の詳細については、『マルチキャスト VLAN レジストレーションについて』の設定ガイドを参照してください。

このドキュメントでは、マルチキャストの送信元と受信先が接続された Catalyst 3750 スイッチのスタックによる簡単なトポロジ、動作可能な設定、およびストリームを送信する際に MVR が動作しているかどうかを確認するためのコマンドの出力について説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、Catalyst 3750 スイッチからの出力に基づくものです。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

関連製品

この設定は、次のスイッチ タイプにも使用できます。

  • Catalyst 3550、2940、2950、2970、3500/2900XL シリーズ スイッチ

Catalyst 3750、35XX、29XX スイッチでは、コード バージョン 12.1(11)AX から MVR がサポートされています。Catalyst 3500/2900 XL スイッチの場合は、最低限必要な Cisco IOS(R) ソフトウェアのリリースは 12.0(5)WC(1) です。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供します。

注:このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

mvr-3750-config1.gif

ネットワーク ダイアグラム
※ 画像をクリックすると、大きく表示されます。

設定

MVR を設定するには、次の手順を実行する必要があります。

  1. 次のコマンドを発行して、スイッチやスイッチ スタックでグローバルにマルチキャスト ルーティングを無効にします。

    switch(config)#no ip multicast-routing distributed
    
  2. 次のコマンドを発行して、MVR をグローバルに有効にします。

    mixed(config)#mvr
    
  3. 次のコマンドを発行して、ストリームを送信するマルチキャスト グループを指定します。

    mixed(config)#mvr group 239.9.0.1
    
  4. 次のコマンドを発行して、送信元が存在する VLAN を指定します。

    mixed(config)#mvr vlan 1200
    
  5. マルチキャスト ルーティングは無効ですが、ルーティングされるインターフェイスでペリフェラル インターフェイス マネージャ(PIM)を有効にするために、これらのコマンドを発行する必要があります。

    これは、一般クエリを送信できるようにマルチキャスト グループのステータスを維持するためです。

    注:PIM を有効にすると、Cisco IOS から警告メッセージを受け取ります。

    mixed(config)#int vlan 1200
    
    mixed(config-if)#ip pim dense-mode
    
    WARNING: "ip multicast-routing distributed" is not configured,
    
             IP Multicast packets will not be forwarded.
    
    WARNING: "ip multicast-routing distributed" is not configured, 
             
             IP Multicast packets will be fast-switched.
    
    mixed(config-if)#int vlan 1100
    
    mixed(config-if)#ip pim dense-mode
    
    WARNING: "ip multicast-routing distributed" is not configured,
    
             IP Multicast packets will not be forwarded.
    
    WARNING: "ip multicast-routing distributed" is not configured, 
    
             IP Multicast packets will be fast-switched.
    
  6. 次のコマンドを発行します。

    mixed(config-if)#int port-channel 20
    
    mixed(config-if)#mvr type source
    

    mvr type source コマンドは、マルチキャスト ストリームを受信するインターフェイスで指定する必要があります。

  7. 次のコマンドを発行します。

    mixed(config-if)#int g6/0/1
    
    mixed(config-if)#mvr type receiver
    

    mvr type receiver コマンドは、サブスクライバが接続されているもう一方のインターフェイスで指定する必要があります。

3750 スイッチ
maui-soho-01#show running-config 
 Building configuration...

!

mvr vlan 1200

mvr

mvr group 239.9.0.1

!

!

vlan 1,1100,1200 

!

interface Port-channel20

 switchport trunk encapsulation isl

 switchport mode trunk

 mvr type source

!

interface GigabitEthernet6/0/1

 switchport access vlan 1100

 mvr type receiver

 spanning-tree portfast      

!

interface GigabitEthernet7/0/49

 switchport trunk encapsulation isl

 switchport mode trunk

 channel-group 20 mode active

!

interface GigabitEthernet7/0/50

 switchport trunk encapsulation isl

 switchport mode trunk

 channel-group 20 mode active

!

interface Vlan1100

 ip address 116.100.1.1 255.255.0.0

 ip pim sparse-dense-mode

!

interface Vlan1200

 ip address 115.200.1.1 255.255.0.0

 ip pim sparse-dense-mode

!

ation interface Gi7/0/2

 !
 end

確認

ここでは、設定が正常に動作していることを確認します。

特定の show コマンドが、アウトプットインタープリタ登録ユーザ専用)(OIT)でサポートされています。OIT を使用して、show コマンド出力の解析を表示できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

MVR のステータスおよびスイッチの値を表示するには、show mvr コマンドを発行します。

mixed#show mvr

MVR Running: TRUE

MVR multicast VLAN: 1200

MVR Max Multicast Groups: 256

MVR Current multicast groups: 1

MVR Global query response time: 5 (tenths of sec)

MVR Mode: compatible

マルチキャスト ストリームのフローを確認するには、show mvr interface コマンドを発行します。

mixed#show mvr interfaces

Port      Type     Status       Immediate Leave

----      ----     ------       ---------------

Gi6/0/1   RECEIVER   ACTIVE/UP   DISABLED  

Po21      SOURCE     ACTIVE/UP   DISABLED

マルチキャスト グループのサブスクライバを確認するには、show mvr member コマンドを発行します。

mixed#show mvr member

MVR Group IP     StatusMembers

----------------------  ----------------

239.009.000.001 ACTIVE        Gi6/0/1(d), Po20(s)

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 71273