音声とユニファイド コミュニケーション : Cisco Unified Border Element

Unified Border Element トランスコーディングの設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Cisco Unified Border Element(CUBE)は、通過するコールのトランスコーディングをサポートし、2 つのコール レッグに異なるコーデックを必要とします。 さまざまなコーデック間のトランスコーディングがサポートされ、CUBE は設定およびコールの 2 つのコール レッグでネゴシエートされるコーデック間の不一致に基づいてトランスコーダを挿入します。

トランスコーディングでは DSP が RTP ストリームを終了し、適切なコーデックを使用してボイス ペイロードを解釈し、符号化する必要があります。 トランスコーディングに CUBE で使用されている DSP は、CUBE と同じルータ上に共存するか、または別のルータのプラットフォームにある可能性があります。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

使用するコンポーネント

このドキュメントの情報は、次のハードウェアに基づくものです。

  • Cisco 3745 ルータで動作し、Cisco IOS リリース 12.3.11T 以降を使用する Cisco Unified Border Element

  • AS5X-PVDM2-64 DSP カードが実装され、AS5X-FC フィーチャ カードを装備した Cisco AS5400XM アクセス サーバのトランスコーディング DSP リソース

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

この図はトランスコーディングに外部 DSP を使用する CUBE の例を示します。

/image/gif/paws/100480/cube_transcode.gif

DSP リソースは CUBE をホストする、同じルータ プラットフォームの内部にある(または共存する)場合もあります。 この場合、DSP リソースの制御はルータに対してローカルであり、図の SCCP 制御フローはありません。

CUBE がトランスコーディングに使用する DSP リソースは、DSP が CUBE と共存するかどうかに関係なく、設定する必要があります。 設定のただ 1 つの違いは、CUBE と DSP リソース間の IP アドレス指定です。 共存設定の場合、IP アドレスは両方とも同じです。

設定手順

ここでは、外部の DSP トランスコーディングを設定する方法について説明します。 Cisco 3745 ルータは CUBE として使用され、AS5400XM はトランスコーディング用の DSP リソースをホストするために使用されます。

この設定は次のコール フローに適用されます。

  1. コールは G.711 の H.323 によって CUBE に向かって OGW から開始します。

  2. CUBE はコールを H.323 によって OGW(G.729 用に設定済み)に転送します。

  3. TGW へのコール セットアップを成功させるには、G.711 から G.729 へのコーデック変換が必要です。 トランスコーディング リソースが設定されていないか、または使用可能でない場合、コール セットアップは失敗します。

外部トランスコーディング制御の CUBE 設定

CUBE ルータはトランスコーディング用の DSP リソースを制御するように設定されます。 この設定は telephony-service コマンドを使用します。このコマンドは Cisco Unified Communication Manager Express 用のトランスコーディング設定に似ています。 DSP リソースは制御エンティティとともに登録されます(この例は CUBE ですが、CUCME または CUCM の場合もあります)。

3745 CUBE
vdouut3#show running-config | begin telephony
!
telephony-service
sdspfarm units 1 -- Specifies the maximum number of DSP farms that can
                    be registered to CUBE. A maximum of 5 DSP resource units
                    (farms) can be configured.
sdspfarm transcode sessions 128 -- Specifies the maximum transcoding
                    sessions supported across all DSP farms registered
                    with CUBE.
sdspfarm tag 1 vdouut1 -- Specifies the device name of the DSP farm. For
                    uniqueness the device name can be the MAC address of the 
                    DSP source interface. In this example the hostname of
                    the DSP farm router is used.
ip source-address 1.2.61.73 port 2000 – The IP address and port-no: (TCP)
                    of the interface through which SCCP messages are
                    transmitted/received from CUBE.

外部トランスコーディング DSP リソースをホストするための DSP ファーム設定

ルータは制御エンティティによって使用されるトランスコーディング用の DSP リソースをホストするように設定されます。この例では別ルータ上の CUBE です。 DSP リソースは制御エンティティとともに登録され、コール フローに対して使用可能になります。

DSP ファーム
vdouut1#show running-config | begin voice-card
voice-card 1
  dsp services dspfarm –- This makes the DSPs available for “DSP farming”
                    which includes transcoding services.

vdouut1#show running-config | begin sccp
sccp local GigabitEthernet0/0 -- Defines the source interface of the DSP
                    farm through which SCCP messages are exchanged with
                    controlling CUBE.               
sccp ccm 1.2.61.73 identifier 1 -- Specifies the IP address of the CUBE
                    system that the DSP farm registers to. This should
                    match the CUBE IP address on the “ip source-address”
                    configuration on CUBE.
sccp
sccp ccm group 1 -- Group configuration for linking “sccp ccm global”
                    configurations as well as the dspfarm profile(s)
  bind interface GigabitEthernet0/0
associate ccm 1 priority 1 -- Associate the sccp identifier “ccm” with
                  the “sccp ccm group”.
associate profile 1 register vdouut1 -- Associate the dspfarm profile 
                  with the DSP farm device name. In this example the 
                  hostname of the DSP farm hosted router is used
                  (vdouut1). The same name must be used on CUBE where
                  “sdspfarm tag 1” is configured.
!
dspfarm profile 1 transcode -- Configure the dspfarm profile to define
                     the codecs supported, the maximum sessions, and
                     enable SCCP.
  codec g711ulaw
  codec g711alaw
  codec g729ar8
  codec g729abr8
  codec g729r8
  codec g729br8
  maximum sessions 128
  associate application SCCP

内部トランスコーディングの完全な設定例

ここでは、トランスコーディング用に CUBE と DSP リソースの両方をホストするために同じルータ(AS5400XM)が設定されている、セットアップの完全な設定例を示します。 設定の重要な部分は太字で表示します。

この設定のセットアップと外部トランスコーディング DSP リソースをホストするための DSP ファーム設定の違いは次のとおりです。

  • 実際の DSP リソース([voice-card x] > [dsp services dspfarm])および制御エンティティ([telephony-service])は同じルータ上に表示されます。

  • DSP リソースの IP アドレス([sccp ccm 9.13.29.30 Identifier - 1])と制御エンティティの IP アドレス([telephony-service] > [ip source-address 9.13.29.30 port])は同じです。

5400XM
5400XM#show run
Building configuration...

Current configuration : 3149 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 5400XM
!
boot-start-marker
no boot startup-test
boot-end-marker
!
logging buffered 100000000 debugging
no logging console
enable secret 5 $1$g301$4BVklIIq97tihABYS6Guy/
enable password xxx
!
resource-pool disable
no aaa new-model
!
resource policy
!
voice-card 1
 dsp services dspfarm
!
voice-card 5
!
ip cef
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 h323
 modem passthrough none codec g729r8 pre-ietf
!
controller T1 5/0
 framing sf
 linecode ami
!
controller T1 5/1
 framing sf
 linecode ami
!
controller T1 5/2
 framing sf
 linecode ami
!
controller T1 5/3
 framing sf
 linecode ami
!
controller T1 5/4
 framing sf
 linecode ami
!
controller T1 5/5
 framing sf
 linecode ami
!
controller T1 5/6
 framing sf
 linecode ami
!
controller T1 5/7
 framing sf
 linecode ami
!
interface GigabitEthernet0/0
 ip address 9.13.29.30 255.255.255.0
 duplex auto
 speed auto
 negotiation auto
 no cdp enable
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 negotiation auto
 no cdp enable
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
 no fair-queue
!
interface Serial5/0
 no ip address
 shutdown
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
 no cdp enable
!
ip route 0.0.0.0 0.0.0.0 9.13.29.1
!
no ip http server
!
dialer-list 1 protocol ip permit
!
sccp local GigabitEthernet0/0
sccp ccm 9.13.29.30 identifier 1 version 4.0 -- Use its own IP address
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 1 register XCODE123456
 keepalive retries 1
 keepalive timeout 10
 switchover method immediate
 switchback method immediate
!
dspfarm profile 1 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec gsmfr
 codec g729r8
 codec g729br8
 maximum sessions 10
 associate application SCCP
!
dial-peer voice 1 voip
 destination-pattern 630222100.
 session protocol sipv2
 session target ipv4:9.13.29.22
 dtmf-relay rtp-nte digit-drop
 codec g711ulaw
!
dial-peer voice 2 voip
 session protocol sipv2
 incoming called-number 630222100.
 codec g729br8 bytes 10
!
dial-peer voice 3 voip
 destination-pattern 2000
 session protocol sipv2
 session target ipv4:9.13.29.22
 dtmf-relay rtp-nte digit-drop
!
dial-peer voice 4 voip
 session protocol sipv2
 incoming called-number 2000
 codec g711ulaw
!
gatekeeper
 shutdown
!
telephony-service
 max-ephones 1
 max-dn 1
 ip source-address 9.13.29.30 port 2000 --> Use its own IP address
 sdspfarm units 1
 sdspfarm transcode sessions 10
 sdspfarm tag 1 XCODE123456
 ss7 mtp2-variant Bellcore 0
 ss7 mtp2-variant Bellcore 1
 ss7 mtp2-variant Bellcore 2
 ss7 mtp2-variant Bellcore 3
 !
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password cisco
 login
!
scheduler allocate 10000 400
no process cpu extended
no process cpu autoprofile hog
end

確認

この項の出力は、外部トランスコーディング用の設定に関するものです。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

CUBE

CUBE とともに DSP ファームが登録されるデバイス名と DSP ファーム ホスト ルータの IP アドレスは太字で表示されます。

vdouut3#show sdspfarm units
Load for five secs: 0%/0%; one minute: 0%; five minutes: 3%
Time source is NTP, 23:46:40.649 PST Tue Nov 21 2006


mtp-1 Device:vdouut1 TCP socket:[1] REGISTERED
actual_stream:256 max_stream 256 IP:1.2.61.71  27519  MTP YOKO keepalive 45  
Supported codec:
                 G711Ulaw
                 G711Alaw
                 G729
                 G729a
                 G729b
                 G729ab
 max-mtps:1, max-streams:256, alloc-streams:256, act-streams:0

この出力は CUBE 設定セットアップを示します。

vdouut3#show telephony-service
ip source-address 1.2.61.73 port 2000
max-ephones 128
max-dn 1
max-conferences 8 gain -6
dspfarm units 1
dspfarm transcode sessions 128
dspfarm 1 vdouut1

この出力はコールが行われた後の、CUBE によりコール レッグで使用されるコーデックを示します(太字で表示)。

vdouut3#show sdspfarm sessions active 
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 23:52:43.922 PST Tue Nov 21 2006

Stream-ID:37 mtp:1 1.2.61.71  20190  Local:2000 START  
 usage: Ip-Ip                        
 codec:G729  duration:20 vad:0 peer Stream-ID:38 

Stream-ID:38 mtp:1 1.2.61.71  21326  Local:2000 START  
 usage: Ip-Ip                        
 codec:G711Ulaw64k  duration:20 vad:0 peer Stream-ID:37

この出力は CUBE による OGW と TGW の間のアクティブなセッションを示します。

vdouut3#show voip rtp connections     
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 23:54:22.722 PST Tue Nov 21 2006
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   3991       3992       18496    17430  1.2.61.73       1.2.61.48      
2   3992       3991       17382    19706  1.2.61.73       1.2.61.68      
Found 2 active RTP connections

この出力はアクティブなセッションとコール レッグで使用されるコーデック(太字で表示)の簡潔な要約を示します。

vdouut3#show call active voice compact 
Load for five secs: 1%/0%; one minute: 1%; five minutes: 1%
Time source is NTP, 02:31:58.156 PST Wed Nov 22 2006
 <callID>  A/O FAX T<sec> Codec     type  Peer Address  IP R<ip>:<udp>
Total call-legs: 2
      4023 ANS     T25    g711ulaw  VOIP  P5200         1.2.61.48:16934
      4024 ORG     T25    g729r8    VOIP  P6200         1.2.61.68:17040

DSP ファーム ホスト

この出力は DSP リソース登録ステータスを示します。 重要な情報は太字で表示します。

vdouut1#show sccp
SCCP Admin State: UP
Gateway IP Address: 1.2.61.71, Port Number: 2000
IP Precedence: 5
User Masked Codec list: None
Call Manager: 1.2.61.73, Port Number: 2000
                Priority: N/A, Version: 3.1, Identifier: 1

Transcoding Oper State: ACTIVE - Cause Code: NONE
Active Call Manager: 1.2.61.73, Port Number: 2000
TCP Link Status: CONNECTED, Profile Identifier: 1
Reported Max Streams: 256, Reported Max OOS Streams: 0
Supported Codec: g711ulaw, Maximum Packetization Period: 30
Supported Codec: g711alaw, Maximum Packetization Period: 30
Supported Codec: g729ar8, Maximum Packetization Period: 60
Supported Codec: g729abr8, Maximum Packetization Period: 60
Supported Codec: g729r8, Maximum Packetization Period: 60
Supported Codec: g729br8, Maximum Packetization Period: 60
Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30
Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30
Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30

この出力は DSP リソースの設定を示します(アイドル状態)。

vdouut1#show dspfarm all
Dspfarm Profile Configuration

 Profile ID = 1, Service = TRANSCODING, Resource ID = 1  
 Profile Description :  
 Profile Admin State : UP 
 Profile Operation State : ACTIVE 
 Application : SCCP   Status : ASSOCIATED 
 Resource Provider : FLEX_DSPRM   Status : UP 
 Number of Resource Configured : 128 
 Number of Resource Available : 128
 Codec Configuration 
 Codec : g711ulaw, Maximum Packetization Period : 30 
Codec : g711alaw, Maximum Packetization Period : 30 
 Codec : g729ar8, Maximum Packetization Period : 60 
 Codec : g729abr8, Maximum Packetization Period : 60 
 Codec : g729r8, Maximum Packetization Period : 60 
 Codec : g729br8, Maximum Packetization Period : 60


SLOT DSP VERSION  STATUS CHNL USE   TYPE   RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -        
1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -        
1    1   9.2.1    UP     N/A  FREE  xcode  1      -         -         -  

この出力は DSP リソースのステータス(コールが行われた後)を示します。

vdouut1#show sccp connections summary 
  SCCP Application Service(s) Statistics Summary:
  Total Conferencing Sessions: 0, Connections: 0
  Total Transcoding Sessions: 1, Connections: 2
  Total MTP Sessions: 0, Connections: 0
  Total ALG-Phone Sessions: 0, Connections: 0
  Total BRI-Phone Sessions: 0, Connections: 0
  Total SCCP Sessions: 1, Connections: 2

vdouut1#show dspfarm dsp active 
SLOT DSP VERSION  STATUS CHNL USE   TYPE   RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

1    1   9.2.1    UP     1    USED  xcode  1      15        9400      9405     
1    1   9.2.1    UP     1    USED  xcode  1      16        9400      9394     

Total number of DSPFARM DSP channel(s) 1

この出力は DSP リソース(このルータ)と制御エンティティ(CUBE)間の RTP セッションを示します。 異なるコーデックを持つ 2 つの VoIP コール レッグが表示されます。 レッグは両方とも CUBE (1.2.61.73)によって確立されます。

vdouut1#show voip rtp connections 
VoIP RTP active connections :
No. CallId     dstCallId  LocalRTP RmtRTP LocalIP         RemoteIP       
1   46         47         17668    2000   1.2.61.71       1.2.61.73      
2   48         47         21530    2000   1.2.61.71       1.2.61.73      
Found 2 active RTP connections

vdouut1#show call active voice compact 
 <callID>  A/O FAX T<sec> Codec     type   Peer Address  IP R<ip>:<udp>
Total call-legs: 2
        46 ORG     T150   g711ulaw  VOIP   P             1.2.61.73:2000 
        48 ORG     T150   g729r8    VOIP   P             1.2.61.73:2000

トラブルシューティング

トランスコーディングに便利なトラブルシューティング コマンドを次に示します。

  • debug sccp messages

  • debug ephone mtp

  • debug ephone state

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 100480